]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
BC: clang to enforce using gcc
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
0be89e87
BZ
2# todo:
3# libvkd3d https://wiki.winehq.org/Vkd3d
4#
7a30e9d7 5# Conditional build:
931f130b 6%bcond_without alsa # don't build ALSA mm driver
8e674d62 7%bcond_with capi # don't build CAPI 2.0 (ISDN) support
beafc810 8%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 9%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 10%bcond_without ldap # don't build LDAP DLL
16e36f25 11%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 12%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 13#
546bbb82 14# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
15# libGL (winex11.drv.so)
16# libOSMesa (gdi32.dll.so)
17# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
18# libcapi20 (capi2032.dll.so)
19# libcups (winspool.drv.so)
20# libdbus (mountmgr.sys.so)
16e36f25 21# libfontconfig (gdi32.dll.so)
5b49e814
JB
22# libfreetype (gdi32.dll.so)
23# libgnutls (secur32.dll.so)
5b49e814
JB
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
5b49e814
JB
26# libsane (sane.ds.so)
27# libtiff (windowscodecs.dll.so)
546bbb82 28# thus requires rebuild after change of any of the above.
db80a28e 29
4ce8abe1
ER
30# library qualifier in rpm generated deps
31%ifarch %{x8664} ia64 ppc64 s390x sparc64
32%define libqual ()(64bit)
33%else
34%define libqual %{nil}
35%endif
36
fe2412f1 37%ifarch %{x8664}
2c7f2af5
BZ
38%define winelib x86_64
39%else
40%define winelib i386
41%endif
42
3e4a4fb9 43%define gecko_ver 2.47.2
698e86e7 44Summary: Program that lets you launch Win applications
93e41e44
ER
45Summary(es.UTF-8): Ejecuta programas Windows en Linux
46Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
47Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 48Name: wine
fe2412f1
KM
49Version: 7.6
50Release: 1
46114a9a 51Epoch: 1
528c1138 52License: LGPL
5c4ec57b 53Group: Applications/Emulators
e9d09a3b 54Source0: https://dl.winehq.org/wine/source/7.x/%{name}-%{version}.tar.xz
fe2412f1 55# Source0-md5: 2a15c22b7a7f56503291381a9f608ecb
3e4a4fb9
BZ
56Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
57# Source1-md5: e0a26e37397961b2c7f624575590ef66
58Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
59# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
beafc810 60Source3: %{name}-uninstaller.desktop
55061442 61Patch0: %{name}-gphoto2_bool.patch
a0ff0658 62Patch1: %{name}-makedep.patch
a4a10255 63Patch2: %{name}-ncurses.patch
8b4bf701 64Patch4: %{name}-disable-valgrind.patch
5312a936 65Patch5: %{name}-ca_certificates.patch
a26a3859
JK
66Patch6: desktop.patch
67Patch7: %{name}-wine64_man.patch
1b3d8891 68URL: http://www.winehq.org/
5b49e814 69BuildRequires: Mesa-libOSMesa-devel
0aac4f59 70BuildRequires: OpenAL-devel >= 1.1
5b49e814 71BuildRequires: OpenCL-devel
489ca66c 72BuildRequires: OpenGL-GLU-devel
fe2412f1 73BuildRequires: SDL2-devel
6547534c
KK
74%{?with_alsa:BuildRequires: alsa-lib-devel}
75%{?with_arts:BuildRequires: artsc-devel}
5b49e814 76BuildRequires: autoconf >= 2.62
c7af491d 77BuildRequires: automake
d3c41437 78BuildRequires: bison
beafc810 79%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 80%{?with_cups:BuildRequires: cups-devel}
5b49e814 81BuildRequires: dbus-devel
5b49e814 82BuildRequires: flex >= 2.5.33
16e36f25 83BuildRequires: fontconfig-devel
5fc34681 84BuildRequires: freetype-devel >= 2.0.5
05596b04 85BuildRequires: gettext-devel
5b49e814
JB
86%ifarch %{x8664}
87BuildRequires: gcc >= 6:4.4
88%endif
1f0c428e 89BuildRequires: gettext-tools
c57a98fe 90BuildRequires: gnutls-devel
f73ad4b6
JP
91%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
92%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
93# for icotool used in build
94BuildRequires: icoutils >= 0.29.0
95BuildRequires: lcms2-devel >= 2
3d0989c1 96BuildRequires: libcap-devel
fe2412f1 97BuildRequires: libglvnd-libEGL-devel
beb8121e 98BuildRequires: libgphoto2-devel
05596b04 99BuildRequires: libpcap-devel
fe2412f1 100BuildRequires: libv4l-devel
af5ae18a 101BuildRequires: lld
9d6715c4 102%{?with_ldap:BuildRequires: openldap-devel}
beb8121e 103BuildRequires: pkgconfig
3d0989c1 104BuildRequires: pulseaudio-devel
d7296a19 105BuildRequires: samba-devel
5715e1d1 106%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 107BuildRequires: xorg-lib-libX11-devel
beb8121e 108BuildRequires: xorg-lib-libXcomposite-devel
109BuildRequires: xorg-lib-libXcursor-devel
5b49e814 110BuildRequires: xorg-lib-libXext-devel
c66c3406 111BuildRequires: xorg-lib-libXi-devel
beb8121e 112BuildRequires: xorg-lib-libXinerama-devel
beb8121e 113BuildRequires: xorg-lib-libXrandr-devel
c66c3406 114BuildRequires: xorg-lib-libXrender-devel
c66c3406 115BuildRequires: xorg-lib-libXxf86vm-devel
5893aa55 116BuildConflicts: clang
d1385401
JR
117BuildConflicts: crossmingw32-gcc
118BuildConflicts: crossmingw64-gcc
4ce8abe1 119Requires: libfreetype.so.6%{libqual}
a85c8746 120Requires: libpng16.so.16%{libqual}
8df63af6 121Requires(post): /sbin/ldconfig
ae42c99e 122Suggests: binfmt-detector
be70b824 123Suggests: ca-certificates
beafc810 124Suggests: cabextract
a2f68044 125Conflicts: ca-certificates < 20080809-4
b3d3861d 126# for printing needs lpr
127Suggests: cups-clients
f96e197b 128# for winelauncher
3bddfbf2 129Suggests: xorg-app-xmessage
f96e197b 130# for ntlm_auth
14e95129 131Suggests: samba-common >= 1:3.0.25
52b6007b
JB
132# link to wine/ntdll.dll.so, without any SONAME
133Provides: libntdll.dll.so
7212da21 134Obsoletes: wine-doc-pdf
93b34e12 135Obsoletes: wine-drv-arts
beafc810
MM
136Obsoletes: wine-drv-jack
137Obsoletes: wine-drv-nas
5b49e814 138ExclusiveArch: %{ix86} %{x8664} arm
206eed29 139ExcludeArch: i386
0403821a 140BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 141
e8f81a0a 142%define no_install_post_strip 1
b955dc60 143%define _noautoprov elf\\\\(buildid\\\\)
e8f81a0a 144
e8f81a0a 145%define _winedir %{_datadir}/%{name}
6731627f 146
5c4ec57b 147%description
6731627f 148Wine is a program which allows running Microsoft Windows programs
a519bc4f 149(including DOS, Windows 3.x and Win32 executables) on Unix. It
150consists of a program loader which loads and executes a Microsoft
151Windows binary, and a library that implements Windows API calls using
152their Unix or X11 equivalents. The library may also be used for
153porting Win32 code into native Unix executables.
5c4ec57b 154
c967e47d 155%description -l es.UTF-8
f33a1517 156Ejecuta programas Windows en Linux.
157
c967e47d
JR
158%description -l pl.UTF-8
159Wine jest programem dzięki któremu można uruchamiać programy napisane
160dla Microsoft Windows pod systemami uniksowymi. Składa się on z
161loadera, który pozwala wczytywać i uruchamiać programy w formacie
162Microsoft Windows, oraz z biblioteki, która implementuje API Windows
163przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
164także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 165
c967e47d
JR
166%description -l pt_BR.UTF-8
167O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 168Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 169binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 170chamadas da API para as equivalentes Unix/X11.
171
5c4ec57b 172%package devel
7a050f82 173Summary: Wine - header files
93e41e44
ER
174Summary(es.UTF-8): Biblioteca de desarrollo de wine
175Summary(pl.UTF-8): Wine - pliki nagłowkowe
176Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 177Group: Development/Libraries
46114a9a 178Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 179
5c4ec57b 180%description devel
181Wine - header files.
182
c967e47d 183%description devel -l es.UTF-8
f33a1517 184Biblioteca de desarrollo de wine.
185
c967e47d
JR
186%description devel -l pl.UTF-8
187Wine - pliki nagłówkowe.
5c4ec57b 188
c967e47d
JR
189%description devel -l pt_BR.UTF-8
190Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 191WINE.
192
e8f81a0a 193%package programs
194Summary: Wine - programs
93e41e44 195Summary(pl.UTF-8): Wine - programy
e8f81a0a 196Group: Applications
46114a9a 197Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 198
199%description programs
0a7c5d50 200Wine - programs.
e8f81a0a 201
c967e47d 202%description programs -l pl.UTF-8
0a7c5d50 203Wine - programy.
e8f81a0a 204
beafc810
MM
205%package dll-capi
206Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
207Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
208Group: Applications/Emulators
209Requires: %{name} = %{epoch}:%{version}-%{release}
210
211%description dll-capi
b1df4aa7 212CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
213
214%description dll-capi -l pl.UTF-8
b1df4aa7 215Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 216
16e36f25
JB
217%package dll-d3d
218Summary: Direct3D implementation DLLs for Wine
93e41e44 219Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 220Group: Applications/Emulators
46114a9a 221Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
222Requires: OpenGL
223
224%description dll-d3d
225Direct3D implementation DLLs for Wine (through OpenGL).
226
c967e47d
JR
227%description dll-d3d -l pl.UTF-8
228Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
229
230%package dll-gl
231Summary: OpenGL implementation DLLs for Wine
93e41e44 232Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 233Group: Applications/Emulators
46114a9a 234Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
235Requires: OpenGL
236
237%description dll-gl
238OpenGL implementation DLLs for Wine.
239
c967e47d
JR
240%description dll-gl -l pl.UTF-8
241Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
242
243%package dll-twain
244Summary: TWAIN implementation DLL for Wine
93e41e44 245Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 246Group: Applications/Emulators
46114a9a 247Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
248
249%description dll-twain
250TWAIN implementation DLL for Wine (through SANE).
251
c967e47d
JR
252%description dll-twain -l pl.UTF-8
253Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 254
9d6715c4 255%package dll-ldap
db80a28e 256Summary: Win32 LDAP API DLL for Wine
b1df4aa7 257Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
258Group: Applications/Emulators
259Requires: %{name} = %{epoch}:%{version}-%{release}
260
261%description dll-ldap
b1df4aa7
JB
262Lightweight Directory Access Protocol Library for Wine.
263
264%description dll-ldap -l pl.UTF-8
265Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 266
16e36f25
JB
267%package drv-alsa
268Summary: ALSA driver for WINE mm.dll implementation
93e41e44 269Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 270Group: Applications/Emulators
46114a9a 271Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
272
273%description drv-alsa
274ALSA driver for WINE mm.dll (multimedia system) implementation.
275
c967e47d
JR
276%description drv-alsa -l pl.UTF-8
277Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 278
5c4ec57b 279%prep
fec39f21 280%setup -q
f67e874d 281#%patch0 -p1
2fbbb535 282%patch1 -p1
8b4bf701 283%patch4 -p1
5312a936 284%patch5 -p1
3bfef0cd 285%patch6 -p1
f6cf693b 286%ifarch %{x8664}
a26a3859 287%patch7 -p1
f6cf693b 288%endif
591d55ba 289
5c4ec57b 290%build
ebbd62c0
GP
291
292#workaround for icon extraction error.
293icotool -x -o . dlls/user32/resources/oic_winlogo.ico
294mv -f oic_winlogo_*32x32x32.png %{name}.png
295rm -f oic_winlogo_*.png
887fffcf 296
2fbbb535 297%{__autoconf}
103d8328 298%{__autoheader}
9d6a128d 299%configure \
f829f028
AM
300%ifarch %{x8664}
301 --enable-win64 \
302%endif
5b49e814
JB
303 --with-alsa%{!?with_alsa:=no} \
304 --with-capi%{!?with_capi:=no} \
d0d61ce7 305 --with-coreaudio \
5b49e814 306 --with-cups%{!?with_cups:=no} \
d7296a19 307 --with-dbus \
c504380e 308 --with-fontconfig \
309 --with-freetype \
d7296a19 310 --with-gphoto \
d0d61ce7 311 --with-gnutls \
8ec65640 312 %{__with_without gstreamer} \
5b49e814 313 --with-ldap%{!?with_ldap:=no} \
d7296a19
JK
314 --with%{!?with_netapi:out}-netapi \
315 --with-openal \
316 --with-opencl \
c504380e 317 --with-opengl \
d7296a19 318 --with-osmesa \
c54d2750 319 --with-pcap \
d0d61ce7 320 --with-pthread \
c54d2750 321 --with-pulse \
c504380e 322 --with%{!?with_sane:out}-sane \
beb8121e 323 --with-xcomposite \
324 --with-xcursor \
325 --with-xinerama \
326 --with-xinput \
d7296a19 327 --with-xinput2 \
beb8121e 328 --with-xrandr \
c504380e 329 --with-xrender \
330 --with-xshape \
331 --with-xshm \
beb8121e 332 --with-xxf86vm \
0be89e87 333 --with-x
fe2412f1 334
05eb066b 335%{__make} depend
4aafdd81 336%{__make}
e8f81a0a 337
5c4ec57b 338%install
339rm -rf $RPM_BUILD_ROOT
ffb676e0 340install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
341%{__make} install \
342 DESTDIR=$RPM_BUILD_ROOT
343
a26a3859 344install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 345cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 346
2a437456 347install -d \
65c325f6 348 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
349 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 350 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
351 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
352 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
353
a91c2692 354touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
355touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
356touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
357
76055aa1 358cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 359[mci]
360cdaudio=mcicda.drv
361sequencer=mciseq.drv
362waveaudio=mciwave.drv
363avivideo=mciavi.drv
364videodisc=mcipionr.drv
365vcr=mciviscd.drv
366MPEGVideo=mciqtz.drv
5c4ec57b 367EOF
368
80496098 369# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 370
887fffcf
ER
371dir=$(pwd)
372> files.so
373> files.programs
887fffcf
ER
374
375programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 376for p in $programs; do
8d493411 377 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
3092e49c 378 echo "%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/$p.exe" >> files.programs
da274952 379 echo "%{_mandir}/man1/$p.1*" >> files.programs
3092e49c
BZ
380# grep -v "$p\.exe\.so$" files.so > files.so.
381# mv -f files.so. files.so
55a96819 382done
55a96819 383
a26a3859
JK
384for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
385 mv "$dir" "${dir%.UTF-8}"
386done
387
f6cf693b 388%ifarch %{x8664}
fe2412f1 389cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
c54d2750
JK
390for lang in de fr pl ; do
391install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 392cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
c54d2750
JK
393done
394%else
fe2412f1 395cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
c54d2750
JK
396for lang in de fr pl ; do
397install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 398cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
399done
400%endif
401
f7357f09 402install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 403%ifnarch %{x8664}
db80a28e 404cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 405%else
db80a28e 406cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 407%endif
f7357f09 408
887fffcf 409install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
410cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
411cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 412
5c4ec57b 413%clean
414rm -rf $RPM_BUILD_ROOT
415
8df63af6 416%post
db80a28e 417/sbin/ldconfig
8df63af6
ER
418%update_desktop_database
419
f1f3af79
JB
420%postun -p /sbin/ldconfig
421
d142aa07 422%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 423rm -f /var/lock/subsys/wine
d142aa07
JB
424if [ -x /sbin/chkconfig ]; then
425 /sbin/chkconfig --del wine
426fi
427
fe2412f1 428%files
5c4ec57b 429%defattr(644,root,root,755)
47bd64d5 430%doc README AUTHORS ANNOUNCE
12b1296e 431%lang(de) %doc documentation/README.de
432%lang(es) %doc documentation/README.es
433%lang(fr) %doc documentation/README.fr
0aac4f59 434%lang(hu) %doc documentation/README.hu
12b1296e 435%lang(it) %doc documentation/README.it
7b9e958b 436%lang(ko) %doc documentation/README.ko
58a0e5f4 437%lang(nb) %doc documentation/README.no
12b1296e 438%lang(pt) %doc documentation/README.pt
74de5921 439%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
440%lang(ru) %doc documentation/README.ru
441%lang(sv) %doc documentation/README.sv
442%lang(tr) %doc documentation/README.tr
3092e49c 443%attr(755,root,root) %{_bindir}/msidb
82432451 444%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
445%ifnarch %{x8664}
446%attr(755,root,root) %{_bindir}/wine
447%else
448%attr(755,root,root) %{_bindir}/wine64
449%endif
d479f953 450%attr(755,root,root) %{_bindir}/wineboot
55a96819 451%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 452%attr(755,root,root) %{_bindir}/winecfg
beafc810 453%ifnarch %{x8664}
f829f028 454%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
455%else
456%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 457%endif
beafc810 458%attr(755,root,root) %{_bindir}/wineserver
861238d3 459%dir %{_libdir}/wine
3092e49c
BZ
460%dir %{_libdir}/wine/%{winelib}-unix
461%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
462%dir %{_libdir}/wine/%{winelib}-windows
463%{_libdir}/wine/%{winelib}-windows/*.acm
464%{_libdir}/wine/%{winelib}-windows/*.ax
465%{_libdir}/wine/%{winelib}-windows/*.com
466%{_libdir}/wine/%{winelib}-windows/*.cpl
467%{_libdir}/wine/%{winelib}-windows/*.dll
beafc810 468%ifarch %{ix86}
3092e49c 469%{_libdir}/wine/%{winelib}-windows/*.dll16
beafc810 470%endif
3092e49c 471%{_libdir}/wine/%{winelib}-windows/*.drv
beafc810 472%ifarch %{ix86}
3092e49c 473%{_libdir}/wine/%{winelib}-windows/*.drv16
beafc810 474%endif
3092e49c
BZ
475%{_libdir}/wine/%{winelib}-windows/*.ds
476%{_libdir}/wine/%{winelib}-windows/*.exe
beafc810 477%ifarch %{ix86}
3092e49c
BZ
478%{_libdir}/wine/%{winelib}-windows/*.exe16
479%{_libdir}/wine/%{winelib}-windows/*.mod16
beafc810 480%endif
3092e49c
BZ
481%{_libdir}/wine/%{winelib}-windows/*.msstyles
482%{_libdir}/wine/%{winelib}-windows/*.ocx
483%{_libdir}/wine/%{winelib}-windows/*.sys
484%{_libdir}/wine/%{winelib}-windows/*.tlb
f829f028 485%ifarch %{ix86}
3092e49c 486%{_libdir}/wine/%{winelib}-windows/*.vxd
f829f028 487%endif
f6cf693b 488%ifnarch %{x8664}
b86f1c34 489%{_mandir}/man1/wine.1*
47bd64d5
JK
490%lang(de) %{_mandir}/de/man1/wine.1*
491%lang(fr) %{_mandir}/fr/man1/wine.1*
492%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
493%else
494%{_mandir}/man1/wine64.1*
495%lang(de) %{_mandir}/de/man1/wine64.1*
496%lang(fr) %{_mandir}/fr/man1/wine64.1*
497%lang(pl) %{_mandir}/pl/man1/wine64.1*
498%endif
da274952
AG
499%{_mandir}/man1/msiexec.1*
500%{_mandir}/man1/wineboot.1*
3092e49c 501
da274952 502%{_mandir}/man1/winecfg.1*
72ede285 503%{_mandir}/man1/winedbg.1*
b86f1c34 504%{_mandir}/man1/wineserver.1*
ad4623a1
AM
505%lang(de) %{_mandir}/de/man1/wineserver.1*
506%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 507%{_winedir}
a6c536e0 508%{_desktopdir}/wine.desktop
76055aa1 509%{_desktopdir}/wine-uninstaller.desktop
887fffcf 510%{_pixmapsdir}/%{name}.png
5c4ec57b 511
55a96819 512%files programs -f files.programs
e8f81a0a 513%defattr(644,root,root,755)
e8f81a0a 514
5c4ec57b 515%files devel
516%defattr(644,root,root,755)
a26a3859 517%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 518%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 519%attr(755,root,root) %{_bindir}/widl
55a96819 520%attr(755,root,root) %{_bindir}/winebuild
55a96819 521%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 522%attr(755,root,root) %{_bindir}/wineg++
d479f953 523%attr(755,root,root) %{_bindir}/winegcc
524%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 525%attr(755,root,root) %{_bindir}/winecpp
55a96819 526%attr(755,root,root) %{_bindir}/wmc
d479f953 527%attr(755,root,root) %{_bindir}/wrc
7265d9f2 528# no shared variants, so not separated
3092e49c 529%{_libdir}/wine/%{winelib}-unix/lib*.a
fe2412f1 530#%{_libdir}/wine/%{winelib}-windows/lib*.a
5c4ec57b 531%{_includedir}/wine
34f03014 532%{_mandir}/man1/widl.1*
0aac4f59 533%{_mandir}/man1/winebuild.1*
da274952 534%{_mandir}/man1/winecpp.1*
34f03014 535%{_mandir}/man1/winedump.1*
bff06719 536%{_mandir}/man1/winegcc.1*
5ec7e550 537%{_mandir}/man1/wineg++.1*
34f03014 538%{_mandir}/man1/winemaker.1*
0aac4f59 539%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 540%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
541%{_mandir}/man1/wmc.1*
542%{_mandir}/man1/wrc.1*
2b5050a8 543%{_aclocaldir}/*.m4
f18f723c 544
ba28a7b8 545%if %{with capi}
beafc810
MM
546%files dll-capi
547%defattr(644,root,root,755)
3092e49c
BZ
548%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
549%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
ba28a7b8 550%endif
beafc810 551
16e36f25
JB
552%files dll-d3d
553%defattr(644,root,root,755)
3092e49c
BZ
554%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8.dll
555%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d8thk.dll
556%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d9.dll
557%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d10*.dll
558%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/d3d11.dll
559%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wined3d.dll
560%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wined3d.dll.so
16e36f25
JB
561
562%files dll-gl
563%defattr(644,root,root,755)
3092e49c
BZ
564%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/glu32.dll
565%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/opengl32.dll
16e36f25
JB
566
567%if %{with sane}
568%files dll-twain
569%defattr(644,root,root,755)
3092e49c
BZ
570%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
571%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
572%ifarch %{ix86}
573%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
574%endif
16e36f25
JB
575%endif
576
9d6715c4
ER
577%if %{with ldap}
578%files dll-ldap
579%defattr(644,root,root,755)
3092e49c
BZ
580%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/wldap*.so
581%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/wldap*.dll
9d6715c4
ER
582%endif
583
16e36f25
JB
584%if %{with alsa}
585%files drv-alsa
586%defattr(644,root,root,755)
3092e49c 587%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/winealsa.drv.so
16e36f25
JB
588%endif
589
16e36f25 590# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
591# ddraw.dll.so,winex11.drv.so depend on X11 libs
592# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.242236 seconds and 4 git commands to generate.