]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- initial version
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
c504380e 9# TODO:
10# - support for CAPI (ISDN support; --with-capi)
11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
13# libcrypto,libssl (wininet.dll)
14# libcups (winspool.dll.so,wineps.dll.so)
15# libcurses/libncurses (wineconsole program)
16# libfontconfig (gdi32.dll.so)
17# libfreetype (wineps.dll.so,gdi32.dll.so)
18# libGL (x11drv.dll.so,ddraw.dll.so)
19# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 20# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 21# thus requires rebuild after change of any of the above.
931f130b
JB
22#
23# JACK requires ALSA
c226320b 24%if %{without alsa}
931f130b
JB
25%undefine with_jack
26%endif
698e86e7 27Summary: Program that lets you launch Win applications
93e41e44
ER
28Summary(es.UTF-8): Ejecuta programas Windows en Linux
29Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
30Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 31Name: wine
182f1b50 32Version: 1.1.8
c1ef0aab 33Release: 1
46114a9a 34Epoch: 1
528c1138 35License: LGPL
5c4ec57b 36Group: Applications/Emulators
9c1d94d6 37Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
182f1b50 38# Source0-md5: 3a65ee3448b80519d1aa606d3bba92be
76055aa1 39Source1: %{name}-uninstaller.desktop
b68a79ec 40Patch0: %{name}-fontcache.patch
a0ff0658 41Patch1: %{name}-makedep.patch
a4a10255 42Patch2: %{name}-ncurses.patch
dc0316fb 43Patch3: %{name}-bug9177_workaround.patch
8b4bf701 44Patch4: %{name}-disable-valgrind.patch
76055aa1 45#PatchX: %{name}-dga.patch
1b3d8891 46URL: http://www.winehq.org/
489ca66c 47BuildRequires: OpenGL-GLU-devel
6547534c
KK
48%{?with_alsa:BuildRequires: alsa-lib-devel}
49%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
50BuildRequires: autoconf
51BuildRequires: automake
d3c41437 52BuildRequires: bison
5715e1d1 53%{?with_cups:BuildRequires: cups-devel}
f88a3451 54BuildRequires: docbook-dtd31-sgml
55BuildRequires: docbook-utils
5fc34681 56BuildRequires: flex
16e36f25 57BuildRequires: fontconfig-devel
22432818 58BuildRequires: fontforge
5fc34681 59BuildRequires: freetype-devel >= 2.0.5
734deeec 60BuildRequires: giflib-devel
c57a98fe 61BuildRequires: gnutls-devel
beb8121e 62BuildRequires: hal-devel
931f130b 63%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
beb8121e 64BuildRequires: lcms-devel
beb8121e 65BuildRequires: libgphoto2-devel
c504380e 66BuildRequires: libjpeg-devel
1e160e6e 67BuildRequires: libtool
fbb1220c 68BuildRequires: libxslt-devel
931f130b 69%{?with_nas:BuildRequires: nas-devel}
8a1d358f 70BuildRequires: ncurses-devel
16e36f25
JB
71# db2* failed previously - probably openjade or opensp bug
72BuildRequires: openjade >= 1:1.3.3-0.pre1
91c42b90 73BuildRequires: openldap-devel
16e36f25 74BuildRequires: opensp >= 1:1.5.1
2c81f5eb 75BuildRequires: openssl-devel >= 0.9.7d
beb8121e 76BuildRequires: pkgconfig
5715e1d1 77%{?with_sane:BuildRequires: sane-backends-devel}
8b4bf701 78#BuildRequires: valgrind
beb8121e 79BuildRequires: xorg-lib-libXcomposite-devel
80BuildRequires: xorg-lib-libXcursor-devel
c66c3406 81BuildRequires: xorg-lib-libXi-devel
beb8121e 82BuildRequires: xorg-lib-libXinerama-devel
c66c3406 83BuildRequires: xorg-lib-libXmu-devel
beb8121e 84BuildRequires: xorg-lib-libXrandr-devel
c66c3406 85BuildRequires: xorg-lib-libXrender-devel
86BuildRequires: xorg-lib-libXxf86dga-devel
87BuildRequires: xorg-lib-libXxf86vm-devel
ae42c99e 88Suggests: binfmt-detector
f96e197b 89# for winelauncher
3bddfbf2 90Suggests: xorg-app-xmessage
f96e197b 91# for ntlm_auth
14e95129 92Suggests: samba-common >= 1:3.0.25
52b6007b
JB
93# link to wine/ntdll.dll.so, without any SONAME
94Provides: libntdll.dll.so
7212da21 95Obsoletes: wine-doc-pdf
93b34e12 96Obsoletes: wine-drv-arts
d9590b9e 97ExclusiveArch: %{ix86}
206eed29 98ExcludeArch: i386
0403821a 99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 100
e8f81a0a 101%define _noautoreqdep libGL.so.1 libGLU.so.1
102%define no_install_post_strip 1
103
e8f81a0a 104%define _winedir %{_datadir}/%{name}
6731627f 105
65c325f6 106%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 107
344ce2c2 108%undefine debuginfocflags
109
5c4ec57b 110%description
6731627f 111Wine is a program which allows running Microsoft Windows programs
a519bc4f 112(including DOS, Windows 3.x and Win32 executables) on Unix. It
113consists of a program loader which loads and executes a Microsoft
114Windows binary, and a library that implements Windows API calls using
115their Unix or X11 equivalents. The library may also be used for
116porting Win32 code into native Unix executables.
5c4ec57b 117
c967e47d 118%description -l es.UTF-8
f33a1517 119Ejecuta programas Windows en Linux.
120
c967e47d
JR
121%description -l pl.UTF-8
122Wine jest programem dzięki któremu można uruchamiać programy napisane
123dla Microsoft Windows pod systemami uniksowymi. Składa się on z
124loadera, który pozwala wczytywać i uruchamiać programy w formacie
125Microsoft Windows, oraz z biblioteki, która implementuje API Windows
126przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
127także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 128
c967e47d
JR
129%description -l pt_BR.UTF-8
130O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 131Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 132binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 133chamadas da API para as equivalentes Unix/X11.
134
5c4ec57b 135%package devel
7a050f82 136Summary: Wine - header files
93e41e44
ER
137Summary(es.UTF-8): Biblioteca de desarrollo de wine
138Summary(pl.UTF-8): Wine - pliki nagłowkowe
139Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 140Group: Development/Libraries
46114a9a 141Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 142
5c4ec57b 143%description devel
144Wine - header files.
145
c967e47d 146%description devel -l es.UTF-8
f33a1517 147Biblioteca de desarrollo de wine.
148
c967e47d
JR
149%description devel -l pl.UTF-8
150Wine - pliki nagłówkowe.
5c4ec57b 151
c967e47d
JR
152%description devel -l pt_BR.UTF-8
153Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 154WINE.
155
e8f81a0a 156%package programs
157Summary: Wine - programs
93e41e44 158Summary(pl.UTF-8): Wine - programy
e8f81a0a 159Group: Applications
46114a9a 160Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 161
162%description programs
0a7c5d50 163Wine - programs.
e8f81a0a 164
c967e47d 165%description programs -l pl.UTF-8
0a7c5d50 166Wine - programy.
e8f81a0a 167
16e36f25
JB
168%package dll-d3d
169Summary: Direct3D implementation DLLs for Wine
93e41e44 170Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 171Group: Applications/Emulators
46114a9a 172Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
173Requires: OpenGL
174
175%description dll-d3d
176Direct3D implementation DLLs for Wine (through OpenGL).
177
c967e47d
JR
178%description dll-d3d -l pl.UTF-8
179Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
180
181%package dll-gl
182Summary: OpenGL implementation DLLs for Wine
93e41e44 183Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 184Group: Applications/Emulators
46114a9a 185Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
186Requires: OpenGL
187
188%description dll-gl
189OpenGL implementation DLLs for Wine.
190
c967e47d
JR
191%description dll-gl -l pl.UTF-8
192Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
193
194%package dll-twain
195Summary: TWAIN implementation DLL for Wine
93e41e44 196Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 197Group: Applications/Emulators
46114a9a 198Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
199
200%description dll-twain
201TWAIN implementation DLL for Wine (through SANE).
202
c967e47d
JR
203%description dll-twain -l pl.UTF-8
204Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
205
206%package drv-alsa
207Summary: ALSA driver for WINE mm.dll implementation
93e41e44 208Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 209Group: Applications/Emulators
46114a9a 210Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
211
212%description drv-alsa
213ALSA driver for WINE mm.dll (multimedia system) implementation.
214
c967e47d
JR
215%description drv-alsa -l pl.UTF-8
216Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 217
16e36f25
JB
218%package drv-jack
219Summary: JACK driver for WINE mm.dll implementation
93e41e44 220Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 221Group: Applications/Emulators
46114a9a 222Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
223Requires: jack-audio-connection-kit
224# dlopened by SONAME detected at build time
42c123f0 225%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
226
227%description drv-jack
228JACK driver for WINE mm.dll (multimedia system) implementation.
229
c967e47d
JR
230%description drv-jack -l pl.UTF-8
231Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 232Wine.
16e36f25
JB
233
234%package drv-nas
235Summary: NAS driver for WINE mm.dll implementation
93e41e44 236Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 237Group: Applications/Emulators
46114a9a 238Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
239
240%description drv-nas
241NAS driver for WINE mm.dll (multimedia system) implementation.
242
c967e47d
JR
243%description drv-nas -l pl.UTF-8
244Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 245
5c4ec57b 246%prep
9c1d94d6 247%setup -q
2fbbb535 248%patch0 -p1
249%patch1 -p1
ab25825d 250%patch2 -p1
dc0316fb 251%patch3 -p1
8b4bf701 252%patch4 -p1
591d55ba 253
254# turn off compilation of some tools
a6c536e0 255sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
256#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 257
258%build
2fbbb535 259%{__autoconf}
103d8328 260%{__autoheader}
9d6a128d 261%configure \
c504380e 262 --with%{!?with_alsa:out}-alsa \
beb8121e 263 --with-cms \
c504380e 264 --with%{!?with_cups:out}-cups \
c504380e 265 --with-cups \
266 --with-curses \
267 --with-esd \
268 --with-fontconfig \
269 --with-freetype \
270 --with-glu \
beb8121e 271 --with-gphoto \
272 --with-hal \
c504380e 273 --with%{!?with_jack:out}-jack \
274 --with-jpeg \
275 --with-ldap \
276 --with%{!?with_nas:out}-nas \
277 --with-opengl \
278 --with-openssl \
279 --with-oss \
280 --with-png \
281 --with%{!?with_sane:out}-sane \
beb8121e 282 --with-xcomposite \
283 --with-xcursor \
284 --with-xinerama \
285 --with-xinput \
c504380e 286 --with-xml \
beb8121e 287 --with-xrandr \
c504380e 288 --with-xrender \
289 --with-xshape \
290 --with-xshm \
291 --with-xslt \
beb8121e 292 --with-xxf86vm \
698e86e7 293 --with-x
05eb066b 294%{__make} depend
4aafdd81 295%{__make}
e8f81a0a 296%{__make} -C programs
297
5c4ec57b 298%install
299rm -rf $RPM_BUILD_ROOT
ffb676e0 300install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 301
c7af491d
JB
302%{__make} install \
303 DESTDIR=$RPM_BUILD_ROOT
304
305%{__make} -C programs install \
306 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 307
6a79cc08 308install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 309
0b87866b 310install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 311
2a437456 312install -d \
65c325f6 313 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
314 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 315 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
316 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
317 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
318
a91c2692 319touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
320touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
321touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
322
76055aa1 323cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 324[mci]
325cdaudio=mcicda.drv
326sequencer=mciseq.drv
327waveaudio=mciwave.drv
328avivideo=mciavi.drv
329videodisc=mcipionr.drv
330vcr=mciviscd.drv
331MPEGVideo=mciqtz.drv
5c4ec57b 332EOF
333
e8f81a0a 334%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
335echo "Strip executable binaries and shared object files."
336filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
337elfexelist=`echo $filelist | xargs -r file | \
338 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
339elfsharedlist=`echo $filelist | xargs -r file | \
340 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
341if [ -n "$elfexelist" ]; then \
342 strip -R .note -R .comment $elfexelist
343fi
344if [ -n "$elfsharedlist" ]; then
65c325f6 345 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 346fi
e8f81a0a 347%endif
f1f3af79 348
80496098 349# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 350
cf94c569 351programs="msiexec notepad progman regedit regsvr32 uninstaller wineboot winebrowser winecfg wineconsole winedbg winefile winemine winepath"
0b87866b 352
8d493411 353BZZZ=`pwd`
354rm -f files.so; touch files.so
355rm -f files.programs; touch files.programs
55a96819 356cd $RPM_BUILD_ROOT%{_libdir}/wine
357for f in *.so; do
16e36f25 358 case $f in
ce2cb51b 359 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 360 ;;
361 *)
362 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 363 esac
55a96819 364done
365cd -
2f6853f9 366for p in $programs; do
8d493411 367 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
368 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
369 grep -v "$p\.exe\.so$" files.so > files.so.
370 mv -f files.so. files.so
55a96819 371done
55a96819 372
76055aa1
ER
373install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
374install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
375install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
376
5c4ec57b 377%clean
378rm -rf $RPM_BUILD_ROOT
379
d142aa07 380%post -p /sbin/ldconfig
f1f3af79
JB
381%postun -p /sbin/ldconfig
382
d142aa07 383%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 384rm -f /var/lock/subsys/wine
d142aa07
JB
385if [ -x /sbin/chkconfig ]; then
386 /sbin/chkconfig --del wine
387fi
388
55a96819 389%files -f files.so
5c4ec57b 390%defattr(644,root,root,755)
64ef6fe1 391%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
12b1296e 392%lang(de) %doc documentation/README.de
393%lang(es) %doc documentation/README.es
394%lang(fr) %doc documentation/README.fr
395%lang(it) %doc documentation/README.it
7b9e958b 396%lang(ko) %doc documentation/README.ko
58a0e5f4 397%lang(nb) %doc documentation/README.no
12b1296e 398%lang(pt) %doc documentation/README.pt
74de5921 399%lang(pt_BR) %doc documentation/README.pt_br
82432451 400%attr(755,root,root) %{_bindir}/msiexec
591d55ba 401%attr(755,root,root) %{_bindir}/wine
d479f953 402%attr(755,root,root) %{_bindir}/wineboot
34f03014 403%attr(755,root,root) %{_bindir}/winebrowser
d479f953 404%attr(755,root,root) %{_bindir}/winecfg
55a96819 405%attr(755,root,root) %{_bindir}/winedbg
5c36538d 406%attr(755,root,root) %{_bindir}/wine-kthread
4f8ea62d 407#%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 408%attr(755,root,root) %{_bindir}/wineprefixcreate
409%attr(755,root,root) %{_bindir}/wine-preloader
410%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 411%attr(755,root,root) %{_bindir}/wineserver
591d55ba 412%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 413%attr(755,root,root) %{_libdir}/*.so*
861238d3 414%dir %{_libdir}/wine
489ca66c 415%{_libdir}/wine/*.dll16
416%{_libdir}/wine/*.drv16
417%{_libdir}/wine/*.exe16
b93e474e 418%{_libdir}/wine/*.mod16
b86f1c34 419%{_mandir}/man1/wine.1*
72ede285 420%{_mandir}/man1/winedbg.1*
b86f1c34
JB
421%{_mandir}/man1/wineprefixcreate.1*
422%{_mandir}/man1/wineserver.1*
a91c2692 423%{_winedir}
a6c536e0 424%{_desktopdir}/wine.desktop
76055aa1
ER
425%{_desktopdir}/wine-uninstaller.desktop
426%{_pixmapsdir}/wine.svg
5c4ec57b 427
55a96819 428%files programs -f files.programs
e8f81a0a 429%defattr(644,root,root,755)
e8f81a0a 430
5c4ec57b 431%files devel
432%defattr(644,root,root,755)
d479f953 433%attr(755,root,root) %{_bindir}/fnt2bdf
434%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 435%attr(755,root,root) %{_bindir}/widl
55a96819 436%attr(755,root,root) %{_bindir}/winebuild
55a96819 437%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 438%attr(755,root,root) %{_bindir}/wineg++
d479f953 439%attr(755,root,root) %{_bindir}/winegcc
440%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 441%attr(755,root,root) %{_bindir}/winecpp
8593fdc2 442#%attr(755,root,root) %{_bindir}/winewrap
55a96819 443%attr(755,root,root) %{_bindir}/wmc
d479f953 444%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
445%{_libdir}/wine/lib*.def
446# no shared variants, so not separated
447%{_libdir}/wine/lib*.def.a
b93e474e 448%{_libdir}/wine/libadsiid.a
7265d9f2
JB
449%{_libdir}/wine/libdx*.a
450%{_libdir}/wine/libstrmiids.a
451%{_libdir}/wine/libuuid.a
452%{_libdir}/wine/libwinecrt0.a
5c4ec57b 453%{_includedir}/wine
34f03014
JB
454%{_mandir}/man1/widl.1*
455%{_mandir}/man1/winedump.1*
bff06719 456%{_mandir}/man1/winegcc.1*
5ec7e550 457%{_mandir}/man1/wineg++.1*
34f03014
JB
458%{_mandir}/man1/winemaker.1*
459%{_mandir}/man1/winebuild.1*
460%{_mandir}/man1/wmc.1*
461%{_mandir}/man1/wrc.1*
2b5050a8 462%{_aclocaldir}/*.m4
f18f723c 463
16e36f25
JB
464%files dll-d3d
465%defattr(644,root,root,755)
466%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
467%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
468%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
469%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
470
471%files dll-gl
472%defattr(644,root,root,755)
473%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
474%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
475
476%if %{with sane}
477%files dll-twain
478%defattr(644,root,root,755)
b08b16bf 479%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 480%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
481%endif
482
483%if %{with alsa}
484%files drv-alsa
485%defattr(644,root,root,755)
486%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
487%endif
488
16e36f25
JB
489%if %{with jack}
490%files drv-jack
491%defattr(644,root,root,755)
492%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
493%endif
494
495%if %{with nas}
496%files drv-nas
497%defattr(644,root,root,755)
498%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
499%endif
500
501# additional dependencies in *.so not separated (yet?) from main package
502# ddraw.dll.so,x11drv.dll.so depend on X11 libs
503# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
504# ttydrv.dll.so depends on ncurses
This page took 0.224698 seconds and 4 git commands to generate.