]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- up to 9.0
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
0be89e87
BZ
2# todo:
3# libvkd3d https://wiki.winehq.org/Vkd3d
4#
7a30e9d7 5# Conditional build:
8e674d62 6%bcond_with capi # don't build CAPI 2.0 (ISDN) support
beafc810 7%bcond_without gstreamer # don't build GStreamer filters support
16e36f25
JB
8%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 10%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
13# libGL (winex11.drv.so)
14# libOSMesa (gdi32.dll.so)
15# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16# libcapi20 (capi2032.dll.so)
17# libcups (winspool.drv.so)
18# libdbus (mountmgr.sys.so)
16e36f25 19# libfontconfig (gdi32.dll.so)
5b49e814
JB
20# libfreetype (gdi32.dll.so)
21# libgnutls (secur32.dll.so)
5b49e814
JB
22# libncurses (kernel32.dll.so)
23# libodbc (odbc32.dll.so)
5b49e814
JB
24# libsane (sane.ds.so)
25# libtiff (windowscodecs.dll.so)
546bbb82 26# thus requires rebuild after change of any of the above.
db80a28e 27
4ce8abe1
ER
28# library qualifier in rpm generated deps
29%ifarch %{x8664} ia64 ppc64 s390x sparc64
30%define libqual ()(64bit)
31%else
32%define libqual %{nil}
33%endif
34
fe2412f1 35%ifarch %{x8664}
2c7f2af5
BZ
36%define winelib x86_64
37%else
38%define winelib i386
39%endif
40
c864c6aa 41%define gecko_ver 2.47.4
698e86e7 42Summary: Program that lets you launch Win applications
93e41e44
ER
43Summary(es.UTF-8): Ejecuta programas Windows en Linux
44Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
45Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 46Name: wine
c864c6aa 47Version: 9.0
2f648c88 48Release: 1
46114a9a 49Epoch: 1
528c1138 50License: LGPL
5c4ec57b 51Group: Applications/Emulators
c864c6aa
KM
52Source0: https://dl.winehq.org/wine/source/9.0/%{name}-%{version}.tar.xz
53# Source0-md5: 78e1cb8d77d20b44820461b056a15069
3e4a4fb9 54Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
c864c6aa 55# Source1-md5: f61c2a0065301ce329aa390342e70f14
3e4a4fb9 56Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
c864c6aa 57# Source2-md5: 8cc7018079a8db70e822320b69185515
beafc810 58Source3: %{name}-uninstaller.desktop
55061442 59Patch0: %{name}-gphoto2_bool.patch
a0ff0658 60Patch1: %{name}-makedep.patch
a4a10255 61Patch2: %{name}-ncurses.patch
8b4bf701 62Patch4: %{name}-disable-valgrind.patch
5312a936 63Patch5: %{name}-ca_certificates.patch
a26a3859
JK
64Patch6: desktop.patch
65Patch7: %{name}-wine64_man.patch
1b3d8891 66URL: http://www.winehq.org/
5b49e814 67BuildRequires: Mesa-libOSMesa-devel
0aac4f59 68BuildRequires: OpenAL-devel >= 1.1
5b49e814 69BuildRequires: OpenCL-devel
489ca66c 70BuildRequires: OpenGL-GLU-devel
fe2412f1 71BuildRequires: SDL2-devel
dd8ee46d 72BuildRequires: alsa-lib-devel
6547534c 73%{?with_arts:BuildRequires: artsc-devel}
5b49e814 74BuildRequires: autoconf >= 2.62
c7af491d 75BuildRequires: automake
d3c41437 76BuildRequires: bison
beafc810 77%{?with_capi:BuildRequires: capi4k-utils-devel}
dd8ee46d 78BuildRequires: clang
5715e1d1 79%{?with_cups:BuildRequires: cups-devel}
5b49e814 80BuildRequires: dbus-devel
5b49e814 81BuildRequires: flex >= 2.5.33
16e36f25 82BuildRequires: fontconfig-devel
5fc34681 83BuildRequires: freetype-devel >= 2.0.5
05596b04 84BuildRequires: gettext-devel
5b49e814
JB
85%ifarch %{x8664}
86BuildRequires: gcc >= 6:4.4
87%endif
1f0c428e 88BuildRequires: gettext-tools
c57a98fe 89BuildRequires: gnutls-devel
f73ad4b6
JP
90%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
91%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
92# for icotool used in build
93BuildRequires: icoutils >= 0.29.0
94BuildRequires: lcms2-devel >= 2
3d0989c1 95BuildRequires: libcap-devel
fe2412f1 96BuildRequires: libglvnd-libEGL-devel
beb8121e 97BuildRequires: libgphoto2-devel
05596b04 98BuildRequires: libpcap-devel
fe2412f1 99BuildRequires: libv4l-devel
c864c6aa 100BuildRequires: libxkbregistry-devel
af5ae18a 101BuildRequires: lld
beb8121e 102BuildRequires: pkgconfig
3d0989c1 103BuildRequires: pulseaudio-devel
d7296a19 104BuildRequires: samba-devel
5715e1d1 105%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 106BuildRequires: xorg-lib-libX11-devel
beb8121e 107BuildRequires: xorg-lib-libXcomposite-devel
108BuildRequires: xorg-lib-libXcursor-devel
5b49e814 109BuildRequires: xorg-lib-libXext-devel
c66c3406 110BuildRequires: xorg-lib-libXi-devel
beb8121e 111BuildRequires: xorg-lib-libXinerama-devel
beb8121e 112BuildRequires: xorg-lib-libXrandr-devel
c66c3406 113BuildRequires: xorg-lib-libXrender-devel
c66c3406 114BuildRequires: xorg-lib-libXxf86vm-devel
d1385401
JR
115BuildConflicts: crossmingw32-gcc
116BuildConflicts: crossmingw64-gcc
dd8ee46d 117Requires: OpenGL
4ce8abe1 118Requires: libfreetype.so.6%{libqual}
a85c8746 119Requires: libpng16.so.16%{libqual}
8df63af6 120Requires(post): /sbin/ldconfig
ae42c99e 121Suggests: binfmt-detector
be70b824 122Suggests: ca-certificates
beafc810 123Suggests: cabextract
a2f68044 124Conflicts: ca-certificates < 20080809-4
b3d3861d 125# for printing needs lpr
126Suggests: cups-clients
f96e197b 127# for winelauncher
3bddfbf2 128Suggests: xorg-app-xmessage
f96e197b 129# for ntlm_auth
14e95129 130Suggests: samba-common >= 1:3.0.25
52b6007b
JB
131# link to wine/ntdll.dll.so, without any SONAME
132Provides: libntdll.dll.so
78e6e4d9
JR
133Obsoletes: wine-dll-d3d < 1:7.7-2
134Obsoletes: wine-dll-gl < 1:7.7-2
c864c6aa 135Obsoletes: wine-dll-ldap < 1:9.0
78e6e4d9
JR
136Obsoletes: wine-doc-pdf < 1:7.7-2
137Obsoletes: wine-drv-alsa < 1:7.7-2
138Obsoletes: wine-drv-arts < 1:7.7-2
139Obsoletes: wine-drv-jack < 1:7.7-2
140Obsoletes: wine-drv-nas < 1:7.7-2
141Obsoletes: wine-programs < 1:7.7-2
5b49e814 142ExclusiveArch: %{ix86} %{x8664} arm
206eed29 143ExcludeArch: i386
0403821a 144BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 145
e8f81a0a 146%define no_install_post_strip 1
b955dc60 147%define _noautoprov elf\\\\(buildid\\\\)
e8f81a0a 148
e8f81a0a 149%define _winedir %{_datadir}/%{name}
6731627f 150
5c4ec57b 151%description
6731627f 152Wine is a program which allows running Microsoft Windows programs
a519bc4f 153(including DOS, Windows 3.x and Win32 executables) on Unix. It
154consists of a program loader which loads and executes a Microsoft
155Windows binary, and a library that implements Windows API calls using
156their Unix or X11 equivalents. The library may also be used for
157porting Win32 code into native Unix executables.
5c4ec57b 158
c967e47d 159%description -l es.UTF-8
f33a1517 160Ejecuta programas Windows en Linux.
161
c967e47d
JR
162%description -l pl.UTF-8
163Wine jest programem dzięki któremu można uruchamiać programy napisane
164dla Microsoft Windows pod systemami uniksowymi. Składa się on z
165loadera, który pozwala wczytywać i uruchamiać programy w formacie
166Microsoft Windows, oraz z biblioteki, która implementuje API Windows
167przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
168także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 169
c967e47d
JR
170%description -l pt_BR.UTF-8
171O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 172Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 173binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 174chamadas da API para as equivalentes Unix/X11.
175
5c4ec57b 176%package devel
7a050f82 177Summary: Wine - header files
93e41e44
ER
178Summary(es.UTF-8): Biblioteca de desarrollo de wine
179Summary(pl.UTF-8): Wine - pliki nagłowkowe
180Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 181Group: Development/Libraries
46114a9a 182Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 183
5c4ec57b 184%description devel
185Wine - header files.
186
c967e47d 187%description devel -l es.UTF-8
f33a1517 188Biblioteca de desarrollo de wine.
189
c967e47d
JR
190%description devel -l pl.UTF-8
191Wine - pliki nagłówkowe.
5c4ec57b 192
c967e47d
JR
193%description devel -l pt_BR.UTF-8
194Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 195WINE.
196
beafc810
MM
197%package dll-capi
198Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
199Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
200Group: Applications/Emulators
201Requires: %{name} = %{epoch}:%{version}-%{release}
202
203%description dll-capi
b1df4aa7 204CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
205
206%description dll-capi -l pl.UTF-8
b1df4aa7 207Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 208
16e36f25
JB
209%package dll-twain
210Summary: TWAIN implementation DLL for Wine
93e41e44 211Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 212Group: Applications/Emulators
46114a9a 213Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
214
215%description dll-twain
216TWAIN implementation DLL for Wine (through SANE).
217
c967e47d
JR
218%description dll-twain -l pl.UTF-8
219Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 220
5c4ec57b 221%prep
fec39f21 222%setup -q
f67e874d 223#%patch0 -p1
2fbbb535 224%patch1 -p1
8b4bf701 225%patch4 -p1
5312a936 226%patch5 -p1
3bfef0cd 227%patch6 -p1
f6cf693b 228%ifarch %{x8664}
a26a3859 229%patch7 -p1
f6cf693b 230%endif
591d55ba 231
5c4ec57b 232%build
ebbd62c0
GP
233
234#workaround for icon extraction error.
235icotool -x -o . dlls/user32/resources/oic_winlogo.ico
236mv -f oic_winlogo_*32x32x32.png %{name}.png
237rm -f oic_winlogo_*.png
887fffcf 238
2fbbb535 239%{__autoconf}
103d8328 240%{__autoheader}
9d6a128d 241%configure \
f829f028
AM
242%ifarch %{x8664}
243 --enable-win64 \
244%endif
dd8ee46d 245 --with-alsa \
5b49e814 246 --with-capi%{!?with_capi:=no} \
d0d61ce7 247 --with-coreaudio \
5b49e814 248 --with-cups%{!?with_cups:=no} \
d7296a19 249 --with-dbus \
c504380e 250 --with-fontconfig \
251 --with-freetype \
d7296a19 252 --with-gphoto \
d0d61ce7 253 --with-gnutls \
8ec65640 254 %{__with_without gstreamer} \
d7296a19 255 --with%{!?with_netapi:out}-netapi \
d7296a19 256 --with-opencl \
c504380e 257 --with-opengl \
d7296a19 258 --with-osmesa \
c54d2750 259 --with-pcap \
d0d61ce7 260 --with-pthread \
c54d2750 261 --with-pulse \
c504380e 262 --with%{!?with_sane:out}-sane \
beb8121e 263 --with-xcomposite \
264 --with-xcursor \
265 --with-xinerama \
266 --with-xinput \
d7296a19 267 --with-xinput2 \
beb8121e 268 --with-xrandr \
c504380e 269 --with-xrender \
270 --with-xshape \
271 --with-xshm \
beb8121e 272 --with-xxf86vm \
0be89e87 273 --with-x
fe2412f1 274
05eb066b 275%{__make} depend
4aafdd81 276%{__make}
e8f81a0a 277
5c4ec57b 278%install
279rm -rf $RPM_BUILD_ROOT
ffb676e0 280install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
281%{__make} install \
282 DESTDIR=$RPM_BUILD_ROOT
283
a26a3859 284install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 285cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 286
2a437456 287install -d \
65c325f6 288 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
289 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 290 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
291 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
292 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
293
a91c2692 294touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
295touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
296touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
297
76055aa1 298cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 299[mci]
300cdaudio=mcicda.drv
301sequencer=mciseq.drv
302waveaudio=mciwave.drv
303avivideo=mciavi.drv
304videodisc=mcipionr.drv
305vcr=mciviscd.drv
306MPEGVideo=mciqtz.drv
5c4ec57b 307EOF
308
80496098 309# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 310
a26a3859
JK
311for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
312 mv "$dir" "${dir%.UTF-8}"
313done
314
f6cf693b 315%ifarch %{x8664}
fe2412f1 316cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
c54d2750
JK
317for lang in de fr pl ; do
318install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 319cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
c54d2750
JK
320done
321%else
fe2412f1 322cp -p loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
c54d2750
JK
323for lang in de fr pl ; do
324install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
fe2412f1 325cp -p loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
326done
327%endif
328
f7357f09 329install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 330%ifnarch %{x8664}
db80a28e 331cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 332%else
db80a28e 333cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 334%endif
f7357f09 335
887fffcf 336install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
337cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
338cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 339
5c4ec57b 340%clean
341rm -rf $RPM_BUILD_ROOT
342
8df63af6 343%post
db80a28e 344/sbin/ldconfig
8df63af6
ER
345%update_desktop_database
346
f1f3af79
JB
347%postun -p /sbin/ldconfig
348
d142aa07 349%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 350rm -f /var/lock/subsys/wine
d142aa07
JB
351if [ -x /sbin/chkconfig ]; then
352 /sbin/chkconfig --del wine
353fi
354
fe2412f1 355%files
5c4ec57b 356%defattr(644,root,root,755)
c864c6aa
KM
357%doc README.md AUTHORS ANNOUNCE.md
358%lang(de) %doc documentation/README-de.md
359%lang(es) %doc documentation/README-es.md
360%lang(fr) %doc documentation/README-fr.md
361%lang(hu) %doc documentation/README-hu.md
362%lang(it) %doc documentation/README-it.md
363%lang(ko) %doc documentation/README-ko.md
364%lang(nb) %doc documentation/README-no.md
365%lang(pt) %doc documentation/README-pt.md
366%lang(pt_BR) %doc documentation/README-pt_br.md
367%lang(ru) %doc documentation/README-ru.md
368%lang(sv) %doc documentation/README-sv.md
369%lang(tr) %doc documentation/README-tr.md
3092e49c 370%attr(755,root,root) %{_bindir}/msidb
82432451 371%attr(755,root,root) %{_bindir}/msiexec
dd8ee46d
JR
372%attr(755,root,root) %{_bindir}/notepad
373%attr(755,root,root) %{_bindir}/regedit
374%attr(755,root,root) %{_bindir}/regsvr32
beafc810
MM
375%ifnarch %{x8664}
376%attr(755,root,root) %{_bindir}/wine
377%else
378%attr(755,root,root) %{_bindir}/wine64
379%endif
d479f953 380%attr(755,root,root) %{_bindir}/wineboot
0aac4f59 381%attr(755,root,root) %{_bindir}/winecfg
dd8ee46d
JR
382%attr(755,root,root) %{_bindir}/wineconsole
383%attr(755,root,root) %{_bindir}/winedbg
384%attr(755,root,root) %{_bindir}/winefile
385%attr(755,root,root) %{_bindir}/winemine
386%attr(755,root,root) %{_bindir}/winepath
beafc810 387%ifnarch %{x8664}
f829f028 388%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
389%else
390%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 391%endif
beafc810 392%attr(755,root,root) %{_bindir}/wineserver
861238d3 393%dir %{_libdir}/wine
3092e49c
BZ
394%dir %{_libdir}/wine/%{winelib}-unix
395%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/*.so*
396%dir %{_libdir}/wine/%{winelib}-windows
397%{_libdir}/wine/%{winelib}-windows/*.acm
398%{_libdir}/wine/%{winelib}-windows/*.ax
399%{_libdir}/wine/%{winelib}-windows/*.com
400%{_libdir}/wine/%{winelib}-windows/*.cpl
401%{_libdir}/wine/%{winelib}-windows/*.dll
beafc810 402%ifarch %{ix86}
3092e49c 403%{_libdir}/wine/%{winelib}-windows/*.dll16
beafc810 404%endif
3092e49c 405%{_libdir}/wine/%{winelib}-windows/*.drv
beafc810 406%ifarch %{ix86}
3092e49c 407%{_libdir}/wine/%{winelib}-windows/*.drv16
beafc810 408%endif
3092e49c
BZ
409%{_libdir}/wine/%{winelib}-windows/*.ds
410%{_libdir}/wine/%{winelib}-windows/*.exe
beafc810 411%ifarch %{ix86}
3092e49c
BZ
412%{_libdir}/wine/%{winelib}-windows/*.exe16
413%{_libdir}/wine/%{winelib}-windows/*.mod16
beafc810 414%endif
3092e49c
BZ
415%{_libdir}/wine/%{winelib}-windows/*.msstyles
416%{_libdir}/wine/%{winelib}-windows/*.ocx
417%{_libdir}/wine/%{winelib}-windows/*.sys
418%{_libdir}/wine/%{winelib}-windows/*.tlb
f829f028 419%ifarch %{ix86}
3092e49c 420%{_libdir}/wine/%{winelib}-windows/*.vxd
f829f028 421%endif
dd8ee46d
JR
422%if %{with capi}
423%exclude %{_libdir}/wine/%{winelib}-windows/capi2032.dll
424%exclude %{_libdir}/wine/%{winelib}-unix/capi2032.so
425%endif
426%if %{with sane}
427%exclude %{_libdir}/wine/%{winelib}-unix/sane.so
428%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll
429%ifarch %{ix86}
430%exclude %{_libdir}/wine/%{winelib}-windows/twain*.dll16
431%endif
432%endif
dd8ee46d
JR
433%{_mandir}/man1/msiexec.1*
434%{_mandir}/man1/notepad.1*
435%{_mandir}/man1/regedit.1*
436%{_mandir}/man1/regsvr32.1*
f6cf693b 437%ifnarch %{x8664}
b86f1c34 438%{_mandir}/man1/wine.1*
47bd64d5
JK
439%lang(de) %{_mandir}/de/man1/wine.1*
440%lang(fr) %{_mandir}/fr/man1/wine.1*
441%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
442%else
443%{_mandir}/man1/wine64.1*
444%lang(de) %{_mandir}/de/man1/wine64.1*
445%lang(fr) %{_mandir}/fr/man1/wine64.1*
446%lang(pl) %{_mandir}/pl/man1/wine64.1*
447%endif
da274952
AG
448%{_mandir}/man1/wineboot.1*
449%{_mandir}/man1/winecfg.1*
dd8ee46d 450%{_mandir}/man1/wineconsole.1*
72ede285 451%{_mandir}/man1/winedbg.1*
dd8ee46d
JR
452%{_mandir}/man1/winefile.1*
453%{_mandir}/man1/winemine.1*
454%{_mandir}/man1/winepath.1*
b86f1c34 455%{_mandir}/man1/wineserver.1*
ad4623a1
AM
456%lang(de) %{_mandir}/de/man1/wineserver.1*
457%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 458%{_winedir}
a6c536e0 459%{_desktopdir}/wine.desktop
76055aa1 460%{_desktopdir}/wine-uninstaller.desktop
887fffcf 461%{_pixmapsdir}/%{name}.png
5c4ec57b 462
463%files devel
464%defattr(644,root,root,755)
a26a3859 465%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 466%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 467%attr(755,root,root) %{_bindir}/widl
55a96819 468%attr(755,root,root) %{_bindir}/winebuild
55a96819 469%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 470%attr(755,root,root) %{_bindir}/wineg++
d479f953 471%attr(755,root,root) %{_bindir}/winegcc
472%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 473%attr(755,root,root) %{_bindir}/winecpp
55a96819 474%attr(755,root,root) %{_bindir}/wmc
d479f953 475%attr(755,root,root) %{_bindir}/wrc
7265d9f2 476# no shared variants, so not separated
3092e49c 477%{_libdir}/wine/%{winelib}-unix/lib*.a
c864c6aa 478%{_libdir}/wine/%{winelib}-windows/lib*.a
5c4ec57b 479%{_includedir}/wine
34f03014 480%{_mandir}/man1/widl.1*
0aac4f59 481%{_mandir}/man1/winebuild.1*
da274952 482%{_mandir}/man1/winecpp.1*
34f03014 483%{_mandir}/man1/winedump.1*
bff06719 484%{_mandir}/man1/winegcc.1*
5ec7e550 485%{_mandir}/man1/wineg++.1*
34f03014 486%{_mandir}/man1/winemaker.1*
0aac4f59 487%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 488%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
489%{_mandir}/man1/wmc.1*
490%{_mandir}/man1/wrc.1*
2b5050a8 491%{_aclocaldir}/*.m4
f18f723c 492
ba28a7b8 493%if %{with capi}
beafc810
MM
494%files dll-capi
495%defattr(644,root,root,755)
3092e49c
BZ
496%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/capi2032.dll
497%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/capi2032.so
ba28a7b8 498%endif
beafc810 499
16e36f25
JB
500%if %{with sane}
501%files dll-twain
502%defattr(644,root,root,755)
3092e49c
BZ
503%attr(755,root,root) %{_libdir}/wine/%{winelib}-unix/sane.so
504%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll
505%ifarch %{ix86}
506%attr(755,root,root) %{_libdir}/wine/%{winelib}-windows/twain*.dll16
507%endif
16e36f25
JB
508%endif
509
16e36f25 510# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
511# ddraw.dll.so,winex11.drv.so depend on X11 libs
512# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.665586 seconds and 5 git commands to generate.