]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- 0.9.34
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b
JB
3%bcond_without alsa # don't build ALSA mm driver
4%bcond_without arts # don't build aRts mm driver
931f130b 5%bcond_without jack # don't build JACK mm driver
a393647c 6%bcond_without nas # don't build NAS mm driver
16e36f25
JB
7%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 9#
546bbb82 10# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
11# libcrypto,libssl (wininet.dll)
12# libcups (winspool.dll.so,wineps.dll.so)
13# libcurses/libncurses (wineconsole program)
14# libfontconfig (gdi32.dll.so)
15# libfreetype (wineps.dll.so,gdi32.dll.so)
16# libGL (x11drv.dll.so,ddraw.dll.so)
17# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 18# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 19# thus requires rebuild after change of any of the above.
931f130b
JB
20#
21# JACK requires ALSA
666ba35e 22%if !%{with alsa}
931f130b
JB
23%undefine with_jack
24%endif
698e86e7 25Summary: Program that lets you launch Win applications
93e41e44
ER
26Summary(es.UTF-8): Ejecuta programas Windows en Linux
27Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
28Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 29Name: wine
14685caf 30Version: 0.9.34
a4a10255 31Release: 1
46114a9a 32Epoch: 1
528c1138 33License: LGPL
5c4ec57b 34Group: Applications/Emulators
46114a9a 35Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
14685caf 36# Source0-md5: 0a06628d3be8f3b28a263f9f5f2c66bc
b68a79ec 37Patch0: %{name}-fontcache.patch
a0ff0658 38Patch1: %{name}-makedep.patch
a4a10255 39Patch2: %{name}-ncurses.patch
1803184e 40#PatchX: %{name}-dga.patch
1b3d8891 41URL: http://www.winehq.org/
489ca66c 42BuildRequires: OpenGL-GLU-devel
6547534c
KK
43%{?with_alsa:BuildRequires: alsa-lib-devel}
44%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
45BuildRequires: autoconf
46BuildRequires: automake
d3c41437 47BuildRequires: bison
5715e1d1 48%{?with_cups:BuildRequires: cups-devel}
f88a3451 49BuildRequires: docbook-dtd31-sgml
50BuildRequires: docbook-utils
5fc34681 51BuildRequires: flex
16e36f25 52BuildRequires: fontconfig-devel
22432818 53BuildRequires: fontforge
5fc34681 54BuildRequires: freetype-devel >= 2.0.5
734deeec 55BuildRequires: giflib-devel
931f130b 56%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 57BuildRequires: libjpeg-devel
1e160e6e 58BuildRequires: libtool
931f130b 59%{?with_nas:BuildRequires: nas-devel}
8a1d358f 60BuildRequires: ncurses-devel
16e36f25
JB
61# db2* failed previously - probably openjade or opensp bug
62BuildRequires: openjade >= 1:1.3.3-0.pre1
63BuildRequires: opensp >= 1:1.5.1
2c81f5eb 64BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 65%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 66BuildRequires: valgrind
c66c3406 67BuildRequires: xorg-lib-libXi-devel
68BuildRequires: xorg-lib-libXmu-devel
69BuildRequires: xorg-lib-libXrender-devel
70BuildRequires: xorg-lib-libXxf86dga-devel
71BuildRequires: xorg-lib-libXxf86vm-devel
2a437456 72Requires: binfmt-detector
52b6007b
JB
73# link to wine/ntdll.dll.so, without any SONAME
74Provides: libntdll.dll.so
d9590b9e 75ExclusiveArch: %{ix86}
0403821a 76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 77
e8f81a0a 78%define _noautoreqdep libGL.so.1 libGLU.so.1
79%define no_install_post_strip 1
80
e8f81a0a 81%define _winedir %{_datadir}/%{name}
6731627f 82
65c325f6 83%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 84
344ce2c2 85%undefine debuginfocflags
86
5c4ec57b 87%description
6731627f 88Wine is a program which allows running Microsoft Windows programs
a519bc4f 89(including DOS, Windows 3.x and Win32 executables) on Unix. It
90consists of a program loader which loads and executes a Microsoft
91Windows binary, and a library that implements Windows API calls using
92their Unix or X11 equivalents. The library may also be used for
93porting Win32 code into native Unix executables.
5c4ec57b 94
c967e47d 95%description -l es.UTF-8
f33a1517 96Ejecuta programas Windows en Linux.
97
c967e47d
JR
98%description -l pl.UTF-8
99Wine jest programem dzięki któremu można uruchamiać programy napisane
100dla Microsoft Windows pod systemami uniksowymi. Składa się on z
101loadera, który pozwala wczytywać i uruchamiać programy w formacie
102Microsoft Windows, oraz z biblioteki, która implementuje API Windows
103przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
104także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 105
c967e47d
JR
106%description -l pt_BR.UTF-8
107O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 108Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 109binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 110chamadas da API para as equivalentes Unix/X11.
111
5c4ec57b 112%package devel
7a050f82 113Summary: Wine - header files
93e41e44
ER
114Summary(es.UTF-8): Biblioteca de desarrollo de wine
115Summary(pl.UTF-8): Wine - pliki nagłowkowe
116Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 117Group: Development/Libraries
46114a9a 118Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 119
5c4ec57b 120%description devel
121Wine - header files.
122
c967e47d 123%description devel -l es.UTF-8
f33a1517 124Biblioteca de desarrollo de wine.
125
c967e47d
JR
126%description devel -l pl.UTF-8
127Wine - pliki nagłówkowe.
5c4ec57b 128
c967e47d
JR
129%description devel -l pt_BR.UTF-8
130Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 131WINE.
132
e8f81a0a 133%package programs
134Summary: Wine - programs
93e41e44 135Summary(pl.UTF-8): Wine - programy
e8f81a0a 136Group: Applications
46114a9a 137Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 138
139%description programs
0a7c5d50 140Wine - programs.
e8f81a0a 141
c967e47d 142%description programs -l pl.UTF-8
0a7c5d50 143Wine - programy.
e8f81a0a 144
16e36f25
JB
145%package dll-d3d
146Summary: Direct3D implementation DLLs for Wine
93e41e44 147Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 148Group: Applications/Emulators
46114a9a 149Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
150Requires: OpenGL
151
152%description dll-d3d
153Direct3D implementation DLLs for Wine (through OpenGL).
154
c967e47d
JR
155%description dll-d3d -l pl.UTF-8
156Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
157
158%package dll-gl
159Summary: OpenGL implementation DLLs for Wine
93e41e44 160Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 161Group: Applications/Emulators
46114a9a 162Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
163Requires: OpenGL
164
165%description dll-gl
166OpenGL implementation DLLs for Wine.
167
c967e47d
JR
168%description dll-gl -l pl.UTF-8
169Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
170
171%package dll-twain
172Summary: TWAIN implementation DLL for Wine
93e41e44 173Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 174Group: Applications/Emulators
46114a9a 175Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
176
177%description dll-twain
178TWAIN implementation DLL for Wine (through SANE).
179
c967e47d
JR
180%description dll-twain -l pl.UTF-8
181Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
182
183%package drv-alsa
184Summary: ALSA driver for WINE mm.dll implementation
93e41e44 185Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 186Group: Applications/Emulators
46114a9a 187Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
188
189%description drv-alsa
190ALSA driver for WINE mm.dll (multimedia system) implementation.
191
c967e47d
JR
192%description drv-alsa -l pl.UTF-8
193Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25
JB
194
195%package drv-arts
196Summary: aRts driver for WINE mm.dll implementation
93e41e44 197Summary(pl.UTF-8): Sterownik aRts dla implementacji mm.dll w Wine
16e36f25 198Group: Applications/Emulators
46114a9a 199Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
200
201%description drv-arts
202aRts driver for WINE mm.dll (multimedia system) implementation.
203
c967e47d
JR
204%description drv-arts -l pl.UTF-8
205Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25
JB
206
207%package drv-jack
208Summary: JACK driver for WINE mm.dll implementation
93e41e44 209Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 210Group: Applications/Emulators
46114a9a 211Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
212Requires: jack-audio-connection-kit
213# dlopened by SONAME detected at build time
42c123f0 214%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
215
216%description drv-jack
217JACK driver for WINE mm.dll (multimedia system) implementation.
218
c967e47d
JR
219%description drv-jack -l pl.UTF-8
220Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 221Wine.
16e36f25
JB
222
223%package drv-nas
224Summary: NAS driver for WINE mm.dll implementation
93e41e44 225Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 226Group: Applications/Emulators
46114a9a 227Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
228
229%description drv-nas
230NAS driver for WINE mm.dll (multimedia system) implementation.
231
c967e47d
JR
232%description drv-nas -l pl.UTF-8
233Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 234
5c4ec57b 235%prep
236%setup -q
2fbbb535 237%patch0 -p1
238%patch1 -p1
ab25825d 239%patch2 -p1
591d55ba 240
241# turn off compilation of some tools
a6c536e0 242sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
243#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 244
245%build
2fbbb535 246%{__autoconf}
103d8328 247%{__autoheader}
9d6a128d 248%configure \
2d927a35 249 %{!?debug:--disable-debug} \
250 %{!?debug:--disable-trace} \
8a1d358f 251 --enable-curses \
c40010b9 252 --enable-opengl \
698e86e7 253 --with-x
05eb066b 254%{__make} depend
4aafdd81 255%{__make}
e8f81a0a 256%{__make} -C programs
a393647c 257#%{__make} -C programs/regapi
e8f81a0a 258
5c4ec57b 259%install
260rm -rf $RPM_BUILD_ROOT
ffb676e0 261install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 262
c7af491d
JB
263%{__make} install \
264 DESTDIR=$RPM_BUILD_ROOT
265
266%{__make} -C programs install \
267 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 268
6a79cc08 269install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 270
0b87866b 271install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
272#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
273
2a437456 274install -d \
65c325f6 275 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
276 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 277 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
278 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
279 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
280
a91c2692 281touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
282touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
283touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
284
285cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
286[mci]
287cdaudio=mcicda.drv
288sequencer=mciseq.drv
289waveaudio=mciwave.drv
290avivideo=mciavi.drv
291videodisc=mcipionr.drv
292vcr=mciviscd.drv
293MPEGVideo=mciqtz.drv
5c4ec57b 294EOF
295
e8f81a0a 296%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
297echo "Strip executable binaries and shared object files."
298filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
299elfexelist=`echo $filelist | xargs -r file | \
300 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
301elfsharedlist=`echo $filelist | xargs -r file | \
302 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
303if [ -n "$elfexelist" ]; then \
304 strip -R .note -R .comment $elfexelist
305fi
306if [ -n "$elfsharedlist" ]; then
65c325f6 307 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 308fi
e8f81a0a 309%endif
f1f3af79 310
80496098 311# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 312
c257af95 313programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 314
8d493411 315BZZZ=`pwd`
316rm -f files.so; touch files.so
317rm -f files.programs; touch files.programs
55a96819 318cd $RPM_BUILD_ROOT%{_libdir}/wine
319for f in *.so; do
16e36f25 320 case $f in
1c5f02ef 321 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 322 ;;
323 *)
324 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 325 esac
55a96819 326done
327cd -
2f6853f9 328for p in $programs; do
8d493411 329 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
330 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
331 grep -v "$p\.exe\.so$" files.so > files.so.
332 mv -f files.so. files.so
55a96819 333done
55a96819 334
5c4ec57b 335%clean
336rm -rf $RPM_BUILD_ROOT
337
d142aa07 338%post -p /sbin/ldconfig
f1f3af79
JB
339%postun -p /sbin/ldconfig
340
d142aa07 341%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 342rm -f /var/lock/subsys/wine
d142aa07
JB
343if [ -x /sbin/chkconfig ]; then
344 /sbin/chkconfig --del wine
345fi
346
55a96819 347%files -f files.so
5c4ec57b 348%defattr(644,root,root,755)
12057076 349%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 350%lang(de) %doc documentation/README.de
351%lang(es) %doc documentation/README.es
352%lang(fr) %doc documentation/README.fr
353%lang(it) %doc documentation/README.it
7b9e958b 354%lang(ko) %doc documentation/README.ko
58a0e5f4 355%lang(nb) %doc documentation/README.no
12b1296e 356%lang(pt) %doc documentation/README.pt
74de5921 357%lang(pt_BR) %doc documentation/README.pt_br
82432451 358%attr(755,root,root) %{_bindir}/msiexec
591d55ba 359%attr(755,root,root) %{_bindir}/wine
d479f953 360%attr(755,root,root) %{_bindir}/wineboot
34f03014 361%attr(755,root,root) %{_bindir}/winebrowser
d479f953 362%attr(755,root,root) %{_bindir}/winecfg
55a96819 363%attr(755,root,root) %{_bindir}/winedbg
5c36538d 364%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 365%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 366%attr(755,root,root) %{_bindir}/wineprefixcreate
367%attr(755,root,root) %{_bindir}/wine-preloader
368%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 369%attr(755,root,root) %{_bindir}/wineserver
591d55ba 370%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 371%attr(755,root,root) %{_libdir}/*.so*
861238d3 372%dir %{_libdir}/wine
489ca66c 373%{_libdir}/wine/*.dll16
374%{_libdir}/wine/*.drv16
375%{_libdir}/wine/*.exe16
b86f1c34 376%{_mandir}/man1/wine.1*
72ede285 377%{_mandir}/man1/winedbg.1*
b86f1c34
JB
378%{_mandir}/man1/wineprefixcreate.1*
379%{_mandir}/man1/wineserver.1*
a91c2692 380%{_winedir}
a6c536e0 381%{_desktopdir}/wine.desktop
5c4ec57b 382
55a96819 383%files programs -f files.programs
e8f81a0a 384%defattr(644,root,root,755)
e8f81a0a 385
5c4ec57b 386%files devel
387%defattr(644,root,root,755)
d479f953 388%attr(755,root,root) %{_bindir}/fnt2bdf
389%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 390%attr(755,root,root) %{_bindir}/widl
55a96819 391%attr(755,root,root) %{_bindir}/winebuild
55a96819 392%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 393%attr(755,root,root) %{_bindir}/wineg++
d479f953 394%attr(755,root,root) %{_bindir}/winegcc
395%attr(755,root,root) %{_bindir}/winemaker
8593fdc2 396#%attr(755,root,root) %{_bindir}/winewrap
55a96819 397%attr(755,root,root) %{_bindir}/wmc
d479f953 398%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
399%{_libdir}/wine/lib*.def
400# no shared variants, so not separated
401%{_libdir}/wine/lib*.def.a
402%{_libdir}/wine/libdx*.a
403%{_libdir}/wine/libstrmiids.a
404%{_libdir}/wine/libuuid.a
405%{_libdir}/wine/libwinecrt0.a
5c4ec57b 406%{_includedir}/wine
34f03014
JB
407%{_mandir}/man1/widl.1*
408%{_mandir}/man1/winedump.1*
bff06719 409%{_mandir}/man1/winegcc.1*
34f03014
JB
410%{_mandir}/man1/winemaker.1*
411%{_mandir}/man1/winebuild.1*
412%{_mandir}/man1/wmc.1*
413%{_mandir}/man1/wrc.1*
2b5050a8 414%{_aclocaldir}/*.m4
f18f723c 415
16e36f25
JB
416%files dll-d3d
417%defattr(644,root,root,755)
418%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
419%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
420%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
421%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
422
423%files dll-gl
424%defattr(644,root,root,755)
425%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
426%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
427
428%if %{with sane}
429%files dll-twain
430%defattr(644,root,root,755)
b08b16bf 431%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 432%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
433%endif
434
435%if %{with alsa}
436%files drv-alsa
437%defattr(644,root,root,755)
438%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
439%endif
440
441%if %{with arts}
442%files drv-arts
443%defattr(644,root,root,755)
444%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
445%endif
446
447%if %{with jack}
448%files drv-jack
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
451%endif
452
453%if %{with nas}
454%files drv-nas
455%defattr(644,root,root,755)
456%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
457%endif
458
459# additional dependencies in *.so not separated (yet?) from main package
460# ddraw.dll.so,x11drv.dll.so depend on X11 libs
461# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
462# ttydrv.dll.so depends on ncurses
This page took 1.899602 seconds and 4 git commands to generate.