]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
Merge commit 'a26a38' from DEVEL branch
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
5b49e814 7%bcond_with hal # HAL dynamic device support [deprecated]
9d6715c4 8%bcond_without ldap # don't build LDAP DLL
16e36f25 9%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 10%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
13# libGL (winex11.drv.so)
14# libOSMesa (gdi32.dll.so)
15# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16# libcapi20 (capi2032.dll.so)
17# libcups (winspool.drv.so)
18# libdbus (mountmgr.sys.so)
16e36f25 19# libfontconfig (gdi32.dll.so)
5b49e814
JB
20# libfreetype (gdi32.dll.so)
21# libgnutls (secur32.dll.so)
22# libhal (mountmgr.sys.so)
23# libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
26# libpng (windowscodecs.dll.so)
27# libsane (sane.ds.so)
28# libtiff (windowscodecs.dll.so)
29# libv4l1 (qcap.dll.so)
30# libxslt (msxml3.dll.so)
546bbb82 31# thus requires rebuild after change of any of the above.
db80a28e 32
4ce8abe1
ER
33# library qualifier in rpm generated deps
34%ifarch %{x8664} ia64 ppc64 s390x sparc64
35%define libqual ()(64bit)
36%else
37%define libqual %{nil}
38%endif
39
c516c269 40%define gecko_ver 2.24
698e86e7 41Summary: Program that lets you launch Win applications
93e41e44
ER
42Summary(es.UTF-8): Ejecuta programas Windows en Linux
43Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
44Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 45Name: wine
c4aead27
JK
46# 1.6.x – stable
47# 1.7.x – development (DEVEL branch)
c516c269
JK
48Version: 1.7.18
49Release: 0.1
46114a9a 50Epoch: 1
528c1138 51License: LGPL
5c4ec57b 52Group: Applications/Emulators
beafc810 53Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
c516c269 54# Source0-md5: b13c19ef69a99f2aa6c0b3fd08ae8d90
beafc810 55Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
c516c269 56# Source1-md5: 766bb034172f7f0a97443951a02a0df8
beafc810 57Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
c516c269 58# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
beafc810 59Source3: %{name}-uninstaller.desktop
55061442 60Patch0: %{name}-gphoto2_bool.patch
a0ff0658 61Patch1: %{name}-makedep.patch
a4a10255 62Patch2: %{name}-ncurses.patch
8b4bf701 63Patch4: %{name}-disable-valgrind.patch
5312a936 64Patch5: %{name}-ca_certificates.patch
a26a3859
JK
65Patch6: desktop.patch
66Patch7: %{name}-wine64_man.patch
1b3d8891 67URL: http://www.winehq.org/
5b49e814 68BuildRequires: Mesa-libOSMesa-devel
0aac4f59 69BuildRequires: OpenAL-devel >= 1.1
5b49e814 70BuildRequires: OpenCL-devel
489ca66c 71BuildRequires: OpenGL-GLU-devel
5b49e814 72BuildRequires: OpenGL-GLX-devel
d7296a19 73BuildRequires: Mesa-libOSMesa-devel
6547534c
KK
74%{?with_alsa:BuildRequires: alsa-lib-devel}
75%{?with_arts:BuildRequires: artsc-devel}
5b49e814 76BuildRequires: autoconf >= 2.62
c7af491d 77BuildRequires: automake
d3c41437 78BuildRequires: bison
beafc810 79%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 80%{?with_cups:BuildRequires: cups-devel}
5b49e814 81BuildRequires: dbus-devel
f88a3451 82BuildRequires: docbook-dtd31-sgml
83BuildRequires: docbook-utils
5b49e814 84BuildRequires: flex >= 2.5.33
16e36f25 85BuildRequires: fontconfig-devel
22432818 86BuildRequires: fontforge
5fc34681 87BuildRequires: freetype-devel >= 2.0.5
5b49e814 88# for findup used after make install
16b3dd87 89BuildRequires: fslint
5b49e814
JB
90%ifarch %{x8664}
91BuildRequires: gcc >= 6:4.4
92%endif
1f0c428e 93BuildRequires: gettext-tools
734deeec 94BuildRequires: giflib-devel
c57a98fe 95BuildRequires: gnutls-devel
5b49e814
JB
96%{?with_gstreamer:BuildRequires: gstreamer0.10-devel >= 0.10}
97%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10}
98%{?with_hal:BuildRequires: hal-devel}
99# for icotool used in build
100BuildRequires: icoutils >= 0.29.0
101BuildRequires: lcms2-devel >= 2
beb8121e 102BuildRequires: libgphoto2-devel
d0d61ce7 103BuildRequires: libgsm-devel
c504380e 104BuildRequires: libjpeg-devel
2341e633 105BuildRequires: libmpg123-devel >= 1.5.0
5b49e814
JB
106BuildRequires: libpng-devel >= 1.5
107BuildRequires: libtiff-devel
1e160e6e 108BuildRequires: libtool
0aac4f59 109BuildRequires: libv4l-devel
5b49e814 110BuildRequires: libxml2-devel >= 2.0
fbb1220c 111BuildRequires: libxslt-devel
8a1d358f 112BuildRequires: ncurses-devel
16e36f25
JB
113# db2* failed previously - probably openjade or opensp bug
114BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 115%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 116BuildRequires: opensp >= 1:1.5.1
beb8121e 117BuildRequires: pkgconfig
beafc810 118BuildRequires: prelink
d7296a19 119BuildRequires: samba-devel
5715e1d1 120%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 121BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 122#BuildRequires: valgrind
5b49e814 123BuildRequires: xorg-lib-libX11-devel
beb8121e 124BuildRequires: xorg-lib-libXcomposite-devel
125BuildRequires: xorg-lib-libXcursor-devel
5b49e814 126BuildRequires: xorg-lib-libXext-devel
c66c3406 127BuildRequires: xorg-lib-libXi-devel
beb8121e 128BuildRequires: xorg-lib-libXinerama-devel
beb8121e 129BuildRequires: xorg-lib-libXrandr-devel
c66c3406 130BuildRequires: xorg-lib-libXrender-devel
c66c3406 131BuildRequires: xorg-lib-libXxf86vm-devel
5b49e814 132BuildRequires: zlib-devel
4ce8abe1 133Requires: libfreetype.so.6%{libqual}
a85c8746 134Requires: libpng16.so.16%{libqual}
8df63af6 135Requires(post): /sbin/ldconfig
ae42c99e 136Suggests: binfmt-detector
be70b824 137Suggests: ca-certificates
beafc810 138Suggests: cabextract
a2f68044 139Conflicts: ca-certificates < 20080809-4
b3d3861d 140# for printing needs lpr
141Suggests: cups-clients
f96e197b 142# for winelauncher
3bddfbf2 143Suggests: xorg-app-xmessage
f96e197b 144# for ntlm_auth
14e95129 145Suggests: samba-common >= 1:3.0.25
52b6007b
JB
146# link to wine/ntdll.dll.so, without any SONAME
147Provides: libntdll.dll.so
7212da21 148Obsoletes: wine-doc-pdf
93b34e12 149Obsoletes: wine-drv-arts
beafc810
MM
150Obsoletes: wine-drv-jack
151Obsoletes: wine-drv-nas
5b49e814 152ExclusiveArch: %{ix86} %{x8664} arm
206eed29 153ExcludeArch: i386
0403821a 154BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 155
e8f81a0a 156%define no_install_post_strip 1
157
e8f81a0a 158%define _winedir %{_datadir}/%{name}
6731627f 159
5c4ec57b 160%description
6731627f 161Wine is a program which allows running Microsoft Windows programs
a519bc4f 162(including DOS, Windows 3.x and Win32 executables) on Unix. It
163consists of a program loader which loads and executes a Microsoft
164Windows binary, and a library that implements Windows API calls using
165their Unix or X11 equivalents. The library may also be used for
166porting Win32 code into native Unix executables.
5c4ec57b 167
c967e47d 168%description -l es.UTF-8
f33a1517 169Ejecuta programas Windows en Linux.
170
c967e47d
JR
171%description -l pl.UTF-8
172Wine jest programem dzięki któremu można uruchamiać programy napisane
173dla Microsoft Windows pod systemami uniksowymi. Składa się on z
174loadera, który pozwala wczytywać i uruchamiać programy w formacie
175Microsoft Windows, oraz z biblioteki, która implementuje API Windows
176przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
177także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 178
c967e47d
JR
179%description -l pt_BR.UTF-8
180O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 181Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 182binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 183chamadas da API para as equivalentes Unix/X11.
184
5c4ec57b 185%package devel
7a050f82 186Summary: Wine - header files
93e41e44
ER
187Summary(es.UTF-8): Biblioteca de desarrollo de wine
188Summary(pl.UTF-8): Wine - pliki nagłowkowe
189Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 190Group: Development/Libraries
46114a9a 191Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 192
5c4ec57b 193%description devel
194Wine - header files.
195
c967e47d 196%description devel -l es.UTF-8
f33a1517 197Biblioteca de desarrollo de wine.
198
c967e47d
JR
199%description devel -l pl.UTF-8
200Wine - pliki nagłówkowe.
5c4ec57b 201
c967e47d
JR
202%description devel -l pt_BR.UTF-8
203Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 204WINE.
205
e8f81a0a 206%package programs
207Summary: Wine - programs
93e41e44 208Summary(pl.UTF-8): Wine - programy
e8f81a0a 209Group: Applications
46114a9a 210Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 211
212%description programs
0a7c5d50 213Wine - programs.
e8f81a0a 214
c967e47d 215%description programs -l pl.UTF-8
0a7c5d50 216Wine - programy.
e8f81a0a 217
beafc810
MM
218%package dll-capi
219Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
220Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
221Group: Applications/Emulators
222Requires: %{name} = %{epoch}:%{version}-%{release}
223
224%description dll-capi
b1df4aa7 225CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
226
227%description dll-capi -l pl.UTF-8
b1df4aa7 228Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 229
16e36f25
JB
230%package dll-d3d
231Summary: Direct3D implementation DLLs for Wine
93e41e44 232Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 233Group: Applications/Emulators
46114a9a 234Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
235Requires: OpenGL
236
237%description dll-d3d
238Direct3D implementation DLLs for Wine (through OpenGL).
239
c967e47d
JR
240%description dll-d3d -l pl.UTF-8
241Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
242
243%package dll-gl
244Summary: OpenGL implementation DLLs for Wine
93e41e44 245Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 246Group: Applications/Emulators
46114a9a 247Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
248Requires: OpenGL
249
250%description dll-gl
251OpenGL implementation DLLs for Wine.
252
c967e47d
JR
253%description dll-gl -l pl.UTF-8
254Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
255
256%package dll-twain
257Summary: TWAIN implementation DLL for Wine
93e41e44 258Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 259Group: Applications/Emulators
46114a9a 260Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
261
262%description dll-twain
263TWAIN implementation DLL for Wine (through SANE).
264
c967e47d
JR
265%description dll-twain -l pl.UTF-8
266Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 267
9d6715c4 268%package dll-ldap
db80a28e 269Summary: Win32 LDAP API DLL for Wine
b1df4aa7 270Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
271Group: Applications/Emulators
272Requires: %{name} = %{epoch}:%{version}-%{release}
273
274%description dll-ldap
b1df4aa7
JB
275Lightweight Directory Access Protocol Library for Wine.
276
277%description dll-ldap -l pl.UTF-8
278Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 279
16e36f25
JB
280%package drv-alsa
281Summary: ALSA driver for WINE mm.dll implementation
93e41e44 282Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 283Group: Applications/Emulators
46114a9a 284Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
285
286%description drv-alsa
287ALSA driver for WINE mm.dll (multimedia system) implementation.
288
c967e47d
JR
289%description drv-alsa -l pl.UTF-8
290Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 291
5c4ec57b 292%prep
db80a28e 293%setup -q
2fbbb535 294%patch0 -p1
295%patch1 -p1
ab25825d 296%patch2 -p1
8b4bf701 297%patch4 -p1
5312a936 298%patch5 -p1
3bfef0cd 299%patch6 -p1
f6cf693b 300%ifarch %{x8664}
a26a3859 301%patch7 -p1
f6cf693b 302%endif
591d55ba 303
5c4ec57b 304%build
887fffcf
ER
305icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
306mv -f oic_winlogo_*.png %{name}.png
307
2fbbb535 308%{__autoconf}
103d8328 309%{__autoheader}
9d6a128d 310%configure \
f829f028
AM
311%ifarch %{x8664}
312 --enable-win64 \
313%endif
5b49e814
JB
314 --with-alsa%{!?with_alsa:=no} \
315 --with-capi%{!?with_capi:=no} \
beb8121e 316 --with-cms \
d0d61ce7 317 --with-coreaudio \
5b49e814 318 --with-cups%{!?with_cups:=no} \
c504380e 319 --with-curses \
d7296a19 320 --with-dbus \
c504380e 321 --with-fontconfig \
322 --with-freetype \
d7296a19 323 --with-gphoto \
c504380e 324 --with-glu \
d0d61ce7 325 --with-gnutls \
d0d61ce7 326 --with-gsm \
8ec65640
JK
327 %{__with_without gstreamer} \
328 %{__with_without hal} \
c504380e 329 --with-jpeg \
5b49e814 330 --with-ldap%{!?with_ldap:=no} \
d0d61ce7 331 --with-mpg123 \
d7296a19
JK
332 --with%{!?with_netapi:out}-netapi \
333 --with-openal \
334 --with-opencl \
c504380e 335 --with-opengl \
336 --with-openssl \
d7296a19 337 --with-osmesa \
c504380e 338 --with-oss \
339 --with-png \
d0d61ce7 340 --with-pthread \
c504380e 341 --with%{!?with_sane:out}-sane \
d7296a19
JK
342 --with-tiff \
343 --with-v4l \
beb8121e 344 --with-xcomposite \
345 --with-xcursor \
346 --with-xinerama \
347 --with-xinput \
d7296a19 348 --with-xinput2 \
c504380e 349 --with-xml \
beb8121e 350 --with-xrandr \
c504380e 351 --with-xrender \
352 --with-xshape \
353 --with-xshm \
354 --with-xslt \
beb8121e 355 --with-xxf86vm \
d7296a19
JK
356 --with-x \
357 --with-zlib
05eb066b 358%{__make} depend
4aafdd81 359%{__make}
e8f81a0a 360
5c4ec57b 361%install
362rm -rf $RPM_BUILD_ROOT
ffb676e0 363install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
364%{__make} install \
365 DESTDIR=$RPM_BUILD_ROOT
366
a26a3859 367install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 368cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 369
2a437456 370install -d \
65c325f6 371 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
372 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 373 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
374 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
375 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
376
a91c2692 377touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
378touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
379touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
380
76055aa1 381cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 382[mci]
383cdaudio=mcicda.drv
384sequencer=mciseq.drv
385waveaudio=mciwave.drv
386avivideo=mciavi.drv
387videodisc=mcipionr.drv
388vcr=mciviscd.drv
389MPEGVideo=mciqtz.drv
5c4ec57b 390EOF
391
80496098 392# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 393
887fffcf
ER
394dir=$(pwd)
395> files.so
396> files.programs
55a96819 397cd $RPM_BUILD_ROOT%{_libdir}/wine
398for f in *.so; do
16e36f25 399 case $f in
ad4623a1 400 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
401 ;;
402 *)
403 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 404 esac
55a96819 405done
406cd -
887fffcf
ER
407
408programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 409for p in $programs; do
8d493411 410 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
411 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 412 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 413 grep -v "$p\.exe\.so$" files.so > files.so.
414 mv -f files.so. files.so
55a96819 415done
55a96819 416
a26a3859
JK
417for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
418 mv "$dir" "${dir%.UTF-8}"
419done
420
f6cf693b
JK
421%ifarch %{x8664}
422for langdir in "" de/ fr/ pl/ ; do
423mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
424done
425%endif
426
f7357f09 427install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 428%ifnarch %{x8664}
db80a28e 429cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 430%else
db80a28e 431cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 432%endif
f7357f09 433
887fffcf 434install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
435cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
436cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 437
5c4ec57b 438%clean
439rm -rf $RPM_BUILD_ROOT
440
8df63af6 441%post
db80a28e 442/sbin/ldconfig
8df63af6
ER
443%update_desktop_database
444
f1f3af79
JB
445%postun -p /sbin/ldconfig
446
d142aa07 447%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 448rm -f /var/lock/subsys/wine
d142aa07
JB
449if [ -x /sbin/chkconfig ]; then
450 /sbin/chkconfig --del wine
451fi
452
55a96819 453%files -f files.so
5c4ec57b 454%defattr(644,root,root,755)
47bd64d5 455%doc README AUTHORS ANNOUNCE
12b1296e 456%lang(de) %doc documentation/README.de
457%lang(es) %doc documentation/README.es
458%lang(fr) %doc documentation/README.fr
0aac4f59 459%lang(hu) %doc documentation/README.hu
12b1296e 460%lang(it) %doc documentation/README.it
7b9e958b 461%lang(ko) %doc documentation/README.ko
58a0e5f4 462%lang(nb) %doc documentation/README.no
12b1296e 463%lang(pt) %doc documentation/README.pt
74de5921 464%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
465%lang(ru) %doc documentation/README.ru
466%lang(sv) %doc documentation/README.sv
467%lang(tr) %doc documentation/README.tr
82432451 468%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
469%ifnarch %{x8664}
470%attr(755,root,root) %{_bindir}/wine
471%else
472%attr(755,root,root) %{_bindir}/wine64
473%endif
d479f953 474%attr(755,root,root) %{_bindir}/wineboot
55a96819 475%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 476%attr(755,root,root) %{_bindir}/winecfg
beafc810 477%ifnarch %{x8664}
f829f028 478%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
479%else
480%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 481%endif
beafc810 482%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 483%attr(755,root,root) %{_libdir}/*.so*
861238d3 484%dir %{_libdir}/wine
61e39970 485%dir %{_libdir}/wine/fakedlls
486%{_libdir}/wine/fakedlls/*.acm
487%{_libdir}/wine/fakedlls/*.cpl
488%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
489%ifarch %{ix86}
490%{_libdir}/wine/fakedlls/*.dll16
491%endif
61e39970 492%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
493%ifarch %{ix86}
494%{_libdir}/wine/fakedlls/*.drv16
495%endif
61e39970 496%{_libdir}/wine/fakedlls/*.ds
497%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
498%ifarch %{ix86}
499%{_libdir}/wine/fakedlls/*.exe16
500%{_libdir}/wine/fakedlls/*.mod16
501%endif
61e39970 502%{_libdir}/wine/fakedlls/*.ocx
503%{_libdir}/wine/fakedlls/*.sys
504%{_libdir}/wine/fakedlls/*.tlb
f829f028 505%ifarch %{ix86}
61e39970 506%{_libdir}/wine/fakedlls/*.vxd
f829f028 507%endif
f6cf693b 508%ifnarch %{x8664}
b86f1c34 509%{_mandir}/man1/wine.1*
47bd64d5
JK
510%lang(de) %{_mandir}/de/man1/wine.1*
511%lang(fr) %{_mandir}/fr/man1/wine.1*
512%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
513%else
514%{_mandir}/man1/wine64.1*
515%lang(de) %{_mandir}/de/man1/wine64.1*
516%lang(fr) %{_mandir}/fr/man1/wine64.1*
517%lang(pl) %{_mandir}/pl/man1/wine64.1*
518%endif
da274952
AG
519%{_mandir}/man1/msiexec.1*
520%{_mandir}/man1/wineboot.1*
521%{_mandir}/man1/winecfg.1*
72ede285 522%{_mandir}/man1/winedbg.1*
b86f1c34 523%{_mandir}/man1/wineserver.1*
ad4623a1
AM
524%lang(de) %{_mandir}/de/man1/wineserver.1*
525%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 526%{_winedir}
a6c536e0 527%{_desktopdir}/wine.desktop
76055aa1 528%{_desktopdir}/wine-uninstaller.desktop
887fffcf 529%{_pixmapsdir}/%{name}.png
5c4ec57b 530
55a96819 531%files programs -f files.programs
e8f81a0a 532%defattr(644,root,root,755)
e8f81a0a 533
5c4ec57b 534%files devel
535%defattr(644,root,root,755)
a26a3859 536%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 537%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 538%attr(755,root,root) %{_bindir}/widl
55a96819 539%attr(755,root,root) %{_bindir}/winebuild
55a96819 540%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 541%attr(755,root,root) %{_bindir}/wineg++
d479f953 542%attr(755,root,root) %{_bindir}/winegcc
543%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 544%attr(755,root,root) %{_bindir}/winecpp
55a96819 545%attr(755,root,root) %{_bindir}/wmc
d479f953 546%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
547%{_libdir}/wine/lib*.def
548# no shared variants, so not separated
549%{_libdir}/wine/lib*.def.a
b93e474e 550%{_libdir}/wine/libadsiid.a
7265d9f2 551%{_libdir}/wine/libdx*.a
beafc810 552%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
553%{_libdir}/wine/libstrmiids.a
554%{_libdir}/wine/libuuid.a
555%{_libdir}/wine/libwinecrt0.a
5c4ec57b 556%{_includedir}/wine
34f03014 557%{_mandir}/man1/widl.1*
0aac4f59 558%{_mandir}/man1/winebuild.1*
da274952 559%{_mandir}/man1/winecpp.1*
34f03014 560%{_mandir}/man1/winedump.1*
bff06719 561%{_mandir}/man1/winegcc.1*
5ec7e550 562%{_mandir}/man1/wineg++.1*
34f03014 563%{_mandir}/man1/winemaker.1*
0aac4f59 564%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 565%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
566%{_mandir}/man1/wmc.1*
567%{_mandir}/man1/wrc.1*
2b5050a8 568%{_aclocaldir}/*.m4
f18f723c 569
beafc810
MM
570%files dll-capi
571%defattr(644,root,root,755)
572%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
573
16e36f25
JB
574%files dll-d3d
575%defattr(644,root,root,755)
576%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
577%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
578%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
579
580%files dll-gl
581%defattr(644,root,root,755)
582%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
583%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
584
585%if %{with sane}
586%files dll-twain
587%defattr(644,root,root,755)
b08b16bf 588%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 589%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
590%endif
591
9d6715c4
ER
592%if %{with ldap}
593%files dll-ldap
594%defattr(644,root,root,755)
595%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
596%endif
597
16e36f25
JB
598%if %{with alsa}
599%files drv-alsa
600%defattr(644,root,root,755)
601%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
602%endif
603
16e36f25 604# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
605# ddraw.dll.so,winex11.drv.so depend on X11 libs
606# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.221594 seconds and 4 git commands to generate.