]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
Merge commit 'a26a38' from DEVEL branch
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 %bcond_without  netapi          # don't use the Samba NetAPI library
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libGL (winex11.drv.so)
14 #   libOSMesa (gdi32.dll.so)
15 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16 #   libcapi20 (capi2032.dll.so)
17 #   libcups (winspool.drv.so)
18 #   libdbus (mountmgr.sys.so)
19 #   libfontconfig (gdi32.dll.so)
20 #   libfreetype (gdi32.dll.so)
21 #   libgnutls (secur32.dll.so)
22 #   libhal (mountmgr.sys.so)
23 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libpng (windowscodecs.dll.so)
27 #   libsane (sane.ds.so)
28 #   libtiff (windowscodecs.dll.so)
29 #   libv4l1 (qcap.dll.so)
30 #   libxslt (msxml3.dll.so)
31 # thus requires rebuild after change of any of the above.
32
33 # library qualifier in rpm generated deps
34 %ifarch %{x8664} ia64 ppc64 s390x sparc64
35 %define libqual ()(64bit)
36 %else
37 %define libqual %{nil}
38 %endif
39
40 %define         gecko_ver       2.24
41 Summary:        Program that lets you launch Win applications
42 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
43 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
44 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
45 Name:           wine
46 # 1.6.x – stable
47 # 1.7.x – development (DEVEL branch)
48 Version:        1.7.18
49 Release:        0.1
50 Epoch:          1
51 License:        LGPL
52 Group:          Applications/Emulators
53 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
54 # Source0-md5:  b13c19ef69a99f2aa6c0b3fd08ae8d90
55 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
56 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
57 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
58 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
59 Source3:        %{name}-uninstaller.desktop
60 Patch0:         %{name}-gphoto2_bool.patch
61 Patch1:         %{name}-makedep.patch
62 Patch2:         %{name}-ncurses.patch
63 Patch4:         %{name}-disable-valgrind.patch
64 Patch5:         %{name}-ca_certificates.patch
65 Patch6:         desktop.patch
66 Patch7:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-GLX-devel
73 BuildRequires:  Mesa-libOSMesa-devel
74 %{?with_alsa:BuildRequires:     alsa-lib-devel}
75 %{?with_arts:BuildRequires:     artsc-devel}
76 BuildRequires:  autoconf >= 2.62
77 BuildRequires:  automake
78 BuildRequires:  bison
79 %{?with_capi:BuildRequires:     capi4k-utils-devel}
80 %{?with_cups:BuildRequires:     cups-devel}
81 BuildRequires:  dbus-devel
82 BuildRequires:  docbook-dtd31-sgml
83 BuildRequires:  docbook-utils
84 BuildRequires:  flex >= 2.5.33
85 BuildRequires:  fontconfig-devel
86 BuildRequires:  fontforge
87 BuildRequires:  freetype-devel >= 2.0.5
88 # for findup used after make install
89 BuildRequires:  fslint
90 %ifarch %{x8664}
91 BuildRequires:  gcc >= 6:4.4
92 %endif
93 BuildRequires:  gettext-tools
94 BuildRequires:  giflib-devel
95 BuildRequires:  gnutls-devel
96 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
97 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
98 %{?with_hal:BuildRequires:      hal-devel}
99 # for icotool used in build
100 BuildRequires:  icoutils >= 0.29.0
101 BuildRequires:  lcms2-devel >= 2
102 BuildRequires:  libgphoto2-devel
103 BuildRequires:  libgsm-devel
104 BuildRequires:  libjpeg-devel
105 BuildRequires:  libmpg123-devel >= 1.5.0
106 BuildRequires:  libpng-devel >= 1.5
107 BuildRequires:  libtiff-devel
108 BuildRequires:  libtool
109 BuildRequires:  libv4l-devel
110 BuildRequires:  libxml2-devel >= 2.0
111 BuildRequires:  libxslt-devel
112 BuildRequires:  ncurses-devel
113 # db2* failed previously - probably openjade or opensp bug
114 BuildRequires:  openjade >= 1:1.3.3-0.pre1
115 %{?with_ldap:BuildRequires:     openldap-devel}
116 BuildRequires:  opensp >= 1:1.5.1
117 BuildRequires:  pkgconfig
118 BuildRequires:  prelink
119 BuildRequires:  samba-devel
120 %{?with_sane:BuildRequires:     sane-backends-devel}
121 BuildRequires:  unixODBC-devel >= 2.2.12-2
122 #BuildRequires: valgrind
123 BuildRequires:  xorg-lib-libX11-devel
124 BuildRequires:  xorg-lib-libXcomposite-devel
125 BuildRequires:  xorg-lib-libXcursor-devel
126 BuildRequires:  xorg-lib-libXext-devel
127 BuildRequires:  xorg-lib-libXi-devel
128 BuildRequires:  xorg-lib-libXinerama-devel
129 BuildRequires:  xorg-lib-libXrandr-devel
130 BuildRequires:  xorg-lib-libXrender-devel
131 BuildRequires:  xorg-lib-libXxf86vm-devel
132 BuildRequires:  zlib-devel
133 Requires:       libfreetype.so.6%{libqual}
134 Requires:       libpng16.so.16%{libqual}
135 Requires(post): /sbin/ldconfig
136 Suggests:       binfmt-detector
137 Suggests:       ca-certificates
138 Suggests:       cabextract
139 Conflicts:      ca-certificates < 20080809-4
140 # for printing needs lpr
141 Suggests:       cups-clients
142 # for winelauncher
143 Suggests:       xorg-app-xmessage
144 # for ntlm_auth
145 Suggests:       samba-common >= 1:3.0.25
146 # link to wine/ntdll.dll.so, without any SONAME
147 Provides:       libntdll.dll.so
148 Obsoletes:      wine-doc-pdf
149 Obsoletes:      wine-drv-arts
150 Obsoletes:      wine-drv-jack
151 Obsoletes:      wine-drv-nas
152 ExclusiveArch:  %{ix86} %{x8664} arm
153 ExcludeArch:    i386
154 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
155
156 %define         no_install_post_strip   1
157
158 %define         _winedir                %{_datadir}/%{name}
159
160 %description
161 Wine is a program which allows running Microsoft Windows programs
162 (including DOS, Windows 3.x and Win32 executables) on Unix. It
163 consists of a program loader which loads and executes a Microsoft
164 Windows binary, and a library that implements Windows API calls using
165 their Unix or X11 equivalents. The library may also be used for
166 porting Win32 code into native Unix executables.
167
168 %description -l es.UTF-8
169 Ejecuta programas Windows en Linux.
170
171 %description -l pl.UTF-8
172 Wine jest programem dzięki któremu można uruchamiać programy napisane
173 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
174 loadera, który pozwala wczytywać i uruchamiać programy w formacie
175 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
176 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
177 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
178
179 %description -l pt_BR.UTF-8
180 O Wine é um programa que permite rodar programas MS-Windows no X11.
181 Ele consiste de um carregador de programa, que carrega e executa um
182 binário MS-Windows, e de uma biblioteca de emulação que traduz as
183 chamadas da API para as equivalentes Unix/X11.
184
185 %package devel
186 Summary:        Wine - header files
187 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
188 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
189 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
190 Group:          Development/Libraries
191 Requires:       %{name} = %{epoch}:%{version}-%{release}
192
193 %description devel
194 Wine - header files.
195
196 %description devel -l es.UTF-8
197 Biblioteca de desarrollo de wine.
198
199 %description devel -l pl.UTF-8
200 Wine - pliki nagłówkowe.
201
202 %description devel -l pt_BR.UTF-8
203 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
204 WINE.
205
206 %package programs
207 Summary:        Wine - programs
208 Summary(pl.UTF-8):      Wine - programy
209 Group:          Applications
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211
212 %description programs
213 Wine - programs.
214
215 %description programs -l pl.UTF-8
216 Wine - programy.
217
218 %package dll-capi
219 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
220 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
221 Group:          Applications/Emulators
222 Requires:       %{name} = %{epoch}:%{version}-%{release}
223
224 %description dll-capi
225 CAPI 2.0 (ISDN) implementation DLLs for Wine.
226
227 %description dll-capi -l pl.UTF-8
228 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
229
230 %package dll-d3d
231 Summary:        Direct3D implementation DLLs for Wine
232 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
233 Group:          Applications/Emulators
234 Requires:       %{name} = %{epoch}:%{version}-%{release}
235 Requires:       OpenGL
236
237 %description dll-d3d
238 Direct3D implementation DLLs for Wine (through OpenGL).
239
240 %description dll-d3d -l pl.UTF-8
241 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
242
243 %package dll-gl
244 Summary:        OpenGL implementation DLLs for Wine
245 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
246 Group:          Applications/Emulators
247 Requires:       %{name} = %{epoch}:%{version}-%{release}
248 Requires:       OpenGL
249
250 %description dll-gl
251 OpenGL implementation DLLs for Wine.
252
253 %description dll-gl -l pl.UTF-8
254 Biblioteki DLL z implementacją OpenGL dla Wine.
255
256 %package dll-twain
257 Summary:        TWAIN implementation DLL for Wine
258 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
259 Group:          Applications/Emulators
260 Requires:       %{name} = %{epoch}:%{version}-%{release}
261
262 %description dll-twain
263 TWAIN implementation DLL for Wine (through SANE).
264
265 %description dll-twain -l pl.UTF-8
266 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
267
268 %package dll-ldap
269 Summary:        Win32 LDAP API DLL for Wine
270 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
271 Group:          Applications/Emulators
272 Requires:       %{name} = %{epoch}:%{version}-%{release}
273
274 %description dll-ldap
275 Lightweight Directory Access Protocol Library for Wine.
276
277 %description dll-ldap -l pl.UTF-8
278 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
279
280 %package drv-alsa
281 Summary:        ALSA driver for WINE mm.dll implementation
282 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
283 Group:          Applications/Emulators
284 Requires:       %{name} = %{epoch}:%{version}-%{release}
285
286 %description drv-alsa
287 ALSA driver for WINE mm.dll (multimedia system) implementation.
288
289 %description drv-alsa -l pl.UTF-8
290 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
291
292 %prep
293 %setup -q
294 %patch0 -p1
295 %patch1 -p1
296 %patch2 -p1
297 %patch4 -p1
298 %patch5 -p1
299 %patch6 -p1
300 %ifarch %{x8664}
301 %patch7 -p1
302 %endif
303
304 %build
305 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
306 mv -f oic_winlogo_*.png %{name}.png
307
308 %{__autoconf}
309 %{__autoheader}
310 %configure \
311 %ifarch %{x8664}
312         --enable-win64 \
313 %endif
314         --with-alsa%{!?with_alsa:=no} \
315         --with-capi%{!?with_capi:=no} \
316         --with-cms \
317         --with-coreaudio \
318         --with-cups%{!?with_cups:=no} \
319         --with-curses \
320         --with-dbus \
321         --with-fontconfig \
322         --with-freetype \
323         --with-gphoto \
324         --with-glu \
325         --with-gnutls \
326         --with-gsm \
327         %{__with_without gstreamer} \
328         %{__with_without hal} \
329         --with-jpeg \
330         --with-ldap%{!?with_ldap:=no} \
331         --with-mpg123 \
332         --with%{!?with_netapi:out}-netapi \
333         --with-openal \
334         --with-opencl \
335         --with-opengl \
336         --with-openssl \
337         --with-osmesa \
338         --with-oss \
339         --with-png \
340         --with-pthread \
341         --with%{!?with_sane:out}-sane \
342         --with-tiff \
343         --with-v4l \
344         --with-xcomposite \
345         --with-xcursor \
346         --with-xinerama \
347         --with-xinput \
348         --with-xinput2 \
349         --with-xml \
350         --with-xrandr \
351         --with-xrender \
352         --with-xshape \
353         --with-xshm \
354         --with-xslt \
355         --with-xxf86vm \
356         --with-x \
357         --with-zlib
358 %{__make} depend
359 %{__make}
360
361 %install
362 rm -rf $RPM_BUILD_ROOT
363 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
364 %{__make} install \
365         DESTDIR=$RPM_BUILD_ROOT
366
367 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
368 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
369
370 install -d \
371         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
372         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
373         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
374         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
375         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
376
377 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
378 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
379 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
380
381 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
382 [mci]
383 cdaudio=mcicda.drv
384 sequencer=mciseq.drv
385 waveaudio=mciwave.drv
386 avivideo=mciavi.drv
387 videodisc=mcipionr.drv
388 vcr=mciviscd.drv
389 MPEGVideo=mciqtz.drv
390 EOF
391
392 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
393
394 dir=$(pwd)
395 > files.so
396 > files.programs
397 cd $RPM_BUILD_ROOT%{_libdir}/wine
398 for f in *.so; do
399         case $f in
400         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
401                 ;;
402         *)
403                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
404         esac
405 done
406 cd -
407
408 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
409 for p in $programs; do
410         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
411         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
412         echo "%{_mandir}/man1/$p.1*" >> files.programs
413         grep -v "$p\.exe\.so$" files.so > files.so.
414         mv -f files.so. files.so
415 done
416
417 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
418         mv "$dir" "${dir%.UTF-8}"
419 done
420
421 %ifarch %{x8664}
422 for langdir in "" de/ fr/ pl/ ; do
423 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
424 done
425 %endif
426
427 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
428 %ifnarch %{x8664}
429 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
430 %else
431 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
432 %endif
433
434 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
435 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
436 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
437
438 %clean
439 rm -rf $RPM_BUILD_ROOT
440
441 %post
442 /sbin/ldconfig
443 %update_desktop_database
444
445 %postun -p /sbin/ldconfig
446
447 %triggerpostun -- wine < 1:0.9.12-1.9
448 rm -f /var/lock/subsys/wine
449 if [ -x /sbin/chkconfig ]; then
450         /sbin/chkconfig --del wine
451 fi
452
453 %files -f files.so
454 %defattr(644,root,root,755)
455 %doc README AUTHORS ANNOUNCE
456 %lang(de) %doc documentation/README.de
457 %lang(es) %doc documentation/README.es
458 %lang(fr) %doc documentation/README.fr
459 %lang(hu) %doc documentation/README.hu
460 %lang(it) %doc documentation/README.it
461 %lang(ko) %doc documentation/README.ko
462 %lang(nb) %doc documentation/README.no
463 %lang(pt) %doc documentation/README.pt
464 %lang(pt_BR) %doc documentation/README.pt_br
465 %lang(ru) %doc documentation/README.ru
466 %lang(sv) %doc documentation/README.sv
467 %lang(tr) %doc documentation/README.tr
468 %attr(755,root,root) %{_bindir}/msiexec
469 %ifnarch %{x8664}
470 %attr(755,root,root) %{_bindir}/wine
471 %else
472 %attr(755,root,root) %{_bindir}/wine64
473 %endif
474 %attr(755,root,root) %{_bindir}/wineboot
475 %attr(755,root,root) %{_bindir}/winedbg
476 %attr(755,root,root) %{_bindir}/winecfg
477 %ifnarch %{x8664}
478 %attr(755,root,root) %{_bindir}/wine-preloader
479 %else
480 %attr(755,root,root) %{_bindir}/wine64-preloader
481 %endif
482 %attr(755,root,root) %{_bindir}/wineserver
483 %attr(755,root,root) %{_libdir}/*.so*
484 %dir %{_libdir}/wine
485 %dir %{_libdir}/wine/fakedlls
486 %{_libdir}/wine/fakedlls/*.acm
487 %{_libdir}/wine/fakedlls/*.cpl
488 %{_libdir}/wine/fakedlls/*.dll
489 %ifarch %{ix86}
490 %{_libdir}/wine/fakedlls/*.dll16
491 %endif
492 %{_libdir}/wine/fakedlls/*.drv
493 %ifarch %{ix86}
494 %{_libdir}/wine/fakedlls/*.drv16
495 %endif
496 %{_libdir}/wine/fakedlls/*.ds
497 %{_libdir}/wine/fakedlls/*.exe
498 %ifarch %{ix86}
499 %{_libdir}/wine/fakedlls/*.exe16
500 %{_libdir}/wine/fakedlls/*.mod16
501 %endif
502 %{_libdir}/wine/fakedlls/*.ocx
503 %{_libdir}/wine/fakedlls/*.sys
504 %{_libdir}/wine/fakedlls/*.tlb
505 %ifarch %{ix86}
506 %{_libdir}/wine/fakedlls/*.vxd
507 %endif
508 %ifnarch %{x8664}
509 %{_mandir}/man1/wine.1*
510 %lang(de) %{_mandir}/de/man1/wine.1*
511 %lang(fr) %{_mandir}/fr/man1/wine.1*
512 %lang(pl) %{_mandir}/pl/man1/wine.1*
513 %else
514 %{_mandir}/man1/wine64.1*
515 %lang(de) %{_mandir}/de/man1/wine64.1*
516 %lang(fr) %{_mandir}/fr/man1/wine64.1*
517 %lang(pl) %{_mandir}/pl/man1/wine64.1*
518 %endif
519 %{_mandir}/man1/msiexec.1*
520 %{_mandir}/man1/wineboot.1*
521 %{_mandir}/man1/winecfg.1*
522 %{_mandir}/man1/winedbg.1*
523 %{_mandir}/man1/wineserver.1*
524 %lang(de) %{_mandir}/de/man1/wineserver.1*
525 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
526 %{_winedir}
527 %{_desktopdir}/wine.desktop
528 %{_desktopdir}/wine-uninstaller.desktop
529 %{_pixmapsdir}/%{name}.png
530
531 %files programs -f files.programs
532 %defattr(644,root,root,755)
533
534 %files devel
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_bindir}/sfnt2fon
537 %attr(755,root,root) %{_bindir}/function_grep.pl
538 %attr(755,root,root) %{_bindir}/widl
539 %attr(755,root,root) %{_bindir}/winebuild
540 %attr(755,root,root) %{_bindir}/winedump
541 %attr(755,root,root) %{_bindir}/wineg++
542 %attr(755,root,root) %{_bindir}/winegcc
543 %attr(755,root,root) %{_bindir}/winemaker
544 %attr(755,root,root) %{_bindir}/winecpp
545 %attr(755,root,root) %{_bindir}/wmc
546 %attr(755,root,root) %{_bindir}/wrc
547 %{_libdir}/wine/lib*.def
548 # no shared variants, so not separated
549 %{_libdir}/wine/lib*.def.a
550 %{_libdir}/wine/libadsiid.a
551 %{_libdir}/wine/libdx*.a
552 %{_libdir}/wine/libstrmbase.a
553 %{_libdir}/wine/libstrmiids.a
554 %{_libdir}/wine/libuuid.a
555 %{_libdir}/wine/libwinecrt0.a
556 %{_includedir}/wine
557 %{_mandir}/man1/widl.1*
558 %{_mandir}/man1/winebuild.1*
559 %{_mandir}/man1/winecpp.1*
560 %{_mandir}/man1/winedump.1*
561 %{_mandir}/man1/winegcc.1*
562 %{_mandir}/man1/wineg++.1*
563 %{_mandir}/man1/winemaker.1*
564 %lang(de) %{_mandir}/de/man1/winemaker.1*
565 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
566 %{_mandir}/man1/wmc.1*
567 %{_mandir}/man1/wrc.1*
568 %{_aclocaldir}/*.m4
569
570 %files dll-capi
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
573
574 %files dll-d3d
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
577 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
578 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
579
580 %files dll-gl
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
583 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
584
585 %if %{with sane}
586 %files dll-twain
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
589 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
590 %endif
591
592 %if %{with ldap}
593 %files dll-ldap
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
596 %endif
597
598 %if %{with alsa}
599 %files drv-alsa
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
602 %endif
603
604 # additional dependencies in *.so not separated (yet?) from main package
605 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
606 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.073389 seconds and 4 git commands to generate.