]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- ensure proper libpng at runtime (does this need lib64 qualifier?)
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 7%bcond_without ldap # don't build LDAP DLL
16e36f25 8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 9#
546bbb82 10# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
11# libcrypto,libssl (wininet.dll)
12# libcups (winspool.dll.so,wineps.dll.so)
13# libcurses/libncurses (wineconsole program)
14# libfontconfig (gdi32.dll.so)
15# libfreetype (wineps.dll.so,gdi32.dll.so)
16# libGL (x11drv.dll.so,ddraw.dll.so)
e7acaf22 17# libX11, libXext, libXi, libXrender (x11drv.dll.so)
db80a28e 18# libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
546bbb82 19# thus requires rebuild after change of any of the above.
db80a28e 20
beafc810 21%define gecko_ver 1.4
698e86e7 22Summary: Program that lets you launch Win applications
93e41e44
ER
23Summary(es.UTF-8): Ejecuta programas Windows en Linux
24Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
25Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 26Name: wine
beafc810
MM
27Version: 1.4
28Release: 1
46114a9a 29Epoch: 1
528c1138 30License: LGPL
5c4ec57b 31Group: Applications/Emulators
beafc810
MM
32Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
33# Source0-md5: 6594ab86a4b1fb2c09dadfb4ea7fc4af
34Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
35# Source1-md5: 700aaa08724be1992cffed7b87e79a44
36Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
37# Source2-md5: 7b4811f667fd01d300fdff68420a9c72
38Source3: %{name}-uninstaller.desktop
b68a79ec 39Patch0: %{name}-fontcache.patch
a0ff0658 40Patch1: %{name}-makedep.patch
a4a10255 41Patch2: %{name}-ncurses.patch
8b4bf701 42Patch4: %{name}-disable-valgrind.patch
5312a936 43Patch5: %{name}-ca_certificates.patch
84474518 44Patch6: %{name}-manpaths.patch
45Patch7: desktop.patch
1b3d8891 46URL: http://www.winehq.org/
0aac4f59 47BuildRequires: OpenAL-devel >= 1.1
489ca66c 48BuildRequires: OpenGL-GLU-devel
6547534c
KK
49%{?with_alsa:BuildRequires: alsa-lib-devel}
50%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
51BuildRequires: autoconf
52BuildRequires: automake
d3c41437 53BuildRequires: bison
beafc810 54%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 55%{?with_cups:BuildRequires: cups-devel}
f88a3451 56BuildRequires: docbook-dtd31-sgml
57BuildRequires: docbook-utils
5fc34681 58BuildRequires: flex
16e36f25 59BuildRequires: fontconfig-devel
22432818 60BuildRequires: fontforge
5fc34681 61BuildRequires: freetype-devel >= 2.0.5
beafc810 62BuildRequires: gettext-devel
734deeec 63BuildRequires: giflib-devel
c57a98fe 64BuildRequires: gnutls-devel
beafc810 65%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel}
887fffcf 66BuildRequires: icoutils
beb8121e 67BuildRequires: lcms-devel
beb8121e 68BuildRequires: libgphoto2-devel
d0d61ce7 69BuildRequires: libgsm-devel
c504380e 70BuildRequires: libjpeg-devel
2341e633 71BuildRequires: libmpg123-devel >= 1.5.0
1e160e6e 72BuildRequires: libtool
0aac4f59 73BuildRequires: libv4l-devel
fbb1220c 74BuildRequires: libxslt-devel
8a1d358f 75BuildRequires: ncurses-devel
16e36f25 76# db2* failed previously - probably openjade or opensp bug
db80a28e 77BuildRequires: libpng-devel >= 1.5
16e36f25 78BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 79%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 80BuildRequires: opensp >= 1:1.5.1
2c81f5eb 81BuildRequires: openssl-devel >= 0.9.7d
beb8121e 82BuildRequires: pkgconfig
beafc810 83BuildRequires: prelink
5715e1d1 84%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 85BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 86#BuildRequires: valgrind
beb8121e 87BuildRequires: xorg-lib-libXcomposite-devel
88BuildRequires: xorg-lib-libXcursor-devel
c66c3406 89BuildRequires: xorg-lib-libXi-devel
beb8121e 90BuildRequires: xorg-lib-libXinerama-devel
c66c3406 91BuildRequires: xorg-lib-libXmu-devel
beb8121e 92BuildRequires: xorg-lib-libXrandr-devel
c66c3406 93BuildRequires: xorg-lib-libXrender-devel
94BuildRequires: xorg-lib-libXxf86dga-devel
95BuildRequires: xorg-lib-libXxf86vm-devel
a2f68044 96Requires: libfreetype.so.6
db80a28e 97Requires: libpng15.so.15
8df63af6 98Requires(post): /sbin/ldconfig
ae42c99e 99Suggests: binfmt-detector
be70b824 100Suggests: ca-certificates
beafc810 101Suggests: cabextract
a2f68044 102Conflicts: ca-certificates < 20080809-4
b3d3861d 103# for printing needs lpr
104Suggests: cups-clients
f96e197b 105# for winelauncher
3bddfbf2 106Suggests: xorg-app-xmessage
f96e197b 107# for ntlm_auth
14e95129 108Suggests: samba-common >= 1:3.0.25
52b6007b
JB
109# link to wine/ntdll.dll.so, without any SONAME
110Provides: libntdll.dll.so
7212da21 111Obsoletes: wine-doc-pdf
93b34e12 112Obsoletes: wine-drv-arts
beafc810
MM
113Obsoletes: wine-drv-jack
114Obsoletes: wine-drv-nas
f829f028 115ExclusiveArch: %{ix86} %{x8664}
206eed29 116ExcludeArch: i386
0403821a 117BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 118
e8f81a0a 119%define _noautoreqdep libGL.so.1 libGLU.so.1
120%define no_install_post_strip 1
121
e8f81a0a 122%define _winedir %{_datadir}/%{name}
6731627f 123
65c325f6 124%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 125
344ce2c2 126%undefine debuginfocflags
127
5c4ec57b 128%description
6731627f 129Wine is a program which allows running Microsoft Windows programs
a519bc4f 130(including DOS, Windows 3.x and Win32 executables) on Unix. It
131consists of a program loader which loads and executes a Microsoft
132Windows binary, and a library that implements Windows API calls using
133their Unix or X11 equivalents. The library may also be used for
134porting Win32 code into native Unix executables.
5c4ec57b 135
c967e47d 136%description -l es.UTF-8
f33a1517 137Ejecuta programas Windows en Linux.
138
c967e47d
JR
139%description -l pl.UTF-8
140Wine jest programem dzięki któremu można uruchamiać programy napisane
141dla Microsoft Windows pod systemami uniksowymi. Składa się on z
142loadera, który pozwala wczytywać i uruchamiać programy w formacie
143Microsoft Windows, oraz z biblioteki, która implementuje API Windows
144przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
145także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 146
c967e47d
JR
147%description -l pt_BR.UTF-8
148O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 149Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 150binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 151chamadas da API para as equivalentes Unix/X11.
152
5c4ec57b 153%package devel
7a050f82 154Summary: Wine - header files
93e41e44
ER
155Summary(es.UTF-8): Biblioteca de desarrollo de wine
156Summary(pl.UTF-8): Wine - pliki nagłowkowe
157Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 158Group: Development/Libraries
46114a9a 159Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 160
5c4ec57b 161%description devel
162Wine - header files.
163
c967e47d 164%description devel -l es.UTF-8
f33a1517 165Biblioteca de desarrollo de wine.
166
c967e47d
JR
167%description devel -l pl.UTF-8
168Wine - pliki nagłówkowe.
5c4ec57b 169
c967e47d
JR
170%description devel -l pt_BR.UTF-8
171Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 172WINE.
173
e8f81a0a 174%package programs
175Summary: Wine - programs
93e41e44 176Summary(pl.UTF-8): Wine - programy
e8f81a0a 177Group: Applications
46114a9a 178Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 179
180%description programs
0a7c5d50 181Wine - programs.
e8f81a0a 182
c967e47d 183%description programs -l pl.UTF-8
0a7c5d50 184Wine - programy.
e8f81a0a 185
beafc810
MM
186%package dll-capi
187Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
188Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
189Group: Applications/Emulators
190Requires: %{name} = %{epoch}:%{version}-%{release}
191
192%description dll-capi
193CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
194
195%description dll-capi -l pl.UTF-8
196Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
197OpenGL).
198
16e36f25
JB
199%package dll-d3d
200Summary: Direct3D implementation DLLs for Wine
93e41e44 201Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 202Group: Applications/Emulators
46114a9a 203Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
204Requires: OpenGL
205
206%description dll-d3d
207Direct3D implementation DLLs for Wine (through OpenGL).
208
c967e47d
JR
209%description dll-d3d -l pl.UTF-8
210Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
211
212%package dll-gl
213Summary: OpenGL implementation DLLs for Wine
93e41e44 214Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 215Group: Applications/Emulators
46114a9a 216Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
217Requires: OpenGL
218
219%description dll-gl
220OpenGL implementation DLLs for Wine.
221
c967e47d
JR
222%description dll-gl -l pl.UTF-8
223Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
224
225%package dll-twain
226Summary: TWAIN implementation DLL for Wine
93e41e44 227Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 228Group: Applications/Emulators
46114a9a 229Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
230
231%description dll-twain
232TWAIN implementation DLL for Wine (through SANE).
233
c967e47d
JR
234%description dll-twain -l pl.UTF-8
235Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 236
9d6715c4 237%package dll-ldap
db80a28e 238Summary: Win32 LDAP API DLL for Wine
9d6715c4
ER
239Group: Applications/Emulators
240Requires: %{name} = %{epoch}:%{version}-%{release}
241
242%description dll-ldap
243Lightweight Directory Access Protocol Library.
244
16e36f25
JB
245%package drv-alsa
246Summary: ALSA driver for WINE mm.dll implementation
93e41e44 247Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 248Group: Applications/Emulators
46114a9a 249Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
250
251%description drv-alsa
252ALSA driver for WINE mm.dll (multimedia system) implementation.
253
c967e47d
JR
254%description drv-alsa -l pl.UTF-8
255Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 256
5c4ec57b 257%prep
db80a28e 258%setup -q
2fbbb535 259%patch0 -p1
260%patch1 -p1
ab25825d 261%patch2 -p1
8b4bf701 262%patch4 -p1
5312a936 263%patch5 -p1
3bfef0cd 264%patch6 -p1
aa3806d3 265%patch7 -p1
591d55ba 266
5c4ec57b 267%build
887fffcf
ER
268icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
269mv -f oic_winlogo_*.png %{name}.png
270
2fbbb535 271%{__autoconf}
103d8328 272%{__autoheader}
9d6a128d 273%configure \
f829f028
AM
274%ifarch %{x8664}
275 --enable-win64 \
276%endif
c504380e 277 --with%{!?with_alsa:out}-alsa \
beafc810 278 --with%{!?with_capi:out}-capi \
beb8121e 279 --with-cms \
d0d61ce7 280 --with-coreaudio \
c504380e 281 --with%{!?with_cups:out}-cups \
c504380e 282 --with-curses \
c504380e 283 --with-fontconfig \
284 --with-freetype \
285 --with-glu \
d0d61ce7 286 --with-gnutls \
beb8121e 287 --with-gphoto \
d0d61ce7 288 --with-gsm \
beafc810 289 --with%{!?with_gstreamer:out}-gstreamer \
c504380e 290 --with-jpeg \
9d6715c4 291 --with%{!?with_ldap:out}-ldap \
d0d61ce7 292 --with-mpg123 \
c504380e 293 --with-opengl \
294 --with-openssl \
295 --with-oss \
296 --with-png \
d0d61ce7 297 --with-pthread \
c504380e 298 --with%{!?with_sane:out}-sane \
beb8121e 299 --with-xcomposite \
300 --with-xcursor \
301 --with-xinerama \
302 --with-xinput \
c504380e 303 --with-xml \
beb8121e 304 --with-xrandr \
c504380e 305 --with-xrender \
306 --with-xshape \
307 --with-xshm \
308 --with-xslt \
beb8121e 309 --with-xxf86vm \
698e86e7 310 --with-x
05eb066b 311%{__make} depend
4aafdd81 312%{__make}
e8f81a0a 313
5c4ec57b 314%install
315rm -rf $RPM_BUILD_ROOT
ffb676e0 316install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
317%{__make} install \
318 DESTDIR=$RPM_BUILD_ROOT
319
887fffcf
ER
320install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
321cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 322
2a437456 323install -d \
65c325f6 324 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
325 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 326 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
327 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
328 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
329
a91c2692 330touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
331touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
332touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
333
76055aa1 334cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 335[mci]
336cdaudio=mcicda.drv
337sequencer=mciseq.drv
338waveaudio=mciwave.drv
339avivideo=mciavi.drv
340videodisc=mcipionr.drv
341vcr=mciviscd.drv
342MPEGVideo=mciqtz.drv
5c4ec57b 343EOF
344
e8f81a0a 345%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
346echo "Strip executable binaries and shared object files."
347filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
348elfexelist=`echo $filelist | xargs -r file | \
349 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
350elfsharedlist=`echo $filelist | xargs -r file | \
351 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
352if [ -n "$elfexelist" ]; then \
353 strip -R .note -R .comment $elfexelist
354fi
355if [ -n "$elfsharedlist" ]; then
65c325f6 356 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 357fi
e8f81a0a 358%endif
f1f3af79 359
80496098 360# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 361
887fffcf
ER
362dir=$(pwd)
363> files.so
364> files.programs
55a96819 365cd $RPM_BUILD_ROOT%{_libdir}/wine
366for f in *.so; do
16e36f25 367 case $f in
beafc810 368 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wldap32.dll.so)
887fffcf
ER
369 ;;
370 *)
371 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 372 esac
55a96819 373done
374cd -
887fffcf
ER
375
376programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 377for p in $programs; do
8d493411 378 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
379 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 380 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 381 grep -v "$p\.exe\.so$" files.so > files.so.
382 mv -f files.so. files.so
55a96819 383done
55a96819 384
f7357f09 385install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 386%ifnarch %{x8664}
db80a28e 387cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 388%else
db80a28e 389cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 390%endif
f7357f09 391
887fffcf 392install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
393cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
394cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 395
5c4ec57b 396%clean
397rm -rf $RPM_BUILD_ROOT
398
8df63af6 399%post
db80a28e 400/sbin/ldconfig
8df63af6
ER
401%update_desktop_database
402
f1f3af79
JB
403%postun -p /sbin/ldconfig
404
d142aa07 405%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 406rm -f /var/lock/subsys/wine
d142aa07
JB
407if [ -x /sbin/chkconfig ]; then
408 /sbin/chkconfig --del wine
409fi
410
55a96819 411%files -f files.so
5c4ec57b 412%defattr(644,root,root,755)
64ef6fe1 413%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
12b1296e 414%lang(de) %doc documentation/README.de
415%lang(es) %doc documentation/README.es
416%lang(fr) %doc documentation/README.fr
0aac4f59 417%lang(hu) %doc documentation/README.hu
12b1296e 418%lang(it) %doc documentation/README.it
7b9e958b 419%lang(ko) %doc documentation/README.ko
58a0e5f4 420%lang(nb) %doc documentation/README.no
12b1296e 421%lang(pt) %doc documentation/README.pt
74de5921 422%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
423%lang(ru) %doc documentation/README.ru
424%lang(sv) %doc documentation/README.sv
425%lang(tr) %doc documentation/README.tr
82432451 426%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
427%ifnarch %{x8664}
428%attr(755,root,root) %{_bindir}/wine
429%else
430%attr(755,root,root) %{_bindir}/wine64
431%endif
d479f953 432%attr(755,root,root) %{_bindir}/wineboot
55a96819 433%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 434%attr(755,root,root) %{_bindir}/winecfg
beafc810 435%ifnarch %{x8664}
f829f028 436%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
437%else
438%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 439%endif
beafc810 440%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 441%attr(755,root,root) %{_libdir}/*.so*
861238d3 442%dir %{_libdir}/wine
61e39970 443%dir %{_libdir}/wine/fakedlls
444%{_libdir}/wine/fakedlls/*.acm
445%{_libdir}/wine/fakedlls/*.cpl
446%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
447%ifarch %{ix86}
448%{_libdir}/wine/fakedlls/*.dll16
449%endif
61e39970 450%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
451%ifarch %{ix86}
452%{_libdir}/wine/fakedlls/*.drv16
453%endif
61e39970 454%{_libdir}/wine/fakedlls/*.ds
455%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
456%ifarch %{ix86}
457%{_libdir}/wine/fakedlls/*.exe16
458%{_libdir}/wine/fakedlls/*.mod16
459%endif
61e39970 460%{_libdir}/wine/fakedlls/*.ocx
461%{_libdir}/wine/fakedlls/*.sys
462%{_libdir}/wine/fakedlls/*.tlb
f829f028 463%ifarch %{ix86}
61e39970 464%{_libdir}/wine/fakedlls/*.vxd
f829f028 465%endif
b86f1c34 466%{_mandir}/man1/wine.1*
beafc810
MM
467%lang(de) %{_mandir}/de/man1/wine*.1*
468%lang(fr) %{_mandir}/fr/man1/wine*.1*
469%lang(pl) %{_mandir}/pl/man1/wine*.1*
da274952
AG
470%{_mandir}/man1/msiexec.1*
471%{_mandir}/man1/wineboot.1*
472%{_mandir}/man1/winecfg.1*
72ede285 473%{_mandir}/man1/winedbg.1*
b86f1c34 474%{_mandir}/man1/wineserver.1*
a91c2692 475%{_winedir}
a6c536e0 476%{_desktopdir}/wine.desktop
76055aa1 477%{_desktopdir}/wine-uninstaller.desktop
887fffcf 478%{_pixmapsdir}/%{name}.png
5c4ec57b 479
55a96819 480%files programs -f files.programs
e8f81a0a 481%defattr(644,root,root,755)
e8f81a0a 482
5c4ec57b 483%files devel
484%defattr(644,root,root,755)
d479f953 485%attr(755,root,root) %{_bindir}/fnt2bdf
486%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 487%attr(755,root,root) %{_bindir}/widl
55a96819 488%attr(755,root,root) %{_bindir}/winebuild
55a96819 489%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 490%attr(755,root,root) %{_bindir}/wineg++
d479f953 491%attr(755,root,root) %{_bindir}/winegcc
492%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 493%attr(755,root,root) %{_bindir}/winecpp
55a96819 494%attr(755,root,root) %{_bindir}/wmc
d479f953 495%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
496%{_libdir}/wine/lib*.def
497# no shared variants, so not separated
498%{_libdir}/wine/lib*.def.a
b93e474e 499%{_libdir}/wine/libadsiid.a
7265d9f2 500%{_libdir}/wine/libdx*.a
beafc810 501%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
502%{_libdir}/wine/libstrmiids.a
503%{_libdir}/wine/libuuid.a
504%{_libdir}/wine/libwinecrt0.a
5c4ec57b 505%{_includedir}/wine
34f03014 506%{_mandir}/man1/widl.1*
0aac4f59 507%{_mandir}/man1/winebuild.1*
da274952 508%{_mandir}/man1/winecpp.1*
34f03014 509%{_mandir}/man1/winedump.1*
bff06719 510%{_mandir}/man1/winegcc.1*
5ec7e550 511%{_mandir}/man1/wineg++.1*
34f03014 512%{_mandir}/man1/winemaker.1*
0aac4f59 513%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 514%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
515%{_mandir}/man1/wmc.1*
516%{_mandir}/man1/wrc.1*
2b5050a8 517%{_aclocaldir}/*.m4
f18f723c 518
beafc810
MM
519%files dll-capi
520%defattr(644,root,root,755)
521%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
522
16e36f25
JB
523%files dll-d3d
524%defattr(644,root,root,755)
525%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
526%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
527%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
528
529%files dll-gl
530%defattr(644,root,root,755)
531%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
532%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
533
534%if %{with sane}
535%files dll-twain
536%defattr(644,root,root,755)
b08b16bf 537%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 538%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
539%endif
540
9d6715c4
ER
541%if %{with ldap}
542%files dll-ldap
543%defattr(644,root,root,755)
544%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
545%endif
546
16e36f25
JB
547%if %{with alsa}
548%files drv-alsa
549%defattr(644,root,root,755)
550%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
551%endif
552
16e36f25
JB
553# additional dependencies in *.so not separated (yet?) from main package
554# ddraw.dll.so,x11drv.dll.so depend on X11 libs
555# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
556# ttydrv.dll.so depends on ncurses
This page took 0.187854 seconds and 4 git commands to generate.