]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- updated to 0.9.45
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
0d46bf62 9# NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10# As a workaroound use `wineconsole --backend=user cmd' (works fine)
4da609fa 11# ref: http://bugs.winehq.org/show_bug.cgi?id=8069
0d46bf62 12#
546bbb82 13# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
14# libcrypto,libssl (wininet.dll)
15# libcups (winspool.dll.so,wineps.dll.so)
16# libcurses/libncurses (wineconsole program)
17# libfontconfig (gdi32.dll.so)
18# libfreetype (wineps.dll.so,gdi32.dll.so)
19# libGL (x11drv.dll.so,ddraw.dll.so)
20# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 21# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 22# thus requires rebuild after change of any of the above.
931f130b
JB
23#
24# JACK requires ALSA
c226320b 25%if %{without alsa}
931f130b
JB
26%undefine with_jack
27%endif
698e86e7 28Summary: Program that lets you launch Win applications
93e41e44
ER
29Summary(es.UTF-8): Ejecuta programas Windows en Linux
30Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
31Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 32Name: wine
145e5ccc 33Version: 0.9.45
96a957f0 34Release: 1
46114a9a 35Epoch: 1
528c1138 36License: LGPL
5c4ec57b 37Group: Applications/Emulators
46114a9a 38Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
145e5ccc 39# Source0-md5: feecc3ccb4639b672d8446154a4fb700
b68a79ec 40Patch0: %{name}-fontcache.patch
a0ff0658 41Patch1: %{name}-makedep.patch
a4a10255 42Patch2: %{name}-ncurses.patch
dc0316fb 43Patch3: %{name}-bug9177_workaround.patch
1803184e 44#PatchX: %{name}-dga.patch
1b3d8891 45URL: http://www.winehq.org/
489ca66c 46BuildRequires: OpenGL-GLU-devel
6547534c
KK
47%{?with_alsa:BuildRequires: alsa-lib-devel}
48%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
49BuildRequires: autoconf
50BuildRequires: automake
d3c41437 51BuildRequires: bison
5715e1d1 52%{?with_cups:BuildRequires: cups-devel}
f88a3451 53BuildRequires: docbook-dtd31-sgml
54BuildRequires: docbook-utils
5fc34681 55BuildRequires: flex
16e36f25 56BuildRequires: fontconfig-devel
22432818 57BuildRequires: fontforge
5fc34681 58BuildRequires: freetype-devel >= 2.0.5
734deeec 59BuildRequires: giflib-devel
931f130b 60%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 61BuildRequires: libjpeg-devel
1e160e6e 62BuildRequires: libtool
931f130b 63%{?with_nas:BuildRequires: nas-devel}
8a1d358f 64BuildRequires: ncurses-devel
16e36f25
JB
65# db2* failed previously - probably openjade or opensp bug
66BuildRequires: openjade >= 1:1.3.3-0.pre1
67BuildRequires: opensp >= 1:1.5.1
2c81f5eb 68BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 69%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 70BuildRequires: valgrind
c66c3406 71BuildRequires: xorg-lib-libXi-devel
72BuildRequires: xorg-lib-libXmu-devel
73BuildRequires: xorg-lib-libXrender-devel
74BuildRequires: xorg-lib-libXxf86dga-devel
75BuildRequires: xorg-lib-libXxf86vm-devel
a88e781b 76#Suggests: binfmt-detector
52b6007b
JB
77# link to wine/ntdll.dll.so, without any SONAME
78Provides: libntdll.dll.so
7212da21 79Obsoletes: wine-doc-pdf
93b34e12 80Obsoletes: wine-drv-arts
d9590b9e 81ExclusiveArch: %{ix86}
206eed29 82ExcludeArch: i386
0403821a 83BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 84
e8f81a0a 85%define _noautoreqdep libGL.so.1 libGLU.so.1
86%define no_install_post_strip 1
87
e8f81a0a 88%define _winedir %{_datadir}/%{name}
6731627f 89
65c325f6 90%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 91
344ce2c2 92%undefine debuginfocflags
93
5c4ec57b 94%description
6731627f 95Wine is a program which allows running Microsoft Windows programs
a519bc4f 96(including DOS, Windows 3.x and Win32 executables) on Unix. It
97consists of a program loader which loads and executes a Microsoft
98Windows binary, and a library that implements Windows API calls using
99their Unix or X11 equivalents. The library may also be used for
100porting Win32 code into native Unix executables.
5c4ec57b 101
c967e47d 102%description -l es.UTF-8
f33a1517 103Ejecuta programas Windows en Linux.
104
c967e47d
JR
105%description -l pl.UTF-8
106Wine jest programem dzięki któremu można uruchamiać programy napisane
107dla Microsoft Windows pod systemami uniksowymi. Składa się on z
108loadera, który pozwala wczytywać i uruchamiać programy w formacie
109Microsoft Windows, oraz z biblioteki, która implementuje API Windows
110przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
111także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 112
c967e47d
JR
113%description -l pt_BR.UTF-8
114O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 115Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 116binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 117chamadas da API para as equivalentes Unix/X11.
118
5c4ec57b 119%package devel
7a050f82 120Summary: Wine - header files
93e41e44
ER
121Summary(es.UTF-8): Biblioteca de desarrollo de wine
122Summary(pl.UTF-8): Wine - pliki nagłowkowe
123Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 124Group: Development/Libraries
46114a9a 125Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 126
5c4ec57b 127%description devel
128Wine - header files.
129
c967e47d 130%description devel -l es.UTF-8
f33a1517 131Biblioteca de desarrollo de wine.
132
c967e47d
JR
133%description devel -l pl.UTF-8
134Wine - pliki nagłówkowe.
5c4ec57b 135
c967e47d
JR
136%description devel -l pt_BR.UTF-8
137Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 138WINE.
139
e8f81a0a 140%package programs
141Summary: Wine - programs
93e41e44 142Summary(pl.UTF-8): Wine - programy
e8f81a0a 143Group: Applications
46114a9a 144Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 145
146%description programs
0a7c5d50 147Wine - programs.
e8f81a0a 148
c967e47d 149%description programs -l pl.UTF-8
0a7c5d50 150Wine - programy.
e8f81a0a 151
16e36f25
JB
152%package dll-d3d
153Summary: Direct3D implementation DLLs for Wine
93e41e44 154Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 155Group: Applications/Emulators
46114a9a 156Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
157Requires: OpenGL
158
159%description dll-d3d
160Direct3D implementation DLLs for Wine (through OpenGL).
161
c967e47d
JR
162%description dll-d3d -l pl.UTF-8
163Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
164
165%package dll-gl
166Summary: OpenGL implementation DLLs for Wine
93e41e44 167Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 168Group: Applications/Emulators
46114a9a 169Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
170Requires: OpenGL
171
172%description dll-gl
173OpenGL implementation DLLs for Wine.
174
c967e47d
JR
175%description dll-gl -l pl.UTF-8
176Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
177
178%package dll-twain
179Summary: TWAIN implementation DLL for Wine
93e41e44 180Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 181Group: Applications/Emulators
46114a9a 182Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
183
184%description dll-twain
185TWAIN implementation DLL for Wine (through SANE).
186
c967e47d
JR
187%description dll-twain -l pl.UTF-8
188Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
189
190%package drv-alsa
191Summary: ALSA driver for WINE mm.dll implementation
93e41e44 192Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 193Group: Applications/Emulators
46114a9a 194Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
195
196%description drv-alsa
197ALSA driver for WINE mm.dll (multimedia system) implementation.
198
c967e47d
JR
199%description drv-alsa -l pl.UTF-8
200Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 201
16e36f25
JB
202%package drv-jack
203Summary: JACK driver for WINE mm.dll implementation
93e41e44 204Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 205Group: Applications/Emulators
46114a9a 206Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
207Requires: jack-audio-connection-kit
208# dlopened by SONAME detected at build time
42c123f0 209%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
210
211%description drv-jack
212JACK driver for WINE mm.dll (multimedia system) implementation.
213
c967e47d
JR
214%description drv-jack -l pl.UTF-8
215Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 216Wine.
16e36f25
JB
217
218%package drv-nas
219Summary: NAS driver for WINE mm.dll implementation
93e41e44 220Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 221Group: Applications/Emulators
46114a9a 222Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
223
224%description drv-nas
225NAS driver for WINE mm.dll (multimedia system) implementation.
226
c967e47d
JR
227%description drv-nas -l pl.UTF-8
228Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 229
5c4ec57b 230%prep
231%setup -q
2fbbb535 232%patch0 -p1
233%patch1 -p1
ab25825d 234%patch2 -p1
dc0316fb 235%patch3 -p1
591d55ba 236
237# turn off compilation of some tools
a6c536e0 238sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
239#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 240
241%build
2fbbb535 242%{__autoconf}
103d8328 243%{__autoheader}
9d6a128d 244%configure \
2d927a35 245 %{!?debug:--disable-debug} \
246 %{!?debug:--disable-trace} \
8a1d358f 247 --enable-curses \
c40010b9 248 --enable-opengl \
698e86e7 249 --with-x
05eb066b 250%{__make} depend
4aafdd81 251%{__make}
e8f81a0a 252%{__make} -C programs
a393647c 253#%{__make} -C programs/regapi
e8f81a0a 254
5c4ec57b 255%install
256rm -rf $RPM_BUILD_ROOT
ffb676e0 257install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 258
c7af491d
JB
259%{__make} install \
260 DESTDIR=$RPM_BUILD_ROOT
261
262%{__make} -C programs install \
263 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 264
6a79cc08 265install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 266
0b87866b 267install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
268#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
269
2a437456 270install -d \
65c325f6 271 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
272 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 273 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
274 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
275 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
276
a91c2692 277touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
278touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
279touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
280
281cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
282[mci]
283cdaudio=mcicda.drv
284sequencer=mciseq.drv
285waveaudio=mciwave.drv
286avivideo=mciavi.drv
287videodisc=mcipionr.drv
288vcr=mciviscd.drv
289MPEGVideo=mciqtz.drv
5c4ec57b 290EOF
291
e8f81a0a 292%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
293echo "Strip executable binaries and shared object files."
294filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
295elfexelist=`echo $filelist | xargs -r file | \
296 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
297elfsharedlist=`echo $filelist | xargs -r file | \
298 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
299if [ -n "$elfexelist" ]; then \
300 strip -R .note -R .comment $elfexelist
301fi
302if [ -n "$elfsharedlist" ]; then
65c325f6 303 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 304fi
e8f81a0a 305%endif
f1f3af79 306
80496098 307# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 308
c257af95 309programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 310
8d493411 311BZZZ=`pwd`
312rm -f files.so; touch files.so
313rm -f files.programs; touch files.programs
55a96819 314cd $RPM_BUILD_ROOT%{_libdir}/wine
315for f in *.so; do
16e36f25 316 case $f in
ce2cb51b 317 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 318 ;;
319 *)
320 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 321 esac
55a96819 322done
323cd -
2f6853f9 324for p in $programs; do
8d493411 325 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
326 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
327 grep -v "$p\.exe\.so$" files.so > files.so.
328 mv -f files.so. files.so
55a96819 329done
55a96819 330
5c4ec57b 331%clean
332rm -rf $RPM_BUILD_ROOT
333
d142aa07 334%post -p /sbin/ldconfig
f1f3af79
JB
335%postun -p /sbin/ldconfig
336
d142aa07 337%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 338rm -f /var/lock/subsys/wine
d142aa07
JB
339if [ -x /sbin/chkconfig ]; then
340 /sbin/chkconfig --del wine
341fi
342
55a96819 343%files -f files.so
5c4ec57b 344%defattr(644,root,root,755)
12057076 345%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 346%lang(de) %doc documentation/README.de
347%lang(es) %doc documentation/README.es
348%lang(fr) %doc documentation/README.fr
349%lang(it) %doc documentation/README.it
7b9e958b 350%lang(ko) %doc documentation/README.ko
58a0e5f4 351%lang(nb) %doc documentation/README.no
12b1296e 352%lang(pt) %doc documentation/README.pt
74de5921 353%lang(pt_BR) %doc documentation/README.pt_br
82432451 354%attr(755,root,root) %{_bindir}/msiexec
591d55ba 355%attr(755,root,root) %{_bindir}/wine
d479f953 356%attr(755,root,root) %{_bindir}/wineboot
34f03014 357%attr(755,root,root) %{_bindir}/winebrowser
d479f953 358%attr(755,root,root) %{_bindir}/winecfg
55a96819 359%attr(755,root,root) %{_bindir}/winedbg
5c36538d 360%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 361%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 362%attr(755,root,root) %{_bindir}/wineprefixcreate
363%attr(755,root,root) %{_bindir}/wine-preloader
364%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 365%attr(755,root,root) %{_bindir}/wineserver
591d55ba 366%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 367%attr(755,root,root) %{_libdir}/*.so*
861238d3 368%dir %{_libdir}/wine
489ca66c 369%{_libdir}/wine/*.dll16
370%{_libdir}/wine/*.drv16
371%{_libdir}/wine/*.exe16
b86f1c34 372%{_mandir}/man1/wine.1*
72ede285 373%{_mandir}/man1/winedbg.1*
b86f1c34
JB
374%{_mandir}/man1/wineprefixcreate.1*
375%{_mandir}/man1/wineserver.1*
a91c2692 376%{_winedir}
a6c536e0 377%{_desktopdir}/wine.desktop
5c4ec57b 378
55a96819 379%files programs -f files.programs
e8f81a0a 380%defattr(644,root,root,755)
e8f81a0a 381
5c4ec57b 382%files devel
383%defattr(644,root,root,755)
d479f953 384%attr(755,root,root) %{_bindir}/fnt2bdf
385%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 386%attr(755,root,root) %{_bindir}/widl
55a96819 387%attr(755,root,root) %{_bindir}/winebuild
55a96819 388%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 389%attr(755,root,root) %{_bindir}/wineg++
d479f953 390%attr(755,root,root) %{_bindir}/winegcc
391%attr(755,root,root) %{_bindir}/winemaker
8593fdc2 392#%attr(755,root,root) %{_bindir}/winewrap
55a96819 393%attr(755,root,root) %{_bindir}/wmc
d479f953 394%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
395%{_libdir}/wine/lib*.def
396# no shared variants, so not separated
397%{_libdir}/wine/lib*.def.a
398%{_libdir}/wine/libdx*.a
399%{_libdir}/wine/libstrmiids.a
400%{_libdir}/wine/libuuid.a
401%{_libdir}/wine/libwinecrt0.a
5c4ec57b 402%{_includedir}/wine
34f03014
JB
403%{_mandir}/man1/widl.1*
404%{_mandir}/man1/winedump.1*
bff06719 405%{_mandir}/man1/winegcc.1*
34f03014
JB
406%{_mandir}/man1/winemaker.1*
407%{_mandir}/man1/winebuild.1*
408%{_mandir}/man1/wmc.1*
409%{_mandir}/man1/wrc.1*
2b5050a8 410%{_aclocaldir}/*.m4
f18f723c 411
16e36f25
JB
412%files dll-d3d
413%defattr(644,root,root,755)
414%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
415%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
416%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
417%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
418
419%files dll-gl
420%defattr(644,root,root,755)
421%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
422%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
423
424%if %{with sane}
425%files dll-twain
426%defattr(644,root,root,755)
b08b16bf 427%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 428%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
429%endif
430
431%if %{with alsa}
432%files drv-alsa
433%defattr(644,root,root,755)
434%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
435%endif
436
16e36f25
JB
437%if %{with jack}
438%files drv-jack
439%defattr(644,root,root,755)
440%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
441%endif
442
443%if %{with nas}
444%files drv-nas
445%defattr(644,root,root,755)
446%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
447%endif
448
449# additional dependencies in *.so not separated (yet?) from main package
450# ddraw.dll.so,x11drv.dll.so depend on X11 libs
451# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
452# ttydrv.dll.so depends on ncurses
This page took 4.055567 seconds and 4 git commands to generate.