]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- S: samba-common for ntlm_auth
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
0d46bf62 9# NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10# As a workaroound use `wineconsole --backend=user cmd' (works fine)
4da609fa 11# ref: http://bugs.winehq.org/show_bug.cgi?id=8069
0d46bf62 12#
546bbb82 13# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
14# libcrypto,libssl (wininet.dll)
15# libcups (winspool.dll.so,wineps.dll.so)
16# libcurses/libncurses (wineconsole program)
17# libfontconfig (gdi32.dll.so)
18# libfreetype (wineps.dll.so,gdi32.dll.so)
19# libGL (x11drv.dll.so,ddraw.dll.so)
20# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 21# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 22# thus requires rebuild after change of any of the above.
931f130b
JB
23#
24# JACK requires ALSA
c226320b 25%if %{without alsa}
931f130b
JB
26%undefine with_jack
27%endif
698e86e7 28Summary: Program that lets you launch Win applications
93e41e44
ER
29Summary(es.UTF-8): Ejecuta programas Windows en Linux
30Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
31Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 32Name: wine
4f8ea62d 33Version: 0.9.60
c6c5abc0 34Release: 1
46114a9a 35Epoch: 1
528c1138 36License: LGPL
5c4ec57b 37Group: Applications/Emulators
13df5964 38Source0: http://dl.sourceforge.net/wine/%{name}-%{version}.tar.bz2
4f8ea62d 39# Source0-md5: 4960869defb2d93daff6fe74da334463
b68a79ec 40Patch0: %{name}-fontcache.patch
a0ff0658 41Patch1: %{name}-makedep.patch
a4a10255 42Patch2: %{name}-ncurses.patch
dc0316fb 43Patch3: %{name}-bug9177_workaround.patch
8b4bf701 44Patch4: %{name}-disable-valgrind.patch
1803184e 45#PatchX: %{name}-dga.patch
1b3d8891 46URL: http://www.winehq.org/
489ca66c 47BuildRequires: OpenGL-GLU-devel
6547534c
KK
48%{?with_alsa:BuildRequires: alsa-lib-devel}
49%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
50BuildRequires: autoconf
51BuildRequires: automake
d3c41437 52BuildRequires: bison
5715e1d1 53%{?with_cups:BuildRequires: cups-devel}
f88a3451 54BuildRequires: docbook-dtd31-sgml
55BuildRequires: docbook-utils
5fc34681 56BuildRequires: flex
16e36f25 57BuildRequires: fontconfig-devel
22432818 58BuildRequires: fontforge
5fc34681 59BuildRequires: freetype-devel >= 2.0.5
734deeec 60BuildRequires: giflib-devel
931f130b 61%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 62BuildRequires: libjpeg-devel
1e160e6e 63BuildRequires: libtool
931f130b 64%{?with_nas:BuildRequires: nas-devel}
8a1d358f 65BuildRequires: ncurses-devel
16e36f25
JB
66# db2* failed previously - probably openjade or opensp bug
67BuildRequires: openjade >= 1:1.3.3-0.pre1
901ee56b 68BuildRequires: openldap-devel >= 2.4.6
16e36f25 69BuildRequires: opensp >= 1:1.5.1
2c81f5eb 70BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 71%{?with_sane:BuildRequires: sane-backends-devel}
8b4bf701 72#BuildRequires: valgrind
c66c3406 73BuildRequires: xorg-lib-libXi-devel
74BuildRequires: xorg-lib-libXmu-devel
75BuildRequires: xorg-lib-libXrender-devel
76BuildRequires: xorg-lib-libXxf86dga-devel
77BuildRequires: xorg-lib-libXxf86vm-devel
ae42c99e 78Suggests: binfmt-detector
f96e197b 79# for winelauncher
3bddfbf2 80Suggests: xorg-app-xmessage
f96e197b
ER
81# for ntlm_auth
82Suggests: samba-common
52b6007b
JB
83# link to wine/ntdll.dll.so, without any SONAME
84Provides: libntdll.dll.so
7212da21 85Obsoletes: wine-doc-pdf
93b34e12 86Obsoletes: wine-drv-arts
d9590b9e 87ExclusiveArch: %{ix86}
206eed29 88ExcludeArch: i386
0403821a 89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 90
e8f81a0a 91%define _noautoreqdep libGL.so.1 libGLU.so.1
92%define no_install_post_strip 1
93
e8f81a0a 94%define _winedir %{_datadir}/%{name}
6731627f 95
65c325f6 96%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 97
344ce2c2 98%undefine debuginfocflags
99
5c4ec57b 100%description
6731627f 101Wine is a program which allows running Microsoft Windows programs
a519bc4f 102(including DOS, Windows 3.x and Win32 executables) on Unix. It
103consists of a program loader which loads and executes a Microsoft
104Windows binary, and a library that implements Windows API calls using
105their Unix or X11 equivalents. The library may also be used for
106porting Win32 code into native Unix executables.
5c4ec57b 107
c967e47d 108%description -l es.UTF-8
f33a1517 109Ejecuta programas Windows en Linux.
110
c967e47d
JR
111%description -l pl.UTF-8
112Wine jest programem dzięki któremu można uruchamiać programy napisane
113dla Microsoft Windows pod systemami uniksowymi. Składa się on z
114loadera, który pozwala wczytywać i uruchamiać programy w formacie
115Microsoft Windows, oraz z biblioteki, która implementuje API Windows
116przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
117także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 118
c967e47d
JR
119%description -l pt_BR.UTF-8
120O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 121Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 122binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 123chamadas da API para as equivalentes Unix/X11.
124
5c4ec57b 125%package devel
7a050f82 126Summary: Wine - header files
93e41e44
ER
127Summary(es.UTF-8): Biblioteca de desarrollo de wine
128Summary(pl.UTF-8): Wine - pliki nagłowkowe
129Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 130Group: Development/Libraries
46114a9a 131Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 132
5c4ec57b 133%description devel
134Wine - header files.
135
c967e47d 136%description devel -l es.UTF-8
f33a1517 137Biblioteca de desarrollo de wine.
138
c967e47d
JR
139%description devel -l pl.UTF-8
140Wine - pliki nagłówkowe.
5c4ec57b 141
c967e47d
JR
142%description devel -l pt_BR.UTF-8
143Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 144WINE.
145
e8f81a0a 146%package programs
147Summary: Wine - programs
93e41e44 148Summary(pl.UTF-8): Wine - programy
e8f81a0a 149Group: Applications
46114a9a 150Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 151
152%description programs
0a7c5d50 153Wine - programs.
e8f81a0a 154
c967e47d 155%description programs -l pl.UTF-8
0a7c5d50 156Wine - programy.
e8f81a0a 157
16e36f25
JB
158%package dll-d3d
159Summary: Direct3D implementation DLLs for Wine
93e41e44 160Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 161Group: Applications/Emulators
46114a9a 162Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
163Requires: OpenGL
164
165%description dll-d3d
166Direct3D implementation DLLs for Wine (through OpenGL).
167
c967e47d
JR
168%description dll-d3d -l pl.UTF-8
169Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
170
171%package dll-gl
172Summary: OpenGL implementation DLLs for Wine
93e41e44 173Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 174Group: Applications/Emulators
46114a9a 175Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
176Requires: OpenGL
177
178%description dll-gl
179OpenGL implementation DLLs for Wine.
180
c967e47d
JR
181%description dll-gl -l pl.UTF-8
182Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
183
184%package dll-twain
185Summary: TWAIN implementation DLL for Wine
93e41e44 186Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 187Group: Applications/Emulators
46114a9a 188Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
189
190%description dll-twain
191TWAIN implementation DLL for Wine (through SANE).
192
c967e47d
JR
193%description dll-twain -l pl.UTF-8
194Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
195
196%package drv-alsa
197Summary: ALSA driver for WINE mm.dll implementation
93e41e44 198Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 199Group: Applications/Emulators
46114a9a 200Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
201
202%description drv-alsa
203ALSA driver for WINE mm.dll (multimedia system) implementation.
204
c967e47d
JR
205%description drv-alsa -l pl.UTF-8
206Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 207
16e36f25
JB
208%package drv-jack
209Summary: JACK driver for WINE mm.dll implementation
93e41e44 210Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 211Group: Applications/Emulators
46114a9a 212Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
213Requires: jack-audio-connection-kit
214# dlopened by SONAME detected at build time
42c123f0 215%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
216
217%description drv-jack
218JACK driver for WINE mm.dll (multimedia system) implementation.
219
c967e47d
JR
220%description drv-jack -l pl.UTF-8
221Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 222Wine.
16e36f25
JB
223
224%package drv-nas
225Summary: NAS driver for WINE mm.dll implementation
93e41e44 226Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 227Group: Applications/Emulators
46114a9a 228Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
229
230%description drv-nas
231NAS driver for WINE mm.dll (multimedia system) implementation.
232
c967e47d
JR
233%description drv-nas -l pl.UTF-8
234Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 235
5c4ec57b 236%prep
237%setup -q
2fbbb535 238%patch0 -p1
239%patch1 -p1
ab25825d 240%patch2 -p1
dc0316fb 241%patch3 -p1
8b4bf701 242%patch4 -p1
591d55ba 243
244# turn off compilation of some tools
a6c536e0 245sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
246#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 247
248%build
2fbbb535 249%{__autoconf}
103d8328 250%{__autoheader}
9d6a128d 251%configure \
2d927a35 252 %{!?debug:--disable-debug} \
253 %{!?debug:--disable-trace} \
8a1d358f 254 --enable-curses \
c40010b9 255 --enable-opengl \
698e86e7 256 --with-x
05eb066b 257%{__make} depend
4aafdd81 258%{__make}
e8f81a0a 259%{__make} -C programs
a393647c 260#%{__make} -C programs/regapi
e8f81a0a 261
5c4ec57b 262%install
263rm -rf $RPM_BUILD_ROOT
ffb676e0 264install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 265
c7af491d
JB
266%{__make} install \
267 DESTDIR=$RPM_BUILD_ROOT
268
269%{__make} -C programs install \
270 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 271
6a79cc08 272install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 273
0b87866b 274install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
275#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
276
2a437456 277install -d \
65c325f6 278 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
279 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 280 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
281 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
282 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
283
a91c2692 284touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
285touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
286touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
287
288cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
289[mci]
290cdaudio=mcicda.drv
291sequencer=mciseq.drv
292waveaudio=mciwave.drv
293avivideo=mciavi.drv
294videodisc=mcipionr.drv
295vcr=mciviscd.drv
296MPEGVideo=mciqtz.drv
5c4ec57b 297EOF
298
e8f81a0a 299%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
300echo "Strip executable binaries and shared object files."
301filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
302elfexelist=`echo $filelist | xargs -r file | \
303 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
304elfsharedlist=`echo $filelist | xargs -r file | \
305 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
306if [ -n "$elfexelist" ]; then \
307 strip -R .note -R .comment $elfexelist
308fi
309if [ -n "$elfsharedlist" ]; then
65c325f6 310 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 311fi
e8f81a0a 312%endif
f1f3af79 313
80496098 314# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 315
c257af95 316programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 317
8d493411 318BZZZ=`pwd`
319rm -f files.so; touch files.so
320rm -f files.programs; touch files.programs
55a96819 321cd $RPM_BUILD_ROOT%{_libdir}/wine
322for f in *.so; do
16e36f25 323 case $f in
ce2cb51b 324 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 325 ;;
326 *)
327 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 328 esac
55a96819 329done
330cd -
2f6853f9 331for p in $programs; do
8d493411 332 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
333 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
334 grep -v "$p\.exe\.so$" files.so > files.so.
335 mv -f files.so. files.so
55a96819 336done
55a96819 337
5c4ec57b 338%clean
339rm -rf $RPM_BUILD_ROOT
340
d142aa07 341%post -p /sbin/ldconfig
f1f3af79
JB
342%postun -p /sbin/ldconfig
343
d142aa07 344%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 345rm -f /var/lock/subsys/wine
d142aa07
JB
346if [ -x /sbin/chkconfig ]; then
347 /sbin/chkconfig --del wine
348fi
349
55a96819 350%files -f files.so
5c4ec57b 351%defattr(644,root,root,755)
12057076 352%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 353%lang(de) %doc documentation/README.de
354%lang(es) %doc documentation/README.es
355%lang(fr) %doc documentation/README.fr
356%lang(it) %doc documentation/README.it
7b9e958b 357%lang(ko) %doc documentation/README.ko
58a0e5f4 358%lang(nb) %doc documentation/README.no
12b1296e 359%lang(pt) %doc documentation/README.pt
74de5921 360%lang(pt_BR) %doc documentation/README.pt_br
82432451 361%attr(755,root,root) %{_bindir}/msiexec
591d55ba 362%attr(755,root,root) %{_bindir}/wine
d479f953 363%attr(755,root,root) %{_bindir}/wineboot
34f03014 364%attr(755,root,root) %{_bindir}/winebrowser
d479f953 365%attr(755,root,root) %{_bindir}/winecfg
55a96819 366%attr(755,root,root) %{_bindir}/winedbg
5c36538d 367%attr(755,root,root) %{_bindir}/wine-kthread
4f8ea62d 368#%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 369%attr(755,root,root) %{_bindir}/wineprefixcreate
370%attr(755,root,root) %{_bindir}/wine-preloader
371%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 372%attr(755,root,root) %{_bindir}/wineserver
591d55ba 373%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 374%attr(755,root,root) %{_libdir}/*.so*
861238d3 375%dir %{_libdir}/wine
489ca66c 376%{_libdir}/wine/*.dll16
377%{_libdir}/wine/*.drv16
378%{_libdir}/wine/*.exe16
b93e474e 379%{_libdir}/wine/*.mod16
b86f1c34 380%{_mandir}/man1/wine.1*
72ede285 381%{_mandir}/man1/winedbg.1*
b86f1c34
JB
382%{_mandir}/man1/wineprefixcreate.1*
383%{_mandir}/man1/wineserver.1*
a91c2692 384%{_winedir}
a6c536e0 385%{_desktopdir}/wine.desktop
5c4ec57b 386
55a96819 387%files programs -f files.programs
e8f81a0a 388%defattr(644,root,root,755)
e8f81a0a 389
5c4ec57b 390%files devel
391%defattr(644,root,root,755)
d479f953 392%attr(755,root,root) %{_bindir}/fnt2bdf
393%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 394%attr(755,root,root) %{_bindir}/widl
55a96819 395%attr(755,root,root) %{_bindir}/winebuild
55a96819 396%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 397%attr(755,root,root) %{_bindir}/wineg++
d479f953 398%attr(755,root,root) %{_bindir}/winegcc
399%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 400%attr(755,root,root) %{_bindir}/winecpp
8593fdc2 401#%attr(755,root,root) %{_bindir}/winewrap
55a96819 402%attr(755,root,root) %{_bindir}/wmc
d479f953 403%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
404%{_libdir}/wine/lib*.def
405# no shared variants, so not separated
406%{_libdir}/wine/lib*.def.a
b93e474e 407%{_libdir}/wine/libadsiid.a
7265d9f2
JB
408%{_libdir}/wine/libdx*.a
409%{_libdir}/wine/libstrmiids.a
410%{_libdir}/wine/libuuid.a
411%{_libdir}/wine/libwinecrt0.a
5c4ec57b 412%{_includedir}/wine
34f03014
JB
413%{_mandir}/man1/widl.1*
414%{_mandir}/man1/winedump.1*
bff06719 415%{_mandir}/man1/winegcc.1*
5ec7e550 416%{_mandir}/man1/wineg++.1*
34f03014
JB
417%{_mandir}/man1/winemaker.1*
418%{_mandir}/man1/winebuild.1*
419%{_mandir}/man1/wmc.1*
420%{_mandir}/man1/wrc.1*
2b5050a8 421%{_aclocaldir}/*.m4
f18f723c 422
16e36f25
JB
423%files dll-d3d
424%defattr(644,root,root,755)
425%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
426%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
427%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
428%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
429
430%files dll-gl
431%defattr(644,root,root,755)
432%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
433%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
434
435%if %{with sane}
436%files dll-twain
437%defattr(644,root,root,755)
b08b16bf 438%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 439%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
440%endif
441
442%if %{with alsa}
443%files drv-alsa
444%defattr(644,root,root,755)
445%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
446%endif
447
16e36f25
JB
448%if %{with jack}
449%files drv-jack
450%defattr(644,root,root,755)
451%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
452%endif
453
454%if %{with nas}
455%files drv-nas
456%defattr(644,root,root,755)
457%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
458%endif
459
460# additional dependencies in *.so not separated (yet?) from main package
461# ddraw.dll.so,x11drv.dll.so depend on X11 libs
462# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
463# ttydrv.dll.so depends on ncurses
This page took 0.252481 seconds and 4 git commands to generate.