]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- up to 0.9.60
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
0d46bf62 9# NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10# As a workaroound use `wineconsole --backend=user cmd' (works fine)
4da609fa 11# ref: http://bugs.winehq.org/show_bug.cgi?id=8069
0d46bf62 12#
546bbb82 13# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
14# libcrypto,libssl (wininet.dll)
15# libcups (winspool.dll.so,wineps.dll.so)
16# libcurses/libncurses (wineconsole program)
17# libfontconfig (gdi32.dll.so)
18# libfreetype (wineps.dll.so,gdi32.dll.so)
19# libGL (x11drv.dll.so,ddraw.dll.so)
20# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 21# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 22# thus requires rebuild after change of any of the above.
931f130b
JB
23#
24# JACK requires ALSA
c226320b 25%if %{without alsa}
931f130b
JB
26%undefine with_jack
27%endif
698e86e7 28Summary: Program that lets you launch Win applications
93e41e44
ER
29Summary(es.UTF-8): Ejecuta programas Windows en Linux
30Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
31Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 32Name: wine
4f8ea62d 33Version: 0.9.60
c6c5abc0 34Release: 1
46114a9a 35Epoch: 1
528c1138 36License: LGPL
5c4ec57b 37Group: Applications/Emulators
13df5964 38Source0: http://dl.sourceforge.net/wine/%{name}-%{version}.tar.bz2
4f8ea62d 39# Source0-md5: 4960869defb2d93daff6fe74da334463
b68a79ec 40Patch0: %{name}-fontcache.patch
a0ff0658 41Patch1: %{name}-makedep.patch
a4a10255 42Patch2: %{name}-ncurses.patch
dc0316fb 43Patch3: %{name}-bug9177_workaround.patch
8b4bf701 44Patch4: %{name}-disable-valgrind.patch
1803184e 45#PatchX: %{name}-dga.patch
1b3d8891 46URL: http://www.winehq.org/
489ca66c 47BuildRequires: OpenGL-GLU-devel
6547534c
KK
48%{?with_alsa:BuildRequires: alsa-lib-devel}
49%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
50BuildRequires: autoconf
51BuildRequires: automake
d3c41437 52BuildRequires: bison
5715e1d1 53%{?with_cups:BuildRequires: cups-devel}
f88a3451 54BuildRequires: docbook-dtd31-sgml
55BuildRequires: docbook-utils
5fc34681 56BuildRequires: flex
16e36f25 57BuildRequires: fontconfig-devel
22432818 58BuildRequires: fontforge
5fc34681 59BuildRequires: freetype-devel >= 2.0.5
734deeec 60BuildRequires: giflib-devel
931f130b 61%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 62BuildRequires: libjpeg-devel
1e160e6e 63BuildRequires: libtool
931f130b 64%{?with_nas:BuildRequires: nas-devel}
8a1d358f 65BuildRequires: ncurses-devel
16e36f25
JB
66# db2* failed previously - probably openjade or opensp bug
67BuildRequires: openjade >= 1:1.3.3-0.pre1
901ee56b 68BuildRequires: openldap-devel >= 2.4.6
16e36f25 69BuildRequires: opensp >= 1:1.5.1
2c81f5eb 70BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 71%{?with_sane:BuildRequires: sane-backends-devel}
8b4bf701 72#BuildRequires: valgrind
c66c3406 73BuildRequires: xorg-lib-libXi-devel
74BuildRequires: xorg-lib-libXmu-devel
75BuildRequires: xorg-lib-libXrender-devel
76BuildRequires: xorg-lib-libXxf86dga-devel
77BuildRequires: xorg-lib-libXxf86vm-devel
ae42c99e 78Suggests: binfmt-detector
3bddfbf2
PG
79# For winelauncher
80Suggests: xorg-app-xmessage
52b6007b
JB
81# link to wine/ntdll.dll.so, without any SONAME
82Provides: libntdll.dll.so
7212da21 83Obsoletes: wine-doc-pdf
93b34e12 84Obsoletes: wine-drv-arts
d9590b9e 85ExclusiveArch: %{ix86}
206eed29 86ExcludeArch: i386
0403821a 87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 88
e8f81a0a 89%define _noautoreqdep libGL.so.1 libGLU.so.1
90%define no_install_post_strip 1
91
e8f81a0a 92%define _winedir %{_datadir}/%{name}
6731627f 93
65c325f6 94%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 95
344ce2c2 96%undefine debuginfocflags
97
5c4ec57b 98%description
6731627f 99Wine is a program which allows running Microsoft Windows programs
a519bc4f 100(including DOS, Windows 3.x and Win32 executables) on Unix. It
101consists of a program loader which loads and executes a Microsoft
102Windows binary, and a library that implements Windows API calls using
103their Unix or X11 equivalents. The library may also be used for
104porting Win32 code into native Unix executables.
5c4ec57b 105
c967e47d 106%description -l es.UTF-8
f33a1517 107Ejecuta programas Windows en Linux.
108
c967e47d
JR
109%description -l pl.UTF-8
110Wine jest programem dzięki któremu można uruchamiać programy napisane
111dla Microsoft Windows pod systemami uniksowymi. Składa się on z
112loadera, który pozwala wczytywać i uruchamiać programy w formacie
113Microsoft Windows, oraz z biblioteki, która implementuje API Windows
114przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
115także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 116
c967e47d
JR
117%description -l pt_BR.UTF-8
118O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 119Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 120binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 121chamadas da API para as equivalentes Unix/X11.
122
5c4ec57b 123%package devel
7a050f82 124Summary: Wine - header files
93e41e44
ER
125Summary(es.UTF-8): Biblioteca de desarrollo de wine
126Summary(pl.UTF-8): Wine - pliki nagłowkowe
127Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 128Group: Development/Libraries
46114a9a 129Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 130
5c4ec57b 131%description devel
132Wine - header files.
133
c967e47d 134%description devel -l es.UTF-8
f33a1517 135Biblioteca de desarrollo de wine.
136
c967e47d
JR
137%description devel -l pl.UTF-8
138Wine - pliki nagłówkowe.
5c4ec57b 139
c967e47d
JR
140%description devel -l pt_BR.UTF-8
141Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 142WINE.
143
e8f81a0a 144%package programs
145Summary: Wine - programs
93e41e44 146Summary(pl.UTF-8): Wine - programy
e8f81a0a 147Group: Applications
46114a9a 148Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 149
150%description programs
0a7c5d50 151Wine - programs.
e8f81a0a 152
c967e47d 153%description programs -l pl.UTF-8
0a7c5d50 154Wine - programy.
e8f81a0a 155
16e36f25
JB
156%package dll-d3d
157Summary: Direct3D implementation DLLs for Wine
93e41e44 158Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 159Group: Applications/Emulators
46114a9a 160Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
161Requires: OpenGL
162
163%description dll-d3d
164Direct3D implementation DLLs for Wine (through OpenGL).
165
c967e47d
JR
166%description dll-d3d -l pl.UTF-8
167Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
168
169%package dll-gl
170Summary: OpenGL implementation DLLs for Wine
93e41e44 171Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 172Group: Applications/Emulators
46114a9a 173Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
174Requires: OpenGL
175
176%description dll-gl
177OpenGL implementation DLLs for Wine.
178
c967e47d
JR
179%description dll-gl -l pl.UTF-8
180Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
181
182%package dll-twain
183Summary: TWAIN implementation DLL for Wine
93e41e44 184Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 185Group: Applications/Emulators
46114a9a 186Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
187
188%description dll-twain
189TWAIN implementation DLL for Wine (through SANE).
190
c967e47d
JR
191%description dll-twain -l pl.UTF-8
192Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
193
194%package drv-alsa
195Summary: ALSA driver for WINE mm.dll implementation
93e41e44 196Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 197Group: Applications/Emulators
46114a9a 198Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
199
200%description drv-alsa
201ALSA driver for WINE mm.dll (multimedia system) implementation.
202
c967e47d
JR
203%description drv-alsa -l pl.UTF-8
204Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 205
16e36f25
JB
206%package drv-jack
207Summary: JACK driver for WINE mm.dll implementation
93e41e44 208Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 209Group: Applications/Emulators
46114a9a 210Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
211Requires: jack-audio-connection-kit
212# dlopened by SONAME detected at build time
42c123f0 213%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
214
215%description drv-jack
216JACK driver for WINE mm.dll (multimedia system) implementation.
217
c967e47d
JR
218%description drv-jack -l pl.UTF-8
219Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 220Wine.
16e36f25
JB
221
222%package drv-nas
223Summary: NAS driver for WINE mm.dll implementation
93e41e44 224Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 225Group: Applications/Emulators
46114a9a 226Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
227
228%description drv-nas
229NAS driver for WINE mm.dll (multimedia system) implementation.
230
c967e47d
JR
231%description drv-nas -l pl.UTF-8
232Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 233
5c4ec57b 234%prep
235%setup -q
2fbbb535 236%patch0 -p1
237%patch1 -p1
ab25825d 238%patch2 -p1
dc0316fb 239%patch3 -p1
8b4bf701 240%patch4 -p1
591d55ba 241
242# turn off compilation of some tools
a6c536e0 243sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
244#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 245
246%build
2fbbb535 247%{__autoconf}
103d8328 248%{__autoheader}
9d6a128d 249%configure \
2d927a35 250 %{!?debug:--disable-debug} \
251 %{!?debug:--disable-trace} \
8a1d358f 252 --enable-curses \
c40010b9 253 --enable-opengl \
698e86e7 254 --with-x
05eb066b 255%{__make} depend
4aafdd81 256%{__make}
e8f81a0a 257%{__make} -C programs
a393647c 258#%{__make} -C programs/regapi
e8f81a0a 259
5c4ec57b 260%install
261rm -rf $RPM_BUILD_ROOT
ffb676e0 262install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 263
c7af491d
JB
264%{__make} install \
265 DESTDIR=$RPM_BUILD_ROOT
266
267%{__make} -C programs install \
268 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 269
6a79cc08 270install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 271
0b87866b 272install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
273#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
274
2a437456 275install -d \
65c325f6 276 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
277 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 278 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
279 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
280 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
281
a91c2692 282touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
283touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
284touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
285
286cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
287[mci]
288cdaudio=mcicda.drv
289sequencer=mciseq.drv
290waveaudio=mciwave.drv
291avivideo=mciavi.drv
292videodisc=mcipionr.drv
293vcr=mciviscd.drv
294MPEGVideo=mciqtz.drv
5c4ec57b 295EOF
296
e8f81a0a 297%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
298echo "Strip executable binaries and shared object files."
299filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
300elfexelist=`echo $filelist | xargs -r file | \
301 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
302elfsharedlist=`echo $filelist | xargs -r file | \
303 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
304if [ -n "$elfexelist" ]; then \
305 strip -R .note -R .comment $elfexelist
306fi
307if [ -n "$elfsharedlist" ]; then
65c325f6 308 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 309fi
e8f81a0a 310%endif
f1f3af79 311
80496098 312# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 313
c257af95 314programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 315
8d493411 316BZZZ=`pwd`
317rm -f files.so; touch files.so
318rm -f files.programs; touch files.programs
55a96819 319cd $RPM_BUILD_ROOT%{_libdir}/wine
320for f in *.so; do
16e36f25 321 case $f in
ce2cb51b 322 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 323 ;;
324 *)
325 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 326 esac
55a96819 327done
328cd -
2f6853f9 329for p in $programs; do
8d493411 330 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
331 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
332 grep -v "$p\.exe\.so$" files.so > files.so.
333 mv -f files.so. files.so
55a96819 334done
55a96819 335
5c4ec57b 336%clean
337rm -rf $RPM_BUILD_ROOT
338
d142aa07 339%post -p /sbin/ldconfig
f1f3af79
JB
340%postun -p /sbin/ldconfig
341
d142aa07 342%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 343rm -f /var/lock/subsys/wine
d142aa07
JB
344if [ -x /sbin/chkconfig ]; then
345 /sbin/chkconfig --del wine
346fi
347
55a96819 348%files -f files.so
5c4ec57b 349%defattr(644,root,root,755)
12057076 350%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 351%lang(de) %doc documentation/README.de
352%lang(es) %doc documentation/README.es
353%lang(fr) %doc documentation/README.fr
354%lang(it) %doc documentation/README.it
7b9e958b 355%lang(ko) %doc documentation/README.ko
58a0e5f4 356%lang(nb) %doc documentation/README.no
12b1296e 357%lang(pt) %doc documentation/README.pt
74de5921 358%lang(pt_BR) %doc documentation/README.pt_br
82432451 359%attr(755,root,root) %{_bindir}/msiexec
591d55ba 360%attr(755,root,root) %{_bindir}/wine
d479f953 361%attr(755,root,root) %{_bindir}/wineboot
34f03014 362%attr(755,root,root) %{_bindir}/winebrowser
d479f953 363%attr(755,root,root) %{_bindir}/winecfg
55a96819 364%attr(755,root,root) %{_bindir}/winedbg
5c36538d 365%attr(755,root,root) %{_bindir}/wine-kthread
4f8ea62d 366#%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 367%attr(755,root,root) %{_bindir}/wineprefixcreate
368%attr(755,root,root) %{_bindir}/wine-preloader
369%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 370%attr(755,root,root) %{_bindir}/wineserver
591d55ba 371%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 372%attr(755,root,root) %{_libdir}/*.so*
861238d3 373%dir %{_libdir}/wine
489ca66c 374%{_libdir}/wine/*.dll16
375%{_libdir}/wine/*.drv16
376%{_libdir}/wine/*.exe16
b93e474e 377%{_libdir}/wine/*.mod16
b86f1c34 378%{_mandir}/man1/wine.1*
72ede285 379%{_mandir}/man1/winedbg.1*
b86f1c34
JB
380%{_mandir}/man1/wineprefixcreate.1*
381%{_mandir}/man1/wineserver.1*
a91c2692 382%{_winedir}
a6c536e0 383%{_desktopdir}/wine.desktop
5c4ec57b 384
55a96819 385%files programs -f files.programs
e8f81a0a 386%defattr(644,root,root,755)
e8f81a0a 387
5c4ec57b 388%files devel
389%defattr(644,root,root,755)
d479f953 390%attr(755,root,root) %{_bindir}/fnt2bdf
391%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 392%attr(755,root,root) %{_bindir}/widl
55a96819 393%attr(755,root,root) %{_bindir}/winebuild
55a96819 394%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 395%attr(755,root,root) %{_bindir}/wineg++
d479f953 396%attr(755,root,root) %{_bindir}/winegcc
397%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 398%attr(755,root,root) %{_bindir}/winecpp
8593fdc2 399#%attr(755,root,root) %{_bindir}/winewrap
55a96819 400%attr(755,root,root) %{_bindir}/wmc
d479f953 401%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
402%{_libdir}/wine/lib*.def
403# no shared variants, so not separated
404%{_libdir}/wine/lib*.def.a
b93e474e 405%{_libdir}/wine/libadsiid.a
7265d9f2
JB
406%{_libdir}/wine/libdx*.a
407%{_libdir}/wine/libstrmiids.a
408%{_libdir}/wine/libuuid.a
409%{_libdir}/wine/libwinecrt0.a
5c4ec57b 410%{_includedir}/wine
34f03014
JB
411%{_mandir}/man1/widl.1*
412%{_mandir}/man1/winedump.1*
bff06719 413%{_mandir}/man1/winegcc.1*
5ec7e550 414%{_mandir}/man1/wineg++.1*
34f03014
JB
415%{_mandir}/man1/winemaker.1*
416%{_mandir}/man1/winebuild.1*
417%{_mandir}/man1/wmc.1*
418%{_mandir}/man1/wrc.1*
2b5050a8 419%{_aclocaldir}/*.m4
f18f723c 420
16e36f25
JB
421%files dll-d3d
422%defattr(644,root,root,755)
423%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
424%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
425%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
426%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
427
428%files dll-gl
429%defattr(644,root,root,755)
430%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
431%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
432
433%if %{with sane}
434%files dll-twain
435%defattr(644,root,root,755)
b08b16bf 436%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 437%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
438%endif
439
440%if %{with alsa}
441%files drv-alsa
442%defattr(644,root,root,755)
443%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
444%endif
445
16e36f25
JB
446%if %{with jack}
447%files drv-jack
448%defattr(644,root,root,755)
449%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
450%endif
451
452%if %{with nas}
453%files drv-nas
454%defattr(644,root,root,755)
455%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
456%endif
457
458# additional dependencies in *.so not separated (yet?) from main package
459# ddraw.dll.so,x11drv.dll.so depend on X11 libs
460# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
461# ttydrv.dll.so depends on ncurses
This page took 0.210258 seconds and 4 git commands to generate.