]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- up to 0.9.51
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
0d46bf62 9# NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10# As a workaroound use `wineconsole --backend=user cmd' (works fine)
4da609fa 11# ref: http://bugs.winehq.org/show_bug.cgi?id=8069
0d46bf62 12#
546bbb82 13# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
14# libcrypto,libssl (wininet.dll)
15# libcups (winspool.dll.so,wineps.dll.so)
16# libcurses/libncurses (wineconsole program)
17# libfontconfig (gdi32.dll.so)
18# libfreetype (wineps.dll.so,gdi32.dll.so)
19# libGL (x11drv.dll.so,ddraw.dll.so)
20# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 21# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 22# thus requires rebuild after change of any of the above.
931f130b
JB
23#
24# JACK requires ALSA
c226320b 25%if %{without alsa}
931f130b
JB
26%undefine with_jack
27%endif
698e86e7 28Summary: Program that lets you launch Win applications
93e41e44
ER
29Summary(es.UTF-8): Ejecuta programas Windows en Linux
30Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
31Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 32Name: wine
e04319f0 33Version: 0.9.51
c6c5abc0 34Release: 1
46114a9a 35Epoch: 1
528c1138 36License: LGPL
5c4ec57b 37Group: Applications/Emulators
46114a9a 38Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
e04319f0 39# Source0-md5: 1cf4fddfe2432f43f8461a0f064d34c5
b68a79ec 40Patch0: %{name}-fontcache.patch
a0ff0658 41Patch1: %{name}-makedep.patch
a4a10255 42Patch2: %{name}-ncurses.patch
dc0316fb 43Patch3: %{name}-bug9177_workaround.patch
1803184e 44#PatchX: %{name}-dga.patch
1b3d8891 45URL: http://www.winehq.org/
489ca66c 46BuildRequires: OpenGL-GLU-devel
6547534c
KK
47%{?with_alsa:BuildRequires: alsa-lib-devel}
48%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
49BuildRequires: autoconf
50BuildRequires: automake
d3c41437 51BuildRequires: bison
5715e1d1 52%{?with_cups:BuildRequires: cups-devel}
f88a3451 53BuildRequires: docbook-dtd31-sgml
54BuildRequires: docbook-utils
5fc34681 55BuildRequires: flex
16e36f25 56BuildRequires: fontconfig-devel
22432818 57BuildRequires: fontforge
5fc34681 58BuildRequires: freetype-devel >= 2.0.5
734deeec 59BuildRequires: giflib-devel
931f130b 60%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 61BuildRequires: libjpeg-devel
1e160e6e 62BuildRequires: libtool
931f130b 63%{?with_nas:BuildRequires: nas-devel}
8a1d358f 64BuildRequires: ncurses-devel
16e36f25
JB
65# db2* failed previously - probably openjade or opensp bug
66BuildRequires: openjade >= 1:1.3.3-0.pre1
901ee56b 67BuildRequires: openldap-devel >= 2.4.6
16e36f25 68BuildRequires: opensp >= 1:1.5.1
2c81f5eb 69BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 70%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 71BuildRequires: valgrind
c66c3406 72BuildRequires: xorg-lib-libXi-devel
73BuildRequires: xorg-lib-libXmu-devel
74BuildRequires: xorg-lib-libXrender-devel
75BuildRequires: xorg-lib-libXxf86dga-devel
76BuildRequires: xorg-lib-libXxf86vm-devel
ae42c99e 77Suggests: binfmt-detector
3bddfbf2
PG
78# For winelauncher
79Suggests: xorg-app-xmessage
52b6007b
JB
80# link to wine/ntdll.dll.so, without any SONAME
81Provides: libntdll.dll.so
7212da21 82Obsoletes: wine-doc-pdf
93b34e12 83Obsoletes: wine-drv-arts
d9590b9e 84ExclusiveArch: %{ix86}
206eed29 85ExcludeArch: i386
0403821a 86BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 87
e8f81a0a 88%define _noautoreqdep libGL.so.1 libGLU.so.1
89%define no_install_post_strip 1
90
e8f81a0a 91%define _winedir %{_datadir}/%{name}
6731627f 92
65c325f6 93%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 94
344ce2c2 95%undefine debuginfocflags
96
5c4ec57b 97%description
6731627f 98Wine is a program which allows running Microsoft Windows programs
a519bc4f 99(including DOS, Windows 3.x and Win32 executables) on Unix. It
100consists of a program loader which loads and executes a Microsoft
101Windows binary, and a library that implements Windows API calls using
102their Unix or X11 equivalents. The library may also be used for
103porting Win32 code into native Unix executables.
5c4ec57b 104
c967e47d 105%description -l es.UTF-8
f33a1517 106Ejecuta programas Windows en Linux.
107
c967e47d
JR
108%description -l pl.UTF-8
109Wine jest programem dzięki któremu można uruchamiać programy napisane
110dla Microsoft Windows pod systemami uniksowymi. Składa się on z
111loadera, który pozwala wczytywać i uruchamiać programy w formacie
112Microsoft Windows, oraz z biblioteki, która implementuje API Windows
113przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
114także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 115
c967e47d
JR
116%description -l pt_BR.UTF-8
117O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 118Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 119binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 120chamadas da API para as equivalentes Unix/X11.
121
5c4ec57b 122%package devel
7a050f82 123Summary: Wine - header files
93e41e44
ER
124Summary(es.UTF-8): Biblioteca de desarrollo de wine
125Summary(pl.UTF-8): Wine - pliki nagłowkowe
126Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 127Group: Development/Libraries
46114a9a 128Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 129
5c4ec57b 130%description devel
131Wine - header files.
132
c967e47d 133%description devel -l es.UTF-8
f33a1517 134Biblioteca de desarrollo de wine.
135
c967e47d
JR
136%description devel -l pl.UTF-8
137Wine - pliki nagłówkowe.
5c4ec57b 138
c967e47d
JR
139%description devel -l pt_BR.UTF-8
140Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 141WINE.
142
e8f81a0a 143%package programs
144Summary: Wine - programs
93e41e44 145Summary(pl.UTF-8): Wine - programy
e8f81a0a 146Group: Applications
46114a9a 147Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 148
149%description programs
0a7c5d50 150Wine - programs.
e8f81a0a 151
c967e47d 152%description programs -l pl.UTF-8
0a7c5d50 153Wine - programy.
e8f81a0a 154
16e36f25
JB
155%package dll-d3d
156Summary: Direct3D implementation DLLs for Wine
93e41e44 157Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 158Group: Applications/Emulators
46114a9a 159Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
160Requires: OpenGL
161
162%description dll-d3d
163Direct3D implementation DLLs for Wine (through OpenGL).
164
c967e47d
JR
165%description dll-d3d -l pl.UTF-8
166Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
167
168%package dll-gl
169Summary: OpenGL implementation DLLs for Wine
93e41e44 170Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 171Group: Applications/Emulators
46114a9a 172Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
173Requires: OpenGL
174
175%description dll-gl
176OpenGL implementation DLLs for Wine.
177
c967e47d
JR
178%description dll-gl -l pl.UTF-8
179Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
180
181%package dll-twain
182Summary: TWAIN implementation DLL for Wine
93e41e44 183Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 184Group: Applications/Emulators
46114a9a 185Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
186
187%description dll-twain
188TWAIN implementation DLL for Wine (through SANE).
189
c967e47d
JR
190%description dll-twain -l pl.UTF-8
191Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
192
193%package drv-alsa
194Summary: ALSA driver for WINE mm.dll implementation
93e41e44 195Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 196Group: Applications/Emulators
46114a9a 197Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
198
199%description drv-alsa
200ALSA driver for WINE mm.dll (multimedia system) implementation.
201
c967e47d
JR
202%description drv-alsa -l pl.UTF-8
203Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 204
16e36f25
JB
205%package drv-jack
206Summary: JACK driver for WINE mm.dll implementation
93e41e44 207Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 208Group: Applications/Emulators
46114a9a 209Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
210Requires: jack-audio-connection-kit
211# dlopened by SONAME detected at build time
42c123f0 212%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
213
214%description drv-jack
215JACK driver for WINE mm.dll (multimedia system) implementation.
216
c967e47d
JR
217%description drv-jack -l pl.UTF-8
218Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 219Wine.
16e36f25
JB
220
221%package drv-nas
222Summary: NAS driver for WINE mm.dll implementation
93e41e44 223Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 224Group: Applications/Emulators
46114a9a 225Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
226
227%description drv-nas
228NAS driver for WINE mm.dll (multimedia system) implementation.
229
c967e47d
JR
230%description drv-nas -l pl.UTF-8
231Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 232
5c4ec57b 233%prep
234%setup -q
2fbbb535 235%patch0 -p1
236%patch1 -p1
ab25825d 237%patch2 -p1
dc0316fb 238%patch3 -p1
591d55ba 239
240# turn off compilation of some tools
a6c536e0 241sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
242#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 243
244%build
2fbbb535 245%{__autoconf}
103d8328 246%{__autoheader}
9d6a128d 247%configure \
2d927a35 248 %{!?debug:--disable-debug} \
249 %{!?debug:--disable-trace} \
8a1d358f 250 --enable-curses \
c40010b9 251 --enable-opengl \
698e86e7 252 --with-x
05eb066b 253%{__make} depend
4aafdd81 254%{__make}
e8f81a0a 255%{__make} -C programs
a393647c 256#%{__make} -C programs/regapi
e8f81a0a 257
5c4ec57b 258%install
259rm -rf $RPM_BUILD_ROOT
ffb676e0 260install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 261
c7af491d
JB
262%{__make} install \
263 DESTDIR=$RPM_BUILD_ROOT
264
265%{__make} -C programs install \
266 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 267
6a79cc08 268install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 269
0b87866b 270install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
271#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
272
2a437456 273install -d \
65c325f6 274 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
275 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 276 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
277 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
278 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
279
a91c2692 280touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
281touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
282touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
283
284cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
285[mci]
286cdaudio=mcicda.drv
287sequencer=mciseq.drv
288waveaudio=mciwave.drv
289avivideo=mciavi.drv
290videodisc=mcipionr.drv
291vcr=mciviscd.drv
292MPEGVideo=mciqtz.drv
5c4ec57b 293EOF
294
e8f81a0a 295%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
296echo "Strip executable binaries and shared object files."
297filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
298elfexelist=`echo $filelist | xargs -r file | \
299 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
300elfsharedlist=`echo $filelist | xargs -r file | \
301 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
302if [ -n "$elfexelist" ]; then \
303 strip -R .note -R .comment $elfexelist
304fi
305if [ -n "$elfsharedlist" ]; then
65c325f6 306 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 307fi
e8f81a0a 308%endif
f1f3af79 309
80496098 310# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 311
c257af95 312programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 313
8d493411 314BZZZ=`pwd`
315rm -f files.so; touch files.so
316rm -f files.programs; touch files.programs
55a96819 317cd $RPM_BUILD_ROOT%{_libdir}/wine
318for f in *.so; do
16e36f25 319 case $f in
ce2cb51b 320 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 321 ;;
322 *)
323 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 324 esac
55a96819 325done
326cd -
2f6853f9 327for p in $programs; do
8d493411 328 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
329 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
330 grep -v "$p\.exe\.so$" files.so > files.so.
331 mv -f files.so. files.so
55a96819 332done
55a96819 333
5c4ec57b 334%clean
335rm -rf $RPM_BUILD_ROOT
336
d142aa07 337%post -p /sbin/ldconfig
f1f3af79
JB
338%postun -p /sbin/ldconfig
339
d142aa07 340%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 341rm -f /var/lock/subsys/wine
d142aa07
JB
342if [ -x /sbin/chkconfig ]; then
343 /sbin/chkconfig --del wine
344fi
345
55a96819 346%files -f files.so
5c4ec57b 347%defattr(644,root,root,755)
12057076 348%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 349%lang(de) %doc documentation/README.de
350%lang(es) %doc documentation/README.es
351%lang(fr) %doc documentation/README.fr
352%lang(it) %doc documentation/README.it
7b9e958b 353%lang(ko) %doc documentation/README.ko
58a0e5f4 354%lang(nb) %doc documentation/README.no
12b1296e 355%lang(pt) %doc documentation/README.pt
74de5921 356%lang(pt_BR) %doc documentation/README.pt_br
82432451 357%attr(755,root,root) %{_bindir}/msiexec
591d55ba 358%attr(755,root,root) %{_bindir}/wine
d479f953 359%attr(755,root,root) %{_bindir}/wineboot
34f03014 360%attr(755,root,root) %{_bindir}/winebrowser
d479f953 361%attr(755,root,root) %{_bindir}/winecfg
55a96819 362%attr(755,root,root) %{_bindir}/winedbg
5c36538d 363%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 364%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 365%attr(755,root,root) %{_bindir}/wineprefixcreate
366%attr(755,root,root) %{_bindir}/wine-preloader
367%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 368%attr(755,root,root) %{_bindir}/wineserver
591d55ba 369%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 370%attr(755,root,root) %{_libdir}/*.so*
861238d3 371%dir %{_libdir}/wine
489ca66c 372%{_libdir}/wine/*.dll16
373%{_libdir}/wine/*.drv16
374%{_libdir}/wine/*.exe16
b86f1c34 375%{_mandir}/man1/wine.1*
72ede285 376%{_mandir}/man1/winedbg.1*
b86f1c34
JB
377%{_mandir}/man1/wineprefixcreate.1*
378%{_mandir}/man1/wineserver.1*
a91c2692 379%{_winedir}
a6c536e0 380%{_desktopdir}/wine.desktop
5c4ec57b 381
55a96819 382%files programs -f files.programs
e8f81a0a 383%defattr(644,root,root,755)
e8f81a0a 384
5c4ec57b 385%files devel
386%defattr(644,root,root,755)
d479f953 387%attr(755,root,root) %{_bindir}/fnt2bdf
388%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 389%attr(755,root,root) %{_bindir}/widl
55a96819 390%attr(755,root,root) %{_bindir}/winebuild
55a96819 391%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 392%attr(755,root,root) %{_bindir}/wineg++
d479f953 393%attr(755,root,root) %{_bindir}/winegcc
394%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 395%attr(755,root,root) %{_bindir}/winecpp
8593fdc2 396#%attr(755,root,root) %{_bindir}/winewrap
55a96819 397%attr(755,root,root) %{_bindir}/wmc
d479f953 398%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
399%{_libdir}/wine/lib*.def
400# no shared variants, so not separated
401%{_libdir}/wine/lib*.def.a
402%{_libdir}/wine/libdx*.a
403%{_libdir}/wine/libstrmiids.a
404%{_libdir}/wine/libuuid.a
405%{_libdir}/wine/libwinecrt0.a
5c4ec57b 406%{_includedir}/wine
34f03014
JB
407%{_mandir}/man1/widl.1*
408%{_mandir}/man1/winedump.1*
bff06719 409%{_mandir}/man1/winegcc.1*
34f03014
JB
410%{_mandir}/man1/winemaker.1*
411%{_mandir}/man1/winebuild.1*
412%{_mandir}/man1/wmc.1*
413%{_mandir}/man1/wrc.1*
2b5050a8 414%{_aclocaldir}/*.m4
f18f723c 415
16e36f25
JB
416%files dll-d3d
417%defattr(644,root,root,755)
418%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
419%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
420%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
421%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
422
423%files dll-gl
424%defattr(644,root,root,755)
425%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
426%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
427
428%if %{with sane}
429%files dll-twain
430%defattr(644,root,root,755)
b08b16bf 431%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 432%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
433%endif
434
435%if %{with alsa}
436%files drv-alsa
437%defattr(644,root,root,755)
438%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
439%endif
440
16e36f25
JB
441%if %{with jack}
442%files drv-jack
443%defattr(644,root,root,755)
444%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
445%endif
446
447%if %{with nas}
448%files drv-nas
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
451%endif
452
453# additional dependencies in *.so not separated (yet?) from main package
454# ddraw.dll.so,x11drv.dll.so depend on X11 libs
455# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
456# ttydrv.dll.so depends on ncurses
This page took 3.774759 seconds and 4 git commands to generate.