]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- obsoletes
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
931f130b 4%bcond_without jack # don't build JACK mm driver
a393647c 5%bcond_without nas # don't build NAS mm driver
16e36f25
JB
6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
7%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 8#
0d46bf62 9# NOTE: wineconsole is a bit broken: try wineconsole cmd to see what will happen
10# As a workaroound use `wineconsole --backend=user cmd' (works fine)
4da609fa 11# ref: http://bugs.winehq.org/show_bug.cgi?id=8069
0d46bf62 12#
546bbb82 13# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
14# libcrypto,libssl (wininet.dll)
15# libcups (winspool.dll.so,wineps.dll.so)
16# libcurses/libncurses (wineconsole program)
17# libfontconfig (gdi32.dll.so)
18# libfreetype (wineps.dll.so,gdi32.dll.so)
19# libGL (x11drv.dll.so,ddraw.dll.so)
20# libjack (winejack.drv.so - explicit dependency in subpackage)
e7acaf22 21# libX11, libXext, libXi, libXrender (x11drv.dll.so)
546bbb82 22# thus requires rebuild after change of any of the above.
931f130b
JB
23#
24# JACK requires ALSA
c226320b 25%if %{without alsa}
931f130b
JB
26%undefine with_jack
27%endif
698e86e7 28Summary: Program that lets you launch Win applications
93e41e44
ER
29Summary(es.UTF-8): Ejecuta programas Windows en Linux
30Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
31Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 32Name: wine
c6c5abc0
RT
33Version: 0.9.49
34Release: 1
46114a9a 35Epoch: 1
528c1138 36License: LGPL
5c4ec57b 37Group: Applications/Emulators
46114a9a 38Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
c6c5abc0 39# Source0-md5: 417912f28e48ddc6c4285a493d070564
b68a79ec 40Patch0: %{name}-fontcache.patch
a0ff0658 41Patch1: %{name}-makedep.patch
a4a10255 42Patch2: %{name}-ncurses.patch
dc0316fb 43Patch3: %{name}-bug9177_workaround.patch
1803184e 44#PatchX: %{name}-dga.patch
1b3d8891 45URL: http://www.winehq.org/
489ca66c 46BuildRequires: OpenGL-GLU-devel
6547534c
KK
47%{?with_alsa:BuildRequires: alsa-lib-devel}
48%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
49BuildRequires: autoconf
50BuildRequires: automake
d3c41437 51BuildRequires: bison
5715e1d1 52%{?with_cups:BuildRequires: cups-devel}
f88a3451 53BuildRequires: docbook-dtd31-sgml
54BuildRequires: docbook-utils
5fc34681 55BuildRequires: flex
16e36f25 56BuildRequires: fontconfig-devel
22432818 57BuildRequires: fontforge
5fc34681 58BuildRequires: freetype-devel >= 2.0.5
734deeec 59BuildRequires: giflib-devel
931f130b 60%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
5fc34681 61BuildRequires: libjpeg-devel
1e160e6e 62BuildRequires: libtool
931f130b 63%{?with_nas:BuildRequires: nas-devel}
8a1d358f 64BuildRequires: ncurses-devel
16e36f25
JB
65# db2* failed previously - probably openjade or opensp bug
66BuildRequires: openjade >= 1:1.3.3-0.pre1
901ee56b 67BuildRequires: openldap-devel >= 2.4.6
16e36f25 68BuildRequires: opensp >= 1:1.5.1
2c81f5eb 69BuildRequires: openssl-devel >= 0.9.7d
5715e1d1 70%{?with_sane:BuildRequires: sane-backends-devel}
452e2226 71BuildRequires: valgrind
c66c3406 72BuildRequires: xorg-lib-libXi-devel
73BuildRequires: xorg-lib-libXmu-devel
74BuildRequires: xorg-lib-libXrender-devel
75BuildRequires: xorg-lib-libXxf86dga-devel
76BuildRequires: xorg-lib-libXxf86vm-devel
ae42c99e 77Suggests: binfmt-detector
52b6007b
JB
78# link to wine/ntdll.dll.so, without any SONAME
79Provides: libntdll.dll.so
7212da21 80Obsoletes: wine-doc-pdf
93b34e12 81Obsoletes: wine-drv-arts
d9590b9e 82ExclusiveArch: %{ix86}
206eed29 83ExcludeArch: i386
0403821a 84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 85
e8f81a0a 86%define _noautoreqdep libGL.so.1 libGLU.so.1
87%define no_install_post_strip 1
88
e8f81a0a 89%define _winedir %{_datadir}/%{name}
6731627f 90
65c325f6 91%define getsoname() %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
16e36f25 92
344ce2c2 93%undefine debuginfocflags
94
5c4ec57b 95%description
6731627f 96Wine is a program which allows running Microsoft Windows programs
a519bc4f 97(including DOS, Windows 3.x and Win32 executables) on Unix. It
98consists of a program loader which loads and executes a Microsoft
99Windows binary, and a library that implements Windows API calls using
100their Unix or X11 equivalents. The library may also be used for
101porting Win32 code into native Unix executables.
5c4ec57b 102
c967e47d 103%description -l es.UTF-8
f33a1517 104Ejecuta programas Windows en Linux.
105
c967e47d
JR
106%description -l pl.UTF-8
107Wine jest programem dzięki któremu można uruchamiać programy napisane
108dla Microsoft Windows pod systemami uniksowymi. Składa się on z
109loadera, który pozwala wczytywać i uruchamiać programy w formacie
110Microsoft Windows, oraz z biblioteki, która implementuje API Windows
111przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
112także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 113
c967e47d
JR
114%description -l pt_BR.UTF-8
115O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 116Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 117binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 118chamadas da API para as equivalentes Unix/X11.
119
5c4ec57b 120%package devel
7a050f82 121Summary: Wine - header files
93e41e44
ER
122Summary(es.UTF-8): Biblioteca de desarrollo de wine
123Summary(pl.UTF-8): Wine - pliki nagłowkowe
124Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 125Group: Development/Libraries
46114a9a 126Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 127
5c4ec57b 128%description devel
129Wine - header files.
130
c967e47d 131%description devel -l es.UTF-8
f33a1517 132Biblioteca de desarrollo de wine.
133
c967e47d
JR
134%description devel -l pl.UTF-8
135Wine - pliki nagłówkowe.
5c4ec57b 136
c967e47d
JR
137%description devel -l pt_BR.UTF-8
138Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 139WINE.
140
e8f81a0a 141%package programs
142Summary: Wine - programs
93e41e44 143Summary(pl.UTF-8): Wine - programy
e8f81a0a 144Group: Applications
46114a9a 145Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 146
147%description programs
0a7c5d50 148Wine - programs.
e8f81a0a 149
c967e47d 150%description programs -l pl.UTF-8
0a7c5d50 151Wine - programy.
e8f81a0a 152
16e36f25
JB
153%package dll-d3d
154Summary: Direct3D implementation DLLs for Wine
93e41e44 155Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 156Group: Applications/Emulators
46114a9a 157Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
158Requires: OpenGL
159
160%description dll-d3d
161Direct3D implementation DLLs for Wine (through OpenGL).
162
c967e47d
JR
163%description dll-d3d -l pl.UTF-8
164Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
165
166%package dll-gl
167Summary: OpenGL implementation DLLs for Wine
93e41e44 168Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 169Group: Applications/Emulators
46114a9a 170Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
171Requires: OpenGL
172
173%description dll-gl
174OpenGL implementation DLLs for Wine.
175
c967e47d
JR
176%description dll-gl -l pl.UTF-8
177Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
178
179%package dll-twain
180Summary: TWAIN implementation DLL for Wine
93e41e44 181Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 182Group: Applications/Emulators
46114a9a 183Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
184
185%description dll-twain
186TWAIN implementation DLL for Wine (through SANE).
187
c967e47d
JR
188%description dll-twain -l pl.UTF-8
189Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25
JB
190
191%package drv-alsa
192Summary: ALSA driver for WINE mm.dll implementation
93e41e44 193Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 194Group: Applications/Emulators
46114a9a 195Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
196
197%description drv-alsa
198ALSA driver for WINE mm.dll (multimedia system) implementation.
199
c967e47d
JR
200%description drv-alsa -l pl.UTF-8
201Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 202
16e36f25
JB
203%package drv-jack
204Summary: JACK driver for WINE mm.dll implementation
93e41e44 205Summary(pl.UTF-8): Sterownik JACK-a dla implementacji mm.dll w Wine
16e36f25 206Group: Applications/Emulators
46114a9a 207Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
208Requires: jack-audio-connection-kit
209# dlopened by SONAME detected at build time
42c123f0 210%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
16e36f25
JB
211
212%description drv-jack
213JACK driver for WINE mm.dll (multimedia system) implementation.
214
c967e47d
JR
215%description drv-jack -l pl.UTF-8
216Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
b9f73ce4 217Wine.
16e36f25
JB
218
219%package drv-nas
220Summary: NAS driver for WINE mm.dll implementation
93e41e44 221Summary(pl.UTF-8): Sterownik NAS dla implementacji mm.dll w Wine
16e36f25 222Group: Applications/Emulators
46114a9a 223Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
224
225%description drv-nas
226NAS driver for WINE mm.dll (multimedia system) implementation.
227
c967e47d
JR
228%description drv-nas -l pl.UTF-8
229Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 230
5c4ec57b 231%prep
232%setup -q
2fbbb535 233%patch0 -p1
234%patch1 -p1
ab25825d 235%patch2 -p1
dc0316fb 236%patch3 -p1
591d55ba 237
238# turn off compilation of some tools
a6c536e0 239sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
240#sed -i -e "s|avitools||" programs/Makefile.in
5c4ec57b 241
242%build
2fbbb535 243%{__autoconf}
103d8328 244%{__autoheader}
9d6a128d 245%configure \
2d927a35 246 %{!?debug:--disable-debug} \
247 %{!?debug:--disable-trace} \
8a1d358f 248 --enable-curses \
c40010b9 249 --enable-opengl \
698e86e7 250 --with-x
05eb066b 251%{__make} depend
4aafdd81 252%{__make}
e8f81a0a 253%{__make} -C programs
a393647c 254#%{__make} -C programs/regapi
e8f81a0a 255
5c4ec57b 256%install
257rm -rf $RPM_BUILD_ROOT
ffb676e0 258install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
5c4ec57b 259
c7af491d
JB
260%{__make} install \
261 DESTDIR=$RPM_BUILD_ROOT
262
263%{__make} -C programs install \
264 DESTDIR=$RPM_BUILD_ROOT
e8f81a0a 265
6a79cc08 266install tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
f88a3451 267
0b87866b 268install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
269#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
270
2a437456 271install -d \
65c325f6 272 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
273 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 274 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
275 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
276 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
277
a91c2692 278touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
279touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
280touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
281
282cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
283[mci]
284cdaudio=mcicda.drv
285sequencer=mciseq.drv
286waveaudio=mciwave.drv
287avivideo=mciavi.drv
288videodisc=mcipionr.drv
289vcr=mciviscd.drv
290MPEGVideo=mciqtz.drv
5c4ec57b 291EOF
292
e8f81a0a 293%if %{?debug:0}%{!?debug:1}
f1f3af79
JB
294echo "Strip executable binaries and shared object files."
295filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
296elfexelist=`echo $filelist | xargs -r file | \
297 awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
298elfsharedlist=`echo $filelist | xargs -r file | \
299 awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
300if [ -n "$elfexelist" ]; then \
301 strip -R .note -R .comment $elfexelist
302fi
303if [ -n "$elfsharedlist" ]; then
65c325f6 304 strip --strip-unneeded -R .note -R .comment $elfsharedlist
f1f3af79 305fi
e8f81a0a 306%endif
f1f3af79 307
80496098 308# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 309
c257af95 310programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
0b87866b 311
8d493411 312BZZZ=`pwd`
313rm -f files.so; touch files.so
314rm -f files.programs; touch files.programs
55a96819 315cd $RPM_BUILD_ROOT%{_libdir}/wine
316for f in *.so; do
16e36f25 317 case $f in
ce2cb51b 318 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
a6deb44f 319 ;;
320 *)
321 echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
16e36f25 322 esac
55a96819 323done
324cd -
2f6853f9 325for p in $programs; do
8d493411 326 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
327 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
328 grep -v "$p\.exe\.so$" files.so > files.so.
329 mv -f files.so. files.so
55a96819 330done
55a96819 331
5c4ec57b 332%clean
333rm -rf $RPM_BUILD_ROOT
334
d142aa07 335%post -p /sbin/ldconfig
f1f3af79
JB
336%postun -p /sbin/ldconfig
337
d142aa07 338%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 339rm -f /var/lock/subsys/wine
d142aa07
JB
340if [ -x /sbin/chkconfig ]; then
341 /sbin/chkconfig --del wine
342fi
343
55a96819 344%files -f files.so
5c4ec57b 345%defattr(644,root,root,755)
12057076 346%doc README ChangeLog AUTHORS ANNOUNCE
12b1296e 347%lang(de) %doc documentation/README.de
348%lang(es) %doc documentation/README.es
349%lang(fr) %doc documentation/README.fr
350%lang(it) %doc documentation/README.it
7b9e958b 351%lang(ko) %doc documentation/README.ko
58a0e5f4 352%lang(nb) %doc documentation/README.no
12b1296e 353%lang(pt) %doc documentation/README.pt
74de5921 354%lang(pt_BR) %doc documentation/README.pt_br
82432451 355%attr(755,root,root) %{_bindir}/msiexec
591d55ba 356%attr(755,root,root) %{_bindir}/wine
d479f953 357%attr(755,root,root) %{_bindir}/wineboot
34f03014 358%attr(755,root,root) %{_bindir}/winebrowser
d479f953 359%attr(755,root,root) %{_bindir}/winecfg
55a96819 360%attr(755,root,root) %{_bindir}/winedbg
5c36538d 361%attr(755,root,root) %{_bindir}/wine-kthread
1ae1bca2 362%attr(755,root,root) %{_bindir}/winelauncher
5c36538d 363%attr(755,root,root) %{_bindir}/wineprefixcreate
364%attr(755,root,root) %{_bindir}/wine-preloader
365%attr(755,root,root) %{_bindir}/wine-pthread
591d55ba 366%attr(755,root,root) %{_bindir}/wineserver
591d55ba 367%attr(755,root,root) %{_bindir}/wineshelllink
8a1d358f 368%attr(755,root,root) %{_libdir}/*.so*
861238d3 369%dir %{_libdir}/wine
489ca66c 370%{_libdir}/wine/*.dll16
371%{_libdir}/wine/*.drv16
372%{_libdir}/wine/*.exe16
b86f1c34 373%{_mandir}/man1/wine.1*
72ede285 374%{_mandir}/man1/winedbg.1*
b86f1c34
JB
375%{_mandir}/man1/wineprefixcreate.1*
376%{_mandir}/man1/wineserver.1*
a91c2692 377%{_winedir}
a6c536e0 378%{_desktopdir}/wine.desktop
5c4ec57b 379
55a96819 380%files programs -f files.programs
e8f81a0a 381%defattr(644,root,root,755)
e8f81a0a 382
5c4ec57b 383%files devel
384%defattr(644,root,root,755)
d479f953 385%attr(755,root,root) %{_bindir}/fnt2bdf
386%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 387%attr(755,root,root) %{_bindir}/widl
55a96819 388%attr(755,root,root) %{_bindir}/winebuild
55a96819 389%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 390%attr(755,root,root) %{_bindir}/wineg++
d479f953 391%attr(755,root,root) %{_bindir}/winegcc
392%attr(755,root,root) %{_bindir}/winemaker
8593fdc2 393#%attr(755,root,root) %{_bindir}/winewrap
55a96819 394%attr(755,root,root) %{_bindir}/wmc
d479f953 395%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
396%{_libdir}/wine/lib*.def
397# no shared variants, so not separated
398%{_libdir}/wine/lib*.def.a
399%{_libdir}/wine/libdx*.a
400%{_libdir}/wine/libstrmiids.a
401%{_libdir}/wine/libuuid.a
402%{_libdir}/wine/libwinecrt0.a
5c4ec57b 403%{_includedir}/wine
34f03014
JB
404%{_mandir}/man1/widl.1*
405%{_mandir}/man1/winedump.1*
bff06719 406%{_mandir}/man1/winegcc.1*
34f03014
JB
407%{_mandir}/man1/winemaker.1*
408%{_mandir}/man1/winebuild.1*
409%{_mandir}/man1/wmc.1*
410%{_mandir}/man1/wrc.1*
2b5050a8 411%{_aclocaldir}/*.m4
f18f723c 412
16e36f25
JB
413%files dll-d3d
414%defattr(644,root,root,755)
415%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
416%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
417%attr(755,root,root) %{_libdir}/wine/d3dx8.dll.so
418%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
419
420%files dll-gl
421%defattr(644,root,root,755)
422%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
423%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
424
425%if %{with sane}
426%files dll-twain
427%defattr(644,root,root,755)
b08b16bf 428%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 429%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
430%endif
431
432%if %{with alsa}
433%files drv-alsa
434%defattr(644,root,root,755)
435%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
436%endif
437
16e36f25
JB
438%if %{with jack}
439%files drv-jack
440%defattr(644,root,root,755)
441%attr(755,root,root) %{_libdir}/wine/winejack.drv.so
442%endif
443
444%if %{with nas}
445%files drv-nas
446%defattr(644,root,root,755)
447%attr(755,root,root) %{_libdir}/wine/winenas.drv.so
448%endif
449
450# additional dependencies in *.so not separated (yet?) from main package
451# ddraw.dll.so,x11drv.dll.so depend on X11 libs
452# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
453# ttydrv.dll.so depends on ncurses
This page took 0.136178 seconds and 4 git commands to generate.