]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- ensure proper libpng at runtime (does this need lib64 qualifier?)
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_without  ldap            # don't build LDAP DLL
8 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
9 #
10 # NOTE: wine detects the following SONAMES for dlopen at build time:
11 #   libcrypto,libssl (wininet.dll)
12 #   libcups (winspool.dll.so,wineps.dll.so)
13 #   libcurses/libncurses (wineconsole program)
14 #   libfontconfig (gdi32.dll.so)
15 #   libfreetype (wineps.dll.so,gdi32.dll.so)
16 #   libGL (x11drv.dll.so,ddraw.dll.so)
17 #   libX11, libXext, libXi, libXrender (x11drv.dll.so)
18 #   libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
19 # thus requires rebuild after change of any of the above.
20
21 %define         gecko_ver       1.4
22 Summary:        Program that lets you launch Win applications
23 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
24 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
25 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
26 Name:           wine
27 Version:        1.4
28 Release:        1
29 Epoch:          1
30 License:        LGPL
31 Group:          Applications/Emulators
32 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
33 # Source0-md5:  6594ab86a4b1fb2c09dadfb4ea7fc4af
34 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
35 # Source1-md5:  700aaa08724be1992cffed7b87e79a44
36 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
37 # Source2-md5:  7b4811f667fd01d300fdff68420a9c72
38 Source3:        %{name}-uninstaller.desktop
39 Patch0:         %{name}-fontcache.patch
40 Patch1:         %{name}-makedep.patch
41 Patch2:         %{name}-ncurses.patch
42 Patch4:         %{name}-disable-valgrind.patch
43 Patch5:         %{name}-ca_certificates.patch
44 Patch6:         %{name}-manpaths.patch
45 Patch7:         desktop.patch
46 URL:            http://www.winehq.org/
47 BuildRequires:  OpenAL-devel >= 1.1
48 BuildRequires:  OpenGL-GLU-devel
49 %{?with_alsa:BuildRequires:     alsa-lib-devel}
50 %{?with_arts:BuildRequires:     artsc-devel}
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 BuildRequires:  bison
54 %{?with_capi:BuildRequires:     capi4k-utils-devel}
55 %{?with_cups:BuildRequires:     cups-devel}
56 BuildRequires:  docbook-dtd31-sgml
57 BuildRequires:  docbook-utils
58 BuildRequires:  flex
59 BuildRequires:  fontconfig-devel
60 BuildRequires:  fontforge
61 BuildRequires:  freetype-devel >= 2.0.5
62 BuildRequires:  gettext-devel
63 BuildRequires:  giflib-devel
64 BuildRequires:  gnutls-devel
65 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel}
66 BuildRequires:  icoutils
67 BuildRequires:  lcms-devel
68 BuildRequires:  libgphoto2-devel
69 BuildRequires:  libgsm-devel
70 BuildRequires:  libjpeg-devel
71 BuildRequires:  libmpg123-devel >= 1.5.0
72 BuildRequires:  libtool
73 BuildRequires:  libv4l-devel
74 BuildRequires:  libxslt-devel
75 BuildRequires:  ncurses-devel
76 # db2* failed previously - probably openjade or opensp bug
77 BuildRequires:  libpng-devel >= 1.5
78 BuildRequires:  openjade >= 1:1.3.3-0.pre1
79 %{?with_ldap:BuildRequires:     openldap-devel}
80 BuildRequires:  opensp >= 1:1.5.1
81 BuildRequires:  openssl-devel >= 0.9.7d
82 BuildRequires:  pkgconfig
83 BuildRequires:  prelink
84 %{?with_sane:BuildRequires:     sane-backends-devel}
85 BuildRequires:  unixODBC-devel >= 2.2.12-2
86 #BuildRequires: valgrind
87 BuildRequires:  xorg-lib-libXcomposite-devel
88 BuildRequires:  xorg-lib-libXcursor-devel
89 BuildRequires:  xorg-lib-libXi-devel
90 BuildRequires:  xorg-lib-libXinerama-devel
91 BuildRequires:  xorg-lib-libXmu-devel
92 BuildRequires:  xorg-lib-libXrandr-devel
93 BuildRequires:  xorg-lib-libXrender-devel
94 BuildRequires:  xorg-lib-libXxf86dga-devel
95 BuildRequires:  xorg-lib-libXxf86vm-devel
96 Requires:       libfreetype.so.6
97 Requires:       libpng15.so.15
98 Requires(post): /sbin/ldconfig
99 Suggests:       binfmt-detector
100 Suggests:       ca-certificates
101 Suggests:       cabextract
102 Conflicts:      ca-certificates < 20080809-4
103 # for printing needs lpr
104 Suggests:       cups-clients
105 # for winelauncher
106 Suggests:       xorg-app-xmessage
107 # for ntlm_auth
108 Suggests:       samba-common >= 1:3.0.25
109 # link to wine/ntdll.dll.so, without any SONAME
110 Provides:       libntdll.dll.so
111 Obsoletes:      wine-doc-pdf
112 Obsoletes:      wine-drv-arts
113 Obsoletes:      wine-drv-jack
114 Obsoletes:      wine-drv-nas
115 ExclusiveArch:  %{ix86} %{x8664}
116 ExcludeArch:    i386
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %define         _noautoreqdep           libGL.so.1 libGLU.so.1
120 %define         no_install_post_strip   1
121
122 %define         _winedir                %{_datadir}/%{name}
123
124 %define         getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
125
126 %undefine       debuginfocflags
127
128 %description
129 Wine is a program which allows running Microsoft Windows programs
130 (including DOS, Windows 3.x and Win32 executables) on Unix. It
131 consists of a program loader which loads and executes a Microsoft
132 Windows binary, and a library that implements Windows API calls using
133 their Unix or X11 equivalents. The library may also be used for
134 porting Win32 code into native Unix executables.
135
136 %description -l es.UTF-8
137 Ejecuta programas Windows en Linux.
138
139 %description -l pl.UTF-8
140 Wine jest programem dzięki któremu można uruchamiać programy napisane
141 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
142 loadera, który pozwala wczytywać i uruchamiać programy w formacie
143 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
144 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
145 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
146
147 %description -l pt_BR.UTF-8
148 O Wine é um programa que permite rodar programas MS-Windows no X11.
149 Ele consiste de um carregador de programa, que carrega e executa um
150 binário MS-Windows, e de uma biblioteca de emulação que traduz as
151 chamadas da API para as equivalentes Unix/X11.
152
153 %package devel
154 Summary:        Wine - header files
155 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
156 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
157 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
158 Group:          Development/Libraries
159 Requires:       %{name} = %{epoch}:%{version}-%{release}
160
161 %description devel
162 Wine - header files.
163
164 %description devel -l es.UTF-8
165 Biblioteca de desarrollo de wine.
166
167 %description devel -l pl.UTF-8
168 Wine - pliki nagłówkowe.
169
170 %description devel -l pt_BR.UTF-8
171 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
172 WINE.
173
174 %package programs
175 Summary:        Wine - programs
176 Summary(pl.UTF-8):      Wine - programy
177 Group:          Applications
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179
180 %description programs
181 Wine - programs.
182
183 %description programs -l pl.UTF-8
184 Wine - programy.
185
186 %package dll-capi
187 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
188 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
189 Group:          Applications/Emulators
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191
192 %description dll-capi
193 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
194
195 %description dll-capi -l pl.UTF-8
196 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
197 OpenGL).
198
199 %package dll-d3d
200 Summary:        Direct3D implementation DLLs for Wine
201 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
202 Group:          Applications/Emulators
203 Requires:       %{name} = %{epoch}:%{version}-%{release}
204 Requires:       OpenGL
205
206 %description dll-d3d
207 Direct3D implementation DLLs for Wine (through OpenGL).
208
209 %description dll-d3d -l pl.UTF-8
210 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
211
212 %package dll-gl
213 Summary:        OpenGL implementation DLLs for Wine
214 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
215 Group:          Applications/Emulators
216 Requires:       %{name} = %{epoch}:%{version}-%{release}
217 Requires:       OpenGL
218
219 %description dll-gl
220 OpenGL implementation DLLs for Wine.
221
222 %description dll-gl -l pl.UTF-8
223 Biblioteki DLL z implementacją OpenGL dla Wine.
224
225 %package dll-twain
226 Summary:        TWAIN implementation DLL for Wine
227 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
228 Group:          Applications/Emulators
229 Requires:       %{name} = %{epoch}:%{version}-%{release}
230
231 %description dll-twain
232 TWAIN implementation DLL for Wine (through SANE).
233
234 %description dll-twain -l pl.UTF-8
235 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
236
237 %package dll-ldap
238 Summary:        Win32 LDAP API DLL for Wine
239 Group:          Applications/Emulators
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241
242 %description dll-ldap
243 Lightweight Directory Access Protocol Library.
244
245 %package drv-alsa
246 Summary:        ALSA driver for WINE mm.dll implementation
247 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
248 Group:          Applications/Emulators
249 Requires:       %{name} = %{epoch}:%{version}-%{release}
250
251 %description drv-alsa
252 ALSA driver for WINE mm.dll (multimedia system) implementation.
253
254 %description drv-alsa -l pl.UTF-8
255 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
256
257 %prep
258 %setup -q
259 %patch0 -p1
260 %patch1 -p1
261 %patch2 -p1
262 %patch4 -p1
263 %patch5 -p1
264 %patch6 -p1
265 %patch7 -p1
266
267 %build
268 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
269 mv -f oic_winlogo_*.png %{name}.png
270
271 %{__autoconf}
272 %{__autoheader}
273 %configure \
274 %ifarch %{x8664}
275         --enable-win64 \
276 %endif
277         --with%{!?with_alsa:out}-alsa \
278         --with%{!?with_capi:out}-capi \
279         --with-cms \
280         --with-coreaudio \
281         --with%{!?with_cups:out}-cups \
282         --with-curses \
283         --with-fontconfig \
284         --with-freetype \
285         --with-glu \
286         --with-gnutls \
287         --with-gphoto \
288         --with-gsm \
289         --with%{!?with_gstreamer:out}-gstreamer \
290         --with-jpeg \
291         --with%{!?with_ldap:out}-ldap \
292         --with-mpg123 \
293         --with-opengl \
294         --with-openssl \
295         --with-oss \
296         --with-png \
297         --with-pthread \
298         --with%{!?with_sane:out}-sane \
299         --with-xcomposite \
300         --with-xcursor \
301         --with-xinerama \
302         --with-xinput \
303         --with-xml \
304         --with-xrandr \
305         --with-xrender \
306         --with-xshape \
307         --with-xshm \
308         --with-xslt \
309         --with-xxf86vm \
310         --with-x
311 %{__make} depend
312 %{__make}
313
314 %install
315 rm -rf $RPM_BUILD_ROOT
316 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
317 %{__make} install \
318         DESTDIR=$RPM_BUILD_ROOT
319
320 install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
321 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
322
323 install -d \
324         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
325         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
326         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
327         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
328         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
329
330 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
331 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
332 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
333
334 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
335 [mci]
336 cdaudio=mcicda.drv
337 sequencer=mciseq.drv
338 waveaudio=mciwave.drv
339 avivideo=mciavi.drv
340 videodisc=mcipionr.drv
341 vcr=mciviscd.drv
342 MPEGVideo=mciqtz.drv
343 EOF
344
345 %if %{?debug:0}%{!?debug:1}
346 echo "Strip executable binaries and shared object files."
347 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
348 elfexelist=`echo $filelist | xargs -r file | \
349         awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
350 elfsharedlist=`echo $filelist | xargs -r file | \
351         awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
352 if [ -n "$elfexelist" ]; then \
353         strip -R .note -R .comment $elfexelist
354 fi
355 if [ -n "$elfsharedlist" ]; then
356         strip --strip-unneeded -R .note -R .comment $elfsharedlist
357 fi
358 %endif
359
360 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
361
362 dir=$(pwd)
363 > files.so
364 > files.programs
365 cd $RPM_BUILD_ROOT%{_libdir}/wine
366 for f in *.so; do
367         case $f in
368         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wldap32.dll.so)
369                 ;;
370         *)
371                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
372         esac
373 done
374 cd -
375
376 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
377 for p in $programs; do
378         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
379         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
380         echo "%{_mandir}/man1/$p.1*" >> files.programs
381         grep -v "$p\.exe\.so$" files.so > files.so.
382         mv -f files.so. files.so
383 done
384
385 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
386 %ifnarch %{x8664}
387 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
388 %else
389 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
390 %endif
391
392 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
393 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
394 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %post
400 /sbin/ldconfig
401 %update_desktop_database
402
403 %postun -p /sbin/ldconfig
404
405 %triggerpostun -- wine < 1:0.9.12-1.9
406 rm -f /var/lock/subsys/wine
407 if [ -x /sbin/chkconfig ]; then
408         /sbin/chkconfig --del wine
409 fi
410
411 %files -f files.so
412 %defattr(644,root,root,755)
413 %doc README documentation/ChangeLog* AUTHORS ANNOUNCE
414 %lang(de) %doc documentation/README.de
415 %lang(es) %doc documentation/README.es
416 %lang(fr) %doc documentation/README.fr
417 %lang(hu) %doc documentation/README.hu
418 %lang(it) %doc documentation/README.it
419 %lang(ko) %doc documentation/README.ko
420 %lang(nb) %doc documentation/README.no
421 %lang(pt) %doc documentation/README.pt
422 %lang(pt_BR) %doc documentation/README.pt_br
423 %lang(ru) %doc documentation/README.ru
424 %lang(sv) %doc documentation/README.sv
425 %lang(tr) %doc documentation/README.tr
426 %attr(755,root,root) %{_bindir}/msiexec
427 %ifnarch %{x8664}
428 %attr(755,root,root) %{_bindir}/wine
429 %else
430 %attr(755,root,root) %{_bindir}/wine64
431 %endif
432 %attr(755,root,root) %{_bindir}/wineboot
433 %attr(755,root,root) %{_bindir}/winedbg
434 %attr(755,root,root) %{_bindir}/winecfg
435 %ifnarch %{x8664}
436 %attr(755,root,root) %{_bindir}/wine-preloader
437 %else
438 %attr(755,root,root) %{_bindir}/wine64-preloader
439 %endif
440 %attr(755,root,root) %{_bindir}/wineserver
441 %attr(755,root,root) %{_libdir}/*.so*
442 %dir %{_libdir}/wine
443 %dir %{_libdir}/wine/fakedlls
444 %{_libdir}/wine/fakedlls/*.acm
445 %{_libdir}/wine/fakedlls/*.cpl
446 %{_libdir}/wine/fakedlls/*.dll
447 %ifarch %{ix86}
448 %{_libdir}/wine/fakedlls/*.dll16
449 %endif
450 %{_libdir}/wine/fakedlls/*.drv
451 %ifarch %{ix86}
452 %{_libdir}/wine/fakedlls/*.drv16
453 %endif
454 %{_libdir}/wine/fakedlls/*.ds
455 %{_libdir}/wine/fakedlls/*.exe
456 %ifarch %{ix86}
457 %{_libdir}/wine/fakedlls/*.exe16
458 %{_libdir}/wine/fakedlls/*.mod16
459 %endif
460 %{_libdir}/wine/fakedlls/*.ocx
461 %{_libdir}/wine/fakedlls/*.sys
462 %{_libdir}/wine/fakedlls/*.tlb
463 %ifarch %{ix86}
464 %{_libdir}/wine/fakedlls/*.vxd
465 %endif
466 %{_mandir}/man1/wine.1*
467 %lang(de) %{_mandir}/de/man1/wine*.1*
468 %lang(fr) %{_mandir}/fr/man1/wine*.1*
469 %lang(pl) %{_mandir}/pl/man1/wine*.1*
470 %{_mandir}/man1/msiexec.1*
471 %{_mandir}/man1/wineboot.1*
472 %{_mandir}/man1/winecfg.1*
473 %{_mandir}/man1/winedbg.1*
474 %{_mandir}/man1/wineserver.1*
475 %{_winedir}
476 %{_desktopdir}/wine.desktop
477 %{_desktopdir}/wine-uninstaller.desktop
478 %{_pixmapsdir}/%{name}.png
479
480 %files programs -f files.programs
481 %defattr(644,root,root,755)
482
483 %files devel
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_bindir}/fnt2bdf
486 %attr(755,root,root) %{_bindir}/function_grep.pl
487 %attr(755,root,root) %{_bindir}/widl
488 %attr(755,root,root) %{_bindir}/winebuild
489 %attr(755,root,root) %{_bindir}/winedump
490 %attr(755,root,root) %{_bindir}/wineg++
491 %attr(755,root,root) %{_bindir}/winegcc
492 %attr(755,root,root) %{_bindir}/winemaker
493 %attr(755,root,root) %{_bindir}/winecpp
494 %attr(755,root,root) %{_bindir}/wmc
495 %attr(755,root,root) %{_bindir}/wrc
496 %{_libdir}/wine/lib*.def
497 # no shared variants, so not separated
498 %{_libdir}/wine/lib*.def.a
499 %{_libdir}/wine/libadsiid.a
500 %{_libdir}/wine/libdx*.a
501 %{_libdir}/wine/libstrmbase.a
502 %{_libdir}/wine/libstrmiids.a
503 %{_libdir}/wine/libuuid.a
504 %{_libdir}/wine/libwinecrt0.a
505 %{_includedir}/wine
506 %{_mandir}/man1/widl.1*
507 %{_mandir}/man1/winebuild.1*
508 %{_mandir}/man1/winecpp.1*
509 %{_mandir}/man1/winedump.1*
510 %{_mandir}/man1/winegcc.1*
511 %{_mandir}/man1/wineg++.1*
512 %{_mandir}/man1/winemaker.1*
513 %lang(de) %{_mandir}/de/man1/winemaker.1*
514 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
515 %{_mandir}/man1/wmc.1*
516 %{_mandir}/man1/wrc.1*
517 %{_aclocaldir}/*.m4
518
519 %files dll-capi
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
522
523 %files dll-d3d
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
526 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
527 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
528
529 %files dll-gl
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
532 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
533
534 %if %{with sane}
535 %files dll-twain
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
538 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
539 %endif
540
541 %if %{with ldap}
542 %files dll-ldap
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
545 %endif
546
547 %if %{with alsa}
548 %files drv-alsa
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
551 %endif
552
553 # additional dependencies in *.so not separated (yet?) from main package
554 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
555 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
556 #   ttydrv.dll.so depends on ncurses
This page took 0.070063 seconds and 4 git commands to generate.