]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- updated BRs, disable hal
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
5b49e814
JB
3%bcond_without alsa # ALSA mm driver
4%bcond_without capi # CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # GStreamer filters support
6%bcond_without sane # TWAIN DLL with scanning support (through SANE)
7%bcond_with hal # HAL dynamic device support [deprecated]
8%bcond_without ldap # LDAP DLL
9%bcond_without cups # CUPS printing support in winspool,wineps DLLs
7a30e9d7 10#
546bbb82 11# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
12# libGL (winex11.drv.so)
13# libOSMesa (gdi32.dll.so)
14# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
15# libcapi20 (capi2032.dll.so)
16# libcups (winspool.drv.so)
17# libdbus (mountmgr.sys.so)
16e36f25 18# libfontconfig (gdi32.dll.so)
5b49e814
JB
19# libfreetype (gdi32.dll.so)
20# libgnutls (secur32.dll.so)
21# libhal (mountmgr.sys.so)
22# libjpeg (gphoto2.ds.so windowscodecs.dll.so)
23# libncurses (kernel32.dll.so)
24# libodbc (odbc32.dll.so)
25# libpng (windowscodecs.dll.so)
26# libsane (sane.ds.so)
27# libtiff (windowscodecs.dll.so)
28# libv4l1 (qcap.dll.so)
29# libxslt (msxml3.dll.so)
546bbb82 30# thus requires rebuild after change of any of the above.
db80a28e 31
4ce8abe1
ER
32# library qualifier in rpm generated deps
33%ifarch %{x8664} ia64 ppc64 s390x sparc64
34%define libqual ()(64bit)
35%else
36%define libqual %{nil}
37%endif
38
47bd64d5 39%define gecko_ver 2.21
698e86e7 40Summary: Program that lets you launch Win applications
93e41e44
ER
41Summary(es.UTF-8): Ejecuta programas Windows en Linux
42Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
43Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 44Name: wine
c4aead27
JK
45# 1.6.x – stable
46# 1.7.x – development (DEVEL branch)
55061442
JK
47Version: 1.6.2
48Release: 1
46114a9a 49Epoch: 1
528c1138 50License: LGPL
5c4ec57b 51Group: Applications/Emulators
beafc810 52Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
55061442 53# Source0-md5: 0f6c56f86befe38e219090915f81f48a
beafc810 54Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
47bd64d5 55# Source1-md5: 432eb3a2d05c3f07df67864f53c87c60
beafc810 56Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
47bd64d5 57# Source2-md5: 580bbabde1ec99ba9caa439c2dbca3f6
beafc810 58Source3: %{name}-uninstaller.desktop
55061442 59Patch0: %{name}-gphoto2_bool.patch
a0ff0658 60Patch1: %{name}-makedep.patch
a4a10255 61Patch2: %{name}-ncurses.patch
8b4bf701 62Patch4: %{name}-disable-valgrind.patch
5312a936 63Patch5: %{name}-ca_certificates.patch
84474518 64Patch6: %{name}-manpaths.patch
65Patch7: desktop.patch
f6cf693b 66Patch8: %{name}-wine64_man.patch
1b3d8891 67URL: http://www.winehq.org/
5b49e814 68BuildRequires: Mesa-libOSMesa-devel
0aac4f59 69BuildRequires: OpenAL-devel >= 1.1
5b49e814 70BuildRequires: OpenCL-devel
489ca66c 71BuildRequires: OpenGL-GLU-devel
5b49e814 72BuildRequires: OpenGL-GLX-devel
6547534c
KK
73%{?with_alsa:BuildRequires: alsa-lib-devel}
74%{?with_arts:BuildRequires: artsc-devel}
5b49e814 75BuildRequires: autoconf >= 2.62
c7af491d 76BuildRequires: automake
d3c41437 77BuildRequires: bison
beafc810 78%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 79%{?with_cups:BuildRequires: cups-devel}
5b49e814 80BuildRequires: dbus-devel
f88a3451 81BuildRequires: docbook-dtd31-sgml
82BuildRequires: docbook-utils
5b49e814 83BuildRequires: flex >= 2.5.33
16e36f25 84BuildRequires: fontconfig-devel
22432818 85BuildRequires: fontforge
5fc34681 86BuildRequires: freetype-devel >= 2.0.5
5b49e814 87# for findup used after make install
16b3dd87 88BuildRequires: fslint
5b49e814
JB
89%ifarch %{x8664}
90BuildRequires: gcc >= 6:4.4
91%endif
beafc810 92BuildRequires: gettext-devel
734deeec 93BuildRequires: giflib-devel
c57a98fe 94BuildRequires: gnutls-devel
5b49e814
JB
95%{?with_gstreamer:BuildRequires: gstreamer0.10-devel >= 0.10}
96%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10}
97%{?with_hal:BuildRequires: hal-devel}
98# for icotool used in build
99BuildRequires: icoutils >= 0.29.0
100BuildRequires: lcms2-devel >= 2
beb8121e 101BuildRequires: libgphoto2-devel
d0d61ce7 102BuildRequires: libgsm-devel
c504380e 103BuildRequires: libjpeg-devel
2341e633 104BuildRequires: libmpg123-devel >= 1.5.0
5b49e814
JB
105BuildRequires: libpng-devel >= 1.5
106BuildRequires: libtiff-devel
1e160e6e 107BuildRequires: libtool
0aac4f59 108BuildRequires: libv4l-devel
5b49e814 109BuildRequires: libxml2-devel >= 2.0
fbb1220c 110BuildRequires: libxslt-devel
8a1d358f 111BuildRequires: ncurses-devel
16e36f25
JB
112# db2* failed previously - probably openjade or opensp bug
113BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 114%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 115BuildRequires: opensp >= 1:1.5.1
beb8121e 116BuildRequires: pkgconfig
beafc810 117BuildRequires: prelink
5715e1d1 118%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 119BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 120#BuildRequires: valgrind
5b49e814 121BuildRequires: xorg-lib-libX11-devel
beb8121e 122BuildRequires: xorg-lib-libXcomposite-devel
123BuildRequires: xorg-lib-libXcursor-devel
5b49e814 124BuildRequires: xorg-lib-libXext-devel
c66c3406 125BuildRequires: xorg-lib-libXi-devel
beb8121e 126BuildRequires: xorg-lib-libXinerama-devel
beb8121e 127BuildRequires: xorg-lib-libXrandr-devel
c66c3406 128BuildRequires: xorg-lib-libXrender-devel
c66c3406 129BuildRequires: xorg-lib-libXxf86vm-devel
5b49e814 130BuildRequires: zlib-devel
4ce8abe1 131Requires: libfreetype.so.6%{libqual}
a85c8746 132Requires: libpng16.so.16%{libqual}
8df63af6 133Requires(post): /sbin/ldconfig
ae42c99e 134Suggests: binfmt-detector
be70b824 135Suggests: ca-certificates
beafc810 136Suggests: cabextract
a2f68044 137Conflicts: ca-certificates < 20080809-4
b3d3861d 138# for printing needs lpr
139Suggests: cups-clients
f96e197b 140# for winelauncher
3bddfbf2 141Suggests: xorg-app-xmessage
f96e197b 142# for ntlm_auth
14e95129 143Suggests: samba-common >= 1:3.0.25
52b6007b
JB
144# link to wine/ntdll.dll.so, without any SONAME
145Provides: libntdll.dll.so
7212da21 146Obsoletes: wine-doc-pdf
93b34e12 147Obsoletes: wine-drv-arts
beafc810
MM
148Obsoletes: wine-drv-jack
149Obsoletes: wine-drv-nas
5b49e814 150ExclusiveArch: %{ix86} %{x8664} arm
206eed29 151ExcludeArch: i386
0403821a 152BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 153
e8f81a0a 154%define no_install_post_strip 1
155
e8f81a0a 156%define _winedir %{_datadir}/%{name}
6731627f 157
5c4ec57b 158%description
6731627f 159Wine is a program which allows running Microsoft Windows programs
a519bc4f 160(including DOS, Windows 3.x and Win32 executables) on Unix. It
161consists of a program loader which loads and executes a Microsoft
162Windows binary, and a library that implements Windows API calls using
163their Unix or X11 equivalents. The library may also be used for
164porting Win32 code into native Unix executables.
5c4ec57b 165
c967e47d 166%description -l es.UTF-8
f33a1517 167Ejecuta programas Windows en Linux.
168
c967e47d
JR
169%description -l pl.UTF-8
170Wine jest programem dzięki któremu można uruchamiać programy napisane
171dla Microsoft Windows pod systemami uniksowymi. Składa się on z
172loadera, który pozwala wczytywać i uruchamiać programy w formacie
173Microsoft Windows, oraz z biblioteki, która implementuje API Windows
174przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
175także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 176
c967e47d
JR
177%description -l pt_BR.UTF-8
178O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 179Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 180binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 181chamadas da API para as equivalentes Unix/X11.
182
5c4ec57b 183%package devel
7a050f82 184Summary: Wine - header files
93e41e44
ER
185Summary(es.UTF-8): Biblioteca de desarrollo de wine
186Summary(pl.UTF-8): Wine - pliki nagłowkowe
187Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 188Group: Development/Libraries
46114a9a 189Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 190
5c4ec57b 191%description devel
192Wine - header files.
193
c967e47d 194%description devel -l es.UTF-8
f33a1517 195Biblioteca de desarrollo de wine.
196
c967e47d
JR
197%description devel -l pl.UTF-8
198Wine - pliki nagłówkowe.
5c4ec57b 199
c967e47d
JR
200%description devel -l pt_BR.UTF-8
201Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 202WINE.
203
e8f81a0a 204%package programs
205Summary: Wine - programs
93e41e44 206Summary(pl.UTF-8): Wine - programy
e8f81a0a 207Group: Applications
46114a9a 208Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 209
210%description programs
0a7c5d50 211Wine - programs.
e8f81a0a 212
c967e47d 213%description programs -l pl.UTF-8
0a7c5d50 214Wine - programy.
e8f81a0a 215
beafc810
MM
216%package dll-capi
217Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
218Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
219Group: Applications/Emulators
220Requires: %{name} = %{epoch}:%{version}-%{release}
221
222%description dll-capi
223CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
224
225%description dll-capi -l pl.UTF-8
226Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
227OpenGL).
228
16e36f25
JB
229%package dll-d3d
230Summary: Direct3D implementation DLLs for Wine
93e41e44 231Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 232Group: Applications/Emulators
46114a9a 233Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
234Requires: OpenGL
235
236%description dll-d3d
237Direct3D implementation DLLs for Wine (through OpenGL).
238
c967e47d
JR
239%description dll-d3d -l pl.UTF-8
240Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
241
242%package dll-gl
243Summary: OpenGL implementation DLLs for Wine
93e41e44 244Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 245Group: Applications/Emulators
46114a9a 246Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
247Requires: OpenGL
248
249%description dll-gl
250OpenGL implementation DLLs for Wine.
251
c967e47d
JR
252%description dll-gl -l pl.UTF-8
253Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
254
255%package dll-twain
256Summary: TWAIN implementation DLL for Wine
93e41e44 257Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 258Group: Applications/Emulators
46114a9a 259Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
260
261%description dll-twain
262TWAIN implementation DLL for Wine (through SANE).
263
c967e47d
JR
264%description dll-twain -l pl.UTF-8
265Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 266
9d6715c4 267%package dll-ldap
db80a28e 268Summary: Win32 LDAP API DLL for Wine
9d6715c4
ER
269Group: Applications/Emulators
270Requires: %{name} = %{epoch}:%{version}-%{release}
271
272%description dll-ldap
273Lightweight Directory Access Protocol Library.
274
16e36f25
JB
275%package drv-alsa
276Summary: ALSA driver for WINE mm.dll implementation
93e41e44 277Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 278Group: Applications/Emulators
46114a9a 279Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
280
281%description drv-alsa
282ALSA driver for WINE mm.dll (multimedia system) implementation.
283
c967e47d
JR
284%description drv-alsa -l pl.UTF-8
285Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 286
5c4ec57b 287%prep
db80a28e 288%setup -q
2fbbb535 289%patch0 -p1
290%patch1 -p1
ab25825d 291%patch2 -p1
8b4bf701 292%patch4 -p1
5312a936 293%patch5 -p1
3bfef0cd 294%patch6 -p1
aa3806d3 295%patch7 -p1
f6cf693b
JK
296%ifarch %{x8664}
297%patch8 -p1
298%endif
591d55ba 299
5c4ec57b 300%build
887fffcf
ER
301icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
302mv -f oic_winlogo_*.png %{name}.png
303
2fbbb535 304%{__autoconf}
103d8328 305%{__autoheader}
9d6a128d 306%configure \
f829f028
AM
307%ifarch %{x8664}
308 --enable-win64 \
309%endif
5b49e814
JB
310 --with-alsa%{!?with_alsa:=no} \
311 --with-capi%{!?with_capi:=no} \
beb8121e 312 --with-cms \
d0d61ce7 313 --with-coreaudio \
5b49e814 314 --with-cups%{!?with_cups:=no} \
c504380e 315 --with-curses \
c504380e 316 --with-fontconfig \
317 --with-freetype \
318 --with-glu \
d0d61ce7 319 --with-gnutls \
beb8121e 320 --with-gphoto \
d0d61ce7 321 --with-gsm \
5b49e814
JB
322 --with-gstreamer%{!?with_gstreamer:=no} \
323 --with-hal%{!?with_hal:=no} \
c504380e 324 --with-jpeg \
5b49e814 325 --with-ldap%{!?with_ldap:=no} \
d0d61ce7 326 --with-mpg123 \
c504380e 327 --with-opengl \
c504380e 328 --with-oss \
329 --with-png \
d0d61ce7 330 --with-pthread \
5b49e814 331 --with-sane%{!?with_sane:=no} \
beb8121e 332 --with-xcomposite \
333 --with-xcursor \
334 --with-xinerama \
335 --with-xinput \
c504380e 336 --with-xml \
beb8121e 337 --with-xrandr \
c504380e 338 --with-xrender \
339 --with-xshape \
340 --with-xshm \
341 --with-xslt \
beb8121e 342 --with-xxf86vm \
698e86e7 343 --with-x
05eb066b 344%{__make} depend
4aafdd81 345%{__make}
e8f81a0a 346
5c4ec57b 347%install
348rm -rf $RPM_BUILD_ROOT
ffb676e0 349install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
350%{__make} install \
351 DESTDIR=$RPM_BUILD_ROOT
352
16b3dd87
ER
353findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
354
47bd64d5 355install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 356cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 357
2a437456 358install -d \
65c325f6 359 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
360 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 361 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
362 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
363 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
364
a91c2692 365touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
366touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
367touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
368
76055aa1 369cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 370[mci]
371cdaudio=mcicda.drv
372sequencer=mciseq.drv
373waveaudio=mciwave.drv
374avivideo=mciavi.drv
375videodisc=mcipionr.drv
376vcr=mciviscd.drv
377MPEGVideo=mciqtz.drv
5c4ec57b 378EOF
379
80496098 380# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 381
887fffcf
ER
382dir=$(pwd)
383> files.so
384> files.programs
55a96819 385cd $RPM_BUILD_ROOT%{_libdir}/wine
386for f in *.so; do
16e36f25 387 case $f in
ad4623a1 388 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
389 ;;
390 *)
391 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 392 esac
55a96819 393done
394cd -
887fffcf
ER
395
396programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 397for p in $programs; do
8d493411 398 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
399 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 400 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 401 grep -v "$p\.exe\.so$" files.so > files.so.
402 mv -f files.so. files.so
55a96819 403done
55a96819 404
f6cf693b
JK
405%ifarch %{x8664}
406for langdir in "" de/ fr/ pl/ ; do
407mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
408done
409%endif
410
f7357f09 411install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 412%ifnarch %{x8664}
db80a28e 413cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 414%else
db80a28e 415cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 416%endif
f7357f09 417
887fffcf 418install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
419cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
420cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 421
5c4ec57b 422%clean
423rm -rf $RPM_BUILD_ROOT
424
8df63af6 425%post
db80a28e 426/sbin/ldconfig
8df63af6
ER
427%update_desktop_database
428
f1f3af79
JB
429%postun -p /sbin/ldconfig
430
d142aa07 431%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 432rm -f /var/lock/subsys/wine
d142aa07
JB
433if [ -x /sbin/chkconfig ]; then
434 /sbin/chkconfig --del wine
435fi
436
55a96819 437%files -f files.so
5c4ec57b 438%defattr(644,root,root,755)
47bd64d5 439%doc README AUTHORS ANNOUNCE
12b1296e 440%lang(de) %doc documentation/README.de
441%lang(es) %doc documentation/README.es
442%lang(fr) %doc documentation/README.fr
0aac4f59 443%lang(hu) %doc documentation/README.hu
12b1296e 444%lang(it) %doc documentation/README.it
7b9e958b 445%lang(ko) %doc documentation/README.ko
58a0e5f4 446%lang(nb) %doc documentation/README.no
12b1296e 447%lang(pt) %doc documentation/README.pt
74de5921 448%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
449%lang(ru) %doc documentation/README.ru
450%lang(sv) %doc documentation/README.sv
451%lang(tr) %doc documentation/README.tr
82432451 452%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
453%ifnarch %{x8664}
454%attr(755,root,root) %{_bindir}/wine
455%else
456%attr(755,root,root) %{_bindir}/wine64
457%endif
d479f953 458%attr(755,root,root) %{_bindir}/wineboot
55a96819 459%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 460%attr(755,root,root) %{_bindir}/winecfg
beafc810 461%ifnarch %{x8664}
f829f028 462%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
463%else
464%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 465%endif
beafc810 466%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 467%attr(755,root,root) %{_libdir}/*.so*
861238d3 468%dir %{_libdir}/wine
61e39970 469%dir %{_libdir}/wine/fakedlls
470%{_libdir}/wine/fakedlls/*.acm
471%{_libdir}/wine/fakedlls/*.cpl
472%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
473%ifarch %{ix86}
474%{_libdir}/wine/fakedlls/*.dll16
475%endif
61e39970 476%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
477%ifarch %{ix86}
478%{_libdir}/wine/fakedlls/*.drv16
479%endif
61e39970 480%{_libdir}/wine/fakedlls/*.ds
481%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
482%ifarch %{ix86}
483%{_libdir}/wine/fakedlls/*.exe16
484%{_libdir}/wine/fakedlls/*.mod16
485%endif
61e39970 486%{_libdir}/wine/fakedlls/*.ocx
487%{_libdir}/wine/fakedlls/*.sys
488%{_libdir}/wine/fakedlls/*.tlb
f829f028 489%ifarch %{ix86}
61e39970 490%{_libdir}/wine/fakedlls/*.vxd
f829f028 491%endif
f6cf693b 492%ifnarch %{x8664}
b86f1c34 493%{_mandir}/man1/wine.1*
47bd64d5
JK
494%lang(de) %{_mandir}/de/man1/wine.1*
495%lang(fr) %{_mandir}/fr/man1/wine.1*
496%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
497%else
498%{_mandir}/man1/wine64.1*
499%lang(de) %{_mandir}/de/man1/wine64.1*
500%lang(fr) %{_mandir}/fr/man1/wine64.1*
501%lang(pl) %{_mandir}/pl/man1/wine64.1*
502%endif
da274952
AG
503%{_mandir}/man1/msiexec.1*
504%{_mandir}/man1/wineboot.1*
505%{_mandir}/man1/winecfg.1*
72ede285 506%{_mandir}/man1/winedbg.1*
b86f1c34 507%{_mandir}/man1/wineserver.1*
ad4623a1
AM
508%lang(de) %{_mandir}/de/man1/wineserver.1*
509%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 510%{_winedir}
a6c536e0 511%{_desktopdir}/wine.desktop
76055aa1 512%{_desktopdir}/wine-uninstaller.desktop
887fffcf 513%{_pixmapsdir}/%{name}.png
5c4ec57b 514
55a96819 515%files programs -f files.programs
e8f81a0a 516%defattr(644,root,root,755)
e8f81a0a 517
5c4ec57b 518%files devel
519%defattr(644,root,root,755)
47bd64d5 520%attr(755,root,root) %{_bindir}/fnt2fon
d479f953 521%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 522%attr(755,root,root) %{_bindir}/widl
55a96819 523%attr(755,root,root) %{_bindir}/winebuild
55a96819 524%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 525%attr(755,root,root) %{_bindir}/wineg++
d479f953 526%attr(755,root,root) %{_bindir}/winegcc
527%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 528%attr(755,root,root) %{_bindir}/winecpp
55a96819 529%attr(755,root,root) %{_bindir}/wmc
d479f953 530%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
531%{_libdir}/wine/lib*.def
532# no shared variants, so not separated
533%{_libdir}/wine/lib*.def.a
b93e474e 534%{_libdir}/wine/libadsiid.a
7265d9f2 535%{_libdir}/wine/libdx*.a
beafc810 536%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
537%{_libdir}/wine/libstrmiids.a
538%{_libdir}/wine/libuuid.a
539%{_libdir}/wine/libwinecrt0.a
5c4ec57b 540%{_includedir}/wine
34f03014 541%{_mandir}/man1/widl.1*
0aac4f59 542%{_mandir}/man1/winebuild.1*
da274952 543%{_mandir}/man1/winecpp.1*
34f03014 544%{_mandir}/man1/winedump.1*
bff06719 545%{_mandir}/man1/winegcc.1*
5ec7e550 546%{_mandir}/man1/wineg++.1*
34f03014 547%{_mandir}/man1/winemaker.1*
0aac4f59 548%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 549%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
550%{_mandir}/man1/wmc.1*
551%{_mandir}/man1/wrc.1*
2b5050a8 552%{_aclocaldir}/*.m4
f18f723c 553
beafc810
MM
554%files dll-capi
555%defattr(644,root,root,755)
556%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
557
16e36f25
JB
558%files dll-d3d
559%defattr(644,root,root,755)
560%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
561%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
562%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
563
564%files dll-gl
565%defattr(644,root,root,755)
566%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
567%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
568
569%if %{with sane}
570%files dll-twain
571%defattr(644,root,root,755)
b08b16bf 572%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 573%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
574%endif
575
9d6715c4
ER
576%if %{with ldap}
577%files dll-ldap
578%defattr(644,root,root,755)
579%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
580%endif
581
16e36f25
JB
582%if %{with alsa}
583%files drv-alsa
584%defattr(644,root,root,755)
585%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
586%endif
587
16e36f25
JB
588# additional dependencies in *.so not separated (yet?) from main package
589# ddraw.dll.so,x11drv.dll.so depend on X11 libs
590# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
591# ttydrv.dll.so depends on ncurses
This page took 0.168122 seconds and 4 git commands to generate.