]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
- updated BRs, disable hal
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA mm driver
4 %bcond_without  capi            # CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # GStreamer filters support
6 %bcond_without  sane            # TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # LDAP DLL
9 %bcond_without  cups            # CUPS printing support in winspool,wineps DLLs
10 #
11 # NOTE: wine detects the following SONAMES for dlopen at build time:
12 #   libGL (winex11.drv.so)
13 #   libOSMesa (gdi32.dll.so)
14 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
15 #   libcapi20 (capi2032.dll.so)
16 #   libcups (winspool.drv.so)
17 #   libdbus (mountmgr.sys.so)
18 #   libfontconfig (gdi32.dll.so)
19 #   libfreetype (gdi32.dll.so)
20 #   libgnutls (secur32.dll.so)
21 #   libhal (mountmgr.sys.so)
22 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
23 #   libncurses (kernel32.dll.so)
24 #   libodbc (odbc32.dll.so)
25 #   libpng (windowscodecs.dll.so)
26 #   libsane (sane.ds.so)
27 #   libtiff (windowscodecs.dll.so)
28 #   libv4l1 (qcap.dll.so)
29 #   libxslt (msxml3.dll.so)
30 # thus requires rebuild after change of any of the above.
31
32 # library qualifier in rpm generated deps
33 %ifarch %{x8664} ia64 ppc64 s390x sparc64
34 %define libqual ()(64bit)
35 %else
36 %define libqual %{nil}
37 %endif
38
39 %define         gecko_ver       2.21
40 Summary:        Program that lets you launch Win applications
41 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
42 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
43 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
44 Name:           wine
45 # 1.6.x – stable
46 # 1.7.x – development (DEVEL branch)
47 Version:        1.6.2
48 Release:        1
49 Epoch:          1
50 License:        LGPL
51 Group:          Applications/Emulators
52 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
53 # Source0-md5:  0f6c56f86befe38e219090915f81f48a
54 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
55 # Source1-md5:  432eb3a2d05c3f07df67864f53c87c60
56 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
57 # Source2-md5:  580bbabde1ec99ba9caa439c2dbca3f6
58 Source3:        %{name}-uninstaller.desktop
59 Patch0:         %{name}-gphoto2_bool.patch
60 Patch1:         %{name}-makedep.patch
61 Patch2:         %{name}-ncurses.patch
62 Patch4:         %{name}-disable-valgrind.patch
63 Patch5:         %{name}-ca_certificates.patch
64 Patch6:         %{name}-manpaths.patch
65 Patch7:         desktop.patch
66 Patch8:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-GLX-devel
73 %{?with_alsa:BuildRequires:     alsa-lib-devel}
74 %{?with_arts:BuildRequires:     artsc-devel}
75 BuildRequires:  autoconf >= 2.62
76 BuildRequires:  automake
77 BuildRequires:  bison
78 %{?with_capi:BuildRequires:     capi4k-utils-devel}
79 %{?with_cups:BuildRequires:     cups-devel}
80 BuildRequires:  dbus-devel
81 BuildRequires:  docbook-dtd31-sgml
82 BuildRequires:  docbook-utils
83 BuildRequires:  flex >= 2.5.33
84 BuildRequires:  fontconfig-devel
85 BuildRequires:  fontforge
86 BuildRequires:  freetype-devel >= 2.0.5
87 # for findup used after make install
88 BuildRequires:  fslint
89 %ifarch %{x8664}
90 BuildRequires:  gcc >= 6:4.4
91 %endif
92 BuildRequires:  gettext-devel
93 BuildRequires:  giflib-devel
94 BuildRequires:  gnutls-devel
95 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
96 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
97 %{?with_hal:BuildRequires:      hal-devel}
98 # for icotool used in build
99 BuildRequires:  icoutils >= 0.29.0
100 BuildRequires:  lcms2-devel >= 2
101 BuildRequires:  libgphoto2-devel
102 BuildRequires:  libgsm-devel
103 BuildRequires:  libjpeg-devel
104 BuildRequires:  libmpg123-devel >= 1.5.0
105 BuildRequires:  libpng-devel >= 1.5
106 BuildRequires:  libtiff-devel
107 BuildRequires:  libtool
108 BuildRequires:  libv4l-devel
109 BuildRequires:  libxml2-devel >= 2.0
110 BuildRequires:  libxslt-devel
111 BuildRequires:  ncurses-devel
112 # db2* failed previously - probably openjade or opensp bug
113 BuildRequires:  openjade >= 1:1.3.3-0.pre1
114 %{?with_ldap:BuildRequires:     openldap-devel}
115 BuildRequires:  opensp >= 1:1.5.1
116 BuildRequires:  pkgconfig
117 BuildRequires:  prelink
118 %{?with_sane:BuildRequires:     sane-backends-devel}
119 BuildRequires:  unixODBC-devel >= 2.2.12-2
120 #BuildRequires: valgrind
121 BuildRequires:  xorg-lib-libX11-devel
122 BuildRequires:  xorg-lib-libXcomposite-devel
123 BuildRequires:  xorg-lib-libXcursor-devel
124 BuildRequires:  xorg-lib-libXext-devel
125 BuildRequires:  xorg-lib-libXi-devel
126 BuildRequires:  xorg-lib-libXinerama-devel
127 BuildRequires:  xorg-lib-libXrandr-devel
128 BuildRequires:  xorg-lib-libXrender-devel
129 BuildRequires:  xorg-lib-libXxf86vm-devel
130 BuildRequires:  zlib-devel
131 Requires:       libfreetype.so.6%{libqual}
132 Requires:       libpng16.so.16%{libqual}
133 Requires(post): /sbin/ldconfig
134 Suggests:       binfmt-detector
135 Suggests:       ca-certificates
136 Suggests:       cabextract
137 Conflicts:      ca-certificates < 20080809-4
138 # for printing needs lpr
139 Suggests:       cups-clients
140 # for winelauncher
141 Suggests:       xorg-app-xmessage
142 # for ntlm_auth
143 Suggests:       samba-common >= 1:3.0.25
144 # link to wine/ntdll.dll.so, without any SONAME
145 Provides:       libntdll.dll.so
146 Obsoletes:      wine-doc-pdf
147 Obsoletes:      wine-drv-arts
148 Obsoletes:      wine-drv-jack
149 Obsoletes:      wine-drv-nas
150 ExclusiveArch:  %{ix86} %{x8664} arm
151 ExcludeArch:    i386
152 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154 %define         no_install_post_strip   1
155
156 %define         _winedir                %{_datadir}/%{name}
157
158 %description
159 Wine is a program which allows running Microsoft Windows programs
160 (including DOS, Windows 3.x and Win32 executables) on Unix. It
161 consists of a program loader which loads and executes a Microsoft
162 Windows binary, and a library that implements Windows API calls using
163 their Unix or X11 equivalents. The library may also be used for
164 porting Win32 code into native Unix executables.
165
166 %description -l es.UTF-8
167 Ejecuta programas Windows en Linux.
168
169 %description -l pl.UTF-8
170 Wine jest programem dzięki któremu można uruchamiać programy napisane
171 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
172 loadera, który pozwala wczytywać i uruchamiać programy w formacie
173 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
174 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
175 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
176
177 %description -l pt_BR.UTF-8
178 O Wine é um programa que permite rodar programas MS-Windows no X11.
179 Ele consiste de um carregador de programa, que carrega e executa um
180 binário MS-Windows, e de uma biblioteca de emulação que traduz as
181 chamadas da API para as equivalentes Unix/X11.
182
183 %package devel
184 Summary:        Wine - header files
185 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
186 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
187 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
188 Group:          Development/Libraries
189 Requires:       %{name} = %{epoch}:%{version}-%{release}
190
191 %description devel
192 Wine - header files.
193
194 %description devel -l es.UTF-8
195 Biblioteca de desarrollo de wine.
196
197 %description devel -l pl.UTF-8
198 Wine - pliki nagłówkowe.
199
200 %description devel -l pt_BR.UTF-8
201 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
202 WINE.
203
204 %package programs
205 Summary:        Wine - programs
206 Summary(pl.UTF-8):      Wine - programy
207 Group:          Applications
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209
210 %description programs
211 Wine - programs.
212
213 %description programs -l pl.UTF-8
214 Wine - programy.
215
216 %package dll-capi
217 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
218 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
219 Group:          Applications/Emulators
220 Requires:       %{name} = %{epoch}:%{version}-%{release}
221
222 %description dll-capi
223 CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
224
225 %description dll-capi -l pl.UTF-8
226 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
227 OpenGL).
228
229 %package dll-d3d
230 Summary:        Direct3D implementation DLLs for Wine
231 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
232 Group:          Applications/Emulators
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234 Requires:       OpenGL
235
236 %description dll-d3d
237 Direct3D implementation DLLs for Wine (through OpenGL).
238
239 %description dll-d3d -l pl.UTF-8
240 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
241
242 %package dll-gl
243 Summary:        OpenGL implementation DLLs for Wine
244 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
245 Group:          Applications/Emulators
246 Requires:       %{name} = %{epoch}:%{version}-%{release}
247 Requires:       OpenGL
248
249 %description dll-gl
250 OpenGL implementation DLLs for Wine.
251
252 %description dll-gl -l pl.UTF-8
253 Biblioteki DLL z implementacją OpenGL dla Wine.
254
255 %package dll-twain
256 Summary:        TWAIN implementation DLL for Wine
257 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
258 Group:          Applications/Emulators
259 Requires:       %{name} = %{epoch}:%{version}-%{release}
260
261 %description dll-twain
262 TWAIN implementation DLL for Wine (through SANE).
263
264 %description dll-twain -l pl.UTF-8
265 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
266
267 %package dll-ldap
268 Summary:        Win32 LDAP API DLL for Wine
269 Group:          Applications/Emulators
270 Requires:       %{name} = %{epoch}:%{version}-%{release}
271
272 %description dll-ldap
273 Lightweight Directory Access Protocol Library.
274
275 %package drv-alsa
276 Summary:        ALSA driver for WINE mm.dll implementation
277 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
278 Group:          Applications/Emulators
279 Requires:       %{name} = %{epoch}:%{version}-%{release}
280
281 %description drv-alsa
282 ALSA driver for WINE mm.dll (multimedia system) implementation.
283
284 %description drv-alsa -l pl.UTF-8
285 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
286
287 %prep
288 %setup -q
289 %patch0 -p1
290 %patch1 -p1
291 %patch2 -p1
292 %patch4 -p1
293 %patch5 -p1
294 %patch6 -p1
295 %patch7 -p1
296 %ifarch %{x8664}
297 %patch8 -p1
298 %endif
299
300 %build
301 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
302 mv -f oic_winlogo_*.png %{name}.png
303
304 %{__autoconf}
305 %{__autoheader}
306 %configure \
307 %ifarch %{x8664}
308         --enable-win64 \
309 %endif
310         --with-alsa%{!?with_alsa:=no} \
311         --with-capi%{!?with_capi:=no} \
312         --with-cms \
313         --with-coreaudio \
314         --with-cups%{!?with_cups:=no} \
315         --with-curses \
316         --with-fontconfig \
317         --with-freetype \
318         --with-glu \
319         --with-gnutls \
320         --with-gphoto \
321         --with-gsm \
322         --with-gstreamer%{!?with_gstreamer:=no} \
323         --with-hal%{!?with_hal:=no} \
324         --with-jpeg \
325         --with-ldap%{!?with_ldap:=no} \
326         --with-mpg123 \
327         --with-opengl \
328         --with-oss \
329         --with-png \
330         --with-pthread \
331         --with-sane%{!?with_sane:=no} \
332         --with-xcomposite \
333         --with-xcursor \
334         --with-xinerama \
335         --with-xinput \
336         --with-xml \
337         --with-xrandr \
338         --with-xrender \
339         --with-xshape \
340         --with-xshm \
341         --with-xslt \
342         --with-xxf86vm \
343         --with-x
344 %{__make} depend
345 %{__make}
346
347 %install
348 rm -rf $RPM_BUILD_ROOT
349 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
350 %{__make} install \
351         DESTDIR=$RPM_BUILD_ROOT
352
353 findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
354
355 install -p tools/fnt2fon $RPM_BUILD_ROOT%{_bindir}
356 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
357
358 install -d \
359         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
360         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
361         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
362         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
363         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
364
365 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
366 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
367 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
368
369 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
370 [mci]
371 cdaudio=mcicda.drv
372 sequencer=mciseq.drv
373 waveaudio=mciwave.drv
374 avivideo=mciavi.drv
375 videodisc=mcipionr.drv
376 vcr=mciviscd.drv
377 MPEGVideo=mciqtz.drv
378 EOF
379
380 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
381
382 dir=$(pwd)
383 > files.so
384 > files.programs
385 cd $RPM_BUILD_ROOT%{_libdir}/wine
386 for f in *.so; do
387         case $f in
388         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
389                 ;;
390         *)
391                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
392         esac
393 done
394 cd -
395
396 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
397 for p in $programs; do
398         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
399         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
400         echo "%{_mandir}/man1/$p.1*" >> files.programs
401         grep -v "$p\.exe\.so$" files.so > files.so.
402         mv -f files.so. files.so
403 done
404
405 %ifarch %{x8664}
406 for langdir in "" de/ fr/ pl/ ; do
407 mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
408 done
409 %endif
410
411 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
412 %ifnarch %{x8664}
413 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
414 %else
415 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
416 %endif
417
418 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
419 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
420 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
421
422 %clean
423 rm -rf $RPM_BUILD_ROOT
424
425 %post
426 /sbin/ldconfig
427 %update_desktop_database
428
429 %postun -p /sbin/ldconfig
430
431 %triggerpostun -- wine < 1:0.9.12-1.9
432 rm -f /var/lock/subsys/wine
433 if [ -x /sbin/chkconfig ]; then
434         /sbin/chkconfig --del wine
435 fi
436
437 %files -f files.so
438 %defattr(644,root,root,755)
439 %doc README AUTHORS ANNOUNCE
440 %lang(de) %doc documentation/README.de
441 %lang(es) %doc documentation/README.es
442 %lang(fr) %doc documentation/README.fr
443 %lang(hu) %doc documentation/README.hu
444 %lang(it) %doc documentation/README.it
445 %lang(ko) %doc documentation/README.ko
446 %lang(nb) %doc documentation/README.no
447 %lang(pt) %doc documentation/README.pt
448 %lang(pt_BR) %doc documentation/README.pt_br
449 %lang(ru) %doc documentation/README.ru
450 %lang(sv) %doc documentation/README.sv
451 %lang(tr) %doc documentation/README.tr
452 %attr(755,root,root) %{_bindir}/msiexec
453 %ifnarch %{x8664}
454 %attr(755,root,root) %{_bindir}/wine
455 %else
456 %attr(755,root,root) %{_bindir}/wine64
457 %endif
458 %attr(755,root,root) %{_bindir}/wineboot
459 %attr(755,root,root) %{_bindir}/winedbg
460 %attr(755,root,root) %{_bindir}/winecfg
461 %ifnarch %{x8664}
462 %attr(755,root,root) %{_bindir}/wine-preloader
463 %else
464 %attr(755,root,root) %{_bindir}/wine64-preloader
465 %endif
466 %attr(755,root,root) %{_bindir}/wineserver
467 %attr(755,root,root) %{_libdir}/*.so*
468 %dir %{_libdir}/wine
469 %dir %{_libdir}/wine/fakedlls
470 %{_libdir}/wine/fakedlls/*.acm
471 %{_libdir}/wine/fakedlls/*.cpl
472 %{_libdir}/wine/fakedlls/*.dll
473 %ifarch %{ix86}
474 %{_libdir}/wine/fakedlls/*.dll16
475 %endif
476 %{_libdir}/wine/fakedlls/*.drv
477 %ifarch %{ix86}
478 %{_libdir}/wine/fakedlls/*.drv16
479 %endif
480 %{_libdir}/wine/fakedlls/*.ds
481 %{_libdir}/wine/fakedlls/*.exe
482 %ifarch %{ix86}
483 %{_libdir}/wine/fakedlls/*.exe16
484 %{_libdir}/wine/fakedlls/*.mod16
485 %endif
486 %{_libdir}/wine/fakedlls/*.ocx
487 %{_libdir}/wine/fakedlls/*.sys
488 %{_libdir}/wine/fakedlls/*.tlb
489 %ifarch %{ix86}
490 %{_libdir}/wine/fakedlls/*.vxd
491 %endif
492 %ifnarch %{x8664}
493 %{_mandir}/man1/wine.1*
494 %lang(de) %{_mandir}/de/man1/wine.1*
495 %lang(fr) %{_mandir}/fr/man1/wine.1*
496 %lang(pl) %{_mandir}/pl/man1/wine.1*
497 %else
498 %{_mandir}/man1/wine64.1*
499 %lang(de) %{_mandir}/de/man1/wine64.1*
500 %lang(fr) %{_mandir}/fr/man1/wine64.1*
501 %lang(pl) %{_mandir}/pl/man1/wine64.1*
502 %endif
503 %{_mandir}/man1/msiexec.1*
504 %{_mandir}/man1/wineboot.1*
505 %{_mandir}/man1/winecfg.1*
506 %{_mandir}/man1/winedbg.1*
507 %{_mandir}/man1/wineserver.1*
508 %lang(de) %{_mandir}/de/man1/wineserver.1*
509 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
510 %{_winedir}
511 %{_desktopdir}/wine.desktop
512 %{_desktopdir}/wine-uninstaller.desktop
513 %{_pixmapsdir}/%{name}.png
514
515 %files programs -f files.programs
516 %defattr(644,root,root,755)
517
518 %files devel
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_bindir}/fnt2fon
521 %attr(755,root,root) %{_bindir}/function_grep.pl
522 %attr(755,root,root) %{_bindir}/widl
523 %attr(755,root,root) %{_bindir}/winebuild
524 %attr(755,root,root) %{_bindir}/winedump
525 %attr(755,root,root) %{_bindir}/wineg++
526 %attr(755,root,root) %{_bindir}/winegcc
527 %attr(755,root,root) %{_bindir}/winemaker
528 %attr(755,root,root) %{_bindir}/winecpp
529 %attr(755,root,root) %{_bindir}/wmc
530 %attr(755,root,root) %{_bindir}/wrc
531 %{_libdir}/wine/lib*.def
532 # no shared variants, so not separated
533 %{_libdir}/wine/lib*.def.a
534 %{_libdir}/wine/libadsiid.a
535 %{_libdir}/wine/libdx*.a
536 %{_libdir}/wine/libstrmbase.a
537 %{_libdir}/wine/libstrmiids.a
538 %{_libdir}/wine/libuuid.a
539 %{_libdir}/wine/libwinecrt0.a
540 %{_includedir}/wine
541 %{_mandir}/man1/widl.1*
542 %{_mandir}/man1/winebuild.1*
543 %{_mandir}/man1/winecpp.1*
544 %{_mandir}/man1/winedump.1*
545 %{_mandir}/man1/winegcc.1*
546 %{_mandir}/man1/wineg++.1*
547 %{_mandir}/man1/winemaker.1*
548 %lang(de) %{_mandir}/de/man1/winemaker.1*
549 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
550 %{_mandir}/man1/wmc.1*
551 %{_mandir}/man1/wrc.1*
552 %{_aclocaldir}/*.m4
553
554 %files dll-capi
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
557
558 %files dll-d3d
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
561 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
562 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
563
564 %files dll-gl
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
567 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
568
569 %if %{with sane}
570 %files dll-twain
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
573 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
574 %endif
575
576 %if %{with ldap}
577 %files dll-ldap
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
580 %endif
581
582 %if %{with alsa}
583 %files drv-alsa
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
586 %endif
587
588 # additional dependencies in *.so not separated (yet?) from main package
589 #   ddraw.dll.so,x11drv.dll.so depend on X11 libs
590 #   ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
591 #   ttydrv.dll.so depends on ncurses
This page took 0.139703 seconds and 4 git commands to generate.