]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
disable autoreqprov
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
5b49e814 7%bcond_with hal # HAL dynamic device support [deprecated]
9d6715c4 8%bcond_without ldap # don't build LDAP DLL
16e36f25 9%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 10%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
13# libGL (winex11.drv.so)
14# libOSMesa (gdi32.dll.so)
15# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16# libcapi20 (capi2032.dll.so)
17# libcups (winspool.drv.so)
18# libdbus (mountmgr.sys.so)
16e36f25 19# libfontconfig (gdi32.dll.so)
5b49e814
JB
20# libfreetype (gdi32.dll.so)
21# libgnutls (secur32.dll.so)
22# libhal (mountmgr.sys.so)
23# libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
26# libpng (windowscodecs.dll.so)
27# libsane (sane.ds.so)
28# libtiff (windowscodecs.dll.so)
29# libv4l1 (qcap.dll.so)
30# libxslt (msxml3.dll.so)
546bbb82 31# thus requires rebuild after change of any of the above.
db80a28e 32
4ce8abe1
ER
33# library qualifier in rpm generated deps
34%ifarch %{x8664} ia64 ppc64 s390x sparc64
35%define libqual ()(64bit)
36%else
37%define libqual %{nil}
38%endif
39
f73ad4b6
JP
40%define gecko_ver 2.47
41%define _rc rc4
698e86e7 42Summary: Program that lets you launch Win applications
93e41e44
ER
43Summary(es.UTF-8): Ejecuta programas Windows en Linux
44Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
45Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 46Name: wine
cbe4db03
JK
47# 1.8.x – stable
48# 1.9.x – development
f73ad4b6
JP
49Version: 3.0
50Release: 0.%{_rc}.1
46114a9a 51Epoch: 1
528c1138 52License: LGPL
5c4ec57b 53Group: Applications/Emulators
f73ad4b6
JP
54Source0: https://dl.winehq.org/wine/source/3.0/%{name}-%{version}-%{_rc}.tar.xz
55# Source0-md5: 843fd4697d153543aba5260214414dfd
56Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}_gecko-%{gecko_ver}-x86.msi
57# Source1-md5: 5ebc4ec71c92b3db3d84b334a1db385d
58Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}_gecko-%{gecko_ver}-x86_64.msi
59# Source2-md5: d93ac0d2e6aceafe9113a9918916df45
beafc810 60Source3: %{name}-uninstaller.desktop
55061442 61Patch0: %{name}-gphoto2_bool.patch
a0ff0658 62Patch1: %{name}-makedep.patch
a4a10255 63Patch2: %{name}-ncurses.patch
8b4bf701 64Patch4: %{name}-disable-valgrind.patch
5312a936 65Patch5: %{name}-ca_certificates.patch
a26a3859
JK
66Patch6: desktop.patch
67Patch7: %{name}-wine64_man.patch
1b3d8891 68URL: http://www.winehq.org/
5b49e814 69BuildRequires: Mesa-libOSMesa-devel
0aac4f59 70BuildRequires: OpenAL-devel >= 1.1
5b49e814 71BuildRequires: OpenCL-devel
489ca66c 72BuildRequires: OpenGL-GLU-devel
6547534c
KK
73%{?with_alsa:BuildRequires: alsa-lib-devel}
74%{?with_arts:BuildRequires: artsc-devel}
5b49e814 75BuildRequires: autoconf >= 2.62
c7af491d 76BuildRequires: automake
d3c41437 77BuildRequires: bison
beafc810 78%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 79%{?with_cups:BuildRequires: cups-devel}
5b49e814 80BuildRequires: dbus-devel
5b49e814 81BuildRequires: flex >= 2.5.33
16e36f25 82BuildRequires: fontconfig-devel
5fc34681 83BuildRequires: freetype-devel >= 2.0.5
05596b04 84BuildRequires: gettext-devel
5b49e814
JB
85%ifarch %{x8664}
86BuildRequires: gcc >= 6:4.4
87%endif
1f0c428e 88BuildRequires: gettext-tools
c57a98fe 89BuildRequires: gnutls-devel
f73ad4b6
JP
90%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
91%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
92%{?with_hal:BuildRequires: hal-devel}
93# for icotool used in build
94BuildRequires: icoutils >= 0.29.0
95BuildRequires: lcms2-devel >= 2
3d0989c1 96BuildRequires: libcap-devel
beb8121e 97BuildRequires: libgphoto2-devel
d0d61ce7 98BuildRequires: libgsm-devel
c504380e 99BuildRequires: libjpeg-devel
2341e633 100BuildRequires: libmpg123-devel >= 1.5.0
05596b04 101BuildRequires: libpcap-devel
5b49e814
JB
102BuildRequires: libpng-devel >= 1.5
103BuildRequires: libtiff-devel
0aac4f59 104BuildRequires: libv4l-devel
5b49e814 105BuildRequires: libxml2-devel >= 2.0
fbb1220c 106BuildRequires: libxslt-devel
8a1d358f 107BuildRequires: ncurses-devel
9d6715c4 108%{?with_ldap:BuildRequires: openldap-devel}
beb8121e 109BuildRequires: pkgconfig
3d0989c1 110BuildRequires: pulseaudio-devel
d7296a19 111BuildRequires: samba-devel
5715e1d1 112%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 113BuildRequires: xorg-lib-libX11-devel
beb8121e 114BuildRequires: xorg-lib-libXcomposite-devel
115BuildRequires: xorg-lib-libXcursor-devel
5b49e814 116BuildRequires: xorg-lib-libXext-devel
c66c3406 117BuildRequires: xorg-lib-libXi-devel
beb8121e 118BuildRequires: xorg-lib-libXinerama-devel
beb8121e 119BuildRequires: xorg-lib-libXrandr-devel
c66c3406 120BuildRequires: xorg-lib-libXrender-devel
c66c3406 121BuildRequires: xorg-lib-libXxf86vm-devel
5b49e814 122BuildRequires: zlib-devel
4ce8abe1 123Requires: libfreetype.so.6%{libqual}
a85c8746 124Requires: libpng16.so.16%{libqual}
8df63af6 125Requires(post): /sbin/ldconfig
ae42c99e 126Suggests: binfmt-detector
be70b824 127Suggests: ca-certificates
beafc810 128Suggests: cabextract
a2f68044 129Conflicts: ca-certificates < 20080809-4
b3d3861d 130# for printing needs lpr
131Suggests: cups-clients
f96e197b 132# for winelauncher
3bddfbf2 133Suggests: xorg-app-xmessage
f96e197b 134# for ntlm_auth
14e95129 135Suggests: samba-common >= 1:3.0.25
e1aa58ad 136AutoReqProv: no
52b6007b
JB
137# link to wine/ntdll.dll.so, without any SONAME
138Provides: libntdll.dll.so
7212da21 139Obsoletes: wine-doc-pdf
93b34e12 140Obsoletes: wine-drv-arts
beafc810
MM
141Obsoletes: wine-drv-jack
142Obsoletes: wine-drv-nas
5b49e814 143ExclusiveArch: %{ix86} %{x8664} arm
206eed29 144ExcludeArch: i386
0403821a 145BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 146
e8f81a0a 147%define no_install_post_strip 1
148
e8f81a0a 149%define _winedir %{_datadir}/%{name}
6731627f 150
5c4ec57b 151%description
6731627f 152Wine is a program which allows running Microsoft Windows programs
a519bc4f 153(including DOS, Windows 3.x and Win32 executables) on Unix. It
154consists of a program loader which loads and executes a Microsoft
155Windows binary, and a library that implements Windows API calls using
156their Unix or X11 equivalents. The library may also be used for
157porting Win32 code into native Unix executables.
5c4ec57b 158
c967e47d 159%description -l es.UTF-8
f33a1517 160Ejecuta programas Windows en Linux.
161
c967e47d
JR
162%description -l pl.UTF-8
163Wine jest programem dzięki któremu można uruchamiać programy napisane
164dla Microsoft Windows pod systemami uniksowymi. Składa się on z
165loadera, który pozwala wczytywać i uruchamiać programy w formacie
166Microsoft Windows, oraz z biblioteki, która implementuje API Windows
167przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
168także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 169
c967e47d
JR
170%description -l pt_BR.UTF-8
171O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 172Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 173binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 174chamadas da API para as equivalentes Unix/X11.
175
5c4ec57b 176%package devel
7a050f82 177Summary: Wine - header files
93e41e44
ER
178Summary(es.UTF-8): Biblioteca de desarrollo de wine
179Summary(pl.UTF-8): Wine - pliki nagłowkowe
180Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 181Group: Development/Libraries
46114a9a 182Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 183
5c4ec57b 184%description devel
185Wine - header files.
186
c967e47d 187%description devel -l es.UTF-8
f33a1517 188Biblioteca de desarrollo de wine.
189
c967e47d
JR
190%description devel -l pl.UTF-8
191Wine - pliki nagłówkowe.
5c4ec57b 192
c967e47d
JR
193%description devel -l pt_BR.UTF-8
194Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 195WINE.
196
e8f81a0a 197%package programs
198Summary: Wine - programs
93e41e44 199Summary(pl.UTF-8): Wine - programy
e8f81a0a 200Group: Applications
46114a9a 201Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 202
203%description programs
0a7c5d50 204Wine - programs.
e8f81a0a 205
c967e47d 206%description programs -l pl.UTF-8
0a7c5d50 207Wine - programy.
e8f81a0a 208
beafc810
MM
209%package dll-capi
210Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
211Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
212Group: Applications/Emulators
213Requires: %{name} = %{epoch}:%{version}-%{release}
214
215%description dll-capi
b1df4aa7 216CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
217
218%description dll-capi -l pl.UTF-8
b1df4aa7 219Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 220
16e36f25
JB
221%package dll-d3d
222Summary: Direct3D implementation DLLs for Wine
93e41e44 223Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 224Group: Applications/Emulators
46114a9a 225Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
226Requires: OpenGL
227
228%description dll-d3d
229Direct3D implementation DLLs for Wine (through OpenGL).
230
c967e47d
JR
231%description dll-d3d -l pl.UTF-8
232Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
233
234%package dll-gl
235Summary: OpenGL implementation DLLs for Wine
93e41e44 236Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 237Group: Applications/Emulators
46114a9a 238Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
239Requires: OpenGL
240
241%description dll-gl
242OpenGL implementation DLLs for Wine.
243
c967e47d
JR
244%description dll-gl -l pl.UTF-8
245Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
246
247%package dll-twain
248Summary: TWAIN implementation DLL for Wine
93e41e44 249Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 250Group: Applications/Emulators
46114a9a 251Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
252
253%description dll-twain
254TWAIN implementation DLL for Wine (through SANE).
255
c967e47d
JR
256%description dll-twain -l pl.UTF-8
257Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 258
9d6715c4 259%package dll-ldap
db80a28e 260Summary: Win32 LDAP API DLL for Wine
b1df4aa7 261Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
262Group: Applications/Emulators
263Requires: %{name} = %{epoch}:%{version}-%{release}
264
265%description dll-ldap
b1df4aa7
JB
266Lightweight Directory Access Protocol Library for Wine.
267
268%description dll-ldap -l pl.UTF-8
269Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 270
16e36f25
JB
271%package drv-alsa
272Summary: ALSA driver for WINE mm.dll implementation
93e41e44 273Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 274Group: Applications/Emulators
46114a9a 275Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
276
277%description drv-alsa
278ALSA driver for WINE mm.dll (multimedia system) implementation.
279
c967e47d
JR
280%description drv-alsa -l pl.UTF-8
281Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 282
5c4ec57b 283%prep
f73ad4b6 284%setup -q -n %{name}-%{version}-%{_rc}
2fbbb535 285%patch0 -p1
286%patch1 -p1
ab25825d 287%patch2 -p1
8b4bf701 288%patch4 -p1
5312a936 289%patch5 -p1
3bfef0cd 290%patch6 -p1
f6cf693b 291%ifarch %{x8664}
a26a3859 292%patch7 -p1
f6cf693b 293%endif
591d55ba 294
5c4ec57b 295%build
887fffcf
ER
296icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
297mv -f oic_winlogo_*.png %{name}.png
298
2fbbb535 299%{__autoconf}
103d8328 300%{__autoheader}
9d6a128d 301%configure \
f829f028
AM
302%ifarch %{x8664}
303 --enable-win64 \
304%endif
5b49e814
JB
305 --with-alsa%{!?with_alsa:=no} \
306 --with-capi%{!?with_capi:=no} \
beb8121e 307 --with-cms \
d0d61ce7 308 --with-coreaudio \
5b49e814 309 --with-cups%{!?with_cups:=no} \
c504380e 310 --with-curses \
d7296a19 311 --with-dbus \
c504380e 312 --with-fontconfig \
313 --with-freetype \
d7296a19 314 --with-gphoto \
c504380e 315 --with-glu \
d0d61ce7 316 --with-gnutls \
d0d61ce7 317 --with-gsm \
8ec65640
JK
318 %{__with_without gstreamer} \
319 %{__with_without hal} \
c504380e 320 --with-jpeg \
5b49e814 321 --with-ldap%{!?with_ldap:=no} \
d0d61ce7 322 --with-mpg123 \
d7296a19
JK
323 --with%{!?with_netapi:out}-netapi \
324 --with-openal \
325 --with-opencl \
c504380e 326 --with-opengl \
d7296a19 327 --with-osmesa \
c54d2750 328 --with-pcap \
c504380e 329 --with-png \
d0d61ce7 330 --with-pthread \
c54d2750 331 --with-pulse \
c504380e 332 --with%{!?with_sane:out}-sane \
d7296a19
JK
333 --with-tiff \
334 --with-v4l \
beb8121e 335 --with-xcomposite \
336 --with-xcursor \
337 --with-xinerama \
338 --with-xinput \
d7296a19 339 --with-xinput2 \
c504380e 340 --with-xml \
beb8121e 341 --with-xrandr \
c504380e 342 --with-xrender \
343 --with-xshape \
344 --with-xshm \
345 --with-xslt \
beb8121e 346 --with-xxf86vm \
d7296a19
JK
347 --with-x \
348 --with-zlib
05eb066b 349%{__make} depend
4aafdd81 350%{__make}
e8f81a0a 351
5c4ec57b 352%install
353rm -rf $RPM_BUILD_ROOT
ffb676e0 354install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
355%{__make} install \
356 DESTDIR=$RPM_BUILD_ROOT
357
a26a3859 358install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 359cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 360
2a437456 361install -d \
65c325f6 362 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
363 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 364 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
365 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
366 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
367
a91c2692 368touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
369touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
370touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
371
76055aa1 372cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 373[mci]
374cdaudio=mcicda.drv
375sequencer=mciseq.drv
376waveaudio=mciwave.drv
377avivideo=mciavi.drv
378videodisc=mcipionr.drv
379vcr=mciviscd.drv
380MPEGVideo=mciqtz.drv
5c4ec57b 381EOF
382
80496098 383# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 384
887fffcf
ER
385dir=$(pwd)
386> files.so
387> files.programs
55a96819 388cd $RPM_BUILD_ROOT%{_libdir}/wine
389for f in *.so; do
16e36f25 390 case $f in
ad4623a1 391 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
392 ;;
393 *)
394 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 395 esac
55a96819 396done
397cd -
887fffcf
ER
398
399programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 400for p in $programs; do
8d493411 401 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
402 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 403 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 404 grep -v "$p\.exe\.so$" files.so > files.so.
405 mv -f files.so. files.so
55a96819 406done
55a96819 407
a26a3859
JK
408for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
409 mv "$dir" "${dir%.UTF-8}"
410done
411
f6cf693b 412%ifarch %{x8664}
c54d2750
JK
413install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
414for lang in de fr pl ; do
415install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
416install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
417done
418%else
419install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
420for lang in de fr pl ; do
421install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
422install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
423done
424%endif
425
f7357f09 426install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 427%ifnarch %{x8664}
db80a28e 428cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 429%else
db80a28e 430cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 431%endif
f7357f09 432
887fffcf 433install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
434cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
435cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 436
5c4ec57b 437%clean
438rm -rf $RPM_BUILD_ROOT
439
8df63af6 440%post
db80a28e 441/sbin/ldconfig
8df63af6
ER
442%update_desktop_database
443
f1f3af79
JB
444%postun -p /sbin/ldconfig
445
d142aa07 446%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 447rm -f /var/lock/subsys/wine
d142aa07
JB
448if [ -x /sbin/chkconfig ]; then
449 /sbin/chkconfig --del wine
450fi
451
55a96819 452%files -f files.so
5c4ec57b 453%defattr(644,root,root,755)
47bd64d5 454%doc README AUTHORS ANNOUNCE
12b1296e 455%lang(de) %doc documentation/README.de
456%lang(es) %doc documentation/README.es
457%lang(fr) %doc documentation/README.fr
0aac4f59 458%lang(hu) %doc documentation/README.hu
12b1296e 459%lang(it) %doc documentation/README.it
7b9e958b 460%lang(ko) %doc documentation/README.ko
58a0e5f4 461%lang(nb) %doc documentation/README.no
12b1296e 462%lang(pt) %doc documentation/README.pt
74de5921 463%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
464%lang(ru) %doc documentation/README.ru
465%lang(sv) %doc documentation/README.sv
466%lang(tr) %doc documentation/README.tr
82432451 467%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
468%ifnarch %{x8664}
469%attr(755,root,root) %{_bindir}/wine
470%else
471%attr(755,root,root) %{_bindir}/wine64
472%endif
d479f953 473%attr(755,root,root) %{_bindir}/wineboot
55a96819 474%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 475%attr(755,root,root) %{_bindir}/winecfg
beafc810 476%ifnarch %{x8664}
f829f028 477%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
478%else
479%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 480%endif
beafc810 481%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 482%attr(755,root,root) %{_libdir}/*.so*
861238d3 483%dir %{_libdir}/wine
61e39970 484%dir %{_libdir}/wine/fakedlls
485%{_libdir}/wine/fakedlls/*.acm
486%{_libdir}/wine/fakedlls/*.cpl
487%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
488%ifarch %{ix86}
489%{_libdir}/wine/fakedlls/*.dll16
490%endif
61e39970 491%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
492%ifarch %{ix86}
493%{_libdir}/wine/fakedlls/*.drv16
494%endif
61e39970 495%{_libdir}/wine/fakedlls/*.ds
496%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
497%ifarch %{ix86}
498%{_libdir}/wine/fakedlls/*.exe16
499%{_libdir}/wine/fakedlls/*.mod16
500%endif
61e39970 501%{_libdir}/wine/fakedlls/*.ocx
502%{_libdir}/wine/fakedlls/*.sys
503%{_libdir}/wine/fakedlls/*.tlb
f829f028 504%ifarch %{ix86}
61e39970 505%{_libdir}/wine/fakedlls/*.vxd
f829f028 506%endif
f6cf693b 507%ifnarch %{x8664}
b86f1c34 508%{_mandir}/man1/wine.1*
47bd64d5
JK
509%lang(de) %{_mandir}/de/man1/wine.1*
510%lang(fr) %{_mandir}/fr/man1/wine.1*
511%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
512%else
513%{_mandir}/man1/wine64.1*
514%lang(de) %{_mandir}/de/man1/wine64.1*
515%lang(fr) %{_mandir}/fr/man1/wine64.1*
516%lang(pl) %{_mandir}/pl/man1/wine64.1*
517%endif
da274952
AG
518%{_mandir}/man1/msiexec.1*
519%{_mandir}/man1/wineboot.1*
520%{_mandir}/man1/winecfg.1*
72ede285 521%{_mandir}/man1/winedbg.1*
b86f1c34 522%{_mandir}/man1/wineserver.1*
ad4623a1
AM
523%lang(de) %{_mandir}/de/man1/wineserver.1*
524%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 525%{_winedir}
a6c536e0 526%{_desktopdir}/wine.desktop
76055aa1 527%{_desktopdir}/wine-uninstaller.desktop
887fffcf 528%{_pixmapsdir}/%{name}.png
5c4ec57b 529
55a96819 530%files programs -f files.programs
e8f81a0a 531%defattr(644,root,root,755)
e8f81a0a 532
5c4ec57b 533%files devel
534%defattr(644,root,root,755)
a26a3859 535%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 536%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 537%attr(755,root,root) %{_bindir}/widl
55a96819 538%attr(755,root,root) %{_bindir}/winebuild
55a96819 539%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 540%attr(755,root,root) %{_bindir}/wineg++
d479f953 541%attr(755,root,root) %{_bindir}/winegcc
542%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 543%attr(755,root,root) %{_bindir}/winecpp
55a96819 544%attr(755,root,root) %{_bindir}/wmc
d479f953 545%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
546%{_libdir}/wine/lib*.def
547# no shared variants, so not separated
b93e474e 548%{_libdir}/wine/libadsiid.a
f73ad4b6 549%{_libdir}/wine/libdinput.a
7265d9f2 550%{_libdir}/wine/libdx*.a
f73ad4b6 551%{_libdir}/wine/libmfuuid.a
beafc810 552%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
553%{_libdir}/wine/libstrmiids.a
554%{_libdir}/wine/libuuid.a
555%{_libdir}/wine/libwinecrt0.a
5c4ec57b 556%{_includedir}/wine
34f03014 557%{_mandir}/man1/widl.1*
0aac4f59 558%{_mandir}/man1/winebuild.1*
da274952 559%{_mandir}/man1/winecpp.1*
34f03014 560%{_mandir}/man1/winedump.1*
bff06719 561%{_mandir}/man1/winegcc.1*
5ec7e550 562%{_mandir}/man1/wineg++.1*
34f03014 563%{_mandir}/man1/winemaker.1*
0aac4f59 564%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 565%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
566%{_mandir}/man1/wmc.1*
567%{_mandir}/man1/wrc.1*
2b5050a8 568%{_aclocaldir}/*.m4
f18f723c 569
beafc810
MM
570%files dll-capi
571%defattr(644,root,root,755)
572%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
573
16e36f25
JB
574%files dll-d3d
575%defattr(644,root,root,755)
576%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
577%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
578%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
579
580%files dll-gl
581%defattr(644,root,root,755)
582%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
583%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
584
585%if %{with sane}
586%files dll-twain
587%defattr(644,root,root,755)
b08b16bf 588%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 589%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
590%endif
591
9d6715c4
ER
592%if %{with ldap}
593%files dll-ldap
594%defattr(644,root,root,755)
595%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
596%endif
597
16e36f25
JB
598%if %{with alsa}
599%files drv-alsa
600%defattr(644,root,root,755)
601%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
602%endif
603
16e36f25 604# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
605# ddraw.dll.so,winex11.drv.so depend on X11 libs
606# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.201468 seconds and 4 git commands to generate.