]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
cleanup obviously bogus deps
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
5b49e814 7%bcond_with hal # HAL dynamic device support [deprecated]
9d6715c4 8%bcond_without ldap # don't build LDAP DLL
16e36f25 9%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 10%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
13# libGL (winex11.drv.so)
14# libOSMesa (gdi32.dll.so)
15# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16# libcapi20 (capi2032.dll.so)
17# libcups (winspool.drv.so)
18# libdbus (mountmgr.sys.so)
16e36f25 19# libfontconfig (gdi32.dll.so)
5b49e814
JB
20# libfreetype (gdi32.dll.so)
21# libgnutls (secur32.dll.so)
22# libhal (mountmgr.sys.so)
23# libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
26# libpng (windowscodecs.dll.so)
27# libsane (sane.ds.so)
28# libtiff (windowscodecs.dll.so)
29# libv4l1 (qcap.dll.so)
30# libxslt (msxml3.dll.so)
546bbb82 31# thus requires rebuild after change of any of the above.
db80a28e 32
4ce8abe1
ER
33# library qualifier in rpm generated deps
34%ifarch %{x8664} ia64 ppc64 s390x sparc64
35%define libqual ()(64bit)
36%else
37%define libqual %{nil}
38%endif
39
c516c269 40%define gecko_ver 2.24
698e86e7 41Summary: Program that lets you launch Win applications
93e41e44
ER
42Summary(es.UTF-8): Ejecuta programas Windows en Linux
43Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
44Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 45Name: wine
cbe4db03
JK
46# 1.8.x – stable
47# 1.9.x – development
c54d2750 48Version: 1.8
9dad7a50 49Release: 1
46114a9a 50Epoch: 1
528c1138 51License: LGPL
5c4ec57b 52Group: Applications/Emulators
beafc810 53Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
c54d2750 54# Source0-md5: 96b51a2f2ae727802d71095354e69fef
beafc810 55Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
c516c269 56# Source1-md5: 766bb034172f7f0a97443951a02a0df8
beafc810 57Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
c516c269 58# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
beafc810 59Source3: %{name}-uninstaller.desktop
55061442 60Patch0: %{name}-gphoto2_bool.patch
a0ff0658 61Patch1: %{name}-makedep.patch
a4a10255 62Patch2: %{name}-ncurses.patch
8b4bf701 63Patch4: %{name}-disable-valgrind.patch
5312a936 64Patch5: %{name}-ca_certificates.patch
a26a3859
JK
65Patch6: desktop.patch
66Patch7: %{name}-wine64_man.patch
1b3d8891 67URL: http://www.winehq.org/
5b49e814 68BuildRequires: Mesa-libOSMesa-devel
0aac4f59 69BuildRequires: OpenAL-devel >= 1.1
5b49e814 70BuildRequires: OpenCL-devel
489ca66c 71BuildRequires: OpenGL-GLU-devel
5b49e814 72BuildRequires: OpenGL-GLX-devel
d7296a19 73BuildRequires: Mesa-libOSMesa-devel
6547534c
KK
74%{?with_alsa:BuildRequires: alsa-lib-devel}
75%{?with_arts:BuildRequires: artsc-devel}
5b49e814 76BuildRequires: autoconf >= 2.62
c7af491d 77BuildRequires: automake
d3c41437 78BuildRequires: bison
beafc810 79%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 80%{?with_cups:BuildRequires: cups-devel}
5b49e814 81BuildRequires: dbus-devel
f88a3451 82BuildRequires: docbook-dtd31-sgml
83BuildRequires: docbook-utils
5b49e814 84BuildRequires: flex >= 2.5.33
16e36f25 85BuildRequires: fontconfig-devel
22432818 86BuildRequires: fontforge
5fc34681 87BuildRequires: freetype-devel >= 2.0.5
5b49e814 88# for findup used after make install
16b3dd87 89BuildRequires: fslint
05596b04
ER
90BuildRequires: gegl-devel
91BuildRequires: gettext-devel
5b49e814
JB
92%ifarch %{x8664}
93BuildRequires: gcc >= 6:4.4
94%endif
1f0c428e 95BuildRequires: gettext-tools
734deeec 96BuildRequires: giflib-devel
c57a98fe 97BuildRequires: gnutls-devel
5b49e814
JB
98%{?with_gstreamer:BuildRequires: gstreamer0.10-devel >= 0.10}
99%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10}
100%{?with_hal:BuildRequires: hal-devel}
101# for icotool used in build
102BuildRequires: icoutils >= 0.29.0
103BuildRequires: lcms2-devel >= 2
beb8121e 104BuildRequires: libgphoto2-devel
d0d61ce7 105BuildRequires: libgsm-devel
c504380e 106BuildRequires: libjpeg-devel
2341e633 107BuildRequires: libmpg123-devel >= 1.5.0
c54d2750 108BuildRequires: libcap-devel
05596b04 109BuildRequires: libpcap-devel
5b49e814
JB
110BuildRequires: libpng-devel >= 1.5
111BuildRequires: libtiff-devel
1e160e6e 112BuildRequires: libtool
0aac4f59 113BuildRequires: libv4l-devel
5b49e814 114BuildRequires: libxml2-devel >= 2.0
fbb1220c 115BuildRequires: libxslt-devel
8a1d358f 116BuildRequires: ncurses-devel
16e36f25
JB
117# db2* failed previously - probably openjade or opensp bug
118BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 119%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 120BuildRequires: opensp >= 1:1.5.1
50f0bbbe 121BuildRequires: pulseaudio-devel
beb8121e 122BuildRequires: pkgconfig
beafc810 123BuildRequires: prelink
d7296a19 124BuildRequires: samba-devel
5715e1d1 125%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 126BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 127#BuildRequires: valgrind
5b49e814 128BuildRequires: xorg-lib-libX11-devel
beb8121e 129BuildRequires: xorg-lib-libXcomposite-devel
130BuildRequires: xorg-lib-libXcursor-devel
5b49e814 131BuildRequires: xorg-lib-libXext-devel
c66c3406 132BuildRequires: xorg-lib-libXi-devel
beb8121e 133BuildRequires: xorg-lib-libXinerama-devel
beb8121e 134BuildRequires: xorg-lib-libXrandr-devel
c66c3406 135BuildRequires: xorg-lib-libXrender-devel
c66c3406 136BuildRequires: xorg-lib-libXxf86vm-devel
5b49e814 137BuildRequires: zlib-devel
4ce8abe1 138Requires: libfreetype.so.6%{libqual}
a85c8746 139Requires: libpng16.so.16%{libqual}
8df63af6 140Requires(post): /sbin/ldconfig
ae42c99e 141Suggests: binfmt-detector
be70b824 142Suggests: ca-certificates
beafc810 143Suggests: cabextract
a2f68044 144Conflicts: ca-certificates < 20080809-4
b3d3861d 145# for printing needs lpr
146Suggests: cups-clients
f96e197b 147# for winelauncher
3bddfbf2 148Suggests: xorg-app-xmessage
f96e197b 149# for ntlm_auth
14e95129 150Suggests: samba-common >= 1:3.0.25
52b6007b
JB
151# link to wine/ntdll.dll.so, without any SONAME
152Provides: libntdll.dll.so
7212da21 153Obsoletes: wine-doc-pdf
93b34e12 154Obsoletes: wine-drv-arts
beafc810
MM
155Obsoletes: wine-drv-jack
156Obsoletes: wine-drv-nas
5b49e814 157ExclusiveArch: %{ix86} %{x8664} arm
206eed29 158ExcludeArch: i386
0403821a 159BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 160
e8f81a0a 161%define no_install_post_strip 1
162
e8f81a0a 163%define _winedir %{_datadir}/%{name}
6731627f 164
5c4ec57b 165%description
6731627f 166Wine is a program which allows running Microsoft Windows programs
a519bc4f 167(including DOS, Windows 3.x and Win32 executables) on Unix. It
168consists of a program loader which loads and executes a Microsoft
169Windows binary, and a library that implements Windows API calls using
170their Unix or X11 equivalents. The library may also be used for
171porting Win32 code into native Unix executables.
5c4ec57b 172
c967e47d 173%description -l es.UTF-8
f33a1517 174Ejecuta programas Windows en Linux.
175
c967e47d
JR
176%description -l pl.UTF-8
177Wine jest programem dzięki któremu można uruchamiać programy napisane
178dla Microsoft Windows pod systemami uniksowymi. Składa się on z
179loadera, który pozwala wczytywać i uruchamiać programy w formacie
180Microsoft Windows, oraz z biblioteki, która implementuje API Windows
181przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
182także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 183
c967e47d
JR
184%description -l pt_BR.UTF-8
185O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 186Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 187binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 188chamadas da API para as equivalentes Unix/X11.
189
5c4ec57b 190%package devel
7a050f82 191Summary: Wine - header files
93e41e44
ER
192Summary(es.UTF-8): Biblioteca de desarrollo de wine
193Summary(pl.UTF-8): Wine - pliki nagłowkowe
194Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 195Group: Development/Libraries
46114a9a 196Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 197
5c4ec57b 198%description devel
199Wine - header files.
200
c967e47d 201%description devel -l es.UTF-8
f33a1517 202Biblioteca de desarrollo de wine.
203
c967e47d
JR
204%description devel -l pl.UTF-8
205Wine - pliki nagłówkowe.
5c4ec57b 206
c967e47d
JR
207%description devel -l pt_BR.UTF-8
208Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 209WINE.
210
e8f81a0a 211%package programs
212Summary: Wine - programs
93e41e44 213Summary(pl.UTF-8): Wine - programy
e8f81a0a 214Group: Applications
46114a9a 215Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 216
217%description programs
0a7c5d50 218Wine - programs.
e8f81a0a 219
c967e47d 220%description programs -l pl.UTF-8
0a7c5d50 221Wine - programy.
e8f81a0a 222
beafc810
MM
223%package dll-capi
224Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
225Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
226Group: Applications/Emulators
227Requires: %{name} = %{epoch}:%{version}-%{release}
228
229%description dll-capi
b1df4aa7 230CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
231
232%description dll-capi -l pl.UTF-8
b1df4aa7 233Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 234
16e36f25
JB
235%package dll-d3d
236Summary: Direct3D implementation DLLs for Wine
93e41e44 237Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 238Group: Applications/Emulators
46114a9a 239Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
240Requires: OpenGL
241
242%description dll-d3d
243Direct3D implementation DLLs for Wine (through OpenGL).
244
c967e47d
JR
245%description dll-d3d -l pl.UTF-8
246Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
247
248%package dll-gl
249Summary: OpenGL implementation DLLs for Wine
93e41e44 250Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 251Group: Applications/Emulators
46114a9a 252Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
253Requires: OpenGL
254
255%description dll-gl
256OpenGL implementation DLLs for Wine.
257
c967e47d
JR
258%description dll-gl -l pl.UTF-8
259Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
260
261%package dll-twain
262Summary: TWAIN implementation DLL for Wine
93e41e44 263Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 264Group: Applications/Emulators
46114a9a 265Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
266
267%description dll-twain
268TWAIN implementation DLL for Wine (through SANE).
269
c967e47d
JR
270%description dll-twain -l pl.UTF-8
271Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 272
9d6715c4 273%package dll-ldap
db80a28e 274Summary: Win32 LDAP API DLL for Wine
b1df4aa7 275Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
276Group: Applications/Emulators
277Requires: %{name} = %{epoch}:%{version}-%{release}
278
279%description dll-ldap
b1df4aa7
JB
280Lightweight Directory Access Protocol Library for Wine.
281
282%description dll-ldap -l pl.UTF-8
283Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 284
16e36f25
JB
285%package drv-alsa
286Summary: ALSA driver for WINE mm.dll implementation
93e41e44 287Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 288Group: Applications/Emulators
46114a9a 289Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
290
291%description drv-alsa
292ALSA driver for WINE mm.dll (multimedia system) implementation.
293
c967e47d
JR
294%description drv-alsa -l pl.UTF-8
295Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 296
5c4ec57b 297%prep
db80a28e 298%setup -q
2fbbb535 299%patch0 -p1
300%patch1 -p1
ab25825d 301%patch2 -p1
8b4bf701 302%patch4 -p1
5312a936 303%patch5 -p1
3bfef0cd 304%patch6 -p1
f6cf693b 305%ifarch %{x8664}
a26a3859 306%patch7 -p1
f6cf693b 307%endif
591d55ba 308
5c4ec57b 309%build
887fffcf
ER
310icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
311mv -f oic_winlogo_*.png %{name}.png
312
2fbbb535 313%{__autoconf}
103d8328 314%{__autoheader}
9d6a128d 315%configure \
f829f028
AM
316%ifarch %{x8664}
317 --enable-win64 \
318%endif
5b49e814
JB
319 --with-alsa%{!?with_alsa:=no} \
320 --with-capi%{!?with_capi:=no} \
beb8121e 321 --with-cms \
d0d61ce7 322 --with-coreaudio \
5b49e814 323 --with-cups%{!?with_cups:=no} \
c504380e 324 --with-curses \
d7296a19 325 --with-dbus \
c504380e 326 --with-fontconfig \
327 --with-freetype \
d7296a19 328 --with-gphoto \
c504380e 329 --with-glu \
d0d61ce7 330 --with-gnutls \
d0d61ce7 331 --with-gsm \
8ec65640
JK
332 %{__with_without gstreamer} \
333 %{__with_without hal} \
c504380e 334 --with-jpeg \
5b49e814 335 --with-ldap%{!?with_ldap:=no} \
d0d61ce7 336 --with-mpg123 \
d7296a19
JK
337 --with%{!?with_netapi:out}-netapi \
338 --with-openal \
339 --with-opencl \
c504380e 340 --with-opengl \
d7296a19 341 --with-osmesa \
c504380e 342 --with-oss \
c54d2750 343 --with-pcap \
c504380e 344 --with-png \
d0d61ce7 345 --with-pthread \
c54d2750 346 --with-pulse \
c504380e 347 --with%{!?with_sane:out}-sane \
d7296a19
JK
348 --with-tiff \
349 --with-v4l \
beb8121e 350 --with-xcomposite \
351 --with-xcursor \
352 --with-xinerama \
353 --with-xinput \
d7296a19 354 --with-xinput2 \
c504380e 355 --with-xml \
beb8121e 356 --with-xrandr \
c504380e 357 --with-xrender \
358 --with-xshape \
359 --with-xshm \
360 --with-xslt \
beb8121e 361 --with-xxf86vm \
d7296a19
JK
362 --with-x \
363 --with-zlib
05eb066b 364%{__make} depend
4aafdd81 365%{__make}
e8f81a0a 366
5c4ec57b 367%install
368rm -rf $RPM_BUILD_ROOT
ffb676e0 369install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
370%{__make} install \
371 DESTDIR=$RPM_BUILD_ROOT
372
a26a3859 373install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 374cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 375
2a437456 376install -d \
65c325f6 377 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
378 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 379 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
380 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
381 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
382
a91c2692 383touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
384touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
385touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
386
76055aa1 387cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 388[mci]
389cdaudio=mcicda.drv
390sequencer=mciseq.drv
391waveaudio=mciwave.drv
392avivideo=mciavi.drv
393videodisc=mcipionr.drv
394vcr=mciviscd.drv
395MPEGVideo=mciqtz.drv
5c4ec57b 396EOF
397
80496098 398# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 399
887fffcf
ER
400dir=$(pwd)
401> files.so
402> files.programs
55a96819 403cd $RPM_BUILD_ROOT%{_libdir}/wine
404for f in *.so; do
16e36f25 405 case $f in
ad4623a1 406 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
407 ;;
408 *)
409 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 410 esac
55a96819 411done
412cd -
887fffcf
ER
413
414programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 415for p in $programs; do
8d493411 416 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
417 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 418 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 419 grep -v "$p\.exe\.so$" files.so > files.so.
420 mv -f files.so. files.so
55a96819 421done
55a96819 422
a26a3859
JK
423for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
424 mv "$dir" "${dir%.UTF-8}"
425done
426
f6cf693b 427%ifarch %{x8664}
c54d2750
JK
428install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
429for lang in de fr pl ; do
430install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
431install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
432done
433%else
434install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
435for lang in de fr pl ; do
436install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
437install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
438done
439%endif
440
f7357f09 441install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 442%ifnarch %{x8664}
db80a28e 443cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 444%else
db80a28e 445cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 446%endif
f7357f09 447
887fffcf 448install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
449cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
450cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 451
5c4ec57b 452%clean
453rm -rf $RPM_BUILD_ROOT
454
8df63af6 455%post
db80a28e 456/sbin/ldconfig
8df63af6
ER
457%update_desktop_database
458
f1f3af79
JB
459%postun -p /sbin/ldconfig
460
d142aa07 461%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 462rm -f /var/lock/subsys/wine
d142aa07
JB
463if [ -x /sbin/chkconfig ]; then
464 /sbin/chkconfig --del wine
465fi
466
55a96819 467%files -f files.so
5c4ec57b 468%defattr(644,root,root,755)
47bd64d5 469%doc README AUTHORS ANNOUNCE
12b1296e 470%lang(de) %doc documentation/README.de
471%lang(es) %doc documentation/README.es
472%lang(fr) %doc documentation/README.fr
0aac4f59 473%lang(hu) %doc documentation/README.hu
12b1296e 474%lang(it) %doc documentation/README.it
7b9e958b 475%lang(ko) %doc documentation/README.ko
58a0e5f4 476%lang(nb) %doc documentation/README.no
12b1296e 477%lang(pt) %doc documentation/README.pt
74de5921 478%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
479%lang(ru) %doc documentation/README.ru
480%lang(sv) %doc documentation/README.sv
481%lang(tr) %doc documentation/README.tr
82432451 482%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
483%ifnarch %{x8664}
484%attr(755,root,root) %{_bindir}/wine
485%else
486%attr(755,root,root) %{_bindir}/wine64
487%endif
d479f953 488%attr(755,root,root) %{_bindir}/wineboot
55a96819 489%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 490%attr(755,root,root) %{_bindir}/winecfg
beafc810 491%ifnarch %{x8664}
f829f028 492%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
493%else
494%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 495%endif
beafc810 496%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 497%attr(755,root,root) %{_libdir}/*.so*
861238d3 498%dir %{_libdir}/wine
61e39970 499%dir %{_libdir}/wine/fakedlls
500%{_libdir}/wine/fakedlls/*.acm
501%{_libdir}/wine/fakedlls/*.cpl
502%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
503%ifarch %{ix86}
504%{_libdir}/wine/fakedlls/*.dll16
505%endif
61e39970 506%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
507%ifarch %{ix86}
508%{_libdir}/wine/fakedlls/*.drv16
509%endif
61e39970 510%{_libdir}/wine/fakedlls/*.ds
511%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
512%ifarch %{ix86}
513%{_libdir}/wine/fakedlls/*.exe16
514%{_libdir}/wine/fakedlls/*.mod16
515%endif
61e39970 516%{_libdir}/wine/fakedlls/*.ocx
517%{_libdir}/wine/fakedlls/*.sys
518%{_libdir}/wine/fakedlls/*.tlb
f829f028 519%ifarch %{ix86}
61e39970 520%{_libdir}/wine/fakedlls/*.vxd
f829f028 521%endif
f6cf693b 522%ifnarch %{x8664}
b86f1c34 523%{_mandir}/man1/wine.1*
47bd64d5
JK
524%lang(de) %{_mandir}/de/man1/wine.1*
525%lang(fr) %{_mandir}/fr/man1/wine.1*
526%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
527%else
528%{_mandir}/man1/wine64.1*
529%lang(de) %{_mandir}/de/man1/wine64.1*
530%lang(fr) %{_mandir}/fr/man1/wine64.1*
531%lang(pl) %{_mandir}/pl/man1/wine64.1*
532%endif
da274952
AG
533%{_mandir}/man1/msiexec.1*
534%{_mandir}/man1/wineboot.1*
535%{_mandir}/man1/winecfg.1*
72ede285 536%{_mandir}/man1/winedbg.1*
b86f1c34 537%{_mandir}/man1/wineserver.1*
ad4623a1
AM
538%lang(de) %{_mandir}/de/man1/wineserver.1*
539%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 540%{_winedir}
a6c536e0 541%{_desktopdir}/wine.desktop
76055aa1 542%{_desktopdir}/wine-uninstaller.desktop
887fffcf 543%{_pixmapsdir}/%{name}.png
5c4ec57b 544
55a96819 545%files programs -f files.programs
e8f81a0a 546%defattr(644,root,root,755)
e8f81a0a 547
5c4ec57b 548%files devel
549%defattr(644,root,root,755)
a26a3859 550%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 551%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 552%attr(755,root,root) %{_bindir}/widl
55a96819 553%attr(755,root,root) %{_bindir}/winebuild
55a96819 554%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 555%attr(755,root,root) %{_bindir}/wineg++
d479f953 556%attr(755,root,root) %{_bindir}/winegcc
557%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 558%attr(755,root,root) %{_bindir}/winecpp
55a96819 559%attr(755,root,root) %{_bindir}/wmc
d479f953 560%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
561%{_libdir}/wine/lib*.def
562# no shared variants, so not separated
563%{_libdir}/wine/lib*.def.a
b93e474e 564%{_libdir}/wine/libadsiid.a
7265d9f2 565%{_libdir}/wine/libdx*.a
beafc810 566%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
567%{_libdir}/wine/libstrmiids.a
568%{_libdir}/wine/libuuid.a
569%{_libdir}/wine/libwinecrt0.a
5c4ec57b 570%{_includedir}/wine
34f03014 571%{_mandir}/man1/widl.1*
0aac4f59 572%{_mandir}/man1/winebuild.1*
da274952 573%{_mandir}/man1/winecpp.1*
34f03014 574%{_mandir}/man1/winedump.1*
bff06719 575%{_mandir}/man1/winegcc.1*
5ec7e550 576%{_mandir}/man1/wineg++.1*
34f03014 577%{_mandir}/man1/winemaker.1*
0aac4f59 578%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 579%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
580%{_mandir}/man1/wmc.1*
581%{_mandir}/man1/wrc.1*
2b5050a8 582%{_aclocaldir}/*.m4
f18f723c 583
beafc810
MM
584%files dll-capi
585%defattr(644,root,root,755)
586%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
587
16e36f25
JB
588%files dll-d3d
589%defattr(644,root,root,755)
590%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
591%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
592%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
593
594%files dll-gl
595%defattr(644,root,root,755)
596%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
597%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
598
599%if %{with sane}
600%files dll-twain
601%defattr(644,root,root,755)
b08b16bf 602%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 603%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
604%endif
605
9d6715c4
ER
606%if %{with ldap}
607%files dll-ldap
608%defattr(644,root,root,755)
609%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
610%endif
611
16e36f25
JB
612%if %{with alsa}
613%files drv-alsa
614%defattr(644,root,root,755)
615%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
616%endif
617
16e36f25 618# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
619# ddraw.dll.so,winex11.drv.so depend on X11 libs
620# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 3.690162 seconds and 4 git commands to generate.