]> git.pld-linux.org Git - packages/wine.git/blob - wine.spec
cleanup obviously bogus deps
[packages/wine.git] / wine.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # don't build ALSA mm driver
4 %bcond_without  capi            # don't build CAPI 2.0 (ISDN) support
5 %bcond_without  gstreamer       # don't build GStreamer filters support
6 %bcond_without  sane            # don't build TWAIN DLL with scanning support (through SANE)
7 %bcond_with     hal             # HAL dynamic device support [deprecated]
8 %bcond_without  ldap            # don't build LDAP DLL
9 %bcond_without  cups            # without CUPS printing support in winspool,wineps DLLs
10 %bcond_without  netapi          # don't use the Samba NetAPI library
11 #
12 # NOTE: wine detects the following SONAMES for dlopen at build time:
13 #   libGL (winex11.drv.so)
14 #   libOSMesa (gdi32.dll.so)
15 #   libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16 #   libcapi20 (capi2032.dll.so)
17 #   libcups (winspool.drv.so)
18 #   libdbus (mountmgr.sys.so)
19 #   libfontconfig (gdi32.dll.so)
20 #   libfreetype (gdi32.dll.so)
21 #   libgnutls (secur32.dll.so)
22 #   libhal (mountmgr.sys.so)
23 #   libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24 #   libncurses (kernel32.dll.so)
25 #   libodbc (odbc32.dll.so)
26 #   libpng (windowscodecs.dll.so)
27 #   libsane (sane.ds.so)
28 #   libtiff (windowscodecs.dll.so)
29 #   libv4l1 (qcap.dll.so)
30 #   libxslt (msxml3.dll.so)
31 # thus requires rebuild after change of any of the above.
32
33 # library qualifier in rpm generated deps
34 %ifarch %{x8664} ia64 ppc64 s390x sparc64
35 %define libqual ()(64bit)
36 %else
37 %define libqual %{nil}
38 %endif
39
40 %define         gecko_ver       2.24
41 Summary:        Program that lets you launch Win applications
42 Summary(es.UTF-8):      Ejecuta programas Windows en Linux
43 Summary(pl.UTF-8):      Program pozwalający uruchamiać aplikacje Windows
44 Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
45 Name:           wine
46 # 1.8.x – stable
47 # 1.9.x – development
48 Version:        1.8
49 Release:        1
50 Epoch:          1
51 License:        LGPL
52 Group:          Applications/Emulators
53 Source0:        http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
54 # Source0-md5:  96b51a2f2ae727802d71095354e69fef
55 Source1:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
56 # Source1-md5:  766bb034172f7f0a97443951a02a0df8
57 Source2:        http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
58 # Source2-md5:  1912fd191872c72d5f562283e44e8ab4
59 Source3:        %{name}-uninstaller.desktop
60 Patch0:         %{name}-gphoto2_bool.patch
61 Patch1:         %{name}-makedep.patch
62 Patch2:         %{name}-ncurses.patch
63 Patch4:         %{name}-disable-valgrind.patch
64 Patch5:         %{name}-ca_certificates.patch
65 Patch6:         desktop.patch
66 Patch7:         %{name}-wine64_man.patch
67 URL:            http://www.winehq.org/
68 BuildRequires:  Mesa-libOSMesa-devel
69 BuildRequires:  OpenAL-devel >= 1.1
70 BuildRequires:  OpenCL-devel
71 BuildRequires:  OpenGL-GLU-devel
72 BuildRequires:  OpenGL-GLX-devel
73 BuildRequires:  Mesa-libOSMesa-devel
74 %{?with_alsa:BuildRequires:     alsa-lib-devel}
75 %{?with_arts:BuildRequires:     artsc-devel}
76 BuildRequires:  autoconf >= 2.62
77 BuildRequires:  automake
78 BuildRequires:  bison
79 %{?with_capi:BuildRequires:     capi4k-utils-devel}
80 %{?with_cups:BuildRequires:     cups-devel}
81 BuildRequires:  dbus-devel
82 BuildRequires:  docbook-dtd31-sgml
83 BuildRequires:  docbook-utils
84 BuildRequires:  flex >= 2.5.33
85 BuildRequires:  fontconfig-devel
86 BuildRequires:  fontforge
87 BuildRequires:  freetype-devel >= 2.0.5
88 # for findup used after make install
89 BuildRequires:  fslint
90 BuildRequires:  gegl-devel
91 BuildRequires:  gettext-devel
92 %ifarch %{x8664}
93 BuildRequires:  gcc >= 6:4.4
94 %endif
95 BuildRequires:  gettext-tools
96 BuildRequires:  giflib-devel
97 BuildRequires:  gnutls-devel
98 %{?with_gstreamer:BuildRequires:        gstreamer0.10-devel >= 0.10}
99 %{?with_gstreamer:BuildRequires:        gstreamer0.10-plugins-base-devel >= 0.10}
100 %{?with_hal:BuildRequires:      hal-devel}
101 # for icotool used in build
102 BuildRequires:  icoutils >= 0.29.0
103 BuildRequires:  lcms2-devel >= 2
104 BuildRequires:  libgphoto2-devel
105 BuildRequires:  libgsm-devel
106 BuildRequires:  libjpeg-devel
107 BuildRequires:  libmpg123-devel >= 1.5.0
108 BuildRequires:  libcap-devel
109 BuildRequires:  libpcap-devel
110 BuildRequires:  libpng-devel >= 1.5
111 BuildRequires:  libtiff-devel
112 BuildRequires:  libtool
113 BuildRequires:  libv4l-devel
114 BuildRequires:  libxml2-devel >= 2.0
115 BuildRequires:  libxslt-devel
116 BuildRequires:  ncurses-devel
117 # db2* failed previously - probably openjade or opensp bug
118 BuildRequires:  openjade >= 1:1.3.3-0.pre1
119 %{?with_ldap:BuildRequires:     openldap-devel}
120 BuildRequires:  opensp >= 1:1.5.1
121 BuildRequires:  pulseaudio-devel
122 BuildRequires:  pkgconfig
123 BuildRequires:  prelink
124 BuildRequires:  samba-devel
125 %{?with_sane:BuildRequires:     sane-backends-devel}
126 BuildRequires:  unixODBC-devel >= 2.2.12-2
127 #BuildRequires: valgrind
128 BuildRequires:  xorg-lib-libX11-devel
129 BuildRequires:  xorg-lib-libXcomposite-devel
130 BuildRequires:  xorg-lib-libXcursor-devel
131 BuildRequires:  xorg-lib-libXext-devel
132 BuildRequires:  xorg-lib-libXi-devel
133 BuildRequires:  xorg-lib-libXinerama-devel
134 BuildRequires:  xorg-lib-libXrandr-devel
135 BuildRequires:  xorg-lib-libXrender-devel
136 BuildRequires:  xorg-lib-libXxf86vm-devel
137 BuildRequires:  zlib-devel
138 Requires:       libfreetype.so.6%{libqual}
139 Requires:       libpng16.so.16%{libqual}
140 Requires(post): /sbin/ldconfig
141 Suggests:       binfmt-detector
142 Suggests:       ca-certificates
143 Suggests:       cabextract
144 Conflicts:      ca-certificates < 20080809-4
145 # for printing needs lpr
146 Suggests:       cups-clients
147 # for winelauncher
148 Suggests:       xorg-app-xmessage
149 # for ntlm_auth
150 Suggests:       samba-common >= 1:3.0.25
151 # link to wine/ntdll.dll.so, without any SONAME
152 Provides:       libntdll.dll.so
153 Obsoletes:      wine-doc-pdf
154 Obsoletes:      wine-drv-arts
155 Obsoletes:      wine-drv-jack
156 Obsoletes:      wine-drv-nas
157 ExclusiveArch:  %{ix86} %{x8664} arm
158 ExcludeArch:    i386
159 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
160
161 %define         no_install_post_strip   1
162
163 %define         _winedir                %{_datadir}/%{name}
164
165 %description
166 Wine is a program which allows running Microsoft Windows programs
167 (including DOS, Windows 3.x and Win32 executables) on Unix. It
168 consists of a program loader which loads and executes a Microsoft
169 Windows binary, and a library that implements Windows API calls using
170 their Unix or X11 equivalents. The library may also be used for
171 porting Win32 code into native Unix executables.
172
173 %description -l es.UTF-8
174 Ejecuta programas Windows en Linux.
175
176 %description -l pl.UTF-8
177 Wine jest programem dzięki któremu można uruchamiać programy napisane
178 dla Microsoft Windows pod systemami uniksowymi. Składa się on z
179 loadera, który pozwala wczytywać i uruchamiać programy w formacie
180 Microsoft Windows, oraz z biblioteki, która implementuje API Windows
181 przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
182 także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
183
184 %description -l pt_BR.UTF-8
185 O Wine é um programa que permite rodar programas MS-Windows no X11.
186 Ele consiste de um carregador de programa, que carrega e executa um
187 binário MS-Windows, e de uma biblioteca de emulação que traduz as
188 chamadas da API para as equivalentes Unix/X11.
189
190 %package devel
191 Summary:        Wine - header files
192 Summary(es.UTF-8):      Biblioteca de desarrollo de wine
193 Summary(pl.UTF-8):      Wine - pliki nagłowkowe
194 Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
195 Group:          Development/Libraries
196 Requires:       %{name} = %{epoch}:%{version}-%{release}
197
198 %description devel
199 Wine - header files.
200
201 %description devel -l es.UTF-8
202 Biblioteca de desarrollo de wine.
203
204 %description devel -l pl.UTF-8
205 Wine - pliki nagłówkowe.
206
207 %description devel -l pt_BR.UTF-8
208 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
209 WINE.
210
211 %package programs
212 Summary:        Wine - programs
213 Summary(pl.UTF-8):      Wine - programy
214 Group:          Applications
215 Requires:       %{name} = %{epoch}:%{version}-%{release}
216
217 %description programs
218 Wine - programs.
219
220 %description programs -l pl.UTF-8
221 Wine - programy.
222
223 %package dll-capi
224 Summary:        CAPI 2.0 (ISDN) implementation DLLs for Wine
225 Summary(pl.UTF-8):      Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
226 Group:          Applications/Emulators
227 Requires:       %{name} = %{epoch}:%{version}-%{release}
228
229 %description dll-capi
230 CAPI 2.0 (ISDN) implementation DLLs for Wine.
231
232 %description dll-capi -l pl.UTF-8
233 Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
234
235 %package dll-d3d
236 Summary:        Direct3D implementation DLLs for Wine
237 Summary(pl.UTF-8):      Biblioteki DLL z implementacją Direct3D dla Wine
238 Group:          Applications/Emulators
239 Requires:       %{name} = %{epoch}:%{version}-%{release}
240 Requires:       OpenGL
241
242 %description dll-d3d
243 Direct3D implementation DLLs for Wine (through OpenGL).
244
245 %description dll-d3d -l pl.UTF-8
246 Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
247
248 %package dll-gl
249 Summary:        OpenGL implementation DLLs for Wine
250 Summary(pl.UTF-8):      Biblioteki DLL z implementacją OpenGL dla Wine
251 Group:          Applications/Emulators
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253 Requires:       OpenGL
254
255 %description dll-gl
256 OpenGL implementation DLLs for Wine.
257
258 %description dll-gl -l pl.UTF-8
259 Biblioteki DLL z implementacją OpenGL dla Wine.
260
261 %package dll-twain
262 Summary:        TWAIN implementation DLL for Wine
263 Summary(pl.UTF-8):      Biblioteka DLL z implementacją TWAIN dla Wine
264 Group:          Applications/Emulators
265 Requires:       %{name} = %{epoch}:%{version}-%{release}
266
267 %description dll-twain
268 TWAIN implementation DLL for Wine (through SANE).
269
270 %description dll-twain -l pl.UTF-8
271 Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
272
273 %package dll-ldap
274 Summary:        Win32 LDAP API DLL for Wine
275 Summary(pl.UTF-8):      Biblioteka DLL z implementacją API Win32 LDAP dla Wine
276 Group:          Applications/Emulators
277 Requires:       %{name} = %{epoch}:%{version}-%{release}
278
279 %description dll-ldap
280 Lightweight Directory Access Protocol Library for Wine.
281
282 %description dll-ldap -l pl.UTF-8
283 Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
284
285 %package drv-alsa
286 Summary:        ALSA driver for WINE mm.dll implementation
287 Summary(pl.UTF-8):      Sterownik ALSA dla implementacji mm.dll w Wine
288 Group:          Applications/Emulators
289 Requires:       %{name} = %{epoch}:%{version}-%{release}
290
291 %description drv-alsa
292 ALSA driver for WINE mm.dll (multimedia system) implementation.
293
294 %description drv-alsa -l pl.UTF-8
295 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
296
297 %prep
298 %setup -q
299 %patch0 -p1
300 %patch1 -p1
301 %patch2 -p1
302 %patch4 -p1
303 %patch5 -p1
304 %patch6 -p1
305 %ifarch %{x8664}
306 %patch7 -p1
307 %endif
308
309 %build
310 icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
311 mv -f oic_winlogo_*.png %{name}.png
312
313 %{__autoconf}
314 %{__autoheader}
315 %configure \
316 %ifarch %{x8664}
317         --enable-win64 \
318 %endif
319         --with-alsa%{!?with_alsa:=no} \
320         --with-capi%{!?with_capi:=no} \
321         --with-cms \
322         --with-coreaudio \
323         --with-cups%{!?with_cups:=no} \
324         --with-curses \
325         --with-dbus \
326         --with-fontconfig \
327         --with-freetype \
328         --with-gphoto \
329         --with-glu \
330         --with-gnutls \
331         --with-gsm \
332         %{__with_without gstreamer} \
333         %{__with_without hal} \
334         --with-jpeg \
335         --with-ldap%{!?with_ldap:=no} \
336         --with-mpg123 \
337         --with%{!?with_netapi:out}-netapi \
338         --with-openal \
339         --with-opencl \
340         --with-opengl \
341         --with-osmesa \
342         --with-oss \
343         --with-pcap \
344         --with-png \
345         --with-pthread \
346         --with-pulse \
347         --with%{!?with_sane:out}-sane \
348         --with-tiff \
349         --with-v4l \
350         --with-xcomposite \
351         --with-xcursor \
352         --with-xinerama \
353         --with-xinput \
354         --with-xinput2 \
355         --with-xml \
356         --with-xrandr \
357         --with-xrender \
358         --with-xshape \
359         --with-xshm \
360         --with-xslt \
361         --with-xxf86vm \
362         --with-x \
363         --with-zlib
364 %{__make} depend
365 %{__make}
366
367 %install
368 rm -rf $RPM_BUILD_ROOT
369 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
370 %{__make} install \
371         DESTDIR=$RPM_BUILD_ROOT
372
373 install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
374 cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
375
376 install -d \
377         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
378         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
379         $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
380         $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
381         $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
382
383 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
384 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
385 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
386
387 cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
388 [mci]
389 cdaudio=mcicda.drv
390 sequencer=mciseq.drv
391 waveaudio=mciwave.drv
392 avivideo=mciavi.drv
393 videodisc=mcipionr.drv
394 vcr=mciviscd.drv
395 MPEGVideo=mciqtz.drv
396 EOF
397
398 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
399
400 dir=$(pwd)
401 > files.so
402 > files.programs
403 cd $RPM_BUILD_ROOT%{_libdir}/wine
404 for f in *.so; do
405         case $f in
406         capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
407                 ;;
408         *)
409                 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
410         esac
411 done
412 cd -
413
414 programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
415 for p in $programs; do
416         echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
417         echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
418         echo "%{_mandir}/man1/$p.1*" >> files.programs
419         grep -v "$p\.exe\.so$" files.so > files.so.
420         mv -f files.so. files.so
421 done
422
423 for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
424         mv "$dir" "${dir%.UTF-8}"
425 done
426
427 %ifarch %{x8664}
428 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
429 for lang in de fr pl ; do
430 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
431 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
432 done
433 %else
434 install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
435 for lang in de fr pl ; do
436 install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
437 install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
438 done
439 %endif
440
441 install -d $RPM_BUILD_ROOT%{_winedir}/gecko
442 %ifnarch %{x8664}
443 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
444 %else
445 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
446 %endif
447
448 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
449 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
450 cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post
456 /sbin/ldconfig
457 %update_desktop_database
458
459 %postun -p /sbin/ldconfig
460
461 %triggerpostun -- wine < 1:0.9.12-1.9
462 rm -f /var/lock/subsys/wine
463 if [ -x /sbin/chkconfig ]; then
464         /sbin/chkconfig --del wine
465 fi
466
467 %files -f files.so
468 %defattr(644,root,root,755)
469 %doc README AUTHORS ANNOUNCE
470 %lang(de) %doc documentation/README.de
471 %lang(es) %doc documentation/README.es
472 %lang(fr) %doc documentation/README.fr
473 %lang(hu) %doc documentation/README.hu
474 %lang(it) %doc documentation/README.it
475 %lang(ko) %doc documentation/README.ko
476 %lang(nb) %doc documentation/README.no
477 %lang(pt) %doc documentation/README.pt
478 %lang(pt_BR) %doc documentation/README.pt_br
479 %lang(ru) %doc documentation/README.ru
480 %lang(sv) %doc documentation/README.sv
481 %lang(tr) %doc documentation/README.tr
482 %attr(755,root,root) %{_bindir}/msiexec
483 %ifnarch %{x8664}
484 %attr(755,root,root) %{_bindir}/wine
485 %else
486 %attr(755,root,root) %{_bindir}/wine64
487 %endif
488 %attr(755,root,root) %{_bindir}/wineboot
489 %attr(755,root,root) %{_bindir}/winedbg
490 %attr(755,root,root) %{_bindir}/winecfg
491 %ifnarch %{x8664}
492 %attr(755,root,root) %{_bindir}/wine-preloader
493 %else
494 %attr(755,root,root) %{_bindir}/wine64-preloader
495 %endif
496 %attr(755,root,root) %{_bindir}/wineserver
497 %attr(755,root,root) %{_libdir}/*.so*
498 %dir %{_libdir}/wine
499 %dir %{_libdir}/wine/fakedlls
500 %{_libdir}/wine/fakedlls/*.acm
501 %{_libdir}/wine/fakedlls/*.cpl
502 %{_libdir}/wine/fakedlls/*.dll
503 %ifarch %{ix86}
504 %{_libdir}/wine/fakedlls/*.dll16
505 %endif
506 %{_libdir}/wine/fakedlls/*.drv
507 %ifarch %{ix86}
508 %{_libdir}/wine/fakedlls/*.drv16
509 %endif
510 %{_libdir}/wine/fakedlls/*.ds
511 %{_libdir}/wine/fakedlls/*.exe
512 %ifarch %{ix86}
513 %{_libdir}/wine/fakedlls/*.exe16
514 %{_libdir}/wine/fakedlls/*.mod16
515 %endif
516 %{_libdir}/wine/fakedlls/*.ocx
517 %{_libdir}/wine/fakedlls/*.sys
518 %{_libdir}/wine/fakedlls/*.tlb
519 %ifarch %{ix86}
520 %{_libdir}/wine/fakedlls/*.vxd
521 %endif
522 %ifnarch %{x8664}
523 %{_mandir}/man1/wine.1*
524 %lang(de) %{_mandir}/de/man1/wine.1*
525 %lang(fr) %{_mandir}/fr/man1/wine.1*
526 %lang(pl) %{_mandir}/pl/man1/wine.1*
527 %else
528 %{_mandir}/man1/wine64.1*
529 %lang(de) %{_mandir}/de/man1/wine64.1*
530 %lang(fr) %{_mandir}/fr/man1/wine64.1*
531 %lang(pl) %{_mandir}/pl/man1/wine64.1*
532 %endif
533 %{_mandir}/man1/msiexec.1*
534 %{_mandir}/man1/wineboot.1*
535 %{_mandir}/man1/winecfg.1*
536 %{_mandir}/man1/winedbg.1*
537 %{_mandir}/man1/wineserver.1*
538 %lang(de) %{_mandir}/de/man1/wineserver.1*
539 %lang(fr) %{_mandir}/fr/man1/wineserver.1*
540 %{_winedir}
541 %{_desktopdir}/wine.desktop
542 %{_desktopdir}/wine-uninstaller.desktop
543 %{_pixmapsdir}/%{name}.png
544
545 %files programs -f files.programs
546 %defattr(644,root,root,755)
547
548 %files devel
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/sfnt2fon
551 %attr(755,root,root) %{_bindir}/function_grep.pl
552 %attr(755,root,root) %{_bindir}/widl
553 %attr(755,root,root) %{_bindir}/winebuild
554 %attr(755,root,root) %{_bindir}/winedump
555 %attr(755,root,root) %{_bindir}/wineg++
556 %attr(755,root,root) %{_bindir}/winegcc
557 %attr(755,root,root) %{_bindir}/winemaker
558 %attr(755,root,root) %{_bindir}/winecpp
559 %attr(755,root,root) %{_bindir}/wmc
560 %attr(755,root,root) %{_bindir}/wrc
561 %{_libdir}/wine/lib*.def
562 # no shared variants, so not separated
563 %{_libdir}/wine/lib*.def.a
564 %{_libdir}/wine/libadsiid.a
565 %{_libdir}/wine/libdx*.a
566 %{_libdir}/wine/libstrmbase.a
567 %{_libdir}/wine/libstrmiids.a
568 %{_libdir}/wine/libuuid.a
569 %{_libdir}/wine/libwinecrt0.a
570 %{_includedir}/wine
571 %{_mandir}/man1/widl.1*
572 %{_mandir}/man1/winebuild.1*
573 %{_mandir}/man1/winecpp.1*
574 %{_mandir}/man1/winedump.1*
575 %{_mandir}/man1/winegcc.1*
576 %{_mandir}/man1/wineg++.1*
577 %{_mandir}/man1/winemaker.1*
578 %lang(de) %{_mandir}/de/man1/winemaker.1*
579 %lang(fr) %{_mandir}/fr/man1/winemaker.1*
580 %{_mandir}/man1/wmc.1*
581 %{_mandir}/man1/wrc.1*
582 %{_aclocaldir}/*.m4
583
584 %files dll-capi
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
587
588 %files dll-d3d
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
591 %attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
592 %attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
593
594 %files dll-gl
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/wine/glu32.dll.so
597 %attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
598
599 %if %{with sane}
600 %files dll-twain
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/wine/sane.ds.so
603 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
604 %endif
605
606 %if %{with ldap}
607 %files dll-ldap
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
610 %endif
611
612 %if %{with alsa}
613 %files drv-alsa
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
616 %endif
617
618 # additional dependencies in *.so not separated (yet?) from main package
619 #   ddraw.dll.so,winex11.drv.so depend on X11 libs
620 #   ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.176044 seconds and 4 git commands to generate.