]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
Release: 1
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
5b49e814 7%bcond_with hal # HAL dynamic device support [deprecated]
9d6715c4 8%bcond_without ldap # don't build LDAP DLL
16e36f25 9%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 10%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
13# libGL (winex11.drv.so)
14# libOSMesa (gdi32.dll.so)
15# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16# libcapi20 (capi2032.dll.so)
17# libcups (winspool.drv.so)
18# libdbus (mountmgr.sys.so)
16e36f25 19# libfontconfig (gdi32.dll.so)
5b49e814
JB
20# libfreetype (gdi32.dll.so)
21# libgnutls (secur32.dll.so)
22# libhal (mountmgr.sys.so)
23# libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
26# libpng (windowscodecs.dll.so)
27# libsane (sane.ds.so)
28# libtiff (windowscodecs.dll.so)
29# libv4l1 (qcap.dll.so)
30# libxslt (msxml3.dll.so)
546bbb82 31# thus requires rebuild after change of any of the above.
db80a28e 32
4ce8abe1
ER
33# library qualifier in rpm generated deps
34%ifarch %{x8664} ia64 ppc64 s390x sparc64
35%define libqual ()(64bit)
36%else
37%define libqual %{nil}
38%endif
39
c516c269 40%define gecko_ver 2.24
698e86e7 41Summary: Program that lets you launch Win applications
93e41e44
ER
42Summary(es.UTF-8): Ejecuta programas Windows en Linux
43Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
44Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 45Name: wine
cbe4db03
JK
46# 1.8.x – stable
47# 1.9.x – development
c54d2750 48Version: 1.8
9dad7a50 49Release: 1
46114a9a 50Epoch: 1
528c1138 51License: LGPL
5c4ec57b 52Group: Applications/Emulators
beafc810 53Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
c54d2750 54# Source0-md5: 96b51a2f2ae727802d71095354e69fef
beafc810 55Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
c516c269 56# Source1-md5: 766bb034172f7f0a97443951a02a0df8
beafc810 57Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
c516c269 58# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
beafc810 59Source3: %{name}-uninstaller.desktop
55061442 60Patch0: %{name}-gphoto2_bool.patch
a0ff0658 61Patch1: %{name}-makedep.patch
a4a10255 62Patch2: %{name}-ncurses.patch
8b4bf701 63Patch4: %{name}-disable-valgrind.patch
5312a936 64Patch5: %{name}-ca_certificates.patch
a26a3859
JK
65Patch6: desktop.patch
66Patch7: %{name}-wine64_man.patch
1b3d8891 67URL: http://www.winehq.org/
5b49e814 68BuildRequires: Mesa-libOSMesa-devel
0aac4f59 69BuildRequires: OpenAL-devel >= 1.1
5b49e814 70BuildRequires: OpenCL-devel
489ca66c 71BuildRequires: OpenGL-GLU-devel
5b49e814 72BuildRequires: OpenGL-GLX-devel
d7296a19 73BuildRequires: Mesa-libOSMesa-devel
6547534c
KK
74%{?with_alsa:BuildRequires: alsa-lib-devel}
75%{?with_arts:BuildRequires: artsc-devel}
5b49e814 76BuildRequires: autoconf >= 2.62
c7af491d 77BuildRequires: automake
d3c41437 78BuildRequires: bison
beafc810 79%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 80%{?with_cups:BuildRequires: cups-devel}
5b49e814 81BuildRequires: dbus-devel
f88a3451 82BuildRequires: docbook-dtd31-sgml
83BuildRequires: docbook-utils
5b49e814 84BuildRequires: flex >= 2.5.33
16e36f25 85BuildRequires: fontconfig-devel
22432818 86BuildRequires: fontforge
5fc34681 87BuildRequires: freetype-devel >= 2.0.5
5b49e814 88# for findup used after make install
16b3dd87 89BuildRequires: fslint
5b49e814
JB
90%ifarch %{x8664}
91BuildRequires: gcc >= 6:4.4
92%endif
1f0c428e 93BuildRequires: gettext-tools
734deeec 94BuildRequires: giflib-devel
c57a98fe 95BuildRequires: gnutls-devel
5b49e814
JB
96%{?with_gstreamer:BuildRequires: gstreamer0.10-devel >= 0.10}
97%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10}
98%{?with_hal:BuildRequires: hal-devel}
99# for icotool used in build
100BuildRequires: icoutils >= 0.29.0
101BuildRequires: lcms2-devel >= 2
beb8121e 102BuildRequires: libgphoto2-devel
d0d61ce7 103BuildRequires: libgsm-devel
c504380e 104BuildRequires: libjpeg-devel
2341e633 105BuildRequires: libmpg123-devel >= 1.5.0
c54d2750 106BuildRequires: libcap-devel
5b49e814
JB
107BuildRequires: libpng-devel >= 1.5
108BuildRequires: libtiff-devel
1e160e6e 109BuildRequires: libtool
0aac4f59 110BuildRequires: libv4l-devel
5b49e814 111BuildRequires: libxml2-devel >= 2.0
fbb1220c 112BuildRequires: libxslt-devel
8a1d358f 113BuildRequires: ncurses-devel
16e36f25
JB
114# db2* failed previously - probably openjade or opensp bug
115BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 116%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 117BuildRequires: opensp >= 1:1.5.1
50f0bbbe 118BuildRequires: pulseaudio-devel
beb8121e 119BuildRequires: pkgconfig
beafc810 120BuildRequires: prelink
d7296a19 121BuildRequires: samba-devel
5715e1d1 122%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 123BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 124#BuildRequires: valgrind
5b49e814 125BuildRequires: xorg-lib-libX11-devel
beb8121e 126BuildRequires: xorg-lib-libXcomposite-devel
127BuildRequires: xorg-lib-libXcursor-devel
5b49e814 128BuildRequires: xorg-lib-libXext-devel
c66c3406 129BuildRequires: xorg-lib-libXi-devel
beb8121e 130BuildRequires: xorg-lib-libXinerama-devel
beb8121e 131BuildRequires: xorg-lib-libXrandr-devel
c66c3406 132BuildRequires: xorg-lib-libXrender-devel
c66c3406 133BuildRequires: xorg-lib-libXxf86vm-devel
5b49e814 134BuildRequires: zlib-devel
4ce8abe1 135Requires: libfreetype.so.6%{libqual}
a85c8746 136Requires: libpng16.so.16%{libqual}
8df63af6 137Requires(post): /sbin/ldconfig
ae42c99e 138Suggests: binfmt-detector
be70b824 139Suggests: ca-certificates
beafc810 140Suggests: cabextract
a2f68044 141Conflicts: ca-certificates < 20080809-4
b3d3861d 142# for printing needs lpr
143Suggests: cups-clients
f96e197b 144# for winelauncher
3bddfbf2 145Suggests: xorg-app-xmessage
f96e197b 146# for ntlm_auth
14e95129 147Suggests: samba-common >= 1:3.0.25
52b6007b
JB
148# link to wine/ntdll.dll.so, without any SONAME
149Provides: libntdll.dll.so
7212da21 150Obsoletes: wine-doc-pdf
93b34e12 151Obsoletes: wine-drv-arts
beafc810
MM
152Obsoletes: wine-drv-jack
153Obsoletes: wine-drv-nas
5b49e814 154ExclusiveArch: %{ix86} %{x8664} arm
206eed29 155ExcludeArch: i386
0403821a 156BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 157
e8f81a0a 158%define no_install_post_strip 1
159
e8f81a0a 160%define _winedir %{_datadir}/%{name}
6731627f 161
5c4ec57b 162%description
6731627f 163Wine is a program which allows running Microsoft Windows programs
a519bc4f 164(including DOS, Windows 3.x and Win32 executables) on Unix. It
165consists of a program loader which loads and executes a Microsoft
166Windows binary, and a library that implements Windows API calls using
167their Unix or X11 equivalents. The library may also be used for
168porting Win32 code into native Unix executables.
5c4ec57b 169
c967e47d 170%description -l es.UTF-8
f33a1517 171Ejecuta programas Windows en Linux.
172
c967e47d
JR
173%description -l pl.UTF-8
174Wine jest programem dzięki któremu można uruchamiać programy napisane
175dla Microsoft Windows pod systemami uniksowymi. Składa się on z
176loadera, który pozwala wczytywać i uruchamiać programy w formacie
177Microsoft Windows, oraz z biblioteki, która implementuje API Windows
178przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
179także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 180
c967e47d
JR
181%description -l pt_BR.UTF-8
182O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 183Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 184binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 185chamadas da API para as equivalentes Unix/X11.
186
5c4ec57b 187%package devel
7a050f82 188Summary: Wine - header files
93e41e44
ER
189Summary(es.UTF-8): Biblioteca de desarrollo de wine
190Summary(pl.UTF-8): Wine - pliki nagłowkowe
191Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 192Group: Development/Libraries
46114a9a 193Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 194
5c4ec57b 195%description devel
196Wine - header files.
197
c967e47d 198%description devel -l es.UTF-8
f33a1517 199Biblioteca de desarrollo de wine.
200
c967e47d
JR
201%description devel -l pl.UTF-8
202Wine - pliki nagłówkowe.
5c4ec57b 203
c967e47d
JR
204%description devel -l pt_BR.UTF-8
205Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 206WINE.
207
e8f81a0a 208%package programs
209Summary: Wine - programs
93e41e44 210Summary(pl.UTF-8): Wine - programy
e8f81a0a 211Group: Applications
46114a9a 212Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 213
214%description programs
0a7c5d50 215Wine - programs.
e8f81a0a 216
c967e47d 217%description programs -l pl.UTF-8
0a7c5d50 218Wine - programy.
e8f81a0a 219
beafc810
MM
220%package dll-capi
221Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
222Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
223Group: Applications/Emulators
224Requires: %{name} = %{epoch}:%{version}-%{release}
225
226%description dll-capi
b1df4aa7 227CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
228
229%description dll-capi -l pl.UTF-8
b1df4aa7 230Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 231
16e36f25
JB
232%package dll-d3d
233Summary: Direct3D implementation DLLs for Wine
93e41e44 234Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 235Group: Applications/Emulators
46114a9a 236Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
237Requires: OpenGL
238
239%description dll-d3d
240Direct3D implementation DLLs for Wine (through OpenGL).
241
c967e47d
JR
242%description dll-d3d -l pl.UTF-8
243Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
244
245%package dll-gl
246Summary: OpenGL implementation DLLs for Wine
93e41e44 247Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 248Group: Applications/Emulators
46114a9a 249Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
250Requires: OpenGL
251
252%description dll-gl
253OpenGL implementation DLLs for Wine.
254
c967e47d
JR
255%description dll-gl -l pl.UTF-8
256Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
257
258%package dll-twain
259Summary: TWAIN implementation DLL for Wine
93e41e44 260Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 261Group: Applications/Emulators
46114a9a 262Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
263
264%description dll-twain
265TWAIN implementation DLL for Wine (through SANE).
266
c967e47d
JR
267%description dll-twain -l pl.UTF-8
268Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 269
9d6715c4 270%package dll-ldap
db80a28e 271Summary: Win32 LDAP API DLL for Wine
b1df4aa7 272Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
273Group: Applications/Emulators
274Requires: %{name} = %{epoch}:%{version}-%{release}
275
276%description dll-ldap
b1df4aa7
JB
277Lightweight Directory Access Protocol Library for Wine.
278
279%description dll-ldap -l pl.UTF-8
280Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 281
16e36f25
JB
282%package drv-alsa
283Summary: ALSA driver for WINE mm.dll implementation
93e41e44 284Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 285Group: Applications/Emulators
46114a9a 286Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
287
288%description drv-alsa
289ALSA driver for WINE mm.dll (multimedia system) implementation.
290
c967e47d
JR
291%description drv-alsa -l pl.UTF-8
292Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 293
5c4ec57b 294%prep
db80a28e 295%setup -q
2fbbb535 296%patch0 -p1
297%patch1 -p1
ab25825d 298%patch2 -p1
8b4bf701 299%patch4 -p1
5312a936 300%patch5 -p1
3bfef0cd 301%patch6 -p1
f6cf693b 302%ifarch %{x8664}
a26a3859 303%patch7 -p1
f6cf693b 304%endif
591d55ba 305
5c4ec57b 306%build
887fffcf
ER
307icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
308mv -f oic_winlogo_*.png %{name}.png
309
2fbbb535 310%{__autoconf}
103d8328 311%{__autoheader}
9d6a128d 312%configure \
f829f028
AM
313%ifarch %{x8664}
314 --enable-win64 \
315%endif
5b49e814
JB
316 --with-alsa%{!?with_alsa:=no} \
317 --with-capi%{!?with_capi:=no} \
beb8121e 318 --with-cms \
d0d61ce7 319 --with-coreaudio \
5b49e814 320 --with-cups%{!?with_cups:=no} \
c504380e 321 --with-curses \
d7296a19 322 --with-dbus \
c504380e 323 --with-fontconfig \
324 --with-freetype \
d7296a19 325 --with-gphoto \
c504380e 326 --with-glu \
d0d61ce7 327 --with-gnutls \
d0d61ce7 328 --with-gsm \
8ec65640
JK
329 %{__with_without gstreamer} \
330 %{__with_without hal} \
c504380e 331 --with-jpeg \
5b49e814 332 --with-ldap%{!?with_ldap:=no} \
d0d61ce7 333 --with-mpg123 \
d7296a19
JK
334 --with%{!?with_netapi:out}-netapi \
335 --with-openal \
336 --with-opencl \
c504380e 337 --with-opengl \
d7296a19 338 --with-osmesa \
c504380e 339 --with-oss \
c54d2750 340 --with-pcap \
c504380e 341 --with-png \
d0d61ce7 342 --with-pthread \
c54d2750 343 --with-pulse \
c504380e 344 --with%{!?with_sane:out}-sane \
d7296a19
JK
345 --with-tiff \
346 --with-v4l \
beb8121e 347 --with-xcomposite \
348 --with-xcursor \
349 --with-xinerama \
350 --with-xinput \
d7296a19 351 --with-xinput2 \
c504380e 352 --with-xml \
beb8121e 353 --with-xrandr \
c504380e 354 --with-xrender \
355 --with-xshape \
356 --with-xshm \
357 --with-xslt \
beb8121e 358 --with-xxf86vm \
d7296a19
JK
359 --with-x \
360 --with-zlib
05eb066b 361%{__make} depend
4aafdd81 362%{__make}
e8f81a0a 363
5c4ec57b 364%install
365rm -rf $RPM_BUILD_ROOT
ffb676e0 366install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
367%{__make} install \
368 DESTDIR=$RPM_BUILD_ROOT
369
a26a3859 370install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 371cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 372
2a437456 373install -d \
65c325f6 374 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
375 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 376 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
377 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
378 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
379
a91c2692 380touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
381touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
382touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
383
76055aa1 384cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 385[mci]
386cdaudio=mcicda.drv
387sequencer=mciseq.drv
388waveaudio=mciwave.drv
389avivideo=mciavi.drv
390videodisc=mcipionr.drv
391vcr=mciviscd.drv
392MPEGVideo=mciqtz.drv
5c4ec57b 393EOF
394
80496098 395# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 396
887fffcf
ER
397dir=$(pwd)
398> files.so
399> files.programs
55a96819 400cd $RPM_BUILD_ROOT%{_libdir}/wine
401for f in *.so; do
16e36f25 402 case $f in
ad4623a1 403 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
404 ;;
405 *)
406 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 407 esac
55a96819 408done
409cd -
887fffcf
ER
410
411programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 412for p in $programs; do
8d493411 413 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
414 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 415 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 416 grep -v "$p\.exe\.so$" files.so > files.so.
417 mv -f files.so. files.so
55a96819 418done
55a96819 419
a26a3859
JK
420for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
421 mv "$dir" "${dir%.UTF-8}"
422done
423
f6cf693b 424%ifarch %{x8664}
c54d2750
JK
425install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
426for lang in de fr pl ; do
427install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
428install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
429done
430%else
431install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
432for lang in de fr pl ; do
433install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
434install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
435done
436%endif
437
f7357f09 438install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 439%ifnarch %{x8664}
db80a28e 440cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 441%else
db80a28e 442cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 443%endif
f7357f09 444
887fffcf 445install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
446cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
447cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 448
5c4ec57b 449%clean
450rm -rf $RPM_BUILD_ROOT
451
8df63af6 452%post
db80a28e 453/sbin/ldconfig
8df63af6
ER
454%update_desktop_database
455
f1f3af79
JB
456%postun -p /sbin/ldconfig
457
d142aa07 458%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 459rm -f /var/lock/subsys/wine
d142aa07
JB
460if [ -x /sbin/chkconfig ]; then
461 /sbin/chkconfig --del wine
462fi
463
55a96819 464%files -f files.so
5c4ec57b 465%defattr(644,root,root,755)
47bd64d5 466%doc README AUTHORS ANNOUNCE
12b1296e 467%lang(de) %doc documentation/README.de
468%lang(es) %doc documentation/README.es
469%lang(fr) %doc documentation/README.fr
0aac4f59 470%lang(hu) %doc documentation/README.hu
12b1296e 471%lang(it) %doc documentation/README.it
7b9e958b 472%lang(ko) %doc documentation/README.ko
58a0e5f4 473%lang(nb) %doc documentation/README.no
12b1296e 474%lang(pt) %doc documentation/README.pt
74de5921 475%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
476%lang(ru) %doc documentation/README.ru
477%lang(sv) %doc documentation/README.sv
478%lang(tr) %doc documentation/README.tr
82432451 479%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
480%ifnarch %{x8664}
481%attr(755,root,root) %{_bindir}/wine
482%else
483%attr(755,root,root) %{_bindir}/wine64
484%endif
d479f953 485%attr(755,root,root) %{_bindir}/wineboot
55a96819 486%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 487%attr(755,root,root) %{_bindir}/winecfg
beafc810 488%ifnarch %{x8664}
f829f028 489%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
490%else
491%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 492%endif
beafc810 493%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 494%attr(755,root,root) %{_libdir}/*.so*
861238d3 495%dir %{_libdir}/wine
61e39970 496%dir %{_libdir}/wine/fakedlls
497%{_libdir}/wine/fakedlls/*.acm
498%{_libdir}/wine/fakedlls/*.cpl
499%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
500%ifarch %{ix86}
501%{_libdir}/wine/fakedlls/*.dll16
502%endif
61e39970 503%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
504%ifarch %{ix86}
505%{_libdir}/wine/fakedlls/*.drv16
506%endif
61e39970 507%{_libdir}/wine/fakedlls/*.ds
508%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
509%ifarch %{ix86}
510%{_libdir}/wine/fakedlls/*.exe16
511%{_libdir}/wine/fakedlls/*.mod16
512%endif
61e39970 513%{_libdir}/wine/fakedlls/*.ocx
514%{_libdir}/wine/fakedlls/*.sys
515%{_libdir}/wine/fakedlls/*.tlb
f829f028 516%ifarch %{ix86}
61e39970 517%{_libdir}/wine/fakedlls/*.vxd
f829f028 518%endif
f6cf693b 519%ifnarch %{x8664}
b86f1c34 520%{_mandir}/man1/wine.1*
47bd64d5
JK
521%lang(de) %{_mandir}/de/man1/wine.1*
522%lang(fr) %{_mandir}/fr/man1/wine.1*
523%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
524%else
525%{_mandir}/man1/wine64.1*
526%lang(de) %{_mandir}/de/man1/wine64.1*
527%lang(fr) %{_mandir}/fr/man1/wine64.1*
528%lang(pl) %{_mandir}/pl/man1/wine64.1*
529%endif
da274952
AG
530%{_mandir}/man1/msiexec.1*
531%{_mandir}/man1/wineboot.1*
532%{_mandir}/man1/winecfg.1*
72ede285 533%{_mandir}/man1/winedbg.1*
b86f1c34 534%{_mandir}/man1/wineserver.1*
ad4623a1
AM
535%lang(de) %{_mandir}/de/man1/wineserver.1*
536%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 537%{_winedir}
a6c536e0 538%{_desktopdir}/wine.desktop
76055aa1 539%{_desktopdir}/wine-uninstaller.desktop
887fffcf 540%{_pixmapsdir}/%{name}.png
5c4ec57b 541
55a96819 542%files programs -f files.programs
e8f81a0a 543%defattr(644,root,root,755)
e8f81a0a 544
5c4ec57b 545%files devel
546%defattr(644,root,root,755)
a26a3859 547%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 548%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 549%attr(755,root,root) %{_bindir}/widl
55a96819 550%attr(755,root,root) %{_bindir}/winebuild
55a96819 551%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 552%attr(755,root,root) %{_bindir}/wineg++
d479f953 553%attr(755,root,root) %{_bindir}/winegcc
554%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 555%attr(755,root,root) %{_bindir}/winecpp
55a96819 556%attr(755,root,root) %{_bindir}/wmc
d479f953 557%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
558%{_libdir}/wine/lib*.def
559# no shared variants, so not separated
560%{_libdir}/wine/lib*.def.a
b93e474e 561%{_libdir}/wine/libadsiid.a
7265d9f2 562%{_libdir}/wine/libdx*.a
beafc810 563%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
564%{_libdir}/wine/libstrmiids.a
565%{_libdir}/wine/libuuid.a
566%{_libdir}/wine/libwinecrt0.a
5c4ec57b 567%{_includedir}/wine
34f03014 568%{_mandir}/man1/widl.1*
0aac4f59 569%{_mandir}/man1/winebuild.1*
da274952 570%{_mandir}/man1/winecpp.1*
34f03014 571%{_mandir}/man1/winedump.1*
bff06719 572%{_mandir}/man1/winegcc.1*
5ec7e550 573%{_mandir}/man1/wineg++.1*
34f03014 574%{_mandir}/man1/winemaker.1*
0aac4f59 575%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 576%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
577%{_mandir}/man1/wmc.1*
578%{_mandir}/man1/wrc.1*
2b5050a8 579%{_aclocaldir}/*.m4
f18f723c 580
beafc810
MM
581%files dll-capi
582%defattr(644,root,root,755)
583%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
584
16e36f25
JB
585%files dll-d3d
586%defattr(644,root,root,755)
587%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
588%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
589%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
590
591%files dll-gl
592%defattr(644,root,root,755)
593%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
594%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
595
596%if %{with sane}
597%files dll-twain
598%defattr(644,root,root,755)
b08b16bf 599%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 600%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
601%endif
602
9d6715c4
ER
603%if %{with ldap}
604%files dll-ldap
605%defattr(644,root,root,755)
606%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
607%endif
608
16e36f25
JB
609%if %{with alsa}
610%files drv-alsa
611%defattr(644,root,root,755)
612%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
613%endif
614
16e36f25 615# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
616# ddraw.dll.so,winex11.drv.so depend on X11 libs
617# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.190561 seconds and 4 git commands to generate.