]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- update bconds
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
0be89e87
BZ
2# todo:
3# libvkd3d https://wiki.winehq.org/Vkd3d
4#
7a30e9d7 5# Conditional build:
931f130b 6%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
7%bcond_without capi # don't build CAPI 2.0 (ISDN) support
8%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 9%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 10%bcond_without ldap # don't build LDAP DLL
16e36f25 11%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 12%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 13#
546bbb82 14# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
15# libGL (winex11.drv.so)
16# libOSMesa (gdi32.dll.so)
17# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
18# libcapi20 (capi2032.dll.so)
19# libcups (winspool.drv.so)
20# libdbus (mountmgr.sys.so)
16e36f25 21# libfontconfig (gdi32.dll.so)
5b49e814
JB
22# libfreetype (gdi32.dll.so)
23# libgnutls (secur32.dll.so)
5b49e814
JB
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
5b49e814
JB
26# libsane (sane.ds.so)
27# libtiff (windowscodecs.dll.so)
546bbb82 28# thus requires rebuild after change of any of the above.
db80a28e 29
4ce8abe1
ER
30# library qualifier in rpm generated deps
31%ifarch %{x8664} ia64 ppc64 s390x sparc64
32%define libqual ()(64bit)
33%else
34%define libqual %{nil}
35%endif
36
3e4a4fb9 37%define gecko_ver 2.47.2
698e86e7 38Summary: Program that lets you launch Win applications
93e41e44
ER
39Summary(es.UTF-8): Ejecuta programas Windows en Linux
40Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
41Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 42Name: wine
3e4a4fb9
BZ
43Version: 7.0
44Release: 0.1
46114a9a 45Epoch: 1
528c1138 46License: LGPL
5c4ec57b 47Group: Applications/Emulators
3e4a4fb9
BZ
48Source0: https://dl.winehq.org/wine/source/7.0/%{name}-%{version}.tar.xz
49# Source0-md5: a148a02826d9bcaa0ba631389cc522f2
50Source1: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86.msi
51# Source1-md5: e0a26e37397961b2c7f624575590ef66
52Source2: https://dl.winehq.org/wine/wine-gecko/%{gecko_ver}/%{name}-gecko-%{gecko_ver}-x86_64.msi
53# Source2-md5: ff7168b08fa901516fbaa8a66aa3cee6
beafc810 54Source3: %{name}-uninstaller.desktop
55061442 55Patch0: %{name}-gphoto2_bool.patch
a0ff0658 56Patch1: %{name}-makedep.patch
a4a10255 57Patch2: %{name}-ncurses.patch
8b4bf701 58Patch4: %{name}-disable-valgrind.patch
5312a936 59Patch5: %{name}-ca_certificates.patch
a26a3859
JK
60Patch6: desktop.patch
61Patch7: %{name}-wine64_man.patch
1b3d8891 62URL: http://www.winehq.org/
5b49e814 63BuildRequires: Mesa-libOSMesa-devel
0aac4f59 64BuildRequires: OpenAL-devel >= 1.1
5b49e814 65BuildRequires: OpenCL-devel
489ca66c 66BuildRequires: OpenGL-GLU-devel
6547534c
KK
67%{?with_alsa:BuildRequires: alsa-lib-devel}
68%{?with_arts:BuildRequires: artsc-devel}
5b49e814 69BuildRequires: autoconf >= 2.62
c7af491d 70BuildRequires: automake
d3c41437 71BuildRequires: bison
beafc810 72%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 73%{?with_cups:BuildRequires: cups-devel}
5b49e814 74BuildRequires: dbus-devel
5b49e814 75BuildRequires: flex >= 2.5.33
16e36f25 76BuildRequires: fontconfig-devel
5fc34681 77BuildRequires: freetype-devel >= 2.0.5
05596b04 78BuildRequires: gettext-devel
5b49e814
JB
79%ifarch %{x8664}
80BuildRequires: gcc >= 6:4.4
81%endif
1f0c428e 82BuildRequires: gettext-tools
c57a98fe 83BuildRequires: gnutls-devel
f73ad4b6
JP
84%{?with_gstreamer:BuildRequires: gstreamer-devel >= 1.0}
85%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 1.0}
5b49e814
JB
86# for icotool used in build
87BuildRequires: icoutils >= 0.29.0
88BuildRequires: lcms2-devel >= 2
3d0989c1 89BuildRequires: libcap-devel
beb8121e 90BuildRequires: libgphoto2-devel
05596b04 91BuildRequires: libpcap-devel
9d6715c4 92%{?with_ldap:BuildRequires: openldap-devel}
beb8121e 93BuildRequires: pkgconfig
3d0989c1 94BuildRequires: pulseaudio-devel
d7296a19 95BuildRequires: samba-devel
5715e1d1 96%{?with_sane:BuildRequires: sane-backends-devel}
5b49e814 97BuildRequires: xorg-lib-libX11-devel
beb8121e 98BuildRequires: xorg-lib-libXcomposite-devel
99BuildRequires: xorg-lib-libXcursor-devel
5b49e814 100BuildRequires: xorg-lib-libXext-devel
c66c3406 101BuildRequires: xorg-lib-libXi-devel
beb8121e 102BuildRequires: xorg-lib-libXinerama-devel
beb8121e 103BuildRequires: xorg-lib-libXrandr-devel
c66c3406 104BuildRequires: xorg-lib-libXrender-devel
c66c3406 105BuildRequires: xorg-lib-libXxf86vm-devel
4ce8abe1 106Requires: libfreetype.so.6%{libqual}
a85c8746 107Requires: libpng16.so.16%{libqual}
8df63af6 108Requires(post): /sbin/ldconfig
ae42c99e 109Suggests: binfmt-detector
be70b824 110Suggests: ca-certificates
beafc810 111Suggests: cabextract
a2f68044 112Conflicts: ca-certificates < 20080809-4
b3d3861d 113# for printing needs lpr
114Suggests: cups-clients
f96e197b 115# for winelauncher
3bddfbf2 116Suggests: xorg-app-xmessage
f96e197b 117# for ntlm_auth
14e95129 118Suggests: samba-common >= 1:3.0.25
52b6007b
JB
119# link to wine/ntdll.dll.so, without any SONAME
120Provides: libntdll.dll.so
7212da21 121Obsoletes: wine-doc-pdf
93b34e12 122Obsoletes: wine-drv-arts
beafc810
MM
123Obsoletes: wine-drv-jack
124Obsoletes: wine-drv-nas
5b49e814 125ExclusiveArch: %{ix86} %{x8664} arm
206eed29 126ExcludeArch: i386
0403821a 127BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 128
e8f81a0a 129%define no_install_post_strip 1
b955dc60 130%define _noautoprov elf\\\\(buildid\\\\)
e8f81a0a 131
e8f81a0a 132%define _winedir %{_datadir}/%{name}
6731627f 133
5c4ec57b 134%description
6731627f 135Wine is a program which allows running Microsoft Windows programs
a519bc4f 136(including DOS, Windows 3.x and Win32 executables) on Unix. It
137consists of a program loader which loads and executes a Microsoft
138Windows binary, and a library that implements Windows API calls using
139their Unix or X11 equivalents. The library may also be used for
140porting Win32 code into native Unix executables.
5c4ec57b 141
c967e47d 142%description -l es.UTF-8
f33a1517 143Ejecuta programas Windows en Linux.
144
c967e47d
JR
145%description -l pl.UTF-8
146Wine jest programem dzięki któremu można uruchamiać programy napisane
147dla Microsoft Windows pod systemami uniksowymi. Składa się on z
148loadera, który pozwala wczytywać i uruchamiać programy w formacie
149Microsoft Windows, oraz z biblioteki, która implementuje API Windows
150przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
151także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 152
c967e47d
JR
153%description -l pt_BR.UTF-8
154O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 155Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 156binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 157chamadas da API para as equivalentes Unix/X11.
158
5c4ec57b 159%package devel
7a050f82 160Summary: Wine - header files
93e41e44
ER
161Summary(es.UTF-8): Biblioteca de desarrollo de wine
162Summary(pl.UTF-8): Wine - pliki nagłowkowe
163Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 164Group: Development/Libraries
46114a9a 165Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 166
5c4ec57b 167%description devel
168Wine - header files.
169
c967e47d 170%description devel -l es.UTF-8
f33a1517 171Biblioteca de desarrollo de wine.
172
c967e47d
JR
173%description devel -l pl.UTF-8
174Wine - pliki nagłówkowe.
5c4ec57b 175
c967e47d
JR
176%description devel -l pt_BR.UTF-8
177Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 178WINE.
179
e8f81a0a 180%package programs
181Summary: Wine - programs
93e41e44 182Summary(pl.UTF-8): Wine - programy
e8f81a0a 183Group: Applications
46114a9a 184Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 185
186%description programs
0a7c5d50 187Wine - programs.
e8f81a0a 188
c967e47d 189%description programs -l pl.UTF-8
0a7c5d50 190Wine - programy.
e8f81a0a 191
beafc810
MM
192%package dll-capi
193Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
194Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
195Group: Applications/Emulators
196Requires: %{name} = %{epoch}:%{version}-%{release}
197
198%description dll-capi
b1df4aa7 199CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
200
201%description dll-capi -l pl.UTF-8
b1df4aa7 202Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 203
16e36f25
JB
204%package dll-d3d
205Summary: Direct3D implementation DLLs for Wine
93e41e44 206Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 207Group: Applications/Emulators
46114a9a 208Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
209Requires: OpenGL
210
211%description dll-d3d
212Direct3D implementation DLLs for Wine (through OpenGL).
213
c967e47d
JR
214%description dll-d3d -l pl.UTF-8
215Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
216
217%package dll-gl
218Summary: OpenGL implementation DLLs for Wine
93e41e44 219Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 220Group: Applications/Emulators
46114a9a 221Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
222Requires: OpenGL
223
224%description dll-gl
225OpenGL implementation DLLs for Wine.
226
c967e47d
JR
227%description dll-gl -l pl.UTF-8
228Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
229
230%package dll-twain
231Summary: TWAIN implementation DLL for Wine
93e41e44 232Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 233Group: Applications/Emulators
46114a9a 234Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
235
236%description dll-twain
237TWAIN implementation DLL for Wine (through SANE).
238
c967e47d
JR
239%description dll-twain -l pl.UTF-8
240Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 241
9d6715c4 242%package dll-ldap
db80a28e 243Summary: Win32 LDAP API DLL for Wine
b1df4aa7 244Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
245Group: Applications/Emulators
246Requires: %{name} = %{epoch}:%{version}-%{release}
247
248%description dll-ldap
b1df4aa7
JB
249Lightweight Directory Access Protocol Library for Wine.
250
251%description dll-ldap -l pl.UTF-8
252Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 253
16e36f25
JB
254%package drv-alsa
255Summary: ALSA driver for WINE mm.dll implementation
93e41e44 256Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 257Group: Applications/Emulators
46114a9a 258Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
259
260%description drv-alsa
261ALSA driver for WINE mm.dll (multimedia system) implementation.
262
c967e47d
JR
263%description drv-alsa -l pl.UTF-8
264Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 265
5c4ec57b 266%prep
fec39f21 267%setup -q
2fbbb535 268%patch0 -p1
269%patch1 -p1
ab25825d 270%patch2 -p1
8b4bf701 271%patch4 -p1
5312a936 272%patch5 -p1
3bfef0cd 273%patch6 -p1
f6cf693b 274%ifarch %{x8664}
a26a3859 275%patch7 -p1
f6cf693b 276%endif
591d55ba 277
5c4ec57b 278%build
ebbd62c0
GP
279
280#workaround for icon extraction error.
281icotool -x -o . dlls/user32/resources/oic_winlogo.ico
282mv -f oic_winlogo_*32x32x32.png %{name}.png
283rm -f oic_winlogo_*.png
887fffcf 284
2fbbb535 285%{__autoconf}
103d8328 286%{__autoheader}
9d6a128d 287%configure \
f829f028
AM
288%ifarch %{x8664}
289 --enable-win64 \
290%endif
5b49e814
JB
291 --with-alsa%{!?with_alsa:=no} \
292 --with-capi%{!?with_capi:=no} \
d0d61ce7 293 --with-coreaudio \
5b49e814 294 --with-cups%{!?with_cups:=no} \
d7296a19 295 --with-dbus \
c504380e 296 --with-fontconfig \
297 --with-freetype \
d7296a19 298 --with-gphoto \
d0d61ce7 299 --with-gnutls \
8ec65640 300 %{__with_without gstreamer} \
5b49e814 301 --with-ldap%{!?with_ldap:=no} \
d7296a19
JK
302 --with%{!?with_netapi:out}-netapi \
303 --with-openal \
304 --with-opencl \
c504380e 305 --with-opengl \
d7296a19 306 --with-osmesa \
c54d2750 307 --with-pcap \
d0d61ce7 308 --with-pthread \
c54d2750 309 --with-pulse \
c504380e 310 --with%{!?with_sane:out}-sane \
beb8121e 311 --with-xcomposite \
312 --with-xcursor \
313 --with-xinerama \
314 --with-xinput \
d7296a19 315 --with-xinput2 \
beb8121e 316 --with-xrandr \
c504380e 317 --with-xrender \
318 --with-xshape \
319 --with-xshm \
beb8121e 320 --with-xxf86vm \
0be89e87
BZ
321 --with-x
322
05eb066b 323%{__make} depend
4aafdd81 324%{__make}
e8f81a0a 325
5c4ec57b 326%install
327rm -rf $RPM_BUILD_ROOT
ffb676e0 328install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
329%{__make} install \
330 DESTDIR=$RPM_BUILD_ROOT
331
a26a3859 332install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 333cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 334
2a437456 335install -d \
65c325f6 336 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
337 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 338 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
339 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
340 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
341
a91c2692 342touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
343touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
344touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
345
76055aa1 346cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 347[mci]
348cdaudio=mcicda.drv
349sequencer=mciseq.drv
350waveaudio=mciwave.drv
351avivideo=mciavi.drv
352videodisc=mcipionr.drv
353vcr=mciviscd.drv
354MPEGVideo=mciqtz.drv
5c4ec57b 355EOF
356
80496098 357# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 358
887fffcf
ER
359dir=$(pwd)
360> files.so
361> files.programs
55a96819 362cd $RPM_BUILD_ROOT%{_libdir}/wine
363for f in *.so; do
16e36f25 364 case $f in
ad4623a1 365 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
366 ;;
367 *)
368 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 369 esac
55a96819 370done
371cd -
887fffcf
ER
372
373programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 374for p in $programs; do
8d493411 375 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
376 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 377 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 378 grep -v "$p\.exe\.so$" files.so > files.so.
379 mv -f files.so. files.so
55a96819 380done
55a96819 381
a26a3859
JK
382for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
383 mv "$dir" "${dir%.UTF-8}"
384done
385
f6cf693b 386%ifarch %{x8664}
c54d2750
JK
387install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
388for lang in de fr pl ; do
389install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
390install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
391done
392%else
393install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
394for lang in de fr pl ; do
395install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
396install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
397done
398%endif
399
f7357f09 400install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 401%ifnarch %{x8664}
db80a28e 402cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 403%else
db80a28e 404cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 405%endif
f7357f09 406
887fffcf 407install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
408cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
409cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 410
5c4ec57b 411%clean
412rm -rf $RPM_BUILD_ROOT
413
8df63af6 414%post
db80a28e 415/sbin/ldconfig
8df63af6
ER
416%update_desktop_database
417
f1f3af79
JB
418%postun -p /sbin/ldconfig
419
d142aa07 420%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 421rm -f /var/lock/subsys/wine
d142aa07
JB
422if [ -x /sbin/chkconfig ]; then
423 /sbin/chkconfig --del wine
424fi
425
55a96819 426%files -f files.so
5c4ec57b 427%defattr(644,root,root,755)
47bd64d5 428%doc README AUTHORS ANNOUNCE
12b1296e 429%lang(de) %doc documentation/README.de
430%lang(es) %doc documentation/README.es
431%lang(fr) %doc documentation/README.fr
0aac4f59 432%lang(hu) %doc documentation/README.hu
12b1296e 433%lang(it) %doc documentation/README.it
7b9e958b 434%lang(ko) %doc documentation/README.ko
58a0e5f4 435%lang(nb) %doc documentation/README.no
12b1296e 436%lang(pt) %doc documentation/README.pt
74de5921 437%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
438%lang(ru) %doc documentation/README.ru
439%lang(sv) %doc documentation/README.sv
440%lang(tr) %doc documentation/README.tr
82432451 441%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
442%ifnarch %{x8664}
443%attr(755,root,root) %{_bindir}/wine
444%else
445%attr(755,root,root) %{_bindir}/wine64
446%endif
d479f953 447%attr(755,root,root) %{_bindir}/wineboot
55a96819 448%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 449%attr(755,root,root) %{_bindir}/winecfg
beafc810 450%ifnarch %{x8664}
f829f028 451%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
452%else
453%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 454%endif
beafc810 455%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 456%attr(755,root,root) %{_libdir}/*.so*
861238d3 457%dir %{_libdir}/wine
61e39970 458%dir %{_libdir}/wine/fakedlls
459%{_libdir}/wine/fakedlls/*.acm
460%{_libdir}/wine/fakedlls/*.cpl
461%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
462%ifarch %{ix86}
463%{_libdir}/wine/fakedlls/*.dll16
464%endif
61e39970 465%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
466%ifarch %{ix86}
467%{_libdir}/wine/fakedlls/*.drv16
468%endif
61e39970 469%{_libdir}/wine/fakedlls/*.ds
470%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
471%ifarch %{ix86}
472%{_libdir}/wine/fakedlls/*.exe16
473%{_libdir}/wine/fakedlls/*.mod16
474%endif
61e39970 475%{_libdir}/wine/fakedlls/*.ocx
476%{_libdir}/wine/fakedlls/*.sys
477%{_libdir}/wine/fakedlls/*.tlb
f829f028 478%ifarch %{ix86}
61e39970 479%{_libdir}/wine/fakedlls/*.vxd
f829f028 480%endif
f6cf693b 481%ifnarch %{x8664}
b86f1c34 482%{_mandir}/man1/wine.1*
47bd64d5
JK
483%lang(de) %{_mandir}/de/man1/wine.1*
484%lang(fr) %{_mandir}/fr/man1/wine.1*
485%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
486%else
487%{_mandir}/man1/wine64.1*
488%lang(de) %{_mandir}/de/man1/wine64.1*
489%lang(fr) %{_mandir}/fr/man1/wine64.1*
490%lang(pl) %{_mandir}/pl/man1/wine64.1*
491%endif
da274952
AG
492%{_mandir}/man1/msiexec.1*
493%{_mandir}/man1/wineboot.1*
494%{_mandir}/man1/winecfg.1*
72ede285 495%{_mandir}/man1/winedbg.1*
b86f1c34 496%{_mandir}/man1/wineserver.1*
ad4623a1
AM
497%lang(de) %{_mandir}/de/man1/wineserver.1*
498%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 499%{_winedir}
a6c536e0 500%{_desktopdir}/wine.desktop
76055aa1 501%{_desktopdir}/wine-uninstaller.desktop
887fffcf 502%{_pixmapsdir}/%{name}.png
5c4ec57b 503
55a96819 504%files programs -f files.programs
e8f81a0a 505%defattr(644,root,root,755)
e8f81a0a 506
5c4ec57b 507%files devel
508%defattr(644,root,root,755)
a26a3859 509%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 510%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 511%attr(755,root,root) %{_bindir}/widl
55a96819 512%attr(755,root,root) %{_bindir}/winebuild
55a96819 513%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 514%attr(755,root,root) %{_bindir}/wineg++
d479f953 515%attr(755,root,root) %{_bindir}/winegcc
516%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 517%attr(755,root,root) %{_bindir}/winecpp
55a96819 518%attr(755,root,root) %{_bindir}/wmc
d479f953 519%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
520%{_libdir}/wine/lib*.def
521# no shared variants, so not separated
b93e474e 522%{_libdir}/wine/libadsiid.a
f73ad4b6 523%{_libdir}/wine/libdinput.a
ebbd62c0
GP
524%{_libdir}/wine/libdinput8.a
525%{_libdir}/wine/libdmoguids.a
7265d9f2 526%{_libdir}/wine/libdx*.a
f73ad4b6 527%{_libdir}/wine/libmfuuid.a
beafc810 528%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
529%{_libdir}/wine/libstrmiids.a
530%{_libdir}/wine/libuuid.a
531%{_libdir}/wine/libwinecrt0.a
ebbd62c0 532%{_libdir}/wine/libwmcodecdspuuid.a
5c4ec57b 533%{_includedir}/wine
34f03014 534%{_mandir}/man1/widl.1*
0aac4f59 535%{_mandir}/man1/winebuild.1*
da274952 536%{_mandir}/man1/winecpp.1*
34f03014 537%{_mandir}/man1/winedump.1*
bff06719 538%{_mandir}/man1/winegcc.1*
5ec7e550 539%{_mandir}/man1/wineg++.1*
34f03014 540%{_mandir}/man1/winemaker.1*
0aac4f59 541%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 542%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
543%{_mandir}/man1/wmc.1*
544%{_mandir}/man1/wrc.1*
2b5050a8 545%{_aclocaldir}/*.m4
f18f723c 546
beafc810
MM
547%files dll-capi
548%defattr(644,root,root,755)
549%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
550
16e36f25
JB
551%files dll-d3d
552%defattr(644,root,root,755)
553%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
554%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
555%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
556
557%files dll-gl
558%defattr(644,root,root,755)
559%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
560%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
561
562%if %{with sane}
563%files dll-twain
564%defattr(644,root,root,755)
b08b16bf 565%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 566%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
567%endif
568
9d6715c4
ER
569%if %{with ldap}
570%files dll-ldap
571%defattr(644,root,root,755)
572%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
573%endif
574
16e36f25
JB
575%if %{with alsa}
576%files drv-alsa
577%defattr(644,root,root,755)
578%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
579%endif
580
16e36f25 581# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
582# ddraw.dll.so,winex11.drv.so depend on X11 libs
583# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.29781 seconds and 4 git commands to generate.