]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
rebuild with openssl 3.0.0
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
9acf6ec8 5%bcond_with tests
7b39c852
JB
6%bcond_without ssl # do not use SSL
7%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5596a2d5
AM
8# better just preload it instead forcing linking
9%bcond_with dante # Dante-based SOCKS support
db510deb
AM
10# broken currently https://www.dnssec-tools.org/trac/ticket/173
11%bcond_with dnssec # DNSSEC local validation
5869f11d 12#
117d16ec 13%if %{with ssl}
14%define with_openssl 1
15%endif
16
4f313d5c 17%if %{with gnutls} && %{with ssl}
117d16ec 18%undefine with_openssl
4f313d5c 19%endif
117d16ec 20
aa601f68 21Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
22Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
23Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
24Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
25Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 26Name: lftp
4949fd71 27Version: 4.9.2
8f392ce0 28Release: 2
474948d1 29License: GPL v3+
4e6de64c 30Group: Applications/Networking
df55f7fc 31Source0: https://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
4949fd71 32# Source0-md5: b3a272ecb7a2b60e3827776f90ffb2f3
e84c29c9 33Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 34# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
93dfd0ea 35Patch100: %{name}-git.patch
5bf73c23
JB
36Patch0: %{name}-makefile.patch
37Patch1: %{name}-m4.patch
38Patch2: aliases.patch
88eff545 39# when updated attach at https://github.com/lavv17/lftp/issues
5bf73c23 40Patch3: %{name}-pl.po-update.patch
9d3763af 41Patch4: %{name}-am.patch
3f82c3cf 42Patch5: %{name}-desktop.patch
df55f7fc 43URL: http://lftp.tech/
3f82c3cf 44BuildRequires: autoconf >= 2.63
2a2b7922 45BuildRequires: automake
5869f11d
JB
46%{?with_dante:BuildRequires: dante-devel}
47%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 48BuildRequires: expat-devel
fb96bafa 49BuildRequires: gettext-tools >= 0.14.2
d4e96cc1 50%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
42656b3d 51BuildRequires: libidn2-devel
131b64b6 52BuildRequires: libstdc++-devel
f9f0c5b5 53BuildRequires: libtool >= 2:2
eb634329 54BuildRequires: ncurses-devel >= 5.2
117d16ec 55%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 56BuildRequires: pkgconfig
f9f0c5b5 57BuildRequires: readline-devel >= 5.0
7bf4d9a3 58BuildRequires: tar >= 1:1.22
59BuildRequires: xz
f9f0c5b5 60BuildRequires: zlib-devel
4502d222 61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 62
63%description
aa601f68 64LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 65advantages over other FTP clients are reliability and ability to
c37d8459 66perform tasks in background. It will reconnect and reget the file
67being transferred if the connection broke. You can start a transfer in
b25ac3f9 68background and continue browsing on the FTP site. It does this all in
c37d8459 69one process. When you have started background jobs and feel you are
70done, you can just exit lftp and it automatically moves to nohup mode
71and completes the transfers. It has also such nice features as reput
72and mirror.
0fcf33fd 73
29127d3f 74%description -l pl.UTF-8
aa601f68 75Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
76połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
77ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
78połączenia po tym jak się wylogujesz. Program ten honoruje komendy
79powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
80jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 81
29127d3f
JR
82%description -l pt_BR.UTF-8
83O lftp é um programa de transferência de arquivos por linha de
aa601f68 84comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
85HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
86tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 87o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 88
0fcf33fd 89%prep
6588894c 90%setup -q
df55f7fc 91#%patch100 -p1
5bf73c23 92%patch0 -p1
43f4d1c2 93%patch1 -p1
ec7a935e 94%patch2 -p1
5634df56 95%patch3 -p1
bce12c75 96%patch4 -p1
3f82c3cf 97%patch5 -p1
a41e3bec 98
b9a2e61d
JB
99%{__rm} po/stamp-po
100
33b4fdae
AM
101%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
102
0fcf33fd 103%build
dc2417fa 104%{__libtoolize}
07e8f8cb 105%{__gettextize}
29f4b0b0 106%{__aclocal} -I m4
cbf16d8c 107%{__autoconf}
108%{__automake}
8ad8d289 109CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 110%configure \
d2c1e0b5 111 --without-included-regex \
5869f11d 112 --with-dnssec-local-validation%{!?with_dnssec:=no} \
3f82c3cf 113 --with-gnutls%{!?with_gnutls:=no} \
9f24e3d9 114 --with-modules \
3f82c3cf
JB
115 --with-openssl%{!?with_openssl:=no} \
116 --with-socksdante%{!?with_dante:=no}
4f313d5c 117
3579d696 118%{__make}
0fcf33fd 119
9acf6ec8 120%{?with_tests:%{__make} check}
324a7201 121
0fcf33fd 122%install
123rm -rf $RPM_BUILD_ROOT
3f82c3cf
JB
124install -d $RPM_BUILD_ROOT%{_sysconfdir}
125
f8f85376
JB
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
be14979d 128
f1bf5d4a 129cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
aaea7f09 130
e84c29c9 131bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
132%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
133%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 134
551b2ae6
AM
135# don't drag in perl deps
136%{__rm} $RPM_BUILD_ROOT%{_datadir}/lftp/{convert-mozilla-cookies,verify-file}
137
df169521 138%find_lang %{name}
165ff9f8 139
0fcf33fd 140%clean
141rm -rf $RPM_BUILD_ROOT
142
43f4d1c2
JB
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
df169521 146%files -f %{name}.lang
be14979d 147%defattr(644,root,root,755)
3f82c3cf 148%doc AUTHORS BUGS ChangeLog FAQ FEATURES NEWS README README.debug-levels README.dnssec THANKS TODO
404c9e4b 149%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
150%attr(755,root,root) %{_bindir}/lftp
151%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 152%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
153%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
154%dir %{_libdir}/lftp
d81e41f6 155%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 156%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
157%{_mandir}/man1/lftp.1*
158%{_mandir}/man1/lftpget.1*
159%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 160%{_mandir}/man5/lftp.conf.5*
10a3b210 161%{_desktopdir}/lftp.desktop
3f82c3cf 162%{_iconsdir}/hicolor/48x48/apps/lftp-icon.png
This page took 0.118941 seconds and 5 git commands to generate.