]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- upstream now
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
34167fe0 22Version: 3.7.6
c132b1e4 23Release: 1
4de3cc6d 24License: GPL v2+
4e6de64c 25Group: Applications/Networking
33b4fdae 26Source0: ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
34167fe0 27# Source0-md5: eed9891b8c2d034f296af5eb86898935
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
9ad5e40a 31Patch0: %{name}-home_etc.patch
f1d0e108 32Patch1: %{name}-makefile.patch
0d6c2643 33URL: http://lftp.yar.ru/
7e9d0681 34BuildRequires: autoconf >= 2.60
2a2b7922 35BuildRequires: automake
404c9e4b 36BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 37%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 38BuildRequires: libstdc++-devel
6b77b6dc 39BuildRequires: libtool >= 1:1.4.2-9
eb634329 40BuildRequires: ncurses-devel >= 5.2
117d16ec 41%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
eb634329 42BuildRequires: readline-devel >= 4.2
4502d222 43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 44
fed66524 45%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
46%if %{_gcc_ver} == 2
47%define __cxx "%{__cc}"
48%endif
f544d322 49
0fcf33fd 50%description
aa601f68 51LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 52advantages over other FTP clients are reliability and ability to
c37d8459 53perform tasks in background. It will reconnect and reget the file
54being transferred if the connection broke. You can start a transfer in
b25ac3f9 55background and continue browsing on the FTP site. It does this all in
c37d8459 56one process. When you have started background jobs and feel you are
57done, you can just exit lftp and it automatically moves to nohup mode
58and completes the transfers. It has also such nice features as reput
59and mirror.
0fcf33fd 60
29127d3f 61%description -l pl.UTF-8
aa601f68 62Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
63połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
64ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
65połączenia po tym jak się wylogujesz. Program ten honoruje komendy
66powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
67jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 68
29127d3f
JR
69%description -l pt_BR.UTF-8
70O lftp é um programa de transferência de arquivos por linha de
aa601f68 71comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
72HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
73tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 74o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 75
0fcf33fd 76%prep
6588894c 77%setup -q
4de3cc6d 78#%%patch0 -p1
43f4d1c2 79%patch1 -p1
3225d16b 80
a41e3bec
JB
81rm -f po/stamp-po
82
33b4fdae
AM
83%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
84
0fcf33fd 85%build
dc2417fa 86%{__libtoolize}
07e8f8cb 87%{__gettextize}
29f4b0b0 88%{__aclocal} -I m4
cbf16d8c 89%{__autoconf}
90%{__automake}
8ad8d289 91CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 92%configure \
9f24e3d9 93 --with-modules \
117d16ec 94 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
95 --with%{!?with_gnutls:out}-gnutls
96
3579d696 97%{__make}
0fcf33fd 98
99%install
100rm -rf $RPM_BUILD_ROOT
10a3b210 101install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
3e02f0be 102
f8f85376
JB
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
be14979d 105
aaea7f09 106install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
c37d8459 107install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
10a3b210 108install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
aaea7f09 109
e84c29c9 110bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
d4e96cc1 111rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
42d7b58c 112rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 113
df169521 114%find_lang %{name}
165ff9f8 115
0fcf33fd 116%clean
117rm -rf $RPM_BUILD_ROOT
118
43f4d1c2
JB
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
df169521 122%files -f %{name}.lang
be14979d 123%defattr(644,root,root,755)
e84c29c9 124%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 125%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
126%attr(755,root,root) %{_bindir}/lftp
127%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 128%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
129%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
130%dir %{_libdir}/lftp
d81e41f6 131%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 132%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
133%{_mandir}/man1/lftp.1*
134%{_mandir}/man1/lftpget.1*
135%lang(pl) %{_mandir}/pl/man1/lftpget.1*
10a3b210 136%{_desktopdir}/lftp.desktop
c37d8459 137%{_pixmapsdir}/lftp.png
This page took 0.056025 seconds and 4 git commands to generate.