]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- 3.6.0 tarball
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
9d5e9312
ER
22Version: 3.6.0
23Release: 0.1
4de3cc6d 24License: GPL v2+
4e6de64c 25Group: Applications/Networking
33b4fdae 26Source0: ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
9d5e9312 27# Source0-md5: bb19dac3cd3f1b43b3074bfd2ca9785b
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
9ad5e40a 31Patch0: %{name}-home_etc.patch
f1d0e108
JB
32Patch1: %{name}-makefile.patch
33Patch2: %{name}-as_needed-fix.patch
0d6c2643 34URL: http://lftp.yar.ru/
7e9d0681 35BuildRequires: autoconf >= 2.60
2a2b7922 36BuildRequires: automake
404c9e4b 37BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 38%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 39BuildRequires: libstdc++-devel
6b77b6dc 40BuildRequires: libtool >= 1:1.4.2-9
eb634329 41BuildRequires: ncurses-devel >= 5.2
117d16ec 42%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
eb634329 43BuildRequires: readline-devel >= 4.2
4502d222 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 45
fed66524 46%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
47%if %{_gcc_ver} == 2
48%define __cxx "%{__cc}"
49%endif
f544d322 50
0fcf33fd 51%description
aa601f68 52LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 53advantages over other FTP clients are reliability and ability to
c37d8459 54perform tasks in background. It will reconnect and reget the file
55being transferred if the connection broke. You can start a transfer in
b25ac3f9 56background and continue browsing on the FTP site. It does this all in
c37d8459 57one process. When you have started background jobs and feel you are
58done, you can just exit lftp and it automatically moves to nohup mode
59and completes the transfers. It has also such nice features as reput
60and mirror.
0fcf33fd 61
29127d3f 62%description -l pl.UTF-8
aa601f68 63Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
64połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
65ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
66połączenia po tym jak się wylogujesz. Program ten honoruje komendy
67powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
68jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 69
29127d3f
JR
70%description -l pt_BR.UTF-8
71O lftp é um programa de transferência de arquivos por linha de
aa601f68 72comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
73HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
74tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 75o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 76
0fcf33fd 77%prep
6588894c 78%setup -q
4de3cc6d 79#%%patch0 -p1
43f4d1c2 80%patch1 -p1
bbd22ed7 81%patch2 -p1
3225d16b 82
a41e3bec
JB
83rm -f po/stamp-po
84
33b4fdae
AM
85%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
86
0fcf33fd 87%build
dc2417fa 88%{__libtoolize}
07e8f8cb 89%{__gettextize}
29f4b0b0 90%{__aclocal} -I m4
cbf16d8c 91%{__autoconf}
92%{__automake}
d61cad06 93CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
75461ea5 94%configure \
9f24e3d9 95 --with-modules \
4f313d5c 96 --with%{!?with_ssl:out}-ssl \
117d16ec 97 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
98 --with%{!?with_gnutls:out}-gnutls
99
3579d696 100%{__make}
0fcf33fd 101
102%install
103rm -rf $RPM_BUILD_ROOT
10a3b210 104install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
3e02f0be 105
f8f85376
JB
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
be14979d 108
aaea7f09 109install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
c37d8459 110install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
10a3b210 111install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
aaea7f09 112
e84c29c9 113bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
d4e96cc1
ER
114rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
7ccee824 116
df169521 117%find_lang %{name}
165ff9f8 118
0fcf33fd 119%clean
120rm -rf $RPM_BUILD_ROOT
121
43f4d1c2
JB
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
df169521 125%files -f %{name}.lang
be14979d 126%defattr(644,root,root,755)
e84c29c9 127%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 128%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
d3458bae 129%attr(755,root,root) %{_bindir}/*
e8b18888 130%dir %{_libdir}/lftp
43f4d1c2 131%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
d81e41f6 132%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 133%attr(755,root,root) %{_datadir}/lftp
131b64b6 134%{_mandir}/man1/*
7ccee824 135%lang(pl) %{_mandir}/pl/man1/*
10a3b210 136%{_desktopdir}/lftp.desktop
c37d8459 137%{_pixmapsdir}/lftp.png
This page took 0.096637 seconds and 4 git commands to generate.