]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- converted to UTF-8
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
29127d3f
JR
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
4de3cc6d 22Version: 3.5.9
8e71a03b 23Release: 2
4de3cc6d 24License: GPL v2+
4e6de64c 25Group: Applications/Networking
33b4fdae 26Source0: ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
4de3cc6d 27# Source0-md5: 242aa0b01be79942bb9bcdd2a4b079ba
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
9ad5e40a 31Patch0: %{name}-home_etc.patch
f1d0e108
JB
32Patch1: %{name}-makefile.patch
33Patch2: %{name}-as_needed-fix.patch
6e9f5d11 34Patch3: %{name}-pl.po-update.patch
0d6c2643 35URL: http://lftp.yar.ru/
7e9d0681 36BuildRequires: autoconf >= 2.60
2a2b7922 37BuildRequires: automake
404c9e4b 38BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 39%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 40BuildRequires: libstdc++-devel
6b77b6dc 41BuildRequires: libtool >= 1:1.4.2-9
eb634329 42BuildRequires: ncurses-devel >= 5.2
117d16ec 43%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
eb634329 44BuildRequires: readline-devel >= 4.2
4502d222 45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 46
fed66524 47%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
48%if %{_gcc_ver} == 2
49%define __cxx "%{__cc}"
50%endif
f544d322 51
0fcf33fd 52%description
aa601f68 53LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 54advantages over other FTP clients are reliability and ability to
c37d8459 55perform tasks in background. It will reconnect and reget the file
56being transferred if the connection broke. You can start a transfer in
b25ac3f9 57background and continue browsing on the FTP site. It does this all in
c37d8459 58one process. When you have started background jobs and feel you are
59done, you can just exit lftp and it automatically moves to nohup mode
60and completes the transfers. It has also such nice features as reput
61and mirror.
0fcf33fd 62
29127d3f 63%description -l pl.UTF-8
aa601f68 64Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
65połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
66ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
67połączenia po tym jak się wylogujesz. Program ten honoruje komendy
68powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
69jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 70
29127d3f
JR
71%description -l pt_BR.UTF-8
72O lftp é um programa de transferência de arquivos por linha de
aa601f68 73comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
74HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
75tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 76o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 77
0fcf33fd 78%prep
6588894c 79%setup -q
4de3cc6d 80#%%patch0 -p1
43f4d1c2 81%patch1 -p1
bbd22ed7 82%patch2 -p1
6e9f5d11 83%patch3 -p1
3225d16b 84
a41e3bec
JB
85rm -f po/stamp-po
86
33b4fdae
AM
87%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
88
0fcf33fd 89%build
dc2417fa 90%{__libtoolize}
07e8f8cb 91%{__gettextize}
29f4b0b0 92%{__aclocal} -I m4
cbf16d8c 93%{__autoconf}
94%{__automake}
d61cad06 95CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
75461ea5 96%configure \
9f24e3d9 97 --with-modules \
4f313d5c 98 --with%{!?with_ssl:out}-ssl \
117d16ec 99 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
100 --with%{!?with_gnutls:out}-gnutls
101
3579d696 102%{__make}
0fcf33fd 103
104%install
105rm -rf $RPM_BUILD_ROOT
10a3b210 106install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
3e02f0be 107
f8f85376
JB
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
be14979d 110
aaea7f09 111install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
c37d8459 112install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
10a3b210 113install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
aaea7f09 114
e84c29c9 115bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
d4e96cc1
ER
116rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
7ccee824 118
df169521 119%find_lang %{name}
165ff9f8 120
0fcf33fd 121%clean
122rm -rf $RPM_BUILD_ROOT
123
43f4d1c2
JB
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
df169521 127%files -f %{name}.lang
be14979d 128%defattr(644,root,root,755)
e84c29c9 129%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 130%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
d3458bae 131%attr(755,root,root) %{_bindir}/*
e8b18888 132%dir %{_libdir}/lftp
43f4d1c2 133%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
d81e41f6 134%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 135%attr(755,root,root) %{_datadir}/lftp
131b64b6 136%{_mandir}/man1/*
7ccee824 137%lang(pl) %{_mandir}/pl/man1/*
10a3b210 138%{_desktopdir}/lftp.desktop
c37d8459 139%{_pixmapsdir}/lftp.png
This page took 0.053945 seconds and 4 git commands to generate.