]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- up to 4.4.2; enable DNSSEC validation; enable socks support
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
d2c1e0b5
AM
22Version: 4.4.2
23Release: 1
474948d1 24License: GPL v3+
4e6de64c 25Group: Applications/Networking
b8664870 26Source0: http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
d2c1e0b5 27# Source0-md5: 3c9411d859e1df9c09d3de0f32774cf3
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
fbf2ab8a 31Source3: %{name}-icon.png
5bf73c23
JB
32Patch0: %{name}-makefile.patch
33Patch1: %{name}-m4.patch
34Patch2: aliases.patch
afc7c8ba 35# maintained by me, sent upstream from time to time --qboosh
5bf73c23 36Patch3: %{name}-pl.po-update.patch
bce12c75 37Patch4: lftp-4.3.8-gets.patch
0d6c2643 38URL: http://lftp.yar.ru/
7e9d0681 39BuildRequires: autoconf >= 2.60
2a2b7922 40BuildRequires: automake
d2c1e0b5
AM
41BuildRequires: dante-devel
42BuildRequires: dnssec-tools-devel
5bf73c23 43BuildRequires: expat-devel
404c9e4b 44BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 45%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 46BuildRequires: libstdc++-devel
6b77b6dc 47BuildRequires: libtool >= 1:1.4.2-9
eb634329 48BuildRequires: ncurses-devel >= 5.2
117d16ec 49%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 50BuildRequires: pkgconfig
eb634329 51BuildRequires: readline-devel >= 4.2
7bf4d9a3 52BuildRequires: tar >= 1:1.22
53BuildRequires: xz
4502d222 54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 55
fed66524 56%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
57%if %{_gcc_ver} == 2
58%define __cxx "%{__cc}"
59%endif
f544d322 60
0fcf33fd 61%description
aa601f68 62LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 63advantages over other FTP clients are reliability and ability to
c37d8459 64perform tasks in background. It will reconnect and reget the file
65being transferred if the connection broke. You can start a transfer in
b25ac3f9 66background and continue browsing on the FTP site. It does this all in
c37d8459 67one process. When you have started background jobs and feel you are
68done, you can just exit lftp and it automatically moves to nohup mode
69and completes the transfers. It has also such nice features as reput
70and mirror.
0fcf33fd 71
29127d3f 72%description -l pl.UTF-8
aa601f68 73Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
74połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
75ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
76połączenia po tym jak się wylogujesz. Program ten honoruje komendy
77powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
78jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 79
29127d3f
JR
80%description -l pt_BR.UTF-8
81O lftp é um programa de transferência de arquivos por linha de
aa601f68 82comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
83HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
84tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 85o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 86
0fcf33fd 87%prep
6588894c 88%setup -q
5bf73c23 89%patch0 -p1
43f4d1c2 90%patch1 -p1
ec7a935e 91%patch2 -p1
d2c1e0b5 92#%patch3 -p1
bce12c75 93%patch4 -p1
a41e3bec 94
33b4fdae
AM
95%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
96
0fcf33fd 97%build
dc2417fa 98%{__libtoolize}
07e8f8cb 99%{__gettextize}
29f4b0b0 100%{__aclocal} -I m4
cbf16d8c 101%{__autoconf}
102%{__automake}
8ad8d289 103CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 104%configure \
d2c1e0b5
AM
105 --without-included-regex \
106 --with-dnssec-local-validation \
9f24e3d9 107 --with-modules \
d2c1e0b5 108 --with-socksdante \
117d16ec 109 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
110 --with%{!?with_gnutls:out}-gnutls
111
3579d696 112%{__make}
0fcf33fd 113
114%install
115rm -rf $RPM_BUILD_ROOT
10a3b210 116install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT
be14979d 119
f1bf5d4a
ER
120cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
121cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
122cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 123
e84c29c9 124bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
125%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
126%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 127
df169521 128%find_lang %{name}
165ff9f8 129
0fcf33fd 130%clean
131rm -rf $RPM_BUILD_ROOT
132
43f4d1c2
JB
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
df169521 136%files -f %{name}.lang
be14979d 137%defattr(644,root,root,755)
e84c29c9 138%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 139%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
140%attr(755,root,root) %{_bindir}/lftp
141%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 142%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
143%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
144%dir %{_libdir}/lftp
d81e41f6 145%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 146%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
147%{_mandir}/man1/lftp.1*
148%{_mandir}/man1/lftpget.1*
149%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 150%{_mandir}/man5/lftp.conf.5*
10a3b210 151%{_desktopdir}/lftp.desktop
c37d8459 152%{_pixmapsdir}/lftp.png
This page took 0.220059 seconds and 4 git commands to generate.