]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- merged hunks
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
b8664870 22Version: 4.0.10
c95f834c 23Release: 1
474948d1 24License: GPL v3+
4e6de64c 25Group: Applications/Networking
b8664870
AM
26Source0: http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27# Source0-md5: 3dfd4458e1a72803821de468b77ae536
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
fbf2ab8a 31Source3: %{name}-icon.png
9ad5e40a 32Patch0: %{name}-home_etc.patch
f1d0e108 33Patch1: %{name}-makefile.patch
922a4344 34# ALWAYS send updated patch to lftp mailing lists
cc06dd55 35Patch2: %{name}-pl.po-update.patch
922a4344 36Patch3: %{name}-m4.patch
0d6c2643 37URL: http://lftp.yar.ru/
7e9d0681 38BuildRequires: autoconf >= 2.60
2a2b7922 39BuildRequires: automake
404c9e4b 40BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 41%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 42BuildRequires: libstdc++-devel
6b77b6dc 43BuildRequires: libtool >= 1:1.4.2-9
eb634329 44BuildRequires: ncurses-devel >= 5.2
117d16ec 45%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 46BuildRequires: pkgconfig
eb634329 47BuildRequires: readline-devel >= 4.2
4502d222 48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 49
fed66524 50%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
51%if %{_gcc_ver} == 2
52%define __cxx "%{__cc}"
53%endif
f544d322 54
0fcf33fd 55%description
aa601f68 56LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 57advantages over other FTP clients are reliability and ability to
c37d8459 58perform tasks in background. It will reconnect and reget the file
59being transferred if the connection broke. You can start a transfer in
b25ac3f9 60background and continue browsing on the FTP site. It does this all in
c37d8459 61one process. When you have started background jobs and feel you are
62done, you can just exit lftp and it automatically moves to nohup mode
63and completes the transfers. It has also such nice features as reput
64and mirror.
0fcf33fd 65
29127d3f 66%description -l pl.UTF-8
aa601f68 67Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
68połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
69ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
70połączenia po tym jak się wylogujesz. Program ten honoruje komendy
71powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
72jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 73
29127d3f
JR
74%description -l pt_BR.UTF-8
75O lftp é um programa de transferência de arquivos por linha de
aa601f68 76comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
77HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
78tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 79o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 80
0fcf33fd 81%prep
6588894c 82%setup -q
4de3cc6d 83#%%patch0 -p1
43f4d1c2 84%patch1 -p1
922a4344
AM
85#%patch2 -p1
86%patch3 -p1
3225d16b 87
a41e3bec
JB
88rm -f po/stamp-po
89
33b4fdae
AM
90%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
91
0fcf33fd 92%build
dc2417fa 93%{__libtoolize}
07e8f8cb 94%{__gettextize}
29f4b0b0 95%{__aclocal} -I m4
cbf16d8c 96%{__autoconf}
97%{__automake}
8ad8d289 98CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 99%configure \
9f24e3d9 100 --with-modules \
117d16ec 101 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
102 --with%{!?with_gnutls:out}-gnutls
103
3579d696 104%{__make}
0fcf33fd 105
106%install
107rm -rf $RPM_BUILD_ROOT
10a3b210 108install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
3e02f0be 109
f8f85376
JB
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
be14979d 112
aaea7f09 113install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
10a3b210 114install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
fbf2ab8a 115install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 116
e84c29c9 117bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
d4e96cc1 118rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
42d7b58c 119rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 120
df169521 121%find_lang %{name}
165ff9f8 122
0fcf33fd 123%clean
124rm -rf $RPM_BUILD_ROOT
125
43f4d1c2
JB
126%post -p /sbin/ldconfig
127%postun -p /sbin/ldconfig
128
df169521 129%files -f %{name}.lang
be14979d 130%defattr(644,root,root,755)
e84c29c9 131%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 132%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
133%attr(755,root,root) %{_bindir}/lftp
134%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 135%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
136%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
137%dir %{_libdir}/lftp
d81e41f6 138%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 139%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
140%{_mandir}/man1/lftp.1*
141%{_mandir}/man1/lftpget.1*
142%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 143%{_mandir}/man5/lftp.conf.5*
10a3b210 144%{_desktopdir}/lftp.desktop
c37d8459 145%{_pixmapsdir}/lftp.png
This page took 0.09587 seconds and 4 git commands to generate.