]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- adjuested for 4.2.0
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
2878f482 22Version: 4.2.0
c8547c71 23Release: 1
474948d1 24License: GPL v3+
4e6de64c 25Group: Applications/Networking
b8664870 26Source0: http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
2878f482 27# Source0-md5: 0ba993d4edda8d975a78b7e8f0c687d0
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
fbf2ab8a 31Source3: %{name}-icon.png
ec7a935e 32# outdated and nobody cared for 8+ years... will be dropped
9ad5e40a 33Patch0: %{name}-home_etc.patch
f1d0e108 34Patch1: %{name}-makefile.patch
922a4344 35# ALWAYS send updated patch to lftp mailing lists
cc06dd55 36Patch2: %{name}-pl.po-update.patch
922a4344 37Patch3: %{name}-m4.patch
f1bf5d4a 38Patch4: aliases.patch
0d6c2643 39URL: http://lftp.yar.ru/
7e9d0681 40BuildRequires: autoconf >= 2.60
2a2b7922 41BuildRequires: automake
404c9e4b 42BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 43%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 44BuildRequires: libstdc++-devel
6b77b6dc 45BuildRequires: libtool >= 1:1.4.2-9
eb634329 46BuildRequires: ncurses-devel >= 5.2
117d16ec 47%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 48BuildRequires: pkgconfig
eb634329 49BuildRequires: readline-devel >= 4.2
4502d222 50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 51
fed66524 52%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
53%if %{_gcc_ver} == 2
54%define __cxx "%{__cc}"
55%endif
f544d322 56
0fcf33fd 57%description
aa601f68 58LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 59advantages over other FTP clients are reliability and ability to
c37d8459 60perform tasks in background. It will reconnect and reget the file
61being transferred if the connection broke. You can start a transfer in
b25ac3f9 62background and continue browsing on the FTP site. It does this all in
c37d8459 63one process. When you have started background jobs and feel you are
64done, you can just exit lftp and it automatically moves to nohup mode
65and completes the transfers. It has also such nice features as reput
66and mirror.
0fcf33fd 67
29127d3f 68%description -l pl.UTF-8
aa601f68 69Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
70połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
71ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
72połączenia po tym jak się wylogujesz. Program ten honoruje komendy
73powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
74jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 75
29127d3f
JR
76%description -l pt_BR.UTF-8
77O lftp é um programa de transferência de arquivos por linha de
aa601f68 78comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
79HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
80tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 81o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 82
0fcf33fd 83%prep
6588894c 84%setup -q
4de3cc6d 85#%%patch0 -p1
43f4d1c2 86%patch1 -p1
ec7a935e 87%patch2 -p1
922a4344 88%patch3 -p1
f1bf5d4a 89%patch4 -p1
3225d16b 90
ec7a935e 91%{__rm} po/stamp-po
a41e3bec 92
33b4fdae
AM
93%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
94
0fcf33fd 95%build
dc2417fa 96%{__libtoolize}
07e8f8cb 97%{__gettextize}
29f4b0b0 98%{__aclocal} -I m4
cbf16d8c 99%{__autoconf}
100%{__automake}
8ad8d289 101CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 102%configure \
9f24e3d9 103 --with-modules \
117d16ec 104 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
105 --with%{!?with_gnutls:out}-gnutls
106
3579d696 107%{__make}
0fcf33fd 108
109%install
110rm -rf $RPM_BUILD_ROOT
10a3b210 111install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
be14979d 114
f1bf5d4a
ER
115cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
116cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
117cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 118
e84c29c9 119bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
120%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
121%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 122
df169521 123%find_lang %{name}
165ff9f8 124
0fcf33fd 125%clean
126rm -rf $RPM_BUILD_ROOT
127
43f4d1c2
JB
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
df169521 131%files -f %{name}.lang
be14979d 132%defattr(644,root,root,755)
e84c29c9 133%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 134%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
135%attr(755,root,root) %{_bindir}/lftp
136%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 137%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
138%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
139%dir %{_libdir}/lftp
d81e41f6 140%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 141%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
142%{_mandir}/man1/lftp.1*
143%{_mandir}/man1/lftpget.1*
144%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 145%{_mandir}/man5/lftp.conf.5*
10a3b210 146%{_desktopdir}/lftp.desktop
c37d8459 147%{_pixmapsdir}/lftp.png
This page took 0.126577 seconds and 4 git commands to generate.