]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- up to 4.3.6; home_etc dropped
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
eaf4e234
AM
22Version: 4.3.6
23Release: 1
474948d1 24License: GPL v3+
4e6de64c 25Group: Applications/Networking
b8664870 26Source0: http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
eaf4e234 27# Source0-md5: ffcdbaec5d1416cb6dd754efd43fa61a
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
fbf2ab8a 31Source3: %{name}-icon.png
eaf4e234 32
f1d0e108 33Patch1: %{name}-makefile.patch
9fc31b4a
JB
34Patch2: %{name}-m4.patch
35Patch3: aliases.patch
afc7c8ba 36# maintained by me, sent upstream from time to time --qboosh
d42bf791 37Patch4: %{name}-pl.po-update.patch
0d6c2643 38URL: http://lftp.yar.ru/
7e9d0681 39BuildRequires: autoconf >= 2.60
2a2b7922 40BuildRequires: automake
404c9e4b 41BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 42%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 43BuildRequires: libstdc++-devel
6b77b6dc 44BuildRequires: libtool >= 1:1.4.2-9
eb634329 45BuildRequires: ncurses-devel >= 5.2
117d16ec 46%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 47BuildRequires: pkgconfig
eb634329 48BuildRequires: readline-devel >= 4.2
7bf4d9a3 49BuildRequires: tar >= 1:1.22
50BuildRequires: xz
4502d222 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 52
fed66524 53%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
54%if %{_gcc_ver} == 2
55%define __cxx "%{__cc}"
56%endif
f544d322 57
0fcf33fd 58%description
aa601f68 59LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 60advantages over other FTP clients are reliability and ability to
c37d8459 61perform tasks in background. It will reconnect and reget the file
62being transferred if the connection broke. You can start a transfer in
b25ac3f9 63background and continue browsing on the FTP site. It does this all in
c37d8459 64one process. When you have started background jobs and feel you are
65done, you can just exit lftp and it automatically moves to nohup mode
66and completes the transfers. It has also such nice features as reput
67and mirror.
0fcf33fd 68
29127d3f 69%description -l pl.UTF-8
aa601f68 70Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
71połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
72ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
73połączenia po tym jak się wylogujesz. Program ten honoruje komendy
74powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
75jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 76
29127d3f
JR
77%description -l pt_BR.UTF-8
78O lftp é um programa de transferência de arquivos por linha de
aa601f68 79comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
80HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
81tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 82o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 83
0fcf33fd 84%prep
6588894c 85%setup -q
eaf4e234 86
43f4d1c2 87%patch1 -p1
ec7a935e 88%patch2 -p1
922a4344 89%patch3 -p1
de3ed365 90#%patch4 -p1
a41e3bec 91
33b4fdae
AM
92%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
93
0fcf33fd 94%build
dc2417fa 95%{__libtoolize}
07e8f8cb 96%{__gettextize}
29f4b0b0 97%{__aclocal} -I m4
cbf16d8c 98%{__autoconf}
99%{__automake}
8ad8d289 100CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 101%configure \
9f24e3d9 102 --with-modules \
117d16ec 103 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
104 --with%{!?with_gnutls:out}-gnutls
105
3579d696 106%{__make}
0fcf33fd 107
108%install
109rm -rf $RPM_BUILD_ROOT
10a3b210 110install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
be14979d 113
f1bf5d4a
ER
114cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
115cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
116cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 117
e84c29c9 118bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
119%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
120%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 121
df169521 122%find_lang %{name}
165ff9f8 123
0fcf33fd 124%clean
125rm -rf $RPM_BUILD_ROOT
126
43f4d1c2
JB
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
df169521 130%files -f %{name}.lang
be14979d 131%defattr(644,root,root,755)
e84c29c9 132%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 133%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
134%attr(755,root,root) %{_bindir}/lftp
135%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 136%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
137%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
138%dir %{_libdir}/lftp
d81e41f6 139%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 140%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
141%{_mandir}/man1/lftp.1*
142%{_mandir}/man1/lftpget.1*
143%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 144%{_mandir}/man5/lftp.conf.5*
10a3b210 145%{_desktopdir}/lftp.desktop
c37d8459 146%{_pixmapsdir}/lftp.png
This page took 0.096233 seconds and 4 git commands to generate.