]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- rel 3
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5596a2d5
AM
7# better just preload it instead forcing linking
8%bcond_with dante # Dante-based SOCKS support
db510deb
AM
9# broken currently https://www.dnssec-tools.org/trac/ticket/173
10%bcond_with dnssec # DNSSEC local validation
5869f11d 11#
117d16ec 12%if %{with ssl}
13%define with_openssl 1
14%endif
15
4f313d5c 16%if %{with gnutls} && %{with ssl}
117d16ec 17%undefine with_openssl
4f313d5c 18%endif
117d16ec 19
aa601f68 20Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
21Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
22Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
23Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
24Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 25Name: lftp
89c89514 26Version: 4.7.3
6efff5be 27Release: 3
474948d1 28License: GPL v3+
4e6de64c 29Group: Applications/Networking
fad90e34 30Source0: http://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
89c89514 31# Source0-md5: 23deda16014412c802f095fbaa0bebee
e84c29c9 32Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 33# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 34Source2: %{name}.desktop
fbf2ab8a 35Source3: %{name}-icon.png
93dfd0ea 36Patch100: %{name}-git.patch
5bf73c23
JB
37Patch0: %{name}-makefile.patch
38Patch1: %{name}-m4.patch
39Patch2: aliases.patch
88eff545 40# when updated attach at https://github.com/lavv17/lftp/issues
5bf73c23 41Patch3: %{name}-pl.po-update.patch
9d3763af 42Patch4: %{name}-am.patch
0d6c2643 43URL: http://lftp.yar.ru/
7e9d0681 44BuildRequires: autoconf >= 2.60
2a2b7922 45BuildRequires: automake
5869f11d
JB
46%{?with_dante:BuildRequires: dante-devel}
47%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 48BuildRequires: expat-devel
fb96bafa 49BuildRequires: gettext-tools >= 0.14.2
d4e96cc1 50%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 51BuildRequires: libstdc++-devel
6b77b6dc 52BuildRequires: libtool >= 1:1.4.2-9
eb634329 53BuildRequires: ncurses-devel >= 5.2
117d16ec 54%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 55BuildRequires: pkgconfig
eb634329 56BuildRequires: readline-devel >= 4.2
7bf4d9a3 57BuildRequires: tar >= 1:1.22
58BuildRequires: xz
4502d222 59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 60
fed66524 61%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
62%if %{_gcc_ver} == 2
63%define __cxx "%{__cc}"
64%endif
f544d322 65
0fcf33fd 66%description
aa601f68 67LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 68advantages over other FTP clients are reliability and ability to
c37d8459 69perform tasks in background. It will reconnect and reget the file
70being transferred if the connection broke. You can start a transfer in
b25ac3f9 71background and continue browsing on the FTP site. It does this all in
c37d8459 72one process. When you have started background jobs and feel you are
73done, you can just exit lftp and it automatically moves to nohup mode
74and completes the transfers. It has also such nice features as reput
75and mirror.
0fcf33fd 76
29127d3f 77%description -l pl.UTF-8
aa601f68 78Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
79połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
80ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
81połączenia po tym jak się wylogujesz. Program ten honoruje komendy
82powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
83jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 84
29127d3f
JR
85%description -l pt_BR.UTF-8
86O lftp é um programa de transferência de arquivos por linha de
aa601f68 87comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
88HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
89tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 90o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 91
0fcf33fd 92%prep
6588894c 93%setup -q
b6884ac3 94%patch100 -p1
5bf73c23 95%patch0 -p1
43f4d1c2 96%patch1 -p1
ec7a935e 97%patch2 -p1
630ae2d7 98%patch3 -p1
bce12c75 99%patch4 -p1
a41e3bec 100
b9a2e61d
JB
101%{__rm} po/stamp-po
102
33b4fdae
AM
103%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
104
0fcf33fd 105%build
dc2417fa 106%{__libtoolize}
07e8f8cb 107%{__gettextize}
29f4b0b0 108%{__aclocal} -I m4
cbf16d8c 109%{__autoconf}
110%{__automake}
8ad8d289 111CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 112%configure \
d2c1e0b5 113 --without-included-regex \
5869f11d 114 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 115 --with-modules \
5869f11d 116 --with-socksdante%{!?with_dante:=no} \
117d16ec 117 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
118 --with%{!?with_gnutls:out}-gnutls
119
3579d696 120%{__make}
0fcf33fd 121
122%install
123rm -rf $RPM_BUILD_ROOT
10a3b210 124install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT
be14979d 127
f1bf5d4a
ER
128cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
129cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 131
e84c29c9 132bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
133%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 135
df169521 136%find_lang %{name}
165ff9f8 137
0fcf33fd 138%clean
139rm -rf $RPM_BUILD_ROOT
140
43f4d1c2
JB
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
df169521 144%files -f %{name}.lang
be14979d 145%defattr(644,root,root,755)
e84c29c9 146%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
148%attr(755,root,root) %{_bindir}/lftp
149%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 150%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
151%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
152%dir %{_libdir}/lftp
d81e41f6 153%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 154%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
155%{_mandir}/man1/lftp.1*
156%{_mandir}/man1/lftpget.1*
157%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 158%{_mandir}/man5/lftp.conf.5*
10a3b210 159%{_desktopdir}/lftp.desktop
c37d8459 160%{_pixmapsdir}/lftp.png
This page took 0.074627 seconds and 4 git commands to generate.