]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- up to 4.4.3
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5869f11d
JB
7%bcond_without dante # Dante-based SOCKS support
8%bcond_without dnssec # DNSSEC local validation
9#
117d16ec 10%if %{with ssl}
11%define with_openssl 1
12%endif
13
4f313d5c 14%if %{with gnutls} && %{with ssl}
117d16ec 15%undefine with_openssl
4f313d5c 16%endif
117d16ec 17
aa601f68 18Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
19Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
20Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
21Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
22Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 23Name: lftp
710f55be 24Version: 4.4.3
d2c1e0b5 25Release: 1
474948d1 26License: GPL v3+
4e6de64c 27Group: Applications/Networking
b8664870 28Source0: http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
710f55be 29# Source0-md5: 6d32f7314453babef80b41e8da5f2a43
e84c29c9 30Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 31# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 32Source2: %{name}.desktop
fbf2ab8a 33Source3: %{name}-icon.png
5bf73c23
JB
34Patch0: %{name}-makefile.patch
35Patch1: %{name}-m4.patch
36Patch2: aliases.patch
afc7c8ba 37# maintained by me, sent upstream from time to time --qboosh
5bf73c23 38Patch3: %{name}-pl.po-update.patch
bce12c75 39Patch4: lftp-4.3.8-gets.patch
5869f11d 40Patch5: %{name}-am.patch
0d6c2643 41URL: http://lftp.yar.ru/
7e9d0681 42BuildRequires: autoconf >= 2.60
2a2b7922 43BuildRequires: automake
5869f11d
JB
44%{?with_dante:BuildRequires: dante-devel}
45%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 46BuildRequires: expat-devel
404c9e4b 47BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 48%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 49BuildRequires: libstdc++-devel
6b77b6dc 50BuildRequires: libtool >= 1:1.4.2-9
eb634329 51BuildRequires: ncurses-devel >= 5.2
117d16ec 52%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 53BuildRequires: pkgconfig
eb634329 54BuildRequires: readline-devel >= 4.2
7bf4d9a3 55BuildRequires: tar >= 1:1.22
56BuildRequires: xz
4502d222 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 58
fed66524 59%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
60%if %{_gcc_ver} == 2
61%define __cxx "%{__cc}"
62%endif
f544d322 63
0fcf33fd 64%description
aa601f68 65LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 66advantages over other FTP clients are reliability and ability to
c37d8459 67perform tasks in background. It will reconnect and reget the file
68being transferred if the connection broke. You can start a transfer in
b25ac3f9 69background and continue browsing on the FTP site. It does this all in
c37d8459 70one process. When you have started background jobs and feel you are
71done, you can just exit lftp and it automatically moves to nohup mode
72and completes the transfers. It has also such nice features as reput
73and mirror.
0fcf33fd 74
29127d3f 75%description -l pl.UTF-8
aa601f68 76Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
77połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
78ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
79połączenia po tym jak się wylogujesz. Program ten honoruje komendy
80powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
81jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 82
29127d3f
JR
83%description -l pt_BR.UTF-8
84O lftp é um programa de transferência de arquivos por linha de
aa601f68 85comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
86HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
87tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 88o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 89
0fcf33fd 90%prep
6588894c 91%setup -q
5bf73c23 92%patch0 -p1
43f4d1c2 93%patch1 -p1
ec7a935e 94%patch2 -p1
d2c1e0b5 95#%patch3 -p1
bce12c75 96%patch4 -p1
5869f11d 97%patch5 -p1
a41e3bec 98
33b4fdae
AM
99%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
100
0fcf33fd 101%build
dc2417fa 102%{__libtoolize}
07e8f8cb 103%{__gettextize}
29f4b0b0 104%{__aclocal} -I m4
cbf16d8c 105%{__autoconf}
106%{__automake}
8ad8d289 107CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 108%configure \
d2c1e0b5 109 --without-included-regex \
5869f11d 110 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 111 --with-modules \
5869f11d 112 --with-socksdante%{!?with_dante:=no} \
117d16ec 113 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
114 --with%{!?with_gnutls:out}-gnutls
115
3579d696 116%{__make}
0fcf33fd 117
118%install
119rm -rf $RPM_BUILD_ROOT
10a3b210 120install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
be14979d 123
f1bf5d4a
ER
124cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
125cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
126cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 127
e84c29c9 128bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
129%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
130%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 131
df169521 132%find_lang %{name}
165ff9f8 133
0fcf33fd 134%clean
135rm -rf $RPM_BUILD_ROOT
136
43f4d1c2
JB
137%post -p /sbin/ldconfig
138%postun -p /sbin/ldconfig
139
df169521 140%files -f %{name}.lang
be14979d 141%defattr(644,root,root,755)
e84c29c9 142%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
144%attr(755,root,root) %{_bindir}/lftp
145%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 146%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
147%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
148%dir %{_libdir}/lftp
d81e41f6 149%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 150%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
151%{_mandir}/man1/lftp.1*
152%{_mandir}/man1/lftpget.1*
153%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 154%{_mandir}/man5/lftp.conf.5*
10a3b210 155%{_desktopdir}/lftp.desktop
c37d8459 156%{_pixmapsdir}/lftp.png
This page took 0.109693 seconds and 4 git commands to generate.