]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
Revert "- workaround for gnulib junk conflict with libtool 2.4.3"
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5596a2d5
AM
7# better just preload it instead forcing linking
8%bcond_with dante # Dante-based SOCKS support
db510deb
AM
9# broken currently https://www.dnssec-tools.org/trac/ticket/173
10%bcond_with dnssec # DNSSEC local validation
5869f11d 11#
117d16ec 12%if %{with ssl}
13%define with_openssl 1
14%endif
15
4f313d5c 16%if %{with gnutls} && %{with ssl}
117d16ec 17%undefine with_openssl
4f313d5c 18%endif
117d16ec 19
aa601f68 20Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
21Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
22Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
23Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
24Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 25Name: lftp
d1e29e62 26Version: 4.6.0
5749762b 27Release: 3
474948d1 28License: GPL v3+
4e6de64c 29Group: Applications/Networking
fad90e34 30Source0: http://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
d1e29e62 31# Source0-md5: fc5f4e3b45c9011a193eb8c0c12eb2eb
e84c29c9 32Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 33# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 34Source2: %{name}.desktop
fbf2ab8a 35Source3: %{name}-icon.png
93dfd0ea 36Patch100: %{name}-git.patch
5bf73c23
JB
37Patch0: %{name}-makefile.patch
38Patch1: %{name}-m4.patch
39Patch2: aliases.patch
88eff545 40# when updated attach at https://github.com/lavv17/lftp/issues
5bf73c23 41Patch3: %{name}-pl.po-update.patch
bce12c75 42Patch4: lftp-4.3.8-gets.patch
5869f11d 43Patch5: %{name}-am.patch
5749762b 44Patch6: lftp-du-block.patch
0d6c2643 45URL: http://lftp.yar.ru/
7e9d0681 46BuildRequires: autoconf >= 2.60
2a2b7922 47BuildRequires: automake
5869f11d
JB
48%{?with_dante:BuildRequires: dante-devel}
49%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 50BuildRequires: expat-devel
404c9e4b 51BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 52%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 53BuildRequires: libstdc++-devel
6b77b6dc 54BuildRequires: libtool >= 1:1.4.2-9
eb634329 55BuildRequires: ncurses-devel >= 5.2
117d16ec 56%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 57BuildRequires: pkgconfig
eb634329 58BuildRequires: readline-devel >= 4.2
7bf4d9a3 59BuildRequires: tar >= 1:1.22
60BuildRequires: xz
4502d222 61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 62
fed66524 63%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
64%if %{_gcc_ver} == 2
65%define __cxx "%{__cc}"
66%endif
f544d322 67
0fcf33fd 68%description
aa601f68 69LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 70advantages over other FTP clients are reliability and ability to
c37d8459 71perform tasks in background. It will reconnect and reget the file
72being transferred if the connection broke. You can start a transfer in
b25ac3f9 73background and continue browsing on the FTP site. It does this all in
c37d8459 74one process. When you have started background jobs and feel you are
75done, you can just exit lftp and it automatically moves to nohup mode
76and completes the transfers. It has also such nice features as reput
77and mirror.
0fcf33fd 78
29127d3f 79%description -l pl.UTF-8
aa601f68 80Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
81połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
82ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
83połączenia po tym jak się wylogujesz. Program ten honoruje komendy
84powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
85jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 86
29127d3f
JR
87%description -l pt_BR.UTF-8
88O lftp é um programa de transferência de arquivos por linha de
aa601f68 89comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
90HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
91tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 92o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 93
0fcf33fd 94%prep
6588894c 95%setup -q
5df5f166 96#%patch100 -p1
5bf73c23 97%patch0 -p1
43f4d1c2 98%patch1 -p1
ec7a935e 99%patch2 -p1
2c088666 100%patch3 -p1
bce12c75 101%patch4 -p1
5869f11d 102%patch5 -p1
5749762b 103%patch6 -p1
a41e3bec 104
b9a2e61d
JB
105%{__rm} po/stamp-po
106
33b4fdae
AM
107%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
108
0fcf33fd 109%build
dc2417fa 110%{__libtoolize}
07e8f8cb 111%{__gettextize}
29f4b0b0 112%{__aclocal} -I m4
cbf16d8c 113%{__autoconf}
114%{__automake}
8ad8d289 115CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 116%configure \
d2c1e0b5 117 --without-included-regex \
5869f11d 118 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 119 --with-modules \
5869f11d 120 --with-socksdante%{!?with_dante:=no} \
117d16ec 121 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
122 --with%{!?with_gnutls:out}-gnutls
123
3579d696 124%{__make}
0fcf33fd 125
126%install
127rm -rf $RPM_BUILD_ROOT
10a3b210 128install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
129%{__make} install \
130 DESTDIR=$RPM_BUILD_ROOT
be14979d 131
f1bf5d4a
ER
132cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
133cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
134cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 135
e84c29c9 136bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
137%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
138%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 139
df169521 140%find_lang %{name}
165ff9f8 141
0fcf33fd 142%clean
143rm -rf $RPM_BUILD_ROOT
144
43f4d1c2
JB
145%post -p /sbin/ldconfig
146%postun -p /sbin/ldconfig
147
df169521 148%files -f %{name}.lang
be14979d 149%defattr(644,root,root,755)
e84c29c9 150%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 151%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
152%attr(755,root,root) %{_bindir}/lftp
153%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 154%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
155%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
156%dir %{_libdir}/lftp
d81e41f6 157%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 158%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
159%{_mandir}/man1/lftp.1*
160%{_mandir}/man1/lftpget.1*
161%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 162%{_mandir}/man5/lftp.conf.5*
10a3b210 163%{_desktopdir}/lftp.desktop
c37d8459 164%{_pixmapsdir}/lftp.png
This page took 0.09564 seconds and 4 git commands to generate.