]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- updated pl.po-update patch
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5596a2d5
AM
7# better just preload it instead forcing linking
8%bcond_with dante # Dante-based SOCKS support
db510deb
AM
9# broken currently https://www.dnssec-tools.org/trac/ticket/173
10%bcond_with dnssec # DNSSEC local validation
5869f11d 11#
117d16ec 12%if %{with ssl}
13%define with_openssl 1
14%endif
15
4f313d5c 16%if %{with gnutls} && %{with ssl}
117d16ec 17%undefine with_openssl
4f313d5c 18%endif
117d16ec 19
aa601f68 20Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
21Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
22Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
23Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
24Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 25Name: lftp
44954320
AM
26Version: 4.6.2
27Release: 1
474948d1 28License: GPL v3+
4e6de64c 29Group: Applications/Networking
fad90e34 30Source0: http://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
44954320 31# Source0-md5: 487c064ee1bd732e5f95928e530435a8
e84c29c9 32Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 33# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 34Source2: %{name}.desktop
fbf2ab8a 35Source3: %{name}-icon.png
93dfd0ea 36Patch100: %{name}-git.patch
5bf73c23
JB
37Patch0: %{name}-makefile.patch
38Patch1: %{name}-m4.patch
39Patch2: aliases.patch
88eff545 40# when updated attach at https://github.com/lavv17/lftp/issues
5bf73c23 41Patch3: %{name}-pl.po-update.patch
bce12c75 42Patch4: lftp-4.3.8-gets.patch
5869f11d 43Patch5: %{name}-am.patch
0d6c2643 44URL: http://lftp.yar.ru/
7e9d0681 45BuildRequires: autoconf >= 2.60
2a2b7922 46BuildRequires: automake
5869f11d
JB
47%{?with_dante:BuildRequires: dante-devel}
48%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 49BuildRequires: expat-devel
fb96bafa 50BuildRequires: gettext-tools >= 0.14.2
d4e96cc1 51%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 52BuildRequires: libstdc++-devel
6b77b6dc 53BuildRequires: libtool >= 1:1.4.2-9
eb634329 54BuildRequires: ncurses-devel >= 5.2
117d16ec 55%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 56BuildRequires: pkgconfig
eb634329 57BuildRequires: readline-devel >= 4.2
7bf4d9a3 58BuildRequires: tar >= 1:1.22
59BuildRequires: xz
4502d222 60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 61
fed66524 62%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
63%if %{_gcc_ver} == 2
64%define __cxx "%{__cc}"
65%endif
f544d322 66
0fcf33fd 67%description
aa601f68 68LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 69advantages over other FTP clients are reliability and ability to
c37d8459 70perform tasks in background. It will reconnect and reget the file
71being transferred if the connection broke. You can start a transfer in
b25ac3f9 72background and continue browsing on the FTP site. It does this all in
c37d8459 73one process. When you have started background jobs and feel you are
74done, you can just exit lftp and it automatically moves to nohup mode
75and completes the transfers. It has also such nice features as reput
76and mirror.
0fcf33fd 77
29127d3f 78%description -l pl.UTF-8
aa601f68 79Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
80połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
81ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
82połączenia po tym jak się wylogujesz. Program ten honoruje komendy
83powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
84jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 85
29127d3f
JR
86%description -l pt_BR.UTF-8
87O lftp é um programa de transferência de arquivos por linha de
aa601f68 88comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
89HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
90tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 91o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 92
0fcf33fd 93%prep
6588894c 94%setup -q
5df5f166 95#%patch100 -p1
5bf73c23 96%patch0 -p1
43f4d1c2 97%patch1 -p1
ec7a935e 98%patch2 -p1
2c088666 99%patch3 -p1
bce12c75 100%patch4 -p1
5869f11d 101%patch5 -p1
a41e3bec 102
b9a2e61d
JB
103%{__rm} po/stamp-po
104
33b4fdae
AM
105%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
106
0fcf33fd 107%build
dc2417fa 108%{__libtoolize}
07e8f8cb 109%{__gettextize}
29f4b0b0 110%{__aclocal} -I m4
cbf16d8c 111%{__autoconf}
112%{__automake}
8ad8d289 113CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 114%configure \
d2c1e0b5 115 --without-included-regex \
5869f11d 116 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 117 --with-modules \
5869f11d 118 --with-socksdante%{!?with_dante:=no} \
117d16ec 119 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
120 --with%{!?with_gnutls:out}-gnutls
121
3579d696 122%{__make}
0fcf33fd 123
124%install
125rm -rf $RPM_BUILD_ROOT
10a3b210 126install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
127%{__make} install \
128 DESTDIR=$RPM_BUILD_ROOT
be14979d 129
f1bf5d4a
ER
130cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
131cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
132cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 133
e84c29c9 134bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
135%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
136%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 137
df169521 138%find_lang %{name}
165ff9f8 139
0fcf33fd 140%clean
141rm -rf $RPM_BUILD_ROOT
142
43f4d1c2
JB
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
df169521 146%files -f %{name}.lang
be14979d 147%defattr(644,root,root,755)
e84c29c9 148%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 149%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
150%attr(755,root,root) %{_bindir}/lftp
151%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 152%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
153%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
154%dir %{_libdir}/lftp
d81e41f6 155%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 156%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
157%{_mandir}/man1/lftp.1*
158%{_mandir}/man1/lftpget.1*
159%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 160%{_mandir}/man5/lftp.conf.5*
10a3b210 161%{_desktopdir}/lftp.desktop
c37d8459 162%{_pixmapsdir}/lftp.png
This page took 0.297376 seconds and 4 git commands to generate.