]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- up to 4.8.0
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
324a7201 5%bcond_without tests
7b39c852
JB
6%bcond_without ssl # do not use SSL
7%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
5596a2d5
AM
8# better just preload it instead forcing linking
9%bcond_with dante # Dante-based SOCKS support
db510deb
AM
10# broken currently https://www.dnssec-tools.org/trac/ticket/173
11%bcond_with dnssec # DNSSEC local validation
5869f11d 12#
117d16ec 13%if %{with ssl}
14%define with_openssl 1
15%endif
16
4f313d5c 17%if %{with gnutls} && %{with ssl}
117d16ec 18%undefine with_openssl
4f313d5c 19%endif
117d16ec 20
aa601f68 21Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
22Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
23Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
24Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
25Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 26Name: lftp
7f7f5464 27Version: 4.8.0
df55f7fc 28Release: 1
474948d1 29License: GPL v3+
4e6de64c 30Group: Applications/Networking
df55f7fc 31Source0: https://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
7f7f5464 32# Source0-md5: 468558412ad3575ef8e98547c41339f4
e84c29c9 33Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 34# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 35Source2: %{name}.desktop
fbf2ab8a 36Source3: %{name}-icon.png
93dfd0ea 37Patch100: %{name}-git.patch
5bf73c23
JB
38Patch0: %{name}-makefile.patch
39Patch1: %{name}-m4.patch
40Patch2: aliases.patch
88eff545 41# when updated attach at https://github.com/lavv17/lftp/issues
5bf73c23 42Patch3: %{name}-pl.po-update.patch
9d3763af 43Patch4: %{name}-am.patch
df55f7fc 44URL: http://lftp.tech/
7e9d0681 45BuildRequires: autoconf >= 2.60
2a2b7922 46BuildRequires: automake
5869f11d
JB
47%{?with_dante:BuildRequires: dante-devel}
48%{?with_dnssec:BuildRequires: dnssec-tools-devel}
5bf73c23 49BuildRequires: expat-devel
fb96bafa 50BuildRequires: gettext-tools >= 0.14.2
d4e96cc1 51%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 52BuildRequires: libstdc++-devel
6b77b6dc 53BuildRequires: libtool >= 1:1.4.2-9
eb634329 54BuildRequires: ncurses-devel >= 5.2
117d16ec 55%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
1ecbb479 56BuildRequires: pkgconfig
eb634329 57BuildRequires: readline-devel >= 4.2
7bf4d9a3 58BuildRequires: tar >= 1:1.22
59BuildRequires: xz
4502d222 60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 61
fed66524 62%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
63%if %{_gcc_ver} == 2
64%define __cxx "%{__cc}"
65%endif
f544d322 66
0fcf33fd 67%description
aa601f68 68LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 69advantages over other FTP clients are reliability and ability to
c37d8459 70perform tasks in background. It will reconnect and reget the file
71being transferred if the connection broke. You can start a transfer in
b25ac3f9 72background and continue browsing on the FTP site. It does this all in
c37d8459 73one process. When you have started background jobs and feel you are
74done, you can just exit lftp and it automatically moves to nohup mode
75and completes the transfers. It has also such nice features as reput
76and mirror.
0fcf33fd 77
29127d3f 78%description -l pl.UTF-8
aa601f68 79Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
80połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
81ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
82połączenia po tym jak się wylogujesz. Program ten honoruje komendy
83powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
84jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 85
29127d3f
JR
86%description -l pt_BR.UTF-8
87O lftp é um programa de transferência de arquivos por linha de
aa601f68 88comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
89HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
90tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 91o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 92
0fcf33fd 93%prep
6588894c 94%setup -q
df55f7fc 95#%patch100 -p1
5bf73c23 96%patch0 -p1
43f4d1c2 97%patch1 -p1
ec7a935e 98%patch2 -p1
df55f7fc 99#%patch3 -p1
bce12c75 100%patch4 -p1
a41e3bec 101
b9a2e61d
JB
102%{__rm} po/stamp-po
103
33b4fdae
AM
104%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
105
0fcf33fd 106%build
dc2417fa 107%{__libtoolize}
07e8f8cb 108%{__gettextize}
29f4b0b0 109%{__aclocal} -I m4
cbf16d8c 110%{__autoconf}
111%{__automake}
8ad8d289 112CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 113%configure \
d2c1e0b5 114 --without-included-regex \
5869f11d 115 --with-dnssec-local-validation%{!?with_dnssec:=no} \
9f24e3d9 116 --with-modules \
5869f11d 117 --with-socksdante%{!?with_dante:=no} \
117d16ec 118 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
119 --with%{!?with_gnutls:out}-gnutls
120
3579d696 121%{__make}
0fcf33fd 122
324a7201
AM
123%{?with_tests:%{__make} check}
124
0fcf33fd 125%install
126rm -rf $RPM_BUILD_ROOT
10a3b210 127install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
f8f85376
JB
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
be14979d 130
f1bf5d4a
ER
131cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
132cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
133cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 134
e84c29c9 135bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
ec7a935e
JB
136%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
137%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 138
df169521 139%find_lang %{name}
165ff9f8 140
0fcf33fd 141%clean
142rm -rf $RPM_BUILD_ROOT
143
43f4d1c2
JB
144%post -p /sbin/ldconfig
145%postun -p /sbin/ldconfig
146
df169521 147%files -f %{name}.lang
be14979d 148%defattr(644,root,root,755)
e84c29c9 149%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 150%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
151%attr(755,root,root) %{_bindir}/lftp
152%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 153%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
154%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
155%dir %{_libdir}/lftp
d81e41f6 156%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 157%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
158%{_mandir}/man1/lftp.1*
159%{_mandir}/man1/lftpget.1*
160%lang(pl) %{_mandir}/pl/man1/lftpget.1*
907c17b9 161%{_mandir}/man5/lftp.conf.5*
10a3b210 162%{_desktopdir}/lftp.desktop
c37d8459 163%{_pixmapsdir}/lftp.png
This page took 0.077591 seconds and 4 git commands to generate.