]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
update BR, from cleanbuild
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
5b49e814 7%bcond_with hal # HAL dynamic device support [deprecated]
9d6715c4 8%bcond_without ldap # don't build LDAP DLL
16e36f25 9%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 10%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
5b49e814
JB
13# libGL (winex11.drv.so)
14# libOSMesa (gdi32.dll.so)
15# libX11 libXcomposite libXcursor libXext libXi libXinerama libXrandr libXrender libXxf86vm (winex11.drv.so)
16# libcapi20 (capi2032.dll.so)
17# libcups (winspool.drv.so)
18# libdbus (mountmgr.sys.so)
16e36f25 19# libfontconfig (gdi32.dll.so)
5b49e814
JB
20# libfreetype (gdi32.dll.so)
21# libgnutls (secur32.dll.so)
22# libhal (mountmgr.sys.so)
23# libjpeg (gphoto2.ds.so windowscodecs.dll.so)
24# libncurses (kernel32.dll.so)
25# libodbc (odbc32.dll.so)
26# libpng (windowscodecs.dll.so)
27# libsane (sane.ds.so)
28# libtiff (windowscodecs.dll.so)
29# libv4l1 (qcap.dll.so)
30# libxslt (msxml3.dll.so)
546bbb82 31# thus requires rebuild after change of any of the above.
db80a28e 32
4ce8abe1
ER
33# library qualifier in rpm generated deps
34%ifarch %{x8664} ia64 ppc64 s390x sparc64
35%define libqual ()(64bit)
36%else
37%define libqual %{nil}
38%endif
39
c516c269 40%define gecko_ver 2.24
698e86e7 41Summary: Program that lets you launch Win applications
93e41e44
ER
42Summary(es.UTF-8): Ejecuta programas Windows en Linux
43Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
44Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 45Name: wine
cbe4db03
JK
46# 1.8.x – stable
47# 1.9.x – development
c54d2750 48Version: 1.8
9dad7a50 49Release: 1
46114a9a 50Epoch: 1
528c1138 51License: LGPL
5c4ec57b 52Group: Applications/Emulators
beafc810 53Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
c54d2750 54# Source0-md5: 96b51a2f2ae727802d71095354e69fef
beafc810 55Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
c516c269 56# Source1-md5: 766bb034172f7f0a97443951a02a0df8
beafc810 57Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
c516c269 58# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
beafc810 59Source3: %{name}-uninstaller.desktop
55061442 60Patch0: %{name}-gphoto2_bool.patch
a0ff0658 61Patch1: %{name}-makedep.patch
a4a10255 62Patch2: %{name}-ncurses.patch
8b4bf701 63Patch4: %{name}-disable-valgrind.patch
5312a936 64Patch5: %{name}-ca_certificates.patch
a26a3859
JK
65Patch6: desktop.patch
66Patch7: %{name}-wine64_man.patch
1b3d8891 67URL: http://www.winehq.org/
5b49e814 68BuildRequires: Mesa-libOSMesa-devel
0aac4f59 69BuildRequires: OpenAL-devel >= 1.1
5b49e814 70BuildRequires: OpenCL-devel
489ca66c 71BuildRequires: OpenGL-GLU-devel
5b49e814 72BuildRequires: OpenGL-GLX-devel
d7296a19 73BuildRequires: Mesa-libOSMesa-devel
05596b04 74BuildRequires: ParaView-devel
6547534c
KK
75%{?with_alsa:BuildRequires: alsa-lib-devel}
76%{?with_arts:BuildRequires: artsc-devel}
5b49e814 77BuildRequires: autoconf >= 2.62
c7af491d 78BuildRequires: automake
d3c41437 79BuildRequires: bison
beafc810 80%{?with_capi:BuildRequires: capi4k-utils-devel}
05596b04 81BuildRequires: crossmingw64-gcc
5715e1d1 82%{?with_cups:BuildRequires: cups-devel}
5b49e814 83BuildRequires: dbus-devel
f88a3451 84BuildRequires: docbook-dtd31-sgml
85BuildRequires: docbook-utils
5b49e814 86BuildRequires: flex >= 2.5.33
16e36f25 87BuildRequires: fontconfig-devel
22432818 88BuildRequires: fontforge
5fc34681 89BuildRequires: freetype-devel >= 2.0.5
5b49e814 90# for findup used after make install
16b3dd87 91BuildRequires: fslint
05596b04
ER
92BuildRequires: ganv-devel
93BuildRequires: gegl-devel
94BuildRequires: gettext-devel
5b49e814
JB
95%ifarch %{x8664}
96BuildRequires: gcc >= 6:4.4
97%endif
1f0c428e 98BuildRequires: gettext-tools
734deeec 99BuildRequires: giflib-devel
c57a98fe 100BuildRequires: gnutls-devel
5b49e814
JB
101%{?with_gstreamer:BuildRequires: gstreamer0.10-devel >= 0.10}
102%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10}
103%{?with_hal:BuildRequires: hal-devel}
104# for icotool used in build
105BuildRequires: icoutils >= 0.29.0
05596b04
ER
106BuildRequires: klibc-devel
107BuildRequires: kudzu-devel
5b49e814 108BuildRequires: lcms2-devel >= 2
05596b04 109BuildRequires: libgcj-devel
beb8121e 110BuildRequires: libgphoto2-devel
d0d61ce7 111BuildRequires: libgsm-devel
c504380e 112BuildRequires: libjpeg-devel
05596b04 113BuildRequires: libkqueue-devel
2341e633 114BuildRequires: libmpg123-devel >= 1.5.0
c54d2750 115BuildRequires: libcap-devel
05596b04 116BuildRequires: libpcap-devel
5b49e814
JB
117BuildRequires: libpng-devel >= 1.5
118BuildRequires: libtiff-devel
1e160e6e 119BuildRequires: libtool
0aac4f59 120BuildRequires: libv4l-devel
5b49e814 121BuildRequires: libxml2-devel >= 2.0
fbb1220c 122BuildRequires: libxslt-devel
05596b04 123BuildRequires: lwp-devel
8a1d358f 124BuildRequires: ncurses-devel
16e36f25
JB
125# db2* failed previously - probably openjade or opensp bug
126BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 127%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 128BuildRequires: opensp >= 1:1.5.1
50f0bbbe 129BuildRequires: pulseaudio-devel
beb8121e 130BuildRequires: pkgconfig
beafc810 131BuildRequires: prelink
d7296a19 132BuildRequires: samba-devel
5715e1d1 133%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 134BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 135#BuildRequires: valgrind
5b49e814 136BuildRequires: xorg-lib-libX11-devel
beb8121e 137BuildRequires: xorg-lib-libXcomposite-devel
138BuildRequires: xorg-lib-libXcursor-devel
5b49e814 139BuildRequires: xorg-lib-libXext-devel
c66c3406 140BuildRequires: xorg-lib-libXi-devel
beb8121e 141BuildRequires: xorg-lib-libXinerama-devel
beb8121e 142BuildRequires: xorg-lib-libXrandr-devel
c66c3406 143BuildRequires: xorg-lib-libXrender-devel
c66c3406 144BuildRequires: xorg-lib-libXxf86vm-devel
05596b04 145BuildRequires: zfs-devel
5b49e814 146BuildRequires: zlib-devel
4ce8abe1 147Requires: libfreetype.so.6%{libqual}
a85c8746 148Requires: libpng16.so.16%{libqual}
8df63af6 149Requires(post): /sbin/ldconfig
ae42c99e 150Suggests: binfmt-detector
be70b824 151Suggests: ca-certificates
beafc810 152Suggests: cabextract
a2f68044 153Conflicts: ca-certificates < 20080809-4
b3d3861d 154# for printing needs lpr
155Suggests: cups-clients
f96e197b 156# for winelauncher
3bddfbf2 157Suggests: xorg-app-xmessage
f96e197b 158# for ntlm_auth
14e95129 159Suggests: samba-common >= 1:3.0.25
52b6007b
JB
160# link to wine/ntdll.dll.so, without any SONAME
161Provides: libntdll.dll.so
7212da21 162Obsoletes: wine-doc-pdf
93b34e12 163Obsoletes: wine-drv-arts
beafc810
MM
164Obsoletes: wine-drv-jack
165Obsoletes: wine-drv-nas
5b49e814 166ExclusiveArch: %{ix86} %{x8664} arm
206eed29 167ExcludeArch: i386
0403821a 168BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 169
e8f81a0a 170%define no_install_post_strip 1
171
e8f81a0a 172%define _winedir %{_datadir}/%{name}
6731627f 173
5c4ec57b 174%description
6731627f 175Wine is a program which allows running Microsoft Windows programs
a519bc4f 176(including DOS, Windows 3.x and Win32 executables) on Unix. It
177consists of a program loader which loads and executes a Microsoft
178Windows binary, and a library that implements Windows API calls using
179their Unix or X11 equivalents. The library may also be used for
180porting Win32 code into native Unix executables.
5c4ec57b 181
c967e47d 182%description -l es.UTF-8
f33a1517 183Ejecuta programas Windows en Linux.
184
c967e47d
JR
185%description -l pl.UTF-8
186Wine jest programem dzięki któremu można uruchamiać programy napisane
187dla Microsoft Windows pod systemami uniksowymi. Składa się on z
188loadera, który pozwala wczytywać i uruchamiać programy w formacie
189Microsoft Windows, oraz z biblioteki, która implementuje API Windows
190przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
191także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 192
c967e47d
JR
193%description -l pt_BR.UTF-8
194O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 195Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 196binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 197chamadas da API para as equivalentes Unix/X11.
198
5c4ec57b 199%package devel
7a050f82 200Summary: Wine - header files
93e41e44
ER
201Summary(es.UTF-8): Biblioteca de desarrollo de wine
202Summary(pl.UTF-8): Wine - pliki nagłowkowe
203Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 204Group: Development/Libraries
46114a9a 205Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 206
5c4ec57b 207%description devel
208Wine - header files.
209
c967e47d 210%description devel -l es.UTF-8
f33a1517 211Biblioteca de desarrollo de wine.
212
c967e47d
JR
213%description devel -l pl.UTF-8
214Wine - pliki nagłówkowe.
5c4ec57b 215
c967e47d
JR
216%description devel -l pt_BR.UTF-8
217Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 218WINE.
219
e8f81a0a 220%package programs
221Summary: Wine - programs
93e41e44 222Summary(pl.UTF-8): Wine - programy
e8f81a0a 223Group: Applications
46114a9a 224Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 225
226%description programs
0a7c5d50 227Wine - programs.
e8f81a0a 228
c967e47d 229%description programs -l pl.UTF-8
0a7c5d50 230Wine - programy.
e8f81a0a 231
beafc810
MM
232%package dll-capi
233Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
234Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
235Group: Applications/Emulators
236Requires: %{name} = %{epoch}:%{version}-%{release}
237
238%description dll-capi
b1df4aa7 239CAPI 2.0 (ISDN) implementation DLLs for Wine.
beafc810
MM
240
241%description dll-capi -l pl.UTF-8
b1df4aa7 242Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine.
beafc810 243
16e36f25
JB
244%package dll-d3d
245Summary: Direct3D implementation DLLs for Wine
93e41e44 246Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 247Group: Applications/Emulators
46114a9a 248Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
249Requires: OpenGL
250
251%description dll-d3d
252Direct3D implementation DLLs for Wine (through OpenGL).
253
c967e47d
JR
254%description dll-d3d -l pl.UTF-8
255Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
256
257%package dll-gl
258Summary: OpenGL implementation DLLs for Wine
93e41e44 259Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 260Group: Applications/Emulators
46114a9a 261Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
262Requires: OpenGL
263
264%description dll-gl
265OpenGL implementation DLLs for Wine.
266
c967e47d
JR
267%description dll-gl -l pl.UTF-8
268Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
269
270%package dll-twain
271Summary: TWAIN implementation DLL for Wine
93e41e44 272Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 273Group: Applications/Emulators
46114a9a 274Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
275
276%description dll-twain
277TWAIN implementation DLL for Wine (through SANE).
278
c967e47d
JR
279%description dll-twain -l pl.UTF-8
280Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 281
9d6715c4 282%package dll-ldap
db80a28e 283Summary: Win32 LDAP API DLL for Wine
b1df4aa7 284Summary(pl.UTF-8): Biblioteka DLL z implementacją API Win32 LDAP dla Wine
9d6715c4
ER
285Group: Applications/Emulators
286Requires: %{name} = %{epoch}:%{version}-%{release}
287
288%description dll-ldap
b1df4aa7
JB
289Lightweight Directory Access Protocol Library for Wine.
290
291%description dll-ldap -l pl.UTF-8
292Biblioteka LDAP (Lightweight Directory Access Protocol) dla Wine.
9d6715c4 293
16e36f25
JB
294%package drv-alsa
295Summary: ALSA driver for WINE mm.dll implementation
93e41e44 296Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 297Group: Applications/Emulators
46114a9a 298Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
299
300%description drv-alsa
301ALSA driver for WINE mm.dll (multimedia system) implementation.
302
c967e47d
JR
303%description drv-alsa -l pl.UTF-8
304Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 305
5c4ec57b 306%prep
db80a28e 307%setup -q
2fbbb535 308%patch0 -p1
309%patch1 -p1
ab25825d 310%patch2 -p1
8b4bf701 311%patch4 -p1
5312a936 312%patch5 -p1
3bfef0cd 313%patch6 -p1
f6cf693b 314%ifarch %{x8664}
a26a3859 315%patch7 -p1
f6cf693b 316%endif
591d55ba 317
5c4ec57b 318%build
887fffcf
ER
319icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
320mv -f oic_winlogo_*.png %{name}.png
321
2fbbb535 322%{__autoconf}
103d8328 323%{__autoheader}
9d6a128d 324%configure \
f829f028
AM
325%ifarch %{x8664}
326 --enable-win64 \
327%endif
5b49e814
JB
328 --with-alsa%{!?with_alsa:=no} \
329 --with-capi%{!?with_capi:=no} \
beb8121e 330 --with-cms \
d0d61ce7 331 --with-coreaudio \
5b49e814 332 --with-cups%{!?with_cups:=no} \
c504380e 333 --with-curses \
d7296a19 334 --with-dbus \
c504380e 335 --with-fontconfig \
336 --with-freetype \
d7296a19 337 --with-gphoto \
c504380e 338 --with-glu \
d0d61ce7 339 --with-gnutls \
d0d61ce7 340 --with-gsm \
8ec65640
JK
341 %{__with_without gstreamer} \
342 %{__with_without hal} \
c504380e 343 --with-jpeg \
5b49e814 344 --with-ldap%{!?with_ldap:=no} \
d0d61ce7 345 --with-mpg123 \
d7296a19
JK
346 --with%{!?with_netapi:out}-netapi \
347 --with-openal \
348 --with-opencl \
c504380e 349 --with-opengl \
d7296a19 350 --with-osmesa \
c504380e 351 --with-oss \
c54d2750 352 --with-pcap \
c504380e 353 --with-png \
d0d61ce7 354 --with-pthread \
c54d2750 355 --with-pulse \
c504380e 356 --with%{!?with_sane:out}-sane \
d7296a19
JK
357 --with-tiff \
358 --with-v4l \
beb8121e 359 --with-xcomposite \
360 --with-xcursor \
361 --with-xinerama \
362 --with-xinput \
d7296a19 363 --with-xinput2 \
c504380e 364 --with-xml \
beb8121e 365 --with-xrandr \
c504380e 366 --with-xrender \
367 --with-xshape \
368 --with-xshm \
369 --with-xslt \
beb8121e 370 --with-xxf86vm \
d7296a19
JK
371 --with-x \
372 --with-zlib
05eb066b 373%{__make} depend
4aafdd81 374%{__make}
e8f81a0a 375
5c4ec57b 376%install
377rm -rf $RPM_BUILD_ROOT
ffb676e0 378install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
379%{__make} install \
380 DESTDIR=$RPM_BUILD_ROOT
381
a26a3859 382install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 383cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 384
2a437456 385install -d \
65c325f6 386 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
387 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 388 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
389 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
390 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
391
a91c2692 392touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
393touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
394touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
395
76055aa1 396cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 397[mci]
398cdaudio=mcicda.drv
399sequencer=mciseq.drv
400waveaudio=mciwave.drv
401avivideo=mciavi.drv
402videodisc=mcipionr.drv
403vcr=mciviscd.drv
404MPEGVideo=mciqtz.drv
5c4ec57b 405EOF
406
80496098 407# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 408
887fffcf
ER
409dir=$(pwd)
410> files.so
411> files.programs
55a96819 412cd $RPM_BUILD_ROOT%{_libdir}/wine
413for f in *.so; do
16e36f25 414 case $f in
ad4623a1 415 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
416 ;;
417 *)
418 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 419 esac
55a96819 420done
421cd -
887fffcf
ER
422
423programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 424for p in $programs; do
8d493411 425 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
426 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 427 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 428 grep -v "$p\.exe\.so$" files.so > files.so.
429 mv -f files.so. files.so
55a96819 430done
55a96819 431
a26a3859
JK
432for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
433 mv "$dir" "${dir%.UTF-8}"
434done
435
f6cf693b 436%ifarch %{x8664}
c54d2750
JK
437install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine64.1
438for lang in de fr pl ; do
439install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
440install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine64.1
441done
442%else
443install loader/wine.man $RPM_BUILD_ROOT%{_mandir}/man1/wine.1
444for lang in de fr pl ; do
445install -d $RPM_BUILD_ROOT%{_mandir}/${lang}/man1
446install loader/wine.${lang}.UTF-8.man $RPM_BUILD_ROOT%{_mandir}/${lang}/man1/wine.1
f6cf693b
JK
447done
448%endif
449
f7357f09 450install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 451%ifnarch %{x8664}
db80a28e 452cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 453%else
db80a28e 454cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 455%endif
f7357f09 456
887fffcf 457install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
458cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
459cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 460
5c4ec57b 461%clean
462rm -rf $RPM_BUILD_ROOT
463
8df63af6 464%post
db80a28e 465/sbin/ldconfig
8df63af6
ER
466%update_desktop_database
467
f1f3af79
JB
468%postun -p /sbin/ldconfig
469
d142aa07 470%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 471rm -f /var/lock/subsys/wine
d142aa07
JB
472if [ -x /sbin/chkconfig ]; then
473 /sbin/chkconfig --del wine
474fi
475
55a96819 476%files -f files.so
5c4ec57b 477%defattr(644,root,root,755)
47bd64d5 478%doc README AUTHORS ANNOUNCE
12b1296e 479%lang(de) %doc documentation/README.de
480%lang(es) %doc documentation/README.es
481%lang(fr) %doc documentation/README.fr
0aac4f59 482%lang(hu) %doc documentation/README.hu
12b1296e 483%lang(it) %doc documentation/README.it
7b9e958b 484%lang(ko) %doc documentation/README.ko
58a0e5f4 485%lang(nb) %doc documentation/README.no
12b1296e 486%lang(pt) %doc documentation/README.pt
74de5921 487%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
488%lang(ru) %doc documentation/README.ru
489%lang(sv) %doc documentation/README.sv
490%lang(tr) %doc documentation/README.tr
82432451 491%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
492%ifnarch %{x8664}
493%attr(755,root,root) %{_bindir}/wine
494%else
495%attr(755,root,root) %{_bindir}/wine64
496%endif
d479f953 497%attr(755,root,root) %{_bindir}/wineboot
55a96819 498%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 499%attr(755,root,root) %{_bindir}/winecfg
beafc810 500%ifnarch %{x8664}
f829f028 501%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
502%else
503%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 504%endif
beafc810 505%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 506%attr(755,root,root) %{_libdir}/*.so*
861238d3 507%dir %{_libdir}/wine
61e39970 508%dir %{_libdir}/wine/fakedlls
509%{_libdir}/wine/fakedlls/*.acm
510%{_libdir}/wine/fakedlls/*.cpl
511%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
512%ifarch %{ix86}
513%{_libdir}/wine/fakedlls/*.dll16
514%endif
61e39970 515%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
516%ifarch %{ix86}
517%{_libdir}/wine/fakedlls/*.drv16
518%endif
61e39970 519%{_libdir}/wine/fakedlls/*.ds
520%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
521%ifarch %{ix86}
522%{_libdir}/wine/fakedlls/*.exe16
523%{_libdir}/wine/fakedlls/*.mod16
524%endif
61e39970 525%{_libdir}/wine/fakedlls/*.ocx
526%{_libdir}/wine/fakedlls/*.sys
527%{_libdir}/wine/fakedlls/*.tlb
f829f028 528%ifarch %{ix86}
61e39970 529%{_libdir}/wine/fakedlls/*.vxd
f829f028 530%endif
f6cf693b 531%ifnarch %{x8664}
b86f1c34 532%{_mandir}/man1/wine.1*
47bd64d5
JK
533%lang(de) %{_mandir}/de/man1/wine.1*
534%lang(fr) %{_mandir}/fr/man1/wine.1*
535%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
536%else
537%{_mandir}/man1/wine64.1*
538%lang(de) %{_mandir}/de/man1/wine64.1*
539%lang(fr) %{_mandir}/fr/man1/wine64.1*
540%lang(pl) %{_mandir}/pl/man1/wine64.1*
541%endif
da274952
AG
542%{_mandir}/man1/msiexec.1*
543%{_mandir}/man1/wineboot.1*
544%{_mandir}/man1/winecfg.1*
72ede285 545%{_mandir}/man1/winedbg.1*
b86f1c34 546%{_mandir}/man1/wineserver.1*
ad4623a1
AM
547%lang(de) %{_mandir}/de/man1/wineserver.1*
548%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 549%{_winedir}
a6c536e0 550%{_desktopdir}/wine.desktop
76055aa1 551%{_desktopdir}/wine-uninstaller.desktop
887fffcf 552%{_pixmapsdir}/%{name}.png
5c4ec57b 553
55a96819 554%files programs -f files.programs
e8f81a0a 555%defattr(644,root,root,755)
e8f81a0a 556
5c4ec57b 557%files devel
558%defattr(644,root,root,755)
a26a3859 559%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 560%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 561%attr(755,root,root) %{_bindir}/widl
55a96819 562%attr(755,root,root) %{_bindir}/winebuild
55a96819 563%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 564%attr(755,root,root) %{_bindir}/wineg++
d479f953 565%attr(755,root,root) %{_bindir}/winegcc
566%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 567%attr(755,root,root) %{_bindir}/winecpp
55a96819 568%attr(755,root,root) %{_bindir}/wmc
d479f953 569%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
570%{_libdir}/wine/lib*.def
571# no shared variants, so not separated
572%{_libdir}/wine/lib*.def.a
b93e474e 573%{_libdir}/wine/libadsiid.a
7265d9f2 574%{_libdir}/wine/libdx*.a
beafc810 575%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
576%{_libdir}/wine/libstrmiids.a
577%{_libdir}/wine/libuuid.a
578%{_libdir}/wine/libwinecrt0.a
5c4ec57b 579%{_includedir}/wine
34f03014 580%{_mandir}/man1/widl.1*
0aac4f59 581%{_mandir}/man1/winebuild.1*
da274952 582%{_mandir}/man1/winecpp.1*
34f03014 583%{_mandir}/man1/winedump.1*
bff06719 584%{_mandir}/man1/winegcc.1*
5ec7e550 585%{_mandir}/man1/wineg++.1*
34f03014 586%{_mandir}/man1/winemaker.1*
0aac4f59 587%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 588%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
589%{_mandir}/man1/wmc.1*
590%{_mandir}/man1/wrc.1*
2b5050a8 591%{_aclocaldir}/*.m4
f18f723c 592
beafc810
MM
593%files dll-capi
594%defattr(644,root,root,755)
595%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
596
16e36f25
JB
597%files dll-d3d
598%defattr(644,root,root,755)
599%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
600%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
601%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
602
603%files dll-gl
604%defattr(644,root,root,755)
605%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
606%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
607
608%if %{with sane}
609%files dll-twain
610%defattr(644,root,root,755)
b08b16bf 611%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 612%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
613%endif
614
9d6715c4
ER
615%if %{with ldap}
616%files dll-ldap
617%defattr(644,root,root,755)
618%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
619%endif
620
16e36f25
JB
621%if %{with alsa}
622%files drv-alsa
623%defattr(644,root,root,755)
624%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
625%endif
626
16e36f25 627# additional dependencies in *.so not separated (yet?) from main package
b1df4aa7
JB
628# ddraw.dll.so,winex11.drv.so depend on X11 libs
629# ole2disp.dll16.so,oleaut32.dll.so,typelib.dll16.so depend on libX11
This page took 0.191158 seconds and 4 git commands to generate.