]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- rel 0.3
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
c296fee0 3# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 4#
89427592 5# Conditional build:
0a1ccab0 6%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6 7%bcond_without python3 # don't build python bindings
b0333243 8%bcond_without plugins # build plugins
af0cc499 9%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
85c29998 10%bcond_with imaevm # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
858aa7d0 11
6f068494
JR
12%define db_ver 5.3.28.0
13%define popt_ver 1.15
24b1f498 14%define sover 9.1.0
fc60c9f3 15
7bf81d56
JR
16%if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
17%define with_recommends_tags 1
18%endif
8a4b67ac 19
e5f02e49 20Summary: RPM Package Manager
4ea2ed33
ER
21Summary(de.UTF-8): RPM Packet-Manager
22Summary(es.UTF-8): Gestor de paquetes RPM
23Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
24Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
25Summary(ru.UTF-8): Менеджер пакетов от RPM
26Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 27Name: rpm
24b1f498 28Version: 4.16.0
224660aa 29Release: 0.3
9fe07969 30Epoch: 1
98d9fc8e 31License: GPL v2 / LGPL v2.1
76214164 32Group: Base
24b1f498
JR
33Source0: http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
34# Source0-md5: 434e166a812e35ef181f6dd176326920
faba01eb
JR
35Source1: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
36# Source1-md5: 23914bb49fafe7153cee87126d966461
37Source2: macros.local
38Source3: macros.lang
39Source4: %{name}.sysconfig
40Source5: %{name}.groups
80b8a1f9 41Source6: %{name}-groups-po.awk
faba01eb
JR
42Source7: %{name}-install-tree
43Source8: %{name}-hrmib-cache
44Source9: %{name}-user_group.sh
a4b7ef27 45# http://svn.pld-linux.org/banner.sh/
faba01eb 46Source10: banner.sh
b2d6b731
JR
47Source11: %{name}.noautoprov
48Source12: %{name}.noautoprovfiles
49Source13: %{name}.noautoreq
50Source14: %{name}.noautoreqfiles
51Source15: perl.prov
52Source16: %{name}db_checkversion.c
53Source17: %{name}db_reset.c
54Source18: dbupgrade.sh
af0cc499
JR
55Patch0: %{name}-man_pl.patch
56Patch1: %{name}-popt-aliases.patch
57Patch2: %{name}-perl-macros.patch
58Patch3: %{name}-perl-req-perlfile.patch
59Patch4: %{name}-scripts-closefds.patch
cbab0cbf
JR
60Patch6: %{name}-perl_req-INC_dirs.patch
61Patch7: %{name}-debuginfo.patch
62Patch8: %{name}-libtool-deps.patch
63Patch9: %{name}-builddir-readlink.patch
64Patch10: %{name}-changelog_order_check_nonfatal.patch
65Patch11: %{name}-postun-nofail.patch
66Patch12: %{name}-clean-docdir.patch
67Patch13: %{name}-perl-magic.patch
68Patch14: %{name}-ignore-missing-macro-files.patch
69Patch15: x32.patch
b2d6b731
JR
70Patch16: rpm5-db-compat.patch
71Patch17: python-internal-build.patch
5570f8e6 72Patch18: rpmversion.patch
837ad262 73Patch19: pkgconfig.patch
f16801b5 74Patch20: uname-deps.patch
7f5abfc0 75Patch21: aarch64.patch
5c979c25 76Patch22: ix86-platforms.patch
681ee2f6 77URL: https://rpm.org/
ee163f1b 78BuildRequires: acl-devel
6f068494 79BuildRequires: db-devel >= %{db_ver}
29855fc2 80BuildRequires: autoconf >= 2.63
644d8958 81BuildRequires: automake >= 1.4
33be5db0 82BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 83BuildRequires: elfutils-devel >= 0.108
3e70c06e 84BuildRequires: gettext-tools >= 0.19.2
af0cc499 85BuildRequires: libarchive-devel
ee163f1b 86BuildRequires: libcap-devel
241257bf 87BuildRequires: libmagic-devel
0d108dc8 88BuildRequires: libgcrypt-devel
b0333243
JR
89%if %{with plugins}
90BuildRequires: audit-libs-devel
91BuildRequires: dbus-devel
85c29998 92%{?with_imaevm:BuildRequires: libimaevm-devel >= 1.0}
6e115b23 93BuildRequires: libselinux-devel >= 2.1.0
6e115b23 94%endif
84cdee7a
JB
95# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
96BuildRequires: libstdc++-devel
b60c74c3 97BuildRequires: libtool >= 1:1.4.2-9
127a0b3c 98BuildRequires: ossp-uuid-devel
7973b351 99BuildRequires: patch >= 2.2
ae228405 100BuildRequires: pkgconfig(lua) >= 5.1
6f068494 101BuildRequires: popt-devel >= %{popt_ver}
85c29998
JR
102BuildRequires: python3-modules
103%if %{with python3}
104BuildRequires: python3-devel
f9d0e5f6 105BuildRequires: rpm-pythonprov
3d169da3 106BuildRequires: rpmbuild(macros) >= 1.750
f9d0e5f6 107%endif
85c29998 108BuildRequires: sqlite3-devel >= 3.22.0
e56a10a9 109BuildRequires: tcl
77fcdbf7 110BuildRequires: xz-devel
3acb62f3 111BuildRequires: zlib-devel
34865f27 112BuildRequires: zstd-devel
5c2ab5c7
AM
113%if %{with apidocs}
114BuildRequires: doxygen
115BuildRequires: ghostscript
116BuildRequires: graphviz
117BuildRequires: tetex-pdftex
118%endif
d25ec6ea 119Requires(posttrans): coreutils
9fe07969
JR
120Requires: %{name}-base = %{epoch}:%{version}-%{release}
121Requires: %{name}-lib = %{epoch}:%{version}-%{release}
3de8e4a9 122Requires: rpm-pld-macros >= 1.744
d1f5e279 123Requires: FHS >= 3.0-2
0d108dc8 124Requires: libgcrypt
6f068494 125Requires: popt >= %{popt_ver}
b0333243
JR
126%if %{with recommends_tags}
127Recommends: rpm-plugin-audit
128Recommends: rpm-plugin-prioreset
129Recommends: rpm-plugin-syslog
130Recommends: rpm-plugin-systemd-inhibit
131%endif
d1f5e279 132Obsoletes: rpm-utils-perl
f57f030d 133Obsoletes: rpm-utils-static
874f4c9a 134Conflicts: glibc < 2.2.92
8ee1c72c
AM
135# db4.6 poldek needed
136Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
137# segfaults with lzma 0.42.2
138Conflicts: lzma-libs < 4.999.3
e4084afd 139Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 140BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 141
4adb7d05 142%define _binary_payload w9.gzdio
6d82b332 143
4cd84746 144# don't require very fresh rpm.macros to build
950eead3 145%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 146%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 147%define ppc ppc ppc7400 ppc7450
9f517079 148%define x8664 amd64 ia32e x86_64
4cd84746 149
d755a548
JK
150%define _rpmlibdir /usr/lib/rpm
151
ff7bc1e6 152%description
153RPM is a powerful package manager, which can be used to build,
154install, query, verify, update, and uninstall individual software
cf6faebc 155packages. A package consists of an archive of files, and package
fed73700 156information, including name, version, and description.
157
dd85fadc
JR
158%description -l de.UTF-8
159RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 160Installation, Anfrage, Verifizierung, Aktualisierung und
161Uninstallation individueller Softwarepakete. Ein Paket besteht aus
162einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 163Beschreibung.
164
dd85fadc 165%description -l es.UTF-8
313a4d1a 166RPM es un poderoso administrador de paquetes, que puede ser usado para
167construir, instalar, pesquisar, verificar, actualizar y desinstalar
168paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
169almacenaje de archivos, y información sobre el paquete, incluyendo
170nombre, versión y descripción.
171
172%description -l pl.UTF-8
173RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
174przebudowanie, instalację czy weryfikację dowolnego pakietu.
175Informacje dotyczące każdego pakietu, takie jak jego opis, lista
176plików wchodzących w skład pakietu, zależności od innych pakietów, są
177przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 178odpytywania programu rpm.
179
dd85fadc
JR
180%description -l pt_BR.UTF-8
181RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 182construir, instalar, pesquisar, verificar, atualizar e desinstalar
183pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
184arquivos e informações adicionais, incluindo nome, versão e descrição
185do pacote, permissões dos arquivos, etc.
186
187%description -l ru.UTF-8
188RPM - это мощный менеджер пакетов, который может быть использован для
189создания, инсталляции, запросов (query), проверки, обновления и
190удаления программных пакетов. Пакет состоит из файлового архива и
191служебной информации, включающей название, версию, описание и другие
192данные о пакете.
193
194%description -l uk.UTF-8
195RPM - це потужний менеджер пакетів, що може бути використаний для
196створення, інсталяції, запитів (query), перевірки, поновлення та
197видалення програмних пакетів. Пакет складається з файлового архіву та
198службової інформації, що містить назву, версію, опис та іншу
199інформацію про пакет.
7c6dc55f 200
66edd895
JB
201%package base
202Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 203Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 204Group: Base
1d9ca0c1 205Requires: filesystem
950eead3 206Obsoletes: rpm-scripts
66edd895
JB
207Obsoletes: vserver-rpm
208
209%description base
210The RPM base package contains scripts used by rpm packages themselves.
211These include:
212- scripts for adding/removing groups and users needed for rpm
213 packages,
214- banner.sh to display %%banner messages from rpm scriptlets.
215
dd85fadc
JR
216%description base -l pl.UTF-8
217Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 218Zawiera on:
dd85fadc
JR
219- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
220- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 221
69131f1a
JB
222%package lib
223Summary: RPMs library
4ea2ed33 224Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 225Group: Libraries
6f068494 226Requires: db >= %{db_ver}
241257bf 227Requires: libmagic >= 1.15-2
6f068494 228Requires: popt >= %{popt_ver}
d1795eb0 229Obsoletes: rpm-libs
69131f1a
JB
230# avoid SEGV caused by mixed db versions
231Conflicts: poldek < 0.18.1-16
232
233%description lib
234RPMs library.
235
dd85fadc 236%description lib -l pl.UTF-8
69131f1a
JB
237Biblioteki RPM-a.
238
fed73700 239%package devel
3f2d796a 240Summary: Header files for rpm libraries
4ea2ed33
ER
241Summary(de.UTF-8): Header-Dateien für rpm Libraries
242Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
243Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
244Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
245Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
246Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 247Group: Development/Libraries
9fe07969 248Requires: %{name}-lib = %{epoch}:%{version}-%{release}
fea3cb89 249Requires: bzip2-devel
24b1f498 250Requires: db-devel >= %{db_ver}
5c583f90 251Requires: elfutils-devel
241257bf 252Requires: libmagic-devel
0d108dc8 253Requires: libgcrypt-devel
c7b2d5f9
KK
254%if %{with selinux}
255Requires: libselinux-devel
256Requires: libsemanage-devel
257Requires: libsepol-devel
258%endif
6f068494 259Requires: popt-devel >= %{popt_ver}
fea3cb89 260Requires: zlib-devel
cf6faebc 261
262%description devel
3f2d796a
JB
263The RPM packaging system includes C libraries that make it easy to
264manipulate RPM packages and databases. They are intended to ease the
cf6faebc 265creation of graphical package managers and other tools that need
3f2d796a
JB
266intimate knowledge of RPM packages. This package contains header files
267for these libraries.
fed73700 268
dd85fadc
JR
269%description devel -l de.UTF-8
270Der RPM-Packensystem enthält eine C-Library, die macht es einfach
271RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 272Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 273Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
274
dd85fadc 275%description devel -l es.UTF-8
313a4d1a 276El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
277fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
278facilitar la creación de administradores gráficos de paquetes y otras
20f89981 279herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 280
dd85fadc
JR
281%description devel -l pl.UTF-8
282System RPM zawiera biblioteki C, które ułatwiają manipulowanie
283pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
284graficznych programów zarządzających pakietami oraz innych narzędzi,
285które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
286zawiera pliki nagłówkowe wspomnianych bibliotek.
287
288%description devel -l pt_BR.UTF-8
289O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
290a manipulação de pacotes e bases de dados RPM. Seu objetivo é
291facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 292ferramentas que precisem de conhecimento profundo de pacotes RPM.
293
dd85fadc
JR
294%description devel -l ru.UTF-8
295Система управления пакетами RPM содержит библиотеку C, которая
296упрощает манипуляцию пакетами RPM и соответствующими базами данных.
297Эта библиотека предназначена для облегчения создания графических
298пакетных менеджеров и других утилит, которым необходимо работать с
299пакетами RPM.
7c6dc55f 300
dd85fadc
JR
301%description devel -l uk.UTF-8
302Система керування пакетами RPM містить бібліотеку C, котра спрощує
303роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
304призначена для полегшення створення графічних пакетних менеджерів та
305інших утиліт, що працюють з пакетами RPM.
7c6dc55f 306
fed73700 307%package utils
8482995c 308Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
309Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
310Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 311Group: Applications/File
9fe07969 312Requires: %{name} = %{epoch}:%{version}-%{release}
6f068494 313Requires: popt >= %{popt_ver}
af0cc499
JR
314%if %{with recommends_tags}
315Recommends: bzip2
316Recommends: gzip
86b85368 317%endif
695e60ad 318Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 319
320%description utils
8482995c 321Additional utilities for managing RPM packages and database.
fed73700 322
dd85fadc
JR
323%description utils -l de.UTF-8
324Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 325
dd85fadc
JR
326%description utils -l pl.UTF-8
327Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 328
fed73700 329%package build
e191287c 330Summary: Scripts for building binary RPM packages
4ea2ed33
ER
331Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
332Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
333Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
334Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
335Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 336Group: Applications/File
f15ca8ca
ER
337Requires(pretrans): coreutils
338Requires(pretrans): findutils
9fe07969 339Requires: %{name}-utils = %{epoch}:%{version}-%{release}
3de8e4a9 340Requires: rpm-pld-macros-build >= 1.744
e191287c 341Requires: /bin/id
342Requires: awk
cfa7898a 343Requires: bzip2
e950a6d7 344Requires: chrpath >= 0.10-4
b6547e10 345Requires: cpio
e191287c 346Requires: diffutils
195f647c 347Requires: elfutils
583135b4 348Requires: file >= 4.17
e191287c 349Requires: fileutils
350Requires: findutils
950eead3
ER
351%ifarch athlon
352Requires: gcc >= 3.0.3
353%else
354Requires: gcc
355%endif
e191287c 356Requires: glibc-devel
357Requires: grep
358Requires: gzip
359Requires: make
360Requires: patch
adbd4815 361Requires: sed >= 4.0
e191287c 362Requires: sh-utils
adbd4815 363Requires: tar >= 1:1.22
e191287c 364Requires: textutils
3acb62f3 365Requires: which
adbd4815 366Requires: xz
37ea389a 367Provides: rpmbuild(noauto) = 3
02d17bf9 368%ifarch %{x8664}
195f647c
JB
369Conflicts: automake < 1:1.7.9-2
370Conflicts: libtool < 2:1.5-13
371%endif
0096c5cd 372
e2025ad1 373%description build
58399c37 374Scripts for building binary RPM packages.
fed73700 375
dd85fadc
JR
376%description build -l de.UTF-8
377Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 378
dd85fadc
JR
379%description build -l pl.UTF-8
380Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 381
dd85fadc
JR
382%description build -l pt_BR.UTF-8
383Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 384construir pacotes usando o RPM.
e73478cd 385
dd85fadc
JR
386%description build -l ru.UTF-8
387Различные вспомогательные скрипты и исполняемые программы, которые
388используются для сборки RPM'ов.
7c6dc55f 389
dd85fadc
JR
390%description build -l uk.UTF-8
391Різноманітні допоміжні скрипти та утиліти, які використовуються для
392побудови RPM'ів.
7c6dc55f 393
69131f1a 394%package perlprov
8482995c 395Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 396Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 397Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 398Group: Applications/File
9fe07969 399Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 400Requires: perl-Encode
69131f1a
JB
401Requires: perl-devel
402Requires: perl-modules
403
404%description perlprov
8482995c 405Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
406packages.
407
dd85fadc
JR
408%description perlprov -l de.UTF-8
409Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 410
dd85fadc 411%description perlprov -l pl.UTF-8
8482995c
JB
412Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
413pakietach RPM.
69131f1a
JB
414
415%package pythonprov
8482995c
JB
416Summary: Python macros, which simplifies creation of RPM packages with Python software
417Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 418Group: Applications/File
9fe07969 419Requires: %{name} = %{epoch}:%{version}-%{release}
85c29998
JR
420Requires: python3
421Requires: python3-modules
422Requires: python3-setuptools
69131f1a
JB
423
424%description pythonprov
8482995c 425Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
426software.
427
dd85fadc 428%description pythonprov -l pl.UTF-8
8482995c 429Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
430Pythonie.
431
f9d0e5f6
JR
432%package -n python3-rpm
433Summary: Python 3 interface to RPM library
434Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
435Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
436Group: Development/Languages/Python
9fe07969 437Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6 438Requires: python3
85c29998
JR
439Obsoletes: python-rpm < 1:4.16.0
440Obsoletes: rpm-python
f9d0e5f6
JR
441
442%description -n python3-rpm
443The python3-rpm package contains a module which permits applications
444written in the Python 3 programming language to use the interface
445supplied by RPM (RPM Package Manager) libraries.
446
447This package should be installed if you want to develop Python 3
448programs that will manipulate RPM packages and databases.
449
450%description -n python3-rpm -l pl.UTF-8
451Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
24b1f498
JR
452Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
453RPM-a.
f9d0e5f6
JR
454
455Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
456Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
457
458%description -n python3-rpm -l pt_BR.UTF-8
459O pacote python3-rpm contém um módulo que permite que aplicações
460escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
461RPM (RPM Package Manager).
462
463Esse pacote deve ser instalado se você quiser desenvolver programas em
464Python 3 para manipular pacotes e bancos de dados RPM.
465
b0333243
JR
466%package plugin-audit
467Summary: Plugin for logging audit events on package operations
24b1f498 468Group: Base
9fe07969 469Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
470
471%description plugin-audit
472Plugin for libaudit support
473
474%package plugin-syslog
475Summary: Plugin for syslog functionality
24b1f498 476Group: Base
9fe07969 477Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
478
479%description plugin-syslog
480This plugin exports RPM actions to the system log.
481
482%package plugin-systemd-inhibit
483Summary: Plugin for systemd inhibit functionality
24b1f498 484Group: Base
9fe07969 485Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
486
487%description plugin-systemd-inhibit
488This plugin blocks systemd from entering idle, sleep or shutdown while
489an rpm transaction is running using the systemd-inhibit mechanism.
490
491%package plugin-ima
492Summary: Plugin for IMA file signatures
493Group: Base
9fe07969 494Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
495
496%description plugin-ima
497This plugin adds support for enforcing and verifying IMA file
498signatures in an rpm.
499
500%package plugin-prioreset
501Summary: Plugin for resetting scriptlet priorities for SysV init
502Group: Base
9fe07969 503Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
504
505%description plugin-prioreset
506This plugin is useful on legacy SysV init systems if you run rpm
507transactions with nice/ionice priorities. Should not be used on
508systemd systems.
509
510%package plugin-selinux
511Summary: Plugin for SELinux functionality
8191f3c5 512Group: Base
9fe07969 513Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
514Requires: libselinux >= 2.1.0
515
516%description plugin-selinux
517Plugin for SELinux functionality.
518
8191f3c5
JR
519%package sign
520Summary: Package signing support
521Group: Base
9fe07969 522Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
523
524%description sign
525This package contains support for digitally signing RPM packages.
526
5c2ab5c7
AM
527%package apidocs
528Summary: RPM API documentation and guides
529Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
530Group: Documentation
d308de4c 531BuildArch: noarch
5c2ab5c7
AM
532
533%description apidocs
534Documentation for RPM API and guides in HTML format generated from rpm
535sources by doxygen.
536
537%description apidocs -l pl.UTF-8
538Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
539źrodeł RPM-a przez doxygen.
540
e2025ad1 541%prep
c546a4d6 542%setup -q -n %{name}-%{version}%{?subver}
af0cc499 543%patch0 -p1
2f0ee4ec 544%patch1 -p1
4d5b8e4c 545%patch2 -p1
af0cc499 546%patch3 -p1
7a3b1f24 547%patch4 -p1
cbab0cbf
JR
548%patch6 -p0
549%patch7 -p1
af0cc499 550%patch8 -p1
cbab0cbf 551%patch9 -p1
af0cc499
JR
552%patch10 -p1
553%patch11 -p1
554%patch12 -p1
555%patch13 -p1
556%patch14 -p1
7033e976 557%patch15 -p1
af0cc499
JR
558%patch16 -p1
559%patch17 -p1
5570f8e6 560%patch18 -p1
837ad262 561%patch19 -p1
f16801b5 562%patch20 -p1
7f5abfc0 563%patch21 -p1
5c979c25 564%patch22 -p1
883e0fac 565
b2d6b731 566install %{SOURCE15} scripts/perl.prov.in
08697680 567
70f8787d 568%{__mv} -f scripts/perl.req{,.in}
633d1e9e 569
cd86db2e 570# generate Group translations to *.po
faba01eb 571awk -f %{SOURCE6} %{SOURCE5}
fefe9d30 572
b2d6b731
JR
573install %{SOURCE16} tools/rpmdb_checkversion.c
574install %{SOURCE17} tools/rpmdb_reset.c
91ee86a9 575
24b1f498 576%{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
40675133 577
87ef0d95 578%build
ea816ea6 579%{__libtoolize}
ceaaacee 580%{__aclocal}
4cd84746 581%{__autoheader}
7a9d72ce 582%{__autoconf}
7a9d72ce 583%{__automake}
7a9d72ce 584
048d06f8
JR
585# rpm checks for CPU type at runtime, but it looks better
586sed -i \
587 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
588 -e 's|@host_cpu@|%{_target_cpu}|' \
589 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 590 macros.in
048d06f8 591
624f96ff 592%configure \
01d7a578 593 WITH_PERL_VERSION=no \
bba1059c 594 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 595 __GPG=%{_bindir}/gpg \
85c29998
JR
596%if %{with python3}
597 PYTHON=python3 \
598 --enable-python \
599%endif
3a3e476f 600 --disable-silent-rules \
cd86db2e 601 --enable-shared \
34865f27 602 --enable-bdb \
85c29998
JR
603 --enable-ndb \
604 --enable-sqlite \
af0cc499 605 --enable-zstd \
c38bf1df 606 --with-lua \
85c29998 607 %{?with_imaevm:--with-imaevm} \
34865f27
JR
608 --with-cap \
609 --with-acl \
610 --with-audit \
af0cc499 611 --with-archive \
b0333243
JR
612 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
613 %{!?with_plugins:--disable-plugins} \
34865f27
JR
614 --with-vendor=pld
615
5c767dc1 616%{__make}
5c2ab5c7 617
6f068494
JR
618%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
619%{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
fb95de52
JR
620
621if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
622 echo "Error linking rpmdb tools!"
623 exit 1
624fi
8e8746c0
JR
625if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
626 echo "Error linking rpmdb tools!"
627 exit 1
628fi
91ee86a9 629
f9d0e5f6
JR
630%if %{with python3}
631cd python
632%py3_build
633%endif
634
b064b8e6 635%install
ff7bc1e6 636rm -rf $RPM_BUILD_ROOT
d1f5e279 637install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
7d12560f 638 $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
54eb1770 639
faba01eb 640cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 641
d1f5e279 642%{__make} install \
241257bf
AM
643 pkgconfigdir=%{_pkgconfigdir} \
644 DESTDIR=$RPM_BUILD_ROOT
718426e1 645
c546a4d6 646# cleanup
c2683840 647%ifnarch %{ix86} %{x8664} x32
2f409bb7 648rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 649rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
650rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
651rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
652rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
653rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
654rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
655rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
656%endif
657
c2683840 658%ifnarch %{x8664} x32
2f409bb7
JR
659rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
660rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
661rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
662rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
663%endif
664
c546a4d6 665%ifnarch %{ppc}
34865f27
JR
666rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
667rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
668rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
669rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
670rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 671rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 672rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
673%endif
674
7f5abfc0 675%ifnarch aarch64
34865f27 676rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
7f5abfc0
JP
677%endif
678
2f409bb7
JR
679rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
680rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
681rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
682rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 683rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 684rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 685rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 686rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 687
0727c61e
JR
688cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
689%ifarch x32
690%{_target_cpu}-%{_target_vendor}-linux-gnux32
691%else
692%{_target_cpu}-%{_target_vendor}-linux
693%endif
694EOF
695
3a3e476f 696%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 697
396a7387 698install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
396a7387 699
faba01eb
JR
700cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
701cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
702cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
703cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 704
faba01eb 705cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 706
faba01eb
JR
707cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
708cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
b2d6b731
JR
709cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
710cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
711cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
712cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 713
f9d0e5f6
JR
714cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
715cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
b2d6b731 716cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 717
950eead3 718# move rpm to /bin
8191f3c5
JR
719%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
720ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
721ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
722
950eead3 723# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
724for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
725 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
726 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
727done
728
7d12560f
JR
729#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
730
85c29998
JR
731# Make sure we have bdb set a default backend
732grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
6f18cdb7 733
f9d0e5f6
JR
734%if %{with python3}
735# Remove anything that rpm make install might put there
736%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
737cd python
738%py3_install
739cd ..
dae5e1a8 740%endif
01d7a578 741
d1f5e279
JR
742%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
743
01d7a578 744# wrong location, not used anyway
2f409bb7 745%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 746
90b03dd6 747%find_lang %{name}
cf6faebc 748
13eb5ebf 749%clean
d7df46b8 750rm -rf $RPM_BUILD_ROOT
76214164 751
be4d3036 752%posttrans
d25ec6ea 753if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 754 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 755 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 756 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 757 echo
e4dd6a34 758 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
759 echo
760 fi
3ca91ccd
JR
761 echo
762 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
763 echo 'you should ignore it and restart poldek'
764 echo
f9d0e5f6 765 %{_rpmlibdir}/dbupgrade.sh
be4d3036 766fi
f7779567 767
b7ee97ef
JR
768%triggerpostun -- %{name} < 4.4.9-44
769%{_rpmlibdir}/hrmib-cache
770
ceaaacee
JB
771%post lib -p /sbin/ldconfig
772%postun lib -p /sbin/ldconfig
76214164 773
37a5a2fc 774%pretrans build
d755a548 775find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 776
3684d90f
JB
777%files -f %{name}.lang
778%defattr(644,root,root,755)
d1f5e279 779%doc ChangeLog CREDITS README
3684d90f 780
3acb62f3
ER
781%dir /etc/pki/rpm-gpg
782/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 783
7a9d72ce 784%attr(755,root,root) /bin/rpm
8191f3c5
JR
785%attr(755,root,root) %{_bindir}/rpmdb
786%attr(755,root,root) %{_bindir}/rpmkeys
787%attr(755,root,root) %{_bindir}/rpmquery
788%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 789
66edd895 790%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 791%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
0727c61e
JR
792# this is ok to be replaced
793%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
caf453d4 794
09bb810c 795%{_mandir}/man8/rpm.8*
8191f3c5
JR
796%{_mandir}/man8/rpmdb.8*
797%{_mandir}/man8/rpmkeys.8*
798%{_mandir}/man8/rpm-misc.8*
24b1f498 799%{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
feb1f12e 800%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 801%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 802%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 803%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 804%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 805%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 806
7d12560f 807%dir /var/lib/rpm
4acac5de 808
cf709a39
ER
809# exported package NVRA (stamped with install tid)
810# net-snmp hrSWInstalledName queries, bash-completions
811%dir /var/cache/hrmib
812
d755a548 813%{_rpmlibdir}/rpmpopt*
8191f3c5 814%{_rpmlibdir}/rpmrc
d755a548 815%{_rpmlibdir}/macros
08697680 816%dir %{_rpmlibdir}/macros.d
e8836e1f 817%dir %{_rpmlibdir}/platform
40675133 818%{_rpmlibdir}/platform/noarch-*
c2683840 819%ifarch %{ix86} %{x8664} x32
34865f27
JR
820%{_rpmlibdir}/platform/athlon*
821%{_rpmlibdir}/platform/geode*
40675133
JR
822%{_rpmlibdir}/platform/i?86*
823%{_rpmlibdir}/platform/pentium*
34865f27
JR
824%endif
825%ifarch %{x8664} x32
826%{_rpmlibdir}/platform/amd64*
827%{_rpmlibdir}/platform/ia32e*
828%{_rpmlibdir}/platform/x86_64*
83a0601a 829%{_rpmlibdir}/platform/x32*
e23edf35
JR
830%endif
831%ifarch alpha
40675133 832%{_rpmlibdir}/platform/alpha*
e23edf35 833%endif
7f5abfc0
JP
834%ifarch aarch64
835%{_rpmlibdir}/platform/aarch64*
836%endif
e23edf35 837%ifarch ia64
40675133 838%{_rpmlibdir}/platform/ia64*
e23edf35
JR
839%endif
840%ifarch mips mipsel mips64 mips64el
40675133 841%{_rpmlibdir}/platform/mips*
e23edf35
JR
842%endif
843%ifarch %{ppc}
40675133 844%{_rpmlibdir}/platform/ppc*
e23edf35
JR
845%endif
846%ifarch sparc sparc64
40675133 847%{_rpmlibdir}/platform/sparc*
e23edf35 848%endif
3684d90f 849
3de8e4a9 850%dir %{_rpmlibdir}/pld
396a7387 851
cf709a39
ER
852%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
853
f9d0e5f6
JR
854%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
855%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
856%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
24b1f498
JR
857%attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
858%attr(755,root,root) %{_rpmlibdir}/rpmdb_load
df50421f 859
7d12560f
JR
860# valgrind suppression file for rpm
861%{_rpmlibdir}/rpm.supp
862
66edd895
JB
863%files base
864%defattr(644,root,root,755)
492a2bd4 865%dir %{_sysconfdir}/rpm
66edd895
JB
866%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
867%dir %{_rpmlibdir}
868%attr(755,root,root) %{_bindir}/banner.sh
869%attr(755,root,root) %{_rpmlibdir}/user_group.sh
870%dir /var/lib/banner
871
874f4c9a
MM
872%files lib
873%defattr(644,root,root,755)
40675133
JR
874%attr(755,root,root) /%{_lib}/librpm.so.9
875%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
876%attr(755,root,root) /%{_lib}/librpmbuild.so.9
877%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
878%attr(755,root,root) /%{_lib}/librpmio.so.9
879%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
880%attr(755,root,root) /%{_lib}/librpmsign.so.9
881%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 882%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 883
69131f1a
JB
884%files devel
885%defattr(644,root,root,755)
69131f1a 886%attr(755,root,root) %{_libdir}/librpm.so
950eead3 887%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 888%attr(755,root,root) %{_libdir}/librpmio.so
40675133 889%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
890%{_libdir}/librpm*.la
891%{_includedir}/rpm
892%{_pkgconfigdir}/*.pc
69131f1a 893
69131f1a
JB
894%files utils
895%defattr(644,root,root,755)
d1f5e279 896%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 897%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 898%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 899%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 900%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
25e974c7 901%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
902%attr(755,root,root) %{_rpmlibdir}/debugedit
903%attr(755,root,root) %{_rpmlibdir}/rpmdeps
24b1f498 904%{_mandir}/man8/rpm2archive.8*
69131f1a
JB
905%{_mandir}/man8/rpm2cpio.8*
906%{_mandir}/man8/rpmdeps.8*
fc36dfd5 907%{_mandir}/man8/rpmgraph.8*
69131f1a 908%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 909%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 910%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 911%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 912%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
913%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
914%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 915
3684d90f 916%files build
a45ae6d8 917%defattr(644,root,root,755)
66edd895 918%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
919%attr(755,root,root) %{_rpmlibdir}/brp-*
920%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 921%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 922%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578
JB
923%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
924# needs hacked pkg-config to return anything
925%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 926%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
37e965e8 927
70f8787d 928%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 929# must be here for "Requires: rpm-*prov" to work
40675133
JR
930#%{_rpmlibdir}/macros.d/cmake
931#%{_rpmlibdir}/macros.d/gstreamer
40675133 932#%{_rpmlibdir}/macros.d/libtool
40675133 933#%{_rpmlibdir}/macros.d/perl
40675133
JR
934#%{_rpmlibdir}/macros.d/pkgconfig
935#%{_rpmlibdir}/macros.d/python
40675133
JR
936#%{_rpmlibdir}/macros.d/selinux
937#%{_rpmlibdir}/macros.d/tcl
938#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 939
7d12560f
JR
940%attr(755,root,root) %{_rpmlibdir}/check-buildroot
941%attr(755,root,root) %{_rpmlibdir}/check-prereqs
942%attr(755,root,root) %{_rpmlibdir}/check-rpaths
943%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
7d12560f
JR
944%attr(755,root,root) %{_rpmlibdir}/find-provides
945%attr(755,root,root) %{_rpmlibdir}/find-requires
24b1f498 946%attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
7d12560f
JR
947%attr(755,root,root) %{_rpmlibdir}/script.req
948%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
7d12560f 949
f9d0e5f6
JR
950%dir %{_rpmlibdir}/fileattrs
951%{_rpmlibdir}/fileattrs/debuginfo.attr
952%{_rpmlibdir}/fileattrs/desktop.attr
953%{_rpmlibdir}/fileattrs/elf.attr
954%{_rpmlibdir}/fileattrs/font.attr
955%{_rpmlibdir}/fileattrs/libtool.attr
956%{_rpmlibdir}/fileattrs/metainfo.attr
957%{_rpmlibdir}/fileattrs/ocaml.attr
958%{_rpmlibdir}/fileattrs/perl.attr
959%{_rpmlibdir}/fileattrs/perllib.attr
f9d0e5f6
JR
960%{_rpmlibdir}/fileattrs/pkgconfig.attr
961%{_rpmlibdir}/fileattrs/python.attr
962%{_rpmlibdir}/fileattrs/pythondist.attr
963%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 964
874f4c9a
MM
965%attr(755,root,root) %{_bindir}/gendiff
966%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 967%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 968
a00926bc 969%{_mandir}/man1/gendiff.1*
d1f5e279 970%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 971%{_mandir}/man8/rpmbuild.8*
fefe9d30 972%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 973%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 974%{_mandir}/man8/rpmspec.8*
f3fe287f 975
89334051
AF
976%files perlprov
977%defattr(644,root,root,755)
d755a548 978%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 979
80d3b868 980%files pythonprov
d8fcb9b0 981%defattr(644,root,root,755)
d1f5e279 982%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 983
f9d0e5f6
JR
984%if %{with python3}
985%files -n python3-rpm
986%defattr(644,root,root,755)
987%dir %{py3_sitedir}/rpm
988%attr(755,root,root) %{py3_sitedir}/rpm/*.so
989%{py3_sitedir}/rpm/*.py
990%{py3_sitedir}/rpm-%{version}-py*.egg-info
991%{py3_sitedir}/rpm/__pycache__
50dc9ac0 992%endif
5c2ab5c7 993
b0333243
JR
994%if %{with plugins}
995%files plugin-audit
996%defattr(644,root,root,755)
997%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
24b1f498 998%{_mandir}/man8/rpm-plugin-audit.8*
b0333243
JR
999
1000%files plugin-syslog
1001%defattr(644,root,root,755)
1002%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
24b1f498 1003%{_mandir}/man8/rpm-plugin-syslog.8*
b0333243
JR
1004
1005%files plugin-systemd-inhibit
1006%defattr(644,root,root,755)
1007%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1008%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1009
1010%files plugin-ima
1011%defattr(644,root,root,755)
1012%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
24b1f498 1013%{_mandir}/man8/rpm-plugin-ima.8*
b0333243
JR
1014
1015%files plugin-prioreset
1016%defattr(644,root,root,755)
1017%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
24b1f498 1018%{_mandir}/man8/rpm-plugin-prioreset.8*
b0333243
JR
1019
1020%files plugin-selinux
1021%defattr(644,root,root,755)
1022%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
24b1f498 1023%{_mandir}/man8/rpm-plugin-selinux.8*
b0333243
JR
1024%endif
1025
8191f3c5
JR
1026%files sign
1027%defattr(644,root,root,755)
1028%attr(755,root,root) %{_bindir}/rpmsign
1029%{_mandir}/man8/rpmsign.8*
1030
5c2ab5c7
AM
1031%if %{with apidocs}
1032%files apidocs
1033%defattr(644,root,root,755)
d1f5e279
JR
1034%doc doc/librpm/html/*
1035%endif
This page took 0.984284 seconds and 4 git commands to generate.