]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- obsolete since 4.3 snaps... and broken
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
02919de5 3# - fix perl.req and perl.prov to support _noauto macros
87ef0d95 4# - use system libmagic not internal libfmagic
52c10eff 5#
89427592 6# Conditional build:
50dc9ac0
JK
7%bcond_without static # - build shared /bin/rpm (doesn't work at the moment)
8%bcond_without docs # - don't generate documentation with doxygen
9%bcond_without python # - don't build python bindings
89427592
JB
10# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
11# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
12# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
54bfdf99 13
d755a548 14%include /usr/lib/rpm/macros.python
9985b35b 15%define snap 20040107
003a039e 16# versions of required libraries
d6d0bf8f 17%define reqdb_ver 4.2.50-1
87ef0d95 18%define reqpopt_ver 1.9
d865fcbb 19%define beecrypt_ver 3.0.0-0.20030610.1
38585a7e 20%define rpm_macros_rev 1.133
e5f02e49
AM
21Summary: RPM Package Manager
22Summary(de): RPM Packet-Manager
313a4d1a 23Summary(es): Gestor de paquetes RPM
609cc585 24