]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- fix lua BRs, lua51-devel provides lua-devel however it does not have lua.pc expecte...
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
c296fee0 3# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 4#
89427592 5# Conditional build:
0a1ccab0 6%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6 7%bcond_without python3 # don't build python bindings
b0333243 8%bcond_without plugins # build plugins
af0cc499 9%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
85c29998 10%bcond_with imaevm # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
858aa7d0 11
6f068494
JR
12%define db_ver 5.3.28.0
13%define popt_ver 1.15
fb35e2d9 14%define openssl_ver 1.1.1d
24b1f498 15%define sover 9.1.0
fc60c9f3 16
8a4b67ac
JR
17 %if %{_ver_ge '%{_rpmversion}' '4.12'} && %{_ver_lt '%{_rpmversion}' '5.0'}
18 %define with_recommends_tags
19 %endif
20
e5f02e49 21Summary: RPM Package Manager
4ea2ed33
ER
22Summary(de.UTF-8): RPM Packet-Manager
23Summary(es.UTF-8): Gestor de paquetes RPM
24Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
25Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
26Summary(ru.UTF-8): Менеджер пакетов от RPM
27Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 28Name: rpm
24b1f498 29Version: 4.16.0
98d9fc8e 30Release: 0.1
9fe07969 31Epoch: 1
98d9fc8e 32License: GPL v2 / LGPL v2.1
76214164 33Group: Base
24b1f498
JR
34Source0: http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
35# Source0-md5: 434e166a812e35ef181f6dd176326920
faba01eb
JR
36Source1: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
37# Source1-md5: 23914bb49fafe7153cee87126d966461
38Source2: macros.local
39Source3: macros.lang
40Source4: %{name}.sysconfig
41Source5: %{name}.groups
80b8a1f9 42Source6: %{name}-groups-po.awk
faba01eb
JR
43Source7: %{name}-install-tree
44Source8: %{name}-hrmib-cache
45Source9: %{name}-user_group.sh
a4b7ef27 46# http://svn.pld-linux.org/banner.sh/
faba01eb 47Source10: banner.sh
b2d6b731
JR
48Source11: %{name}.noautoprov
49Source12: %{name}.noautoprovfiles
50Source13: %{name}.noautoreq
51Source14: %{name}.noautoreqfiles
52Source15: perl.prov
53Source16: %{name}db_checkversion.c
54Source17: %{name}db_reset.c
55Source18: dbupgrade.sh
af0cc499
JR
56Patch0: %{name}-man_pl.patch
57Patch1: %{name}-popt-aliases.patch
58Patch2: %{name}-perl-macros.patch
59Patch3: %{name}-perl-req-perlfile.patch
60Patch4: %{name}-scripts-closefds.patch
cbab0cbf
JR
61Patch6: %{name}-perl_req-INC_dirs.patch
62Patch7: %{name}-debuginfo.patch
63Patch8: %{name}-libtool-deps.patch
64Patch9: %{name}-builddir-readlink.patch
65Patch10: %{name}-changelog_order_check_nonfatal.patch
66Patch11: %{name}-postun-nofail.patch
67Patch12: %{name}-clean-docdir.patch
68Patch13: %{name}-perl-magic.patch
69Patch14: %{name}-ignore-missing-macro-files.patch
70Patch15: x32.patch
b2d6b731
JR
71Patch16: rpm5-db-compat.patch
72Patch17: python-internal-build.patch
5570f8e6 73Patch18: rpmversion.patch
837ad262 74Patch19: pkgconfig.patch
f16801b5 75Patch20: uname-deps.patch
681ee2f6 76URL: https://rpm.org/
6f068494 77BuildRequires: db-devel >= %{db_ver}
29855fc2 78BuildRequires: autoconf >= 2.63
644d8958 79BuildRequires: automake >= 1.4
33be5db0 80BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 81BuildRequires: elfutils-devel >= 0.108
3e70c06e 82BuildRequires: gettext-tools >= 0.19.2
af0cc499 83BuildRequires: libarchive-devel
241257bf 84BuildRequires: libmagic-devel
d1f5e279 85BuildRequires: openssl-devel >= %{openssl_ver}
b0333243
JR
86%if %{with plugins}
87BuildRequires: audit-libs-devel
88BuildRequires: dbus-devel
85c29998 89%{?with_imaevm:BuildRequires: libimaevm-devel >= 1.0}
6e115b23 90BuildRequires: libselinux-devel >= 2.1.0
6e115b23 91%endif
84cdee7a
JB
92# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
93BuildRequires: libstdc++-devel
b60c74c3 94BuildRequires: libtool >= 1:1.4.2-9
127a0b3c 95BuildRequires: ossp-uuid-devel
7973b351 96BuildRequires: patch >= 2.2
ae228405 97BuildRequires: pkgconfig(lua) >= 5.1
6f068494 98BuildRequires: popt-devel >= %{popt_ver}
85c29998
JR
99BuildRequires: python3-modules
100%if %{with python3}
101BuildRequires: python3-devel
f9d0e5f6
JR
102BuildRequires: rpm-pythonprov
103%endif
85c29998 104BuildRequires: sqlite3-devel >= 3.22.0
e56a10a9 105BuildRequires: tcl
77fcdbf7 106BuildRequires: xz-devel
3acb62f3 107BuildRequires: zlib-devel
34865f27 108BuildRequires: zstd-devel
5c2ab5c7
AM
109%if %{with apidocs}
110BuildRequires: doxygen
111BuildRequires: ghostscript
112BuildRequires: graphviz
113BuildRequires: tetex-pdftex
114%endif
d25ec6ea 115Requires(posttrans): coreutils
9fe07969
JR
116Requires: %{name}-base = %{epoch}:%{version}-%{release}
117Requires: %{name}-lib = %{epoch}:%{version}-%{release}
3de8e4a9 118Requires: rpm-pld-macros >= 1.744
d1f5e279 119Requires: FHS >= 3.0-2
fb35e2d9 120Requires: openssl >= %{openssl_ver}
6f068494 121Requires: popt >= %{popt_ver}
b0333243
JR
122%if %{with recommends_tags}
123Recommends: rpm-plugin-audit
124Recommends: rpm-plugin-prioreset
125Recommends: rpm-plugin-syslog
126Recommends: rpm-plugin-systemd-inhibit
127%endif
d1f5e279 128Obsoletes: rpm-utils-perl
f57f030d 129Obsoletes: rpm-utils-static
874f4c9a 130Conflicts: glibc < 2.2.92
8ee1c72c
AM
131# db4.6 poldek needed
132Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
133# segfaults with lzma 0.42.2
134Conflicts: lzma-libs < 4.999.3
e4084afd 135Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 136BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 137
4adb7d05 138%define _binary_payload w9.gzdio
6d82b332 139
4cd84746 140# don't require very fresh rpm.macros to build
950eead3 141%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 142%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 143%define ppc ppc ppc7400 ppc7450
9f517079 144%define x8664 amd64 ia32e x86_64
4cd84746 145
d755a548
JK
146%define _rpmlibdir /usr/lib/rpm
147
ff7bc1e6 148%description
149RPM is a powerful package manager, which can be used to build,
150install, query, verify, update, and uninstall individual software
cf6faebc 151packages. A package consists of an archive of files, and package
fed73700 152information, including name, version, and description.
153
dd85fadc
JR
154%description -l de.UTF-8
155RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 156Installation, Anfrage, Verifizierung, Aktualisierung und
157Uninstallation individueller Softwarepakete. Ein Paket besteht aus
158einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 159Beschreibung.
160
dd85fadc 161%description -l es.UTF-8
313a4d1a 162RPM es un poderoso administrador de paquetes, que puede ser usado para
163construir, instalar, pesquisar, verificar, actualizar y desinstalar
164paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
165almacenaje de archivos, y información sobre el paquete, incluyendo
166nombre, versión y descripción.
167
168%description -l pl.UTF-8
169RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
170przebudowanie, instalację czy weryfikację dowolnego pakietu.
171Informacje dotyczące każdego pakietu, takie jak jego opis, lista
172plików wchodzących w skład pakietu, zależności od innych pakietów, są
173przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 174odpytywania programu rpm.
175
dd85fadc
JR
176%description -l pt_BR.UTF-8
177RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 178construir, instalar, pesquisar, verificar, atualizar e desinstalar
179pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
180arquivos e informações adicionais, incluindo nome, versão e descrição
181do pacote, permissões dos arquivos, etc.
182
183%description -l ru.UTF-8
184RPM - это мощный менеджер пакетов, который может быть использован для
185создания, инсталляции, запросов (query), проверки, обновления и
186удаления программных пакетов. Пакет состоит из файлового архива и
187служебной информации, включающей название, версию, описание и другие
188данные о пакете.
189
190%description -l uk.UTF-8
191RPM - це потужний менеджер пакетів, що може бути використаний для
192створення, інсталяції, запитів (query), перевірки, поновлення та
193видалення програмних пакетів. Пакет складається з файлового архіву та
194службової інформації, що містить назву, версію, опис та іншу
195інформацію про пакет.
7c6dc55f 196
66edd895
JB
197%package base
198Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 199Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 200Group: Base
1d9ca0c1 201Requires: filesystem
950eead3 202Obsoletes: rpm-scripts
66edd895
JB
203Obsoletes: vserver-rpm
204
205%description base
206The RPM base package contains scripts used by rpm packages themselves.
207These include:
208- scripts for adding/removing groups and users needed for rpm
209 packages,
210- banner.sh to display %%banner messages from rpm scriptlets.
211
dd85fadc
JR
212%description base -l pl.UTF-8
213Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 214Zawiera on:
dd85fadc
JR
215- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
216- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 217
69131f1a
JB
218%package lib
219Summary: RPMs library
4ea2ed33 220Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 221Group: Libraries
6f068494 222Requires: db >= %{db_ver}
241257bf 223Requires: libmagic >= 1.15-2
d1f5e279 224Requires: openssl >= %{openssl_ver}
6f068494 225Requires: popt >= %{popt_ver}
d1795eb0 226Obsoletes: rpm-libs
69131f1a
JB
227# avoid SEGV caused by mixed db versions
228Conflicts: poldek < 0.18.1-16
229
230%description lib
231RPMs library.
232
dd85fadc 233%description lib -l pl.UTF-8
69131f1a
JB
234Biblioteki RPM-a.
235
fed73700 236%package devel
3f2d796a 237Summary: Header files for rpm libraries
4ea2ed33
ER
238Summary(de.UTF-8): Header-Dateien für rpm Libraries
239Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
240Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
241Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
242Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
243Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 244Group: Development/Libraries
9fe07969 245Requires: %{name}-lib = %{epoch}:%{version}-%{release}
fea3cb89 246Requires: bzip2-devel
24b1f498 247Requires: db-devel >= %{db_ver}
5c583f90 248Requires: elfutils-devel
241257bf 249Requires: libmagic-devel
d1f5e279 250Requires: openssl-devel >= %{openssl_ver}
c7b2d5f9
KK
251%if %{with selinux}
252Requires: libselinux-devel
253Requires: libsemanage-devel
254Requires: libsepol-devel
255%endif
6f068494 256Requires: popt-devel >= %{popt_ver}
fea3cb89 257Requires: zlib-devel
cf6faebc 258
259%description devel
3f2d796a
JB
260The RPM packaging system includes C libraries that make it easy to
261manipulate RPM packages and databases. They are intended to ease the
cf6faebc 262creation of graphical package managers and other tools that need
3f2d796a
JB
263intimate knowledge of RPM packages. This package contains header files
264for these libraries.
fed73700 265
dd85fadc
JR
266%description devel -l de.UTF-8
267Der RPM-Packensystem enthält eine C-Library, die macht es einfach
268RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 269Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 270Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
271
dd85fadc 272%description devel -l es.UTF-8
313a4d1a 273El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
274fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
275facilitar la creación de administradores gráficos de paquetes y otras
20f89981 276herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 277
dd85fadc
JR
278%description devel -l pl.UTF-8
279System RPM zawiera biblioteki C, które ułatwiają manipulowanie
280pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
281graficznych programów zarządzających pakietami oraz innych narzędzi,
282które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
283zawiera pliki nagłówkowe wspomnianych bibliotek.
284
285%description devel -l pt_BR.UTF-8
286O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
287a manipulação de pacotes e bases de dados RPM. Seu objetivo é
288facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 289ferramentas que precisem de conhecimento profundo de pacotes RPM.
290
dd85fadc
JR
291%description devel -l ru.UTF-8
292Система управления пакетами RPM содержит библиотеку C, которая
293упрощает манипуляцию пакетами RPM и соответствующими базами данных.
294Эта библиотека предназначена для облегчения создания графических
295пакетных менеджеров и других утилит, которым необходимо работать с
296пакетами RPM.
7c6dc55f 297
dd85fadc
JR
298%description devel -l uk.UTF-8
299Система керування пакетами RPM містить бібліотеку C, котра спрощує
300роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
301призначена для полегшення створення графічних пакетних менеджерів та
302інших утиліт, що працюють з пакетами RPM.
7c6dc55f 303
fed73700 304%package utils
8482995c 305Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
306Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
307Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 308Group: Applications/File
9fe07969 309Requires: %{name} = %{epoch}:%{version}-%{release}
6f068494 310Requires: popt >= %{popt_ver}
af0cc499
JR
311%if %{with recommends_tags}
312Recommends: bzip2
313Recommends: gzip
86b85368 314%endif
695e60ad 315Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 316
317%description utils
8482995c 318Additional utilities for managing RPM packages and database.
fed73700 319
dd85fadc
JR
320%description utils -l de.UTF-8
321Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 322
dd85fadc
JR
323%description utils -l pl.UTF-8
324Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 325
fed73700 326%package build
e191287c 327Summary: Scripts for building binary RPM packages
4ea2ed33
ER
328Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
329Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
330Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
331Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
332Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 333Group: Applications/File
f15ca8ca
ER
334Requires(pretrans): coreutils
335Requires(pretrans): findutils
9fe07969 336Requires: %{name}-utils = %{epoch}:%{version}-%{release}
3de8e4a9 337Requires: rpm-pld-macros-build >= 1.744
e191287c 338Requires: /bin/id
339Requires: awk
cfa7898a 340Requires: bzip2
e950a6d7 341Requires: chrpath >= 0.10-4
b6547e10 342Requires: cpio
e191287c 343Requires: diffutils
195f647c 344Requires: elfutils
583135b4 345Requires: file >= 4.17
e191287c 346Requires: fileutils
347Requires: findutils
950eead3
ER
348%ifarch athlon
349Requires: gcc >= 3.0.3
350%else
351Requires: gcc
352%endif
e191287c 353Requires: glibc-devel
354Requires: grep
355Requires: gzip
356Requires: make
357Requires: patch
adbd4815 358Requires: sed >= 4.0
e191287c 359Requires: sh-utils
adbd4815 360Requires: tar >= 1:1.22
e191287c 361Requires: textutils
3acb62f3 362Requires: which
adbd4815 363Requires: xz
37ea389a 364Provides: rpmbuild(noauto) = 3
02d17bf9 365%ifarch %{x8664}
195f647c
JB
366Conflicts: automake < 1:1.7.9-2
367Conflicts: libtool < 2:1.5-13
368%endif
0096c5cd 369
e2025ad1 370%description build
58399c37 371Scripts for building binary RPM packages.
fed73700 372
dd85fadc
JR
373%description build -l de.UTF-8
374Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 375
dd85fadc
JR
376%description build -l pl.UTF-8
377Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 378
dd85fadc
JR
379%description build -l pt_BR.UTF-8
380Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 381construir pacotes usando o RPM.
e73478cd 382
dd85fadc
JR
383%description build -l ru.UTF-8
384Различные вспомогательные скрипты и исполняемые программы, которые
385используются для сборки RPM'ов.
7c6dc55f 386
dd85fadc
JR
387%description build -l uk.UTF-8
388Різноманітні допоміжні скрипти та утиліти, які використовуються для
389побудови RPM'ів.
7c6dc55f 390
69131f1a 391%package perlprov
8482995c 392Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 393Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 394Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 395Group: Applications/File
9fe07969 396Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 397Requires: perl-Encode
69131f1a
JB
398Requires: perl-devel
399Requires: perl-modules
400
401%description perlprov
8482995c 402Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
403packages.
404
dd85fadc
JR
405%description perlprov -l de.UTF-8
406Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 407
dd85fadc 408%description perlprov -l pl.UTF-8
8482995c
JB
409Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
410pakietach RPM.
69131f1a
JB
411
412%package pythonprov
8482995c
JB
413Summary: Python macros, which simplifies creation of RPM packages with Python software
414Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 415Group: Applications/File
9fe07969 416Requires: %{name} = %{epoch}:%{version}-%{release}
85c29998
JR
417Requires: python3
418Requires: python3-modules
419Requires: python3-setuptools
69131f1a
JB
420
421%description pythonprov
8482995c 422Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
423software.
424
dd85fadc 425%description pythonprov -l pl.UTF-8
8482995c 426Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
427Pythonie.
428
f9d0e5f6
JR
429%package -n python3-rpm
430Summary: Python 3 interface to RPM library
431Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
432Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
433Group: Development/Languages/Python
9fe07969 434Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6 435Requires: python3
85c29998
JR
436Obsoletes: python-rpm < 1:4.16.0
437Obsoletes: rpm-python
f9d0e5f6
JR
438
439%description -n python3-rpm
440The python3-rpm package contains a module which permits applications
441written in the Python 3 programming language to use the interface
442supplied by RPM (RPM Package Manager) libraries.
443
444This package should be installed if you want to develop Python 3
445programs that will manipulate RPM packages and databases.
446
447%description -n python3-rpm -l pl.UTF-8
448Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
24b1f498
JR
449Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
450RPM-a.
f9d0e5f6
JR
451
452Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
453Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
454
455%description -n python3-rpm -l pt_BR.UTF-8
456O pacote python3-rpm contém um módulo que permite que aplicações
457escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
458RPM (RPM Package Manager).
459
460Esse pacote deve ser instalado se você quiser desenvolver programas em
461Python 3 para manipular pacotes e bancos de dados RPM.
462
b0333243
JR
463%package plugin-audit
464Summary: Plugin for logging audit events on package operations
24b1f498 465Group: Base
9fe07969 466Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
467
468%description plugin-audit
469Plugin for libaudit support
470
471%package plugin-syslog
472Summary: Plugin for syslog functionality
24b1f498 473Group: Base
9fe07969 474Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
475
476%description plugin-syslog
477This plugin exports RPM actions to the system log.
478
479%package plugin-systemd-inhibit
480Summary: Plugin for systemd inhibit functionality
24b1f498 481Group: Base
9fe07969 482Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
483
484%description plugin-systemd-inhibit
485This plugin blocks systemd from entering idle, sleep or shutdown while
486an rpm transaction is running using the systemd-inhibit mechanism.
487
488%package plugin-ima
489Summary: Plugin for IMA file signatures
490Group: Base
9fe07969 491Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
492
493%description plugin-ima
494This plugin adds support for enforcing and verifying IMA file
495signatures in an rpm.
496
497%package plugin-prioreset
498Summary: Plugin for resetting scriptlet priorities for SysV init
499Group: Base
9fe07969 500Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
501
502%description plugin-prioreset
503This plugin is useful on legacy SysV init systems if you run rpm
504transactions with nice/ionice priorities. Should not be used on
505systemd systems.
506
507%package plugin-selinux
508Summary: Plugin for SELinux functionality
8191f3c5 509Group: Base
9fe07969 510Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
511Requires: libselinux >= 2.1.0
512
513%description plugin-selinux
514Plugin for SELinux functionality.
515
8191f3c5
JR
516%package sign
517Summary: Package signing support
518Group: Base
9fe07969 519Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
520
521%description sign
522This package contains support for digitally signing RPM packages.
523
5c2ab5c7
AM
524%package apidocs
525Summary: RPM API documentation and guides
526Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
527Group: Documentation
d308de4c 528BuildArch: noarch
5c2ab5c7
AM
529
530%description apidocs
531Documentation for RPM API and guides in HTML format generated from rpm
532sources by doxygen.
533
534%description apidocs -l pl.UTF-8
535Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
536źrodeł RPM-a przez doxygen.
537
e2025ad1 538%prep
c546a4d6 539%setup -q -n %{name}-%{version}%{?subver}
af0cc499 540%patch0 -p1
2f0ee4ec 541%patch1 -p1
4d5b8e4c 542%patch2 -p1
af0cc499 543%patch3 -p1
7a3b1f24 544%patch4 -p1
cbab0cbf
JR
545%patch6 -p0
546%patch7 -p1
af0cc499 547%patch8 -p1
cbab0cbf 548%patch9 -p1
af0cc499
JR
549%patch10 -p1
550%patch11 -p1
551%patch12 -p1
552%patch13 -p1
553%patch14 -p1
7033e976 554%patch15 -p1
af0cc499
JR
555%patch16 -p1
556%patch17 -p1
5570f8e6 557%patch18 -p1
837ad262 558%patch19 -p1
f16801b5 559%patch20 -p1
883e0fac 560
b2d6b731 561install %{SOURCE15} scripts/perl.prov.in
08697680 562
70f8787d 563%{__mv} -f scripts/perl.req{,.in}
633d1e9e 564
cd86db2e 565# generate Group translations to *.po
faba01eb 566awk -f %{SOURCE6} %{SOURCE5}
fefe9d30 567
b2d6b731
JR
568install %{SOURCE16} tools/rpmdb_checkversion.c
569install %{SOURCE17} tools/rpmdb_reset.c
91ee86a9 570
24b1f498 571%{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
40675133 572
87ef0d95 573%build
ea816ea6 574%{__libtoolize}
ceaaacee 575%{__aclocal}
4cd84746 576%{__autoheader}
7a9d72ce 577%{__autoconf}
7a9d72ce 578%{__automake}
7a9d72ce 579
048d06f8
JR
580# rpm checks for CPU type at runtime, but it looks better
581sed -i \
582 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
583 -e 's|@host_cpu@|%{_target_cpu}|' \
584 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 585 macros.in
048d06f8 586
624f96ff 587%configure \
01d7a578 588 WITH_PERL_VERSION=no \
bba1059c 589 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 590 __GPG=%{_bindir}/gpg \
85c29998
JR
591%if %{with python3}
592 PYTHON=python3 \
593 --enable-python \
594%endif
3a3e476f 595 --disable-silent-rules \
cd86db2e 596 --enable-shared \
34865f27 597 --enable-bdb \
85c29998
JR
598 --enable-ndb \
599 --enable-sqlite \
af0cc499 600 --enable-zstd \
fb35e2d9 601 --with-crypto=openssl \
c38bf1df 602 --with-lua \
85c29998 603 %{?with_imaevm:--with-imaevm} \
34865f27
JR
604 --with-cap \
605 --with-acl \
606 --with-audit \
af0cc499 607 --with-archive \
b0333243
JR
608 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
609 %{!?with_plugins:--disable-plugins} \
34865f27
JR
610 --with-vendor=pld
611
5c767dc1 612%{__make}
5c2ab5c7 613
6f068494
JR
614%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
615%{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
fb95de52
JR
616
617if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
618 echo "Error linking rpmdb tools!"
619 exit 1
620fi
8e8746c0
JR
621if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
622 echo "Error linking rpmdb tools!"
623 exit 1
624fi
91ee86a9 625
f9d0e5f6
JR
626%if %{with python3}
627cd python
628%py3_build
629%endif
630
b064b8e6 631%install
ff7bc1e6 632rm -rf $RPM_BUILD_ROOT
d1f5e279 633install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
7d12560f 634 $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
54eb1770 635
faba01eb 636cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 637
d1f5e279 638%{__make} install \
241257bf
AM
639 pkgconfigdir=%{_pkgconfigdir} \
640 DESTDIR=$RPM_BUILD_ROOT
718426e1 641
c546a4d6 642# cleanup
c2683840 643%ifnarch %{ix86} %{x8664} x32
2f409bb7 644rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 645rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
646rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
647rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
648rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
649rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
650rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
651rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
652%endif
653
c2683840 654%ifnarch %{x8664} x32
2f409bb7
JR
655rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
656rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
657rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
658rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
659%endif
660
c546a4d6 661%ifnarch %{ppc}
34865f27
JR
662rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
663rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
664rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
665rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
666rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 667rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 668rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
669%endif
670
34865f27 671rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
2f409bb7
JR
672rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
673rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
674rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
675rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 676rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 677rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 678rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 679rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 680
3a3e476f 681%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 682
396a7387 683install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
396a7387 684
faba01eb
JR
685cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
686cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
687cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
688cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 689
faba01eb 690cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 691
faba01eb
JR
692cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
693cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
b2d6b731
JR
694cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
695cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
696cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
697cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 698
f9d0e5f6
JR
699cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
700cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
b2d6b731 701cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 702
950eead3 703# move rpm to /bin
8191f3c5
JR
704%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
705ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
706ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
707
950eead3 708# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
709for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
710 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
711 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
712done
713
7d12560f
JR
714#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
715
85c29998
JR
716# Make sure we have bdb set a default backend
717grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
6f18cdb7 718
f9d0e5f6
JR
719%if %{with python3}
720# Remove anything that rpm make install might put there
721%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
722cd python
723%py3_install
724cd ..
dae5e1a8 725%endif
01d7a578 726
d1f5e279
JR
727%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
728
01d7a578 729# wrong location, not used anyway
2f409bb7 730%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 731
90b03dd6 732%find_lang %{name}
cf6faebc 733
13eb5ebf 734%clean
d7df46b8 735rm -rf $RPM_BUILD_ROOT
76214164 736
be4d3036 737%posttrans
d25ec6ea 738if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 739 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 740 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 741 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 742 echo
e4dd6a34 743 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
744 echo
745 fi
3ca91ccd
JR
746 echo
747 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
748 echo 'you should ignore it and restart poldek'
749 echo
f9d0e5f6 750 %{_rpmlibdir}/dbupgrade.sh
be4d3036 751fi
f7779567 752
b7ee97ef
JR
753%triggerpostun -- %{name} < 4.4.9-44
754%{_rpmlibdir}/hrmib-cache
755
ceaaacee
JB
756%post lib -p /sbin/ldconfig
757%postun lib -p /sbin/ldconfig
76214164 758
37a5a2fc 759%pretrans build
d755a548 760find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 761
3684d90f
JB
762%files -f %{name}.lang
763%defattr(644,root,root,755)
d1f5e279 764%doc ChangeLog CREDITS README
3684d90f 765
3acb62f3
ER
766%dir /etc/pki/rpm-gpg
767/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 768
7a9d72ce 769%attr(755,root,root) /bin/rpm
8191f3c5
JR
770%attr(755,root,root) %{_bindir}/rpmdb
771%attr(755,root,root) %{_bindir}/rpmkeys
772%attr(755,root,root) %{_bindir}/rpmquery
773%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 774
66edd895 775%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 776%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
caf453d4 777
09bb810c 778%{_mandir}/man8/rpm.8*
8191f3c5
JR
779%{_mandir}/man8/rpmdb.8*
780%{_mandir}/man8/rpmkeys.8*
781%{_mandir}/man8/rpm-misc.8*
24b1f498 782%{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
feb1f12e 783%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 784%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 785%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 786%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 787%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 788%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 789
7d12560f 790%dir /var/lib/rpm
4acac5de 791
cf709a39
ER
792# exported package NVRA (stamped with install tid)
793# net-snmp hrSWInstalledName queries, bash-completions
794%dir /var/cache/hrmib
795
d755a548 796%{_rpmlibdir}/rpmpopt*
8191f3c5 797%{_rpmlibdir}/rpmrc
d755a548 798%{_rpmlibdir}/macros
08697680 799%dir %{_rpmlibdir}/macros.d
e8836e1f 800%dir %{_rpmlibdir}/platform
40675133 801%{_rpmlibdir}/platform/noarch-*
c2683840 802%ifarch %{ix86} %{x8664} x32
34865f27
JR
803%{_rpmlibdir}/platform/athlon*
804%{_rpmlibdir}/platform/geode*
40675133
JR
805%{_rpmlibdir}/platform/i?86*
806%{_rpmlibdir}/platform/pentium*
34865f27
JR
807%endif
808%ifarch %{x8664} x32
809%{_rpmlibdir}/platform/amd64*
810%{_rpmlibdir}/platform/ia32e*
811%{_rpmlibdir}/platform/x86_64*
83a0601a 812%{_rpmlibdir}/platform/x32*
e23edf35
JR
813%endif
814%ifarch alpha
40675133 815%{_rpmlibdir}/platform/alpha*
e23edf35
JR
816%endif
817%ifarch ia64
40675133 818%{_rpmlibdir}/platform/ia64*
e23edf35
JR
819%endif
820%ifarch mips mipsel mips64 mips64el
40675133 821%{_rpmlibdir}/platform/mips*
e23edf35
JR
822%endif
823%ifarch %{ppc}
40675133 824%{_rpmlibdir}/platform/ppc*
e23edf35
JR
825%endif
826%ifarch sparc sparc64
40675133 827%{_rpmlibdir}/platform/sparc*
e23edf35 828%endif
3684d90f 829
3de8e4a9 830%dir %{_rpmlibdir}/pld
396a7387 831
cf709a39
ER
832%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
833
f9d0e5f6
JR
834%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
835%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
836%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
24b1f498
JR
837%attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
838%attr(755,root,root) %{_rpmlibdir}/rpmdb_load
df50421f 839
7d12560f
JR
840# valgrind suppression file for rpm
841%{_rpmlibdir}/rpm.supp
842
66edd895
JB
843%files base
844%defattr(644,root,root,755)
492a2bd4 845%dir %{_sysconfdir}/rpm
66edd895
JB
846%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
847%dir %{_rpmlibdir}
848%attr(755,root,root) %{_bindir}/banner.sh
849%attr(755,root,root) %{_rpmlibdir}/user_group.sh
850%dir /var/lib/banner
851
874f4c9a
MM
852%files lib
853%defattr(644,root,root,755)
40675133
JR
854%attr(755,root,root) /%{_lib}/librpm.so.9
855%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
856%attr(755,root,root) /%{_lib}/librpmbuild.so.9
857%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
858%attr(755,root,root) /%{_lib}/librpmio.so.9
859%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
860%attr(755,root,root) /%{_lib}/librpmsign.so.9
861%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 862%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 863
69131f1a
JB
864%files devel
865%defattr(644,root,root,755)
69131f1a 866%attr(755,root,root) %{_libdir}/librpm.so
950eead3 867%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 868%attr(755,root,root) %{_libdir}/librpmio.so
40675133 869%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
870%{_libdir}/librpm*.la
871%{_includedir}/rpm
872%{_pkgconfigdir}/*.pc
69131f1a 873
69131f1a
JB
874%files utils
875%defattr(644,root,root,755)
d1f5e279 876%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 877%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 878%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 879%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 880%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
25e974c7 881%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
882%attr(755,root,root) %{_rpmlibdir}/debugedit
883%attr(755,root,root) %{_rpmlibdir}/rpmdeps
24b1f498 884%{_mandir}/man8/rpm2archive.8*
69131f1a
JB
885%{_mandir}/man8/rpm2cpio.8*
886%{_mandir}/man8/rpmdeps.8*
fc36dfd5 887%{_mandir}/man8/rpmgraph.8*
69131f1a 888%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 889%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 890%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 891%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 892%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
893%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
894%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 895
3684d90f 896%files build
a45ae6d8 897%defattr(644,root,root,755)
66edd895 898%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
899%attr(755,root,root) %{_rpmlibdir}/brp-*
900%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 901%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 902%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578
JB
903%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
904# needs hacked pkg-config to return anything
905%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 906%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
37e965e8 907
70f8787d 908%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 909# must be here for "Requires: rpm-*prov" to work
40675133
JR
910#%{_rpmlibdir}/macros.d/cmake
911#%{_rpmlibdir}/macros.d/gstreamer
40675133 912#%{_rpmlibdir}/macros.d/libtool
40675133 913#%{_rpmlibdir}/macros.d/perl
40675133
JR
914#%{_rpmlibdir}/macros.d/pkgconfig
915#%{_rpmlibdir}/macros.d/python
40675133
JR
916#%{_rpmlibdir}/macros.d/selinux
917#%{_rpmlibdir}/macros.d/tcl
918#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 919
7d12560f
JR
920%attr(755,root,root) %{_rpmlibdir}/check-buildroot
921%attr(755,root,root) %{_rpmlibdir}/check-prereqs
922%attr(755,root,root) %{_rpmlibdir}/check-rpaths
923%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
7d12560f
JR
924%attr(755,root,root) %{_rpmlibdir}/find-provides
925%attr(755,root,root) %{_rpmlibdir}/find-requires
24b1f498 926%attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
7d12560f
JR
927%attr(755,root,root) %{_rpmlibdir}/script.req
928%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
7d12560f 929
f9d0e5f6
JR
930%dir %{_rpmlibdir}/fileattrs
931%{_rpmlibdir}/fileattrs/debuginfo.attr
932%{_rpmlibdir}/fileattrs/desktop.attr
933%{_rpmlibdir}/fileattrs/elf.attr
934%{_rpmlibdir}/fileattrs/font.attr
935%{_rpmlibdir}/fileattrs/libtool.attr
936%{_rpmlibdir}/fileattrs/metainfo.attr
937%{_rpmlibdir}/fileattrs/ocaml.attr
938%{_rpmlibdir}/fileattrs/perl.attr
939%{_rpmlibdir}/fileattrs/perllib.attr
f9d0e5f6
JR
940%{_rpmlibdir}/fileattrs/pkgconfig.attr
941%{_rpmlibdir}/fileattrs/python.attr
942%{_rpmlibdir}/fileattrs/pythondist.attr
943%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 944
874f4c9a
MM
945%attr(755,root,root) %{_bindir}/gendiff
946%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 947%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 948
a00926bc 949%{_mandir}/man1/gendiff.1*
d1f5e279 950%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 951%{_mandir}/man8/rpmbuild.8*
fefe9d30 952%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 953%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 954%{_mandir}/man8/rpmspec.8*
f3fe287f 955
89334051
AF
956%files perlprov
957%defattr(644,root,root,755)
d755a548 958%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 959
80d3b868 960%files pythonprov
d8fcb9b0 961%defattr(644,root,root,755)
d1f5e279 962%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 963
f9d0e5f6
JR
964%if %{with python3}
965%files -n python3-rpm
966%defattr(644,root,root,755)
967%dir %{py3_sitedir}/rpm
968%attr(755,root,root) %{py3_sitedir}/rpm/*.so
969%{py3_sitedir}/rpm/*.py
970%{py3_sitedir}/rpm-%{version}-py*.egg-info
971%{py3_sitedir}/rpm/__pycache__
50dc9ac0 972%endif
5c2ab5c7 973
b0333243
JR
974%if %{with plugins}
975%files plugin-audit
976%defattr(644,root,root,755)
977%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
24b1f498 978%{_mandir}/man8/rpm-plugin-audit.8*
b0333243
JR
979
980%files plugin-syslog
981%defattr(644,root,root,755)
982%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
24b1f498 983%{_mandir}/man8/rpm-plugin-syslog.8*
b0333243
JR
984
985%files plugin-systemd-inhibit
986%defattr(644,root,root,755)
987%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
988%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
989
990%files plugin-ima
991%defattr(644,root,root,755)
992%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
24b1f498 993%{_mandir}/man8/rpm-plugin-ima.8*
b0333243
JR
994
995%files plugin-prioreset
996%defattr(644,root,root,755)
997%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
24b1f498 998%{_mandir}/man8/rpm-plugin-prioreset.8*
b0333243
JR
999
1000%files plugin-selinux
1001%defattr(644,root,root,755)
1002%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
24b1f498 1003%{_mandir}/man8/rpm-plugin-selinux.8*
b0333243
JR
1004%endif
1005
8191f3c5
JR
1006%files sign
1007%defattr(644,root,root,755)
1008%attr(755,root,root) %{_bindir}/rpmsign
1009%{_mandir}/man8/rpmsign.8*
1010
5c2ab5c7
AM
1011%if %{with apidocs}
1012%files apidocs
1013%defattr(644,root,root,755)
d1f5e279
JR
1014%doc doc/librpm/html/*
1015%endif
This page took 1.03821 seconds and 4 git commands to generate.