- drop static packages
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
c296fee0 3# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 4#
89427592 5# Conditional build:
0a1ccab0 6%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6
JR
7%bcond_without python2 # don't build python bindings
8%bcond_without python3 # don't build python bindings
4af66a2c 9%bcond_without selinux # build without selinux support
af0cc499 10%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
fb35e2d9 11%bcond_with db61 # use DB 6.1 instead of 5.3
858aa7d0 12
003a039e 13# versions of required libraries
7f47af9c
JB
14%if %{with db61}
15%define reqdb_pkg db6.1
16%define reqdb_ver 6.1
17%define reqdb_pkgver 6.1.19
5f3f5bd6 18%else
fb35e2d9
JR
19%define reqdb_pkg db5.3
20%define reqdb_ver 5.3
21%define reqdb_pkgver 5.3.28.0
5f3f5bd6 22%endif
ec44785a 23%define reqpopt_ver 1.15
fb35e2d9 24%define openssl_ver 1.1.1d
2f409bb7 25%define sover 9.0.1
fc60c9f3 26
e5f02e49 27Summary: RPM Package Manager
4ea2ed33
ER
28Summary(de.UTF-8): RPM Packet-Manager
29Summary(es.UTF-8): Gestor de paquetes RPM
30Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
31Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
32Summary(ru.UTF-8): Менеджер пакетов от RPM
33Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 34Name: rpm
6ecfe7c2 35Version: 4.15.1
98d9fc8e
JR
36Release: 0.1
37License: GPL v2 / LGPL v2.1
76214164 38Group: Base
6ecfe7c2
JR
39Source0: http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
40# Source0-md5: ed72147451a5ed93b2a48e2f8f5413c3
ff7bc1e6 41Source1: %{name}.groups
08697680 42Source2: macros.pld.in
ff7bc1e6 43Source3: %{name}-install-tree
80b8a1f9 44Source4: %{name}-find-spec-bcond
cf709a39 45Source5: %{name}-hrmib-cache
80b8a1f9
JB
46Source6: %{name}-groups-po.awk
47Source7: %{name}-compress-doc
0bf34f68
JR
48Source8: %{name}-php-provides
49Source9: %{name}-php-requires
50Source10: %{name}.sysinfo
51Source11: perl.prov
52Source12: %{name}-user_group.sh
53Source13: %{name}.sysconfig
54Source14: %{name}-java-requires
a4b7ef27 55# http://svn.pld-linux.org/banner.sh/
0bf34f68 56Source15: banner.sh
34f36471 57Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
e1b97821 58# Source16-md5: 23914bb49fafe7153cee87126d966461
0bf34f68
JR
59Source17: %{name}-mimetypedeps
60Source18: macros.local
f09b01ac
ER
61Source19: %{name}.noautocompressdoc
62Source20: %{name}.noautoprov
63Source21: %{name}.noautoprovfiles
64Source22: %{name}.noautoreq
f09b01ac 65Source24: %{name}.noautoreqfiles
0bf34f68 66Source25: %{name}-php-requires.php
f09b01ac 67Source26: %{name}db_checkversion.c
b1541d4c 68Source27: macros.lang
f09b01ac 69Source28: %{name}db_reset.c
14138aba 70Source29: dbupgrade.sh
e2489d8e 71Source30: rubygems.rb
63194730 72Source31: gem_helper.rb
af0cc499
JR
73Patch0: %{name}-man_pl.patch
74Patch1: %{name}-popt-aliases.patch
75Patch2: %{name}-perl-macros.patch
76Patch3: %{name}-perl-req-perlfile.patch
77Patch4: %{name}-scripts-closefds.patch
78Patch5: %{name}-php-macros.patch
79Patch6: %{name}-lua.patch
80Patch7: %{name}-perl_req-INC_dirs.patch
81Patch8: %{name}-debuginfo.patch
82Patch9: %{name}-javadeps.patch
83Patch10: %{name}-libtool-deps.patch
84Patch11: %{name}-builddir-readlink.patch
85Patch12: %{name}-changelog_order_check_nonfatal.patch
86Patch13: %{name}-postun-nofail.patch
87Patch14: %{name}-clean-docdir.patch
88Patch15: %{name}-perl-magic.patch
89Patch16: %{name}-ignore-missing-macro-files.patch
90Patch17: x32.patch
91Patch18: %{name}-fix-compress-doc.patch
92Patch19: vendor-pld.patch
681ee2f6 93URL: https://rpm.org/
cf169f7c 94BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
cf169f7c 95BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
29855fc2 96BuildRequires: autoconf >= 2.63
644d8958 97BuildRequires: automake >= 1.4
33be5db0 98BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 99BuildRequires: elfutils-devel >= 0.108
3e70c06e 100BuildRequires: gettext-tools >= 0.19.2
af0cc499 101BuildRequires: libarchive-devel
241257bf 102BuildRequires: libmagic-devel
d1f5e279 103BuildRequires: openssl-devel >= %{openssl_ver}
6e115b23
JR
104%if %{with selinux}
105BuildRequires: libselinux-devel >= 2.1.0
6e115b23 106BuildRequires: libsemanage-devel >= 2.1.0
3acb62f3 107BuildRequires: libsepol-devel >= 2.1.0
6e115b23 108%endif
84cdee7a
JB
109# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
110BuildRequires: libstdc++-devel
b60c74c3 111BuildRequires: libtool >= 1:1.4.2-9
5c767dc1 112BuildRequires: lua53-devel >= 5.3.5
127a0b3c 113BuildRequires: ossp-uuid-devel
7973b351 114BuildRequires: patch >= 2.2
1d49ffbc 115BuildRequires: popt-devel >= %{reqpopt_ver}
f9d0e5f6
JR
116%{?with_python2:BuildRequires: python-devel >= 1:2.3}
117%{?with_python3:BuildRequires: python3-devel}
950eead3 118BuildRequires: python-modules >= 1:2.3
f9d0e5f6
JR
119%if %{with python2} || %{with python3}
120BuildRequires: rpm-pythonprov
121%endif
e56a10a9 122BuildRequires: tcl
77fcdbf7 123BuildRequires: xz-devel
3acb62f3 124BuildRequires: zlib-devel
34865f27 125BuildRequires: zstd-devel
5c2ab5c7
AM
126%if %{with apidocs}
127BuildRequires: doxygen
128BuildRequires: ghostscript
129BuildRequires: graphviz
130BuildRequires: tetex-pdftex
131%endif
d25ec6ea 132Requires(posttrans): coreutils
66edd895 133Requires: %{name}-base = %{version}-%{release}
b26a9709 134Requires: %{name}-lib = %{version}-%{release}
d1f5e279 135Requires: FHS >= 3.0-2
fb35e2d9 136Requires: openssl >= %{openssl_ver}
10abbd40 137Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
138Provides: rpm-db-ver = %{reqdb_ver}
139Obsoletes: rpm-getdeps
d1f5e279 140Obsoletes: rpm-utils-perl
f57f030d 141Obsoletes: rpm-utils-static
874f4c9a 142Conflicts: glibc < 2.2.92
8ee1c72c
AM
143# db4.6 poldek needed
144Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
145# segfaults with lzma 0.42.2
146Conflicts: lzma-libs < 4.999.3
e4084afd 147Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 148BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 149
4adb7d05 150%define _binary_payload w9.gzdio
6d82b332 151
4cd84746 152# don't require very fresh rpm.macros to build
950eead3 153%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 154%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 155%define ppc ppc ppc7400 ppc7450
9f517079 156%define x8664 amd64 ia32e x86_64
4cd84746 157
d755a548 158%define _rpmlibdir /usr/lib/rpm
950eead3 159%define _noautocompressdoc RPM-GPG-KEY
d755a548 160
ff7bc1e6 161%description
162RPM is a powerful package manager, which can be used to build,
163install, query, verify, update, and uninstall individual software
cf6faebc 164packages. A package consists of an archive of files, and package
fed73700 165information, including name, version, and description.
166
dd85fadc
JR
167%description -l de.UTF-8
168RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 169Installation, Anfrage, Verifizierung, Aktualisierung und
170Uninstallation individueller Softwarepakete. Ein Paket besteht aus
171einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 172Beschreibung.
173
dd85fadc 174%description -l es.UTF-8
313a4d1a 175RPM es un poderoso administrador de paquetes, que puede ser usado para
176construir, instalar, pesquisar, verificar, actualizar y desinstalar
177paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
178almacenaje de archivos, y información sobre el paquete, incluyendo
179nombre, versión y descripción.
180
181%description -l pl.UTF-8
182RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
183przebudowanie, instalację czy weryfikację dowolnego pakietu.
184Informacje dotyczące każdego pakietu, takie jak jego opis, lista
185plików wchodzących w skład pakietu, zależności od innych pakietów, są
186przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 187odpytywania programu rpm.
188
dd85fadc
JR
189%description -l pt_BR.UTF-8
190RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 191construir, instalar, pesquisar, verificar, atualizar e desinstalar
192pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
193arquivos e informações adicionais, incluindo nome, versão e descrição
194do pacote, permissões dos arquivos, etc.
195
196%description -l ru.UTF-8
197RPM - это мощный менеджер пакетов, который может быть использован для
198создания, инсталляции, запросов (query), проверки, обновления и
199удаления программных пакетов. Пакет состоит из файлового архива и
200служебной информации, включающей название, версию, описание и другие
201данные о пакете.
202
203%description -l uk.UTF-8
204RPM - це потужний менеджер пакетів, що може бути використаний для
205створення, інсталяції, запитів (query), перевірки, поновлення та
206видалення програмних пакетів. Пакет складається з файлового архіву та
207службової інформації, що містить назву, версію, опис та іншу
208інформацію про пакет.
7c6dc55f 209
66edd895
JB
210%package base
211Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 212Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 213Group: Base
1d9ca0c1 214Requires: filesystem
950eead3 215Obsoletes: rpm-scripts
66edd895
JB
216Obsoletes: vserver-rpm
217
218%description base
219The RPM base package contains scripts used by rpm packages themselves.
220These include:
221- scripts for adding/removing groups and users needed for rpm
222 packages,
223- banner.sh to display %%banner messages from rpm scriptlets.
224
dd85fadc
JR
225%description base -l pl.UTF-8
226Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 227Zawiera on:
dd85fadc
JR
228- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
229- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 230
69131f1a
JB
231%package lib
232Summary: RPMs library
4ea2ed33 233Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 234Group: Libraries
cf169f7c 235Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
cf169f7c 236Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
241257bf 237Requires: libmagic >= 1.15-2
6e115b23 238%{?with_selinux:Requires: libselinux >= 2.1.0}
d1f5e279 239Requires: openssl >= %{openssl_ver}
69131f1a 240Requires: popt >= %{reqpopt_ver}
d1795eb0 241Obsoletes: rpm-libs
69131f1a
JB
242# avoid SEGV caused by mixed db versions
243Conflicts: poldek < 0.18.1-16
244
245%description lib
246RPMs library.
247
dd85fadc 248%description lib -l pl.UTF-8
69131f1a
JB
249Biblioteki RPM-a.
250
fed73700 251%package devel
3f2d796a 252Summary: Header files for rpm libraries
4ea2ed33
ER
253Summary(de.UTF-8): Header-Dateien für rpm Libraries
254Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
255Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
256Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
257Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
258Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 259Group: Development/Libraries
153e5706 260Requires: %{name}-lib = %{version}-%{release}
cf169f7c 261Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
fea3cb89 262Requires: bzip2-devel
5c583f90 263Requires: elfutils-devel
241257bf 264Requires: libmagic-devel
d1f5e279 265Requires: openssl-devel >= %{openssl_ver}
c7b2d5f9
KK
266%if %{with selinux}
267Requires: libselinux-devel
268Requires: libsemanage-devel
269Requires: libsepol-devel
270%endif
a998ac11 271Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 272Requires: zlib-devel
cf6faebc 273
274%description devel
3f2d796a
JB
275The RPM packaging system includes C libraries that make it easy to
276manipulate RPM packages and databases. They are intended to ease the
cf6faebc 277creation of graphical package managers and other tools that need
3f2d796a
JB
278intimate knowledge of RPM packages. This package contains header files
279for these libraries.
fed73700 280
dd85fadc
JR
281%description devel -l de.UTF-8
282Der RPM-Packensystem enthält eine C-Library, die macht es einfach
283RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 284Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 285Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
286
dd85fadc 287%description devel -l es.UTF-8
313a4d1a 288El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
289fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
290facilitar la creación de administradores gráficos de paquetes y otras
20f89981 291herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 292
dd85fadc
JR
293%description devel -l pl.UTF-8
294System RPM zawiera biblioteki C, które ułatwiają manipulowanie
295pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
296graficznych programów zarządzających pakietami oraz innych narzędzi,
297które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
298zawiera pliki nagłówkowe wspomnianych bibliotek.
299
300%description devel -l pt_BR.UTF-8
301O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
302a manipulação de pacotes e bases de dados RPM. Seu objetivo é
303facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 304ferramentas que precisem de conhecimento profundo de pacotes RPM.
305
dd85fadc
JR
306%description devel -l ru.UTF-8
307Система управления пакетами RPM содержит библиотеку C, которая
308упрощает манипуляцию пакетами RPM и соответствующими базами данных.
309Эта библиотека предназначена для облегчения создания графических
310пакетных менеджеров и других утилит, которым необходимо работать с
311пакетами RPM.
7c6dc55f 312
dd85fadc
JR
313%description devel -l uk.UTF-8
314Система керування пакетами RPM містить бібліотеку C, котра спрощує
315роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
316призначена для полегшення створення графічних пакетних менеджерів та
317інших утиліт, що працюють з пакетами RPM.
7c6dc55f 318
fed73700 319%package utils
8482995c 320Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
321Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
322Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 323Group: Applications/File
153e5706 324Requires: %{name} = %{version}-%{release}
a998ac11 325Requires: popt >= %{reqpopt_ver}
af0cc499
JR
326%if %{with recommends_tags}
327Recommends: bzip2
328Recommends: gzip
86b85368 329%endif
695e60ad 330Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 331
332%description utils
8482995c 333Additional utilities for managing RPM packages and database.
fed73700 334
dd85fadc
JR
335%description utils -l de.UTF-8
336Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 337
dd85fadc
JR
338%description utils -l pl.UTF-8
339Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 340
92b3f576 341%package utils-perl
8482995c 342Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
343Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
344Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 345Group: Applications/File
153e5706 346Requires: %{name}-utils = %{version}-%{release}
92b3f576 347Requires: popt >= %{reqpopt_ver}
348
349%description utils-perl
8482995c 350Additional utilities for managing RPM packages and database.
92b3f576 351
dd85fadc
JR
352%description utils-perl -l de.UTF-8
353Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 354
dd85fadc
JR
355%description utils-perl -l pl.UTF-8
356Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 357
fed73700 358%package build
e191287c 359Summary: Scripts for building binary RPM packages
4ea2ed33
ER
360Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
361Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
362Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
363Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
364Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 365Group: Applications/File
f15ca8ca
ER
366Requires(pretrans): coreutils
367Requires(pretrans): findutils
716fe3ca 368Requires: %{name}-build-macros >= 1.712
153e5706 369Requires: %{name}-utils = %{version}-%{release}
e191287c 370Requires: /bin/id
371Requires: awk
cfa7898a 372Requires: bzip2
e950a6d7 373Requires: chrpath >= 0.10-4
b6547e10 374Requires: cpio
e191287c 375Requires: diffutils
195f647c 376Requires: elfutils
583135b4 377Requires: file >= 4.17
e191287c 378Requires: fileutils
379Requires: findutils
950eead3
ER
380%ifarch athlon
381Requires: gcc >= 3.0.3
382%else
383Requires: gcc
384%endif
e191287c 385Requires: glibc-devel
386Requires: grep
387Requires: gzip
388Requires: make
389Requires: patch
adbd4815 390Requires: sed >= 4.0
e191287c 391Requires: sh-utils
adbd4815 392Requires: tar >= 1:1.22
e191287c 393Requires: textutils
3acb62f3 394Requires: which
adbd4815 395Requires: xz
ca3648b1 396Provides: rpmbuild(monoautodeps)
37ea389a 397Provides: rpmbuild(noauto) = 3
02d17bf9 398%ifarch %{x8664}
195f647c
JB
399Conflicts: automake < 1:1.7.9-2
400Conflicts: libtool < 2:1.5-13
401%endif
0096c5cd 402
e2025ad1 403%description build
58399c37 404Scripts for building binary RPM packages.
fed73700 405
dd85fadc
JR
406%description build -l de.UTF-8
407Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 408
dd85fadc
JR
409%description build -l pl.UTF-8
410Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 411
dd85fadc
JR
412%description build -l pt_BR.UTF-8
413Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 414construir pacotes usando o RPM.
e73478cd 415
dd85fadc
JR
416%description build -l ru.UTF-8
417Различные вспомогательные скрипты и исполняемые программы, которые
418используются для сборки RPM'ов.
7c6dc55f 419
dd85fadc
JR
420%description build -l uk.UTF-8
421Різноманітні допоміжні скрипти та утиліти, які використовуються для
422побудови RPM'ів.
7c6dc55f 423
8482995c
JB
424%package javaprov
425Summary: Additional utilities for checking Java provides/requires in RPM packages
426Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
427Group: Applications/File
428Requires: %{name} = %{version}-%{release}
429Requires: file
430Requires: findutils >= 1:4.2.26
431Requires: mktemp
432Requires: unzip
433
434%description javaprov
435Additional utilities for checking Java provides/requires in RPM
436packages.
437
438%description javaprov -l pl.UTF-8
439Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
440RPM.
441
69131f1a 442%package perlprov
8482995c 443Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 444Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 445Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
446Group: Applications/File
447Requires: %{name} = %{version}-%{release}
b82853ee 448Requires: perl-Encode
69131f1a
JB
449Requires: perl-devel
450Requires: perl-modules
451
452%description perlprov
8482995c 453Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
454packages.
455
dd85fadc
JR
456%description perlprov -l de.UTF-8
457Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 458
dd85fadc 459%description perlprov -l pl.UTF-8
8482995c
JB
460Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
461pakietach RPM.
69131f1a
JB
462
463%package pythonprov
8482995c
JB
464Summary: Python macros, which simplifies creation of RPM packages with Python software
465Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
466Group: Applications/File
467Requires: %{name} = %{version}-%{release}
cd800b3c 468Requires: python
3acb62f3 469Requires: python-modules
d1f5e279 470Requires: python-setuptools
69131f1a
JB
471
472%description pythonprov
8482995c 473Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
474software.
475
dd85fadc 476%description pythonprov -l pl.UTF-8
8482995c 477Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
478Pythonie.
479
480%package php-pearprov
8482995c
JB
481Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
482Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
483Group: Applications/File
484Requires: %{name} = %{version}-%{release}
632f1b5c 485Requires: sed >= 4.0
1b39d378 486Suggests: php-pear-PHP_CompatInfo
69131f1a
JB
487
488%description php-pearprov
8482995c 489Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
490packages.
491
dd85fadc 492%description php-pearprov -l pl.UTF-8
8482995c
JB
493Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
494pakietach RPM.
69131f1a 495
ec49e9fb
ER
496%package rubyprov
497Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
498Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
499Group: Applications/File
500Requires: %{name} = %{version}-%{release}
501Requires: ruby
502Requires: ruby-modules
b53b1f84 503Requires: ruby-rubygems
ec49e9fb
ER
504
505%description rubyprov
506Ruby tools, which simplifies creation of RPM packages with Ruby
507software.
508
509%description rubyprov -l pl.UTF-8
510Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
511Ruby.
512
69131f1a
JB
513%package -n python-rpm
514Summary: Python interface to RPM library
4ea2ed33
ER
515Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
516Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
517Group: Development/Languages/Python
518Requires: %{name} = %{version}-%{release}
3acb62f3 519Requires: python
69131f1a
JB
520Obsoletes: rpm-python
521
522%description -n python-rpm
f9d0e5f6 523The python-rpm package contains a module which permits applications
69131f1a
JB
524written in the Python programming language to use the interface
525supplied by RPM (RPM Package Manager) libraries.
526
527This package should be installed if you want to develop Python
528programs that will manipulate RPM packages and databases.
529
dd85fadc 530%description -n python-rpm -l pl.UTF-8
f9d0e5f6 531Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
dd85fadc 532Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 533
dd85fadc
JR
534Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
535Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 536
dd85fadc 537%description -n python-rpm -l pt_BR.UTF-8
f9d0e5f6 538O pacote python-rpm contém um módulo que permite que aplicações
69131f1a
JB
539escritas em Python utilizem a interface fornecida pelas bibliotecas
540RPM (RPM Package Manager).
541
dd85fadc 542Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
543Python para manipular pacotes e bancos de dados RPM.
544
f9d0e5f6
JR
545%package -n python3-rpm
546Summary: Python 3 interface to RPM library
547Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
548Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
549Group: Development/Languages/Python
550Requires: %{name} = %{version}-%{release}
551Requires: python3
552
553%description -n python3-rpm
554The python3-rpm package contains a module which permits applications
555written in the Python 3 programming language to use the interface
556supplied by RPM (RPM Package Manager) libraries.
557
558This package should be installed if you want to develop Python 3
559programs that will manipulate RPM packages and databases.
560
561%description -n python3-rpm -l pl.UTF-8
562Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
563Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
564
565Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
566Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
567
568%description -n python3-rpm -l pt_BR.UTF-8
569O pacote python3-rpm contém um módulo que permite que aplicações
570escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
571RPM (RPM Package Manager).
572
573Esse pacote deve ser instalado se você quiser desenvolver programas em
574Python 3 para manipular pacotes e bancos de dados RPM.
575
5c2ab5c7
AM
576%package apidocs
577Summary: RPM API documentation and guides
578Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
579Group: Documentation
d308de4c 580BuildArch: noarch
5c2ab5c7
AM
581
582%description apidocs
583Documentation for RPM API and guides in HTML format generated from rpm
584sources by doxygen.
585
586%description apidocs -l pl.UTF-8
587Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
588źrodeł RPM-a przez doxygen.
589
e2025ad1 590%prep
c546a4d6 591%setup -q -n %{name}-%{version}%{?subver}
af0cc499 592%patch0 -p1
2f0ee4ec 593%patch1 -p1
4d5b8e4c 594%patch2 -p1
af0cc499 595%patch3 -p1
7a3b1f24
AM
596%patch4 -p1
597%patch5 -p1
3c7590cc 598%patch6 -p1
af0cc499
JR
599%patch7 -p0
600%patch8 -p1
c38bf1df 601%patch9 -p1
af0cc499
JR
602%patch10 -p1
603%patch11 -p1
604%patch12 -p1
605%patch13 -p1
606%patch14 -p1
7033e976 607%patch15 -p1
af0cc499
JR
608%patch16 -p1
609%patch17 -p1
610#%patch18 -p1
611#%patch19 -p1
883e0fac 612
fb35e2d9 613install %{SOURCE2} pld.in
34865f27
JR
614install %{SOURCE8} scripts/php.prov.in
615install %{SOURCE9} scripts/php.req.in
0bf34f68 616install %{SOURCE11} scripts/perl.prov.in
e2489d8e 617cp -p %{SOURCE30} scripts/rubygems.rb
63194730 618cp -p %{SOURCE31} scripts/gem_helper.rb
08697680 619
70f8787d 620%{__mv} -f scripts/perl.req{,.in}
633d1e9e 621
cd86db2e 622# generate Group translations to *.po
80b8a1f9 623awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 624
91ee86a9 625install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 626install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 627
40675133
JR
628%{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
629
87ef0d95 630%build
ea816ea6 631%{__libtoolize}
ceaaacee 632%{__aclocal}
4cd84746 633%{__autoheader}
7a9d72ce 634%{__autoconf}
7a9d72ce 635%{__automake}
7a9d72ce 636
048d06f8
JR
637# rpm checks for CPU type at runtime, but it looks better
638sed -i \
639 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
640 -e 's|@host_cpu@|%{_target_cpu}|' \
641 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 642 macros.in
048d06f8 643
5c767dc1 644CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
624f96ff 645%configure \
01d7a578 646 WITH_PERL_VERSION=no \
bba1059c 647 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 648 __GPG=%{_bindir}/gpg \
f9d0e5f6
JR
649 %{?with_python3:PYTHON=python3} \
650 %{!?with_python3:%{?with_python2:PYTHON=python2}} \
3a3e476f 651 --disable-silent-rules \
cd86db2e 652 --enable-shared \
34865f27 653 --enable-bdb \
af0cc499 654 --enable-zstd \
fb35e2d9 655 --with-crypto=openssl \
c38bf1df 656 --with-lua \
34865f27
JR
657 --with-cap \
658 --with-acl \
659 --with-audit \
af0cc499 660 --with-archive \
f9d0e5f6
JR
661%if %{with python2} || %{with python3}
662 --enable-python \
663%endif
fb35e2d9 664 --with-selinux=%{!?with_selinux:no}%{?with_selinux:yes} \
34865f27
JR
665 --with-vendor=pld
666
34865f27
JR
667# --enable-ndb (EXPERIMENTAL) enable the new rpm database format
668# --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
34865f27 669# --with-imaevm build with imaevm support
cf6faebc 670
5c767dc1 671%{__make}
5c2ab5c7 672
fb95de52
JR
673%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
674 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
675%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
676 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
677
678if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
679 echo "Error linking rpmdb tools!"
680 exit 1
681fi
8e8746c0
JR
682if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
683 echo "Error linking rpmdb tools!"
684 exit 1
685fi
91ee86a9 686
f9d0e5f6
JR
687%if %{with python2}
688cd python
689%py_build
690cd ..
691%endif
692
693%if %{with python3}
694cd python
695%py3_build
696%endif
697
b064b8e6 698%install
ff7bc1e6 699rm -rf $RPM_BUILD_ROOT
d1f5e279
JR
700install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
701 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib}
54eb1770 702
d1f5e279 703cp -p %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 704
d1f5e279 705%{__make} install \
241257bf
AM
706 pkgconfigdir=%{_pkgconfigdir} \
707 DESTDIR=$RPM_BUILD_ROOT
718426e1 708
c546a4d6 709# cleanup
c2683840 710%ifnarch %{ix86} %{x8664} x32
2f409bb7 711rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 712rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
713rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
714rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
715rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
716rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
717rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
718rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
719%endif
720
c2683840 721%ifnarch %{x8664} x32
2f409bb7
JR
722rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
723rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
724rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
725rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
726%endif
727
c546a4d6 728%ifnarch %{ppc}
34865f27
JR
729rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
730rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
731rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
732rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
733rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 734rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 735rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
736%endif
737
34865f27 738rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
2f409bb7
JR
739rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
740rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
741rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
742rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 743rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 744rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 745rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 746rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 747
3a3e476f 748%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 749
d1f5e279
JR
750cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
751cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
752cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
753cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
754cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
755cp -p scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68 756cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
d1f5e279
JR
757cp -p %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
758cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
759cp -p %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 760
d1f5e279 761cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 762
950eead3
ER
763install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
764
d1f5e279
JR
765cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
766cp -p %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
767cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
768cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
769cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
770cp -p %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
771cp -p %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 772
950eead3
ER
773touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
774touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
d1f5e279 775cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
776touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
777touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
778touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 779
f9d0e5f6
JR
780cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
781cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
782cp -p %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 783
950eead3
ER
784# move rpm to /bin
785mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
786# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
787for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
788 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
789 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
790done
791
f9d0e5f6
JR
792%if %{with python2}
793# Remove anything that rpm make install might put there
794%{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
795cd python
796%py_install
797%py_postclean
798cd ..
799%endif
6f18cdb7 800
f9d0e5f6
JR
801%if %{with python3}
802# Remove anything that rpm make install might put there
803%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
804cd python
805%py3_install
806cd ..
dae5e1a8 807%endif
01d7a578 808
d1f5e279
JR
809%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
810
01d7a578 811# wrong location, not used anyway
2f409bb7 812%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 813
90b03dd6 814%find_lang %{name}
cf6faebc 815
13eb5ebf 816%clean
d7df46b8 817rm -rf $RPM_BUILD_ROOT
76214164 818
cc1a4992
ER
819%pretrans
820# this needs to be a dir
821if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 822 umask 022
cc1a4992
ER
823 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
824 mkdir %{_sysconfdir}/rpm/sysinfo
825fi
826
be4d3036 827%posttrans
d25ec6ea 828if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 829 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 830 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 831 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 832 echo
e4dd6a34 833 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
834 echo
835 fi
3ca91ccd
JR
836 echo
837 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
838 echo 'you should ignore it and restart poldek'
839 echo
f9d0e5f6 840 %{_rpmlibdir}/dbupgrade.sh
be4d3036 841fi
f7779567 842
b7ee97ef
JR
843%triggerpostun -- %{name} < 4.4.9-44
844%{_rpmlibdir}/hrmib-cache
845
ceaaacee
JB
846%post lib -p /sbin/ldconfig
847%postun lib -p /sbin/ldconfig
76214164 848
37a5a2fc 849%pretrans build
d755a548 850find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 851
3684d90f
JB
852%files -f %{name}.lang
853%defattr(644,root,root,755)
d1f5e279 854%doc ChangeLog CREDITS README
3684d90f 855
3acb62f3
ER
856%dir /etc/pki/rpm-gpg
857/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 858
7a9d72ce 859%attr(755,root,root) /bin/rpm
e73478cd 860
66edd895 861%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 862%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 863%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 864# these are ok to be replaced
950eead3 865%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4 866
09bb810c 867%{_mandir}/man8/rpm.8*
feb1f12e 868%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 869%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 870%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 871%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 872%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 873%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 874
40675133
JR
875#%dir /var/lib/rpm
876#%dir /var/lib/rpm/log
877#%dir /var/lib/rpm/tmp
878#%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
4acac5de 879
cf709a39
ER
880# exported package NVRA (stamped with install tid)
881# net-snmp hrSWInstalledName queries, bash-completions
882%dir /var/cache/hrmib
883
d755a548
JK
884%{_rpmlibdir}/rpmpopt*
885%{_rpmlibdir}/macros
08697680 886%dir %{_rpmlibdir}/macros.d
40675133
JR
887#%{_rpmlibdir}/macros.d/pld
888%{_rpmlibdir}/platform/noarch-*
c2683840 889%ifarch %{ix86} %{x8664} x32
34865f27
JR
890%{_rpmlibdir}/platform/athlon*
891%{_rpmlibdir}/platform/geode*
40675133
JR
892%{_rpmlibdir}/platform/i?86*
893%{_rpmlibdir}/platform/pentium*
34865f27
JR
894%endif
895%ifarch %{x8664} x32
896%{_rpmlibdir}/platform/amd64*
897%{_rpmlibdir}/platform/ia32e*
898%{_rpmlibdir}/platform/x86_64*
83a0601a 899%{_rpmlibdir}/platform/x32*
e23edf35
JR
900%endif
901%ifarch alpha
40675133 902%{_rpmlibdir}/platform/alpha*
e23edf35
JR
903%endif
904%ifarch ia64
40675133 905%{_rpmlibdir}/platform/ia64*
e23edf35
JR
906%endif
907%ifarch mips mipsel mips64 mips64el
40675133 908%{_rpmlibdir}/platform/mips*
e23edf35
JR
909%endif
910%ifarch %{ppc}
40675133 911%{_rpmlibdir}/platform/ppc*
e23edf35
JR
912%endif
913%ifarch sparc sparc64
40675133 914%{_rpmlibdir}/platform/sparc*
e23edf35 915%endif
3684d90f 916
cf709a39
ER
917%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
918
f9d0e5f6
JR
919%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
920%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
921%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
df50421f 922
66edd895
JB
923%files base
924%defattr(644,root,root,755)
492a2bd4 925%dir %{_sysconfdir}/rpm
66edd895
JB
926%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
927%dir %{_rpmlibdir}
928%attr(755,root,root) %{_bindir}/banner.sh
929%attr(755,root,root) %{_rpmlibdir}/user_group.sh
930%dir /var/lib/banner
931
874f4c9a
MM
932%files lib
933%defattr(644,root,root,755)
40675133
JR
934%attr(755,root,root) /%{_lib}/librpm.so.9
935%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
936%attr(755,root,root) /%{_lib}/librpmbuild.so.9
937%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
938%attr(755,root,root) /%{_lib}/librpmio.so.9
939%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
940%attr(755,root,root) /%{_lib}/librpmsign.so.9
941%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
874f4c9a 942
69131f1a
JB
943%files devel
944%defattr(644,root,root,755)
69131f1a 945%attr(755,root,root) %{_libdir}/librpm.so
950eead3 946%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 947%attr(755,root,root) %{_libdir}/librpmio.so
40675133 948%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
949%{_libdir}/librpm*.la
950%{_includedir}/rpm
951%{_pkgconfigdir}/*.pc
69131f1a 952
69131f1a
JB
953%files utils
954%defattr(644,root,root,755)
d1f5e279 955%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 956%attr(755,root,root) %{_bindir}/rpm2cpio
d1f5e279 957%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 958%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 959%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 960%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
961%attr(755,root,root) %{_rpmlibdir}/debugedit
962%attr(755,root,root) %{_rpmlibdir}/rpmdeps
69131f1a
JB
963%{_mandir}/man8/rpm2cpio.8*
964%{_mandir}/man8/rpmdeps.8*
69131f1a 965%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 966%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 967%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 968%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 969%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a 970
3684d90f 971%files build
a45ae6d8 972%defattr(644,root,root,755)
66edd895 973%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
974%attr(755,root,root) %{_rpmlibdir}/brp-*
975%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 976%attr(755,root,root) %{_rpmlibdir}/compress-doc
d755a548 977%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548 978%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 979%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578 980%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 981%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
982# needs hacked pkg-config to return anything
983%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 984%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
428645e9
JR
985# we always used scripts provided by mono-devel, maybe move them here
986#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
987#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 988
70f8787d 989%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 990# must be here for "Requires: rpm-*prov" to work
40675133
JR
991#%{_rpmlibdir}/macros.d/cmake
992#%{_rpmlibdir}/macros.d/gstreamer
993#%{_rpmlibdir}/macros.d/java
994#%{_rpmlibdir}/macros.d/libtool
995#%{_rpmlibdir}/macros.d/mono
996#%{_rpmlibdir}/macros.d/perl
997#%{_rpmlibdir}/macros.d/php
998#%{_rpmlibdir}/macros.d/pkgconfig
999#%{_rpmlibdir}/macros.d/python
1000#%{_rpmlibdir}/macros.d/ruby
1001#%{_rpmlibdir}/macros.d/selinux
1002#%{_rpmlibdir}/macros.d/tcl
1003#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6
JR
1004
1005%dir %{_rpmlibdir}/fileattrs
1006%{_rpmlibdir}/fileattrs/debuginfo.attr
1007%{_rpmlibdir}/fileattrs/desktop.attr
1008%{_rpmlibdir}/fileattrs/elf.attr
1009%{_rpmlibdir}/fileattrs/font.attr
1010%{_rpmlibdir}/fileattrs/libtool.attr
1011%{_rpmlibdir}/fileattrs/metainfo.attr
1012%{_rpmlibdir}/fileattrs/ocaml.attr
1013%{_rpmlibdir}/fileattrs/perl.attr
1014%{_rpmlibdir}/fileattrs/perllib.attr
1015%{_rpmlibdir}/fileattrs/php.attr
1016%{_rpmlibdir}/fileattrs/pkgconfig.attr
1017%{_rpmlibdir}/fileattrs/python.attr
1018%{_rpmlibdir}/fileattrs/pythondist.attr
1019%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 1020
874f4c9a
MM
1021%attr(755,root,root) %{_bindir}/gendiff
1022%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 1023%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 1024
a00926bc 1025%{_mandir}/man1/gendiff.1*
d1f5e279 1026%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 1027%{_mandir}/man8/rpmbuild.8*
fefe9d30 1028%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 1029%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 1030%{_mandir}/man8/rpmspec.8*
f3fe287f 1031
7d8492bb
JB
1032%files javaprov
1033%defattr(644,root,root,755)
1034%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1035# needs jar (any jdk), jcf-dump (gcc-java) to work
40675133 1036#%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
7d8492bb 1037
ec49e9fb
ER
1038%files rubyprov
1039%defattr(644,root,root,755)
40675133
JR
1040#%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1041#%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
ec49e9fb 1042
89334051
AF
1043%files perlprov
1044%defattr(644,root,root,755)
d755a548 1045%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 1046
80d3b868 1047%files pythonprov
d8fcb9b0 1048%defattr(644,root,root,755)
25d296e1 1049%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
d1f5e279 1050%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 1051
d36cb682
PG
1052%files php-pearprov
1053%defattr(644,root,root,755)
34865f27
JR
1054%attr(755,root,root) %{_rpmlibdir}/php.prov
1055%attr(755,root,root) %{_rpmlibdir}/php.req
9d09e076 1056%attr(755,root,root) %{_rpmlibdir}/php.req.php
d36cb682 1057
f9d0e5f6 1058%if %{with python2}
cf6faebc 1059%files -n python-rpm
42a0025c 1060%defattr(644,root,root,755)
34865f27
JR
1061%dir %{py_sitedir}/rpm
1062%attr(755,root,root) %{py_sitedir}/rpm/*.so
1063%{py_sitedir}/rpm/*.py[co]
f9d0e5f6
JR
1064%{py_sitedir}/rpm-%{version}-py*.egg-info
1065%endif
1066
1067%if %{with python3}
1068%files -n python3-rpm
1069%defattr(644,root,root,755)
1070%dir %{py3_sitedir}/rpm
1071%attr(755,root,root) %{py3_sitedir}/rpm/*.so
1072%{py3_sitedir}/rpm/*.py
1073%{py3_sitedir}/rpm-%{version}-py*.egg-info
1074%{py3_sitedir}/rpm/__pycache__
50dc9ac0 1075%endif
5c2ab5c7
AM
1076
1077%if %{with apidocs}
1078%files apidocs
1079%defattr(644,root,root,755)
d1f5e279
JR
1080%doc doc/librpm/html/*
1081%endif
1082
1083
1084%if 0
1085%attr(755,root,root) %{_bindir}/rpmdb
1086%attr(755,root,root) %{_bindir}/rpmgraph
1087%attr(755,root,root) %{_bindir}/rpmkeys
1088%attr(755,root,root) %{_bindir}/rpmquery
1089%attr(755,root,root) %{_bindir}/rpmsign
1090%attr(755,root,root) %{_bindir}/rpmverify
1091%attr(755,root,root) %{_rpmlibdir}/check-buildroot
1092%attr(755,root,root) %{_rpmlibdir}/check-prereqs
1093%attr(755,root,root) %{_rpmlibdir}/check-rpaths
1094%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
1095%attr(755,root,root) %{_rpmlibdir}/config.guess
1096%attr(755,root,root) %{_rpmlibdir}/config.sub
1097%attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
1098%attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
1099%attr(755,root,root) %{_rpmlibdir}/find-provides
1100%attr(755,root,root) %{_rpmlibdir}/find-requires
1101%attr(755,root,root) %{_rpmlibdir}/metainfo.prov
1102%attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
1103%attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
1104# valgrind suppression file for rpm
1105%{_rpmlibdir}/rpm.supp
1106%{_rpmlibdir}/rpmrc
1107%attr(755,root,root) %{_rpmlibdir}/script.req
1108%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
1109
d1f5e279
JR
1110
1111%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1112%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1113%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1114%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1115%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1116%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1117%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1118
1119%{_mandir}/man8/rpm-misc.8*
1120%{_mandir}/man8/rpmdb.8*
1121%{_mandir}/man8/rpmkeys.8*
1122%{_mandir}/man8/rpmsign.8*
1123%{_mandir}/man8/rpmgraph.8*
1124%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
1125%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
5c2ab5c7 1126%endif
This page took 0.99774 seconds and 4 git commands to generate.