]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- don't use possibly missing macros in preamble
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
c296fee0 3# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 4#
89427592 5# Conditional build:
0a1ccab0 6%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6 7%bcond_without python3 # don't build python bindings
b0333243 8%bcond_without plugins # build plugins
af0cc499 9%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
85c29998 10%bcond_with imaevm # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
858aa7d0 11
6f068494
JR
12%define db_ver 5.3.28.0
13%define popt_ver 1.15
24b1f498 14%define sover 9.1.0
fc60c9f3 15
7bf81d56
JR
16%if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
17%define with_recommends_tags 1
18%endif
8a4b67ac 19
e5f02e49 20Summary: RPM Package Manager
4ea2ed33
ER
21Summary(de.UTF-8): RPM Packet-Manager
22Summary(es.UTF-8): Gestor de paquetes RPM
23Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
24Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
25Summary(ru.UTF-8): Менеджер пакетов от RPM
26Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 27Name: rpm
24b1f498 28Version: 4.16.0
98d9fc8e 29Release: 0.1
9fe07969 30Epoch: 1
98d9fc8e 31License: GPL v2 / LGPL v2.1
76214164 32Group: Base
24b1f498
JR
33Source0: http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
34# Source0-md5: 434e166a812e35ef181f6dd176326920
faba01eb
JR
35Source1: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
36# Source1-md5: 23914bb49fafe7153cee87126d966461
37Source2: macros.local
38Source3: macros.lang
39Source4: %{name}.sysconfig
40Source5: %{name}.groups
80b8a1f9 41Source6: %{name}-groups-po.awk
faba01eb
JR
42Source7: %{name}-install-tree
43Source8: %{name}-hrmib-cache
44Source9: %{name}-user_group.sh
a4b7ef27 45# http://svn.pld-linux.org/banner.sh/
faba01eb 46Source10: banner.sh
b2d6b731
JR
47Source11: %{name}.noautoprov
48Source12: %{name}.noautoprovfiles
49Source13: %{name}.noautoreq
50Source14: %{name}.noautoreqfiles
51Source15: perl.prov
52Source16: %{name}db_checkversion.c
53Source17: %{name}db_reset.c
54Source18: dbupgrade.sh
af0cc499
JR
55Patch0: %{name}-man_pl.patch
56Patch1: %{name}-popt-aliases.patch
57Patch2: %{name}-perl-macros.patch
58Patch3: %{name}-perl-req-perlfile.patch
59Patch4: %{name}-scripts-closefds.patch
cbab0cbf
JR
60Patch6: %{name}-perl_req-INC_dirs.patch
61Patch7: %{name}-debuginfo.patch
62Patch8: %{name}-libtool-deps.patch
63Patch9: %{name}-builddir-readlink.patch
64Patch10: %{name}-changelog_order_check_nonfatal.patch
65Patch11: %{name}-postun-nofail.patch
66Patch12: %{name}-clean-docdir.patch
67Patch13: %{name}-perl-magic.patch
68Patch14: %{name}-ignore-missing-macro-files.patch
69Patch15: x32.patch
b2d6b731
JR
70Patch16: rpm5-db-compat.patch
71Patch17: python-internal-build.patch
5570f8e6 72Patch18: rpmversion.patch
837ad262 73Patch19: pkgconfig.patch
f16801b5 74Patch20: uname-deps.patch
7f5abfc0 75Patch21: aarch64.patch
681ee2f6 76URL: https://rpm.org/
ee163f1b 77BuildRequires: acl-devel
6f068494 78BuildRequires: db-devel >= %{db_ver}
29855fc2 79BuildRequires: autoconf >= 2.63
644d8958 80BuildRequires: automake >= 1.4
33be5db0 81BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 82BuildRequires: elfutils-devel >= 0.108
3e70c06e 83BuildRequires: gettext-tools >= 0.19.2
af0cc499 84BuildRequires: libarchive-devel
ee163f1b 85BuildRequires: libcap-devel
241257bf 86BuildRequires: libmagic-devel
0d108dc8 87BuildRequires: libgcrypt-devel
b0333243
JR
88%if %{with plugins}
89BuildRequires: audit-libs-devel
90BuildRequires: dbus-devel
85c29998 91%{?with_imaevm:BuildRequires: libimaevm-devel >= 1.0}
6e115b23 92BuildRequires: libselinux-devel >= 2.1.0
6e115b23 93%endif
84cdee7a
JB
94# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
95BuildRequires: libstdc++-devel
b60c74c3 96BuildRequires: libtool >= 1:1.4.2-9
127a0b3c 97BuildRequires: ossp-uuid-devel
7973b351 98BuildRequires: patch >= 2.2
ae228405 99BuildRequires: pkgconfig(lua) >= 5.1
6f068494 100BuildRequires: popt-devel >= %{popt_ver}
85c29998
JR
101BuildRequires: python3-modules
102%if %{with python3}
103BuildRequires: python3-devel
f9d0e5f6 104BuildRequires: rpm-pythonprov
3d169da3 105BuildRequires: rpmbuild(macros) >= 1.750
f9d0e5f6 106%endif
85c29998 107BuildRequires: sqlite3-devel >= 3.22.0
e56a10a9 108BuildRequires: tcl
77fcdbf7 109BuildRequires: xz-devel
3acb62f3 110BuildRequires: zlib-devel
34865f27 111BuildRequires: zstd-devel
5c2ab5c7
AM
112%if %{with apidocs}
113BuildRequires: doxygen
114BuildRequires: ghostscript
115BuildRequires: graphviz
116BuildRequires: tetex-pdftex
117%endif
d25ec6ea 118Requires(posttrans): coreutils
9fe07969
JR
119Requires: %{name}-base = %{epoch}:%{version}-%{release}
120Requires: %{name}-lib = %{epoch}:%{version}-%{release}
3de8e4a9 121Requires: rpm-pld-macros >= 1.744
d1f5e279 122Requires: FHS >= 3.0-2
0d108dc8 123Requires: libgcrypt
6f068494 124Requires: popt >= %{popt_ver}
b0333243
JR
125%if %{with recommends_tags}
126Recommends: rpm-plugin-audit
127Recommends: rpm-plugin-prioreset
128Recommends: rpm-plugin-syslog
129Recommends: rpm-plugin-systemd-inhibit
130%endif
d1f5e279 131Obsoletes: rpm-utils-perl
f57f030d 132Obsoletes: rpm-utils-static
874f4c9a 133Conflicts: glibc < 2.2.92
8ee1c72c
AM
134# db4.6 poldek needed
135Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
136# segfaults with lzma 0.42.2
137Conflicts: lzma-libs < 4.999.3
e4084afd 138Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 139BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 140
4adb7d05 141%define _binary_payload w9.gzdio
6d82b332 142
4cd84746 143# don't require very fresh rpm.macros to build
950eead3 144%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 145%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 146%define ppc ppc ppc7400 ppc7450
9f517079 147%define x8664 amd64 ia32e x86_64
4cd84746 148
d755a548
JK
149%define _rpmlibdir /usr/lib/rpm
150
ff7bc1e6 151%description
152RPM is a powerful package manager, which can be used to build,
153install, query, verify, update, and uninstall individual software
cf6faebc 154packages. A package consists of an archive of files, and package
fed73700 155information, including name, version, and description.
156
dd85fadc
JR
157%description -l de.UTF-8
158RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 159Installation, Anfrage, Verifizierung, Aktualisierung und
160Uninstallation individueller Softwarepakete. Ein Paket besteht aus
161einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 162Beschreibung.
163
dd85fadc 164%description -l es.UTF-8
313a4d1a 165RPM es un poderoso administrador de paquetes, que puede ser usado para
166construir, instalar, pesquisar, verificar, actualizar y desinstalar
167paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
168almacenaje de archivos, y información sobre el paquete, incluyendo
169nombre, versión y descripción.
170
171%description -l pl.UTF-8
172RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
173przebudowanie, instalację czy weryfikację dowolnego pakietu.
174Informacje dotyczące każdego pakietu, takie jak jego opis, lista
175plików wchodzących w skład pakietu, zależności od innych pakietów, są
176przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 177odpytywania programu rpm.
178
dd85fadc
JR
179%description -l pt_BR.UTF-8
180RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 181construir, instalar, pesquisar, verificar, atualizar e desinstalar
182pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
183arquivos e informações adicionais, incluindo nome, versão e descrição
184do pacote, permissões dos arquivos, etc.
185
186%description -l ru.UTF-8
187RPM - это мощный менеджер пакетов, который может быть использован для
188создания, инсталляции, запросов (query), проверки, обновления и
189удаления программных пакетов. Пакет состоит из файлового архива и
190служебной информации, включающей название, версию, описание и другие
191данные о пакете.
192
193%description -l uk.UTF-8
194RPM - це потужний менеджер пакетів, що може бути використаний для
195створення, інсталяції, запитів (query), перевірки, поновлення та
196видалення програмних пакетів. Пакет складається з файлового архіву та
197службової інформації, що містить назву, версію, опис та іншу
198інформацію про пакет.
7c6dc55f 199
66edd895
JB
200%package base
201Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 202Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 203Group: Base
1d9ca0c1 204Requires: filesystem
950eead3 205Obsoletes: rpm-scripts
66edd895
JB
206Obsoletes: vserver-rpm
207
208%description base
209The RPM base package contains scripts used by rpm packages themselves.
210These include:
211- scripts for adding/removing groups and users needed for rpm
212 packages,
213- banner.sh to display %%banner messages from rpm scriptlets.
214
dd85fadc
JR
215%description base -l pl.UTF-8
216Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 217Zawiera on:
dd85fadc
JR
218- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
219- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 220
69131f1a
JB
221%package lib
222Summary: RPMs library
4ea2ed33 223Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 224Group: Libraries
6f068494 225Requires: db >= %{db_ver}
241257bf 226Requires: libmagic >= 1.15-2
6f068494 227Requires: popt >= %{popt_ver}
d1795eb0 228Obsoletes: rpm-libs
69131f1a
JB
229# avoid SEGV caused by mixed db versions
230Conflicts: poldek < 0.18.1-16
231
232%description lib
233RPMs library.
234
dd85fadc 235%description lib -l pl.UTF-8
69131f1a
JB
236Biblioteki RPM-a.
237
fed73700 238%package devel
3f2d796a 239Summary: Header files for rpm libraries
4ea2ed33
ER
240Summary(de.UTF-8): Header-Dateien für rpm Libraries
241Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
242Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
243Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
244Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
245Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 246Group: Development/Libraries
9fe07969 247Requires: %{name}-lib = %{epoch}:%{version}-%{release}
fea3cb89 248Requires: bzip2-devel
24b1f498 249Requires: db-devel >= %{db_ver}
5c583f90 250Requires: elfutils-devel
241257bf 251Requires: libmagic-devel
0d108dc8 252Requires: libgcrypt-devel
c7b2d5f9
KK
253%if %{with selinux}
254Requires: libselinux-devel
255Requires: libsemanage-devel
256Requires: libsepol-devel
257%endif
6f068494 258Requires: popt-devel >= %{popt_ver}
fea3cb89 259Requires: zlib-devel
cf6faebc 260
261%description devel
3f2d796a
JB
262The RPM packaging system includes C libraries that make it easy to
263manipulate RPM packages and databases. They are intended to ease the
cf6faebc 264creation of graphical package managers and other tools that need
3f2d796a
JB
265intimate knowledge of RPM packages. This package contains header files
266for these libraries.
fed73700 267
dd85fadc
JR
268%description devel -l de.UTF-8
269Der RPM-Packensystem enthält eine C-Library, die macht es einfach
270RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 271Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 272Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
273
dd85fadc 274%description devel -l es.UTF-8
313a4d1a 275El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
276fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
277facilitar la creación de administradores gráficos de paquetes y otras
20f89981 278herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 279
dd85fadc
JR
280%description devel -l pl.UTF-8
281System RPM zawiera biblioteki C, które ułatwiają manipulowanie
282pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
283graficznych programów zarządzających pakietami oraz innych narzędzi,
284które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
285zawiera pliki nagłówkowe wspomnianych bibliotek.
286
287%description devel -l pt_BR.UTF-8
288O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
289a manipulação de pacotes e bases de dados RPM. Seu objetivo é
290facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 291ferramentas que precisem de conhecimento profundo de pacotes RPM.
292
dd85fadc
JR
293%description devel -l ru.UTF-8
294Система управления пакетами RPM содержит библиотеку C, которая
295упрощает манипуляцию пакетами RPM и соответствующими базами данных.
296Эта библиотека предназначена для облегчения создания графических
297пакетных менеджеров и других утилит, которым необходимо работать с
298пакетами RPM.
7c6dc55f 299
dd85fadc
JR
300%description devel -l uk.UTF-8
301Система керування пакетами RPM містить бібліотеку C, котра спрощує
302роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
303призначена для полегшення створення графічних пакетних менеджерів та
304інших утиліт, що працюють з пакетами RPM.
7c6dc55f 305
fed73700 306%package utils
8482995c 307Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
308Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
309Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 310Group: Applications/File
9fe07969 311Requires: %{name} = %{epoch}:%{version}-%{release}
6f068494 312Requires: popt >= %{popt_ver}
af0cc499
JR
313%if %{with recommends_tags}
314Recommends: bzip2
315Recommends: gzip
86b85368 316%endif
695e60ad 317Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 318
319%description utils
8482995c 320Additional utilities for managing RPM packages and database.
fed73700 321
dd85fadc
JR
322%description utils -l de.UTF-8
323Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 324
dd85fadc
JR
325%description utils -l pl.UTF-8
326Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 327
fed73700 328%package build
e191287c 329Summary: Scripts for building binary RPM packages
4ea2ed33
ER
330Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
331Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
332Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
333Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
334Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 335Group: Applications/File
f15ca8ca
ER
336Requires(pretrans): coreutils
337Requires(pretrans): findutils
9fe07969 338Requires: %{name}-utils = %{epoch}:%{version}-%{release}
3de8e4a9 339Requires: rpm-pld-macros-build >= 1.744
e191287c 340Requires: /bin/id
341Requires: awk
cfa7898a 342Requires: bzip2
e950a6d7 343Requires: chrpath >= 0.10-4
b6547e10 344Requires: cpio
e191287c 345Requires: diffutils
195f647c 346Requires: elfutils
583135b4 347Requires: file >= 4.17
e191287c 348Requires: fileutils
349Requires: findutils
950eead3
ER
350%ifarch athlon
351Requires: gcc >= 3.0.3
352%else
353Requires: gcc
354%endif
e191287c 355Requires: glibc-devel
356Requires: grep
357Requires: gzip
358Requires: make
359Requires: patch
adbd4815 360Requires: sed >= 4.0
e191287c 361Requires: sh-utils
adbd4815 362Requires: tar >= 1:1.22
e191287c 363Requires: textutils
3acb62f3 364Requires: which
adbd4815 365Requires: xz
37ea389a 366Provides: rpmbuild(noauto) = 3
02d17bf9 367%ifarch %{x8664}
195f647c
JB
368Conflicts: automake < 1:1.7.9-2
369Conflicts: libtool < 2:1.5-13
370%endif
0096c5cd 371
e2025ad1 372%description build
58399c37 373Scripts for building binary RPM packages.
fed73700 374
dd85fadc
JR
375%description build -l de.UTF-8
376Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 377
dd85fadc
JR
378%description build -l pl.UTF-8
379Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 380
dd85fadc
JR
381%description build -l pt_BR.UTF-8
382Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 383construir pacotes usando o RPM.
e73478cd 384
dd85fadc
JR
385%description build -l ru.UTF-8
386Различные вспомогательные скрипты и исполняемые программы, которые
387используются для сборки RPM'ов.
7c6dc55f 388
dd85fadc
JR
389%description build -l uk.UTF-8
390Різноманітні допоміжні скрипти та утиліти, які використовуються для
391побудови RPM'ів.
7c6dc55f 392
69131f1a 393%package perlprov
8482995c 394Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 395Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 396Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 397Group: Applications/File
9fe07969 398Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 399Requires: perl-Encode
69131f1a
JB
400Requires: perl-devel
401Requires: perl-modules
402
403%description perlprov
8482995c 404Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
405packages.
406
dd85fadc
JR
407%description perlprov -l de.UTF-8
408Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 409
dd85fadc 410%description perlprov -l pl.UTF-8
8482995c
JB
411Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
412pakietach RPM.
69131f1a
JB
413
414%package pythonprov
8482995c
JB
415Summary: Python macros, which simplifies creation of RPM packages with Python software
416Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 417Group: Applications/File
9fe07969 418Requires: %{name} = %{epoch}:%{version}-%{release}
85c29998
JR
419Requires: python3
420Requires: python3-modules
421Requires: python3-setuptools
69131f1a
JB
422
423%description pythonprov
8482995c 424Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
425software.
426
dd85fadc 427%description pythonprov -l pl.UTF-8
8482995c 428Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
429Pythonie.
430
f9d0e5f6
JR
431%package -n python3-rpm
432Summary: Python 3 interface to RPM library
433Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
434Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
435Group: Development/Languages/Python
9fe07969 436Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6 437Requires: python3
85c29998
JR
438Obsoletes: python-rpm < 1:4.16.0
439Obsoletes: rpm-python
f9d0e5f6
JR
440
441%description -n python3-rpm
442The python3-rpm package contains a module which permits applications
443written in the Python 3 programming language to use the interface
444supplied by RPM (RPM Package Manager) libraries.
445
446This package should be installed if you want to develop Python 3
447programs that will manipulate RPM packages and databases.
448
449%description -n python3-rpm -l pl.UTF-8
450Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
24b1f498
JR
451Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
452RPM-a.
f9d0e5f6
JR
453
454Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
455Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
456
457%description -n python3-rpm -l pt_BR.UTF-8
458O pacote python3-rpm contém um módulo que permite que aplicações
459escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
460RPM (RPM Package Manager).
461
462Esse pacote deve ser instalado se você quiser desenvolver programas em
463Python 3 para manipular pacotes e bancos de dados RPM.
464
b0333243
JR
465%package plugin-audit
466Summary: Plugin for logging audit events on package operations
24b1f498 467Group: Base
9fe07969 468Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
469
470%description plugin-audit
471Plugin for libaudit support
472
473%package plugin-syslog
474Summary: Plugin for syslog functionality
24b1f498 475Group: Base
9fe07969 476Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
477
478%description plugin-syslog
479This plugin exports RPM actions to the system log.
480
481%package plugin-systemd-inhibit
482Summary: Plugin for systemd inhibit functionality
24b1f498 483Group: Base
9fe07969 484Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
485
486%description plugin-systemd-inhibit
487This plugin blocks systemd from entering idle, sleep or shutdown while
488an rpm transaction is running using the systemd-inhibit mechanism.
489
490%package plugin-ima
491Summary: Plugin for IMA file signatures
492Group: Base
9fe07969 493Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
494
495%description plugin-ima
496This plugin adds support for enforcing and verifying IMA file
497signatures in an rpm.
498
499%package plugin-prioreset
500Summary: Plugin for resetting scriptlet priorities for SysV init
501Group: Base
9fe07969 502Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
503
504%description plugin-prioreset
505This plugin is useful on legacy SysV init systems if you run rpm
506transactions with nice/ionice priorities. Should not be used on
507systemd systems.
508
509%package plugin-selinux
510Summary: Plugin for SELinux functionality
8191f3c5 511Group: Base
9fe07969 512Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
513Requires: libselinux >= 2.1.0
514
515%description plugin-selinux
516Plugin for SELinux functionality.
517
8191f3c5
JR
518%package sign
519Summary: Package signing support
520Group: Base
9fe07969 521Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
522
523%description sign
524This package contains support for digitally signing RPM packages.
525
5c2ab5c7
AM
526%package apidocs
527Summary: RPM API documentation and guides
528Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
529Group: Documentation
d308de4c 530BuildArch: noarch
5c2ab5c7
AM
531
532%description apidocs
533Documentation for RPM API and guides in HTML format generated from rpm
534sources by doxygen.
535
536%description apidocs -l pl.UTF-8
537Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
538źrodeł RPM-a przez doxygen.
539
e2025ad1 540%prep
c546a4d6 541%setup -q -n %{name}-%{version}%{?subver}
af0cc499 542%patch0 -p1
2f0ee4ec 543%patch1 -p1
4d5b8e4c 544%patch2 -p1
af0cc499 545%patch3 -p1
7a3b1f24 546%patch4 -p1
cbab0cbf
JR
547%patch6 -p0
548%patch7 -p1
af0cc499 549%patch8 -p1
cbab0cbf 550%patch9 -p1
af0cc499
JR
551%patch10 -p1
552%patch11 -p1
553%patch12 -p1
554%patch13 -p1
555%patch14 -p1
7033e976 556%patch15 -p1
af0cc499
JR
557%patch16 -p1
558%patch17 -p1
5570f8e6 559%patch18 -p1
837ad262 560%patch19 -p1
f16801b5 561%patch20 -p1
7f5abfc0
JP
562%ifarch aarch64
563%patch21 -p1
564%endif
883e0fac 565
b2d6b731 566install %{SOURCE15} scripts/perl.prov.in
08697680 567
70f8787d 568%{__mv} -f scripts/perl.req{,.in}
633d1e9e 569
cd86db2e 570# generate Group translations to *.po
faba01eb 571awk -f %{SOURCE6} %{SOURCE5}
fefe9d30 572
b2d6b731
JR
573install %{SOURCE16} tools/rpmdb_checkversion.c
574install %{SOURCE17} tools/rpmdb_reset.c
91ee86a9 575
24b1f498 576%{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
40675133 577
87ef0d95 578%build
ea816ea6 579%{__libtoolize}
ceaaacee 580%{__aclocal}
4cd84746 581%{__autoheader}
7a9d72ce 582%{__autoconf}
7a9d72ce 583%{__automake}
7a9d72ce 584
048d06f8
JR
585# rpm checks for CPU type at runtime, but it looks better
586sed -i \
587 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
588 -e 's|@host_cpu@|%{_target_cpu}|' \
589 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 590 macros.in
048d06f8 591
624f96ff 592%configure \
01d7a578 593 WITH_PERL_VERSION=no \
bba1059c 594 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 595 __GPG=%{_bindir}/gpg \
85c29998
JR
596%if %{with python3}
597 PYTHON=python3 \
598 --enable-python \
599%endif
3a3e476f 600 --disable-silent-rules \
cd86db2e 601 --enable-shared \
34865f27 602 --enable-bdb \
85c29998
JR
603 --enable-ndb \
604 --enable-sqlite \
af0cc499 605 --enable-zstd \
c38bf1df 606 --with-lua \
85c29998 607 %{?with_imaevm:--with-imaevm} \
34865f27
JR
608 --with-cap \
609 --with-acl \
610 --with-audit \
af0cc499 611 --with-archive \
b0333243
JR
612 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
613 %{!?with_plugins:--disable-plugins} \
34865f27
JR
614 --with-vendor=pld
615
5c767dc1 616%{__make}
5c2ab5c7 617
6f068494
JR
618%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
619%{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
fb95de52
JR
620
621if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
622 echo "Error linking rpmdb tools!"
623 exit 1
624fi
8e8746c0
JR
625if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
626 echo "Error linking rpmdb tools!"
627 exit 1
628fi
91ee86a9 629
f9d0e5f6
JR
630%if %{with python3}
631cd python
632%py3_build
633%endif
634
b064b8e6 635%install
ff7bc1e6 636rm -rf $RPM_BUILD_ROOT
d1f5e279 637install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
7d12560f 638 $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
54eb1770 639
faba01eb 640cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 641
d1f5e279 642%{__make} install \
241257bf
AM
643 pkgconfigdir=%{_pkgconfigdir} \
644 DESTDIR=$RPM_BUILD_ROOT
718426e1 645
c546a4d6 646# cleanup
c2683840 647%ifnarch %{ix86} %{x8664} x32
2f409bb7 648rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 649rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
650rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
651rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
652rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
653rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
654rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
655rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
656%endif
657
c2683840 658%ifnarch %{x8664} x32
2f409bb7
JR
659rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
660rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
661rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
662rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
663%endif
664
c546a4d6 665%ifnarch %{ppc}
34865f27
JR
666rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
667rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
668rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
669rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
670rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 671rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 672rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
673%endif
674
7f5abfc0 675%ifnarch aarch64
34865f27 676rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
7f5abfc0
JP
677%endif
678
2f409bb7
JR
679rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
680rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
681rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
682rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 683rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 684rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 685rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 686rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 687
3a3e476f 688%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 689
396a7387 690install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
396a7387 691
faba01eb
JR
692cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
693cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
694cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
695cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 696
faba01eb 697cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 698
faba01eb
JR
699cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
700cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
b2d6b731
JR
701cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
702cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
703cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
704cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 705
f9d0e5f6
JR
706cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
707cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
b2d6b731 708cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 709
950eead3 710# move rpm to /bin
8191f3c5
JR
711%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
712ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
713ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
714
950eead3 715# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
716for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
717 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
718 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
719done
720
7d12560f
JR
721#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
722
85c29998
JR
723# Make sure we have bdb set a default backend
724grep -qE "db_backend[[:blank:]]+bdb" $RPM_BUILD_ROOT%{_rpmlibdir}/macros
6f18cdb7 725
f9d0e5f6
JR
726%if %{with python3}
727# Remove anything that rpm make install might put there
728%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
729cd python
730%py3_install
731cd ..
dae5e1a8 732%endif
01d7a578 733
d1f5e279
JR
734%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
735
01d7a578 736# wrong location, not used anyway
2f409bb7 737%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 738
90b03dd6 739%find_lang %{name}
cf6faebc 740
13eb5ebf 741%clean
d7df46b8 742rm -rf $RPM_BUILD_ROOT
76214164 743
be4d3036 744%posttrans
d25ec6ea 745if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 746 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 747 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 748 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 749 echo
e4dd6a34 750 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
751 echo
752 fi
3ca91ccd
JR
753 echo
754 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
755 echo 'you should ignore it and restart poldek'
756 echo
f9d0e5f6 757 %{_rpmlibdir}/dbupgrade.sh
be4d3036 758fi
f7779567 759
b7ee97ef
JR
760%triggerpostun -- %{name} < 4.4.9-44
761%{_rpmlibdir}/hrmib-cache
762
ceaaacee
JB
763%post lib -p /sbin/ldconfig
764%postun lib -p /sbin/ldconfig
76214164 765
37a5a2fc 766%pretrans build
d755a548 767find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 768
3684d90f
JB
769%files -f %{name}.lang
770%defattr(644,root,root,755)
d1f5e279 771%doc ChangeLog CREDITS README
3684d90f 772
3acb62f3
ER
773%dir /etc/pki/rpm-gpg
774/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 775
7a9d72ce 776%attr(755,root,root) /bin/rpm
8191f3c5
JR
777%attr(755,root,root) %{_bindir}/rpmdb
778%attr(755,root,root) %{_bindir}/rpmkeys
779%attr(755,root,root) %{_bindir}/rpmquery
780%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 781
66edd895 782%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 783%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
caf453d4 784
09bb810c 785%{_mandir}/man8/rpm.8*
8191f3c5
JR
786%{_mandir}/man8/rpmdb.8*
787%{_mandir}/man8/rpmkeys.8*
788%{_mandir}/man8/rpm-misc.8*
24b1f498 789%{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
feb1f12e 790%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 791%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 792%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 793%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 794%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 795%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 796
7d12560f 797%dir /var/lib/rpm
4acac5de 798
cf709a39
ER
799# exported package NVRA (stamped with install tid)
800# net-snmp hrSWInstalledName queries, bash-completions
801%dir /var/cache/hrmib
802
d755a548 803%{_rpmlibdir}/rpmpopt*
8191f3c5 804%{_rpmlibdir}/rpmrc
d755a548 805%{_rpmlibdir}/macros
08697680 806%dir %{_rpmlibdir}/macros.d
e8836e1f 807%dir %{_rpmlibdir}/platform
40675133 808%{_rpmlibdir}/platform/noarch-*
c2683840 809%ifarch %{ix86} %{x8664} x32
34865f27
JR
810%{_rpmlibdir}/platform/athlon*
811%{_rpmlibdir}/platform/geode*
40675133
JR
812%{_rpmlibdir}/platform/i?86*
813%{_rpmlibdir}/platform/pentium*
34865f27
JR
814%endif
815%ifarch %{x8664} x32
816%{_rpmlibdir}/platform/amd64*
817%{_rpmlibdir}/platform/ia32e*
818%{_rpmlibdir}/platform/x86_64*
83a0601a 819%{_rpmlibdir}/platform/x32*
e23edf35
JR
820%endif
821%ifarch alpha
40675133 822%{_rpmlibdir}/platform/alpha*
e23edf35 823%endif
7f5abfc0
JP
824%ifarch aarch64
825%{_rpmlibdir}/platform/aarch64*
826%endif
e23edf35 827%ifarch ia64
40675133 828%{_rpmlibdir}/platform/ia64*
e23edf35
JR
829%endif
830%ifarch mips mipsel mips64 mips64el
40675133 831%{_rpmlibdir}/platform/mips*
e23edf35
JR
832%endif
833%ifarch %{ppc}
40675133 834%{_rpmlibdir}/platform/ppc*
e23edf35
JR
835%endif
836%ifarch sparc sparc64
40675133 837%{_rpmlibdir}/platform/sparc*
e23edf35 838%endif
3684d90f 839
3de8e4a9 840%dir %{_rpmlibdir}/pld
396a7387 841
cf709a39
ER
842%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
843
f9d0e5f6
JR
844%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
845%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
846%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
24b1f498
JR
847%attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
848%attr(755,root,root) %{_rpmlibdir}/rpmdb_load
df50421f 849
7d12560f
JR
850# valgrind suppression file for rpm
851%{_rpmlibdir}/rpm.supp
852
66edd895
JB
853%files base
854%defattr(644,root,root,755)
492a2bd4 855%dir %{_sysconfdir}/rpm
66edd895
JB
856%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
857%dir %{_rpmlibdir}
858%attr(755,root,root) %{_bindir}/banner.sh
859%attr(755,root,root) %{_rpmlibdir}/user_group.sh
860%dir /var/lib/banner
861
874f4c9a
MM
862%files lib
863%defattr(644,root,root,755)
40675133
JR
864%attr(755,root,root) /%{_lib}/librpm.so.9
865%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
866%attr(755,root,root) /%{_lib}/librpmbuild.so.9
867%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
868%attr(755,root,root) /%{_lib}/librpmio.so.9
869%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
870%attr(755,root,root) /%{_lib}/librpmsign.so.9
871%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 872%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 873
69131f1a
JB
874%files devel
875%defattr(644,root,root,755)
69131f1a 876%attr(755,root,root) %{_libdir}/librpm.so
950eead3 877%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 878%attr(755,root,root) %{_libdir}/librpmio.so
40675133 879%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
880%{_libdir}/librpm*.la
881%{_includedir}/rpm
882%{_pkgconfigdir}/*.pc
69131f1a 883
69131f1a
JB
884%files utils
885%defattr(644,root,root,755)
d1f5e279 886%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 887%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 888%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 889%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 890%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
25e974c7 891%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
892%attr(755,root,root) %{_rpmlibdir}/debugedit
893%attr(755,root,root) %{_rpmlibdir}/rpmdeps
24b1f498 894%{_mandir}/man8/rpm2archive.8*
69131f1a
JB
895%{_mandir}/man8/rpm2cpio.8*
896%{_mandir}/man8/rpmdeps.8*
fc36dfd5 897%{_mandir}/man8/rpmgraph.8*
69131f1a 898%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 899%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 900%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 901%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 902%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
903%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
904%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 905
3684d90f 906%files build
a45ae6d8 907%defattr(644,root,root,755)
66edd895 908%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
909%attr(755,root,root) %{_rpmlibdir}/brp-*
910%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 911%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 912%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578
JB
913%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
914# needs hacked pkg-config to return anything
915%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 916%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
37e965e8 917
70f8787d 918%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 919# must be here for "Requires: rpm-*prov" to work
40675133
JR
920#%{_rpmlibdir}/macros.d/cmake
921#%{_rpmlibdir}/macros.d/gstreamer
40675133 922#%{_rpmlibdir}/macros.d/libtool
40675133 923#%{_rpmlibdir}/macros.d/perl
40675133
JR
924#%{_rpmlibdir}/macros.d/pkgconfig
925#%{_rpmlibdir}/macros.d/python
40675133
JR
926#%{_rpmlibdir}/macros.d/selinux
927#%{_rpmlibdir}/macros.d/tcl
928#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 929
7d12560f
JR
930%attr(755,root,root) %{_rpmlibdir}/check-buildroot
931%attr(755,root,root) %{_rpmlibdir}/check-prereqs
932%attr(755,root,root) %{_rpmlibdir}/check-rpaths
933%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
7d12560f
JR
934%attr(755,root,root) %{_rpmlibdir}/find-provides
935%attr(755,root,root) %{_rpmlibdir}/find-requires
24b1f498 936%attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
7d12560f
JR
937%attr(755,root,root) %{_rpmlibdir}/script.req
938%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
7d12560f 939
f9d0e5f6
JR
940%dir %{_rpmlibdir}/fileattrs
941%{_rpmlibdir}/fileattrs/debuginfo.attr
942%{_rpmlibdir}/fileattrs/desktop.attr
943%{_rpmlibdir}/fileattrs/elf.attr
944%{_rpmlibdir}/fileattrs/font.attr
945%{_rpmlibdir}/fileattrs/libtool.attr
946%{_rpmlibdir}/fileattrs/metainfo.attr
947%{_rpmlibdir}/fileattrs/ocaml.attr
948%{_rpmlibdir}/fileattrs/perl.attr
949%{_rpmlibdir}/fileattrs/perllib.attr
f9d0e5f6
JR
950%{_rpmlibdir}/fileattrs/pkgconfig.attr
951%{_rpmlibdir}/fileattrs/python.attr
952%{_rpmlibdir}/fileattrs/pythondist.attr
953%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 954
874f4c9a
MM
955%attr(755,root,root) %{_bindir}/gendiff
956%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 957%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 958
a00926bc 959%{_mandir}/man1/gendiff.1*
d1f5e279 960%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 961%{_mandir}/man8/rpmbuild.8*
fefe9d30 962%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 963%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 964%{_mandir}/man8/rpmspec.8*
f3fe287f 965
89334051
AF
966%files perlprov
967%defattr(644,root,root,755)
d755a548 968%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 969
80d3b868 970%files pythonprov
d8fcb9b0 971%defattr(644,root,root,755)
d1f5e279 972%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 973
f9d0e5f6
JR
974%if %{with python3}
975%files -n python3-rpm
976%defattr(644,root,root,755)
977%dir %{py3_sitedir}/rpm
978%attr(755,root,root) %{py3_sitedir}/rpm/*.so
979%{py3_sitedir}/rpm/*.py
980%{py3_sitedir}/rpm-%{version}-py*.egg-info
981%{py3_sitedir}/rpm/__pycache__
50dc9ac0 982%endif
5c2ab5c7 983
b0333243
JR
984%if %{with plugins}
985%files plugin-audit
986%defattr(644,root,root,755)
987%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
24b1f498 988%{_mandir}/man8/rpm-plugin-audit.8*
b0333243
JR
989
990%files plugin-syslog
991%defattr(644,root,root,755)
992%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
24b1f498 993%{_mandir}/man8/rpm-plugin-syslog.8*
b0333243
JR
994
995%files plugin-systemd-inhibit
996%defattr(644,root,root,755)
997%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
998%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
999
1000%files plugin-ima
1001%defattr(644,root,root,755)
1002%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
24b1f498 1003%{_mandir}/man8/rpm-plugin-ima.8*
b0333243
JR
1004
1005%files plugin-prioreset
1006%defattr(644,root,root,755)
1007%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
24b1f498 1008%{_mandir}/man8/rpm-plugin-prioreset.8*
b0333243
JR
1009
1010%files plugin-selinux
1011%defattr(644,root,root,755)
1012%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
24b1f498 1013%{_mandir}/man8/rpm-plugin-selinux.8*
b0333243
JR
1014%endif
1015
8191f3c5
JR
1016%files sign
1017%defattr(644,root,root,755)
1018%attr(755,root,root) %{_bindir}/rpmsign
1019%{_mandir}/man8/rpmsign.8*
1020
5c2ab5c7
AM
1021%if %{with apidocs}
1022%files apidocs
1023%defattr(644,root,root,755)
d1f5e279
JR
1024%doc doc/librpm/html/*
1025%endif
This page took 0.582129 seconds and 4 git commands to generate.