]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- renumbered patches
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
9fb5ee9e 3# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 4#
c296fee0 5# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 6#
89427592 7# Conditional build:
01d7a578 8%bcond_with static # build static rpm+rpmi
0a1ccab0 9%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
10%bcond_without python # don't build python bindings
11%bcond_without selinux # build without selinux support
0dc47449 12%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
77fcdbf7 13%bcond_without neon # build with HTTP/WebDAV support (neon library)
858aa7d0 14%bcond_without db # BerkeleyDB
77fcdbf7 15%bcond_without sqlite # build with SQLite support
858aa7d0 16%bcond_with sqlite_dbapi # default database backend is sqlite
7564deb4 17%bcond_without system_lua # use system lua
89427592
JB
18# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
19# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
20# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0
AM
21#
22%if %{with sqlite_dbapi}
23%define with_sqlite 1
24%endif
54bfdf99 25
858aa7d0 26%if %{without db} && %{without sqlite}
25ac75ae 27%{error:Need db or sqlite}
858aa7d0
AM
28ERROR
29%endif
30
003a039e 31# versions of required libraries
afb55538 32%define reqdb_ver 5.3
ec44785a 33%define reqpopt_ver 1.15
fc60c9f3 34%define beecrypt_ver 2:4.1.2-4
70f8787d 35%define sover 5.4
fc60c9f3 36
e5f02e49 37Summary: RPM Package Manager
4ea2ed33
ER
38Summary(de.UTF-8): RPM Packet-Manager
39Summary(es.UTF-8): Gestor de paquetes RPM
40Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
41Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
42Summary(ru.UTF-8): Менеджер пакетов от RPM
43Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 44Name: rpm
afb55538 45Version: 5.4.10
31c26402 46Release: 0.19
b0434f77 47License: LGPL
76214164 48Group: Base
afb55538
JR
49# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
50Source0: %{name}-%{version}.tar.gz
51# Source0-md5: 5d099161bdd3203265ab32ffad3360b5
d38aed81
JR
52Source100: cpu-os-macros.tar.gz
53# Source100-md5: 928034a5bdceb398881bc14b5f29973b
ff7bc1e6 54Source1: %{name}.groups
08697680 55Source2: macros.pld.in
ff7bc1e6 56Source3: %{name}-install-tree
80b8a1f9 57Source4: %{name}-find-spec-bcond
cf709a39 58Source5: %{name}-hrmib-cache
80b8a1f9
JB
59Source6: %{name}-groups-po.awk
60Source7: %{name}-compress-doc
0bf34f68
JR
61Source8: %{name}-php-provides
62Source9: %{name}-php-requires
63Source10: %{name}.sysinfo
64Source11: perl.prov
65Source12: %{name}-user_group.sh
66Source13: %{name}.sysconfig
67Source14: %{name}-java-requires
a4b7ef27 68# http://svn.pld-linux.org/banner.sh/
0bf34f68
JR
69Source15: banner.sh
70Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
71# Source16-md5: 08b29584dd349aac9caa7610131a0a88
72Source17: %{name}-mimetypedeps
73Source18: macros.local
74Source19: rpm.noautocompressdoc
75Source20: rpm.noautoprov
76Source21: rpm.noautoprovfiles
77Source22: rpm.noautoreq
78Source23: rpm.noautoreqdep
79Source24: rpm.noautoreqfiles
80Source25: %{name}-php-requires.php
f05db907 81Patch0: %{name}-branch.patch
2f0ee4ec 82Patch1: %{name}-man_pl.patch
38e53563 83Patch2: %{name}-popt-aliases.patch
b174986a 84Patch3: %{name}-rpmpopt.patch
3465efba 85Patch4: %{name}-perl-macros.patch
c1768ce2 86Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
87Patch6: %{name}-scripts-closefds.patch
88Patch7: %{name}-php-macros.patch
89Patch8: %{name}-gettext-in-header.patch
044171ea 90Patch9: %{name}-lua.patch
9ee75c3c
JR
91Patch10: %{name}-php-deps.patch
92Patch11: %{name}-notsc.patch
93Patch12: %{name}-hack-norpmlibdep.patch
94Patch13: %{name}-epoch0.patch
95Patch14: %{name}-perl_req-INC_dirs.patch
96Patch15: %{name}-debuginfo.patch
97Patch16: vendor-pld.patch
98Patch17: %{name}-old-fileconflicts-behaviour.patch
99Patch18: %{name}-javadeps.patch
100Patch19: %{name}-truncate-cvslog.patch
101Patch20: %{name}-libtool-deps.patch
102Patch21: %{name}-mimetype.patch
103Patch22: %{name}-sparc64.patch
104Patch23: %{name}-gendiff.patch
105Patch24: openmp.patch
106Patch25: %{name}-URPM-build-fix.patch
107Patch26: %{name}-db5.3.patch
108Patch27: %{name}-helperEVR-noassert.patch
109Patch28: %{name}-unglobal.patch
110Patch29: %{name}-builddir-readlink.patch
111Patch30: %{name}-changelog_order_check_nonfatal.patch
112Patch31: %{name}-cleanbody.patch
113Patch32: %{name}-dirdeps-macro.patch
114Patch33: %{name}-installbeforeerase.patch
115Patch34: %{name}-libmagic-locale.patch
116Patch35: %{name}-namespace-compare.patch
117Patch36: %{name}-popt-coreutils.patch
118Patch37: %{name}-postun-nofail.patch
119Patch38: %{name}-silence-RPM_CHAR_TYPE.patch
120Patch39: %{name}-fix-missing-types-in-headers.patch
121Patch40: %{name}-fix--p-interpreter-and-empty-script.patch
122Patch41: %{name}-db_buffer_small.patch
123Patch42: %{name}-pattern_Release.patch
124Patch43: %{name}-fix-___build_pre-macro.patch
125Patch44: %{name}-missing-patch-file-fails-build.patch
126Patch45: %{name}-remove-misleading-missing-patch-message.patch
127Patch46: %{name}-file-magic-can-be-mixed-case.patch
70f8787d
JR
128
129# Patches imported from Mandriva
130
131# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
132# would basically just mean backporting it..
133Patch1000: rpm-5.4.4-add-_specfile-macro.patch
134# status: needs to be cleaned up and properly reviewed together with rest
135# of the patches related to dependency generation
136Patch1001: rpm-5.4.9-avoid-dependencies-on-self.patch
137# status: probably ready to merge
138Patch1002: rpm-5.4.4-pkgconfigdeps-check-path.patch
139# status: probably okay to merge, but discuss on rpm-devel first
140Patch1003: rpm-5.4.4-glob-wildcards-for-loading-macro-files.patch
141# status: needs to be discussed
142Patch1004: rpm-5.4.4-allow-installation-of-repackaged-rpms.patch
143# status: ready to merge
144Patch1005: rpm-5.4.8-dont-show-suggests-with-requires.patch
145# status: ready for merge
146Patch1006: rpm-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
147# status: probably okay to merge, but discuss on rpm-devel first
148Patch1007: rpm-5.4.10-duplicate_files_terminate_build.patch
149# status: same as above
150Patch1008: rpm-5.4.10-unpackaged_subdirs_terminate_build.patch
151# mdvbz#64898
152# status: uncertain, might be okay to merge, discuss on rpm-devel first
153Patch1009: rpm-5.4.4-rpmbuild-withoutclean.patch
154# no sense in having an additional dependency on 'pkgconfig' on all packages that
155# have a pkgconfig file, it's not needed for them to be made useful and anything
156# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
157# status: might be okay to merge, but discuss on rpm-devel first
158Patch1010: rpm-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
159# status: ready for merge
160Patch1011: rpm-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
161# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
162# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
163# status: needs to be discussed and investigated a bit better..
164Patch1012: rpm-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
165# status: probably okay to merge, but discuss on rpm-devel first
166Patch1013: rpm-5.4.10-files-listed-twice-terminates-build.patch
167# status: probably okay to merge
168Patch1014: rpm-5.4.9-ruby1.9-fixes.patch
169# status: keep locally
170Patch1015: rpm-5.4.9-keep-loading-script-macros.patch
171# status: same as for other dep gen patches
172Patch1016: rpm-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
173# status: idem
174Patch1017: rpm-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
175# status: ready for merge
176Patch1018: rpm-5.4.5-rubygems-add-missing-newline.patch
177# status: probably okay to merge
178Patch1019: rpm-5.4.5-python-export-spec-macros.patch
179# status: idem
180Patch1020: rpm-5.4.9-font-provides.patch
181# stauus: idem
182Patch1021: rpm-5.4.7-kmod-dependencies.patch
183# status: probably okay to merge, discuss on rpm-devel first
184Patch1022: rpm-5.4.5-skip-dependencies-for-character-devices.patch
185# status: ready to merge
186Patch1023: rpm-5.4.5-rpmfc-use-strlen-not-sizeof.patch
187# status: probably okay to merge
188Patch1024: rpm-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
189# status: ready to merge
190Patch1025: rpm-5.4.7-rpmfc-fix-invalid-free-if-not-_defaultdocdir-set.patch
191# status: probably okay to merge
192Patch1026: rpm-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
193# status: ready
194Patch1027: rpm-5.4.7-fix-generation-of-ruby-abi-provides.patch
195# crash reproducable with 'rpm -qa --triggers'
196# status: ready
197Patch1028: rpm-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
198# status: same as for other dep gen patches
199Patch1029: rpm-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
200# status: ready
201Patch1030: rpm-5.4.7-fix-minor-memleaks.patch
202# status: ready
203Patch1031: rpm-5.4.9-mire-fix-strings-lacking-null-terminator.patch
204# status: ready
205Patch1032: rpm-5.4.9-rpmpython-fix-input.patch
206# status: ready
207Patch1033: rpm-5.4.7-no-seqid_init-on-rdonly-database.patch
208# status: probably ready for merging
209Patch1034: rpm-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
210# status: probably ready to merge, discuss on rpm-devel first
211Patch1035: rpm-5.4.9-fix-verify-segfault.patch
212# status: ready and should be merged
213Patch1036: rpm-5.4.9-fix-typo-in-rpmtag-header.patch
214# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
215# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
216# with the result being that when unable to download files, neon will save error
217# page as the target file.
218# status: should go upstream, but uncertain about "correct" fix, ie. this is
219# more of a workaround, while rewriting rpmdav code to behave consistently
220# would be "the right thing to do". Yet I'm not fully able to grasp all of the
221# code and don't want to spend more time just to get the API..
222Patch1037: rpm-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
223# As the transaction flags for ignoring arch & os are no longer used, there's
224# currently no way to ignore arch & os of packages anymore. This patch adds
225# support for doing this again by defining rpm variables and overriding
226# --ignorearch & --ignoreos to set these.
227# status: needs to be discussed upstream before thinking about merging
228Patch1038: rpm-5.4.10-support-ignore-arch-and-os-again.patch
9f9190ed
JR
229# status: ready for merge
230Patch1039: rpm-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
70f8787d 231
955f2725 232URL: http://rpm5.org/
6a8612bc 233BuildRequires: autoconf >= 2.60
644d8958 234BuildRequires: automake >= 1.4
87ef0d95 235BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 236BuildRequires: bzip2-devel >= 1.0.2-17
858aa7d0 237%{?with_db:BuildRequires: db-devel >= %{reqdb_ver}}
33be5db0 238BuildRequires: elfutils-devel >= 0.108
0ef6aeae 239#BuildRequires: gettext-autopoint >= 0.11.4-2
d1795eb0 240BuildRequires: gettext-devel >= 0.11.4-2
f7100a40 241BuildRequires: keyutils-devel
241257bf 242BuildRequires: libmagic-devel
8e159d42 243%{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
84cdee7a
JB
244# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
245BuildRequires: libstdc++-devel
b60c74c3 246BuildRequires: libtool >= 1:1.4.2-9
33be5db0 247%if %{with neon}
fe861705 248BuildRequires: libxml2-devel
83d6a3fe 249BuildRequires: neon-devel >= 0.25.5
33be5db0 250%endif
127a0b3c 251BuildRequires: ossp-uuid-devel
7973b351 252BuildRequires: patch >= 2.2
1d49ffbc 253BuildRequires: popt-devel >= %{reqpopt_ver}
6a8612bc 254%{?with_system_lua:BuildRequires: lua51-devel >= 5.1.2}
950eead3
ER
255%{?with_python:BuildRequires: python-devel >= 1:2.3}
256BuildRequires: python-modules >= 1:2.3
2a813afe 257%{?with_python:BuildRequires: rpm-pythonprov}
241257bf 258%{?with_sqlite:BuildRequires: sqlite3-devel}
e56a10a9 259BuildRequires: tcl
874f4c9a 260BuildRequires: zlib-devel
77fcdbf7 261BuildRequires: xz-devel
5c2ab5c7
AM
262%if %{with apidocs}
263BuildRequires: doxygen
264BuildRequires: ghostscript
265BuildRequires: graphviz
266BuildRequires: tetex-pdftex
267%endif
a6e56ce4 268%if %{with static}
e6090a7b 269# Require static library only for static build
87ef0d95 270BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 271BuildRequires: bzip2-static >= 1.0.2-17
858aa7d0 272%{?with_db:BuildRequires: db-static >= %{reqdb_ver}}
290c1c30 273BuildRequires: elfutils-static
10abbd40 274BuildRequires: glibc-static >= 2.2.94
241257bf 275BuildRequires: libmagic-static
8e159d42 276%{?with_selinux:BuildRequires: libselinux-static >= 1.18}
003a039e 277BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 278BuildRequires: zlib-static
7a9d72ce 279%endif
66edd895 280Requires: %{name}-base = %{version}-%{release}
b26a9709 281Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
282Requires: beecrypt >= %{beecrypt_ver}
283Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
284Provides: rpm-db-ver = %{reqdb_ver}
285Obsoletes: rpm-getdeps
4adb7d05 286%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 287Conflicts: glibc < 2.2.92
8ee1c72c
AM
288# db4.6 poldek needed
289Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
290# segfaults with lzma 0.42.2
291Conflicts: lzma-libs < 4.999.3
1d49ffbc 292BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 293
4adb7d05 294%define _binary_payload w9.gzdio
6d82b332 295
4cd84746
JB
296# don't require very fresh rpm.macros to build
297%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 298%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 299%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 300%define ppc ppc ppc7400 ppc7450
9f517079 301%define x8664 amd64 ia32e x86_64
4cd84746 302
89427592 303# stabilize new build environment
f9ac32aa
AM
304%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
305%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
306%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 307
d755a548 308%define _rpmlibdir /usr/lib/rpm
950eead3 309%define _noautocompressdoc RPM-GPG-KEY
d755a548 310
573e40e1
PS
311%define specflags -fno-strict-aliasing
312
ff7bc1e6 313%description
314RPM is a powerful package manager, which can be used to build,
315install, query, verify, update, and uninstall individual software
cf6faebc 316packages. A package consists of an archive of files, and package
fed73700 317information, including name, version, and description.
318
dd85fadc
JR
319%description -l de.UTF-8
320RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 321Installation, Anfrage, Verifizierung, Aktualisierung und
322Uninstallation individueller Softwarepakete. Ein Paket besteht aus
323einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 324Beschreibung.
325
dd85fadc 326%description -l es.UTF-8
313a4d1a 327RPM es un poderoso administrador de paquetes, que puede ser usado para
328construir, instalar, pesquisar, verificar, actualizar y desinstalar
329paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
330almacenaje de archivos, y información sobre el paquete, incluyendo
331nombre, versión y descripción.
332
333%description -l pl.UTF-8
334RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
335przebudowanie, instalację czy weryfikację dowolnego pakietu.
336Informacje dotyczące każdego pakietu, takie jak jego opis, lista
337plików wchodzących w skład pakietu, zależności od innych pakietów, są
338przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 339odpytywania programu rpm.
340
dd85fadc
JR
341%description -l pt_BR.UTF-8
342RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 343construir, instalar, pesquisar, verificar, atualizar e desinstalar
344pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
345arquivos e informações adicionais, incluindo nome, versão e descrição
346do pacote, permissões dos arquivos, etc.
347
348%description -l ru.UTF-8
349RPM - это мощный менеджер пакетов, который может быть использован для
350создания, инсталляции, запросов (query), проверки, обновления и
351удаления программных пакетов. Пакет состоит из файлового архива и
352служебной информации, включающей название, версию, описание и другие
353данные о пакете.
354
355%description -l uk.UTF-8
356RPM - це потужний менеджер пакетів, що може бути використаний для
357створення, інсталяції, запитів (query), перевірки, поновлення та
358видалення програмних пакетів. Пакет складається з файлового архіву та
359службової інформації, що містить назву, версію, опис та іншу
360інформацію про пакет.
7c6dc55f 361
66edd895
JB
362%package base
363Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 364Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 365Group: Base
1d9ca0c1 366Requires: filesystem
950eead3 367Obsoletes: rpm-scripts
66edd895
JB
368Obsoletes: vserver-rpm
369
370%description base
371The RPM base package contains scripts used by rpm packages themselves.
372These include:
373- scripts for adding/removing groups and users needed for rpm
374 packages,
375- banner.sh to display %%banner messages from rpm scriptlets.
376
dd85fadc
JR
377%description base -l pl.UTF-8
378Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 379Zawiera on:
dd85fadc
JR
380- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
381- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 382
69131f1a
JB
383%package lib
384Summary: RPMs library
4ea2ed33 385Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 386Group: Libraries
33be5db0 387Requires: beecrypt >= %{beecrypt_ver}
858aa7d0 388%{?with_db:Requires: db >= %{reqdb_ver}}
241257bf 389Requires: libmagic >= 1.15-2
d1795eb0 390%{?with_selinux:Requires: libselinux >= 1.18}
69131f1a 391Requires: popt >= %{reqpopt_ver}
d1795eb0 392Obsoletes: rpm-libs
69131f1a
JB
393# avoid SEGV caused by mixed db versions
394Conflicts: poldek < 0.18.1-16
395
396%description lib
397RPMs library.
398
dd85fadc 399%description lib -l pl.UTF-8
69131f1a
JB
400Biblioteki RPM-a.
401
fed73700 402%package devel
3f2d796a 403Summary: Header files for rpm libraries
4ea2ed33
ER
404Summary(de.UTF-8): Header-Dateien für rpm Libraries
405Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
406Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
407Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
408Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
409Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 410Group: Development/Libraries
153e5706 411Requires: %{name}-lib = %{version}-%{release}
87ef0d95 412Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 413Requires: bzip2-devel
858aa7d0 414%{?with_db:Requires: db-devel >= %{reqdb_ver}}
5c583f90 415Requires: elfutils-devel
f7100a40 416Requires: keyutils-devel
241257bf 417Requires: libmagic-devel
10abbd40 418%{?with_selinux:Requires: libselinux-devel}
a998ac11 419Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 420Requires: zlib-devel
cf6faebc 421
422%description devel
3f2d796a
JB
423The RPM packaging system includes C libraries that make it easy to
424manipulate RPM packages and databases. They are intended to ease the
cf6faebc 425creation of graphical package managers and other tools that need
3f2d796a
JB
426intimate knowledge of RPM packages. This package contains header files
427for these libraries.
fed73700 428
dd85fadc
JR
429%description devel -l de.UTF-8
430Der RPM-Packensystem enthält eine C-Library, die macht es einfach
431RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 432Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 433Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
434
dd85fadc 435%description devel -l es.UTF-8
313a4d1a 436El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
437fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
438facilitar la creación de administradores gráficos de paquetes y otras
20f89981 439herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 440
dd85fadc
JR
441%description devel -l pl.UTF-8
442System RPM zawiera biblioteki C, które ułatwiają manipulowanie
443pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
444graficznych programów zarządzających pakietami oraz innych narzędzi,
445które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
446zawiera pliki nagłówkowe wspomnianych bibliotek.
447
448%description devel -l pt_BR.UTF-8
449O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
450a manipulação de pacotes e bases de dados RPM. Seu objetivo é
451facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 452ferramentas que precisem de conhecimento profundo de pacotes RPM.
453
dd85fadc
JR
454%description devel -l ru.UTF-8
455Система управления пакетами RPM содержит библиотеку C, которая
456упрощает манипуляцию пакетами RPM и соответствующими базами данных.
457Эта библиотека предназначена для облегчения создания графических
458пакетных менеджеров и других утилит, которым необходимо работать с
459пакетами RPM.
7c6dc55f 460
dd85fadc
JR
461%description devel -l uk.UTF-8
462Система керування пакетами RPM містить бібліотеку C, котра спрощує
463роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
464призначена для полегшення створення графічних пакетних менеджерів та
465інших утиліт, що працюють з пакетами RPM.
7c6dc55f 466
fed73700 467%package static
9e42d68a 468Summary: RPM static libraries
4ea2ed33
ER
469Summary(de.UTF-8): RPMs statische Libraries
470Summary(pl.UTF-8): Biblioteki statyczne RPM-a
471Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
472Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
473Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 474Group: Development/Libraries
153e5706 475Requires: %{name}-devel = %{version}-%{release}
87ef0d95 476Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 477Requires: bzip2-static
858aa7d0 478%{?with_db:Requires: db-static >= %{reqdb_ver}}
ff03e01a 479Requires: elfutils-static
f7100a40 480Requires: keyutils-static
241257bf 481Requires: libmagic-static
a998ac11 482Requires: popt-static >= %{reqpopt_ver}
df76dbd9 483Requires: zlib-static
edacdf8f 484
485%description static
20f89981 486RPM static libraries.
fed73700 487
dd85fadc 488%description static -l de.UTF-8
20f89981 489RPMs statische Libraries.
9e42d68a 490
dd85fadc 491%description static -l pl.UTF-8
0a7ae9bc 492Biblioteki statyczne RPM-a.
313a4d1a 493
dd85fadc
JR
494%description static -l pt_BR.UTF-8
495Bibliotecas estáticas para desenvolvimento.
edacdf8f 496
dd85fadc
JR
497%description static -l ru.UTF-8
498Система управления пакетами RPM содержит библиотеку C, которая
499упрощает манипуляцию пакетами RPM и соответствующими базами данных.
500Это статическая библиотека RPM.
7c6dc55f 501
dd85fadc
JR
502%description static -l uk.UTF-8
503Система керування пакетами RPM містить бібліотеку C, котра спрощує
504роботу з пакетами RPM та відповідними базами даних. Це статична
505бібліотека RPM.
7c6dc55f 506
fed73700 507%package utils
8482995c 508Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
509Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
510Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 511Group: Applications/File
153e5706 512Requires: %{name} = %{version}-%{release}
a998ac11 513Requires: popt >= %{reqpopt_ver}
86b85368
AG
514%if %{with suggest_tags}
515Suggests: bzip2
516Suggests: gzip
86b85368 517%endif
695e60ad 518Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 519
520%description utils
8482995c 521Additional utilities for managing RPM packages and database.
fed73700 522
dd85fadc
JR
523%description utils -l de.UTF-8
524Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 525
dd85fadc
JR
526%description utils -l pl.UTF-8
527Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 528
92b3f576 529%package utils-perl
8482995c 530Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
531Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
532Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 533Group: Applications/File
153e5706 534Requires: %{name}-utils = %{version}-%{release}
92b3f576 535Requires: popt >= %{reqpopt_ver}
536
537%description utils-perl
8482995c 538Additional utilities for managing RPM packages and database.
92b3f576 539
dd85fadc
JR
540%description utils-perl -l de.UTF-8
541Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 542
dd85fadc
JR
543%description utils-perl -l pl.UTF-8
544Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 545
a00926bc
JB
546%package utils-static
547Summary: Static rpm utilities
4ea2ed33 548Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 549Group: Applications/System
153e5706 550Requires: %{name} = %{version}-%{release}
a00926bc
JB
551
552%description utils-static
553Static rpm utilities for repairing system in case something with
554shared libraries used by rpm become broken. Currently it contains rpmi
555binary, which can be used to install/upgrade/remove packages without
556using shared libraries (well, in fact with exception of NSS modules).
557
dd85fadc
JR
558%description utils-static -l pl.UTF-8
559Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
560związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
561Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
562uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
563(z wyjątkiem modułów NSS).
a00926bc 564
fed73700 565%package build
e191287c 566Summary: Scripts for building binary RPM packages
4ea2ed33
ER
567Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
568Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
569Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
570Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
571Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 572Group: Applications/File
8f76a271 573Requires(pre): findutils
8f3e4798 574Requires: %{name}-build-macros >= 1.653
153e5706 575Requires: %{name}-utils = %{version}-%{release}
e191287c 576Requires: /bin/id
577Requires: awk
cfa7898a 578Requires: bzip2
e950a6d7 579Requires: chrpath >= 0.10-4
b6547e10 580Requires: cpio
e191287c 581Requires: diffutils
195f647c 582Requires: elfutils
583135b4 583Requires: file >= 4.17
e191287c 584Requires: fileutils
585Requires: findutils
950eead3
ER
586%ifarch athlon
587Requires: gcc >= 3.0.3
588%else
589Requires: gcc
590%endif
e191287c 591Requires: glibc-devel
592Requires: grep
593Requires: gzip
594Requires: make
595Requires: patch
e191287c 596Requires: sed
597Requires: sh-utils
598Requires: tar
599Requires: textutils
ca3648b1 600Provides: rpmbuild(monoautodeps)
37ea389a 601Provides: rpmbuild(noauto) = 3
02d17bf9 602%ifarch %{x8664}
195f647c
JB
603Conflicts: automake < 1:1.7.9-2
604Conflicts: libtool < 2:1.5-13
605%endif
0096c5cd 606
e2025ad1 607%description build
58399c37 608Scripts for building binary RPM packages.
fed73700 609
dd85fadc
JR
610%description build -l de.UTF-8
611Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 612
dd85fadc
JR
613%description build -l pl.UTF-8
614Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 615
dd85fadc
JR
616%description build -l pt_BR.UTF-8
617Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 618construir pacotes usando o RPM.
e73478cd 619
dd85fadc
JR
620%description build -l ru.UTF-8
621Различные вспомогательные скрипты и исполняемые программы, которые
622используются для сборки RPM'ов.
7c6dc55f 623
dd85fadc
JR
624%description build -l uk.UTF-8
625Різноманітні допоміжні скрипти та утиліти, які використовуються для
626побудови RPM'ів.
7c6dc55f 627
8482995c
JB
628%package javaprov
629Summary: Additional utilities for checking Java provides/requires in RPM packages
630Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
631Group: Applications/File
632Requires: %{name} = %{version}-%{release}
633Requires: file
634Requires: findutils >= 1:4.2.26
635Requires: mktemp
636Requires: unzip
637
638%description javaprov
639Additional utilities for checking Java provides/requires in RPM
640packages.
641
642%description javaprov -l pl.UTF-8
643Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
644RPM.
645
69131f1a 646%package perlprov
8482995c 647Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 648Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 649Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
650Group: Applications/File
651Requires: %{name} = %{version}-%{release}
652Requires: perl-devel
653Requires: perl-modules
654
655%description perlprov
8482995c 656Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
657packages.
658
dd85fadc
JR
659%description perlprov -l de.UTF-8
660Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 661
dd85fadc 662%description perlprov -l pl.UTF-8
8482995c
JB
663Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
664pakietach RPM.
69131f1a
JB
665
666%package pythonprov
8482995c
JB
667Summary: Python macros, which simplifies creation of RPM packages with Python software
668Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
669Group: Applications/File
670Requires: %{name} = %{version}-%{release}
cd800b3c 671Requires: python
243c6264 672Requires: python-modules
bdbae303 673Requires: python-distribute
69131f1a
JB
674
675%description pythonprov
8482995c 676Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
677software.
678
dd85fadc 679%description pythonprov -l pl.UTF-8
8482995c 680Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
681Pythonie.
682
683%package php-pearprov
8482995c
JB
684Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
685Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
686Group: Applications/File
687Requires: %{name} = %{version}-%{release}
632f1b5c 688Requires: sed >= 4.0
69131f1a
JB
689
690%description php-pearprov
8482995c 691Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
692packages.
693
dd85fadc 694%description php-pearprov -l pl.UTF-8
8482995c
JB
695Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
696pakietach RPM.
69131f1a
JB
697
698%package -n python-rpm
699Summary: Python interface to RPM library
4ea2ed33
ER
700Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
701Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
702Group: Development/Languages/Python
703Requires: %{name} = %{version}-%{release}
704%pyrequires_eq python
705Obsoletes: rpm-python
706
707%description -n python-rpm
708The rpm-python package contains a module which permits applications
709written in the Python programming language to use the interface
710supplied by RPM (RPM Package Manager) libraries.
711
712This package should be installed if you want to develop Python
713programs that will manipulate RPM packages and databases.
714
dd85fadc
JR
715%description -n python-rpm -l pl.UTF-8
716Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
717Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 718
dd85fadc
JR
719Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
720Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 721
dd85fadc
JR
722%description -n python-rpm -l pt_BR.UTF-8
723O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
724escritas em Python utilizem a interface fornecida pelas bibliotecas
725RPM (RPM Package Manager).
726
dd85fadc 727Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
728Python para manipular pacotes e bancos de dados RPM.
729
5c2ab5c7
AM
730%package apidocs
731Summary: RPM API documentation and guides
732Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
733Group: Documentation
734
735%description apidocs
736Documentation for RPM API and guides in HTML format generated from rpm
737sources by doxygen.
738
739%description apidocs -l pl.UTF-8
740Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
741źrodeł RPM-a przez doxygen.
742
e2025ad1 743%prep
d38aed81 744%setup -q -n %{name}-%{version}%{?subver} -a100
317ef122 745#patch0 -p1
2f0ee4ec 746%patch1 -p1
4d5b8e4c 747%patch2 -p1
ece43ea2 748%patch3 -p1
7a3b1f24
AM
749%patch4 -p1
750%patch5 -p1
3c7590cc 751%patch6 -p1
c1768ce2 752%patch7 -p1
7a3b1f24 753%patch8 -p1
3c7590cc 754%{?with_system_lua:%patch9 -p1}
9ee75c3c 755%patch10 -p1
686b0204
JR
756%ifnarch i386 i486
757# enable TSC for capable archs
9ee75c3c 758%patch11 -p1
3c7590cc 759%endif
9ee75c3c
JR
760%patch12 -p1
761%patch13 -p1
762%patch14 -p0
3c7590cc 763%patch15 -p1
9ee75c3c 764%patch16 -p1
3c7590cc
JR
765%patch17 -p1
766%patch18 -p1
767%patch19 -p1
768%patch20 -p1
769%patch21 -p1
9ee75c3c 770%ifarch sparc64
3c7590cc 771%patch22 -p1
9ee75c3c 772%endif
3c7590cc 773%patch23 -p1
3c7590cc 774%patch24 -p1
3c7590cc 775%patch25 -p1
9ee75c3c 776%patch26 -p1
24123ddd 777%patch27 -p1
3c7590cc
JR
778%patch28 -p1
779%patch29 -p1
780%patch30 -p1
781%patch31 -p1
782%patch32 -p1
783%patch33 -p1
950eead3 784%patch34 -p1
3c7590cc 785%patch35 -p1
148c9957 786%patch36 -p1
3c7590cc
JR
787%patch37 -p1
788%patch38 -p1
789%patch39 -p1
790%patch40 -p1
9282ffe4 791%patch41 -p1
9ee75c3c 792%patch42 -p1
9f9190ed 793%patch43 -p1
1d20bd4e 794%patch44 -p1
e94735a5 795%patch45 -p1
7070b427 796%patch46 -p1
765b7c41 797
70f8787d
JR
798%patch1000 -p1
799%patch1001 -p1
800%patch1002 -p1
801%patch1003 -p1
802%patch1004 -p1
803%patch1005 -p1
804%patch1006 -p1
805%patch1007 -p1
806%patch1008 -p1
807%patch1009 -p1
808%patch1010 -p1
809%patch1011 -p1
810%patch1012 -p1
811%patch1013 -p1
812%patch1014 -p1
813%patch1015 -p1
814%patch1016 -p1
815%patch1017 -p1
816%patch1018 -p1
817%patch1019 -p1
818%patch1020 -p1
819%patch1021 -p1
820%patch1022 -p1
821%patch1023 -p1
822%patch1024 -p1
823%patch1025 -p1
824%patch1026 -p1
825%patch1027 -p1
826%patch1028 -p1
827%patch1029 -p1
828%patch1030 -p1
829%patch1031 -p1
830%patch1032 -p1
831%patch1033 -p1
832%patch1034 -p1
833%patch1035 -p1
834%patch1036 -p1
835%patch1037 -p1
836%patch1038 -p1
9f9190ed 837%patch1039 -p1
70f8787d
JR
838
839install %{SOURCE2} macros/pld.in
0bf34f68
JR
840install %{SOURCE8} scripts/php.prov.in
841install %{SOURCE9} scripts/php.req.in
842install %{SOURCE11} scripts/perl.prov.in
08697680 843
70f8787d 844%{__mv} -f scripts/perl.req{,.in}
633d1e9e 845
cd86db2e 846# generate Group translations to *.po
80b8a1f9 847awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 848
87ef0d95 849%build
ea816ea6 850%{__libtoolize}
c0a9be8f 851#%{__autopoint}
ceaaacee 852%{__aclocal}
4cd84746 853%{__autoheader}
7a9d72ce 854%{__autoconf}
7a9d72ce 855%{__automake}
7a9d72ce 856
048d06f8
JR
857# rpm checks for CPU type at runtime, but it looks better
858sed -i \
859 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
860 -e 's|@host_cpu@|%{_target_cpu}|' \
861 -e 's|@host_os@|%{_target_os}|' \
3f84726d 862 macros/macros.in
048d06f8 863
d268a169 864%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 865# pass CC and CXX too in case of building with some older configure macro
624f96ff 866%configure \
f9ac32aa
AM
867 CC="%{__newcc}" \
868 CXX="%{__newcxx}" \
869 CPP="%{__newcpp}" \
01d7a578 870 WITH_PERL_VERSION=no \
cd86db2e 871 --enable-shared \
874f4c9a 872 --enable-static \
5c2ab5c7 873 %{!?with_apidocs:--without-apidocs} \
f3cb8244 874 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
a6e56ce4 875 %{!?with_python:--without-python} \
241257bf
AM
876 --with%{!?with_selinux:out}-selinux \
877 --with-libelf \
878 --with-zlib=external \
879 --with-bzip2=external \
880 --with-beecrypt=external \
1afa05ce 881 --with-lzma=external \
77fcdbf7 882 --with-xz=external \
241257bf
AM
883 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
884 --with-file=external \
885 --with-popt=external \
afb55538 886 --with-db=%{?with_db:external}%{!?with_db:no} \
77fcdbf7 887 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
950eead3 888 --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
6a8612bc 889 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
77fcdbf7 890 --with-pcre=external \
241257bf 891 --with-keyutils=none \
127a0b3c 892 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
241257bf 893 --without-path-versioned \
044171ea 894 --with-extra-path-macros='%{_sysconfdir}/rpm/macros.d/*.macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:~/etc/.rpmmacros:~/.rpmmacros' \
08697680
JR
895 --with-bugreport="http://bugs.pld-linux.org/" \
896 --with-vendor=pld
cf6faebc 897
25e974c7 898%{__make} -j1 \
f9ac32aa
AM
899 CC="%{__cc}" \
900 CXX="%{__cxx}" \
241257bf 901 CPP="%{__cpp}"
33be5db0 902
5c2ab5c7
AM
903%{?with_apidocs:%{__make} apidocs}
904
b064b8e6 905%install
ff7bc1e6 906rm -rf $RPM_BUILD_ROOT
e9eb00af 907install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 908 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 909
0bf34f68 910install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 911
a5e7fb84 912%{__make} install \
241257bf
AM
913 pkgconfigdir=%{_pkgconfigdir} \
914 DESTDIR=$RPM_BUILD_ROOT
718426e1 915
25ac75ae
AM
916# install ARCH macros
917install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
d38aed81 918install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
25ac75ae
AM
919
920%ifarch %{ix86}
921install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
d38aed81
JR
922install cpu-os-macros/athlon-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
923install cpu-os-macros/i386-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
924install cpu-os-macros/i486-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
925install cpu-os-macros/i586-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
926install cpu-os-macros/i686-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
927install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
928install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
929%endif
930
931%ifarch %{x8664}
932install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
d38aed81
JR
933install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
934install cpu-os-macros/ia32e-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
935install cpu-os-macros/amd64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
25ac75ae
AM
936%endif
937
938%ifarch %{ppc}
939install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
d38aed81 940install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
941%endif
942
2eb9303e 943cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 944# first platform file entry can't contain regexps
2eb9303e 945%{_target_cpu}-%{_target_vendor}-linux
caf453d4 946
2d8ae03e
AM
947# x86_64 things
948%ifarch x86_64
53fd58bc 949x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 950amd64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 951%endif
2d8ae03e 952%ifarch amd64
53fd58bc
AM
953amd64-[^-]*-[Ll]inux(-gnu)?
954x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 955%endif
2d8ae03e 956%ifarch ia32e
53fd58bc
AM
957ia32e-[^-]*-[Ll]inux(-gnu)?
958x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
959%endif
960
961# x86 things
06bd38df 962%ifarch athlon %{x8664}
53fd58bc 963athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 964%endif
06bd38df 965%ifarch pentium4 athlon %{x8664}
53fd58bc 966pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 967%endif
06bd38df 968%ifarch pentium3 pentium4 athlon %{x8664}
53fd58bc 969pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 970%endif
06bd38df 971%ifarch i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 972i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 973%endif
06bd38df 974%ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 975i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 976%endif
06bd38df 977%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 978i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 979%endif
06bd38df 980%ifarch %{ix86} %{x8664}
53fd58bc 981i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
982%endif
983
5074eba9 984%ifarch alpha
53fd58bc 985alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
986%endif
987
988%ifarch ia64
53fd58bc 989ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
990%endif
991
992%ifarch ppc64
53fd58bc
AM
993powerpc64-[^-]*-[Ll]inux(-gnu)?
994ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 995%endif
950eead3 996%ifarch %{ppc} ppc64
53fd58bc
AM
997powerpc-[^-]*-[Ll]inux(-gnu)?
998ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
999%endif
1000
1001%ifarch s390x
53fd58bc 1002s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1003%endif
1004%ifarch s390 s390x
53fd58bc 1005s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1006%endif
1007
1008%ifarch sparc64
53fd58bc
AM
1009sparc64-[^-]*-[Ll]inux(-gnu)?
1010sparcv8-[^-]*-[Ll]inux(-gnu)?
1011sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1012%endif
1013%ifarch sparcv9
53fd58bc
AM
1014sparcv8-[^-]*-[Ll]inux(-gnu)?
1015sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1016%endif
1017%ifarch sparc sparcv9 sparc64
53fd58bc 1018sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1019%endif
1020
1021# noarch
2eb9303e
ER
1022noarch-[^-]*-.*
1023EOF
2d8ae03e 1024
02919de5
JK
1025rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1026rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1027rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
950eead3 1028rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
02919de5 1029
644d8958
JB
1030# not installed since 4.4.8 (-tools-perl subpackage)
1031install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1032
61f7e1b3 1033install %{SOURCE1} doc/manual/groups
d755a548 1034install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1035install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1036install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
1037install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1038install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548
JK
1039install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
1040install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
1041cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1042install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1043install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 1044install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1045
0bf34f68 1046install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1047
950eead3
ER
1048install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1049
0bf34f68
JR
1050install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1051install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1052install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1053install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1054install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1055install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep
1056install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 1057
950eead3
ER
1058touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1059touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 1060install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
1061touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1062touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1063touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1064
9776a251
JR
1065# create macro loading wrappers for backward compatibility
1066for m in gstreamer java mono perl php python; do
b279f099 1067 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
1068done
1069
f3fd387a 1070# for rpm -e|-U --repackage
a11e0e27
AM
1071install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1072touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1073
950eead3
ER
1074# move rpm to /bin
1075mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1076# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1077for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1078 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1079 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1080done
1081
950eead3
ER
1082# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1083mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1084
6f18cdb7
AF
1085%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1086%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1087
08697680 1088%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
01d7a578 1089
01d7a578 1090# wrong location, not used anyway
08697680 1091%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
950eead3 1092# utils dropped in 4.4.8 -- their manuals
08697680 1093%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
e86bfbff 1094# utils dropped in 5.4 -- their manuals
854562c1 1095%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1096# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1097%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1098
90b03dd6 1099%find_lang %{name}
cf6faebc 1100
08697680 1101%{__rm} -rf manual
a998ac11 1102cp -a doc/manual manual
08697680 1103%{__rm} -f manual/Makefile*
874f4c9a 1104
13eb5ebf 1105%clean
d7df46b8 1106rm -rf $RPM_BUILD_ROOT
76214164 1107
cc1a4992
ER
1108%pretrans
1109# this needs to be a dir
1110if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1111 umask 022
cc1a4992
ER
1112 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1113 mkdir %{_sysconfdir}/rpm/sysinfo
1114fi
1115
be4d3036
JR
1116%posttrans
1117if [ -e /var/lib/rpm/__convert_needed ]; then
1118 %{_rpmlibdir}/bin/dbconvert --rebuilddb
1119 %{__rm} -f /var/lib/rpm/__convert_needed
1120fi
1121
1122%triggerpostun -- %{name} < 5.4.0-1
1123:>/var/lib/rpm/__convert_needed
1124
cf709a39
ER
1125%triggerpostun -- %{name} < 4.4.9-44
1126%{_rpmlibdir}/hrmib-cache
1127
ceaaacee
JB
1128%post lib -p /sbin/ldconfig
1129%postun lib -p /sbin/ldconfig
76214164 1130
37a5a2fc 1131%pretrans build
d755a548 1132find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1133
3684d90f
JB
1134%files -f %{name}.lang
1135%defattr(644,root,root,755)
241257bf 1136%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1137
54eb1770
AM
1138%dir %{_sysconfdir}/pki/rpm-gpg
1139%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1140
7a9d72ce 1141%attr(755,root,root) /bin/rpm
e73478cd 1142
66edd895 1143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
950eead3 1144%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1145# these are ok to be replaced
950eead3 1146%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1147%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1148
09bb810c 1149%{_mandir}/man8/rpm.8*
feb1f12e 1150%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1151%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 1152%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 1153%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1154%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1155%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1156
e2025ad1 1157%dir /var/lib/rpm
74a997bd
JR
1158%dir /var/lib/rpm/log
1159%dir /var/lib/rpm/tmp
1160%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1161%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1162%dir /var/lock/rpm
1163/var/lock/rpm/transaction
4acac5de 1164
cf709a39
ER
1165# exported package NVRA (stamped with install tid)
1166# net-snmp hrSWInstalledName queries, bash-completions
1167%dir /var/cache/hrmib
1168
ec44785a 1169%{_rpmlibdir}/qf
d755a548
JK
1170%{_rpmlibdir}/rpmpopt*
1171%{_rpmlibdir}/macros
08697680
JR
1172%dir %{_rpmlibdir}/macros.d
1173%{_rpmlibdir}/macros.d/pld
9282ffe4 1174%{_rpmlibdir}/cpuinfo.yaml
3684d90f 1175
cf709a39
ER
1176%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1177
df50421f
JR
1178%dir %{_rpmlibdir}/bin
1179%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1180
66edd895
JB
1181%files base
1182%defattr(644,root,root,755)
492a2bd4 1183%dir %{_sysconfdir}/rpm
66edd895
JB
1184%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1185%dir %{_rpmlibdir}
1186%attr(755,root,root) %{_bindir}/banner.sh
df50421f 1187%attr(755,root,root) %{_bindir}/multiarch-dispatch
66edd895
JB
1188%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1189%dir /var/lib/banner
1190
874f4c9a
MM
1191%files lib
1192%defattr(644,root,root,755)
950eead3
ER
1193%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1194%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1195%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1196%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1197%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1198%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1199
69131f1a
JB
1200%files devel
1201%defattr(644,root,root,755)
69131f1a
JB
1202%attr(755,root,root) %{_libdir}/librpm.so
1203%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1204%attr(755,root,root) %{_libdir}/librpmbuild.so
1205%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1206%attr(755,root,root) %{_libdir}/librpmconstant.so
1207%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1208%attr(755,root,root) %{_libdir}/librpmdb.so
1209%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1210%attr(755,root,root) %{_libdir}/librpmio.so
1211%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1212%attr(755,root,root) %{_libdir}/librpmmisc.so
1213%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1214%{_libdir}/librpm*.la
1215%{_includedir}/rpm
df50421f 1216%{_includedir}/multiarch-dispatch.h
950eead3 1217%{_pkgconfigdir}/*.pc
69131f1a
JB
1218
1219%files static
1220%defattr(644,root,root,755)
1221%{_libdir}/librpm*.a
1222
1223%files utils
1224%defattr(644,root,root,755)
69131f1a 1225%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1226%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1227%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1228%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1229%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1230%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1231%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1232%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1233%attr(755,root,root) %{_rpmlibdir}/bin/find
1234%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1235%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1236%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1237%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1238%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1239%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1240%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey
1241%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1242%{_mandir}/man8/rpm2cpio.8*
950eead3 1243%{_mandir}/man8/rpmcache.8*
ec44785a 1244%{_mandir}/man8/rpmconstant.8*
69131f1a 1245%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1246%{_mandir}/man8/rpmmtree.8*
69131f1a 1247%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
950eead3 1248%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
69131f1a
JB
1249%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1250%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
950eead3 1251%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
69131f1a 1252%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1253%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1254
1255%files utils-perl
1256%defattr(644,root,root,755)
1257%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1258
1259%if %{with static}
1260%files utils-static
1261%defattr(644,root,root,755)
1262%attr(755,root,root) %{_bindir}/rpm[ieu]
1263%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1264%endif
1265
3684d90f 1266%files build
a45ae6d8 1267%defattr(644,root,root,755)
66edd895 1268%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1269%attr(755,root,root) %{_rpmlibdir}/brp-*
1270%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1271%attr(755,root,root) %{_rpmlibdir}/compress-doc
1272%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1273%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1274%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1275%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1276%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1277%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1278%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1279%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1280# needs hacked pkg-config to return anything
1281%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1282%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1283%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
77fcdbf7
AF
1284%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1285%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f
JR
1286%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1287%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1288%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1289%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1290%attr(755,root,root) %{_rpmlibdir}/vcheck
d755a548 1291%{_rpmlibdir}/noarch-*
e9fe9fc5 1292%ifarch %{ix86}
d755a548 1293%{_rpmlibdir}/i?86*
e9fe9fc5 1294%{_rpmlibdir}/pentium*
d755a548
JK
1295%{_rpmlibdir}/athlon*
1296%endif
ad628734
JB
1297%ifarch alpha
1298%{_rpmlibdir}/alpha*
1299%endif
ad628734
JB
1300%ifarch ia64
1301%{_rpmlibdir}/ia64*
8f76a271 1302%endif
410dd742 1303%ifarch mips mipsel mips64 mips64el
1304%{_rpmlibdir}/mips*
1305%endif
80e9f34d 1306%ifarch %{ppc}
410dd742 1307%{_rpmlibdir}/ppc*
1308%endif
1309%ifarch sparc sparc64
1310%{_rpmlibdir}/sparc*
1311%endif
9f517079 1312%ifarch %{x8664}
206b32be
JB
1313%{_rpmlibdir}/amd64*
1314%{_rpmlibdir}/ia32e*
cedf1bfa
PS
1315%{_rpmlibdir}/x86_64*
1316%endif
410dd742 1317# not used yet ... these six depend on perl
ec44785a 1318%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1319# we always used scripts provided by mono-devel, maybe move them here
1320#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1321#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1322
70f8787d 1323%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1324# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1325%{_rpmlibdir}/macros.d/cmake
1326%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7 1327%{_rpmlibdir}/macros.d/java
df50421f 1328%{_rpmlibdir}/macros.d/kernel
77fcdbf7
AF
1329%{_rpmlibdir}/macros.d/libtool
1330%{_rpmlibdir}/macros.d/mono
1331%{_rpmlibdir}/macros.d/perl
1332%{_rpmlibdir}/macros.d/php
1333%{_rpmlibdir}/macros.d/pkgconfig
1334%{_rpmlibdir}/macros.d/python
df50421f 1335%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1336%{_rpmlibdir}/macros.d/selinux
df50421f 1337%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1338%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1339# compat wrappers
1340%{_rpmlibdir}/macros.gstreamer
1341%{_rpmlibdir}/macros.java
1342%{_rpmlibdir}/macros.mono
1343%{_rpmlibdir}/macros.perl
1344%{_rpmlibdir}/macros.php
1345%{_rpmlibdir}/macros.python
77fcdbf7 1346
df50421f
JR
1347%attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
1348%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1349%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1350%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1351%attr(755,root,root) %{_rpmlibdir}/mkmultiarch
df50421f
JR
1352%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1353
874f4c9a 1354%attr(755,root,root) %{_bindir}/gendiff
df50421f 1355%attr(755,root,root) %{_bindir}/multiarch-platform
874f4c9a 1356%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1357
1358%dir %{_rpmlibdir}/helpers
1359%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1360
a00926bc 1361%{_mandir}/man1/gendiff.1*
874f4c9a 1362%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1363%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1364%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1365%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1366
7d8492bb
JB
1367%files javaprov
1368%defattr(644,root,root,755)
1369%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1370# needs jar (any jdk), jcf-dump (gcc-java) to work
1371%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1372
89334051
AF
1373%files perlprov
1374%defattr(644,root,root,755)
d755a548 1375%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1376%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1377%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1378
80d3b868 1379%files pythonprov
d8fcb9b0 1380%defattr(644,root,root,755)
bdbae303 1381%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1382%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1383
d36cb682
PG
1384%files php-pearprov
1385%defattr(644,root,root,755)
d755a548
JK
1386%attr(755,root,root) %{_rpmlibdir}/php*
1387%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1388
50dc9ac0 1389%if %{with python}
cf6faebc 1390%files -n python-rpm
42a0025c 1391%defattr(644,root,root,755)
b33910fe 1392%dir %{py_sitedir}/rpm
6f18cdb7 1393%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1394%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1395%endif
5c2ab5c7
AM
1396
1397%if %{with apidocs}
1398%files apidocs
1399%defattr(644,root,root,755)
1400%doc apidocs
1401%endif
This page took 1.05354 seconds and 4 git commands to generate.