]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- conflict for automake and libtool versions without amd64 support in rpm-build for...
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
3# - learn find-perl-provides to use the __perl macro instead
4# of /usr/bin/perl
630203f1 5# NOTE: there is no find-perl* now, only perl.{prov,req}
87ef0d95 6# - use system libmagic not internal libfmagic
52c10eff 7#
89427592 8# Conditional build:
50dc9ac0
JK
9%bcond_without static # - build shared /bin/rpm (doesn't work at the moment)
10%bcond_without docs # - don't generate documentation with doxygen
11%bcond_without python # - don't build python bindings
89427592
JB
12# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
13# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
14# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
54bfdf99
JK
15
16%include /usr/%{_lib}/rpm/macros.python
92bb4c97 17%define snap 20030610
003a039e 18# versions of required libraries
d6d0bf8f 19%define reqdb_ver 4.2.50-1
87ef0d95 20%define reqpopt_ver 1.9
d865fcbb 21%define beecrypt_ver 3.0.0-0.20030610.1
38585a7e 22%define rpm_macros_rev 1.133
e5f02e49
AM
23Summary: RPM Package Manager
24Summary(de): RPM Packet-Manager
313a4d1a 25Summary(es): Gestor de paquetes RPM
609cc585 26