]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- up to 4.16.0
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
e8836e1f 3# - rebuild database after upgrading from rpm5
c296fee0 4# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 5#
89427592 6# Conditional build:
0a1ccab0 7%bcond_without apidocs # don't generate documentation with doxygen
24b1f498 8%bcond_with python2 # don't build python bindings
f9d0e5f6 9%bcond_without python3 # don't build python bindings
b0333243 10%bcond_without plugins # build plugins
af0cc499 11%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
858aa7d0 12
6f068494
JR
13%define db_ver 5.3.28.0
14%define popt_ver 1.15
fb35e2d9 15%define openssl_ver 1.1.1d
24b1f498 16%define sover 9.1.0
fc60c9f3 17
e5f02e49 18Summary: RPM Package Manager
4ea2ed33
ER
19Summary(de.UTF-8): RPM Packet-Manager
20Summary(es.UTF-8): Gestor de paquetes RPM
21Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
22Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
23Summary(ru.UTF-8): Менеджер пакетов от RPM
24Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 25Name: rpm
24b1f498 26Version: 4.16.0
98d9fc8e 27Release: 0.1
9fe07969 28Epoch: 1
98d9fc8e 29License: GPL v2 / LGPL v2.1
76214164 30Group: Base
24b1f498
JR
31Source0: http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
32# Source0-md5: 434e166a812e35ef181f6dd176326920
faba01eb
JR
33Source1: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
34# Source1-md5: 23914bb49fafe7153cee87126d966461
35Source2: macros.local
36Source3: macros.lang
37Source4: %{name}.sysconfig
38Source5: %{name}.groups
80b8a1f9 39Source6: %{name}-groups-po.awk
faba01eb
JR
40Source7: %{name}-install-tree
41Source8: %{name}-hrmib-cache
42Source9: %{name}-user_group.sh
a4b7ef27 43# http://svn.pld-linux.org/banner.sh/
faba01eb
JR
44Source10: banner.sh
45Source11: %{name}.noautocompressdoc
46Source12: %{name}.noautoprov
47Source13: %{name}.noautoprovfiles
48Source14: %{name}.noautoreq
49Source15: %{name}.noautoreqfiles
50Source16: perl.prov
51Source17: %{name}db_checkversion.c
52Source18: %{name}db_reset.c
53Source19: dbupgrade.sh
af0cc499
JR
54Patch0: %{name}-man_pl.patch
55Patch1: %{name}-popt-aliases.patch
56Patch2: %{name}-perl-macros.patch
57Patch3: %{name}-perl-req-perlfile.patch
58Patch4: %{name}-scripts-closefds.patch
cbab0cbf
JR
59Patch5: %{name}-lua.patch
60Patch6: %{name}-perl_req-INC_dirs.patch
61Patch7: %{name}-debuginfo.patch
62Patch8: %{name}-libtool-deps.patch
63Patch9: %{name}-builddir-readlink.patch
64Patch10: %{name}-changelog_order_check_nonfatal.patch
65Patch11: %{name}-postun-nofail.patch
66Patch12: %{name}-clean-docdir.patch
67Patch13: %{name}-perl-magic.patch
68Patch14: %{name}-ignore-missing-macro-files.patch
69Patch15: x32.patch
70Patch16: %{name}-add-compress-doc.patch
71Patch17: rpm5-db-compat.patch
72Patch18: python-internal-build.patch
681ee2f6 73URL: https://rpm.org/
6f068494 74BuildRequires: db-devel >= %{db_ver}
29855fc2 75BuildRequires: autoconf >= 2.63
644d8958 76BuildRequires: automake >= 1.4
33be5db0 77BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 78BuildRequires: elfutils-devel >= 0.108
3e70c06e 79BuildRequires: gettext-tools >= 0.19.2
af0cc499 80BuildRequires: libarchive-devel
241257bf 81BuildRequires: libmagic-devel
d1f5e279 82BuildRequires: openssl-devel >= %{openssl_ver}
b0333243
JR
83%if %{with plugins}
84BuildRequires: audit-libs-devel
85BuildRequires: dbus-devel
6e115b23 86BuildRequires: libselinux-devel >= 2.1.0
6e115b23 87%endif
84cdee7a
JB
88# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
89BuildRequires: libstdc++-devel
b60c74c3 90BuildRequires: libtool >= 1:1.4.2-9
5c767dc1 91BuildRequires: lua53-devel >= 5.3.5
127a0b3c 92BuildRequires: ossp-uuid-devel
7973b351 93BuildRequires: patch >= 2.2
6f068494 94BuildRequires: popt-devel >= %{popt_ver}
f9d0e5f6 95%{?with_python2:BuildRequires: python-devel >= 1:2.3}
950eead3 96BuildRequires: python-modules >= 1:2.3
24b1f498 97%{?with_python3:BuildRequires: python3-devel}
f9d0e5f6
JR
98%if %{with python2} || %{with python3}
99BuildRequires: rpm-pythonprov
100%endif
e56a10a9 101BuildRequires: tcl
77fcdbf7 102BuildRequires: xz-devel
3acb62f3 103BuildRequires: zlib-devel
34865f27 104BuildRequires: zstd-devel
5c2ab5c7
AM
105%if %{with apidocs}
106BuildRequires: doxygen
107BuildRequires: ghostscript
108BuildRequires: graphviz
109BuildRequires: tetex-pdftex
110%endif
d25ec6ea 111Requires(posttrans): coreutils
9fe07969
JR
112Requires: %{name}-base = %{epoch}:%{version}-%{release}
113Requires: %{name}-lib = %{epoch}:%{version}-%{release}
3de8e4a9 114Requires: rpm-pld-macros >= 1.744
d1f5e279 115Requires: FHS >= 3.0-2
fb35e2d9 116Requires: openssl >= %{openssl_ver}
6f068494 117Requires: popt >= %{popt_ver}
b0333243
JR
118%if %{with recommends_tags}
119Recommends: rpm-plugin-audit
120Recommends: rpm-plugin-prioreset
121Recommends: rpm-plugin-syslog
122Recommends: rpm-plugin-systemd-inhibit
123%endif
0229a8b9 124Obsoletes: rpm-getdeps
d1f5e279 125Obsoletes: rpm-utils-perl
f57f030d 126Obsoletes: rpm-utils-static
874f4c9a 127Conflicts: glibc < 2.2.92
8ee1c72c
AM
128# db4.6 poldek needed
129Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
130# segfaults with lzma 0.42.2
131Conflicts: lzma-libs < 4.999.3
e4084afd 132Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 133BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 134
4adb7d05 135%define _binary_payload w9.gzdio
6d82b332 136
4cd84746 137# don't require very fresh rpm.macros to build
950eead3 138%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 139%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 140%define ppc ppc ppc7400 ppc7450
9f517079 141%define x8664 amd64 ia32e x86_64
4cd84746 142
d755a548 143%define _rpmlibdir /usr/lib/rpm
950eead3 144%define _noautocompressdoc RPM-GPG-KEY
d755a548 145
ff7bc1e6 146%description
147RPM is a powerful package manager, which can be used to build,
148install, query, verify, update, and uninstall individual software
cf6faebc 149packages. A package consists of an archive of files, and package
fed73700 150information, including name, version, and description.
151
dd85fadc
JR
152%description -l de.UTF-8
153RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 154Installation, Anfrage, Verifizierung, Aktualisierung und
155Uninstallation individueller Softwarepakete. Ein Paket besteht aus
156einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 157Beschreibung.
158
dd85fadc 159%description -l es.UTF-8
313a4d1a 160RPM es un poderoso administrador de paquetes, que puede ser usado para
161construir, instalar, pesquisar, verificar, actualizar y desinstalar
162paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
163almacenaje de archivos, y información sobre el paquete, incluyendo
164nombre, versión y descripción.
165
166%description -l pl.UTF-8
167RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
168przebudowanie, instalację czy weryfikację dowolnego pakietu.
169Informacje dotyczące każdego pakietu, takie jak jego opis, lista
170plików wchodzących w skład pakietu, zależności od innych pakietów, są
171przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 172odpytywania programu rpm.
173
dd85fadc
JR
174%description -l pt_BR.UTF-8
175RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 176construir, instalar, pesquisar, verificar, atualizar e desinstalar
177pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
178arquivos e informações adicionais, incluindo nome, versão e descrição
179do pacote, permissões dos arquivos, etc.
180
181%description -l ru.UTF-8
182RPM - это мощный менеджер пакетов, который может быть использован для
183создания, инсталляции, запросов (query), проверки, обновления и
184удаления программных пакетов. Пакет состоит из файлового архива и
185служебной информации, включающей название, версию, описание и другие
186данные о пакете.
187
188%description -l uk.UTF-8
189RPM - це потужний менеджер пакетів, що може бути використаний для
190створення, інсталяції, запитів (query), перевірки, поновлення та
191видалення програмних пакетів. Пакет складається з файлового архіву та
192службової інформації, що містить назву, версію, опис та іншу
193інформацію про пакет.
7c6dc55f 194
66edd895
JB
195%package base
196Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 197Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 198Group: Base
1d9ca0c1 199Requires: filesystem
950eead3 200Obsoletes: rpm-scripts
66edd895
JB
201Obsoletes: vserver-rpm
202
203%description base
204The RPM base package contains scripts used by rpm packages themselves.
205These include:
206- scripts for adding/removing groups and users needed for rpm
207 packages,
208- banner.sh to display %%banner messages from rpm scriptlets.
209
dd85fadc
JR
210%description base -l pl.UTF-8
211Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 212Zawiera on:
dd85fadc
JR
213- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
214- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 215
69131f1a
JB
216%package lib
217Summary: RPMs library
4ea2ed33 218Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 219Group: Libraries
6f068494 220Requires: db >= %{db_ver}
241257bf 221Requires: libmagic >= 1.15-2
d1f5e279 222Requires: openssl >= %{openssl_ver}
6f068494 223Requires: popt >= %{popt_ver}
d1795eb0 224Obsoletes: rpm-libs
69131f1a
JB
225# avoid SEGV caused by mixed db versions
226Conflicts: poldek < 0.18.1-16
227
228%description lib
229RPMs library.
230
dd85fadc 231%description lib -l pl.UTF-8
69131f1a
JB
232Biblioteki RPM-a.
233
fed73700 234%package devel
3f2d796a 235Summary: Header files for rpm libraries
4ea2ed33
ER
236Summary(de.UTF-8): Header-Dateien für rpm Libraries
237Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
238Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
239Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
240Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
241Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 242Group: Development/Libraries
9fe07969 243Requires: %{name}-lib = %{epoch}:%{version}-%{release}
fea3cb89 244Requires: bzip2-devel
24b1f498 245Requires: db-devel >= %{db_ver}
5c583f90 246Requires: elfutils-devel
241257bf 247Requires: libmagic-devel
d1f5e279 248Requires: openssl-devel >= %{openssl_ver}
c7b2d5f9
KK
249%if %{with selinux}
250Requires: libselinux-devel
251Requires: libsemanage-devel
252Requires: libsepol-devel
253%endif
6f068494 254Requires: popt-devel >= %{popt_ver}
fea3cb89 255Requires: zlib-devel
cf6faebc 256
257%description devel
3f2d796a
JB
258The RPM packaging system includes C libraries that make it easy to
259manipulate RPM packages and databases. They are intended to ease the
cf6faebc 260creation of graphical package managers and other tools that need
3f2d796a
JB
261intimate knowledge of RPM packages. This package contains header files
262for these libraries.
fed73700 263
dd85fadc
JR
264%description devel -l de.UTF-8
265Der RPM-Packensystem enthält eine C-Library, die macht es einfach
266RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 267Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 268Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
269
dd85fadc 270%description devel -l es.UTF-8
313a4d1a 271El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
272fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
273facilitar la creación de administradores gráficos de paquetes y otras
20f89981 274herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 275
dd85fadc
JR
276%description devel -l pl.UTF-8
277System RPM zawiera biblioteki C, które ułatwiają manipulowanie
278pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
279graficznych programów zarządzających pakietami oraz innych narzędzi,
280które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
281zawiera pliki nagłówkowe wspomnianych bibliotek.
282
283%description devel -l pt_BR.UTF-8
284O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
285a manipulação de pacotes e bases de dados RPM. Seu objetivo é
286facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 287ferramentas que precisem de conhecimento profundo de pacotes RPM.
288
dd85fadc
JR
289%description devel -l ru.UTF-8
290Система управления пакетами RPM содержит библиотеку C, которая
291упрощает манипуляцию пакетами RPM и соответствующими базами данных.
292Эта библиотека предназначена для облегчения создания графических
293пакетных менеджеров и других утилит, которым необходимо работать с
294пакетами RPM.
7c6dc55f 295
dd85fadc
JR
296%description devel -l uk.UTF-8
297Система керування пакетами RPM містить бібліотеку C, котра спрощує
298роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
299призначена для полегшення створення графічних пакетних менеджерів та
300інших утиліт, що працюють з пакетами RPM.
7c6dc55f 301
fed73700 302%package utils
8482995c 303Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
304Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
305Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 306Group: Applications/File
9fe07969 307Requires: %{name} = %{epoch}:%{version}-%{release}
6f068494 308Requires: popt >= %{popt_ver}
af0cc499
JR
309%if %{with recommends_tags}
310Recommends: bzip2
311Recommends: gzip
86b85368 312%endif
695e60ad 313Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 314
315%description utils
8482995c 316Additional utilities for managing RPM packages and database.
fed73700 317
dd85fadc
JR
318%description utils -l de.UTF-8
319Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 320
dd85fadc
JR
321%description utils -l pl.UTF-8
322Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 323
fed73700 324%package build
e191287c 325Summary: Scripts for building binary RPM packages
4ea2ed33
ER
326Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
327Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
328Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
329Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
330Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 331Group: Applications/File
f15ca8ca
ER
332Requires(pretrans): coreutils
333Requires(pretrans): findutils
9fe07969 334Requires: %{name}-utils = %{epoch}:%{version}-%{release}
3de8e4a9 335Requires: rpm-pld-macros-build >= 1.744
e191287c 336Requires: /bin/id
337Requires: awk
cfa7898a 338Requires: bzip2
e950a6d7 339Requires: chrpath >= 0.10-4
b6547e10 340Requires: cpio
e191287c 341Requires: diffutils
195f647c 342Requires: elfutils
583135b4 343Requires: file >= 4.17
e191287c 344Requires: fileutils
345Requires: findutils
950eead3
ER
346%ifarch athlon
347Requires: gcc >= 3.0.3
348%else
349Requires: gcc
350%endif
e191287c 351Requires: glibc-devel
352Requires: grep
353Requires: gzip
354Requires: make
355Requires: patch
adbd4815 356Requires: sed >= 4.0
e191287c 357Requires: sh-utils
adbd4815 358Requires: tar >= 1:1.22
e191287c 359Requires: textutils
3acb62f3 360Requires: which
adbd4815 361Requires: xz
37ea389a 362Provides: rpmbuild(noauto) = 3
02d17bf9 363%ifarch %{x8664}
195f647c
JB
364Conflicts: automake < 1:1.7.9-2
365Conflicts: libtool < 2:1.5-13
366%endif
0096c5cd 367
e2025ad1 368%description build
58399c37 369Scripts for building binary RPM packages.
fed73700 370
dd85fadc
JR
371%description build -l de.UTF-8
372Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 373
dd85fadc
JR
374%description build -l pl.UTF-8
375Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 376
dd85fadc
JR
377%description build -l pt_BR.UTF-8
378Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 379construir pacotes usando o RPM.
e73478cd 380
dd85fadc
JR
381%description build -l ru.UTF-8
382Различные вспомогательные скрипты и исполняемые программы, которые
383используются для сборки RPM'ов.
7c6dc55f 384
dd85fadc
JR
385%description build -l uk.UTF-8
386Різноманітні допоміжні скрипти та утиліти, які використовуються для
387побудови RPM'ів.
7c6dc55f 388
69131f1a 389%package perlprov
8482995c 390Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 391Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 392Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 393Group: Applications/File
9fe07969 394Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 395Requires: perl-Encode
69131f1a
JB
396Requires: perl-devel
397Requires: perl-modules
398
399%description perlprov
8482995c 400Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
401packages.
402
dd85fadc
JR
403%description perlprov -l de.UTF-8
404Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 405
dd85fadc 406%description perlprov -l pl.UTF-8
8482995c
JB
407Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
408pakietach RPM.
69131f1a
JB
409
410%package pythonprov
8482995c
JB
411Summary: Python macros, which simplifies creation of RPM packages with Python software
412Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 413Group: Applications/File
9fe07969 414Requires: %{name} = %{epoch}:%{version}-%{release}
cd800b3c 415Requires: python
3acb62f3 416Requires: python-modules
d1f5e279 417Requires: python-setuptools
69131f1a
JB
418
419%description pythonprov
8482995c 420Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
421software.
422
dd85fadc 423%description pythonprov -l pl.UTF-8
8482995c 424Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
425Pythonie.
426
69131f1a
JB
427%package -n python-rpm
428Summary: Python interface to RPM library
4ea2ed33
ER
429Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
430Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a 431Group: Development/Languages/Python
9fe07969 432Requires: %{name} = %{epoch}:%{version}-%{release}
3acb62f3 433Requires: python
69131f1a
JB
434Obsoletes: rpm-python
435
436%description -n python-rpm
f9d0e5f6 437The python-rpm package contains a module which permits applications
69131f1a
JB
438written in the Python programming language to use the interface
439supplied by RPM (RPM Package Manager) libraries.
440
441This package should be installed if you want to develop Python
442programs that will manipulate RPM packages and databases.
443
dd85fadc 444%description -n python-rpm -l pl.UTF-8
f9d0e5f6 445Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
dd85fadc 446Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 447
dd85fadc
JR
448Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
449Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 450
dd85fadc 451%description -n python-rpm -l pt_BR.UTF-8
f9d0e5f6 452O pacote python-rpm contém um módulo que permite que aplicações
69131f1a
JB
453escritas em Python utilizem a interface fornecida pelas bibliotecas
454RPM (RPM Package Manager).
455
dd85fadc 456Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
457Python para manipular pacotes e bancos de dados RPM.
458
f9d0e5f6
JR
459%package -n python3-rpm
460Summary: Python 3 interface to RPM library
461Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
462Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
463Group: Development/Languages/Python
9fe07969 464Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6
JR
465Requires: python3
466
467%description -n python3-rpm
468The python3-rpm package contains a module which permits applications
469written in the Python 3 programming language to use the interface
470supplied by RPM (RPM Package Manager) libraries.
471
472This package should be installed if you want to develop Python 3
473programs that will manipulate RPM packages and databases.
474
475%description -n python3-rpm -l pl.UTF-8
476Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
24b1f498
JR
477Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
478RPM-a.
f9d0e5f6
JR
479
480Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
481Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
482
483%description -n python3-rpm -l pt_BR.UTF-8
484O pacote python3-rpm contém um módulo que permite que aplicações
485escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
486RPM (RPM Package Manager).
487
488Esse pacote deve ser instalado se você quiser desenvolver programas em
489Python 3 para manipular pacotes e bancos de dados RPM.
490
b0333243
JR
491%package plugin-audit
492Summary: Plugin for logging audit events on package operations
24b1f498 493Group: Base
9fe07969 494Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
495
496%description plugin-audit
497Plugin for libaudit support
498
499%package plugin-syslog
500Summary: Plugin for syslog functionality
24b1f498 501Group: Base
9fe07969 502Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
503
504%description plugin-syslog
505This plugin exports RPM actions to the system log.
506
507%package plugin-systemd-inhibit
508Summary: Plugin for systemd inhibit functionality
24b1f498 509Group: Base
9fe07969 510Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
511
512%description plugin-systemd-inhibit
513This plugin blocks systemd from entering idle, sleep or shutdown while
514an rpm transaction is running using the systemd-inhibit mechanism.
515
516%package plugin-ima
517Summary: Plugin for IMA file signatures
518Group: Base
9fe07969 519Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
520
521%description plugin-ima
522This plugin adds support for enforcing and verifying IMA file
523signatures in an rpm.
524
525%package plugin-prioreset
526Summary: Plugin for resetting scriptlet priorities for SysV init
527Group: Base
9fe07969 528Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
529
530%description plugin-prioreset
531This plugin is useful on legacy SysV init systems if you run rpm
532transactions with nice/ionice priorities. Should not be used on
533systemd systems.
534
535%package plugin-selinux
536Summary: Plugin for SELinux functionality
8191f3c5 537Group: Base
9fe07969 538Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
539Requires: libselinux >= 2.1.0
540
541%description plugin-selinux
542Plugin for SELinux functionality.
543
8191f3c5
JR
544%package sign
545Summary: Package signing support
546Group: Base
9fe07969 547Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
548
549%description sign
550This package contains support for digitally signing RPM packages.
551
5c2ab5c7
AM
552%package apidocs
553Summary: RPM API documentation and guides
554Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
555Group: Documentation
d308de4c 556BuildArch: noarch
5c2ab5c7
AM
557
558%description apidocs
559Documentation for RPM API and guides in HTML format generated from rpm
560sources by doxygen.
561
562%description apidocs -l pl.UTF-8
563Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
564źrodeł RPM-a przez doxygen.
565
e2025ad1 566%prep
c546a4d6 567%setup -q -n %{name}-%{version}%{?subver}
af0cc499 568%patch0 -p1
2f0ee4ec 569%patch1 -p1
4d5b8e4c 570%patch2 -p1
af0cc499 571%patch3 -p1
7a3b1f24 572%patch4 -p1
cbab0cbf
JR
573%patch5 -p1
574%patch6 -p0
575%patch7 -p1
af0cc499 576%patch8 -p1
cbab0cbf 577%patch9 -p1
af0cc499
JR
578%patch10 -p1
579%patch11 -p1
580%patch12 -p1
581%patch13 -p1
582%patch14 -p1
7033e976 583%patch15 -p1
af0cc499
JR
584%patch16 -p1
585%patch17 -p1
79191ca9 586%patch18 -p1
883e0fac 587
faba01eb 588install %{SOURCE16} scripts/perl.prov.in
08697680 589
70f8787d 590%{__mv} -f scripts/perl.req{,.in}
633d1e9e 591
cd86db2e 592# generate Group translations to *.po
faba01eb 593awk -f %{SOURCE6} %{SOURCE5}
fefe9d30 594
faba01eb
JR
595install %{SOURCE17} tools/rpmdb_checkversion.c
596install %{SOURCE18} tools/rpmdb_reset.c
91ee86a9 597
24b1f498 598%{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
40675133 599
87ef0d95 600%build
ea816ea6 601%{__libtoolize}
ceaaacee 602%{__aclocal}
4cd84746 603%{__autoheader}
7a9d72ce 604%{__autoconf}
7a9d72ce 605%{__automake}
7a9d72ce 606
048d06f8
JR
607# rpm checks for CPU type at runtime, but it looks better
608sed -i \
609 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
610 -e 's|@host_cpu@|%{_target_cpu}|' \
611 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 612 macros.in
048d06f8 613
5c767dc1 614CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
624f96ff 615%configure \
01d7a578 616 WITH_PERL_VERSION=no \
bba1059c 617 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 618 __GPG=%{_bindir}/gpg \
f9d0e5f6
JR
619 %{?with_python3:PYTHON=python3} \
620 %{!?with_python3:%{?with_python2:PYTHON=python2}} \
3a3e476f 621 --disable-silent-rules \
cd86db2e 622 --enable-shared \
34865f27 623 --enable-bdb \
af0cc499 624 --enable-zstd \
fb35e2d9 625 --with-crypto=openssl \
c38bf1df 626 --with-lua \
34865f27
JR
627 --with-cap \
628 --with-acl \
629 --with-audit \
af0cc499 630 --with-archive \
f9d0e5f6
JR
631%if %{with python2} || %{with python3}
632 --enable-python \
633%endif
b0333243
JR
634 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
635 %{!?with_plugins:--disable-plugins} \
34865f27
JR
636 --with-vendor=pld
637
34865f27
JR
638# --enable-ndb (EXPERIMENTAL) enable the new rpm database format
639# --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
34865f27 640# --with-imaevm build with imaevm support
cf6faebc 641
5c767dc1 642%{__make}
5c2ab5c7 643
6f068494
JR
644%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb
645%{__cc} %{rpmcflags} tools/rpmdb_reset.c -o tools/rpmdb_reset -ldb
fb95de52
JR
646
647if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
648 echo "Error linking rpmdb tools!"
649 exit 1
650fi
8e8746c0
JR
651if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
652 echo "Error linking rpmdb tools!"
653 exit 1
654fi
91ee86a9 655
f9d0e5f6
JR
656%if %{with python2}
657cd python
658%py_build
659cd ..
660%endif
661
662%if %{with python3}
663cd python
664%py3_build
665%endif
666
b064b8e6 667%install
ff7bc1e6 668rm -rf $RPM_BUILD_ROOT
d1f5e279 669install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
7d12560f 670 $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
54eb1770 671
faba01eb 672cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 673
d1f5e279 674%{__make} install \
241257bf
AM
675 pkgconfigdir=%{_pkgconfigdir} \
676 DESTDIR=$RPM_BUILD_ROOT
718426e1 677
c546a4d6 678# cleanup
c2683840 679%ifnarch %{ix86} %{x8664} x32
2f409bb7 680rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 681rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
682rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
683rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
684rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
685rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
686rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
687rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
688%endif
689
c2683840 690%ifnarch %{x8664} x32
2f409bb7
JR
691rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
692rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
693rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
694rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
695%endif
696
c546a4d6 697%ifnarch %{ppc}
34865f27
JR
698rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
699rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
700rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
701rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
702rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 703rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 704rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
705%endif
706
34865f27 707rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
2f409bb7
JR
708rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
709rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
710rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
711rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 712rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 713rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 714rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 715rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 716
3a3e476f 717%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 718
396a7387 719install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
396a7387 720
faba01eb
JR
721cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
722cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
723cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
724cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 725
faba01eb 726cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 727
faba01eb
JR
728cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
729cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
730cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
731cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
732cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
733cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
734cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 735
f9d0e5f6
JR
736cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
737cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
faba01eb 738cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 739
950eead3 740# move rpm to /bin
8191f3c5
JR
741%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
742ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
743ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
744
950eead3 745# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
746for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
747 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
748 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
749done
750
7d12560f
JR
751#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
752
f9d0e5f6
JR
753%if %{with python2}
754# Remove anything that rpm make install might put there
755%{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
756cd python
757%py_install
758%py_postclean
759cd ..
760%endif
6f18cdb7 761
f9d0e5f6
JR
762%if %{with python3}
763# Remove anything that rpm make install might put there
764%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
765cd python
766%py3_install
767cd ..
dae5e1a8 768%endif
01d7a578 769
d1f5e279
JR
770%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
771
01d7a578 772# wrong location, not used anyway
2f409bb7 773%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 774
90b03dd6 775%find_lang %{name}
cf6faebc 776
13eb5ebf 777%clean
d7df46b8 778rm -rf $RPM_BUILD_ROOT
76214164 779
be4d3036 780%posttrans
d25ec6ea 781if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 782 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 783 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 784 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 785 echo
e4dd6a34 786 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
787 echo
788 fi
3ca91ccd
JR
789 echo
790 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
791 echo 'you should ignore it and restart poldek'
792 echo
f9d0e5f6 793 %{_rpmlibdir}/dbupgrade.sh
be4d3036 794fi
f7779567 795
b7ee97ef
JR
796%triggerpostun -- %{name} < 4.4.9-44
797%{_rpmlibdir}/hrmib-cache
798
ceaaacee
JB
799%post lib -p /sbin/ldconfig
800%postun lib -p /sbin/ldconfig
76214164 801
37a5a2fc 802%pretrans build
d755a548 803find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 804
3684d90f
JB
805%files -f %{name}.lang
806%defattr(644,root,root,755)
d1f5e279 807%doc ChangeLog CREDITS README
3684d90f 808
3acb62f3
ER
809%dir /etc/pki/rpm-gpg
810/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 811
7a9d72ce 812%attr(755,root,root) /bin/rpm
8191f3c5
JR
813%attr(755,root,root) %{_bindir}/rpmdb
814%attr(755,root,root) %{_bindir}/rpmkeys
815%attr(755,root,root) %{_bindir}/rpmquery
816%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 817
66edd895 818%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 819%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
caf453d4 820
09bb810c 821%{_mandir}/man8/rpm.8*
8191f3c5
JR
822%{_mandir}/man8/rpmdb.8*
823%{_mandir}/man8/rpmkeys.8*
824%{_mandir}/man8/rpm-misc.8*
24b1f498 825%{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
feb1f12e 826%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 827%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 828%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 829%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 830%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 831%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 832
7d12560f 833%dir /var/lib/rpm
4acac5de 834
cf709a39
ER
835# exported package NVRA (stamped with install tid)
836# net-snmp hrSWInstalledName queries, bash-completions
837%dir /var/cache/hrmib
838
d755a548 839%{_rpmlibdir}/rpmpopt*
8191f3c5 840%{_rpmlibdir}/rpmrc
d755a548 841%{_rpmlibdir}/macros
08697680 842%dir %{_rpmlibdir}/macros.d
e8836e1f 843%dir %{_rpmlibdir}/platform
40675133 844%{_rpmlibdir}/platform/noarch-*
c2683840 845%ifarch %{ix86} %{x8664} x32
34865f27
JR
846%{_rpmlibdir}/platform/athlon*
847%{_rpmlibdir}/platform/geode*
40675133
JR
848%{_rpmlibdir}/platform/i?86*
849%{_rpmlibdir}/platform/pentium*
34865f27
JR
850%endif
851%ifarch %{x8664} x32
852%{_rpmlibdir}/platform/amd64*
853%{_rpmlibdir}/platform/ia32e*
854%{_rpmlibdir}/platform/x86_64*
83a0601a 855%{_rpmlibdir}/platform/x32*
e23edf35
JR
856%endif
857%ifarch alpha
40675133 858%{_rpmlibdir}/platform/alpha*
e23edf35
JR
859%endif
860%ifarch ia64
40675133 861%{_rpmlibdir}/platform/ia64*
e23edf35
JR
862%endif
863%ifarch mips mipsel mips64 mips64el
40675133 864%{_rpmlibdir}/platform/mips*
e23edf35
JR
865%endif
866%ifarch %{ppc}
40675133 867%{_rpmlibdir}/platform/ppc*
e23edf35
JR
868%endif
869%ifarch sparc sparc64
40675133 870%{_rpmlibdir}/platform/sparc*
e23edf35 871%endif
3684d90f 872
3de8e4a9 873%dir %{_rpmlibdir}/pld
396a7387 874
cf709a39
ER
875%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
876
f9d0e5f6
JR
877%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
878%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
879%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
24b1f498
JR
880%attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
881%attr(755,root,root) %{_rpmlibdir}/rpmdb_load
df50421f 882
7d12560f
JR
883# valgrind suppression file for rpm
884%{_rpmlibdir}/rpm.supp
885
66edd895
JB
886%files base
887%defattr(644,root,root,755)
492a2bd4 888%dir %{_sysconfdir}/rpm
66edd895
JB
889%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
890%dir %{_rpmlibdir}
891%attr(755,root,root) %{_bindir}/banner.sh
892%attr(755,root,root) %{_rpmlibdir}/user_group.sh
893%dir /var/lib/banner
894
874f4c9a
MM
895%files lib
896%defattr(644,root,root,755)
40675133
JR
897%attr(755,root,root) /%{_lib}/librpm.so.9
898%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
899%attr(755,root,root) /%{_lib}/librpmbuild.so.9
900%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
901%attr(755,root,root) /%{_lib}/librpmio.so.9
902%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
903%attr(755,root,root) /%{_lib}/librpmsign.so.9
904%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 905%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 906
69131f1a
JB
907%files devel
908%defattr(644,root,root,755)
69131f1a 909%attr(755,root,root) %{_libdir}/librpm.so
950eead3 910%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 911%attr(755,root,root) %{_libdir}/librpmio.so
40675133 912%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
913%{_libdir}/librpm*.la
914%{_includedir}/rpm
915%{_pkgconfigdir}/*.pc
69131f1a 916
69131f1a
JB
917%files utils
918%defattr(644,root,root,755)
d1f5e279 919%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 920%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 921%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 922%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 923%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
25e974c7 924%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
925%attr(755,root,root) %{_rpmlibdir}/debugedit
926%attr(755,root,root) %{_rpmlibdir}/rpmdeps
24b1f498 927%{_mandir}/man8/rpm2archive.8*
69131f1a
JB
928%{_mandir}/man8/rpm2cpio.8*
929%{_mandir}/man8/rpmdeps.8*
fc36dfd5 930%{_mandir}/man8/rpmgraph.8*
69131f1a 931%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 932%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 933%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 934%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 935%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
936%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
937%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 938
3684d90f 939%files build
a45ae6d8 940%defattr(644,root,root,755)
66edd895 941%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
942%attr(755,root,root) %{_rpmlibdir}/brp-*
943%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 944%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 945%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578
JB
946%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
947# needs hacked pkg-config to return anything
948%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 949%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
37e965e8 950
70f8787d 951%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 952# must be here for "Requires: rpm-*prov" to work
40675133
JR
953#%{_rpmlibdir}/macros.d/cmake
954#%{_rpmlibdir}/macros.d/gstreamer
40675133 955#%{_rpmlibdir}/macros.d/libtool
40675133 956#%{_rpmlibdir}/macros.d/perl
40675133
JR
957#%{_rpmlibdir}/macros.d/pkgconfig
958#%{_rpmlibdir}/macros.d/python
40675133
JR
959#%{_rpmlibdir}/macros.d/selinux
960#%{_rpmlibdir}/macros.d/tcl
961#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 962
7d12560f
JR
963%attr(755,root,root) %{_rpmlibdir}/check-buildroot
964%attr(755,root,root) %{_rpmlibdir}/check-prereqs
965%attr(755,root,root) %{_rpmlibdir}/check-rpaths
966%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
7d12560f
JR
967%attr(755,root,root) %{_rpmlibdir}/find-provides
968%attr(755,root,root) %{_rpmlibdir}/find-requires
24b1f498 969%attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
7d12560f
JR
970%attr(755,root,root) %{_rpmlibdir}/script.req
971%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
7d12560f 972
f9d0e5f6
JR
973%dir %{_rpmlibdir}/fileattrs
974%{_rpmlibdir}/fileattrs/debuginfo.attr
975%{_rpmlibdir}/fileattrs/desktop.attr
976%{_rpmlibdir}/fileattrs/elf.attr
977%{_rpmlibdir}/fileattrs/font.attr
978%{_rpmlibdir}/fileattrs/libtool.attr
979%{_rpmlibdir}/fileattrs/metainfo.attr
980%{_rpmlibdir}/fileattrs/ocaml.attr
981%{_rpmlibdir}/fileattrs/perl.attr
982%{_rpmlibdir}/fileattrs/perllib.attr
f9d0e5f6
JR
983%{_rpmlibdir}/fileattrs/pkgconfig.attr
984%{_rpmlibdir}/fileattrs/python.attr
985%{_rpmlibdir}/fileattrs/pythondist.attr
986%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 987
874f4c9a
MM
988%attr(755,root,root) %{_bindir}/gendiff
989%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 990%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 991
a00926bc 992%{_mandir}/man1/gendiff.1*
d1f5e279 993%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 994%{_mandir}/man8/rpmbuild.8*
fefe9d30 995%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 996%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 997%{_mandir}/man8/rpmspec.8*
f3fe287f 998
89334051
AF
999%files perlprov
1000%defattr(644,root,root,755)
d755a548 1001%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 1002
80d3b868 1003%files pythonprov
d8fcb9b0 1004%defattr(644,root,root,755)
24b1f498 1005#%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
d1f5e279 1006%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 1007
f9d0e5f6 1008%if %{with python2}
cf6faebc 1009%files -n python-rpm
42a0025c 1010%defattr(644,root,root,755)
34865f27
JR
1011%dir %{py_sitedir}/rpm
1012%attr(755,root,root) %{py_sitedir}/rpm/*.so
1013%{py_sitedir}/rpm/*.py[co]
f9d0e5f6
JR
1014%{py_sitedir}/rpm-%{version}-py*.egg-info
1015%endif
1016
1017%if %{with python3}
1018%files -n python3-rpm
1019%defattr(644,root,root,755)
1020%dir %{py3_sitedir}/rpm
1021%attr(755,root,root) %{py3_sitedir}/rpm/*.so
1022%{py3_sitedir}/rpm/*.py
1023%{py3_sitedir}/rpm-%{version}-py*.egg-info
1024%{py3_sitedir}/rpm/__pycache__
50dc9ac0 1025%endif
5c2ab5c7 1026
b0333243
JR
1027%if %{with plugins}
1028%files plugin-audit
1029%defattr(644,root,root,755)
1030%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
24b1f498 1031%{_mandir}/man8/rpm-plugin-audit.8*
b0333243
JR
1032
1033%files plugin-syslog
1034%defattr(644,root,root,755)
1035%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
24b1f498 1036%{_mandir}/man8/rpm-plugin-syslog.8*
b0333243
JR
1037
1038%files plugin-systemd-inhibit
1039%defattr(644,root,root,755)
1040%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1041%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1042
1043%files plugin-ima
1044%defattr(644,root,root,755)
1045%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
24b1f498 1046%{_mandir}/man8/rpm-plugin-ima.8*
b0333243
JR
1047
1048%files plugin-prioreset
1049%defattr(644,root,root,755)
1050%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
24b1f498 1051%{_mandir}/man8/rpm-plugin-prioreset.8*
b0333243
JR
1052
1053%files plugin-selinux
1054%defattr(644,root,root,755)
1055%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
24b1f498 1056%{_mandir}/man8/rpm-plugin-selinux.8*
b0333243
JR
1057%endif
1058
8191f3c5
JR
1059%files sign
1060%defattr(644,root,root,755)
1061%attr(755,root,root) %{_bindir}/rpmsign
1062%{_mandir}/man8/rpmsign.8*
1063
5c2ab5c7
AM
1064%if %{with apidocs}
1065%files apidocs
1066%defattr(644,root,root,755)
d1f5e279
JR
1067%doc doc/librpm/html/*
1068%endif
This page took 1.62954 seconds and 4 git commands to generate.