]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- don't continue if conversion failed
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
d0ee0933
JR
3# - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4# returns -ENOSYS
9fb5ee9e 5# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 6#
c296fee0 7# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 8#
89427592 9# Conditional build:
01d7a578 10%bcond_with static # build static rpm+rpmi
0a1ccab0 11%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
12%bcond_without python # don't build python bindings
13%bcond_without selinux # build without selinux support
0dc47449 14%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
34befcc5 15%bcond_with neon # build with HTTP/WebDAV support (neon library)
858aa7d0 16%bcond_without db # BerkeleyDB
77fcdbf7 17%bcond_without sqlite # build with SQLite support
858aa7d0 18%bcond_with sqlite_dbapi # default database backend is sqlite
70df63f3 19%bcond_with system_lua # use system lua
d0ee0933 20%bcond_with keyutils # build with keyutils support
89427592
JB
21# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
22# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
23# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0
AM
24#
25%if %{with sqlite_dbapi}
26%define with_sqlite 1
27%endif
54bfdf99 28
858aa7d0 29%if %{without db} && %{without sqlite}
25ac75ae 30%{error:Need db or sqlite}
858aa7d0
AM
31ERROR
32%endif
33
ba7bedbb
JR
34%if %{with sqlite}
35# Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
36%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
37%endif
38
003a039e 39# versions of required libraries
bf728d07
JR
40%define reqdb_pkg db5.2
41%define reqdb_ver 5.2
ec44785a 42%define reqpopt_ver 1.15
fc60c9f3 43%define beecrypt_ver 2:4.1.2-4
70f8787d 44%define sover 5.4
fc60c9f3 45
e5f02e49 46Summary: RPM Package Manager
4ea2ed33
ER
47Summary(de.UTF-8): RPM Packet-Manager
48Summary(es.UTF-8): Gestor de paquetes RPM
49Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
50Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
51Summary(ru.UTF-8): Менеджер пакетов от RPM
52Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 53Name: rpm
afb55538 54Version: 5.4.10
f7779567 55Release: 35.1
b0434f77 56License: LGPL
76214164 57Group: Base
afb55538
JR
58# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
59Source0: %{name}-%{version}.tar.gz
60# Source0-md5: 5d099161bdd3203265ab32ffad3360b5
d38aed81
JR
61Source100: cpu-os-macros.tar.gz
62# Source100-md5: 928034a5bdceb398881bc14b5f29973b
ff7bc1e6 63Source1: %{name}.groups
08697680 64Source2: macros.pld.in
ff7bc1e6 65Source3: %{name}-install-tree
80b8a1f9 66Source4: %{name}-find-spec-bcond
cf709a39 67Source5: %{name}-hrmib-cache
80b8a1f9
JB
68Source6: %{name}-groups-po.awk
69Source7: %{name}-compress-doc
0bf34f68
JR
70Source8: %{name}-php-provides
71Source9: %{name}-php-requires
72Source10: %{name}.sysinfo
73Source11: perl.prov
74Source12: %{name}-user_group.sh
75Source13: %{name}.sysconfig
76Source14: %{name}-java-requires
a4b7ef27 77# http://svn.pld-linux.org/banner.sh/
0bf34f68
JR
78Source15: banner.sh
79Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
80# Source16-md5: 08b29584dd349aac9caa7610131a0a88
81Source17: %{name}-mimetypedeps
82Source18: macros.local
83Source19: rpm.noautocompressdoc
84Source20: rpm.noautoprov
85Source21: rpm.noautoprovfiles
86Source22: rpm.noautoreq
87Source23: rpm.noautoreqdep
88Source24: rpm.noautoreqfiles
89Source25: %{name}-php-requires.php
91ee86a9 90Source26: rpmdb_checkversion.c
b1541d4c 91Source27: macros.lang
f05db907 92Patch0: %{name}-branch.patch
2f0ee4ec 93Patch1: %{name}-man_pl.patch
38e53563 94Patch2: %{name}-popt-aliases.patch
b174986a 95Patch3: %{name}-rpmpopt.patch
3465efba 96Patch4: %{name}-perl-macros.patch
c1768ce2 97Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
98Patch6: %{name}-scripts-closefds.patch
99Patch7: %{name}-php-macros.patch
100Patch8: %{name}-gettext-in-header.patch
044171ea 101Patch9: %{name}-lua.patch
9ee75c3c
JR
102Patch10: %{name}-php-deps.patch
103Patch11: %{name}-notsc.patch
104Patch12: %{name}-hack-norpmlibdep.patch
06405080 105Patch13: %{name}-dont-copy-descriptive-tags.patch
9ee75c3c
JR
106Patch14: %{name}-perl_req-INC_dirs.patch
107Patch15: %{name}-debuginfo.patch
108Patch16: vendor-pld.patch
109Patch17: %{name}-old-fileconflicts-behaviour.patch
110Patch18: %{name}-javadeps.patch
111Patch19: %{name}-truncate-cvslog.patch
112Patch20: %{name}-libtool-deps.patch
113Patch21: %{name}-mimetype.patch
114Patch22: %{name}-sparc64.patch
115Patch23: %{name}-gendiff.patch
116Patch24: openmp.patch
117Patch25: %{name}-URPM-build-fix.patch
f7779567 118Patch26: %{name}-db5.3.patch
9ee75c3c
JR
119Patch27: %{name}-helperEVR-noassert.patch
120Patch28: %{name}-unglobal.patch
121Patch29: %{name}-builddir-readlink.patch
122Patch30: %{name}-changelog_order_check_nonfatal.patch
123Patch31: %{name}-cleanbody.patch
124Patch32: %{name}-dirdeps-macro.patch
125Patch33: %{name}-installbeforeerase.patch
126Patch34: %{name}-libmagic-locale.patch
127Patch35: %{name}-namespace-compare.patch
128Patch36: %{name}-popt-coreutils.patch
129Patch37: %{name}-postun-nofail.patch
130Patch38: %{name}-silence-RPM_CHAR_TYPE.patch
131Patch39: %{name}-fix-missing-types-in-headers.patch
132Patch40: %{name}-fix--p-interpreter-and-empty-script.patch
133Patch41: %{name}-db_buffer_small.patch
134Patch42: %{name}-pattern_Release.patch
135Patch43: %{name}-fix-___build_pre-macro.patch
136Patch44: %{name}-missing-patch-file-fails-build.patch
137Patch45: %{name}-remove-misleading-missing-patch-message.patch
138Patch46: %{name}-file-magic-can-be-mixed-case.patch
0b0a7839 139Patch47: %{name}-query-always-noisy.patch
7f7a3f24 140Patch48: %{name}-verify-ghosts-broken-logic.patch
295c267a 141Patch49: %{name}-python-enable-compat-RPMSENSE.patch
d6a36788 142Patch50: %{name}-dont-treat-gstreamer-modules-as-font.patch
bba1059c 143Patch51: %{name}-gst-inspect-typo.patch
1fcc9b69 144Patch52: %{name}-null-term-ascii-digest.patch
70df63f3 145Patch53: %{name}-lua-enable-extra-libs.patch
330093fa 146Patch54: %{name}-fix-filedigests-verify.patch
9158f140 147Patch55: %{name}-disable-hmac-verify.patch
267d7641 148Patch56: rpm-macros.patch
f7779567 149Patch57: %{name}-db5.2.patch
70f8787d
JR
150
151# Patches imported from Mandriva
152
153# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
154# would basically just mean backporting it..
155Patch1000: rpm-5.4.4-add-_specfile-macro.patch
156# status: needs to be cleaned up and properly reviewed together with rest
157# of the patches related to dependency generation
158Patch1001: rpm-5.4.9-avoid-dependencies-on-self.patch
159# status: probably ready to merge
160Patch1002: rpm-5.4.4-pkgconfigdeps-check-path.patch
161# status: probably okay to merge, but discuss on rpm-devel first
162Patch1003: rpm-5.4.4-glob-wildcards-for-loading-macro-files.patch
163# status: needs to be discussed
164Patch1004: rpm-5.4.4-allow-installation-of-repackaged-rpms.patch
165# status: ready to merge
166Patch1005: rpm-5.4.8-dont-show-suggests-with-requires.patch
167# status: ready for merge
168Patch1006: rpm-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
169# status: probably okay to merge, but discuss on rpm-devel first
170Patch1007: rpm-5.4.10-duplicate_files_terminate_build.patch
171# status: same as above
172Patch1008: rpm-5.4.10-unpackaged_subdirs_terminate_build.patch
173# mdvbz#64898
174# status: uncertain, might be okay to merge, discuss on rpm-devel first
175Patch1009: rpm-5.4.4-rpmbuild-withoutclean.patch
176# no sense in having an additional dependency on 'pkgconfig' on all packages that
177# have a pkgconfig file, it's not needed for them to be made useful and anything
178# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
179# status: might be okay to merge, but discuss on rpm-devel first
180Patch1010: rpm-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
181# status: ready for merge
182Patch1011: rpm-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
183# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
184# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
185# status: needs to be discussed and investigated a bit better..
186Patch1012: rpm-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
187# status: probably okay to merge, but discuss on rpm-devel first
188Patch1013: rpm-5.4.10-files-listed-twice-terminates-build.patch
189# status: probably okay to merge
190Patch1014: rpm-5.4.9-ruby1.9-fixes.patch
191# status: keep locally
192Patch1015: rpm-5.4.9-keep-loading-script-macros.patch
193# status: same as for other dep gen patches
194Patch1016: rpm-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
195# status: idem
196Patch1017: rpm-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
197# status: ready for merge
198Patch1018: rpm-5.4.5-rubygems-add-missing-newline.patch
199# status: probably okay to merge
200Patch1019: rpm-5.4.5-python-export-spec-macros.patch
201# status: idem
202Patch1020: rpm-5.4.9-font-provides.patch
203# stauus: idem
204Patch1021: rpm-5.4.7-kmod-dependencies.patch
205# status: probably okay to merge, discuss on rpm-devel first
206Patch1022: rpm-5.4.5-skip-dependencies-for-character-devices.patch
207# status: ready to merge
208Patch1023: rpm-5.4.5-rpmfc-use-strlen-not-sizeof.patch
209# status: probably okay to merge
210Patch1024: rpm-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
211# status: ready to merge
212Patch1025: rpm-5.4.7-rpmfc-fix-invalid-free-if-not-_defaultdocdir-set.patch
213# status: probably okay to merge
214Patch1026: rpm-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
215# status: ready
216Patch1027: rpm-5.4.7-fix-generation-of-ruby-abi-provides.patch
217# crash reproducable with 'rpm -qa --triggers'
218# status: ready
219Patch1028: rpm-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
220# status: same as for other dep gen patches
221Patch1029: rpm-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
222# status: ready
223Patch1030: rpm-5.4.7-fix-minor-memleaks.patch
224# status: ready
225Patch1031: rpm-5.4.9-mire-fix-strings-lacking-null-terminator.patch
226# status: ready
227Patch1032: rpm-5.4.9-rpmpython-fix-input.patch
228# status: ready
229Patch1033: rpm-5.4.7-no-seqid_init-on-rdonly-database.patch
230# status: probably ready for merging
231Patch1034: rpm-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
232# status: probably ready to merge, discuss on rpm-devel first
233Patch1035: rpm-5.4.9-fix-verify-segfault.patch
234# status: ready and should be merged
235Patch1036: rpm-5.4.9-fix-typo-in-rpmtag-header.patch
236# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
237# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
238# with the result being that when unable to download files, neon will save error
239# page as the target file.
240# status: should go upstream, but uncertain about "correct" fix, ie. this is
241# more of a workaround, while rewriting rpmdav code to behave consistently
242# would be "the right thing to do". Yet I'm not fully able to grasp all of the
243# code and don't want to spend more time just to get the API..
244Patch1037: rpm-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
245# As the transaction flags for ignoring arch & os are no longer used, there's
246# currently no way to ignore arch & os of packages anymore. This patch adds
247# support for doing this again by defining rpm variables and overriding
248# --ignorearch & --ignoreos to set these.
249# status: needs to be discussed upstream before thinking about merging
250Patch1038: rpm-5.4.10-support-ignore-arch-and-os-again.patch
9f9190ed
JR
251# status: ready for merge
252Patch1039: rpm-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
e85b33bb
JR
253# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
254Patch1040: rpm-5.4.9-support-signatures-and-digest-disablers.patch
5555c3a0
JR
255# lack insight on actual functionality, which anyways seems broken, so let's
256# disable it to avoid errors from berkeley db..
257# status: keep locally
258Patch1041: rpm-5.4.9-disable-l10ndir.patch
dfd6cb49
JR
259# status: ready for merge
260Patch1042: rpm-5.4.9-fix-rpm_qa-pattern.patch
70f8787d 261
955f2725 262URL: http://rpm5.org/
6a8612bc 263BuildRequires: autoconf >= 2.60
644d8958 264BuildRequires: automake >= 1.4
87ef0d95 265BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 266BuildRequires: bzip2-devel >= 1.0.2-17
7ef0925f 267%{?with_db:BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_ver}}
33be5db0 268BuildRequires: elfutils-devel >= 0.108
0ef6aeae 269#BuildRequires: gettext-autopoint >= 0.11.4-2
d1795eb0 270BuildRequires: gettext-devel >= 0.11.4-2
d0ee0933 271%{?with_keyutils:BuildRequires: keyutils-devel}
241257bf 272BuildRequires: libmagic-devel
6e115b23
JR
273%if %{with selinux}
274BuildRequires: libselinux-devel >= 2.1.0
275BuildRequires: libsepol-devel >= 2.1.0
276BuildRequires: libsemanage-devel >= 2.1.0
277%endif
84cdee7a
JB
278# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
279BuildRequires: libstdc++-devel
b60c74c3 280BuildRequires: libtool >= 1:1.4.2-9
33be5db0 281%if %{with neon}
fe861705 282BuildRequires: libxml2-devel
83d6a3fe 283BuildRequires: neon-devel >= 0.25.5
33be5db0 284%endif
127a0b3c 285BuildRequires: ossp-uuid-devel
7973b351 286BuildRequires: patch >= 2.2
1d49ffbc 287BuildRequires: popt-devel >= %{reqpopt_ver}
6a8612bc 288%{?with_system_lua:BuildRequires: lua51-devel >= 5.1.2}
950eead3
ER
289%{?with_python:BuildRequires: python-devel >= 1:2.3}
290BuildRequires: python-modules >= 1:2.3
2a813afe 291%{?with_python:BuildRequires: rpm-pythonprov}
241257bf 292%{?with_sqlite:BuildRequires: sqlite3-devel}
e56a10a9 293BuildRequires: tcl
874f4c9a 294BuildRequires: zlib-devel
77fcdbf7 295BuildRequires: xz-devel
5c2ab5c7
AM
296%if %{with apidocs}
297BuildRequires: doxygen
298BuildRequires: ghostscript
299BuildRequires: graphviz
300BuildRequires: tetex-pdftex
301%endif
a6e56ce4 302%if %{with static}
e6090a7b 303# Require static library only for static build
87ef0d95 304BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 305BuildRequires: bzip2-static >= 1.0.2-17
62eceee6 306%{?with_db:BuildRequires: %{reqdb_pkg}-static >= %{reqdb_ver}}
290c1c30 307BuildRequires: elfutils-static
10abbd40 308BuildRequires: glibc-static >= 2.2.94
241257bf 309BuildRequires: libmagic-static
6e115b23
JR
310%if %{with selinux}
311BuildRequires: libselinux-static >= 2.1.0
312BuildRequires: libsepol-static >= 2.1.0
313BuildRequires: libsemanage-static >= 2.1.0
314%endif
003a039e 315BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 316BuildRequires: zlib-static
7a9d72ce 317%endif
66edd895 318Requires: %{name}-base = %{version}-%{release}
b26a9709 319Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
320Requires: beecrypt >= %{beecrypt_ver}
321Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
322Provides: rpm-db-ver = %{reqdb_ver}
323Obsoletes: rpm-getdeps
4adb7d05 324%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 325Conflicts: glibc < 2.2.92
8ee1c72c
AM
326# db4.6 poldek needed
327Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
328# segfaults with lzma 0.42.2
329Conflicts: lzma-libs < 4.999.3
1d49ffbc 330BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 331
4adb7d05 332%define _binary_payload w9.gzdio
6d82b332 333
4cd84746
JB
334# don't require very fresh rpm.macros to build
335%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 336%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 337%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 338%define ppc ppc ppc7400 ppc7450
9f517079 339%define x8664 amd64 ia32e x86_64
4cd84746 340
89427592 341# stabilize new build environment
f9ac32aa
AM
342%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
343%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
344%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 345
d755a548 346%define _rpmlibdir /usr/lib/rpm
950eead3 347%define _noautocompressdoc RPM-GPG-KEY
d755a548 348
573e40e1
PS
349%define specflags -fno-strict-aliasing
350
ff7bc1e6 351%description
352RPM is a powerful package manager, which can be used to build,
353install, query, verify, update, and uninstall individual software
cf6faebc 354packages. A package consists of an archive of files, and package
fed73700 355information, including name, version, and description.
356
dd85fadc
JR
357%description -l de.UTF-8
358RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 359Installation, Anfrage, Verifizierung, Aktualisierung und
360Uninstallation individueller Softwarepakete. Ein Paket besteht aus
361einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 362Beschreibung.
363
dd85fadc 364%description -l es.UTF-8
313a4d1a 365RPM es un poderoso administrador de paquetes, que puede ser usado para
366construir, instalar, pesquisar, verificar, actualizar y desinstalar
367paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
368almacenaje de archivos, y información sobre el paquete, incluyendo
369nombre, versión y descripción.
370
371%description -l pl.UTF-8
372RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
373przebudowanie, instalację czy weryfikację dowolnego pakietu.
374Informacje dotyczące każdego pakietu, takie jak jego opis, lista
375plików wchodzących w skład pakietu, zależności od innych pakietów, są
376przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 377odpytywania programu rpm.
378
dd85fadc
JR
379%description -l pt_BR.UTF-8
380RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 381construir, instalar, pesquisar, verificar, atualizar e desinstalar
382pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
383arquivos e informações adicionais, incluindo nome, versão e descrição
384do pacote, permissões dos arquivos, etc.
385
386%description -l ru.UTF-8
387RPM - это мощный менеджер пакетов, который может быть использован для
388создания, инсталляции, запросов (query), проверки, обновления и
389удаления программных пакетов. Пакет состоит из файлового архива и
390служебной информации, включающей название, версию, описание и другие
391данные о пакете.
392
393%description -l uk.UTF-8
394RPM - це потужний менеджер пакетів, що може бути використаний для
395створення, інсталяції, запитів (query), перевірки, поновлення та
396видалення програмних пакетів. Пакет складається з файлового архіву та
397службової інформації, що містить назву, версію, опис та іншу
398інформацію про пакет.
7c6dc55f 399
66edd895
JB
400%package base
401Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 402Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 403Group: Base
1d9ca0c1 404Requires: filesystem
950eead3 405Obsoletes: rpm-scripts
66edd895
JB
406Obsoletes: vserver-rpm
407
408%description base
409The RPM base package contains scripts used by rpm packages themselves.
410These include:
411- scripts for adding/removing groups and users needed for rpm
412 packages,
413- banner.sh to display %%banner messages from rpm scriptlets.
414
dd85fadc
JR
415%description base -l pl.UTF-8
416Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 417Zawiera on:
dd85fadc
JR
418- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
419- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 420
69131f1a
JB
421%package lib
422Summary: RPMs library
4ea2ed33 423Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 424Group: Libraries
33be5db0 425Requires: beecrypt >= %{beecrypt_ver}
62eceee6 426%{?with_db:Requires: %{reqdb_pkg} >= %{reqdb_ver}}
241257bf 427Requires: libmagic >= 1.15-2
6e115b23 428%{?with_selinux:Requires: libselinux >= 2.1.0}
69131f1a 429Requires: popt >= %{reqpopt_ver}
ba7bedbb 430%{?with_sqlite:Requires: sqlite3 >= %{sqlite_build_version}}
d1795eb0 431Obsoletes: rpm-libs
69131f1a
JB
432# avoid SEGV caused by mixed db versions
433Conflicts: poldek < 0.18.1-16
434
435%description lib
436RPMs library.
437
dd85fadc 438%description lib -l pl.UTF-8
69131f1a
JB
439Biblioteki RPM-a.
440
fed73700 441%package devel
3f2d796a 442Summary: Header files for rpm libraries
4ea2ed33
ER
443Summary(de.UTF-8): Header-Dateien für rpm Libraries
444Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
445Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
446Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
447Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
448Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 449Group: Development/Libraries
153e5706 450Requires: %{name}-lib = %{version}-%{release}
87ef0d95 451Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 452Requires: bzip2-devel
62eceee6 453%{?with_db:Requires: %{reqdb_pkg}-devel >= %{reqdb_ver}}
5c583f90 454Requires: elfutils-devel
d0ee0933 455%{?with_keyutils:Requires: keyutils-devel}
241257bf 456Requires: libmagic-devel
10abbd40 457%{?with_selinux:Requires: libselinux-devel}
a998ac11 458Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 459Requires: zlib-devel
cf6faebc 460
461%description devel
3f2d796a
JB
462The RPM packaging system includes C libraries that make it easy to
463manipulate RPM packages and databases. They are intended to ease the
cf6faebc 464creation of graphical package managers and other tools that need
3f2d796a
JB
465intimate knowledge of RPM packages. This package contains header files
466for these libraries.
fed73700 467
dd85fadc
JR
468%description devel -l de.UTF-8
469Der RPM-Packensystem enthält eine C-Library, die macht es einfach
470RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 471Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 472Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
473
dd85fadc 474%description devel -l es.UTF-8
313a4d1a 475El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
476fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
477facilitar la creación de administradores gráficos de paquetes y otras
20f89981 478herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 479
dd85fadc
JR
480%description devel -l pl.UTF-8
481System RPM zawiera biblioteki C, które ułatwiają manipulowanie
482pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
483graficznych programów zarządzających pakietami oraz innych narzędzi,
484które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
485zawiera pliki nagłówkowe wspomnianych bibliotek.
486
487%description devel -l pt_BR.UTF-8
488O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
489a manipulação de pacotes e bases de dados RPM. Seu objetivo é
490facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 491ferramentas que precisem de conhecimento profundo de pacotes RPM.
492
dd85fadc
JR
493%description devel -l ru.UTF-8
494Система управления пакетами RPM содержит библиотеку C, которая
495упрощает манипуляцию пакетами RPM и соответствующими базами данных.
496Эта библиотека предназначена для облегчения создания графических
497пакетных менеджеров и других утилит, которым необходимо работать с
498пакетами RPM.
7c6dc55f 499
dd85fadc
JR
500%description devel -l uk.UTF-8
501Система керування пакетами RPM містить бібліотеку C, котра спрощує
502роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
503призначена для полегшення створення графічних пакетних менеджерів та
504інших утиліт, що працюють з пакетами RPM.
7c6dc55f 505
fed73700 506%package static
9e42d68a 507Summary: RPM static libraries
4ea2ed33
ER
508Summary(de.UTF-8): RPMs statische Libraries
509Summary(pl.UTF-8): Biblioteki statyczne RPM-a
510Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
511Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
512Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 513Group: Development/Libraries
153e5706 514Requires: %{name}-devel = %{version}-%{release}
87ef0d95 515Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 516Requires: bzip2-static
62eceee6 517%{?with_db:Requires: %{reqdb_pkg}-static >= %{reqdb_ver}}
ff03e01a 518Requires: elfutils-static
d0ee0933 519%{?with_keyutils:Requires: keyutils-static}
241257bf 520Requires: libmagic-static
a998ac11 521Requires: popt-static >= %{reqpopt_ver}
df76dbd9 522Requires: zlib-static
edacdf8f 523
524%description static
20f89981 525RPM static libraries.
fed73700 526
dd85fadc 527%description static -l de.UTF-8
20f89981 528RPMs statische Libraries.
9e42d68a 529
dd85fadc 530%description static -l pl.UTF-8
0a7ae9bc 531Biblioteki statyczne RPM-a.
313a4d1a 532
dd85fadc
JR
533%description static -l pt_BR.UTF-8
534Bibliotecas estáticas para desenvolvimento.
edacdf8f 535
dd85fadc
JR
536%description static -l ru.UTF-8
537Система управления пакетами RPM содержит библиотеку C, которая
538упрощает манипуляцию пакетами RPM и соответствующими базами данных.
539Это статическая библиотека RPM.
7c6dc55f 540
dd85fadc
JR
541%description static -l uk.UTF-8
542Система керування пакетами RPM містить бібліотеку C, котра спрощує
543роботу з пакетами RPM та відповідними базами даних. Це статична
544бібліотека RPM.
7c6dc55f 545
fed73700 546%package utils
8482995c 547Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
548Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
549Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 550Group: Applications/File
153e5706 551Requires: %{name} = %{version}-%{release}
a998ac11 552Requires: popt >= %{reqpopt_ver}
86b85368
AG
553%if %{with suggest_tags}
554Suggests: bzip2
555Suggests: gzip
86b85368 556%endif
695e60ad 557Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 558
559%description utils
8482995c 560Additional utilities for managing RPM packages and database.
fed73700 561
dd85fadc
JR
562%description utils -l de.UTF-8
563Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 564
dd85fadc
JR
565%description utils -l pl.UTF-8
566Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 567
92b3f576 568%package utils-perl
8482995c 569Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
570Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
571Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 572Group: Applications/File
153e5706 573Requires: %{name}-utils = %{version}-%{release}
92b3f576 574Requires: popt >= %{reqpopt_ver}
575
576%description utils-perl
8482995c 577Additional utilities for managing RPM packages and database.
92b3f576 578
dd85fadc
JR
579%description utils-perl -l de.UTF-8
580Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 581
dd85fadc
JR
582%description utils-perl -l pl.UTF-8
583Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 584
a00926bc
JB
585%package utils-static
586Summary: Static rpm utilities
4ea2ed33 587Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 588Group: Applications/System
153e5706 589Requires: %{name} = %{version}-%{release}
a00926bc
JB
590
591%description utils-static
592Static rpm utilities for repairing system in case something with
593shared libraries used by rpm become broken. Currently it contains rpmi
594binary, which can be used to install/upgrade/remove packages without
595using shared libraries (well, in fact with exception of NSS modules).
596
dd85fadc
JR
597%description utils-static -l pl.UTF-8
598Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
599związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
600Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
601uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
602(z wyjątkiem modułów NSS).
a00926bc 603
fed73700 604%package build
e191287c 605Summary: Scripts for building binary RPM packages
4ea2ed33
ER
606Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
607Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
608Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
609Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
610Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 611Group: Applications/File
8f76a271 612Requires(pre): findutils
8f3e4798 613Requires: %{name}-build-macros >= 1.653
153e5706 614Requires: %{name}-utils = %{version}-%{release}
e191287c 615Requires: /bin/id
616Requires: awk
cfa7898a 617Requires: bzip2
e950a6d7 618Requires: chrpath >= 0.10-4
b6547e10 619Requires: cpio
e191287c 620Requires: diffutils
195f647c 621Requires: elfutils
583135b4 622Requires: file >= 4.17
e191287c 623Requires: fileutils
624Requires: findutils
950eead3
ER
625%ifarch athlon
626Requires: gcc >= 3.0.3
627%else
628Requires: gcc
629%endif
e191287c 630Requires: glibc-devel
631Requires: grep
632Requires: gzip
633Requires: make
634Requires: patch
adbd4815 635Requires: sed >= 4.0
e191287c 636Requires: sh-utils
adbd4815 637Requires: tar >= 1:1.22
e191287c 638Requires: textutils
adbd4815 639Requires: xz
ca3648b1 640Provides: rpmbuild(monoautodeps)
37ea389a 641Provides: rpmbuild(noauto) = 3
02d17bf9 642%ifarch %{x8664}
195f647c
JB
643Conflicts: automake < 1:1.7.9-2
644Conflicts: libtool < 2:1.5-13
645%endif
0096c5cd 646
e2025ad1 647%description build
58399c37 648Scripts for building binary RPM packages.
fed73700 649
dd85fadc
JR
650%description build -l de.UTF-8
651Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 652
dd85fadc
JR
653%description build -l pl.UTF-8
654Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 655
dd85fadc
JR
656%description build -l pt_BR.UTF-8
657Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 658construir pacotes usando o RPM.
e73478cd 659
dd85fadc
JR
660%description build -l ru.UTF-8
661Различные вспомогательные скрипты и исполняемые программы, которые
662используются для сборки RPM'ов.
7c6dc55f 663
dd85fadc
JR
664%description build -l uk.UTF-8
665Різноманітні допоміжні скрипти та утиліти, які використовуються для
666побудови RPM'ів.
7c6dc55f 667
8482995c
JB
668%package javaprov
669Summary: Additional utilities for checking Java provides/requires in RPM packages
670Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
671Group: Applications/File
672Requires: %{name} = %{version}-%{release}
673Requires: file
674Requires: findutils >= 1:4.2.26
675Requires: mktemp
676Requires: unzip
677
678%description javaprov
679Additional utilities for checking Java provides/requires in RPM
680packages.
681
682%description javaprov -l pl.UTF-8
683Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
684RPM.
685
69131f1a 686%package perlprov
8482995c 687Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 688Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 689Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
690Group: Applications/File
691Requires: %{name} = %{version}-%{release}
692Requires: perl-devel
693Requires: perl-modules
694
695%description perlprov
8482995c 696Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
697packages.
698
dd85fadc
JR
699%description perlprov -l de.UTF-8
700Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 701
dd85fadc 702%description perlprov -l pl.UTF-8
8482995c
JB
703Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
704pakietach RPM.
69131f1a
JB
705
706%package pythonprov
8482995c
JB
707Summary: Python macros, which simplifies creation of RPM packages with Python software
708Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
709Group: Applications/File
710Requires: %{name} = %{version}-%{release}
cd800b3c 711Requires: python
243c6264 712Requires: python-modules
bdbae303 713Requires: python-distribute
69131f1a
JB
714
715%description pythonprov
8482995c 716Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
717software.
718
dd85fadc 719%description pythonprov -l pl.UTF-8
8482995c 720Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
721Pythonie.
722
723%package php-pearprov
8482995c
JB
724Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
725Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
726Group: Applications/File
727Requires: %{name} = %{version}-%{release}
632f1b5c 728Requires: sed >= 4.0
69131f1a
JB
729
730%description php-pearprov
8482995c 731Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
732packages.
733
dd85fadc 734%description php-pearprov -l pl.UTF-8
8482995c
JB
735Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
736pakietach RPM.
69131f1a
JB
737
738%package -n python-rpm
739Summary: Python interface to RPM library
4ea2ed33
ER
740Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
741Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
742Group: Development/Languages/Python
743Requires: %{name} = %{version}-%{release}
744%pyrequires_eq python
745Obsoletes: rpm-python
746
747%description -n python-rpm
748The rpm-python package contains a module which permits applications
749written in the Python programming language to use the interface
750supplied by RPM (RPM Package Manager) libraries.
751
752This package should be installed if you want to develop Python
753programs that will manipulate RPM packages and databases.
754
dd85fadc
JR
755%description -n python-rpm -l pl.UTF-8
756Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
757Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 758
dd85fadc
JR
759Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
760Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 761
dd85fadc
JR
762%description -n python-rpm -l pt_BR.UTF-8
763O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
764escritas em Python utilizem a interface fornecida pelas bibliotecas
765RPM (RPM Package Manager).
766
dd85fadc 767Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
768Python para manipular pacotes e bancos de dados RPM.
769
5c2ab5c7
AM
770%package apidocs
771Summary: RPM API documentation and guides
772Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
773Group: Documentation
774
775%description apidocs
776Documentation for RPM API and guides in HTML format generated from rpm
777sources by doxygen.
778
779%description apidocs -l pl.UTF-8
780Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
781źrodeł RPM-a przez doxygen.
782
e2025ad1 783%prep
d38aed81 784%setup -q -n %{name}-%{version}%{?subver} -a100
317ef122 785#patch0 -p1
2f0ee4ec 786%patch1 -p1
4d5b8e4c 787%patch2 -p1
ece43ea2 788%patch3 -p1
7a3b1f24
AM
789%patch4 -p1
790%patch5 -p1
3c7590cc 791%patch6 -p1
c1768ce2 792%patch7 -p1
7a3b1f24 793%patch8 -p1
3c7590cc 794%{?with_system_lua:%patch9 -p1}
9ee75c3c 795%patch10 -p1
686b0204
JR
796%ifnarch i386 i486
797# enable TSC for capable archs
9ee75c3c 798%patch11 -p1
3c7590cc 799%endif
9ee75c3c
JR
800%patch12 -p1
801%patch13 -p1
802%patch14 -p0
7033e976 803%patch15 -p1
9ee75c3c 804%patch16 -p1
3c7590cc
JR
805%patch17 -p1
806%patch18 -p1
807%patch19 -p1
808%patch20 -p1
809%patch21 -p1
9ee75c3c 810%ifarch sparc64
3c7590cc 811%patch22 -p1
9ee75c3c 812%endif
3c7590cc 813%patch23 -p1
3c7590cc 814%patch24 -p1
3c7590cc 815%patch25 -p1
f7779567 816####%patch26 -p1
24123ddd 817%patch27 -p1
3c7590cc
JR
818%patch28 -p1
819%patch29 -p1
820%patch30 -p1
821%patch31 -p1
822%patch32 -p1
823%patch33 -p1
950eead3 824%patch34 -p1
3c7590cc 825%patch35 -p1
148c9957 826%patch36 -p1
3c7590cc
JR
827%patch37 -p1
828%patch38 -p1
829%patch39 -p1
830%patch40 -p1
f7779567 831####%patch41 -p1
9ee75c3c 832%patch42 -p1
9f9190ed 833%patch43 -p1
1d20bd4e 834%patch44 -p1
e94735a5 835%patch45 -p1
7070b427 836%patch46 -p1
358bccd1 837%patch47 -p1
7f7a3f24 838%patch48 -p1
295c267a 839%patch49 -p1
d6a36788 840%patch50 -p1
bba1059c 841%patch51 -p1
1fcc9b69 842%patch52 -p0
70df63f3 843%patch53 -p1
330093fa 844%patch54 -p1
9158f140 845%patch55 -p1
267d7641 846%patch56 -p1
f7779567 847%patch57 -p1
765b7c41 848
70f8787d
JR
849%patch1000 -p1
850%patch1001 -p1
851%patch1002 -p1
852%patch1003 -p1
853%patch1004 -p1
854%patch1005 -p1
855%patch1006 -p1
856%patch1007 -p1
857%patch1008 -p1
858%patch1009 -p1
859%patch1010 -p1
860%patch1011 -p1
861%patch1012 -p1
862%patch1013 -p1
863%patch1014 -p1
864%patch1015 -p1
865%patch1016 -p1
866%patch1017 -p1
867%patch1018 -p1
868%patch1019 -p1
869%patch1020 -p1
870%patch1021 -p1
871%patch1022 -p1
872%patch1023 -p1
873%patch1024 -p1
874%patch1025 -p1
875%patch1026 -p1
876%patch1027 -p1
877%patch1028 -p1
878%patch1029 -p1
879%patch1030 -p1
880%patch1031 -p1
881%patch1032 -p1
882%patch1033 -p1
883%patch1034 -p1
884%patch1035 -p1
885%patch1036 -p1
85771a72 886%patch1037 -p1
70f8787d 887%patch1038 -p1
9f9190ed 888%patch1039 -p1
e85b33bb 889%patch1040 -p1
5555c3a0 890%patch1041 -p1
dfd6cb49 891%patch1042 -p1
70f8787d
JR
892
893install %{SOURCE2} macros/pld.in
0bf34f68
JR
894install %{SOURCE8} scripts/php.prov.in
895install %{SOURCE9} scripts/php.req.in
896install %{SOURCE11} scripts/perl.prov.in
08697680 897
70f8787d 898%{__mv} -f scripts/perl.req{,.in}
633d1e9e 899
cd86db2e 900# generate Group translations to *.po
80b8a1f9 901awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 902
91ee86a9
JR
903install %{SOURCE26} tools/rpmdb_checkversion.c
904
87ef0d95 905%build
ea816ea6 906%{__libtoolize}
c0a9be8f 907#%{__autopoint}
ceaaacee 908%{__aclocal}
4cd84746 909%{__autoheader}
7a9d72ce 910%{__autoconf}
7a9d72ce 911%{__automake}
7a9d72ce 912
048d06f8
JR
913# rpm checks for CPU type at runtime, but it looks better
914sed -i \
915 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
916 -e 's|@host_cpu@|%{_target_cpu}|' \
917 -e 's|@host_os@|%{_target_os}|' \
3f84726d 918 macros/macros.in
048d06f8 919
d268a169 920%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 921# pass CC and CXX too in case of building with some older configure macro
624f96ff 922%configure \
f9ac32aa
AM
923 CC="%{__newcc}" \
924 CXX="%{__newcxx}" \
925 CPP="%{__newcpp}" \
01d7a578 926 WITH_PERL_VERSION=no \
bba1059c 927 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
cd86db2e 928 --enable-shared \
874f4c9a 929 --enable-static \
5c2ab5c7 930 %{!?with_apidocs:--without-apidocs} \
f3cb8244 931 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
a6e56ce4 932 %{!?with_python:--without-python} \
6e115b23
JR
933 --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
934 --with-sepol=%{!?with_selinux:not}%{?with_selinux:external} \
935 --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
241257bf
AM
936 --with-libelf \
937 --with-zlib=external \
938 --with-bzip2=external \
939 --with-beecrypt=external \
1afa05ce 940 --with-lzma=external \
77fcdbf7 941 --with-xz=external \
241257bf
AM
942 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
943 --with-file=external \
944 --with-popt=external \
afb55538 945 --with-db=%{?with_db:external}%{!?with_db:no} \
77fcdbf7 946 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
950eead3 947 --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
6a8612bc 948 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
77fcdbf7 949 --with-pcre=external \
d0ee0933 950 --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
127a0b3c 951 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
241257bf 952 --without-path-versioned \
adbd4815 953 --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
08697680
JR
954 --with-bugreport="http://bugs.pld-linux.org/" \
955 --with-vendor=pld
cf6faebc 956
25e974c7 957%{__make} -j1 \
f9ac32aa
AM
958 CC="%{__cc}" \
959 CXX="%{__cxx}" \
241257bf 960 CPP="%{__cpp}"
33be5db0 961
5c2ab5c7
AM
962%{?with_apidocs:%{__make} apidocs}
963
7ef0925f 964%{__cc} %{rpmcflags} tools/rpmdb_checkversion.c -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
91ee86a9 965
b064b8e6 966%install
ff7bc1e6 967rm -rf $RPM_BUILD_ROOT
e9eb00af 968install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 969 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 970
0bf34f68 971install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 972
a5e7fb84 973%{__make} install \
241257bf
AM
974 pkgconfigdir=%{_pkgconfigdir} \
975 DESTDIR=$RPM_BUILD_ROOT
718426e1 976
25ac75ae
AM
977# install ARCH macros
978install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
d38aed81 979install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
25ac75ae
AM
980
981%ifarch %{ix86}
982install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
d38aed81
JR
983install cpu-os-macros/athlon-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
984install cpu-os-macros/i386-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
985install cpu-os-macros/i486-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
986install cpu-os-macros/i586-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
987install cpu-os-macros/i686-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
988install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
989install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
990%endif
991
992%ifarch %{x8664}
993install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
d38aed81
JR
994install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
995install cpu-os-macros/ia32e-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
996install cpu-os-macros/amd64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
25ac75ae
AM
997%endif
998
999%ifarch %{ppc}
1000install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
d38aed81 1001install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
1002%endif
1003
2eb9303e 1004cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 1005# first platform file entry can't contain regexps
2eb9303e 1006%{_target_cpu}-%{_target_vendor}-linux
caf453d4 1007
2d8ae03e
AM
1008# x86_64 things
1009%ifarch x86_64
53fd58bc 1010x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 1011amd64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1012%endif
2d8ae03e 1013%ifarch amd64
53fd58bc
AM
1014amd64-[^-]*-[Ll]inux(-gnu)?
1015x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1016%endif
2d8ae03e 1017%ifarch ia32e
53fd58bc
AM
1018ia32e-[^-]*-[Ll]inux(-gnu)?
1019x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1020%endif
1021
1022# x86 things
06bd38df 1023%ifarch athlon %{x8664}
53fd58bc 1024athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1025%endif
06bd38df 1026%ifarch pentium4 athlon %{x8664}
53fd58bc 1027pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1028%endif
06bd38df 1029%ifarch pentium3 pentium4 athlon %{x8664}
53fd58bc 1030pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1031%endif
06bd38df 1032%ifarch i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1033i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1034%endif
06bd38df 1035%ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1036i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1037%endif
06bd38df 1038%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1039i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1040%endif
06bd38df 1041%ifarch %{ix86} %{x8664}
53fd58bc 1042i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1043%endif
1044
5074eba9 1045%ifarch alpha
53fd58bc 1046alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1047%endif
1048
1049%ifarch ia64
53fd58bc 1050ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1051%endif
1052
1053%ifarch ppc64
53fd58bc
AM
1054powerpc64-[^-]*-[Ll]inux(-gnu)?
1055ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 1056%endif
950eead3 1057%ifarch %{ppc} ppc64
53fd58bc
AM
1058powerpc-[^-]*-[Ll]inux(-gnu)?
1059ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1060%endif
1061
1062%ifarch s390x
53fd58bc 1063s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1064%endif
1065%ifarch s390 s390x
53fd58bc 1066s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1067%endif
1068
1069%ifarch sparc64
53fd58bc
AM
1070sparc64-[^-]*-[Ll]inux(-gnu)?
1071sparcv8-[^-]*-[Ll]inux(-gnu)?
1072sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1073%endif
1074%ifarch sparcv9
53fd58bc
AM
1075sparcv8-[^-]*-[Ll]inux(-gnu)?
1076sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1077%endif
1078%ifarch sparc sparcv9 sparc64
53fd58bc 1079sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1080%endif
1081
1082# noarch
2eb9303e
ER
1083noarch-[^-]*-.*
1084EOF
2d8ae03e 1085
02919de5
JK
1086rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1087rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1088rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
950eead3 1089rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
02919de5 1090
644d8958
JB
1091# not installed since 4.4.8 (-tools-perl subpackage)
1092install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1093
61f7e1b3 1094install %{SOURCE1} doc/manual/groups
d755a548 1095install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1096install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1097install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
1098install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1099install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548
JK
1100install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
1101install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
1102cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1103install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1104install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 1105install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1106
0bf34f68 1107install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1108
950eead3
ER
1109install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1110
0bf34f68 1111install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
b1541d4c 1112install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
0bf34f68
JR
1113install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1114install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1115install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1116install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1117install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep
1118install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 1119
950eead3
ER
1120touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1121touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 1122install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
1123touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1124touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1125touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1126
91ee86a9
JR
1127install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
1128
9776a251
JR
1129# create macro loading wrappers for backward compatibility
1130for m in gstreamer java mono perl php python; do
b279f099 1131 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
1132done
1133
f3fd387a 1134# for rpm -e|-U --repackage
a11e0e27
AM
1135install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1136touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1137
950eead3
ER
1138# move rpm to /bin
1139mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1140# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1141for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1142 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1143 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1144done
1145
950eead3
ER
1146# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1147mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1148
6f18cdb7
AF
1149%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1150%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1151
08697680 1152%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
01d7a578 1153
01d7a578 1154# wrong location, not used anyway
08697680 1155%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
950eead3 1156# utils dropped in 4.4.8 -- their manuals
08697680 1157%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
e86bfbff 1158# utils dropped in 5.4 -- their manuals
854562c1 1159%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1160# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1161%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1162
90b03dd6 1163%find_lang %{name}
cf6faebc 1164
08697680 1165%{__rm} -rf manual
a998ac11 1166cp -a doc/manual manual
08697680 1167%{__rm} -f manual/Makefile*
874f4c9a 1168
13eb5ebf 1169%clean
d7df46b8 1170rm -rf $RPM_BUILD_ROOT
76214164 1171
cc1a4992
ER
1172%pretrans
1173# this needs to be a dir
1174if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1175 umask 022
cc1a4992
ER
1176 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1177 mkdir %{_sysconfdir}/rpm/sysinfo
1178fi
1179
f7779567 1180%if 0
be4d3036 1181%posttrans
f7779567
JR
1182if [ ! -e /var/lib/rpm/Packages ]; then
1183 %{__rm} -f /var/lib/rpm/need_rpmdb_downgrade 2>/dev/null >/dev/null
1184 exit 0
1185fi
1186NEEDDBCONV=
1187if [ -e /var/lib/rpm/need_rpmdb_downgrade ]; then
1188 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && [ -x /bin/cp ] && \
1189 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
1190 echo
1191 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
1192 echo
1193 fi
1194 %{__rm} -f /var/lib/rpm/log/*
1195 /usr/bin/db5.2_dump /var/lib/rpm/Packages | /usr/bin/db5.2_load /var/lib/rpm/Packages.downgraded
1196 %{__mv} -f /var/lib/rpm/Packages /var/lib/rpm/Packages.rpmsave
1197 %{__mv} -f /var/lib/rpm/Packages.downgraded /var/lib/rpm/Packages
1198 NEEDDBCONV="YES"
1199fi
1200if [ -x %{_rpmlibdir}/bin/rpmdb_checkversion ] && \
6a934782
ER
1201 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
1202 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && [ -x /bin/cp ] && \
1203 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 1204 echo
e4dd6a34 1205 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
1206 echo
1207 fi
f7779567
JR
1208 NEEDDBCONV="YES"
1209fi
1210if [ "x$NEEDDBCONV" = "xYES" ]; then
4f9a73d3
ER
1211 echo 'If poldek aborts after migration with rpmdb error, this is "normal", you should ignore it'
1212
91049ef3 1213 if [ -x %{_rpmlibdir}/bin/dbconvert ]; then
6a934782 1214 if ! %{_rpmlibdir}/bin/dbconvert --rebuilddb; then
91049ef3
JR
1215 echo
1216 echo "rpm database conversion failed!"
1217 echo "You have to run %{_rpmlibdir}/bin/dbconvert manually"
1218 echo
1219 fi
1220 fi
be4d3036 1221fi
f7779567
JR
1222endif
1223
1224%triggerpostun -- %{name} > 5.0.0-1, %{name} < 5.4.10-36
1225:>/var/lib/rpm/need_rpmdb_downgrade
be4d3036 1226
cf709a39
ER
1227%triggerpostun -- %{name} < 4.4.9-44
1228%{_rpmlibdir}/hrmib-cache
1229
ceaaacee
JB
1230%post lib -p /sbin/ldconfig
1231%postun lib -p /sbin/ldconfig
76214164 1232
37a5a2fc 1233%pretrans build
d755a548 1234find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1235
3684d90f
JB
1236%files -f %{name}.lang
1237%defattr(644,root,root,755)
241257bf 1238%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1239
54eb1770
AM
1240%dir %{_sysconfdir}/pki/rpm-gpg
1241%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1242
7a9d72ce 1243%attr(755,root,root) /bin/rpm
e73478cd 1244
66edd895 1245%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 1246%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 1247%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1248# these are ok to be replaced
950eead3 1249%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1250%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1251
09bb810c 1252%{_mandir}/man8/rpm.8*
feb1f12e 1253%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1254%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 1255%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 1256%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1257%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1258%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1259
e2025ad1 1260%dir /var/lib/rpm
74a997bd
JR
1261%dir /var/lib/rpm/log
1262%dir /var/lib/rpm/tmp
1263%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1264%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1265%dir /var/lock/rpm
1266/var/lock/rpm/transaction
4acac5de 1267
cf709a39
ER
1268# exported package NVRA (stamped with install tid)
1269# net-snmp hrSWInstalledName queries, bash-completions
1270%dir /var/cache/hrmib
1271
ec44785a 1272%{_rpmlibdir}/qf
d755a548
JK
1273%{_rpmlibdir}/rpmpopt*
1274%{_rpmlibdir}/macros
08697680
JR
1275%dir %{_rpmlibdir}/macros.d
1276%{_rpmlibdir}/macros.d/pld
9282ffe4 1277%{_rpmlibdir}/cpuinfo.yaml
3684d90f 1278
cf709a39
ER
1279%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1280
df50421f
JR
1281%dir %{_rpmlibdir}/bin
1282%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
91ee86a9 1283%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
df50421f 1284
66edd895
JB
1285%files base
1286%defattr(644,root,root,755)
492a2bd4 1287%dir %{_sysconfdir}/rpm
66edd895
JB
1288%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1289%dir %{_rpmlibdir}
1290%attr(755,root,root) %{_bindir}/banner.sh
df50421f 1291%attr(755,root,root) %{_bindir}/multiarch-dispatch
66edd895
JB
1292%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1293%dir /var/lib/banner
1294
874f4c9a
MM
1295%files lib
1296%defattr(644,root,root,755)
950eead3
ER
1297%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1298%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1299%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1300%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1301%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1302%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1303
69131f1a
JB
1304%files devel
1305%defattr(644,root,root,755)
69131f1a
JB
1306%attr(755,root,root) %{_libdir}/librpm.so
1307%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1308%attr(755,root,root) %{_libdir}/librpmbuild.so
1309%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1310%attr(755,root,root) %{_libdir}/librpmconstant.so
1311%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1312%attr(755,root,root) %{_libdir}/librpmdb.so
1313%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1314%attr(755,root,root) %{_libdir}/librpmio.so
1315%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1316%attr(755,root,root) %{_libdir}/librpmmisc.so
1317%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1318%{_libdir}/librpm*.la
1319%{_includedir}/rpm
df50421f 1320%{_includedir}/multiarch-dispatch.h
950eead3 1321%{_pkgconfigdir}/*.pc
69131f1a
JB
1322
1323%files static
1324%defattr(644,root,root,755)
1325%{_libdir}/librpm*.a
1326
1327%files utils
1328%defattr(644,root,root,755)
69131f1a 1329%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1330%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1331%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1332%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1333%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1334%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1335%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1336%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1337%attr(755,root,root) %{_rpmlibdir}/bin/find
1338%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1339%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1340%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1341%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1342%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1343%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
6e115b23
JR
1344%if %{with selinux}
1345%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1346%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1347%endif
70df63f3
JR
1348%if %{without system_lua}
1349%attr(755,root,root) %{_rpmlibdir}/bin/lua
1350%attr(755,root,root) %{_rpmlibdir}/bin/luac
1351%attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1352%attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1353%endif
d0ee0933 1354%{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
9282ffe4 1355%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1356%{_mandir}/man8/rpm2cpio.8*
950eead3 1357%{_mandir}/man8/rpmcache.8*
ec44785a 1358%{_mandir}/man8/rpmconstant.8*
69131f1a 1359%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1360%{_mandir}/man8/rpmmtree.8*
69131f1a 1361%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
950eead3 1362%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
69131f1a
JB
1363%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1364%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
950eead3 1365%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
69131f1a 1366%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1367%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1368
1369%files utils-perl
1370%defattr(644,root,root,755)
1371%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1372
1373%if %{with static}
1374%files utils-static
1375%defattr(644,root,root,755)
1376%attr(755,root,root) %{_bindir}/rpm[ieu]
1377%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1378%endif
1379
3684d90f 1380%files build
a45ae6d8 1381%defattr(644,root,root,755)
66edd895 1382%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1383%attr(755,root,root) %{_rpmlibdir}/brp-*
1384%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1385%attr(755,root,root) %{_rpmlibdir}/compress-doc
1386%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1387%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1388%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1389%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1390%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1391%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1392%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1393%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1394# needs hacked pkg-config to return anything
1395%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1396%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1397%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
77fcdbf7
AF
1398%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1399%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f
JR
1400%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1401%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1402%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1403%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1404%attr(755,root,root) %{_rpmlibdir}/vcheck
d755a548 1405%{_rpmlibdir}/noarch-*
e9fe9fc5 1406%ifarch %{ix86}
d755a548 1407%{_rpmlibdir}/i?86*
e9fe9fc5 1408%{_rpmlibdir}/pentium*
d755a548
JK
1409%{_rpmlibdir}/athlon*
1410%endif
ad628734
JB
1411%ifarch alpha
1412%{_rpmlibdir}/alpha*
1413%endif
ad628734
JB
1414%ifarch ia64
1415%{_rpmlibdir}/ia64*
8f76a271 1416%endif
410dd742 1417%ifarch mips mipsel mips64 mips64el
1418%{_rpmlibdir}/mips*
1419%endif
80e9f34d 1420%ifarch %{ppc}
410dd742 1421%{_rpmlibdir}/ppc*
1422%endif
1423%ifarch sparc sparc64
1424%{_rpmlibdir}/sparc*
1425%endif
9f517079 1426%ifarch %{x8664}
206b32be
JB
1427%{_rpmlibdir}/amd64*
1428%{_rpmlibdir}/ia32e*
cedf1bfa
PS
1429%{_rpmlibdir}/x86_64*
1430%endif
410dd742 1431# not used yet ... these six depend on perl
ec44785a 1432%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1433# we always used scripts provided by mono-devel, maybe move them here
1434#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1435#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1436
70f8787d 1437%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1438# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1439%{_rpmlibdir}/macros.d/cmake
1440%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7 1441%{_rpmlibdir}/macros.d/java
df50421f 1442%{_rpmlibdir}/macros.d/kernel
77fcdbf7
AF
1443%{_rpmlibdir}/macros.d/libtool
1444%{_rpmlibdir}/macros.d/mono
1445%{_rpmlibdir}/macros.d/perl
1446%{_rpmlibdir}/macros.d/php
1447%{_rpmlibdir}/macros.d/pkgconfig
1448%{_rpmlibdir}/macros.d/python
df50421f 1449%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1450%{_rpmlibdir}/macros.d/selinux
df50421f 1451%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1452%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1453# compat wrappers
1454%{_rpmlibdir}/macros.gstreamer
1455%{_rpmlibdir}/macros.java
1456%{_rpmlibdir}/macros.mono
1457%{_rpmlibdir}/macros.perl
1458%{_rpmlibdir}/macros.php
1459%{_rpmlibdir}/macros.python
77fcdbf7 1460
df50421f
JR
1461%attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
1462%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1463%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1464%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1465%attr(755,root,root) %{_rpmlibdir}/mkmultiarch
df50421f
JR
1466%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1467
874f4c9a 1468%attr(755,root,root) %{_bindir}/gendiff
df50421f 1469%attr(755,root,root) %{_bindir}/multiarch-platform
874f4c9a 1470%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1471
1472%dir %{_rpmlibdir}/helpers
1473%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1474
a00926bc 1475%{_mandir}/man1/gendiff.1*
874f4c9a 1476%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1477%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1478%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1479%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1480
7d8492bb
JB
1481%files javaprov
1482%defattr(644,root,root,755)
1483%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1484# needs jar (any jdk), jcf-dump (gcc-java) to work
1485%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1486
89334051
AF
1487%files perlprov
1488%defattr(644,root,root,755)
d755a548 1489%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1490%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1491%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1492
80d3b868 1493%files pythonprov
d8fcb9b0 1494%defattr(644,root,root,755)
bdbae303 1495%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1496%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1497
d36cb682
PG
1498%files php-pearprov
1499%defattr(644,root,root,755)
d755a548
JK
1500%attr(755,root,root) %{_rpmlibdir}/php*
1501%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1502
50dc9ac0 1503%if %{with python}
cf6faebc 1504%files -n python-rpm
42a0025c 1505%defattr(644,root,root,755)
b33910fe 1506%dir %{py_sitedir}/rpm
6f18cdb7 1507%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1508%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1509%endif
5c2ab5c7
AM
1510
1511%if %{with apidocs}
1512%files apidocs
1513%defattr(644,root,root,755)
1514%doc apidocs
1515%endif
This page took 0.747699 seconds and 4 git commands to generate.