]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- condition to enable TSC has been reverted just for us, so update patch
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
317ef122 3# - check if glob() patch needs resurrecting/rewriting
9dce4e74 4# - check if we want shell autodeps: Requires: executable(ln) executable(mv)
2d806774 5# - %{_arch} = i686 not as used to be i386 (platform file thing?):
afbcf91a
ER
6# 5.0.2: rpm -E '%_target_base_arch %_arch'
7# i386 i686
8# 4.4.9: rpm -E '%_target_base_arch %_arch'
9# i386 i386
644d8958
JB
10# - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
11# matches ELF first
9fb5ee9e 12# - add macros for some ppc, mipsel, alpha and sparc
10abbd40 13#
76005b82 14# - headerGet() making poldek segfault http://rpm5.org/cvs/tktview?tn=38,1
76005b82 15# - rpm doesn't exit when no sources/patches available http://rpm5.org/cvs/tktview?tn=40,1
6664e05e 16# - http://rpm5.org/cvs/tktview?tn=41&_submit=Show
c296fee0 17# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 18#
89427592 19# Conditional build:
01d7a578 20%bcond_with static # build static rpm+rpmi
0a1ccab0 21%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
22%bcond_without python # don't build python bindings
23%bcond_without selinux # build without selinux support
0dc47449 24%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
77fcdbf7 25%bcond_without neon # build with HTTP/WebDAV support (neon library)
858aa7d0 26%bcond_without db # BerkeleyDB
77fcdbf7 27%bcond_without sqlite # build with SQLite support
858aa7d0 28%bcond_with sqlite_dbapi # default database backend is sqlite
7564deb4 29%bcond_without system_lua # use system lua
89427592
JB
30# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
31# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
32# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0
AM
33#
34%if %{with sqlite_dbapi}
35%define with_sqlite 1
36%endif
54bfdf99 37
858aa7d0 38%if %{without db} && %{without sqlite}
25ac75ae 39%{error:Need db or sqlite}
858aa7d0
AM
40ERROR
41%endif
42
003a039e 43# versions of required libraries
afb55538 44%define reqdb_ver 5.3
ec44785a 45%define reqpopt_ver 1.15
fc60c9f3 46%define beecrypt_ver 2:4.1.2-4
70f8787d 47%define sover 5.4
fc60c9f3 48
e5f02e49 49Summary: RPM Package Manager
4ea2ed33
ER
50Summary(de.UTF-8): RPM Packet-Manager
51Summary(es.UTF-8): Gestor de paquetes RPM
52Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
53Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
54Summary(ru.UTF-8): Менеджер пакетов от RPM
55Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 56Name: rpm
afb55538 57Version: 5.4.10
9282ffe4 58Release: 0.1
b0434f77 59License: LGPL
76214164 60Group: Base
afb55538
JR
61# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
62Source0: %{name}-%{version}.tar.gz
63# Source0-md5: 5d099161bdd3203265ab32ffad3360b5
d38aed81
JR
64Source100: cpu-os-macros.tar.gz
65# Source100-md5: 928034a5bdceb398881bc14b5f29973b
ff7bc1e6 66Source1: %{name}.groups
08697680 67Source2: macros.pld.in
ff7bc1e6 68Source3: %{name}-install-tree
80b8a1f9 69Source4: %{name}-find-spec-bcond
cf709a39 70Source5: %{name}-hrmib-cache
80b8a1f9
JB
71Source6: %{name}-groups-po.awk
72Source7: %{name}-compress-doc
80b8a1f9
JB
73Source9: %{name}-php-provides
74Source10: %{name}-php-requires
fbc0ff35 75Source11: %{name}.sysinfo
80b8a1f9 76Source12: perl.prov
d0370fe5 77Source13: %{name}-user_group.sh
78Source14: %{name}.sysconfig
1f625675 79Source16: %{name}-java-requires
a4b7ef27 80# http://svn.pld-linux.org/banner.sh/
1c2e2d8e 81Source17: banner.sh
54eb1770 82Source19: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
317ef122 83# Source19-md5: 08b29584dd349aac9caa7610131a0a88
c75b3936 84Source20: %{name}-mimetypedeps
08697680
JR
85Source21: macros.local
86Source22: rpm.noautocompressdoc
87Source23: rpm.noautoprov
88Source24: rpm.noautoprovfiles
89Source25: rpm.noautoreq
90Source26: rpm.noautoreqdep
91Source27: rpm.noautoreqfiles
f15af52e 92Source29: %{name}-php-requires.php
25ac75ae 93
f05db907 94Patch0: %{name}-branch.patch
2f0ee4ec 95Patch1: %{name}-man_pl.patch
38e53563 96Patch2: %{name}-popt-aliases.patch
b174986a 97Patch3: %{name}-rpmpopt.patch
3465efba 98Patch4: %{name}-perl-macros.patch
c1768ce2 99Patch5: %{name}-perl-req-perlfile.patch
f14234e4 100Patch7: %{name}-scripts-closefds.patch
7a3b1f24 101Patch8: %{name}-php-macros.patch
f14234e4 102Patch9: %{name}-gettext-in-header.patch
6a8612bc 103Patch11: %{name}-lua.patch
7a3b1f24 104
f14234e4 105Patch14: %{name}-etc_dir.patch
f14234e4 106Patch16: %{name}-php-deps.patch
32d103b5 107Patch19: %{name}-glob.patch
7a3b1f24 108
f14234e4
JB
109Patch26: %{name}-notsc.patch
110Patch27: %{name}-hack-norpmlibdep.patch
7a3b1f24 111
950eead3 112Patch34: %{name}-epoch0.patch
f14234e4
JB
113Patch35: %{name}-perl_req-INC_dirs.patch
114Patch36: %{name}-debuginfo.patch
7a3b1f24 115
9282ffe4
AF
116Patch41: vendor-pld.patch
117
bb98669b 118Patch42: %{name}-old-fileconflicts-behaviour.patch
644d8958 119
8482995c 120Patch47: %{name}-javadeps.patch
fbc0ff35 121
d6080f70 122Patch55: %{name}-truncate-cvslog.patch
644d8958 123
59a562c2 124Patch59: %{name}-libtool-deps.patch
c75b3936 125Patch60: %{name}-mimetype.patch
7ffa7946 126Patch61: %{name}-sparc64.patch
7f26883c 127Patch62: %{name}-gendiff.patch
77fcdbf7 128Patch72: openmp.patch
a3809792
JR
129Patch73: %{name}-URPM-build-fix.patch
130Patch74: %{name}-db5.3.patch
131Patch75: %{name}-helperEVR-noassert.patch
132Patch76: %{name}-unglobal.patch
133Patch77: %{name}-builddir-readlink.patch
134Patch78: %{name}-changelog_order_check_nonfatal.patch
135Patch79: %{name}-cleanbody.patch
136Patch80: %{name}-dirdeps-macro.patch
137Patch81: %{name}-installbeforeerase.patch
138Patch82: %{name}-libmagic-locale.patch
139Patch83: %{name}-namespace-probe.patch
140Patch84: %{name}-popt-coreutils.patch
141Patch85: %{name}-postun-nofail.patch
70f8787d
JR
142
143# Patches imported from Mandriva
144
145# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
146# would basically just mean backporting it..
147Patch1000: rpm-5.4.4-add-_specfile-macro.patch
148# status: needs to be cleaned up and properly reviewed together with rest
149# of the patches related to dependency generation
150Patch1001: rpm-5.4.9-avoid-dependencies-on-self.patch
151# status: probably ready to merge
152Patch1002: rpm-5.4.4-pkgconfigdeps-check-path.patch
153# status: probably okay to merge, but discuss on rpm-devel first
154Patch1003: rpm-5.4.4-glob-wildcards-for-loading-macro-files.patch
155# status: needs to be discussed
156Patch1004: rpm-5.4.4-allow-installation-of-repackaged-rpms.patch
157# status: ready to merge
158Patch1005: rpm-5.4.8-dont-show-suggests-with-requires.patch
159# status: ready for merge
160Patch1006: rpm-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
161# status: probably okay to merge, but discuss on rpm-devel first
162Patch1007: rpm-5.4.10-duplicate_files_terminate_build.patch
163# status: same as above
164Patch1008: rpm-5.4.10-unpackaged_subdirs_terminate_build.patch
165# mdvbz#64898
166# status: uncertain, might be okay to merge, discuss on rpm-devel first
167Patch1009: rpm-5.4.4-rpmbuild-withoutclean.patch
168# no sense in having an additional dependency on 'pkgconfig' on all packages that
169# have a pkgconfig file, it's not needed for them to be made useful and anything
170# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
171# status: might be okay to merge, but discuss on rpm-devel first
172Patch1010: rpm-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
173# status: ready for merge
174Patch1011: rpm-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
175# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
176# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
177# status: needs to be discussed and investigated a bit better..
178Patch1012: rpm-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
179# status: probably okay to merge, but discuss on rpm-devel first
180Patch1013: rpm-5.4.10-files-listed-twice-terminates-build.patch
181# status: probably okay to merge
182Patch1014: rpm-5.4.9-ruby1.9-fixes.patch
183# status: keep locally
184Patch1015: rpm-5.4.9-keep-loading-script-macros.patch
185# status: same as for other dep gen patches
186Patch1016: rpm-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
187# status: idem
188Patch1017: rpm-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
189# status: ready for merge
190Patch1018: rpm-5.4.5-rubygems-add-missing-newline.patch
191# status: probably okay to merge
192Patch1019: rpm-5.4.5-python-export-spec-macros.patch
193# status: idem
194Patch1020: rpm-5.4.9-font-provides.patch
195# stauus: idem
196Patch1021: rpm-5.4.7-kmod-dependencies.patch
197# status: probably okay to merge, discuss on rpm-devel first
198Patch1022: rpm-5.4.5-skip-dependencies-for-character-devices.patch
199# status: ready to merge
200Patch1023: rpm-5.4.5-rpmfc-use-strlen-not-sizeof.patch
201# status: probably okay to merge
202Patch1024: rpm-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
203# status: ready to merge
204Patch1025: rpm-5.4.7-rpmfc-fix-invalid-free-if-not-_defaultdocdir-set.patch
205# status: probably okay to merge
206Patch1026: rpm-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
207# status: ready
208Patch1027: rpm-5.4.7-fix-generation-of-ruby-abi-provides.patch
209# crash reproducable with 'rpm -qa --triggers'
210# status: ready
211Patch1028: rpm-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
212# status: same as for other dep gen patches
213Patch1029: rpm-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
214# status: ready
215Patch1030: rpm-5.4.7-fix-minor-memleaks.patch
216# status: ready
217Patch1031: rpm-5.4.9-mire-fix-strings-lacking-null-terminator.patch
218# status: ready
219Patch1032: rpm-5.4.9-rpmpython-fix-input.patch
220# status: ready
221Patch1033: rpm-5.4.7-no-seqid_init-on-rdonly-database.patch
222# status: probably ready for merging
223Patch1034: rpm-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
224# status: probably ready to merge, discuss on rpm-devel first
225Patch1035: rpm-5.4.9-fix-verify-segfault.patch
226# status: ready and should be merged
227Patch1036: rpm-5.4.9-fix-typo-in-rpmtag-header.patch
228# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
229# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
230# with the result being that when unable to download files, neon will save error
231# page as the target file.
232# status: should go upstream, but uncertain about "correct" fix, ie. this is
233# more of a workaround, while rewriting rpmdav code to behave consistently
234# would be "the right thing to do". Yet I'm not fully able to grasp all of the
235# code and don't want to spend more time just to get the API..
236Patch1037: rpm-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
237# As the transaction flags for ignoring arch & os are no longer used, there's
238# currently no way to ignore arch & os of packages anymore. This patch adds
239# support for doing this again by defining rpm variables and overriding
240# --ignorearch & --ignoreos to set these.
241# status: needs to be discussed upstream before thinking about merging
242Patch1038: rpm-5.4.10-support-ignore-arch-and-os-again.patch
243
955f2725 244URL: http://rpm5.org/
6a8612bc 245BuildRequires: autoconf >= 2.60
644d8958 246BuildRequires: automake >= 1.4
87ef0d95 247BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 248BuildRequires: bzip2-devel >= 1.0.2-17
858aa7d0 249%{?with_db:BuildRequires: db-devel >= %{reqdb_ver}}
33be5db0 250BuildRequires: elfutils-devel >= 0.108
0ef6aeae 251#BuildRequires: gettext-autopoint >= 0.11.4-2
d1795eb0 252BuildRequires: gettext-devel >= 0.11.4-2
f7100a40 253BuildRequires: keyutils-devel
241257bf 254BuildRequires: libmagic-devel
8e159d42 255%{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
84cdee7a
JB
256# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
257BuildRequires: libstdc++-devel
b60c74c3 258BuildRequires: libtool >= 1:1.4.2-9
33be5db0 259%if %{with neon}
fe861705 260BuildRequires: libxml2-devel
83d6a3fe 261BuildRequires: neon-devel >= 0.25.5
33be5db0 262%endif
7973b351 263BuildRequires: patch >= 2.2
1d49ffbc 264BuildRequires: popt-devel >= %{reqpopt_ver}
6a8612bc 265%{?with_system_lua:BuildRequires: lua51-devel >= 5.1.2}
950eead3
ER
266%{?with_python:BuildRequires: python-devel >= 1:2.3}
267BuildRequires: python-modules >= 1:2.3
2a813afe 268%{?with_python:BuildRequires: rpm-pythonprov}
241257bf 269%{?with_sqlite:BuildRequires: sqlite3-devel}
e56a10a9 270BuildRequires: tcl
874f4c9a 271BuildRequires: zlib-devel
77fcdbf7 272BuildRequires: xz-devel
5c2ab5c7
AM
273%if %{with apidocs}
274BuildRequires: doxygen
275BuildRequires: ghostscript
276BuildRequires: graphviz
277BuildRequires: tetex-pdftex
278%endif
a6e56ce4 279%if %{with static}
e6090a7b 280# Require static library only for static build
87ef0d95 281BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 282BuildRequires: bzip2-static >= 1.0.2-17
858aa7d0 283%{?with_db:BuildRequires: db-static >= %{reqdb_ver}}
290c1c30 284BuildRequires: elfutils-static
10abbd40 285BuildRequires: glibc-static >= 2.2.94
241257bf 286BuildRequires: libmagic-static
8e159d42 287%{?with_selinux:BuildRequires: libselinux-static >= 1.18}
003a039e 288BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 289BuildRequires: zlib-static
7a9d72ce 290%endif
66edd895 291Requires: %{name}-base = %{version}-%{release}
b26a9709 292Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
293Requires: beecrypt >= %{beecrypt_ver}
294Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
295Provides: rpm-db-ver = %{reqdb_ver}
296Obsoletes: rpm-getdeps
4adb7d05 297%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 298Conflicts: glibc < 2.2.92
8ee1c72c
AM
299# db4.6 poldek needed
300Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
301# segfaults with lzma 0.42.2
302Conflicts: lzma-libs < 4.999.3
1d49ffbc 303BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 304
4adb7d05
JB
305%define _binary_payload w9.gzdio
306%define _noPayloadPrefix 1
6d82b332 307
4cd84746
JB
308# don't require very fresh rpm.macros to build
309%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 310%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 311%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 312%define ppc ppc ppc7400 ppc7450
9f517079 313%define x8664 amd64 ia32e x86_64
4cd84746 314
89427592 315# stabilize new build environment
f9ac32aa
AM
316%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
317%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
318%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 319
d755a548 320%define _rpmlibdir /usr/lib/rpm
950eead3 321%define _noautocompressdoc RPM-GPG-KEY
d755a548 322
573e40e1
PS
323%define specflags -fno-strict-aliasing
324
ff7bc1e6 325%description
326RPM is a powerful package manager, which can be used to build,
327install, query, verify, update, and uninstall individual software
cf6faebc 328packages. A package consists of an archive of files, and package
fed73700 329information, including name, version, and description.
330
dd85fadc
JR
331%description -l de.UTF-8
332RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 333Installation, Anfrage, Verifizierung, Aktualisierung und
334Uninstallation individueller Softwarepakete. Ein Paket besteht aus
335einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 336Beschreibung.
337
dd85fadc 338%description -l es.UTF-8
313a4d1a 339RPM es un poderoso administrador de paquetes, que puede ser usado para
340construir, instalar, pesquisar, verificar, actualizar y desinstalar
341paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
342almacenaje de archivos, y información sobre el paquete, incluyendo
343nombre, versión y descripción.
344
345%description -l pl.UTF-8
346RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
347przebudowanie, instalację czy weryfikację dowolnego pakietu.
348Informacje dotyczące każdego pakietu, takie jak jego opis, lista
349plików wchodzących w skład pakietu, zależności od innych pakietów, są
350przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 351odpytywania programu rpm.
352
dd85fadc
JR
353%description -l pt_BR.UTF-8
354RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 355construir, instalar, pesquisar, verificar, atualizar e desinstalar
356pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
357arquivos e informações adicionais, incluindo nome, versão e descrição
358do pacote, permissões dos arquivos, etc.
359
360%description -l ru.UTF-8
361RPM - это мощный менеджер пакетов, который может быть использован для
362создания, инсталляции, запросов (query), проверки, обновления и
363удаления программных пакетов. Пакет состоит из файлового архива и
364служебной информации, включающей название, версию, описание и другие
365данные о пакете.
366
367%description -l uk.UTF-8
368RPM - це потужний менеджер пакетів, що може бути використаний для
369створення, інсталяції, запитів (query), перевірки, поновлення та
370видалення програмних пакетів. Пакет складається з файлового архіву та
371службової інформації, що містить назву, версію, опис та іншу
372інформацію про пакет.
7c6dc55f 373
66edd895
JB
374%package base
375Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 376Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 377Group: Base
1d9ca0c1 378Requires: filesystem
950eead3 379Obsoletes: rpm-scripts
66edd895
JB
380Obsoletes: vserver-rpm
381
382%description base
383The RPM base package contains scripts used by rpm packages themselves.
384These include:
385- scripts for adding/removing groups and users needed for rpm
386 packages,
387- banner.sh to display %%banner messages from rpm scriptlets.
388
dd85fadc
JR
389%description base -l pl.UTF-8
390Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 391Zawiera on:
dd85fadc
JR
392- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
393- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 394
69131f1a
JB
395%package lib
396Summary: RPMs library
4ea2ed33 397Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 398Group: Libraries
33be5db0 399Requires: beecrypt >= %{beecrypt_ver}
858aa7d0 400%{?with_db:Requires: db >= %{reqdb_ver}}
241257bf 401Requires: libmagic >= 1.15-2
d1795eb0 402%{?with_selinux:Requires: libselinux >= 1.18}
69131f1a 403Requires: popt >= %{reqpopt_ver}
d1795eb0 404Obsoletes: rpm-libs
69131f1a
JB
405# avoid SEGV caused by mixed db versions
406Conflicts: poldek < 0.18.1-16
407
408%description lib
409RPMs library.
410
dd85fadc 411%description lib -l pl.UTF-8
69131f1a
JB
412Biblioteki RPM-a.
413
fed73700 414%package devel
3f2d796a 415Summary: Header files for rpm libraries
4ea2ed33
ER
416Summary(de.UTF-8): Header-Dateien für rpm Libraries
417Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
418Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
419Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
420Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
421Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 422Group: Development/Libraries
153e5706 423Requires: %{name}-lib = %{version}-%{release}
87ef0d95 424Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 425Requires: bzip2-devel
858aa7d0 426%{?with_db:Requires: db-devel >= %{reqdb_ver}}
5c583f90 427Requires: elfutils-devel
f7100a40 428Requires: keyutils-devel
241257bf 429Requires: libmagic-devel
10abbd40 430%{?with_selinux:Requires: libselinux-devel}
a998ac11 431Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 432Requires: zlib-devel
cf6faebc 433
434%description devel
3f2d796a
JB
435The RPM packaging system includes C libraries that make it easy to
436manipulate RPM packages and databases. They are intended to ease the
cf6faebc 437creation of graphical package managers and other tools that need
3f2d796a
JB
438intimate knowledge of RPM packages. This package contains header files
439for these libraries.
fed73700 440
dd85fadc
JR
441%description devel -l de.UTF-8
442Der RPM-Packensystem enthält eine C-Library, die macht es einfach
443RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 444Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 445Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
446
dd85fadc 447%description devel -l es.UTF-8
313a4d1a 448El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
449fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
450facilitar la creación de administradores gráficos de paquetes y otras
20f89981 451herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 452
dd85fadc
JR
453%description devel -l pl.UTF-8
454System RPM zawiera biblioteki C, które ułatwiają manipulowanie
455pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
456graficznych programów zarządzających pakietami oraz innych narzędzi,
457które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
458zawiera pliki nagłówkowe wspomnianych bibliotek.
459
460%description devel -l pt_BR.UTF-8
461O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
462a manipulação de pacotes e bases de dados RPM. Seu objetivo é
463facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 464ferramentas que precisem de conhecimento profundo de pacotes RPM.
465
dd85fadc
JR
466%description devel -l ru.UTF-8
467Система управления пакетами RPM содержит библиотеку C, которая
468упрощает манипуляцию пакетами RPM и соответствующими базами данных.
469Эта библиотека предназначена для облегчения создания графических
470пакетных менеджеров и других утилит, которым необходимо работать с
471пакетами RPM.
7c6dc55f 472
dd85fadc
JR
473%description devel -l uk.UTF-8
474Система керування пакетами RPM містить бібліотеку C, котра спрощує
475роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
476призначена для полегшення створення графічних пакетних менеджерів та
477інших утиліт, що працюють з пакетами RPM.
7c6dc55f 478
fed73700 479%package static
9e42d68a 480Summary: RPM static libraries
4ea2ed33
ER
481Summary(de.UTF-8): RPMs statische Libraries
482Summary(pl.UTF-8): Biblioteki statyczne RPM-a
483Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
484Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
485Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 486Group: Development/Libraries
153e5706 487Requires: %{name}-devel = %{version}-%{release}
87ef0d95 488Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 489Requires: bzip2-static
858aa7d0 490%{?with_db:Requires: db-static >= %{reqdb_ver}}
ff03e01a 491Requires: elfutils-static
f7100a40 492Requires: keyutils-static
241257bf 493Requires: libmagic-static
a998ac11 494Requires: popt-static >= %{reqpopt_ver}
df76dbd9 495Requires: zlib-static
edacdf8f 496
497%description static
20f89981 498RPM static libraries.
fed73700 499
dd85fadc 500%description static -l de.UTF-8
20f89981 501RPMs statische Libraries.
9e42d68a 502
dd85fadc 503%description static -l pl.UTF-8
0a7ae9bc 504Biblioteki statyczne RPM-a.
313a4d1a 505
dd85fadc
JR
506%description static -l pt_BR.UTF-8
507Bibliotecas estáticas para desenvolvimento.
edacdf8f 508
dd85fadc
JR
509%description static -l ru.UTF-8
510Система управления пакетами RPM содержит библиотеку C, которая
511упрощает манипуляцию пакетами RPM и соответствующими базами данных.
512Это статическая библиотека RPM.
7c6dc55f 513
dd85fadc
JR
514%description static -l uk.UTF-8
515Система керування пакетами RPM містить бібліотеку C, котра спрощує
516роботу з пакетами RPM та відповідними базами даних. Це статична
517бібліотека RPM.
7c6dc55f 518
fed73700 519%package utils
8482995c 520Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
521Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
522Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 523Group: Applications/File
153e5706 524Requires: %{name} = %{version}-%{release}
a998ac11 525Requires: popt >= %{reqpopt_ver}
86b85368
AG
526%if %{with suggest_tags}
527Suggests: bzip2
528Suggests: gzip
86b85368 529%endif
695e60ad 530Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 531
532%description utils
8482995c 533Additional utilities for managing RPM packages and database.
fed73700 534
dd85fadc
JR
535%description utils -l de.UTF-8
536Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 537
dd85fadc
JR
538%description utils -l pl.UTF-8
539Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 540
92b3f576 541%package utils-perl
8482995c 542Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
543Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
544Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 545Group: Applications/File
153e5706 546Requires: %{name}-utils = %{version}-%{release}
92b3f576 547Requires: popt >= %{reqpopt_ver}
548
549%description utils-perl
8482995c 550Additional utilities for managing RPM packages and database.
92b3f576 551
dd85fadc
JR
552%description utils-perl -l de.UTF-8
553Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 554
dd85fadc
JR
555%description utils-perl -l pl.UTF-8
556Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 557
a00926bc
JB
558%package utils-static
559Summary: Static rpm utilities
4ea2ed33 560Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 561Group: Applications/System
153e5706 562Requires: %{name} = %{version}-%{release}
a00926bc
JB
563
564%description utils-static
565Static rpm utilities for repairing system in case something with
566shared libraries used by rpm become broken. Currently it contains rpmi
567binary, which can be used to install/upgrade/remove packages without
568using shared libraries (well, in fact with exception of NSS modules).
569
dd85fadc
JR
570%description utils-static -l pl.UTF-8
571Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
572związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
573Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
574uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
575(z wyjątkiem modułów NSS).
a00926bc 576
fed73700 577%package build
e191287c 578Summary: Scripts for building binary RPM packages
4ea2ed33
ER
579Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
580Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
581Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
582Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
583Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 584Group: Applications/File
8f76a271 585Requires(pre): findutils
950eead3 586Requires: %{name}-build-macros >= 1.433-2
153e5706 587Requires: %{name}-utils = %{version}-%{release}
e191287c 588Requires: /bin/id
589Requires: awk
cfa7898a 590Requires: bzip2
e950a6d7 591Requires: chrpath >= 0.10-4
b6547e10 592Requires: cpio
e191287c 593Requires: diffutils
195f647c 594Requires: elfutils
583135b4 595Requires: file >= 4.17
e191287c 596Requires: fileutils
597Requires: findutils
950eead3
ER
598%ifarch athlon
599Requires: gcc >= 3.0.3
600%else
601Requires: gcc
602%endif
e191287c 603Requires: glibc-devel
604Requires: grep
605Requires: gzip
606Requires: make
607Requires: patch
e191287c 608Requires: sed
609Requires: sh-utils
610Requires: tar
611Requires: textutils
ca3648b1 612Provides: rpmbuild(monoautodeps)
37ea389a 613Provides: rpmbuild(noauto) = 3
02d17bf9 614%ifarch %{x8664}
195f647c
JB
615Conflicts: automake < 1:1.7.9-2
616Conflicts: libtool < 2:1.5-13
617%endif
0096c5cd 618
e2025ad1 619%description build
58399c37 620Scripts for building binary RPM packages.
fed73700 621
dd85fadc
JR
622%description build -l de.UTF-8
623Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 624
dd85fadc
JR
625%description build -l pl.UTF-8
626Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 627
dd85fadc
JR
628%description build -l pt_BR.UTF-8
629Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 630construir pacotes usando o RPM.
e73478cd 631
dd85fadc
JR
632%description build -l ru.UTF-8
633Различные вспомогательные скрипты и исполняемые программы, которые
634используются для сборки RPM'ов.
7c6dc55f 635
dd85fadc
JR
636%description build -l uk.UTF-8
637Різноманітні допоміжні скрипти та утиліти, які використовуються для
638побудови RPM'ів.
7c6dc55f 639
8482995c
JB
640%package javaprov
641Summary: Additional utilities for checking Java provides/requires in RPM packages
642Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
643Group: Applications/File
644Requires: %{name} = %{version}-%{release}
645Requires: file
646Requires: findutils >= 1:4.2.26
647Requires: mktemp
648Requires: unzip
649
650%description javaprov
651Additional utilities for checking Java provides/requires in RPM
652packages.
653
654%description javaprov -l pl.UTF-8
655Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
656RPM.
657
69131f1a 658%package perlprov
8482995c 659Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 660Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 661Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
662Group: Applications/File
663Requires: %{name} = %{version}-%{release}
664Requires: perl-devel
665Requires: perl-modules
666
667%description perlprov
8482995c 668Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
669packages.
670
dd85fadc
JR
671%description perlprov -l de.UTF-8
672Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 673
dd85fadc 674%description perlprov -l pl.UTF-8
8482995c
JB
675Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
676pakietach RPM.
69131f1a
JB
677
678%package pythonprov
8482995c
JB
679Summary: Python macros, which simplifies creation of RPM packages with Python software
680Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
681Group: Applications/File
682Requires: %{name} = %{version}-%{release}
cd800b3c 683Requires: python
243c6264 684Requires: python-modules
bdbae303 685Requires: python-distribute
69131f1a
JB
686
687%description pythonprov
8482995c 688Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
689software.
690
dd85fadc 691%description pythonprov -l pl.UTF-8
8482995c 692Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
693Pythonie.
694
695%package php-pearprov
8482995c
JB
696Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
697Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
698Group: Applications/File
699Requires: %{name} = %{version}-%{release}
632f1b5c 700Requires: sed >= 4.0
69131f1a
JB
701
702%description php-pearprov
8482995c 703Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
704packages.
705
dd85fadc 706%description php-pearprov -l pl.UTF-8
8482995c
JB
707Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
708pakietach RPM.
69131f1a
JB
709
710%package -n python-rpm
711Summary: Python interface to RPM library
4ea2ed33
ER
712Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
713Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
714Group: Development/Languages/Python
715Requires: %{name} = %{version}-%{release}
716%pyrequires_eq python
717Obsoletes: rpm-python
718
719%description -n python-rpm
720The rpm-python package contains a module which permits applications
721written in the Python programming language to use the interface
722supplied by RPM (RPM Package Manager) libraries.
723
724This package should be installed if you want to develop Python
725programs that will manipulate RPM packages and databases.
726
dd85fadc
JR
727%description -n python-rpm -l pl.UTF-8
728Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
729Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 730
dd85fadc
JR
731Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
732Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 733
dd85fadc
JR
734%description -n python-rpm -l pt_BR.UTF-8
735O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
736escritas em Python utilizem a interface fornecida pelas bibliotecas
737RPM (RPM Package Manager).
738
dd85fadc 739Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
740Python para manipular pacotes e bancos de dados RPM.
741
5c2ab5c7
AM
742%package apidocs
743Summary: RPM API documentation and guides
744Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
745Group: Documentation
746
747%description apidocs
748Documentation for RPM API and guides in HTML format generated from rpm
749sources by doxygen.
750
751%description apidocs -l pl.UTF-8
752Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
753źrodeł RPM-a przez doxygen.
754
e2025ad1 755%prep
d38aed81 756%setup -q -n %{name}-%{version}%{?subver} -a100
317ef122 757#patch0 -p1
2f0ee4ec 758%patch1 -p1
4d5b8e4c 759%patch2 -p1
ece43ea2 760%patch3 -p1
7a3b1f24
AM
761%patch4 -p1
762%patch5 -p1
c1768ce2 763%patch7 -p1
7a3b1f24 764%patch8 -p1
fefe9d30 765%patch9 -p1
6a8612bc 766%{?with_system_lua:%patch11 -p1}
2a321171 767# CHECK ME - macrofiles: ~/etc could be used
98a21402 768#%%patch14 -p1
fefe9d30 769%patch16 -p1
686b0204
JR
770%ifnarch i386 i486
771# enable TSC for capable archs
f5afdd6c 772%patch26 -p1
0bf2c47b 773%endif
24123ddd 774%patch27 -p1
950eead3 775%patch34 -p1
7a3b1f24 776%patch35 -p0
148c9957 777%patch36 -p1
9282ffe4 778%patch41 -p1
ece43ea2 779%patch42 -p1
775829eb 780%patch47 -p1
d6080f70 781%patch55 -p1
59a562c2 782%patch59 -p1
317ef122
JR
783# Maybe, at last we can remove this?
784#patch19 -p1
c50e9031 785%patch60 -p1
7ffa7946 786%ifarch sparc64
787%patch61 -p1
788%endif
7f26883c 789%patch62 -p1
77fcdbf7 790%patch72 -p1 -b .wiget
afb55538
JR
791%patch73 -p1
792%patch74 -p1
a3809792
JR
793%patch75 -p1
794%patch76 -p1
795%patch77 -p1
796%patch78 -p1
797%patch79 -p1
798%patch80 -p1
799%patch81 -p1
800%patch82 -p1
801%patch83 -p1
802%patch84 -p1
803%patch85 -p1
765b7c41 804
70f8787d
JR
805%patch1000 -p1
806%patch1001 -p1
807%patch1002 -p1
808%patch1003 -p1
809%patch1004 -p1
810%patch1005 -p1
811%patch1006 -p1
812%patch1007 -p1
813%patch1008 -p1
814%patch1009 -p1
815%patch1010 -p1
816%patch1011 -p1
817%patch1012 -p1
818%patch1013 -p1
819%patch1014 -p1
820%patch1015 -p1
821%patch1016 -p1
822%patch1017 -p1
823%patch1018 -p1
824%patch1019 -p1
825%patch1020 -p1
826%patch1021 -p1
827%patch1022 -p1
828%patch1023 -p1
829%patch1024 -p1
830%patch1025 -p1
831%patch1026 -p1
832%patch1027 -p1
833%patch1028 -p1
834%patch1029 -p1
835%patch1030 -p1
836%patch1031 -p1
837%patch1032 -p1
838%patch1033 -p1
839%patch1034 -p1
840%patch1035 -p1
841%patch1036 -p1
842%patch1037 -p1
843%patch1038 -p1
844
845install %{SOURCE2} macros/pld.in
846install %{SOURCE9} scripts/php.prov.in
847install %{SOURCE10} scripts/php.req.in
848install %{SOURCE12} scripts/perl.prov.in
08697680 849
70f8787d 850%{__mv} -f scripts/perl.req{,.in}
633d1e9e 851
cd86db2e 852# generate Group translations to *.po
80b8a1f9 853awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 854
87ef0d95 855%build
ea816ea6 856%{__libtoolize}
c0a9be8f 857#%{__autopoint}
ceaaacee 858%{__aclocal}
4cd84746 859%{__autoheader}
7a9d72ce 860%{__autoconf}
7a9d72ce 861%{__automake}
7a9d72ce 862
d268a169 863%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 864# pass CC and CXX too in case of building with some older configure macro
624f96ff 865%configure \
f9ac32aa
AM
866 CC="%{__newcc}" \
867 CXX="%{__newcxx}" \
868 CPP="%{__newcpp}" \
01d7a578 869 WITH_PERL_VERSION=no \
cd86db2e 870 --enable-shared \
874f4c9a 871 --enable-static \
5c2ab5c7 872 %{!?with_apidocs:--without-apidocs} \
f3cb8244 873 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
a6e56ce4 874 %{!?with_python:--without-python} \
241257bf
AM
875 --with%{!?with_selinux:out}-selinux \
876 --with-libelf \
877 --with-zlib=external \
878 --with-bzip2=external \
879 --with-beecrypt=external \
1afa05ce 880 --with-lzma=external \
77fcdbf7 881 --with-xz=external \
241257bf
AM
882 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
883 --with-file=external \
884 --with-popt=external \
afb55538 885 --with-db=%{?with_db:external}%{!?with_db:no} \
77fcdbf7 886 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
950eead3 887 --with-dbapi=%{!?with_sqlite_dbapi:db}%{?with_sqlite_dbapi:sqlite} \
6a8612bc 888 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
77fcdbf7 889 --with-pcre=external \
241257bf
AM
890 --with-keyutils=none \
891 --without-path-versioned \
0387ab85 892 --with-extra-path-macros='%{_sysconfdir}/rpm/macros.d/*.macros:%{_rpmlibdir}/macros.build:%{_rpmlibdir}/macros.d/pld:~/etc/rpmmacros:~/etc/.rpmmacros:~/.rpmmacros' \
08697680
JR
893 --with-bugreport="http://bugs.pld-linux.org/" \
894 --with-vendor=pld
cf6faebc 895
25e974c7 896%{__make} -j1 \
f9ac32aa
AM
897 CC="%{__cc}" \
898 CXX="%{__cxx}" \
241257bf 899 CPP="%{__cpp}"
33be5db0 900
5c2ab5c7
AM
901%{?with_apidocs:%{__make} apidocs}
902
b064b8e6 903%install
ff7bc1e6 904rm -rf $RPM_BUILD_ROOT
54eb1770
AM
905install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm,/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
906
907install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 908
a5e7fb84 909%{__make} install \
241257bf
AM
910 pkgconfigdir=%{_pkgconfigdir} \
911 DESTDIR=$RPM_BUILD_ROOT
718426e1 912
25ac75ae
AM
913# install ARCH macros
914install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
d38aed81 915install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
25ac75ae
AM
916
917%ifarch %{ix86}
918install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
d38aed81
JR
919install cpu-os-macros/athlon-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
920install cpu-os-macros/i386-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
921install cpu-os-macros/i486-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
922install cpu-os-macros/i586-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
923install cpu-os-macros/i686-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
924install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
925install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
926%endif
927
928%ifarch %{x8664}
929install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
d38aed81
JR
930install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
931install cpu-os-macros/ia32e-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
932install cpu-os-macros/amd64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
25ac75ae
AM
933%endif
934
935%ifarch %{ppc}
936install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
d38aed81 937install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
938%endif
939
2eb9303e 940cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 941# first platform file entry can't contain regexps
2eb9303e 942%{_target_cpu}-%{_target_vendor}-linux
caf453d4 943
2d8ae03e
AM
944# x86_64 things
945%ifarch x86_64
53fd58bc 946x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 947amd64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 948%endif
2d8ae03e 949%ifarch amd64
53fd58bc
AM
950amd64-[^-]*-[Ll]inux(-gnu)?
951x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 952%endif
2d8ae03e 953%ifarch ia32e
53fd58bc
AM
954ia32e-[^-]*-[Ll]inux(-gnu)?
955x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
956%endif
957
958# x86 things
06bd38df 959%ifarch athlon %{x8664}
53fd58bc 960athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 961%endif
06bd38df 962%ifarch pentium4 athlon %{x8664}
53fd58bc 963pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 964%endif
06bd38df 965%ifarch pentium3 pentium4 athlon %{x8664}
53fd58bc 966pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 967%endif
06bd38df 968%ifarch i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 969i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 970%endif
06bd38df 971%ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 972i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 973%endif
06bd38df 974%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 975i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 976%endif
06bd38df 977%ifarch %{ix86} %{x8664}
53fd58bc 978i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
979%endif
980
5074eba9 981%ifarch alpha
53fd58bc 982alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
983%endif
984
985%ifarch ia64
53fd58bc 986ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
987%endif
988
989%ifarch ppc64
53fd58bc
AM
990powerpc64-[^-]*-[Ll]inux(-gnu)?
991ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 992%endif
950eead3 993%ifarch %{ppc} ppc64
53fd58bc
AM
994powerpc-[^-]*-[Ll]inux(-gnu)?
995ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
996%endif
997
998%ifarch s390x
53fd58bc 999s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1000%endif
1001%ifarch s390 s390x
53fd58bc 1002s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1003%endif
1004
1005%ifarch sparc64
53fd58bc
AM
1006sparc64-[^-]*-[Ll]inux(-gnu)?
1007sparcv8-[^-]*-[Ll]inux(-gnu)?
1008sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1009%endif
1010%ifarch sparcv9
53fd58bc
AM
1011sparcv8-[^-]*-[Ll]inux(-gnu)?
1012sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1013%endif
1014%ifarch sparc sparcv9 sparc64
53fd58bc 1015sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1016%endif
1017
1018# noarch
2eb9303e
ER
1019noarch-[^-]*-.*
1020EOF
2d8ae03e 1021
02919de5
JK
1022rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1023rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1024rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
950eead3 1025rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
02919de5 1026
644d8958
JB
1027# not installed since 4.4.8 (-tools-perl subpackage)
1028install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1029
61f7e1b3 1030install %{SOURCE1} doc/manual/groups
d755a548 1031install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1032install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1033install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
d0370fe5 1034install %{SOURCE13} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
7d8492bb 1035install %{SOURCE16} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548
JK
1036install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
1037install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
f15af52e 1038cp -p %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
c75b3936 1039install %{SOURCE20} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1040install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
d0370fe5 1041install %{SOURCE14} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1042
1c2e2d8e 1043install %{SOURCE17} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1044
950eead3
ER
1045install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1046
08697680
JR
1047install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
1048install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1049install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1050install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1051install %{SOURCE25} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1052install %{SOURCE26} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep
1053install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
1054
950eead3
ER
1055touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1056touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
1057install %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
1058touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1059touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1060touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1061
f3fd387a 1062# for rpm -e|-U --repackage
a11e0e27
AM
1063install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1064touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1065
950eead3
ER
1066# move rpm to /bin
1067mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1068# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1069for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1070 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1071 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1072done
1073
950eead3
ER
1074# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1075mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1076
6f18cdb7
AF
1077%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1078%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1079
08697680 1080%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
01d7a578 1081
01d7a578 1082# wrong location, not used anyway
08697680 1083%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
950eead3 1084# utils dropped in 4.4.8 -- their manuals
08697680 1085%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
e86bfbff 1086# utils dropped in 5.4 -- their manuals
854562c1 1087%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1088# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1089%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1090
90b03dd6 1091%find_lang %{name}
cf6faebc 1092
08697680 1093%{__rm} -rf manual
a998ac11 1094cp -a doc/manual manual
08697680 1095%{__rm} -f manual/Makefile*
874f4c9a 1096
13eb5ebf 1097%clean
d7df46b8 1098rm -rf $RPM_BUILD_ROOT
76214164 1099
cc1a4992
ER
1100%triggerpostun lib -- %{name}-lib < %{version}
1101rm -f /var/lib/rpm/__db*
1102
1103%pretrans
1104# this needs to be a dir
1105if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1106 umask 022
cc1a4992
ER
1107 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1108 mkdir %{_sysconfdir}/rpm/sysinfo
1109fi
1110
cf709a39
ER
1111%triggerpostun -- %{name} < 4.4.9-44
1112%{_rpmlibdir}/hrmib-cache
1113
ceaaacee
JB
1114%post lib -p /sbin/ldconfig
1115%postun lib -p /sbin/ldconfig
76214164 1116
37a5a2fc 1117%pretrans build
d755a548 1118find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1119
3684d90f
JB
1120%files -f %{name}.lang
1121%defattr(644,root,root,755)
241257bf 1122%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1123
54eb1770
AM
1124%dir %{_sysconfdir}/pki/rpm-gpg
1125%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
1126
7a9d72ce 1127%attr(755,root,root) /bin/rpm
e73478cd 1128
66edd895 1129%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
950eead3 1130%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1131# these are ok to be replaced
950eead3 1132%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1133%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1134
09bb810c 1135%{_mandir}/man8/rpm.8*
feb1f12e 1136%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1137%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 1138%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 1139%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1140%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1141%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1142
e2025ad1 1143%dir /var/lib/rpm
74a997bd
JR
1144%dir /var/lib/rpm/log
1145%dir /var/lib/rpm/tmp
1146%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1147%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1148%dir /var/lock/rpm
1149/var/lock/rpm/transaction
4acac5de 1150
cf709a39
ER
1151# exported package NVRA (stamped with install tid)
1152# net-snmp hrSWInstalledName queries, bash-completions
1153%dir /var/cache/hrmib
1154
ec44785a 1155%{_rpmlibdir}/qf
d755a548
JK
1156%{_rpmlibdir}/rpmpopt*
1157%{_rpmlibdir}/macros
08697680
JR
1158%dir %{_rpmlibdir}/macros.d
1159%{_rpmlibdir}/macros.d/pld
9282ffe4 1160%{_rpmlibdir}/cpuinfo.yaml
3684d90f 1161
cf709a39
ER
1162%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1163
df50421f
JR
1164%dir %{_rpmlibdir}/bin
1165%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
1166
66edd895
JB
1167%files base
1168%defattr(644,root,root,755)
492a2bd4 1169%dir %{_sysconfdir}/rpm
66edd895
JB
1170%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1171%dir %{_rpmlibdir}
1172%attr(755,root,root) %{_bindir}/banner.sh
df50421f 1173%attr(755,root,root) %{_bindir}/multiarch-dispatch
66edd895
JB
1174%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1175%dir /var/lib/banner
1176
874f4c9a
MM
1177%files lib
1178%defattr(644,root,root,755)
950eead3
ER
1179%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1180%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1181%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1182%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1183%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1184%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1185
69131f1a
JB
1186%files devel
1187%defattr(644,root,root,755)
69131f1a
JB
1188%attr(755,root,root) %{_libdir}/librpm.so
1189%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1190%attr(755,root,root) %{_libdir}/librpmbuild.so
1191%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1192%attr(755,root,root) %{_libdir}/librpmconstant.so
1193%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1194%attr(755,root,root) %{_libdir}/librpmdb.so
1195%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1196%attr(755,root,root) %{_libdir}/librpmio.so
1197%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1198%attr(755,root,root) %{_libdir}/librpmmisc.so
1199%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1200%{_libdir}/librpm*.la
1201%{_includedir}/rpm
df50421f 1202%{_includedir}/multiarch-dispatch.h
950eead3 1203%{_pkgconfigdir}/*.pc
69131f1a
JB
1204
1205%files static
1206%defattr(644,root,root,755)
1207%{_libdir}/librpm*.a
1208
1209%files utils
1210%defattr(644,root,root,755)
69131f1a 1211%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1212%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1213%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1214%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1215%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1216%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1217%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1218%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1219%attr(755,root,root) %{_rpmlibdir}/bin/find
1220%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1221%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1222%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1223%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1224%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1225%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
1226%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey
1227%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1228%{_mandir}/man8/rpm2cpio.8*
950eead3 1229%{_mandir}/man8/rpmcache.8*
ec44785a 1230%{_mandir}/man8/rpmconstant.8*
69131f1a 1231%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1232%{_mandir}/man8/rpmmtree.8*
69131f1a 1233%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
950eead3 1234%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
69131f1a
JB
1235%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1236%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
950eead3 1237%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
69131f1a 1238%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1239%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1240
1241%files utils-perl
1242%defattr(644,root,root,755)
1243%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1244
1245%if %{with static}
1246%files utils-static
1247%defattr(644,root,root,755)
1248%attr(755,root,root) %{_bindir}/rpm[ieu]
1249%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1250%endif
1251
3684d90f 1252%files build
a45ae6d8 1253%defattr(644,root,root,755)
66edd895 1254%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1255%attr(755,root,root) %{_rpmlibdir}/brp-*
1256%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1257%attr(755,root,root) %{_rpmlibdir}/compress-doc
1258%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1259%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1260%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1261%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1262%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1263%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1264%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1265%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1266# needs hacked pkg-config to return anything
1267%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1268%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1269%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
77fcdbf7
AF
1270%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1271%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f
JR
1272%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1273%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1274%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1275%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1276%attr(755,root,root) %{_rpmlibdir}/vcheck
d755a548 1277%{_rpmlibdir}/noarch-*
e9fe9fc5 1278%ifarch %{ix86}
d755a548 1279%{_rpmlibdir}/i?86*
e9fe9fc5 1280%{_rpmlibdir}/pentium*
d755a548
JK
1281%{_rpmlibdir}/athlon*
1282%endif
ad628734
JB
1283%ifarch alpha
1284%{_rpmlibdir}/alpha*
1285%endif
ad628734
JB
1286%ifarch ia64
1287%{_rpmlibdir}/ia64*
8f76a271 1288%endif
410dd742 1289%ifarch mips mipsel mips64 mips64el
1290%{_rpmlibdir}/mips*
1291%endif
80e9f34d 1292%ifarch %{ppc}
410dd742 1293%{_rpmlibdir}/ppc*
1294%endif
1295%ifarch sparc sparc64
1296%{_rpmlibdir}/sparc*
1297%endif
9f517079 1298%ifarch %{x8664}
206b32be
JB
1299%{_rpmlibdir}/amd64*
1300%{_rpmlibdir}/ia32e*
cedf1bfa
PS
1301%{_rpmlibdir}/x86_64*
1302%endif
410dd742 1303# not used yet ... these six depend on perl
ec44785a 1304%attr(755,root,root) %{_rpmlibdir}/http.req
ec44785a 1305%attr(755,root,root) %{_rpmlibdir}/mono*
37e965e8 1306
70f8787d 1307%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1308# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1309%{_rpmlibdir}/macros.d/cmake
1310%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7 1311%{_rpmlibdir}/macros.d/java
df50421f 1312%{_rpmlibdir}/macros.d/kernel
77fcdbf7
AF
1313%{_rpmlibdir}/macros.d/libtool
1314%{_rpmlibdir}/macros.d/mono
1315%{_rpmlibdir}/macros.d/perl
1316%{_rpmlibdir}/macros.d/php
1317%{_rpmlibdir}/macros.d/pkgconfig
1318%{_rpmlibdir}/macros.d/python
df50421f 1319%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1320%{_rpmlibdir}/macros.d/selinux
df50421f 1321%{_rpmlibdir}/macros.d/tcl
77fcdbf7
AF
1322%{_rpmlibdir}/macros.rpmbuild
1323
df50421f
JR
1324%attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
1325%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1326%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1327%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1328%attr(755,root,root) %{_rpmlibdir}/mkmultiarch
df50421f
JR
1329%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1330
874f4c9a 1331%attr(755,root,root) %{_bindir}/gendiff
df50421f 1332%attr(755,root,root) %{_bindir}/multiarch-platform
874f4c9a 1333%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1334
1335%dir %{_rpmlibdir}/helpers
1336%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1337
a00926bc 1338%{_mandir}/man1/gendiff.1*
874f4c9a 1339%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1340%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1341%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1342%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1343
7d8492bb
JB
1344%files javaprov
1345%defattr(644,root,root,755)
1346%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1347# needs jar (any jdk), jcf-dump (gcc-java) to work
1348%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1349
89334051
AF
1350%files perlprov
1351%defattr(644,root,root,755)
d755a548 1352%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1353%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1354%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1355
80d3b868 1356%files pythonprov
d8fcb9b0 1357%defattr(644,root,root,755)
bdbae303 1358%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1359%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1360
d36cb682
PG
1361%files php-pearprov
1362%defattr(644,root,root,755)
d755a548
JK
1363%attr(755,root,root) %{_rpmlibdir}/php*
1364%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1365
50dc9ac0 1366%if %{with python}
cf6faebc 1367%files -n python-rpm
42a0025c 1368%defattr(644,root,root,755)
b33910fe 1369%dir %{py_sitedir}/rpm
6f18cdb7 1370%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1371%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1372%endif
5c2ab5c7
AM
1373
1374%if %{with apidocs}
1375%files apidocs
1376%defattr(644,root,root,755)
1377%doc apidocs
1378%endif
This page took 1.265949 seconds and 4 git commands to generate.