- cpu-os-macros are autogenerated here
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
d0ee0933
JR
3# - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4# returns -ENOSYS
9fb5ee9e 5# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 6#
c296fee0 7# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 8#
89427592 9# Conditional build:
01d7a578 10%bcond_with static # build static rpm+rpmi
0a1ccab0 11%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
12%bcond_without python # don't build python bindings
13%bcond_without selinux # build without selinux support
0dc47449 14%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
fb35e2d9 15%bcond_with db61 # use DB 6.1 instead of 5.3
34befcc5 16%bcond_with neon # build with HTTP/WebDAV support (neon library)
6f6c7465 17%bcond_with sqlite # build with SQLite support
a22a4387 18%bcond_without system_pcre # use system pcre
d0ee0933 19%bcond_with keyutils # build with keyutils support
858aa7d0 20
ba7bedbb
JR
21%if %{with sqlite}
22# Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
23%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24%endif
25
003a039e 26# versions of required libraries
7f47af9c
JB
27%if %{with db61}
28%define reqdb_pkg db6.1
29%define reqdb_ver 6.1
30%define reqdb_pkgver 6.1.19
5f3f5bd6 31%else
fb35e2d9
JR
32%define reqdb_pkg db5.3
33%define reqdb_ver 5.3
34%define reqdb_pkgver 5.3.28.0
5f3f5bd6 35%endif
ec44785a 36%define reqpopt_ver 1.15
fb35e2d9 37%define openssl_ver 1.1.1d
2f409bb7 38%define sover 9.0.1
fc60c9f3 39
e5f02e49 40Summary: RPM Package Manager
4ea2ed33
ER
41Summary(de.UTF-8): RPM Packet-Manager
42Summary(es.UTF-8): Gestor de paquetes RPM
43Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
44Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
45Summary(ru.UTF-8): Менеджер пакетов от RPM
46Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 47Name: rpm
6ecfe7c2 48Version: 4.15.1
98d9fc8e
JR
49Release: 0.1
50License: GPL v2 / LGPL v2.1
76214164 51Group: Base
6ecfe7c2
JR
52Source0: http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
53# Source0-md5: ed72147451a5ed93b2a48e2f8f5413c3
ff7bc1e6 54Source1: %{name}.groups
08697680 55Source2: macros.pld.in
ff7bc1e6 56Source3: %{name}-install-tree
80b8a1f9 57Source4: %{name}-find-spec-bcond
cf709a39 58Source5: %{name}-hrmib-cache
80b8a1f9
JB
59Source6: %{name}-groups-po.awk
60Source7: %{name}-compress-doc
0bf34f68
JR
61Source8: %{name}-php-provides
62Source9: %{name}-php-requires
63Source10: %{name}.sysinfo
64Source11: perl.prov
65Source12: %{name}-user_group.sh
66Source13: %{name}.sysconfig
67Source14: %{name}-java-requires
a4b7ef27 68# http://svn.pld-linux.org/banner.sh/
0bf34f68 69Source15: banner.sh
34f36471 70Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
e1b97821 71# Source16-md5: 23914bb49fafe7153cee87126d966461
0bf34f68
JR
72Source17: %{name}-mimetypedeps
73Source18: macros.local
f09b01ac
ER
74Source19: %{name}.noautocompressdoc
75Source20: %{name}.noautoprov
76Source21: %{name}.noautoprovfiles
77Source22: %{name}.noautoreq
f09b01ac 78Source24: %{name}.noautoreqfiles
0bf34f68 79Source25: %{name}-php-requires.php
f09b01ac 80Source26: %{name}db_checkversion.c
b1541d4c 81Source27: macros.lang
f09b01ac 82Source28: %{name}db_reset.c
14138aba 83Source29: dbupgrade.sh
e2489d8e 84Source30: rubygems.rb
63194730 85Source31: gem_helper.rb
f05db907 86Patch0: %{name}-branch.patch
2f0ee4ec 87Patch1: %{name}-man_pl.patch
38e53563 88Patch2: %{name}-popt-aliases.patch
3465efba 89Patch4: %{name}-perl-macros.patch
c1768ce2 90Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
91Patch6: %{name}-scripts-closefds.patch
92Patch7: %{name}-php-macros.patch
044171ea 93Patch9: %{name}-lua.patch
9ee75c3c
JR
94Patch14: %{name}-perl_req-INC_dirs.patch
95Patch15: %{name}-debuginfo.patch
96Patch16: vendor-pld.patch
9ee75c3c 97Patch18: %{name}-javadeps.patch
9ee75c3c 98Patch20: %{name}-libtool-deps.patch
9ee75c3c
JR
99Patch29: %{name}-builddir-readlink.patch
100Patch30: %{name}-changelog_order_check_nonfatal.patch
9ee75c3c 101Patch35: %{name}-namespace-compare.patch
9ee75c3c 102Patch37: %{name}-postun-nofail.patch
a6170fd4 103Patch61: %{name}-clean-docdir.patch
80e5119e 104Patch64: %{name}-fix-compress-doc.patch
9d486499 105Patch81: %{name}-perl-magic.patch
10a92209 106Patch83: %{name}-ignore-missing-macro-files.patch
321b78b0 107Patch84: x32.patch
883e0fac 108
955f2725 109URL: http://rpm5.org/
cf169f7c 110BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
6f6c7465
JR
111%if %{with sqlite}
112BuildRequires: sqlite3-devel
113%else
cf169f7c 114BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
6f6c7465 115%endif
29855fc2 116BuildRequires: autoconf >= 2.63
644d8958 117BuildRequires: automake >= 1.4
fb35e2d9 118BuildRequires: openssl-devel >= %{openssl_ver}
33be5db0 119BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 120BuildRequires: elfutils-devel >= 0.108
3e70c06e 121BuildRequires: gettext-tools >= 0.19.2
d0ee0933 122%{?with_keyutils:BuildRequires: keyutils-devel}
241257bf 123BuildRequires: libmagic-devel
6e115b23
JR
124%if %{with selinux}
125BuildRequires: libselinux-devel >= 2.1.0
6e115b23 126BuildRequires: libsemanage-devel >= 2.1.0
3acb62f3 127BuildRequires: libsepol-devel >= 2.1.0
6e115b23 128%endif
84cdee7a
JB
129# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
130BuildRequires: libstdc++-devel
b60c74c3 131BuildRequires: libtool >= 1:1.4.2-9
33be5db0 132%if %{with neon}
fe861705 133BuildRequires: libxml2-devel
83d6a3fe 134BuildRequires: neon-devel >= 0.25.5
33be5db0 135%endif
5c767dc1 136BuildRequires: lua53-devel >= 5.3.5
127a0b3c 137BuildRequires: ossp-uuid-devel
7973b351 138BuildRequires: patch >= 2.2
1d49ffbc 139BuildRequires: popt-devel >= %{reqpopt_ver}
950eead3
ER
140%{?with_python:BuildRequires: python-devel >= 1:2.3}
141BuildRequires: python-modules >= 1:2.3
2a813afe 142%{?with_python:BuildRequires: rpm-pythonprov}
e56a10a9 143BuildRequires: tcl
77fcdbf7 144BuildRequires: xz-devel
3acb62f3 145BuildRequires: zlib-devel
5c2ab5c7
AM
146%if %{with apidocs}
147BuildRequires: doxygen
148BuildRequires: ghostscript
149BuildRequires: graphviz
150BuildRequires: tetex-pdftex
151%endif
a6e56ce4 152%if %{with static}
e6090a7b 153# Require static library only for static build
cf169f7c 154BuildRequires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
fb35e2d9 155BuildRequires: openssl-static >= %{openssl_ver}
33be5db0 156BuildRequires: bzip2-static >= 1.0.2-17
290c1c30 157BuildRequires: elfutils-static
10abbd40 158BuildRequires: glibc-static >= 2.2.94
241257bf 159BuildRequires: libmagic-static
6e115b23
JR
160%if %{with selinux}
161BuildRequires: libselinux-static >= 2.1.0
6e115b23 162BuildRequires: libsemanage-static >= 2.1.0
3acb62f3 163BuildRequires: libsepol-static >= 2.1.0
6e115b23 164%endif
003a039e 165BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 166BuildRequires: zlib-static
7a9d72ce 167%endif
d25ec6ea 168Requires(posttrans): coreutils
affe917d 169Requires: FHS >= 3.0-2
66edd895 170Requires: %{name}-base = %{version}-%{release}
b26a9709 171Requires: %{name}-lib = %{version}-%{release}
fb35e2d9 172Requires: openssl >= %{openssl_ver}
10abbd40 173Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
174Provides: rpm-db-ver = %{reqdb_ver}
175Obsoletes: rpm-getdeps
4adb7d05 176%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 177Conflicts: glibc < 2.2.92
8ee1c72c
AM
178# db4.6 poldek needed
179Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
180# segfaults with lzma 0.42.2
181Conflicts: lzma-libs < 4.999.3
e4084afd 182Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 183BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 184
4adb7d05 185%define _binary_payload w9.gzdio
6d82b332 186
4cd84746
JB
187# don't require very fresh rpm.macros to build
188%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 189%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 190%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 191%define ppc ppc ppc7400 ppc7450
9f517079 192%define x8664 amd64 ia32e x86_64
4cd84746 193
d755a548 194%define _rpmlibdir /usr/lib/rpm
950eead3 195%define _noautocompressdoc RPM-GPG-KEY
d755a548 196
ff7bc1e6 197%description
198RPM is a powerful package manager, which can be used to build,
199install, query, verify, update, and uninstall individual software
cf6faebc 200packages. A package consists of an archive of files, and package
fed73700 201information, including name, version, and description.
202
dd85fadc
JR
203%description -l de.UTF-8
204RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 205Installation, Anfrage, Verifizierung, Aktualisierung und
206Uninstallation individueller Softwarepakete. Ein Paket besteht aus
207einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 208Beschreibung.
209
dd85fadc 210%description -l es.UTF-8
313a4d1a 211RPM es un poderoso administrador de paquetes, que puede ser usado para
212construir, instalar, pesquisar, verificar, actualizar y desinstalar
213paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
214almacenaje de archivos, y información sobre el paquete, incluyendo
215nombre, versión y descripción.
216
217%description -l pl.UTF-8
218RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
219przebudowanie, instalację czy weryfikację dowolnego pakietu.
220Informacje dotyczące każdego pakietu, takie jak jego opis, lista
221plików wchodzących w skład pakietu, zależności od innych pakietów, są
222przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 223odpytywania programu rpm.
224
dd85fadc
JR
225%description -l pt_BR.UTF-8
226RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 227construir, instalar, pesquisar, verificar, atualizar e desinstalar
228pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
229arquivos e informações adicionais, incluindo nome, versão e descrição
230do pacote, permissões dos arquivos, etc.
231
232%description -l ru.UTF-8
233RPM - это мощный менеджер пакетов, который может быть использован для
234создания, инсталляции, запросов (query), проверки, обновления и
235удаления программных пакетов. Пакет состоит из файлового архива и
236служебной информации, включающей название, версию, описание и другие
237данные о пакете.
238
239%description -l uk.UTF-8
240RPM - це потужний менеджер пакетів, що може бути використаний для
241створення, інсталяції, запитів (query), перевірки, поновлення та
242видалення програмних пакетів. Пакет складається з файлового архіву та
243службової інформації, що містить назву, версію, опис та іншу
244інформацію про пакет.
7c6dc55f 245
66edd895
JB
246%package base
247Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 248Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 249Group: Base
1d9ca0c1 250Requires: filesystem
950eead3 251Obsoletes: rpm-scripts
66edd895
JB
252Obsoletes: vserver-rpm
253
254%description base
255The RPM base package contains scripts used by rpm packages themselves.
256These include:
257- scripts for adding/removing groups and users needed for rpm
258 packages,
259- banner.sh to display %%banner messages from rpm scriptlets.
260
dd85fadc
JR
261%description base -l pl.UTF-8
262Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 263Zawiera on:
dd85fadc
JR
264- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
265- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 266
69131f1a
JB
267%package lib
268Summary: RPMs library
4ea2ed33 269Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 270Group: Libraries
cf169f7c 271Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
6f6c7465
JR
272%if %{with sqlite}
273Requires: sqlite3 >= %{sqlite_build_version}
274%else
cf169f7c 275Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
6f6c7465 276%endif
fb35e2d9 277Requires: openssl >= %{openssl_ver}
241257bf 278Requires: libmagic >= 1.15-2
6e115b23 279%{?with_selinux:Requires: libselinux >= 2.1.0}
69131f1a 280Requires: popt >= %{reqpopt_ver}
d1795eb0 281Obsoletes: rpm-libs
69131f1a
JB
282# avoid SEGV caused by mixed db versions
283Conflicts: poldek < 0.18.1-16
284
285%description lib
286RPMs library.
287
dd85fadc 288%description lib -l pl.UTF-8
69131f1a
JB
289Biblioteki RPM-a.
290
fed73700 291%package devel
3f2d796a 292Summary: Header files for rpm libraries
4ea2ed33
ER
293Summary(de.UTF-8): Header-Dateien für rpm Libraries
294Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
295Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
296Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
297Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
298Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 299Group: Development/Libraries
153e5706 300Requires: %{name}-lib = %{version}-%{release}
cf169f7c 301Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
fb35e2d9 302Requires: openssl-devel >= %{openssl_ver}
fea3cb89 303Requires: bzip2-devel
5c583f90 304Requires: elfutils-devel
d0ee0933 305%{?with_keyutils:Requires: keyutils-devel}
241257bf 306Requires: libmagic-devel
c7b2d5f9
KK
307%if %{with selinux}
308Requires: libselinux-devel
309Requires: libsemanage-devel
310Requires: libsepol-devel
311%endif
a998ac11 312Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 313Requires: zlib-devel
cf6faebc 314
315%description devel
3f2d796a
JB
316The RPM packaging system includes C libraries that make it easy to
317manipulate RPM packages and databases. They are intended to ease the
cf6faebc 318creation of graphical package managers and other tools that need
3f2d796a
JB
319intimate knowledge of RPM packages. This package contains header files
320for these libraries.
fed73700 321
dd85fadc
JR
322%description devel -l de.UTF-8
323Der RPM-Packensystem enthält eine C-Library, die macht es einfach
324RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 325Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 326Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
327
dd85fadc 328%description devel -l es.UTF-8
313a4d1a 329El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
330fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
331facilitar la creación de administradores gráficos de paquetes y otras
20f89981 332herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 333
dd85fadc
JR
334%description devel -l pl.UTF-8
335System RPM zawiera biblioteki C, które ułatwiają manipulowanie
336pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
337graficznych programów zarządzających pakietami oraz innych narzędzi,
338które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
339zawiera pliki nagłówkowe wspomnianych bibliotek.
340
341%description devel -l pt_BR.UTF-8
342O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
343a manipulação de pacotes e bases de dados RPM. Seu objetivo é
344facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 345ferramentas que precisem de conhecimento profundo de pacotes RPM.
346
dd85fadc
JR
347%description devel -l ru.UTF-8
348Система управления пакетами RPM содержит библиотеку C, которая
349упрощает манипуляцию пакетами RPM и соответствующими базами данных.
350Эта библиотека предназначена для облегчения создания графических
351пакетных менеджеров и других утилит, которым необходимо работать с
352пакетами RPM.
7c6dc55f 353
dd85fadc
JR
354%description devel -l uk.UTF-8
355Система керування пакетами RPM містить бібліотеку C, котра спрощує
356роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
357призначена для полегшення створення графічних пакетних менеджерів та
358інших утиліт, що працюють з пакетами RPM.
7c6dc55f 359
fed73700 360%package static
9e42d68a 361Summary: RPM static libraries
4ea2ed33
ER
362Summary(de.UTF-8): RPMs statische Libraries
363Summary(pl.UTF-8): Biblioteki statyczne RPM-a
364Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
365Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
366Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 367Group: Development/Libraries
153e5706 368Requires: %{name}-devel = %{version}-%{release}
cf169f7c 369Requires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
fb35e2d9 370Requires: openssl-static >= %{openssl_ver}
df76dbd9 371Requires: bzip2-static
ff03e01a 372Requires: elfutils-static
d0ee0933 373%{?with_keyutils:Requires: keyutils-static}
241257bf 374Requires: libmagic-static
c7b2d5f9
KK
375%if %{with selinux}
376Requires: libselinux-static
377Requires: libsemanage-static
378Requires: libsepol-static
379%endif
a998ac11 380Requires: popt-static >= %{reqpopt_ver}
df76dbd9 381Requires: zlib-static
edacdf8f 382
383%description static
20f89981 384RPM static libraries.
fed73700 385
dd85fadc 386%description static -l de.UTF-8
20f89981 387RPMs statische Libraries.
9e42d68a 388
dd85fadc 389%description static -l pl.UTF-8
0a7ae9bc 390Biblioteki statyczne RPM-a.
313a4d1a 391
dd85fadc
JR
392%description static -l pt_BR.UTF-8
393Bibliotecas estáticas para desenvolvimento.
edacdf8f 394
dd85fadc
JR
395%description static -l ru.UTF-8
396Система управления пакетами RPM содержит библиотеку C, которая
397упрощает манипуляцию пакетами RPM и соответствующими базами данных.
398Это статическая библиотека RPM.
7c6dc55f 399
dd85fadc
JR
400%description static -l uk.UTF-8
401Система керування пакетами RPM містить бібліотеку C, котра спрощує
402роботу з пакетами RPM та відповідними базами даних. Це статична
403бібліотека RPM.
7c6dc55f 404
fed73700 405%package utils
8482995c 406Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
407Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
408Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 409Group: Applications/File
153e5706 410Requires: %{name} = %{version}-%{release}
a998ac11 411Requires: popt >= %{reqpopt_ver}
86b85368
AG
412%if %{with suggest_tags}
413Suggests: bzip2
414Suggests: gzip
86b85368 415%endif
695e60ad 416Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 417
418%description utils
8482995c 419Additional utilities for managing RPM packages and database.
fed73700 420
dd85fadc
JR
421%description utils -l de.UTF-8
422Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 423
dd85fadc
JR
424%description utils -l pl.UTF-8
425Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 426
92b3f576 427%package utils-perl
8482995c 428Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
429Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
430Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 431Group: Applications/File
153e5706 432Requires: %{name}-utils = %{version}-%{release}
92b3f576 433Requires: popt >= %{reqpopt_ver}
434
435%description utils-perl
8482995c 436Additional utilities for managing RPM packages and database.
92b3f576 437
dd85fadc
JR
438%description utils-perl -l de.UTF-8
439Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 440
dd85fadc
JR
441%description utils-perl -l pl.UTF-8
442Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 443
a00926bc
JB
444%package utils-static
445Summary: Static rpm utilities
4ea2ed33 446Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 447Group: Applications/System
153e5706 448Requires: %{name} = %{version}-%{release}
a00926bc
JB
449
450%description utils-static
451Static rpm utilities for repairing system in case something with
452shared libraries used by rpm become broken. Currently it contains rpmi
453binary, which can be used to install/upgrade/remove packages without
454using shared libraries (well, in fact with exception of NSS modules).
455
dd85fadc
JR
456%description utils-static -l pl.UTF-8
457Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
458związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
459Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
460uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
461(z wyjątkiem modułów NSS).
a00926bc 462
fed73700 463%package build
e191287c 464Summary: Scripts for building binary RPM packages
4ea2ed33
ER
465Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
466Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
467Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
468Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
469Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 470Group: Applications/File
f15ca8ca
ER
471Requires(pretrans): coreutils
472Requires(pretrans): findutils
716fe3ca 473Requires: %{name}-build-macros >= 1.712
153e5706 474Requires: %{name}-utils = %{version}-%{release}
e191287c 475Requires: /bin/id
476Requires: awk
cfa7898a 477Requires: bzip2
e950a6d7 478Requires: chrpath >= 0.10-4
b6547e10 479Requires: cpio
e191287c 480Requires: diffutils
195f647c 481Requires: elfutils
583135b4 482Requires: file >= 4.17
e191287c 483Requires: fileutils
484Requires: findutils
950eead3
ER
485%ifarch athlon
486Requires: gcc >= 3.0.3
487%else
488Requires: gcc
489%endif
e191287c 490Requires: glibc-devel
491Requires: grep
492Requires: gzip
493Requires: make
494Requires: patch
adbd4815 495Requires: sed >= 4.0
e191287c 496Requires: sh-utils
adbd4815 497Requires: tar >= 1:1.22
e191287c 498Requires: textutils
3acb62f3 499Requires: which
adbd4815 500Requires: xz
ca3648b1 501Provides: rpmbuild(monoautodeps)
37ea389a 502Provides: rpmbuild(noauto) = 3
02d17bf9 503%ifarch %{x8664}
195f647c
JB
504Conflicts: automake < 1:1.7.9-2
505Conflicts: libtool < 2:1.5-13
506%endif
0096c5cd 507
e2025ad1 508%description build
58399c37 509Scripts for building binary RPM packages.
fed73700 510
dd85fadc
JR
511%description build -l de.UTF-8
512Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 513
dd85fadc
JR
514%description build -l pl.UTF-8
515Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 516
dd85fadc
JR
517%description build -l pt_BR.UTF-8
518Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 519construir pacotes usando o RPM.
e73478cd 520
dd85fadc
JR
521%description build -l ru.UTF-8
522Различные вспомогательные скрипты и исполняемые программы, которые
523используются для сборки RPM'ов.
7c6dc55f 524
dd85fadc
JR
525%description build -l uk.UTF-8
526Різноманітні допоміжні скрипти та утиліти, які використовуються для
527побудови RPM'ів.
7c6dc55f 528
8482995c
JB
529%package javaprov
530Summary: Additional utilities for checking Java provides/requires in RPM packages
531Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
532Group: Applications/File
533Requires: %{name} = %{version}-%{release}
534Requires: file
535Requires: findutils >= 1:4.2.26
536Requires: mktemp
537Requires: unzip
538
539%description javaprov
540Additional utilities for checking Java provides/requires in RPM
541packages.
542
543%description javaprov -l pl.UTF-8
544Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
545RPM.
546
69131f1a 547%package perlprov
8482995c 548Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 549Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 550Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
551Group: Applications/File
552Requires: %{name} = %{version}-%{release}
b82853ee 553Requires: perl-Encode
69131f1a
JB
554Requires: perl-devel
555Requires: perl-modules
556
557%description perlprov
8482995c 558Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
559packages.
560
dd85fadc
JR
561%description perlprov -l de.UTF-8
562Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 563
dd85fadc 564%description perlprov -l pl.UTF-8
8482995c
JB
565Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
566pakietach RPM.
69131f1a
JB
567
568%package pythonprov
8482995c
JB
569Summary: Python macros, which simplifies creation of RPM packages with Python software
570Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
571Group: Applications/File
572Requires: %{name} = %{version}-%{release}
cd800b3c 573Requires: python
cfbc7086 574Requires: python-setuptools
3acb62f3 575Requires: python-modules
69131f1a
JB
576
577%description pythonprov
8482995c 578Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
579software.
580
dd85fadc 581%description pythonprov -l pl.UTF-8
8482995c 582Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
583Pythonie.
584
585%package php-pearprov
8482995c
JB
586Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
587Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
588Group: Applications/File
589Requires: %{name} = %{version}-%{release}
632f1b5c 590Requires: sed >= 4.0
1b39d378 591Suggests: php-pear-PHP_CompatInfo
69131f1a
JB
592
593%description php-pearprov
8482995c 594Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
595packages.
596
dd85fadc 597%description php-pearprov -l pl.UTF-8
8482995c
JB
598Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
599pakietach RPM.
69131f1a 600
ec49e9fb
ER
601%package rubyprov
602Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
603Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
604Group: Applications/File
605Requires: %{name} = %{version}-%{release}
606Requires: ruby
607Requires: ruby-modules
b53b1f84 608Requires: ruby-rubygems
ec49e9fb
ER
609
610%description rubyprov
611Ruby tools, which simplifies creation of RPM packages with Ruby
612software.
613
614%description rubyprov -l pl.UTF-8
615Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
616Ruby.
617
69131f1a
JB
618%package -n python-rpm
619Summary: Python interface to RPM library
4ea2ed33
ER
620Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
621Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
622Group: Development/Languages/Python
623Requires: %{name} = %{version}-%{release}
3acb62f3 624Requires: python
69131f1a
JB
625Obsoletes: rpm-python
626
627%description -n python-rpm
628The rpm-python package contains a module which permits applications
629written in the Python programming language to use the interface
630supplied by RPM (RPM Package Manager) libraries.
631
632This package should be installed if you want to develop Python
633programs that will manipulate RPM packages and databases.
634
dd85fadc
JR
635%description -n python-rpm -l pl.UTF-8
636Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
637Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 638
dd85fadc
JR
639Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
640Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 641
dd85fadc
JR
642%description -n python-rpm -l pt_BR.UTF-8
643O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
644escritas em Python utilizem a interface fornecida pelas bibliotecas
645RPM (RPM Package Manager).
646
dd85fadc 647Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
648Python para manipular pacotes e bancos de dados RPM.
649
5c2ab5c7
AM
650%package apidocs
651Summary: RPM API documentation and guides
652Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
653Group: Documentation
d308de4c
ER
654%if "%{_rpmversion}" >= "5"
655BuildArch: noarch
656%endif
5c2ab5c7
AM
657
658%description apidocs
659Documentation for RPM API and guides in HTML format generated from rpm
660sources by doxygen.
661
662%description apidocs -l pl.UTF-8
663Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
664źrodeł RPM-a przez doxygen.
665
e2025ad1 666%prep
c546a4d6 667%setup -q -n %{name}-%{version}%{?subver}
c546a4d6 668
317ef122 669#patch0 -p1
2f0ee4ec 670%patch1 -p1
4d5b8e4c 671%patch2 -p1
7a3b1f24
AM
672%patch4 -p1
673%patch5 -p1
3c7590cc 674%patch6 -p1
6ecfe7c2 675#%patch7 -p1
c38bf1df 676%patch9 -p1
9ee75c3c 677%patch14 -p0
7033e976 678%patch15 -p1
c38bf1df
JR
679#%patch16 -p1
680#%patch18 -p1
3c7590cc 681%patch20 -p1
3c7590cc
JR
682%patch29 -p1
683%patch30 -p1
c38bf1df 684#%patch35 -p1
3c7590cc 685%patch37 -p1
a6170fd4 686%patch61 -p1
fb35e2d9
JR
687#%patch64 -p1
688%patch81 -p1
10a92209 689%patch83 -p1
fb35e2d9 690#%patch84 -p1
883e0fac 691
fb35e2d9 692install %{SOURCE2} pld.in
6ecfe7c2
JR
693#install %{SOURCE8} scripts/php.prov.in
694#install %{SOURCE9} scripts/php.req.in
0bf34f68 695install %{SOURCE11} scripts/perl.prov.in
e2489d8e 696cp -p %{SOURCE30} scripts/rubygems.rb
63194730 697cp -p %{SOURCE31} scripts/gem_helper.rb
08697680 698
70f8787d 699%{__mv} -f scripts/perl.req{,.in}
633d1e9e 700
cd86db2e 701# generate Group translations to *.po
80b8a1f9 702awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 703
91ee86a9 704install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 705install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 706
fb35e2d9 707for extlib in openssl neon %{?with_system_pcre:pcre} popt; do
95bd7348
JR
708 [ -d $extlib ] && %{__rm} -r $extlib
709done
710
87ef0d95 711%build
ea816ea6 712%{__libtoolize}
c0a9be8f 713#%{__autopoint}
ceaaacee 714%{__aclocal}
4cd84746 715%{__autoheader}
7a9d72ce 716%{__autoconf}
7a9d72ce 717%{__automake}
7a9d72ce 718
048d06f8
JR
719# rpm checks for CPU type at runtime, but it looks better
720sed -i \
721 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
722 -e 's|@host_cpu@|%{_target_cpu}|' \
723 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 724 macros.in
048d06f8 725
5c767dc1 726CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
624f96ff 727%configure \
01d7a578 728 WITH_PERL_VERSION=no \
bba1059c 729 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 730 __GPG=%{_bindir}/gpg \
3a3e476f 731 --disable-silent-rules \
cd86db2e 732 --enable-shared \
874f4c9a 733 --enable-static \
5c2ab5c7 734 %{!?with_apidocs:--without-apidocs} \
fb35e2d9 735 --with-crypto=openssl \
3a3e476f
JB
736 --with-bugreport="http://bugs.pld-linux.org/" \
737 --with-bzip2=external \
57256551
JR
738 --with-db=external \
739 --with-dbapi=db \
3a3e476f
JB
740 --with-file=external \
741 --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
742 --with-libelf \
c38bf1df 743 --with-lua \
3a3e476f
JB
744 --with-lzma=external \
745 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
8a13e4c4 746 --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/%%{_target}/macros:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
3a3e476f 747 --without-path-versioned \
f012e16d 748 --with-pcre=%{!?with_system_pcre:internal}%{?with_system_pcre:external} \
3a3e476f
JB
749 --with-popt=external \
750 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
751 %{!?with_python:--without-python} \
fb35e2d9 752 --with-selinux=%{!?with_selinux:no}%{?with_selinux:yes} \
3a3e476f
JB
753 --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
754 --with-sepol=%{!?with_selinux:no}%{?with_selinux:external} \
755 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
127a0b3c 756 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
3a3e476f
JB
757 --with-vendor=pld \
758 --with-xz=external \
759 --with-zlib=external
cf6faebc 760
5c767dc1 761%{__make}
5c2ab5c7 762
fb95de52
JR
763%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
764 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
765%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
766 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
767
768if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
769 echo "Error linking rpmdb tools!"
770 exit 1
771fi
8e8746c0
JR
772if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
773 echo "Error linking rpmdb tools!"
774 exit 1
775fi
91ee86a9 776
b064b8e6 777%install
ff7bc1e6 778rm -rf $RPM_BUILD_ROOT
e9eb00af 779install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 780 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 781
0bf34f68 782install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 783
26a5bf70 784%{__make} -j1 install \
241257bf
AM
785 pkgconfigdir=%{_pkgconfigdir} \
786 DESTDIR=$RPM_BUILD_ROOT
718426e1 787
c546a4d6 788# cleanup
c2683840 789%ifnarch %{ix86} %{x8664} x32
2f409bb7
JR
790rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
791rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
792rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
793rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
794rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
795rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
796rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
797%endif
798
c2683840 799%ifnarch %{x8664} x32
2f409bb7
JR
800rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
801rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
802rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
803rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
804%endif
805
c546a4d6 806%ifnarch %{ppc}
2f409bb7 807rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
25ac75ae
AM
808%endif
809
2f409bb7
JR
810rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
811rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
812rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
813rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
814rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
815rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
816rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
817rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 818
2eb9303e 819cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 820# first platform file entry can't contain regexps
c2683840
JR
821%ifarch x32
822%{_target_cpu}-%{_target_vendor}-linux-gnux32
823%else
2eb9303e 824%{_target_cpu}-%{_target_vendor}-linux
c2683840 825%endif
caf453d4 826
2d8ae03e 827%ifarch x86_64
53fd58bc 828x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 829amd64-[^-]*-[Ll]inux(-gnu)?
c2683840 830x32-[^-]*-[Ll]inux(-gnu(x32)?)?
2d8ae03e 831%endif
2d8ae03e 832%ifarch amd64
53fd58bc
AM
833amd64-[^-]*-[Ll]inux(-gnu)?
834x86_64-[^-]*-[Ll]inux(-gnu)?
c2683840 835x32-[^-]*-[Ll]inux(-gnu(x32)?)?
2d8ae03e 836%endif
2d8ae03e 837%ifarch ia32e
53fd58bc
AM
838ia32e-[^-]*-[Ll]inux(-gnu)?
839x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 840%endif
c2683840
JR
841%ifarch x32
842x32-[^-]*-[Ll]inux(-gnu(x32)?)?
843x86_64-[^-]*-[Ll]inux(-gnu)?
844amd64-[^-]*-[Ll]inux(-gnu)?
845%endif
2d8ae03e 846
c2683840 847%ifarch athlon %{x8664} x32
53fd58bc 848athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 849%endif
c2683840 850%ifarch pentium4 athlon %{x8664} x32
53fd58bc 851pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 852%endif
c2683840 853%ifarch pentium3 pentium4 athlon %{x8664} x32
53fd58bc 854pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 855%endif
c2683840 856%ifarch i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 857i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 858%endif
c2683840 859%ifarch i586 i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 860i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 861%endif
c2683840 862%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32
53fd58bc 863i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 864%endif
c2683840 865%ifarch %{ix86} %{x8664} x32
53fd58bc 866i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
867%endif
868
5074eba9 869%ifarch alpha
53fd58bc 870alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
871%endif
872
873%ifarch ia64
53fd58bc 874ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
875%endif
876
877%ifarch ppc64
53fd58bc
AM
878powerpc64-[^-]*-[Ll]inux(-gnu)?
879ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 880%endif
950eead3 881%ifarch %{ppc} ppc64
53fd58bc
AM
882powerpc-[^-]*-[Ll]inux(-gnu)?
883ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
884%endif
885
886%ifarch s390x
53fd58bc 887s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
888%endif
889%ifarch s390 s390x
53fd58bc 890s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
891%endif
892
893%ifarch sparc64
53fd58bc
AM
894sparc64-[^-]*-[Ll]inux(-gnu)?
895sparcv8-[^-]*-[Ll]inux(-gnu)?
896sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
897%endif
898%ifarch sparcv9
53fd58bc
AM
899sparcv8-[^-]*-[Ll]inux(-gnu)?
900sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
901%endif
902%ifarch sparc sparcv9 sparc64
53fd58bc 903sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
904%endif
905
2eb9303e
ER
906noarch-[^-]*-.*
907EOF
2d8ae03e 908
e5486255
ER
909# Squash Extra Blank Lines
910%{__sed} -i -e '/./,/^$/!d' $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
911
3a3e476f 912%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 913
61f7e1b3 914install %{SOURCE1} doc/manual/groups
d755a548 915install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
916install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
917install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
918install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
919install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
2f409bb7 920#install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
921cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
922install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 923install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 924install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 925
0bf34f68 926install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 927
950eead3
ER
928install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
929
0bf34f68 930install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
b1541d4c 931install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
0bf34f68
JR
932install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
933install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
934install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
935install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
0bf34f68 936install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 937
950eead3
ER
938touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
939touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 940install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
941touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
942touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
943touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 944
91ee86a9 945install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
345a6923 946install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
2f409bb7 947#install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 948
9776a251
JR
949# create macro loading wrappers for backward compatibility
950for m in gstreamer java mono perl php python; do
b279f099 951 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
952done
953
f3fd387a 954# for rpm -e|-U --repackage
a11e0e27
AM
955install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
956touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 957
950eead3
ER
958# move rpm to /bin
959mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
960# move essential libs to /lib (libs that /bin/rpm links to)
2f409bb7 961for a in librpm.so.%{sover} librpmbuild.so.%{sover} librpmio.so.%{sover} librpmsign.so.%{sover}; do
50dc9ac0
JK
962 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
963 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
964done
965
dae5e1a8 966%if %{with python}
6f18cdb7
AF
967%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
968%py_comp $RPM_BUILD_ROOT%{py_sitedir}
969
2f409bb7 970#%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
dae5e1a8 971%endif
01d7a578 972
01d7a578 973# wrong location, not used anyway
2f409bb7 974%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 975
90b03dd6 976%find_lang %{name}
cf6faebc 977
08697680 978%{__rm} -rf manual
a998ac11 979cp -a doc/manual manual
08697680 980%{__rm} -f manual/Makefile*
874f4c9a 981
13eb5ebf 982%clean
d7df46b8 983rm -rf $RPM_BUILD_ROOT
76214164 984
cc1a4992
ER
985%pretrans
986# this needs to be a dir
987if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 988 umask 022
cc1a4992
ER
989 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
990 mkdir %{_sysconfdir}/rpm/sysinfo
991fi
992
be4d3036 993%posttrans
d25ec6ea 994if [ -e /var/lib/rpm/Packages ] && \
6a934782 995 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 996 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 997 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 998 echo
e4dd6a34 999 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
1000 echo
1001 fi
3ca91ccd
JR
1002 echo
1003 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1004 echo 'you should ignore it and restart poldek'
1005 echo
3fc92bf7 1006 %{_rpmlibdir}/bin/dbupgrade.sh
be4d3036 1007fi
f7779567 1008
b7ee97ef
JR
1009%triggerpostun -- %{name} < 4.4.9-44
1010%{_rpmlibdir}/hrmib-cache
1011
ceaaacee
JB
1012%post lib -p /sbin/ldconfig
1013%postun lib -p /sbin/ldconfig
76214164 1014
37a5a2fc 1015%pretrans build
d755a548 1016find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1017
3684d90f
JB
1018%files -f %{name}.lang
1019%defattr(644,root,root,755)
241257bf 1020%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1021
3acb62f3
ER
1022%dir /etc/pki/rpm-gpg
1023/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 1024
7a9d72ce 1025%attr(755,root,root) /bin/rpm
e73478cd 1026
66edd895 1027%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 1028%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 1029%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1030# these are ok to be replaced
950eead3 1031%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1032%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1033
09bb810c 1034%{_mandir}/man8/rpm.8*
feb1f12e 1035%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1036%lang(ja) %{_mandir}/ja/man8/rpm.8*
ff7bc1e6 1037%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1038%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1039%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1040
e2025ad1 1041%dir /var/lib/rpm
74a997bd
JR
1042%dir /var/lib/rpm/log
1043%dir /var/lib/rpm/tmp
1044%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1045%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1046%dir /var/lock/rpm
1047/var/lock/rpm/transaction
4acac5de 1048
cf709a39
ER
1049# exported package NVRA (stamped with install tid)
1050# net-snmp hrSWInstalledName queries, bash-completions
1051%dir /var/cache/hrmib
1052
ec44785a 1053%{_rpmlibdir}/qf
d755a548
JK
1054%{_rpmlibdir}/rpmpopt*
1055%{_rpmlibdir}/macros
08697680
JR
1056%dir %{_rpmlibdir}/macros.d
1057%{_rpmlibdir}/macros.d/pld
9282ffe4 1058%{_rpmlibdir}/cpuinfo.yaml
e23edf35 1059%{_rpmlibdir}/noarch-*
c2683840 1060%ifarch %{ix86} %{x8664} x32
e23edf35
JR
1061%{_rpmlibdir}/i?86*
1062%{_rpmlibdir}/pentium*
1063%{_rpmlibdir}/athlon*
1064%endif
1065%ifarch alpha
1066%{_rpmlibdir}/alpha*
1067%endif
1068%ifarch ia64
1069%{_rpmlibdir}/ia64*
1070%endif
1071%ifarch mips mipsel mips64 mips64el
1072%{_rpmlibdir}/mips*
1073%endif
1074%ifarch %{ppc}
1075%{_rpmlibdir}/ppc*
1076%endif
1077%ifarch sparc sparc64
1078%{_rpmlibdir}/sparc*
1079%endif
c2683840 1080%ifarch %{x8664} x32
e23edf35
JR
1081%{_rpmlibdir}/amd64*
1082%{_rpmlibdir}/ia32e*
1083%{_rpmlibdir}/x86_64*
c2683840 1084%{_rpmlibdir}/x32*
e23edf35 1085%endif
3684d90f 1086
cf709a39
ER
1087%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1088
df50421f
JR
1089%dir %{_rpmlibdir}/bin
1090%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
14138aba 1091%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1092%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
345a6923 1093%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
0004e9b0 1094%attr(755,root,root) %{_rpmlibdir}/bin/rpmdbchk
df50421f 1095
66edd895
JB
1096%files base
1097%defattr(644,root,root,755)
492a2bd4 1098%dir %{_sysconfdir}/rpm
66edd895
JB
1099%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1100%dir %{_rpmlibdir}
1101%attr(755,root,root) %{_bindir}/banner.sh
1102%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1103%dir /var/lib/banner
1104
874f4c9a
MM
1105%files lib
1106%defattr(644,root,root,755)
950eead3
ER
1107%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1108%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1109%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1110%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1111%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1112%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1113
69131f1a
JB
1114%files devel
1115%defattr(644,root,root,755)
69131f1a
JB
1116%attr(755,root,root) %{_libdir}/librpm.so
1117%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1118%attr(755,root,root) %{_libdir}/librpmbuild.so
1119%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1120%attr(755,root,root) %{_libdir}/librpmconstant.so
1121%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1122%attr(755,root,root) %{_libdir}/librpmdb.so
1123%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1124%attr(755,root,root) %{_libdir}/librpmio.so
1125%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1126%attr(755,root,root) %{_libdir}/librpmmisc.so
1127%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1128%{_libdir}/librpm*.la
1129%{_includedir}/rpm
1130%{_pkgconfigdir}/*.pc
69131f1a
JB
1131
1132%files static
1133%defattr(644,root,root,755)
1134%{_libdir}/librpm*.a
1135
1136%files utils
1137%defattr(644,root,root,755)
69131f1a 1138%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1139%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1140%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1141%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1142%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1143%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1144%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1145%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1146%attr(755,root,root) %{_rpmlibdir}/bin/find
1147%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1148%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1149%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1150%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1151%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1152%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
6e115b23
JR
1153%if %{with selinux}
1154%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1155%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1156%endif
d0ee0933 1157%{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
9282ffe4 1158%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1159%{_mandir}/man8/rpm2cpio.8*
ec44785a 1160%{_mandir}/man8/rpmconstant.8*
69131f1a 1161%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1162%{_mandir}/man8/rpmmtree.8*
69131f1a 1163%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
69131f1a
JB
1164%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
1165%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1166%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1167
1168%files utils-perl
1169%defattr(644,root,root,755)
1170%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1171
1172%if %{with static}
1173%files utils-static
1174%defattr(644,root,root,755)
1175%attr(755,root,root) %{_bindir}/rpm[ieu]
1176%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1177%endif
1178
3684d90f 1179%files build
a45ae6d8 1180%defattr(644,root,root,755)
66edd895 1181%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1182%attr(755,root,root) %{_rpmlibdir}/brp-*
1183%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1184%attr(755,root,root) %{_rpmlibdir}/compress-doc
1185%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1186%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1187%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1188%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1189%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1190%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1191%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1192%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1193# needs hacked pkg-config to return anything
1194%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1195%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1196%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
ac8ac881 1197%{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
77fcdbf7
AF
1198%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1199%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f 1200%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
5131d1d1 1201%attr(755,root,root) %{_rpmlibdir}/bin/rpmspec
df50421f
JR
1202%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1203%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1204%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1205%attr(755,root,root) %{_rpmlibdir}/vcheck
410dd742 1206# not used yet ... these six depend on perl
ec44785a 1207%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1208# we always used scripts provided by mono-devel, maybe move them here
1209#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1210#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1211
70f8787d 1212%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1213# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1214%{_rpmlibdir}/macros.d/cmake
1215%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7
AF
1216%{_rpmlibdir}/macros.d/java
1217%{_rpmlibdir}/macros.d/libtool
1218%{_rpmlibdir}/macros.d/mono
1219%{_rpmlibdir}/macros.d/perl
1220%{_rpmlibdir}/macros.d/php
1221%{_rpmlibdir}/macros.d/pkgconfig
1222%{_rpmlibdir}/macros.d/python
3b644c29 1223%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1224%{_rpmlibdir}/macros.d/selinux
df50421f 1225%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1226%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1227# compat wrappers
1228%{_rpmlibdir}/macros.gstreamer
1229%{_rpmlibdir}/macros.java
1230%{_rpmlibdir}/macros.mono
1231%{_rpmlibdir}/macros.perl
1232%{_rpmlibdir}/macros.php
1233%{_rpmlibdir}/macros.python
77fcdbf7 1234
df50421f
JR
1235%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1236%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
df50421f 1237
874f4c9a
MM
1238%attr(755,root,root) %{_bindir}/gendiff
1239%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1240
1241%dir %{_rpmlibdir}/helpers
1242%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1243
a00926bc 1244%{_mandir}/man1/gendiff.1*
874f4c9a 1245%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1246%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1247%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1248%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1249
7d8492bb
JB
1250%files javaprov
1251%defattr(644,root,root,755)
1252%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1253# needs jar (any jdk), jcf-dump (gcc-java) to work
1254%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1255
ec49e9fb
ER
1256%files rubyprov
1257%defattr(644,root,root,755)
1258%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1259%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1260
89334051
AF
1261%files perlprov
1262%defattr(644,root,root,755)
d755a548 1263%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1264%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1265%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1266
80d3b868 1267%files pythonprov
d8fcb9b0 1268%defattr(644,root,root,755)
bdbae303 1269%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1270%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1271
d36cb682
PG
1272%files php-pearprov
1273%defattr(644,root,root,755)
9d09e076
ER
1274%attr(755,root,root) %{_rpmlibdir}/php.prov
1275%attr(755,root,root) %{_rpmlibdir}/php.req
1276%attr(755,root,root) %{_rpmlibdir}/php.req.php
d36cb682 1277
50dc9ac0 1278%if %{with python}
cf6faebc 1279%files -n python-rpm
42a0025c 1280%defattr(644,root,root,755)
b33910fe 1281%dir %{py_sitedir}/rpm
6f18cdb7 1282%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1283%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1284%endif
5c2ab5c7
AM
1285
1286%if %{with apidocs}
1287%files apidocs
1288%defattr(644,root,root,755)
1289%doc apidocs
1290%endif
This page took 0.994182 seconds and 4 git commands to generate.