]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
gem_helper: add action 'spec' just to write out .gemspec; always load rubygems
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
d0ee0933
JR
3# - make key infrastructure code fallback from keyutils to plain mode in case keyctl
4# returns -ENOSYS
9fb5ee9e 5# - add macros for some ppc, mipsel, alpha and sparc
a0c0c9ca 6#
c296fee0 7# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 8#
89427592 9# Conditional build:
01d7a578 10%bcond_with static # build static rpm+rpmi
0a1ccab0 11%bcond_without apidocs # don't generate documentation with doxygen
4af66a2c
JB
12%bcond_without python # don't build python bindings
13%bcond_without selinux # build without selinux support
0dc47449 14%bcond_without suggest_tags # build without Suggest tag (bootstrapping)
34befcc5 15%bcond_with neon # build with HTTP/WebDAV support (neon library)
6f6c7465 16%bcond_with sqlite # build with SQLite support
70df63f3 17%bcond_with system_lua # use system lua
d0ee0933 18%bcond_with keyutils # build with keyutils support
89427592
JB
19# force_cc - force using __cc other than "%{_target_cpu}-pld-linux-gcc"
20# force_cxx - force using __cxx other than "%{_target_cpu}-pld-linux-g++"
21# force_cpp - force using __cpp other than "%{_target_cpu}-pld-linux-gcc -E"
858aa7d0 22#
858aa7d0 23
ba7bedbb
JR
24%if %{with sqlite}
25# Error: /lib64/librpmio-5.4.so: undefined symbol: sqlite3_enable_load_extension
26%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
27%endif
28
003a039e 29# versions of required libraries
bf728d07 30%define reqdb_pkg db5.2
cf169f7c
JR
31%define reqdb_ver 5.2
32%define reqdb_pkgver 5.2.36.0-4
ec44785a 33%define reqpopt_ver 1.15
fc60c9f3 34%define beecrypt_ver 2:4.1.2-4
70f8787d 35%define sover 5.4
fc60c9f3 36
e5f02e49 37Summary: RPM Package Manager
4ea2ed33
ER
38Summary(de.UTF-8): RPM Packet-Manager
39Summary(es.UTF-8): Gestor de paquetes RPM
40Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
41Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
42Summary(ru.UTF-8): Менеджер пакетов от RPM
43Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 44Name: rpm
afb55538 45Version: 5.4.10
b53b1f84 46Release: 55
4e2db228 47License: LGPL v2.1
76214164 48Group: Base
afb55538
JR
49# http://rpm5.org/files/rpm/rpm-5.4/rpm-5.4.10-0.20120706.src.rpm
50Source0: %{name}-%{version}.tar.gz
51# Source0-md5: 5d099161bdd3203265ab32ffad3360b5
d38aed81
JR
52Source100: cpu-os-macros.tar.gz
53# Source100-md5: 928034a5bdceb398881bc14b5f29973b
ff7bc1e6 54Source1: %{name}.groups
08697680 55Source2: macros.pld.in
ff7bc1e6 56Source3: %{name}-install-tree
80b8a1f9 57Source4: %{name}-find-spec-bcond
cf709a39 58Source5: %{name}-hrmib-cache
80b8a1f9
JB
59Source6: %{name}-groups-po.awk
60Source7: %{name}-compress-doc
0bf34f68
JR
61Source8: %{name}-php-provides
62Source9: %{name}-php-requires
63Source10: %{name}.sysinfo
64Source11: perl.prov
65Source12: %{name}-user_group.sh
66Source13: %{name}.sysconfig
67Source14: %{name}-java-requires
a4b7ef27 68# http://svn.pld-linux.org/banner.sh/
0bf34f68
JR
69Source15: banner.sh
70Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
71# Source16-md5: 08b29584dd349aac9caa7610131a0a88
72Source17: %{name}-mimetypedeps
73Source18: macros.local
f09b01ac
ER
74Source19: %{name}.noautocompressdoc
75Source20: %{name}.noautoprov
76Source21: %{name}.noautoprovfiles
77Source22: %{name}.noautoreq
78Source23: %{name}.noautoreqdep
79Source24: %{name}.noautoreqfiles
0bf34f68 80Source25: %{name}-php-requires.php
f09b01ac 81Source26: %{name}db_checkversion.c
b1541d4c 82Source27: macros.lang
f09b01ac 83Source28: %{name}db_reset.c
14138aba 84Source29: dbupgrade.sh
f05db907 85Patch0: %{name}-branch.patch
2f0ee4ec 86Patch1: %{name}-man_pl.patch
38e53563 87Patch2: %{name}-popt-aliases.patch
c0fe6b09 88Patch3: %{name}-nosetproctitle.patch
3465efba 89Patch4: %{name}-perl-macros.patch
c1768ce2 90Patch5: %{name}-perl-req-perlfile.patch
3c7590cc
JR
91Patch6: %{name}-scripts-closefds.patch
92Patch7: %{name}-php-macros.patch
93Patch8: %{name}-gettext-in-header.patch
044171ea 94Patch9: %{name}-lua.patch
9ee75c3c
JR
95Patch10: %{name}-php-deps.patch
96Patch11: %{name}-notsc.patch
97Patch12: %{name}-hack-norpmlibdep.patch
06405080 98Patch13: %{name}-dont-copy-descriptive-tags.patch
9ee75c3c
JR
99Patch14: %{name}-perl_req-INC_dirs.patch
100Patch15: %{name}-debuginfo.patch
101Patch16: vendor-pld.patch
102Patch17: %{name}-old-fileconflicts-behaviour.patch
103Patch18: %{name}-javadeps.patch
104Patch19: %{name}-truncate-cvslog.patch
105Patch20: %{name}-libtool-deps.patch
106Patch21: %{name}-mimetype.patch
107Patch22: %{name}-sparc64.patch
108Patch23: %{name}-gendiff.patch
109Patch24: openmp.patch
110Patch25: %{name}-URPM-build-fix.patch
f7779567 111Patch26: %{name}-db5.3.patch
9ee75c3c
JR
112Patch27: %{name}-helperEVR-noassert.patch
113Patch28: %{name}-unglobal.patch
114Patch29: %{name}-builddir-readlink.patch
115Patch30: %{name}-changelog_order_check_nonfatal.patch
116Patch31: %{name}-cleanbody.patch
117Patch32: %{name}-dirdeps-macro.patch
118Patch33: %{name}-installbeforeerase.patch
119Patch34: %{name}-libmagic-locale.patch
120Patch35: %{name}-namespace-compare.patch
121Patch36: %{name}-popt-coreutils.patch
122Patch37: %{name}-postun-nofail.patch
123Patch38: %{name}-silence-RPM_CHAR_TYPE.patch
124Patch39: %{name}-fix-missing-types-in-headers.patch
125Patch40: %{name}-fix--p-interpreter-and-empty-script.patch
126Patch41: %{name}-db_buffer_small.patch
127Patch42: %{name}-pattern_Release.patch
128Patch43: %{name}-fix-___build_pre-macro.patch
129Patch44: %{name}-missing-patch-file-fails-build.patch
130Patch45: %{name}-remove-misleading-missing-patch-message.patch
131Patch46: %{name}-file-magic-can-be-mixed-case.patch
0b0a7839 132Patch47: %{name}-query-always-noisy.patch
7f7a3f24 133Patch48: %{name}-verify-ghosts-broken-logic.patch
295c267a 134Patch49: %{name}-python-enable-compat-RPMSENSE.patch
d6a36788 135Patch50: %{name}-dont-treat-gstreamer-modules-as-font.patch
bba1059c 136Patch51: %{name}-gst-inspect-typo.patch
1fcc9b69 137Patch52: %{name}-null-term-ascii-digest.patch
70df63f3 138Patch53: %{name}-lua-enable-extra-libs.patch
330093fa 139Patch54: %{name}-fix-filedigests-verify.patch
9158f140 140Patch55: %{name}-disable-hmac-verify.patch
f09b01ac 141Patch56: %{name}-macros.patch
f7779567 142Patch57: %{name}-db5.2.patch
c4861085 143Patch58: %{name}-preserve-iterator.patch
9e6f2e68 144Patch59: %{name}-triggerin-compat.patch
b10643ac 145Patch60: %{name}-python-sitescriptdir.patch
a6170fd4 146Patch61: %{name}-clean-docdir.patch
108e9711 147Patch62: %{name}-DB_CONFIG.patch
fb11a0dd 148Patch63: %{name}-pythoneggs.patch
80e5119e 149Patch64: %{name}-fix-compress-doc.patch
94807250 150Patch65: %{name}-parseSpec-skip-empty-tags.patch
10526c23 151Patch66: %{name}-payload-use-hashed-inode.patch
4e2db228 152Patch67: %{name}-repackage-dont-force-max-compression.patch
281a8c30 153Patch68: rubyprov-archdirs.patch
e229e8ab 154Patch69: rubyprov-abi-versioned.patch
4e2db228 155Patch70: python-%{name}sense-missingok.patch
497556c4 156Patch71: %{name}-changelog-encoding.patch
c065c1c1 157Patch72: %{name}-preserve-tag-type.patch
b53b1f84 158Patch73: gem_helper-spec-arg.patch
70f8787d
JR
159
160# Patches imported from Mandriva
161
162# status: ready to merge, it's already been merged on HEAD, so commiting it to rpm-5_4
163# would basically just mean backporting it..
f09b01ac 164Patch1000: %{name}-5.4.4-add-_specfile-macro.patch
70f8787d
JR
165# status: needs to be cleaned up and properly reviewed together with rest
166# of the patches related to dependency generation
f09b01ac 167Patch1001: %{name}-5.4.9-avoid-dependencies-on-self.patch
70f8787d 168# status: probably ready to merge
f09b01ac 169Patch1002: %{name}-5.4.4-pkgconfigdeps-check-path.patch
70f8787d 170# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 171Patch1003: %{name}-5.4.4-glob-wildcards-for-loading-macro-files.patch
70f8787d 172# status: needs to be discussed
f09b01ac 173Patch1004: %{name}-5.4.4-allow-installation-of-repackaged-rpms.patch
70f8787d 174# status: ready to merge
f09b01ac 175Patch1005: %{name}-5.4.8-dont-show-suggests-with-requires.patch
70f8787d 176# status: ready for merge
f09b01ac 177Patch1006: %{name}-5.4.9-strip-buildroot-away-from-duplicate-files-list.patch
70f8787d 178# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 179Patch1007: %{name}-5.4.10-duplicate_files_terminate_build.patch
70f8787d 180# status: same as above
f09b01ac 181Patch1008: %{name}-5.4.10-unpackaged_subdirs_terminate_build.patch
70f8787d
JR
182# mdvbz#64898
183# status: uncertain, might be okay to merge, discuss on rpm-devel first
f09b01ac 184Patch1009: %{name}-5.4.4-rpmbuild-withoutclean.patch
70f8787d
JR
185# no sense in having an additional dependency on 'pkgconfig' on all packages that
186# have a pkgconfig file, it's not needed for them to be made useful and anything
187# actuallly using pkgconfig for this purpose will pull it in as a dependency anyways...
188# status: might be okay to merge, but discuss on rpm-devel first
f09b01ac 189Patch1010: %{name}-5.4.4-drop-useless-auto-generated-pkgconfig-dependency.patch
70f8787d 190# status: ready for merge
f09b01ac 191Patch1011: %{name}-5.4.4-fix-rpmconstant-to-always-use-LC_CTYPE-C-for-case-conversion.patch
70f8787d
JR
192# $RPM_BUILD_DIR isn't necessarily the same as $PWD, it's %%{_builddir}, not
193# %%{_builddir}/%%{?buildsubdir}, messing up paths in debug packages created..
194# status: needs to be discussed and investigated a bit better..
f09b01ac 195Patch1012: %{name}-5.4.4-pass-_builddir-properly-to-find-debuginfo.patch
70f8787d 196# status: probably okay to merge, but discuss on rpm-devel first
f09b01ac 197Patch1013: %{name}-5.4.10-files-listed-twice-terminates-build.patch
70f8787d 198# status: probably okay to merge
f09b01ac 199Patch1014: %{name}-5.4.9-ruby1.9-fixes.patch
70f8787d 200# status: keep locally
f09b01ac 201Patch1015: %{name}-5.4.9-keep-loading-script-macros.patch
70f8787d 202# status: same as for other dep gen patches
f09b01ac 203Patch1016: %{name}-5.4.9-update-rpmfc-when-removing-dependencies-on-self.patch
70f8787d 204# status: idem
f09b01ac 205Patch1017: %{name}-5.4.9-rpmfc-extract-dependencies-for-all-files.patch
70f8787d 206# status: ready for merge
f09b01ac 207Patch1018: %{name}-5.4.5-rubygems-add-missing-newline.patch
70f8787d 208# status: probably okay to merge
f09b01ac 209Patch1019: %{name}-5.4.5-python-export-spec-macros.patch
70f8787d 210# status: idem
f09b01ac 211Patch1020: %{name}-5.4.9-font-provides.patch
70f8787d 212# stauus: idem
f09b01ac 213Patch1021: %{name}-5.4.7-kmod-dependencies.patch
70f8787d 214# status: probably okay to merge, discuss on rpm-devel first
f09b01ac 215Patch1022: %{name}-5.4.5-skip-dependencies-for-character-devices.patch
70f8787d 216# status: ready to merge
f09b01ac 217Patch1023: %{name}-5.4.5-rpmfc-use-strlen-not-sizeof.patch
70f8787d 218# status: probably okay to merge
f09b01ac 219Patch1024: %{name}-5.4.5-rpmfc-apply-python-coloring-from-magic.patch
70f8787d 220# status: ready to merge
f09b01ac 221Patch1025: %{name}-5.4.7-rpmfc-fix-invalid-free-if-not-_defaultdocdir-set.patch
70f8787d 222# status: probably okay to merge
f09b01ac 223Patch1026: %{name}-5.4.10-dont-try-generate-rpmfc-dependencies-from-doc-files.patch
70f8787d 224# status: ready
f09b01ac 225Patch1027: %{name}-5.4.7-fix-generation-of-ruby-abi-provides.patch
70f8787d
JR
226# crash reproducable with 'rpm -qa --triggers'
227# status: ready
f09b01ac 228Patch1028: %{name}-5.4.7-hdrfmt-fix-unitialized-argv-element.patch
70f8787d 229# status: same as for other dep gen patches
f09b01ac 230Patch1029: %{name}-5.4.7-dont-consider-trigger-dependencies-as-overlapping.patch
70f8787d 231# status: ready
f09b01ac 232Patch1030: %{name}-5.4.7-fix-minor-memleaks.patch
70f8787d 233# status: ready
f09b01ac 234Patch1031: %{name}-5.4.9-mire-fix-strings-lacking-null-terminator.patch
70f8787d 235# status: ready
f09b01ac 236Patch1032: %{name}-5.4.9-rpmpython-fix-input.patch
70f8787d 237# status: ready
f09b01ac 238Patch1033: %{name}-5.4.7-no-seqid_init-on-rdonly-database.patch
70f8787d 239# status: probably ready for merging
f09b01ac 240Patch1034: %{name}-5.4.9-avoid-double-slash-in-path-for-dirname-filetrigger-matching.patch
70f8787d 241# status: probably ready to merge, discuss on rpm-devel first
f09b01ac 242Patch1035: %{name}-5.4.9-fix-verify-segfault.patch
70f8787d 243# status: ready and should be merged
f09b01ac 244Patch1036: %{name}-5.4.9-fix-typo-in-rpmtag-header.patch
70f8787d
JR
245# Due to rpmdav/neon being written in a different fashion than other rpmio clients,
246# the inconsistent behaviour affects code elsewhere which expects consistent behaviour,
247# with the result being that when unable to download files, neon will save error
248# page as the target file.
249# status: should go upstream, but uncertain about "correct" fix, ie. this is
250# more of a workaround, while rewriting rpmdav code to behave consistently
251# would be "the right thing to do". Yet I'm not fully able to grasp all of the
252# code and don't want to spend more time just to get the API..
f09b01ac 253Patch1037: %{name}-5.4.10-fix-neon-saving-error-pages-as-target-file.patch
70f8787d
JR
254# As the transaction flags for ignoring arch & os are no longer used, there's
255# currently no way to ignore arch & os of packages anymore. This patch adds
256# support for doing this again by defining rpm variables and overriding
257# --ignorearch & --ignoreos to set these.
258# status: needs to be discussed upstream before thinking about merging
f09b01ac 259Patch1038: %{name}-5.4.10-support-ignore-arch-and-os-again.patch
9f9190ed 260# status: ready for merge
f09b01ac 261Patch1039: %{name}-5.4.4-fix-same-package-with-epoch-possible-to-upgrade.patch
e85b33bb 262# we want that patch too, a bit of builder infrastructure relies on NOSIGNATURES
f09b01ac 263Patch1040: %{name}-5.4.9-support-signatures-and-digest-disablers.patch
5555c3a0
JR
264# lack insight on actual functionality, which anyways seems broken, so let's
265# disable it to avoid errors from berkeley db..
266# status: keep locally
f09b01ac 267Patch1041: %{name}-5.4.9-disable-l10ndir.patch
dfd6cb49 268# status: ready for merge
f09b01ac 269Patch1042: %{name}-5.4.9-fix-rpm_qa-pattern.patch
70f8787d 270
955f2725 271URL: http://rpm5.org/
cf169f7c 272BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
6f6c7465
JR
273%if %{with sqlite}
274BuildRequires: sqlite3-devel
275%else
cf169f7c 276BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
6f6c7465 277%endif
6a8612bc 278BuildRequires: autoconf >= 2.60
644d8958 279BuildRequires: automake >= 1.4
87ef0d95 280BuildRequires: beecrypt-devel >= %{beecrypt_ver}
33be5db0 281BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 282BuildRequires: elfutils-devel >= 0.108
0ef6aeae 283#BuildRequires: gettext-autopoint >= 0.11.4-2
d1795eb0 284BuildRequires: gettext-devel >= 0.11.4-2
d0ee0933 285%{?with_keyutils:BuildRequires: keyutils-devel}
241257bf 286BuildRequires: libmagic-devel
6e115b23
JR
287%if %{with selinux}
288BuildRequires: libselinux-devel >= 2.1.0
6e115b23 289BuildRequires: libsemanage-devel >= 2.1.0
3acb62f3 290BuildRequires: libsepol-devel >= 2.1.0
6e115b23 291%endif
84cdee7a
JB
292# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
293BuildRequires: libstdc++-devel
b60c74c3 294BuildRequires: libtool >= 1:1.4.2-9
33be5db0 295%if %{with neon}
fe861705 296BuildRequires: libxml2-devel
83d6a3fe 297BuildRequires: neon-devel >= 0.25.5
33be5db0 298%endif
3acb62f3 299%{?with_system_lua:BuildRequires: lua51-devel >= 5.1.2}
127a0b3c 300BuildRequires: ossp-uuid-devel
7973b351 301BuildRequires: patch >= 2.2
1d49ffbc 302BuildRequires: popt-devel >= %{reqpopt_ver}
950eead3
ER
303%{?with_python:BuildRequires: python-devel >= 1:2.3}
304BuildRequires: python-modules >= 1:2.3
2a813afe 305%{?with_python:BuildRequires: rpm-pythonprov}
e56a10a9 306BuildRequires: tcl
77fcdbf7 307BuildRequires: xz-devel
3acb62f3 308BuildRequires: zlib-devel
5c2ab5c7
AM
309%if %{with apidocs}
310BuildRequires: doxygen
311BuildRequires: ghostscript
312BuildRequires: graphviz
313BuildRequires: tetex-pdftex
314%endif
a6e56ce4 315%if %{with static}
e6090a7b 316# Require static library only for static build
cf169f7c 317BuildRequires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
87ef0d95 318BuildRequires: beecrypt-static >= %{beecrypt_ver}
33be5db0 319BuildRequires: bzip2-static >= 1.0.2-17
290c1c30 320BuildRequires: elfutils-static
10abbd40 321BuildRequires: glibc-static >= 2.2.94
241257bf 322BuildRequires: libmagic-static
6e115b23
JR
323%if %{with selinux}
324BuildRequires: libselinux-static >= 2.1.0
6e115b23 325BuildRequires: libsemanage-static >= 2.1.0
3acb62f3 326BuildRequires: libsepol-static >= 2.1.0
6e115b23 327%endif
003a039e 328BuildRequires: popt-static >= %{reqpopt_ver}
1d49ffbc 329BuildRequires: zlib-static
7a9d72ce 330%endif
d25ec6ea 331Requires(posttrans): coreutils
66edd895 332Requires: %{name}-base = %{version}-%{release}
b26a9709 333Requires: %{name}-lib = %{version}-%{release}
10abbd40
ER
334Requires: beecrypt >= %{beecrypt_ver}
335Requires: popt >= %{reqpopt_ver}
0229a8b9
AM
336Provides: rpm-db-ver = %{reqdb_ver}
337Obsoletes: rpm-getdeps
4adb7d05 338%{!?with_static:Obsoletes: rpm-utils-static}
874f4c9a 339Conflicts: glibc < 2.2.92
8ee1c72c
AM
340# db4.6 poldek needed
341Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
342# segfaults with lzma 0.42.2
343Conflicts: lzma-libs < 4.999.3
e4084afd 344Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 345BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 346
4adb7d05 347%define _binary_payload w9.gzdio
6d82b332 348
4cd84746
JB
349# don't require very fresh rpm.macros to build
350%define __gettextize gettextize --copy --force --intl ; cp -f po/Makevars{.template,}
950eead3 351%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
9f517079 352%define ix86 i386 i486 i586 i686 athlon pentium3 pentium4
80e9f34d 353%define ppc ppc ppc7400 ppc7450
9f517079 354%define x8664 amd64 ia32e x86_64
4cd84746 355
89427592 356# stabilize new build environment
f9ac32aa
AM
357%define __newcc %{?force_cc}%{!?force_cc:%{_target_cpu}-pld-linux-gcc}
358%define __newcxx %{?force_cxx}%{!?force_cxx:%{_target_cpu}-pld-linux-g++}
359%define __newcpp %{?force_cpp}%{!?force_cpp:%{_target_cpu}-pld-linux-gcc -E}
89427592 360
d755a548 361%define _rpmlibdir /usr/lib/rpm
950eead3 362%define _noautocompressdoc RPM-GPG-KEY
d755a548 363
ff7bc1e6 364%description
365RPM is a powerful package manager, which can be used to build,
366install, query, verify, update, and uninstall individual software
cf6faebc 367packages. A package consists of an archive of files, and package
fed73700 368information, including name, version, and description.
369
dd85fadc
JR
370%description -l de.UTF-8
371RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 372Installation, Anfrage, Verifizierung, Aktualisierung und
373Uninstallation individueller Softwarepakete. Ein Paket besteht aus
374einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 375Beschreibung.
376
dd85fadc 377%description -l es.UTF-8
313a4d1a 378RPM es un poderoso administrador de paquetes, que puede ser usado para
379construir, instalar, pesquisar, verificar, actualizar y desinstalar
380paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
381almacenaje de archivos, y información sobre el paquete, incluyendo
382nombre, versión y descripción.
383
384%description -l pl.UTF-8
385RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
386przebudowanie, instalację czy weryfikację dowolnego pakietu.
387Informacje dotyczące każdego pakietu, takie jak jego opis, lista
388plików wchodzących w skład pakietu, zależności od innych pakietów, są
389przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 390odpytywania programu rpm.
391
dd85fadc
JR
392%description -l pt_BR.UTF-8
393RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 394construir, instalar, pesquisar, verificar, atualizar e desinstalar
395pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
396arquivos e informações adicionais, incluindo nome, versão e descrição
397do pacote, permissões dos arquivos, etc.
398
399%description -l ru.UTF-8
400RPM - это мощный менеджер пакетов, который может быть использован для
401создания, инсталляции, запросов (query), проверки, обновления и
402удаления программных пакетов. Пакет состоит из файлового архива и
403служебной информации, включающей название, версию, описание и другие
404данные о пакете.
405
406%description -l uk.UTF-8
407RPM - це потужний менеджер пакетів, що може бути використаний для
408створення, інсталяції, запитів (query), перевірки, поновлення та
409видалення програмних пакетів. Пакет складається з файлового архіву та
410службової інформації, що містить назву, версію, опис та іншу
411інформацію про пакет.
7c6dc55f 412
66edd895
JB
413%package base
414Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 415Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 416Group: Base
1d9ca0c1 417Requires: filesystem
950eead3 418Obsoletes: rpm-scripts
66edd895
JB
419Obsoletes: vserver-rpm
420
421%description base
422The RPM base package contains scripts used by rpm packages themselves.
423These include:
424- scripts for adding/removing groups and users needed for rpm
425 packages,
426- banner.sh to display %%banner messages from rpm scriptlets.
427
dd85fadc
JR
428%description base -l pl.UTF-8
429Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 430Zawiera on:
dd85fadc
JR
431- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
432- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 433
69131f1a
JB
434%package lib
435Summary: RPMs library
4ea2ed33 436Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 437Group: Libraries
cf169f7c 438Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
6f6c7465
JR
439%if %{with sqlite}
440Requires: sqlite3 >= %{sqlite_build_version}
441%else
cf169f7c 442Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
6f6c7465 443%endif
3acb62f3 444Requires: beecrypt >= %{beecrypt_ver}
241257bf 445Requires: libmagic >= 1.15-2
6e115b23 446%{?with_selinux:Requires: libselinux >= 2.1.0}
69131f1a 447Requires: popt >= %{reqpopt_ver}
d1795eb0 448Obsoletes: rpm-libs
69131f1a
JB
449# avoid SEGV caused by mixed db versions
450Conflicts: poldek < 0.18.1-16
451
452%description lib
453RPMs library.
454
dd85fadc 455%description lib -l pl.UTF-8
69131f1a
JB
456Biblioteki RPM-a.
457
fed73700 458%package devel
3f2d796a 459Summary: Header files for rpm libraries
4ea2ed33
ER
460Summary(de.UTF-8): Header-Dateien für rpm Libraries
461Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
462Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
463Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
464Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
465Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 466Group: Development/Libraries
153e5706 467Requires: %{name}-lib = %{version}-%{release}
cf169f7c 468Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
87ef0d95 469Requires: beecrypt-devel >= %{beecrypt_ver}
fea3cb89 470Requires: bzip2-devel
5c583f90 471Requires: elfutils-devel
d0ee0933 472%{?with_keyutils:Requires: keyutils-devel}
241257bf 473Requires: libmagic-devel
10abbd40 474%{?with_selinux:Requires: libselinux-devel}
a998ac11 475Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 476Requires: zlib-devel
cf6faebc 477
478%description devel
3f2d796a
JB
479The RPM packaging system includes C libraries that make it easy to
480manipulate RPM packages and databases. They are intended to ease the
cf6faebc 481creation of graphical package managers and other tools that need
3f2d796a
JB
482intimate knowledge of RPM packages. This package contains header files
483for these libraries.
fed73700 484
dd85fadc
JR
485%description devel -l de.UTF-8
486Der RPM-Packensystem enthält eine C-Library, die macht es einfach
487RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 488Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 489Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
490
dd85fadc 491%description devel -l es.UTF-8
313a4d1a 492El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
493fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
494facilitar la creación de administradores gráficos de paquetes y otras
20f89981 495herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 496
dd85fadc
JR
497%description devel -l pl.UTF-8
498System RPM zawiera biblioteki C, które ułatwiają manipulowanie
499pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
500graficznych programów zarządzających pakietami oraz innych narzędzi,
501które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
502zawiera pliki nagłówkowe wspomnianych bibliotek.
503
504%description devel -l pt_BR.UTF-8
505O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
506a manipulação de pacotes e bases de dados RPM. Seu objetivo é
507facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 508ferramentas que precisem de conhecimento profundo de pacotes RPM.
509
dd85fadc
JR
510%description devel -l ru.UTF-8
511Система управления пакетами RPM содержит библиотеку C, которая
512упрощает манипуляцию пакетами RPM и соответствующими базами данных.
513Эта библиотека предназначена для облегчения создания графических
514пакетных менеджеров и других утилит, которым необходимо работать с
515пакетами RPM.
7c6dc55f 516
dd85fadc
JR
517%description devel -l uk.UTF-8
518Система керування пакетами RPM містить бібліотеку C, котра спрощує
519роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
520призначена для полегшення створення графічних пакетних менеджерів та
521інших утиліт, що працюють з пакетами RPM.
7c6dc55f 522
fed73700 523%package static
9e42d68a 524Summary: RPM static libraries
4ea2ed33
ER
525Summary(de.UTF-8): RPMs statische Libraries
526Summary(pl.UTF-8): Biblioteki statyczne RPM-a
527Summary(pt_BR.UTF-8): Bibliotecas estáticas para o desenvolvimento de aplicações RPM
528Summary(ru.UTF-8): Статическая библиотека для программ, работающих с rpm-пакетами
529Summary(uk.UTF-8): Статична бібліотека для програм, що працюють з пакетами rpm
edacdf8f 530Group: Development/Libraries
153e5706 531Requires: %{name}-devel = %{version}-%{release}
cf169f7c 532Requires: %{reqdb_pkg}-static >= %{reqdb_pkgver}
87ef0d95 533Requires: beecrypt-static >= %{beecrypt_ver}
df76dbd9 534Requires: bzip2-static
ff03e01a 535Requires: elfutils-static
d0ee0933 536%{?with_keyutils:Requires: keyutils-static}
241257bf 537Requires: libmagic-static
a998ac11 538Requires: popt-static >= %{reqpopt_ver}
df76dbd9 539Requires: zlib-static
edacdf8f 540
541%description static
20f89981 542RPM static libraries.
fed73700 543
dd85fadc 544%description static -l de.UTF-8
20f89981 545RPMs statische Libraries.
9e42d68a 546
dd85fadc 547%description static -l pl.UTF-8
0a7ae9bc 548Biblioteki statyczne RPM-a.
313a4d1a 549
dd85fadc
JR
550%description static -l pt_BR.UTF-8
551Bibliotecas estáticas para desenvolvimento.
edacdf8f 552
dd85fadc
JR
553%description static -l ru.UTF-8
554Система управления пакетами RPM содержит библиотеку C, которая
555упрощает манипуляцию пакетами RPM и соответствующими базами данных.
556Это статическая библиотека RPM.
7c6dc55f 557
dd85fadc
JR
558%description static -l uk.UTF-8
559Система керування пакетами RPM містить бібліотеку C, котра спрощує
560роботу з пакетами RPM та відповідними базами даних. Це статична
561бібліотека RPM.
7c6dc55f 562
fed73700 563%package utils
8482995c 564Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
565Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
566Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 567Group: Applications/File
153e5706 568Requires: %{name} = %{version}-%{release}
a998ac11 569Requires: popt >= %{reqpopt_ver}
86b85368
AG
570%if %{with suggest_tags}
571Suggests: bzip2
572Suggests: gzip
86b85368 573%endif
695e60ad 574Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 575
576%description utils
8482995c 577Additional utilities for managing RPM packages and database.
fed73700 578
dd85fadc
JR
579%description utils -l de.UTF-8
580Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 581
dd85fadc
JR
582%description utils -l pl.UTF-8
583Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 584
92b3f576 585%package utils-perl
8482995c 586Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
587Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
588Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
92b3f576 589Group: Applications/File
153e5706 590Requires: %{name}-utils = %{version}-%{release}
92b3f576 591Requires: popt >= %{reqpopt_ver}
592
593%description utils-perl
8482995c 594Additional utilities for managing RPM packages and database.
92b3f576 595
dd85fadc
JR
596%description utils-perl -l de.UTF-8
597Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
92b3f576 598
dd85fadc
JR
599%description utils-perl -l pl.UTF-8
600Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
92b3f576 601
a00926bc
JB
602%package utils-static
603Summary: Static rpm utilities
4ea2ed33 604Summary(pl.UTF-8): Statyczne narzędzia rpm
a00926bc 605Group: Applications/System
153e5706 606Requires: %{name} = %{version}-%{release}
a00926bc
JB
607
608%description utils-static
609Static rpm utilities for repairing system in case something with
610shared libraries used by rpm become broken. Currently it contains rpmi
611binary, which can be used to install/upgrade/remove packages without
612using shared libraries (well, in fact with exception of NSS modules).
613
dd85fadc
JR
614%description utils-static -l pl.UTF-8
615Statyczne narzędzia rpm do naprawy systemu w przypadku zepsucia czegoś
616związanego z bibliotekami współdzielonymi używanymi przez rpm-a.
617Aktualnie pakiet zawiera binarkę rpmi, którą można użyć do instalacji,
618uaktualniania lub usuwania pakietów bez udziału bibliotek statycznych
619(z wyjątkiem modułów NSS).
a00926bc 620
fed73700 621%package build
e191287c 622Summary: Scripts for building binary RPM packages
4ea2ed33
ER
623Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
624Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
625Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
626Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
627Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 628Group: Applications/File
8f76a271 629Requires(pre): findutils
7cf857f2 630Requires: %{name}-build-macros >= 1.656
153e5706 631Requires: %{name}-utils = %{version}-%{release}
e191287c 632Requires: /bin/id
633Requires: awk
cfa7898a 634Requires: bzip2
e950a6d7 635Requires: chrpath >= 0.10-4
b6547e10 636Requires: cpio
e191287c 637Requires: diffutils
195f647c 638Requires: elfutils
583135b4 639Requires: file >= 4.17
e191287c 640Requires: fileutils
641Requires: findutils
950eead3
ER
642%ifarch athlon
643Requires: gcc >= 3.0.3
644%else
645Requires: gcc
646%endif
e191287c 647Requires: glibc-devel
648Requires: grep
649Requires: gzip
650Requires: make
651Requires: patch
adbd4815 652Requires: sed >= 4.0
e191287c 653Requires: sh-utils
adbd4815 654Requires: tar >= 1:1.22
e191287c 655Requires: textutils
3acb62f3 656Requires: which
adbd4815 657Requires: xz
ca3648b1 658Provides: rpmbuild(monoautodeps)
37ea389a 659Provides: rpmbuild(noauto) = 3
02d17bf9 660%ifarch %{x8664}
195f647c
JB
661Conflicts: automake < 1:1.7.9-2
662Conflicts: libtool < 2:1.5-13
663%endif
0096c5cd 664
e2025ad1 665%description build
58399c37 666Scripts for building binary RPM packages.
fed73700 667
dd85fadc
JR
668%description build -l de.UTF-8
669Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 670
dd85fadc
JR
671%description build -l pl.UTF-8
672Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 673
dd85fadc
JR
674%description build -l pt_BR.UTF-8
675Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 676construir pacotes usando o RPM.
e73478cd 677
dd85fadc
JR
678%description build -l ru.UTF-8
679Различные вспомогательные скрипты и исполняемые программы, которые
680используются для сборки RPM'ов.
7c6dc55f 681
dd85fadc
JR
682%description build -l uk.UTF-8
683Різноманітні допоміжні скрипти та утиліти, які використовуються для
684побудови RPM'ів.
7c6dc55f 685
8482995c
JB
686%package javaprov
687Summary: Additional utilities for checking Java provides/requires in RPM packages
688Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach RPM
689Group: Applications/File
690Requires: %{name} = %{version}-%{release}
691Requires: file
692Requires: findutils >= 1:4.2.26
693Requires: mktemp
694Requires: unzip
695
696%description javaprov
697Additional utilities for checking Java provides/requires in RPM
698packages.
699
700%description javaprov -l pl.UTF-8
701Dodatkowe narzędzia do sprawdzania zależności kodu w Javie w pakietach
702RPM.
703
69131f1a 704%package perlprov
8482995c 705Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 706Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 707Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a
JB
708Group: Applications/File
709Requires: %{name} = %{version}-%{release}
710Requires: perl-devel
711Requires: perl-modules
712
713%description perlprov
8482995c 714Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
715packages.
716
dd85fadc
JR
717%description perlprov -l de.UTF-8
718Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 719
dd85fadc 720%description perlprov -l pl.UTF-8
8482995c
JB
721Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
722pakietach RPM.
69131f1a
JB
723
724%package pythonprov
8482995c
JB
725Summary: Python macros, which simplifies creation of RPM packages with Python software
726Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a
JB
727Group: Applications/File
728Requires: %{name} = %{version}-%{release}
cd800b3c 729Requires: python
bdbae303 730Requires: python-distribute
3acb62f3 731Requires: python-modules
69131f1a
JB
732
733%description pythonprov
8482995c 734Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
735software.
736
dd85fadc 737%description pythonprov -l pl.UTF-8
8482995c 738Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
739Pythonie.
740
741%package php-pearprov
8482995c
JB
742Summary: Additional utilities for checking PHP PEAR provides/requires in RPM packages
743Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzania zależności skryptów php w RPM
69131f1a
JB
744Group: Applications/File
745Requires: %{name} = %{version}-%{release}
632f1b5c 746Requires: sed >= 4.0
1b39d378 747Suggests: php-pear-PHP_CompatInfo
69131f1a
JB
748
749%description php-pearprov
8482995c 750Additional utilities for checking PHP PEAR provides/requires in RPM
69131f1a
JB
751packages.
752
dd85fadc 753%description php-pearprov -l pl.UTF-8
8482995c
JB
754Dodatkowe narzędzia do sprawdzenia zależności skryptów PHP PEAR w
755pakietach RPM.
69131f1a 756
ec49e9fb
ER
757%package rubyprov
758Summary: Ruby tools, which simplify creation of RPM packages with Ruby software
759Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Ruby
760Group: Applications/File
761Requires: %{name} = %{version}-%{release}
762Requires: ruby
763Requires: ruby-modules
b53b1f84 764Requires: ruby-rubygems
ec49e9fb
ER
765
766%description rubyprov
767Ruby tools, which simplifies creation of RPM packages with Ruby
768software.
769
770%description rubyprov -l pl.UTF-8
771Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
772Ruby.
773
69131f1a
JB
774%package -n python-rpm
775Summary: Python interface to RPM library
4ea2ed33
ER
776Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
777Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a
JB
778Group: Development/Languages/Python
779Requires: %{name} = %{version}-%{release}
3acb62f3 780Requires: python
69131f1a
JB
781Obsoletes: rpm-python
782
783%description -n python-rpm
784The rpm-python package contains a module which permits applications
785written in the Python programming language to use the interface
786supplied by RPM (RPM Package Manager) libraries.
787
788This package should be installed if you want to develop Python
789programs that will manipulate RPM packages and databases.
790
dd85fadc
JR
791%description -n python-rpm -l pl.UTF-8
792Pakiet rpm-python zawiera moduł, który pozwala aplikacjom napisanym w
793Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 794
dd85fadc
JR
795Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
796Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 797
dd85fadc
JR
798%description -n python-rpm -l pt_BR.UTF-8
799O pacote rpm-python contém um módulo que permite que aplicações
69131f1a
JB
800escritas em Python utilizem a interface fornecida pelas bibliotecas
801RPM (RPM Package Manager).
802
dd85fadc 803Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
804Python para manipular pacotes e bancos de dados RPM.
805
5c2ab5c7
AM
806%package apidocs
807Summary: RPM API documentation and guides
808Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
809Group: Documentation
810
811%description apidocs
812Documentation for RPM API and guides in HTML format generated from rpm
813sources by doxygen.
814
815%description apidocs -l pl.UTF-8
816Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
817źrodeł RPM-a przez doxygen.
818
e2025ad1 819%prep
d38aed81 820%setup -q -n %{name}-%{version}%{?subver} -a100
317ef122 821#patch0 -p1
2f0ee4ec 822%patch1 -p1
4d5b8e4c 823%patch2 -p1
c0fe6b09 824%patch3 -p1
7a3b1f24
AM
825%patch4 -p1
826%patch5 -p1
3c7590cc 827%patch6 -p1
c1768ce2 828%patch7 -p1
7a3b1f24 829%patch8 -p1
3c7590cc 830%{?with_system_lua:%patch9 -p1}
9ee75c3c 831%patch10 -p1
686b0204
JR
832%ifnarch i386 i486
833# enable TSC for capable archs
9ee75c3c 834%patch11 -p1
3c7590cc 835%endif
9ee75c3c
JR
836%patch12 -p1
837%patch13 -p1
838%patch14 -p0
7033e976 839%patch15 -p1
9ee75c3c 840%patch16 -p1
3c7590cc
JR
841%patch17 -p1
842%patch18 -p1
843%patch19 -p1
844%patch20 -p1
845%patch21 -p1
9ee75c3c 846%ifarch sparc64
3c7590cc 847%patch22 -p1
9ee75c3c 848%endif
3c7590cc 849%patch23 -p1
3c7590cc 850%patch24 -p1
3c7590cc 851%patch25 -p1
f7779567 852####%patch26 -p1
24123ddd 853%patch27 -p1
3c7590cc
JR
854%patch28 -p1
855%patch29 -p1
856%patch30 -p1
857%patch31 -p1
858%patch32 -p1
859%patch33 -p1
950eead3 860%patch34 -p1
3c7590cc 861%patch35 -p1
148c9957 862%patch36 -p1
3c7590cc
JR
863%patch37 -p1
864%patch38 -p1
865%patch39 -p1
866%patch40 -p1
f7779567 867####%patch41 -p1
9ee75c3c 868%patch42 -p1
9f9190ed 869%patch43 -p1
1d20bd4e 870%patch44 -p1
e94735a5 871%patch45 -p1
7070b427 872%patch46 -p1
358bccd1 873%patch47 -p1
7f7a3f24 874%patch48 -p1
295c267a 875%patch49 -p1
d6a36788 876%patch50 -p1
bba1059c 877%patch51 -p1
1fcc9b69 878%patch52 -p0
70df63f3 879%patch53 -p1
330093fa 880%patch54 -p1
9158f140 881%patch55 -p1
267d7641 882%patch56 -p1
f7779567 883%patch57 -p1
c4861085 884%patch58 -p1
9e6f2e68 885%patch59 -p1
b10643ac 886%patch60 -p1
a6170fd4 887%patch61 -p1
108e9711 888%patch62 -p1
fb11a0dd 889%patch63 -p1
80e5119e 890%patch64 -p1
94807250 891%patch65 -p1
10526c23 892%patch66 -p1
2f067477 893%patch67 -p1
4cfbd61f 894%patch70 -p1
497556c4 895%patch71 -p1
c065c1c1 896%patch72 -p1
b53b1f84 897%patch73 -p1
765b7c41 898
70f8787d
JR
899%patch1000 -p1
900%patch1001 -p1
901%patch1002 -p1
902%patch1003 -p1
903%patch1004 -p1
904%patch1005 -p1
905%patch1006 -p1
906%patch1007 -p1
907%patch1008 -p1
908%patch1009 -p1
909%patch1010 -p1
910%patch1011 -p1
911%patch1012 -p1
912%patch1013 -p1
913%patch1014 -p1
914%patch1015 -p1
915%patch1016 -p1
916%patch1017 -p1
917%patch1018 -p1
918%patch1019 -p1
919%patch1020 -p1
920%patch1021 -p1
921%patch1022 -p1
922%patch1023 -p1
923%patch1024 -p1
924%patch1025 -p1
925%patch1026 -p1
926%patch1027 -p1
927%patch1028 -p1
928%patch1029 -p1
929%patch1030 -p1
930%patch1031 -p1
931%patch1032 -p1
932%patch1033 -p1
933%patch1034 -p1
934%patch1035 -p1
935%patch1036 -p1
85771a72 936%patch1037 -p1
70f8787d 937%patch1038 -p1
9f9190ed 938%patch1039 -p1
e85b33bb 939%patch1040 -p1
5555c3a0 940%patch1041 -p1
dfd6cb49 941%patch1042 -p1
281a8c30 942%patch68 -p1
e229e8ab 943%patch69 -p1
70f8787d
JR
944
945install %{SOURCE2} macros/pld.in
0bf34f68
JR
946install %{SOURCE8} scripts/php.prov.in
947install %{SOURCE9} scripts/php.req.in
948install %{SOURCE11} scripts/perl.prov.in
08697680 949
70f8787d 950%{__mv} -f scripts/perl.req{,.in}
633d1e9e 951
cd86db2e 952# generate Group translations to *.po
80b8a1f9 953awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 954
91ee86a9 955install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 956install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 957
87ef0d95 958%build
ea816ea6 959%{__libtoolize}
c0a9be8f 960#%{__autopoint}
ceaaacee 961%{__aclocal}
4cd84746 962%{__autoheader}
7a9d72ce 963%{__autoconf}
7a9d72ce 964%{__automake}
7a9d72ce 965
048d06f8
JR
966# rpm checks for CPU type at runtime, but it looks better
967sed -i \
968 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
969 -e 's|@host_cpu@|%{_target_cpu}|' \
970 -e 's|@host_os@|%{_target_os}|' \
3f84726d 971 macros/macros.in
048d06f8 972
d268a169 973%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
89427592 974# pass CC and CXX too in case of building with some older configure macro
624f96ff 975%configure \
f9ac32aa
AM
976 CC="%{__newcc}" \
977 CXX="%{__newcxx}" \
978 CPP="%{__newcpp}" \
01d7a578 979 WITH_PERL_VERSION=no \
bba1059c 980 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
cd86db2e 981 --enable-shared \
874f4c9a 982 --enable-static \
5c2ab5c7 983 %{!?with_apidocs:--without-apidocs} \
f3cb8244 984 %{?with_python:--with-python=%{py_ver} --with-python-lib-dir=%{py_sitedir}} \
a6e56ce4 985 %{!?with_python:--without-python} \
6e115b23
JR
986 --with-selinux=%{!?with_selinux:no}%{?with_selinux:external} \
987 --with-sepol=%{!?with_selinux:not}%{?with_selinux:external} \
988 --with-semanage=%{!?with_selinux:no}%{?with_selinux:external} \
241257bf
AM
989 --with-libelf \
990 --with-zlib=external \
991 --with-bzip2=external \
992 --with-beecrypt=external \
1afa05ce 993 --with-lzma=external \
77fcdbf7 994 --with-xz=external \
241257bf
AM
995 --with-neon=%{?with_neon:external}%{!?with_neon:no} \
996 --with-file=external \
997 --with-popt=external \
57256551
JR
998 --with-db=external \
999 --with-dbapi=db \
77fcdbf7 1000 --with-sqlite=%{?with_sqlite:yes}%{!?with_sqlite:no} \
6a8612bc 1001 --with-lua=%{!?with_system_lua:internal}%{?with_system_lua:external} \
77fcdbf7 1002 --with-pcre=external \
d0ee0933 1003 --with-keyutils=%{?with_keyutils:external}%{!?with_keyutils:no} \
127a0b3c 1004 --with-uuid=%{_libdir}:%{_includedir}/ossp-uuid \
241257bf 1005 --without-path-versioned \
adbd4815 1006 --with-path-macros='%{_rpmlibdir}/macros:%{_rpmlibdir}/%{_target}/macros:%{_rpmlibdir}/macros.d/pld:%{_rpmlibdir}/macros.build:%{_sysconfdir}/rpm/macros.*:%{_sysconfdir}/rpm/macros:%{_sysconfdir}/rpm/%{_target}/macros:%{_sysconfdir}/rpm/macros.d/*.macros:~/etc/.rpmmacros:~/.rpmmacros' \
08697680
JR
1007 --with-bugreport="http://bugs.pld-linux.org/" \
1008 --with-vendor=pld
cf6faebc 1009
25e974c7 1010%{__make} -j1 \
f9ac32aa
AM
1011 CC="%{__cc}" \
1012 CXX="%{__cxx}" \
241257bf 1013 CPP="%{__cpp}"
33be5db0 1014
5c2ab5c7
AM
1015%{?with_apidocs:%{__make} apidocs}
1016
fb95de52
JR
1017%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
1018 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
1019%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
1020 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
1021
1022if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
1023 echo "Error linking rpmdb tools!"
1024 exit 1
1025fi
8e8746c0
JR
1026if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
1027 echo "Error linking rpmdb tools!"
1028 exit 1
1029fi
91ee86a9 1030
b064b8e6 1031%install
ff7bc1e6 1032rm -rf $RPM_BUILD_ROOT
e9eb00af 1033install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/rpm} \
51081e43 1034 $RPM_BUILD_ROOT{/var/lib/banner,/var/cache/hrmib,/etc/pki/rpm-gpg}
54eb1770 1035
0bf34f68 1036install %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 1037
a5e7fb84 1038%{__make} install \
241257bf
AM
1039 pkgconfigdir=%{_pkgconfigdir} \
1040 DESTDIR=$RPM_BUILD_ROOT
718426e1 1041
25ac75ae
AM
1042# install ARCH macros
1043install -d $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux
d38aed81 1044install cpu-os-macros/noarch-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/noarch-linux/macros
25ac75ae
AM
1045
1046%ifarch %{ix86}
1047install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{i386,i486,i586,i686,athlon,pentium3,pentium4}-linux
d38aed81
JR
1048install cpu-os-macros/athlon-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/athlon-linux/macros
1049install cpu-os-macros/i386-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i386-linux/macros
1050install cpu-os-macros/i486-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i486-linux/macros
1051install cpu-os-macros/i586-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i586-linux/macros
1052install cpu-os-macros/i686-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/i686-linux/macros
1053install cpu-os-macros/pentium3-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium3-linux/macros
1054install cpu-os-macros/pentium4-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/pentium4-linux/macros
25ac75ae
AM
1055%endif
1056
1057%ifarch %{x8664}
1058install -d $RPM_BUILD_ROOT%{_rpmlibdir}/{x86_64,ia32e,amd64}-linux
d38aed81
JR
1059install cpu-os-macros/x86_64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/x86_64-linux/macros
1060install cpu-os-macros/ia32e-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ia32e-linux/macros
1061install cpu-os-macros/amd64-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/amd64-linux/macros
25ac75ae
AM
1062%endif
1063
1064%ifarch %{ppc}
1065install -d $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux
d38aed81 1066install cpu-os-macros/ppc-linux/macros $RPM_BUILD_ROOT%{_rpmlibdir}/ppc-linux/macros
25ac75ae
AM
1067%endif
1068
2eb9303e 1069cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
ca076ee5 1070# first platform file entry can't contain regexps
2eb9303e 1071%{_target_cpu}-%{_target_vendor}-linux
caf453d4 1072
2d8ae03e
AM
1073# x86_64 things
1074%ifarch x86_64
53fd58bc 1075x86_64-[^-]*-[Ll]inux(-gnu)?
9cfcb6c8 1076amd64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1077%endif
2d8ae03e 1078%ifarch amd64
53fd58bc
AM
1079amd64-[^-]*-[Ll]inux(-gnu)?
1080x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1081%endif
2d8ae03e 1082%ifarch ia32e
53fd58bc
AM
1083ia32e-[^-]*-[Ll]inux(-gnu)?
1084x86_64-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1085%endif
1086
1087# x86 things
06bd38df 1088%ifarch athlon %{x8664}
53fd58bc 1089athlon-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1090%endif
06bd38df 1091%ifarch pentium4 athlon %{x8664}
53fd58bc 1092pentium4-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1093%endif
06bd38df 1094%ifarch pentium3 pentium4 athlon %{x8664}
53fd58bc 1095pentium3-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1096%endif
06bd38df 1097%ifarch i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1098i686-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1099%endif
06bd38df 1100%ifarch i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1101i586-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1102%endif
06bd38df 1103%ifarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
53fd58bc 1104i486-[^-]*-[Ll]inux(-gnu)?
2d8ae03e 1105%endif
06bd38df 1106%ifarch %{ix86} %{x8664}
53fd58bc 1107i386-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1108%endif
1109
5074eba9 1110%ifarch alpha
53fd58bc 1111alpha-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1112%endif
1113
1114%ifarch ia64
53fd58bc 1115ia64-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1116%endif
1117
1118%ifarch ppc64
53fd58bc
AM
1119powerpc64-[^-]*-[Ll]inux(-gnu)?
1120ppc64-[^-]*-[Ll]inux(-gnu)?
5074eba9 1121%endif
950eead3 1122%ifarch %{ppc} ppc64
53fd58bc
AM
1123powerpc-[^-]*-[Ll]inux(-gnu)?
1124ppc-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1125%endif
1126
1127%ifarch s390x
53fd58bc 1128s390x-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1129%endif
1130%ifarch s390 s390x
53fd58bc 1131s390-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1132%endif
1133
1134%ifarch sparc64
53fd58bc
AM
1135sparc64-[^-]*-[Ll]inux(-gnu)?
1136sparcv8-[^-]*-[Ll]inux(-gnu)?
1137sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1138%endif
1139%ifarch sparcv9
53fd58bc
AM
1140sparcv8-[^-]*-[Ll]inux(-gnu)?
1141sparcv9-[^-]*-[Ll]inux(-gnu)?
5074eba9
JB
1142%endif
1143%ifarch sparc sparcv9 sparc64
53fd58bc 1144sparc-[^-]*-[Ll]inux(-gnu)?
2d8ae03e
AM
1145%endif
1146
1147# noarch
2eb9303e
ER
1148noarch-[^-]*-.*
1149EOF
2d8ae03e 1150
02919de5
JK
1151rm $RPM_BUILD_ROOT%{_rpmlibdir}/vpkg-provides*
1152rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{prov,req}.pl
1153rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-{provides,requires}.perl
950eead3 1154rm $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
7cf857f2
ER
1155rm $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.a
1156rm $RPM_BUILD_ROOT%{_rpmlibdir}/lib/liblua.la
1157rm $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-provides
1158rm $RPM_BUILD_ROOT%{_rpmlibdir}/mono-find-requires
1159
644d8958
JB
1160# not installed since 4.4.8 (-tools-perl subpackage)
1161install scripts/rpmdiff scripts/rpmdiff.cgi $RPM_BUILD_ROOT%{_rpmlibdir}
1162
61f7e1b3 1163install %{SOURCE1} doc/manual/groups
d755a548 1164install %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
80b8a1f9
JB
1165install %{SOURCE4} $RPM_BUILD_ROOT%{_rpmlibdir}/find-spec-bcond
1166install %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/compress-doc
0bf34f68
JR
1167install %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
1168install %{SOURCE14} $RPM_BUILD_ROOT%{_rpmlibdir}/java-find-requires
d755a548
JK
1169install scripts/find-php* $RPM_BUILD_ROOT%{_rpmlibdir}
1170install scripts/php.{prov,req} $RPM_BUILD_ROOT%{_rpmlibdir}
0bf34f68
JR
1171cp -p %{SOURCE25} $RPM_BUILD_ROOT%{_rpmlibdir}/php.req.php
1172install %{SOURCE17} $RPM_BUILD_ROOT%{_rpmlibdir}/mimetypedeps.sh
cf709a39 1173install %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
0bf34f68 1174install %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 1175
0bf34f68 1176install %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 1177
950eead3
ER
1178install -d $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo
1179
0bf34f68 1180install %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
b1541d4c 1181install %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
0bf34f68
JR
1182install %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
1183install %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
1184install %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
1185install %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
1186install %{SOURCE23} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqdep
1187install %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 1188
950eead3
ER
1189touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Conflictname
1190touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Dirnames
0bf34f68 1191install %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Filelinktos
950eead3
ER
1192touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Obsoletename
1193touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Providename
1194touch $RPM_BUILD_ROOT%{_sysconfdir}/rpm/sysinfo/Requirename
fbc0ff35 1195
91ee86a9 1196install tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/bin
345a6923 1197install tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/bin
14138aba 1198install %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1199
9776a251
JR
1200# create macro loading wrappers for backward compatibility
1201for m in gstreamer java mono perl php python; do
b279f099 1202 echo "%%{load:%{_rpmlibdir}/macros.d/$m}" >$RPM_BUILD_ROOT%{_rpmlibdir}/macros.$m
9776a251
JR
1203done
1204
f3fd387a 1205# for rpm -e|-U --repackage
a11e0e27
AM
1206install -d $RPM_BUILD_ROOT/var/{spool/repackage,lock/rpm}
1207touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
f3fd387a 1208
950eead3
ER
1209# move rpm to /bin
1210mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
1211# move essential libs to /lib (libs that /bin/rpm links to)
ece880e2 1212for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so librpmconstant-%{sover}.so; do
50dc9ac0
JK
1213 mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
1214 ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
c2673e18
AF
1215done
1216
950eead3
ER
1217# Bourne shell script vs ELF executable linked with rpm,rpmdb,rpmio
1218mv $RPM_BUILD_ROOT{%{_rpmlibdir},%{_bindir}}/rpm2cpio
1219
dae5e1a8 1220%if %{with python}
6f18cdb7
AF
1221%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
1222%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1223
08697680 1224%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
dae5e1a8 1225%endif
01d7a578 1226
01d7a578 1227# wrong location, not used anyway
08697680 1228%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
950eead3 1229# utils dropped in 4.4.8 -- their manuals
08697680 1230%{__rm} $RPM_BUILD_ROOT%{_mandir}/*/man8/rpmgraph.8
e86bfbff 1231# utils dropped in 5.4 -- their manuals
854562c1 1232%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rpmgrep.1
e86bfbff
JR
1233# script obsoleted by /usr/lib/rpm/bin/dbconvert binary
1234%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/dbconvert.sh
01d7a578 1235
90b03dd6 1236%find_lang %{name}
cf6faebc 1237
08697680 1238%{__rm} -rf manual
a998ac11 1239cp -a doc/manual manual
08697680 1240%{__rm} -f manual/Makefile*
874f4c9a 1241
13eb5ebf 1242%clean
d7df46b8 1243rm -rf $RPM_BUILD_ROOT
76214164 1244
cc1a4992
ER
1245%pretrans
1246# this needs to be a dir
1247if [ -f %{_sysconfdir}/rpm/sysinfo ]; then
c1097150 1248 umask 022
cc1a4992
ER
1249 mv -f %{_sysconfdir}/rpm/sysinfo{,.rpmsave}
1250 mkdir %{_sysconfdir}/rpm/sysinfo
1251fi
1252
be4d3036 1253%posttrans
d25ec6ea 1254if [ -e /var/lib/rpm/Packages ] && \
6a934782 1255 ! %{_rpmlibdir}/bin/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 1256 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 1257 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 1258 echo
e4dd6a34 1259 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
1260 echo
1261 fi
3ca91ccd
JR
1262 echo
1263 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
1264 echo 'you should ignore it and restart poldek'
1265 echo
3fc92bf7 1266 %{_rpmlibdir}/bin/dbupgrade.sh
be4d3036 1267fi
f7779567 1268
b7ee97ef
JR
1269%triggerpostun -- %{name} < 4.4.9-44
1270%{_rpmlibdir}/hrmib-cache
1271
ceaaacee
JB
1272%post lib -p /sbin/ldconfig
1273%postun lib -p /sbin/ldconfig
76214164 1274
37a5a2fc 1275%pretrans build
d755a548 1276find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 1277
3684d90f
JB
1278%files -f %{name}.lang
1279%defattr(644,root,root,755)
241257bf 1280%doc CHANGES CREDITS README pubkeys/JBJ-GPG-KEY manual/*
3684d90f 1281
3acb62f3
ER
1282%dir /etc/pki/rpm-gpg
1283/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 1284
7a9d72ce 1285%attr(755,root,root) /bin/rpm
e73478cd 1286
66edd895 1287%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 1288%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
950eead3 1289%dir %{_sysconfdir}/rpm/sysinfo
caf453d4 1290# these are ok to be replaced
950eead3 1291%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/sysinfo/*
caf453d4
AM
1292%config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
1293
09bb810c 1294%{_mandir}/man8/rpm.8*
feb1f12e 1295%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 1296%lang(ja) %{_mandir}/ja/man8/rpm.8*
1162bdc1 1297%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 1298%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 1299%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 1300%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 1301
e2025ad1 1302%dir /var/lib/rpm
74a997bd
JR
1303%dir /var/lib/rpm/log
1304%dir /var/lib/rpm/tmp
1305%config(noreplace) %verify(not md5 mtime size) /var/lib/rpm/DB_CONFIG
f3fd387a 1306%dir %attr(700,root,root) /var/spool/repackage
a11e0e27
AM
1307%dir /var/lock/rpm
1308/var/lock/rpm/transaction
4acac5de 1309
cf709a39
ER
1310# exported package NVRA (stamped with install tid)
1311# net-snmp hrSWInstalledName queries, bash-completions
1312%dir /var/cache/hrmib
1313
ec44785a 1314%{_rpmlibdir}/qf
d755a548
JK
1315%{_rpmlibdir}/rpmpopt*
1316%{_rpmlibdir}/macros
08697680
JR
1317%dir %{_rpmlibdir}/macros.d
1318%{_rpmlibdir}/macros.d/pld
9282ffe4 1319%{_rpmlibdir}/cpuinfo.yaml
3684d90f 1320
cf709a39
ER
1321%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
1322
df50421f
JR
1323%dir %{_rpmlibdir}/bin
1324%attr(755,root,root) %{_rpmlibdir}/bin/dbconvert
14138aba 1325%attr(755,root,root) %{_rpmlibdir}/bin/dbupgrade.sh
91ee86a9 1326%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_checkversion
345a6923 1327%attr(755,root,root) %{_rpmlibdir}/bin/rpmdb_reset
df50421f 1328
66edd895
JB
1329%files base
1330%defattr(644,root,root,755)
492a2bd4 1331%dir %{_sysconfdir}/rpm
66edd895
JB
1332%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
1333%dir %{_rpmlibdir}
1334%attr(755,root,root) %{_bindir}/banner.sh
df50421f 1335%attr(755,root,root) %{_bindir}/multiarch-dispatch
66edd895
JB
1336%attr(755,root,root) %{_rpmlibdir}/user_group.sh
1337%dir /var/lib/banner
1338
874f4c9a
MM
1339%files lib
1340%defattr(644,root,root,755)
950eead3
ER
1341%attr(755,root,root) /%{_lib}/librpm-%{sover}.so
1342%attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
1343%attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
1344%attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
a434679c 1345%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
ece880e2 1346%attr(755,root,root) /%{_lib}/librpmconstant-%{sover}.so
874f4c9a 1347
69131f1a
JB
1348%files devel
1349%defattr(644,root,root,755)
69131f1a
JB
1350%attr(755,root,root) %{_libdir}/librpm.so
1351%attr(755,root,root) %{_libdir}/librpm-%{sover}.so
950eead3
ER
1352%attr(755,root,root) %{_libdir}/librpmbuild.so
1353%attr(755,root,root) %{_libdir}/librpmbuild-%{sover}.so
02510ee8
AM
1354%attr(755,root,root) %{_libdir}/librpmconstant.so
1355%attr(755,root,root) %{_libdir}/librpmconstant-%{sover}.so
950eead3
ER
1356%attr(755,root,root) %{_libdir}/librpmdb.so
1357%attr(755,root,root) %{_libdir}/librpmdb-%{sover}.so
69131f1a
JB
1358%attr(755,root,root) %{_libdir}/librpmio.so
1359%attr(755,root,root) %{_libdir}/librpmio-%{sover}.so
02510ee8
AM
1360%attr(755,root,root) %{_libdir}/librpmmisc.so
1361%attr(755,root,root) %{_libdir}/librpmmisc-%{sover}.so
950eead3
ER
1362%{_libdir}/librpm*.la
1363%{_includedir}/rpm
df50421f 1364%{_includedir}/multiarch-dispatch.h
950eead3 1365%{_pkgconfigdir}/*.pc
69131f1a
JB
1366
1367%files static
1368%defattr(644,root,root,755)
1369%{_libdir}/librpm*.a
1370
1371%files utils
1372%defattr(644,root,root,755)
69131f1a 1373%attr(755,root,root) %{_bindir}/rpm2cpio
25e974c7 1374%attr(755,root,root) %{_bindir}/rpmconstant
69131f1a 1375%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 1376%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 1377%attr(755,root,root) %{_rpmlibdir}/tgpg
df50421f
JR
1378%attr(755,root,root) %{_rpmlibdir}/bin/chroot
1379%attr(755,root,root) %{_rpmlibdir}/bin/cp
9282ffe4 1380%attr(755,root,root) %{_rpmlibdir}/bin/debugedit
df50421f
JR
1381%attr(755,root,root) %{_rpmlibdir}/bin/find
1382%attr(755,root,root) %{_rpmlibdir}/bin/mgo
9282ffe4
AF
1383%attr(755,root,root) %{_rpmlibdir}/bin/mtree
1384%attr(755,root,root) %{_rpmlibdir}/bin/rpmcache
1385%attr(755,root,root) %{_rpmlibdir}/bin/rpmcmp
1386%attr(755,root,root) %{_rpmlibdir}/bin/rpmdeps
1387%attr(755,root,root) %{_rpmlibdir}/bin/rpmdigest
6e115b23
JR
1388%if %{with selinux}
1389%attr(755,root,root) %{_rpmlibdir}/bin/semodule
1390%attr(755,root,root) %{_rpmlibdir}/bin/spooktool
1391%endif
70df63f3
JR
1392%if %{without system_lua}
1393%attr(755,root,root) %{_rpmlibdir}/bin/lua
1394%attr(755,root,root) %{_rpmlibdir}/bin/luac
1395%attr(755,root,root) %{_rpmlibdir}/bin/rpmlua
1396%attr(755,root,root) %{_rpmlibdir}/bin/rpmluac
1397%endif
d0ee0933 1398%{?with_keyutils:%attr(755,root,root) %{_rpmlibdir}/bin/rpmkey}
9282ffe4 1399%attr(755,root,root) %{_rpmlibdir}/bin/rpmrepo
69131f1a 1400%{_mandir}/man8/rpm2cpio.8*
950eead3 1401%{_mandir}/man8/rpmcache.8*
ec44785a 1402%{_mandir}/man8/rpmconstant.8*
69131f1a 1403%{_mandir}/man8/rpmdeps.8*
c0a9be8f 1404%{_mandir}/man8/rpmmtree.8*
69131f1a 1405%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
950eead3 1406%lang(ja) %{_mandir}/ja/man8/rpmcache.8*
69131f1a
JB
1407%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
1408%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
950eead3 1409%lang(pl) %{_mandir}/pl/man8/rpmcache.8*
69131f1a 1410%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
69131f1a
JB
1411%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
1412
1413%files utils-perl
1414%defattr(644,root,root,755)
1415%attr(755,root,root) %{_rpmlibdir}/rpmdiff*
69131f1a
JB
1416
1417%if %{with static}
1418%files utils-static
1419%defattr(644,root,root,755)
1420%attr(755,root,root) %{_bindir}/rpm[ieu]
1421%attr(755,root,root) %{_rpmlibdir}/rpm[ieu]
1422%endif
1423
3684d90f 1424%files build
a45ae6d8 1425%defattr(644,root,root,755)
66edd895 1426%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
1427%attr(755,root,root) %{_rpmlibdir}/brp-*
1428%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548
JK
1429%attr(755,root,root) %{_rpmlibdir}/compress-doc
1430%attr(755,root,root) %{_rpmlibdir}/cross-build
d755a548 1431%attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
d755a548
JK
1432%attr(755,root,root) %{_rpmlibdir}/getpo.sh
1433%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d755a548 1434%attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
01d7a578 1435%attr(755,root,root) %{_rpmlibdir}/executabledeps.sh
01d7a578 1436%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
c75b3936 1437%attr(755,root,root) %{_rpmlibdir}/mimetypedeps.sh
01d7a578
JB
1438# needs hacked pkg-config to return anything
1439%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
df50421f
JR
1440%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-autotest.pl
1441%attr(755,root,root) %{_rpmlibdir}/bin/api-sanity-checker.pl
ac8ac881 1442%{!?with_sqlite:%attr(755,root,root) %{_rpmlibdir}/bin/dbsql}
77fcdbf7
AF
1443%attr(755,root,root) %{_rpmlibdir}/bin/install-sh
1444%attr(755,root,root) %{_rpmlibdir}/bin/mkinstalldirs
df50421f
JR
1445%attr(755,root,root) %{_rpmlibdir}/bin/pom2spec
1446%attr(755,root,root) %{_rpmlibdir}/bin/rpmspecdump
1447%attr(755,root,root) %{_rpmlibdir}/bin/sqlite3
1448%attr(755,root,root) %{_rpmlibdir}/bin/wget
ec44785a 1449%attr(755,root,root) %{_rpmlibdir}/vcheck
d755a548 1450%{_rpmlibdir}/noarch-*
e9fe9fc5 1451%ifarch %{ix86}
d755a548 1452%{_rpmlibdir}/i?86*
e9fe9fc5 1453%{_rpmlibdir}/pentium*
d755a548
JK
1454%{_rpmlibdir}/athlon*
1455%endif
ad628734
JB
1456%ifarch alpha
1457%{_rpmlibdir}/alpha*
1458%endif
ad628734
JB
1459%ifarch ia64
1460%{_rpmlibdir}/ia64*
8f76a271 1461%endif
410dd742 1462%ifarch mips mipsel mips64 mips64el
1463%{_rpmlibdir}/mips*
1464%endif
80e9f34d 1465%ifarch %{ppc}
410dd742 1466%{_rpmlibdir}/ppc*
1467%endif
1468%ifarch sparc sparc64
1469%{_rpmlibdir}/sparc*
1470%endif
9f517079 1471%ifarch %{x8664}
206b32be
JB
1472%{_rpmlibdir}/amd64*
1473%{_rpmlibdir}/ia32e*
cedf1bfa
PS
1474%{_rpmlibdir}/x86_64*
1475%endif
410dd742 1476# not used yet ... these six depend on perl
ec44785a 1477%attr(755,root,root) %{_rpmlibdir}/http.req
428645e9
JR
1478# we always used scripts provided by mono-devel, maybe move them here
1479#%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
1480#%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
37e965e8 1481
70f8787d 1482%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 1483# must be here for "Requires: rpm-*prov" to work
df50421f
JR
1484%{_rpmlibdir}/macros.d/cmake
1485%{_rpmlibdir}/macros.d/gstreamer
77fcdbf7 1486%{_rpmlibdir}/macros.d/java
df50421f 1487%{_rpmlibdir}/macros.d/kernel
77fcdbf7
AF
1488%{_rpmlibdir}/macros.d/libtool
1489%{_rpmlibdir}/macros.d/mono
1490%{_rpmlibdir}/macros.d/perl
1491%{_rpmlibdir}/macros.d/php
1492%{_rpmlibdir}/macros.d/pkgconfig
1493%{_rpmlibdir}/macros.d/python
3b644c29 1494%{_rpmlibdir}/macros.d/ruby
77fcdbf7 1495%{_rpmlibdir}/macros.d/selinux
df50421f 1496%{_rpmlibdir}/macros.d/tcl
77fcdbf7 1497%{_rpmlibdir}/macros.rpmbuild
9776a251
JR
1498# compat wrappers
1499%{_rpmlibdir}/macros.gstreamer
1500%{_rpmlibdir}/macros.java
1501%{_rpmlibdir}/macros.mono
1502%{_rpmlibdir}/macros.perl
1503%{_rpmlibdir}/macros.php
1504%{_rpmlibdir}/macros.python
77fcdbf7 1505
df50421f 1506%attr(755,root,root) %{_rpmlibdir}/check-multiarch-files
df50421f
JR
1507%attr(755,root,root) %{_rpmlibdir}/gstreamer.sh
1508%attr(755,root,root) %{_rpmlibdir}/kmod-deps.sh
1509%attr(755,root,root) %{_rpmlibdir}/mkmultiarch
df50421f 1510
874f4c9a 1511%attr(755,root,root) %{_bindir}/gendiff
df50421f 1512%attr(755,root,root) %{_bindir}/multiarch-platform
874f4c9a 1513%attr(755,root,root) %{_bindir}/rpmbuild
ec44785a
BZ
1514
1515%dir %{_rpmlibdir}/helpers
1516%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
874f4c9a 1517
a00926bc 1518%{_mandir}/man1/gendiff.1*
874f4c9a 1519%{_mandir}/man8/rpmbuild.8*
fefe9d30
JB
1520%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
1521%lang(pl) %{_mandir}/pl/man1/gendiff.1*
1522%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
f3fe287f 1523
7d8492bb
JB
1524%files javaprov
1525%defattr(644,root,root,755)
1526%attr(755,root,root) %{_rpmlibdir}/java-find-requires
1527# needs jar (any jdk), jcf-dump (gcc-java) to work
1528%attr(755,root,root) %{_rpmlibdir}/javadeps.sh
1529
ec49e9fb
ER
1530%files rubyprov
1531%defattr(644,root,root,755)
1532%attr(755,root,root) %{_rpmlibdir}/gem_helper.rb
1533%attr(755,root,root) %{_rpmlibdir}/rubygems.rb
1534
89334051
AF
1535%files perlprov
1536%defattr(644,root,root,755)
d755a548 1537%attr(755,root,root) %{_rpmlibdir}/perl.*
ec44785a
BZ
1538%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
1539%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
9805fd6d 1540
80d3b868 1541%files pythonprov
d8fcb9b0 1542%defattr(644,root,root,755)
bdbae303 1543%attr(755,root,root) %{_rpmlibdir}/pythoneggs.py
25d296e1 1544%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
09bb810c 1545
d36cb682
PG
1546%files php-pearprov
1547%defattr(644,root,root,755)
d755a548
JK
1548%attr(755,root,root) %{_rpmlibdir}/php*
1549%attr(755,root,root) %{_rpmlibdir}/find-php*
d36cb682 1550
50dc9ac0 1551%if %{with python}
cf6faebc 1552%files -n python-rpm
42a0025c 1553%defattr(644,root,root,755)
b33910fe 1554%dir %{py_sitedir}/rpm
6f18cdb7 1555%attr(755,root,root) %{py_sitedir}/rpm/*.so
8c99b39a 1556%{py_sitedir}/rpm/*.py[co]
50dc9ac0 1557%endif
5c2ab5c7
AM
1558
1559%if %{with apidocs}
1560%files apidocs
1561%defattr(644,root,root,755)
1562%doc apidocs
1563%endif
This page took 1.034642 seconds and 4 git commands to generate.