]> git.pld-linux.org Git - packages/rpm.git/blame - rpm.spec
- cleanup patch ids
[packages/rpm.git] / rpm.spec
CommitLineData
52c10eff 1#
2# TODO:
e8836e1f 3# - rebuild database after upgrading from rpm5
c296fee0 4# - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
76005b82 5#
89427592 6# Conditional build:
0a1ccab0 7%bcond_without apidocs # don't generate documentation with doxygen
f9d0e5f6
JR
8%bcond_without python2 # don't build python bindings
9%bcond_without python3 # don't build python bindings
b0333243 10%bcond_without plugins # build plugins
af0cc499 11%bcond_without recommends_tags # build without Recommends tag (bootstrapping)
fb35e2d9 12%bcond_with db61 # use DB 6.1 instead of 5.3
858aa7d0 13
003a039e 14# versions of required libraries
7f47af9c
JB
15%if %{with db61}
16%define reqdb_pkg db6.1
17%define reqdb_ver 6.1
18%define reqdb_pkgver 6.1.19
5f3f5bd6 19%else
fb35e2d9
JR
20%define reqdb_pkg db5.3
21%define reqdb_ver 5.3
22%define reqdb_pkgver 5.3.28.0
5f3f5bd6 23%endif
ec44785a 24%define reqpopt_ver 1.15
fb35e2d9 25%define openssl_ver 1.1.1d
2f409bb7 26%define sover 9.0.1
fc60c9f3 27
e5f02e49 28Summary: RPM Package Manager
4ea2ed33
ER
29Summary(de.UTF-8): RPM Packet-Manager
30Summary(es.UTF-8): Gestor de paquetes RPM
31Summary(pl.UTF-8): Aplikacja do zarządzania pakietami RPM
32Summary(pt_BR.UTF-8): Gerenciador de pacotes RPM
33Summary(ru.UTF-8): Менеджер пакетов от RPM
34Summary(uk.UTF-8): Менеджер пакетів від RPM
76214164 35Name: rpm
6ecfe7c2 36Version: 4.15.1
98d9fc8e 37Release: 0.1
9fe07969 38Epoch: 1
98d9fc8e 39License: GPL v2 / LGPL v2.1
76214164 40Group: Base
6ecfe7c2
JR
41Source0: http://ftp.rpm.org/releases/rpm-4.15.x/%{name}-%{version}.tar.bz2
42# Source0-md5: ed72147451a5ed93b2a48e2f8f5413c3
ff7bc1e6 43Source1: %{name}.groups
ff7bc1e6 44Source3: %{name}-install-tree
cf709a39 45Source5: %{name}-hrmib-cache
80b8a1f9 46Source6: %{name}-groups-po.awk
0bf34f68
JR
47Source11: perl.prov
48Source12: %{name}-user_group.sh
49Source13: %{name}.sysconfig
a4b7ef27 50# http://svn.pld-linux.org/banner.sh/
0bf34f68 51Source15: banner.sh
34f36471 52Source16: ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
e1b97821 53# Source16-md5: 23914bb49fafe7153cee87126d966461
0bf34f68 54Source18: macros.local
f09b01ac
ER
55Source19: %{name}.noautocompressdoc
56Source20: %{name}.noautoprov
57Source21: %{name}.noautoprovfiles
58Source22: %{name}.noautoreq
f09b01ac 59Source24: %{name}.noautoreqfiles
f09b01ac 60Source26: %{name}db_checkversion.c
b1541d4c 61Source27: macros.lang
f09b01ac 62Source28: %{name}db_reset.c
14138aba 63Source29: dbupgrade.sh
fde810b9 64Source32: rpmrc.pld
af0cc499
JR
65Patch0: %{name}-man_pl.patch
66Patch1: %{name}-popt-aliases.patch
67Patch2: %{name}-perl-macros.patch
68Patch3: %{name}-perl-req-perlfile.patch
69Patch4: %{name}-scripts-closefds.patch
cbab0cbf
JR
70Patch5: %{name}-lua.patch
71Patch6: %{name}-perl_req-INC_dirs.patch
72Patch7: %{name}-debuginfo.patch
73Patch8: %{name}-libtool-deps.patch
74Patch9: %{name}-builddir-readlink.patch
75Patch10: %{name}-changelog_order_check_nonfatal.patch
76Patch11: %{name}-postun-nofail.patch
77Patch12: %{name}-clean-docdir.patch
78Patch13: %{name}-perl-magic.patch
79Patch14: %{name}-ignore-missing-macro-files.patch
80Patch15: x32.patch
81Patch16: %{name}-add-compress-doc.patch
82Patch17: rpm5-db-compat.patch
83Patch18: python-internal-build.patch
681ee2f6 84URL: https://rpm.org/
cf169f7c 85BuildRequires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
cf169f7c 86BuildRequires: %{reqdb_pkg}-sql-devel >= %{reqdb_pkgver}
29855fc2 87BuildRequires: autoconf >= 2.63
644d8958 88BuildRequires: automake >= 1.4
33be5db0 89BuildRequires: bzip2-devel >= 1.0.2-17
33be5db0 90BuildRequires: elfutils-devel >= 0.108
3e70c06e 91BuildRequires: gettext-tools >= 0.19.2
af0cc499 92BuildRequires: libarchive-devel
241257bf 93BuildRequires: libmagic-devel
d1f5e279 94BuildRequires: openssl-devel >= %{openssl_ver}
b0333243
JR
95%if %{with plugins}
96BuildRequires: audit-libs-devel
97BuildRequires: dbus-devel
6e115b23 98BuildRequires: libselinux-devel >= 2.1.0
6e115b23 99%endif
84cdee7a
JB
100# needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
101BuildRequires: libstdc++-devel
b60c74c3 102BuildRequires: libtool >= 1:1.4.2-9
5c767dc1 103BuildRequires: lua53-devel >= 5.3.5
127a0b3c 104BuildRequires: ossp-uuid-devel
7973b351 105BuildRequires: patch >= 2.2
1d49ffbc 106BuildRequires: popt-devel >= %{reqpopt_ver}
f9d0e5f6
JR
107%{?with_python2:BuildRequires: python-devel >= 1:2.3}
108%{?with_python3:BuildRequires: python3-devel}
950eead3 109BuildRequires: python-modules >= 1:2.3
f9d0e5f6
JR
110%if %{with python2} || %{with python3}
111BuildRequires: rpm-pythonprov
112%endif
e56a10a9 113BuildRequires: tcl
77fcdbf7 114BuildRequires: xz-devel
3acb62f3 115BuildRequires: zlib-devel
34865f27 116BuildRequires: zstd-devel
5c2ab5c7
AM
117%if %{with apidocs}
118BuildRequires: doxygen
119BuildRequires: ghostscript
120BuildRequires: graphviz
121BuildRequires: tetex-pdftex
122%endif
d25ec6ea 123Requires(posttrans): coreutils
9fe07969
JR
124Requires: %{name}-base = %{epoch}:%{version}-%{release}
125Requires: %{name}-lib = %{epoch}:%{version}-%{release}
3de8e4a9 126Requires: rpm-pld-macros >= 1.744
d1f5e279 127Requires: FHS >= 3.0-2
fb35e2d9 128Requires: openssl >= %{openssl_ver}
10abbd40 129Requires: popt >= %{reqpopt_ver}
b0333243
JR
130%if %{with recommends_tags}
131Recommends: rpm-plugin-audit
132Recommends: rpm-plugin-prioreset
133Recommends: rpm-plugin-syslog
134Recommends: rpm-plugin-systemd-inhibit
135%endif
0229a8b9
AM
136Provides: rpm-db-ver = %{reqdb_ver}
137Obsoletes: rpm-getdeps
d1f5e279 138Obsoletes: rpm-utils-perl
f57f030d 139Obsoletes: rpm-utils-static
874f4c9a 140Conflicts: glibc < 2.2.92
8ee1c72c
AM
141# db4.6 poldek needed
142Conflicts: poldek < 0.21-0.20070703.00.3
d268a169
AM
143# segfaults with lzma 0.42.2
144Conflicts: lzma-libs < 4.999.3
e4084afd 145Conflicts: util-vserver < 0.30.216-1.pre3034.7
1d49ffbc 146BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
6d82b332 147
4adb7d05 148%define _binary_payload w9.gzdio
6d82b332 149
4cd84746 150# don't require very fresh rpm.macros to build
950eead3 151%define find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
af0cc499 152%define ix86 i386 i486 i586 i686 athlon geode pentium3 pentium4
80e9f34d 153%define ppc ppc ppc7400 ppc7450
9f517079 154%define x8664 amd64 ia32e x86_64
4cd84746 155
d755a548 156%define _rpmlibdir /usr/lib/rpm
950eead3 157%define _noautocompressdoc RPM-GPG-KEY
d755a548 158
ff7bc1e6 159%description
160RPM is a powerful package manager, which can be used to build,
161install, query, verify, update, and uninstall individual software
cf6faebc 162packages. A package consists of an archive of files, and package
fed73700 163information, including name, version, and description.
164
dd85fadc
JR
165%description -l de.UTF-8
166RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
fed73700 167Installation, Anfrage, Verifizierung, Aktualisierung und
168Uninstallation individueller Softwarepakete. Ein Paket besteht aus
169einem Archiv Dateien und Paketinformation, inklusive Name, Version und
313a4d1a 170Beschreibung.
171
dd85fadc 172%description -l es.UTF-8
313a4d1a 173RPM es un poderoso administrador de paquetes, que puede ser usado para
174construir, instalar, pesquisar, verificar, actualizar y desinstalar
175paquetes individuales de software. Un paquete consiste en un
dd85fadc
JR
176almacenaje de archivos, y información sobre el paquete, incluyendo
177nombre, versión y descripción.
178
179%description -l pl.UTF-8
180RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
181przebudowanie, instalację czy weryfikację dowolnego pakietu.
182Informacje dotyczące każdego pakietu, takie jak jego opis, lista
183plików wchodzących w skład pakietu, zależności od innych pakietów, są
184przechowywane w bazie danych i można je uzyskać za pomocą opcji
313a4d1a 185odpytywania programu rpm.
186
dd85fadc
JR
187%description -l pt_BR.UTF-8
188RPM é um poderoso gerenciador de pacotes, que pode ser usado para
313a4d1a 189construir, instalar, pesquisar, verificar, atualizar e desinstalar
190pacotes individuais de software. Um pacote consiste de um conjunto de
dd85fadc
JR
191arquivos e informações adicionais, incluindo nome, versão e descrição
192do pacote, permissões dos arquivos, etc.
193
194%description -l ru.UTF-8
195RPM - это мощный менеджер пакетов, который может быть использован для
196создания, инсталляции, запросов (query), проверки, обновления и
197удаления программных пакетов. Пакет состоит из файлового архива и
198служебной информации, включающей название, версию, описание и другие
199данные о пакете.
200
201%description -l uk.UTF-8
202RPM - це потужний менеджер пакетів, що може бути використаний для
203створення, інсталяції, запитів (query), перевірки, поновлення та
204видалення програмних пакетів. Пакет складається з файлового архіву та
205службової інформації, що містить назву, версію, опис та іншу
206інформацію про пакет.
7c6dc55f 207
66edd895
JB
208%package base
209Summary: RPM base package - scripts used by rpm packages themselves
4ea2ed33 210Summary(pl.UTF-8): Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
66edd895 211Group: Base
1d9ca0c1 212Requires: filesystem
950eead3 213Obsoletes: rpm-scripts
66edd895
JB
214Obsoletes: vserver-rpm
215
216%description base
217The RPM base package contains scripts used by rpm packages themselves.
218These include:
219- scripts for adding/removing groups and users needed for rpm
220 packages,
221- banner.sh to display %%banner messages from rpm scriptlets.
222
dd85fadc
JR
223%description base -l pl.UTF-8
224Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
66edd895 225Zawiera on:
dd85fadc
JR
226- skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
227- banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
66edd895 228
69131f1a
JB
229%package lib
230Summary: RPMs library
4ea2ed33 231Summary(pl.UTF-8): Biblioteki RPM-a
69131f1a 232Group: Libraries
cf169f7c 233Requires: %{reqdb_pkg} >= %{reqdb_pkgver}
cf169f7c 234Requires: %{reqdb_pkg}-sql >= %{reqdb_pkgver}
241257bf 235Requires: libmagic >= 1.15-2
d1f5e279 236Requires: openssl >= %{openssl_ver}
69131f1a 237Requires: popt >= %{reqpopt_ver}
d1795eb0 238Obsoletes: rpm-libs
69131f1a
JB
239# avoid SEGV caused by mixed db versions
240Conflicts: poldek < 0.18.1-16
241
242%description lib
243RPMs library.
244
dd85fadc 245%description lib -l pl.UTF-8
69131f1a
JB
246Biblioteki RPM-a.
247
fed73700 248%package devel
3f2d796a 249Summary: Header files for rpm libraries
4ea2ed33
ER
250Summary(de.UTF-8): Header-Dateien für rpm Libraries
251Summary(es.UTF-8): Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
252Summary(pl.UTF-8): Pliki nagłówkowe bibliotek rpm
253Summary(pt_BR.UTF-8): Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
254Summary(ru.UTF-8): Хедеры и библиотеки для программ, работающих с rpm-пакетами
255Summary(uk.UTF-8): Хедери та бібліотеки для програм, що працюють з пакетами rpm
89f92de0 256Group: Development/Libraries
9fe07969 257Requires: %{name}-lib = %{epoch}:%{version}-%{release}
cf169f7c 258Requires: %{reqdb_pkg}-devel >= %{reqdb_pkgver}
fea3cb89 259Requires: bzip2-devel
5c583f90 260Requires: elfutils-devel
241257bf 261Requires: libmagic-devel
d1f5e279 262Requires: openssl-devel >= %{openssl_ver}
c7b2d5f9
KK
263%if %{with selinux}
264Requires: libselinux-devel
265Requires: libsemanage-devel
266Requires: libsepol-devel
267%endif
a998ac11 268Requires: popt-devel >= %{reqpopt_ver}
fea3cb89 269Requires: zlib-devel
cf6faebc 270
271%description devel
3f2d796a
JB
272The RPM packaging system includes C libraries that make it easy to
273manipulate RPM packages and databases. They are intended to ease the
cf6faebc 274creation of graphical package managers and other tools that need
3f2d796a
JB
275intimate knowledge of RPM packages. This package contains header files
276for these libraries.
fed73700 277
dd85fadc
JR
278%description devel -l de.UTF-8
279Der RPM-Packensystem enthält eine C-Library, die macht es einfach
280RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
fed73700 281Vereinfachung des Schaffens grafischer Paket-Manager und anderer
313a4d1a 282Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
283
dd85fadc 284%description devel -l es.UTF-8
313a4d1a 285El sistema de empaquetado RPM incluye una biblioteca C que vuelve
dd85fadc
JR
286fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
287facilitar la creación de administradores gráficos de paquetes y otras
20f89981 288herramientas que necesiten un conocimiento profundo de paquetes RPM.
9e42d68a 289
dd85fadc
JR
290%description devel -l pl.UTF-8
291System RPM zawiera biblioteki C, które ułatwiają manipulowanie
292pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
293graficznych programów zarządzających pakietami oraz innych narzędzi,
294które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
295zawiera pliki nagłówkowe wspomnianych bibliotek.
296
297%description devel -l pt_BR.UTF-8
298O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
299a manipulação de pacotes e bases de dados RPM. Seu objetivo é
300facilitar a criação de gerenciadores gráficos de pacotes e outras
edacdf8f 301ferramentas que precisem de conhecimento profundo de pacotes RPM.
302
dd85fadc
JR
303%description devel -l ru.UTF-8
304Система управления пакетами RPM содержит библиотеку C, которая
305упрощает манипуляцию пакетами RPM и соответствующими базами данных.
306Эта библиотека предназначена для облегчения создания графических
307пакетных менеджеров и других утилит, которым необходимо работать с
308пакетами RPM.
7c6dc55f 309
dd85fadc
JR
310%description devel -l uk.UTF-8
311Система керування пакетами RPM містить бібліотеку C, котра спрощує
312роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
313призначена для полегшення створення графічних пакетних менеджерів та
314інших утиліт, що працюють з пакетами RPM.
7c6dc55f 315
fed73700 316%package utils
8482995c 317Summary: Additional utilities for managing RPM packages and database
4ea2ed33
ER
318Summary(de.UTF-8): Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
319Summary(pl.UTF-8): Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
edacdf8f 320Group: Applications/File
9fe07969 321Requires: %{name} = %{epoch}:%{version}-%{release}
a998ac11 322Requires: popt >= %{reqpopt_ver}
af0cc499
JR
323%if %{with recommends_tags}
324Recommends: bzip2
325Recommends: gzip
86b85368 326%endif
695e60ad 327Conflicts: filesystem-debuginfo < 3.0-16
edacdf8f 328
329%description utils
8482995c 330Additional utilities for managing RPM packages and database.
fed73700 331
dd85fadc
JR
332%description utils -l de.UTF-8
333Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
9e42d68a 334
dd85fadc
JR
335%description utils -l pl.UTF-8
336Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
fed73700 337
fed73700 338%package build
e191287c 339Summary: Scripts for building binary RPM packages
4ea2ed33
ER
340Summary(de.UTF-8): Scripts fürs Bauen binärer RPM-Pakete
341Summary(pl.UTF-8): Skrypty pomocnicze do budowania binarnych RPM-ów
342Summary(pt_BR.UTF-8): Scripts e programas executáveis usados para construir pacotes
343Summary(ru.UTF-8): Скрипты и утилиты, необходимые для сборки пакетов
344Summary(uk.UTF-8): Скрипти та утиліти, необхідні для побудови пакетів
e191287c 345Group: Applications/File
f15ca8ca
ER
346Requires(pretrans): coreutils
347Requires(pretrans): findutils
9fe07969 348Requires: %{name}-utils = %{epoch}:%{version}-%{release}
3de8e4a9 349Requires: rpm-pld-macros-build >= 1.744
e191287c 350Requires: /bin/id
351Requires: awk
cfa7898a 352Requires: bzip2
e950a6d7 353Requires: chrpath >= 0.10-4
b6547e10 354Requires: cpio
e191287c 355Requires: diffutils
195f647c 356Requires: elfutils
583135b4 357Requires: file >= 4.17
e191287c 358Requires: fileutils
359Requires: findutils
950eead3
ER
360%ifarch athlon
361Requires: gcc >= 3.0.3
362%else
363Requires: gcc
364%endif
e191287c 365Requires: glibc-devel
366Requires: grep
367Requires: gzip
368Requires: make
369Requires: patch
adbd4815 370Requires: sed >= 4.0
e191287c 371Requires: sh-utils
adbd4815 372Requires: tar >= 1:1.22
e191287c 373Requires: textutils
3acb62f3 374Requires: which
adbd4815 375Requires: xz
37ea389a 376Provides: rpmbuild(noauto) = 3
02d17bf9 377%ifarch %{x8664}
195f647c
JB
378Conflicts: automake < 1:1.7.9-2
379Conflicts: libtool < 2:1.5-13
380%endif
0096c5cd 381
e2025ad1 382%description build
58399c37 383Scripts for building binary RPM packages.
fed73700 384
dd85fadc
JR
385%description build -l de.UTF-8
386Scripts fürs Bauen binärer RPM-Pakete.
9e42d68a 387
dd85fadc
JR
388%description build -l pl.UTF-8
389Skrypty pomocnicze do budowania binarnych RPM-ów.
313a4d1a 390
dd85fadc
JR
391%description build -l pt_BR.UTF-8
392Este pacote contém scripts e programas executáveis que são usados para
cf6faebc 393construir pacotes usando o RPM.
e73478cd 394
dd85fadc
JR
395%description build -l ru.UTF-8
396Различные вспомогательные скрипты и исполняемые программы, которые
397используются для сборки RPM'ов.
7c6dc55f 398
dd85fadc
JR
399%description build -l uk.UTF-8
400Різноманітні допоміжні скрипти та утиліти, які використовуються для
401побудови RPM'ів.
7c6dc55f 402
69131f1a 403%package perlprov
8482995c 404Summary: Additional utilities for checking Perl provides/requires in RPM packages
4ea2ed33 405Summary(de.UTF-8): Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
8482995c 406Summary(pl.UTF-8): Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
69131f1a 407Group: Applications/File
9fe07969 408Requires: %{name} = %{epoch}:%{version}-%{release}
b82853ee 409Requires: perl-Encode
69131f1a
JB
410Requires: perl-devel
411Requires: perl-modules
412
413%description perlprov
8482995c 414Additional utilities for checking Perl provides/requires in RPM
69131f1a
JB
415packages.
416
dd85fadc
JR
417%description perlprov -l de.UTF-8
418Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
69131f1a 419
dd85fadc 420%description perlprov -l pl.UTF-8
8482995c
JB
421Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
422pakietach RPM.
69131f1a
JB
423
424%package pythonprov
8482995c
JB
425Summary: Python macros, which simplifies creation of RPM packages with Python software
426Summary(pl.UTF-8): Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
69131f1a 427Group: Applications/File
9fe07969 428Requires: %{name} = %{epoch}:%{version}-%{release}
cd800b3c 429Requires: python
3acb62f3 430Requires: python-modules
d1f5e279 431Requires: python-setuptools
69131f1a
JB
432
433%description pythonprov
8482995c 434Python macros, which simplifies creation of RPM packages with Python
69131f1a
JB
435software.
436
dd85fadc 437%description pythonprov -l pl.UTF-8
8482995c 438Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
69131f1a
JB
439Pythonie.
440
69131f1a
JB
441%package -n python-rpm
442Summary: Python interface to RPM library
4ea2ed33
ER
443Summary(pl.UTF-8): Pythonowy interfejs do biblioteki RPM-a
444Summary(pt_BR.UTF-8): Módulo Python para aplicativos que manipulam pacotes RPM
69131f1a 445Group: Development/Languages/Python
9fe07969 446Requires: %{name} = %{epoch}:%{version}-%{release}
3acb62f3 447Requires: python
69131f1a
JB
448Obsoletes: rpm-python
449
450%description -n python-rpm
f9d0e5f6 451The python-rpm package contains a module which permits applications
69131f1a
JB
452written in the Python programming language to use the interface
453supplied by RPM (RPM Package Manager) libraries.
454
455This package should be installed if you want to develop Python
456programs that will manipulate RPM packages and databases.
457
dd85fadc 458%description -n python-rpm -l pl.UTF-8
f9d0e5f6 459Pakiet python-rpm zawiera moduł, który pozwala aplikacjom napisanym w
dd85fadc 460Pythonie na używanie interfejsu dostarczanego przez biblioteki RPM-a.
69131f1a 461
dd85fadc
JR
462Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
463Pythonie programy manipulujące pakietami i bazami danych rpm.
69131f1a 464
dd85fadc 465%description -n python-rpm -l pt_BR.UTF-8
f9d0e5f6 466O pacote python-rpm contém um módulo que permite que aplicações
69131f1a
JB
467escritas em Python utilizem a interface fornecida pelas bibliotecas
468RPM (RPM Package Manager).
469
dd85fadc 470Esse pacote deve ser instalado se você quiser desenvolver programas em
69131f1a
JB
471Python para manipular pacotes e bancos de dados RPM.
472
f9d0e5f6
JR
473%package -n python3-rpm
474Summary: Python 3 interface to RPM library
475Summary(pl.UTF-8): Interfejs Pythona 3 do biblioteki RPM-a
476Summary(pt_BR.UTF-8): Módulo Python 3 para aplicativos que manipulam pacotes RPM
477Group: Development/Languages/Python
9fe07969 478Requires: %{name} = %{epoch}:%{version}-%{release}
f9d0e5f6
JR
479Requires: python3
480
481%description -n python3-rpm
482The python3-rpm package contains a module which permits applications
483written in the Python 3 programming language to use the interface
484supplied by RPM (RPM Package Manager) libraries.
485
486This package should be installed if you want to develop Python 3
487programs that will manipulate RPM packages and databases.
488
489%description -n python3-rpm -l pl.UTF-8
490Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
491Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki RPM-a.
492
493Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
494Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
495
496%description -n python3-rpm -l pt_BR.UTF-8
497O pacote python3-rpm contém um módulo que permite que aplicações
498escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
499RPM (RPM Package Manager).
500
501Esse pacote deve ser instalado se você quiser desenvolver programas em
502Python 3 para manipular pacotes e bancos de dados RPM.
503
b0333243
JR
504%package plugin-audit
505Summary: Plugin for logging audit events on package operations
506Group: System/Base
9fe07969 507Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
508
509%description plugin-audit
510Plugin for libaudit support
511
512%package plugin-syslog
513Summary: Plugin for syslog functionality
514Group: System/Base
9fe07969 515Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
516
517%description plugin-syslog
518This plugin exports RPM actions to the system log.
519
520%package plugin-systemd-inhibit
521Summary: Plugin for systemd inhibit functionality
522Group: System/Base
9fe07969 523Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
524
525%description plugin-systemd-inhibit
526This plugin blocks systemd from entering idle, sleep or shutdown while
527an rpm transaction is running using the systemd-inhibit mechanism.
528
529%package plugin-ima
530Summary: Plugin for IMA file signatures
531Group: Base
9fe07969 532Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
533
534%description plugin-ima
535This plugin adds support for enforcing and verifying IMA file
536signatures in an rpm.
537
538%package plugin-prioreset
539Summary: Plugin for resetting scriptlet priorities for SysV init
540Group: Base
9fe07969 541Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
542
543%description plugin-prioreset
544This plugin is useful on legacy SysV init systems if you run rpm
545transactions with nice/ionice priorities. Should not be used on
546systemd systems.
547
548%package plugin-selinux
549Summary: Plugin for SELinux functionality
8191f3c5 550Group: Base
9fe07969 551Requires: %{name}-lib = %{epoch}:%{version}-%{release}
b0333243
JR
552Requires: libselinux >= 2.1.0
553
554%description plugin-selinux
555Plugin for SELinux functionality.
556
8191f3c5
JR
557%package sign
558Summary: Package signing support
559Group: Base
9fe07969 560Requires: %{name}-lib = %{epoch}:%{version}-%{release}
8191f3c5
JR
561
562%description sign
563This package contains support for digitally signing RPM packages.
564
5c2ab5c7
AM
565%package apidocs
566Summary: RPM API documentation and guides
567Summary(pl.UTF-8): Documentacja API RPM-a i przewodniki
568Group: Documentation
d308de4c 569BuildArch: noarch
5c2ab5c7
AM
570
571%description apidocs
572Documentation for RPM API and guides in HTML format generated from rpm
573sources by doxygen.
574
575%description apidocs -l pl.UTF-8
576Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
577źrodeł RPM-a przez doxygen.
578
e2025ad1 579%prep
c546a4d6 580%setup -q -n %{name}-%{version}%{?subver}
af0cc499 581%patch0 -p1
2f0ee4ec 582%patch1 -p1
4d5b8e4c 583%patch2 -p1
af0cc499 584%patch3 -p1
7a3b1f24 585%patch4 -p1
cbab0cbf
JR
586%patch5 -p1
587%patch6 -p0
588%patch7 -p1
af0cc499 589%patch8 -p1
cbab0cbf 590%patch9 -p1
af0cc499
JR
591%patch10 -p1
592%patch11 -p1
593%patch12 -p1
594%patch13 -p1
595%patch14 -p1
7033e976 596%patch15 -p1
af0cc499
JR
597%patch16 -p1
598%patch17 -p1
79191ca9 599%patch18 -p1
883e0fac 600
0bf34f68 601install %{SOURCE11} scripts/perl.prov.in
08697680 602
70f8787d 603%{__mv} -f scripts/perl.req{,.in}
633d1e9e 604
cd86db2e 605# generate Group translations to *.po
80b8a1f9 606awk -f %{SOURCE6} %{SOURCE1}
fefe9d30 607
91ee86a9 608install %{SOURCE26} tools/rpmdb_checkversion.c
8e8746c0 609install %{SOURCE28} tools/rpmdb_reset.c
91ee86a9 610
40675133
JR
611%{__sed} -i -e '1s,/usr/bin/python,%{__python},' scripts/pythondistdeps.py
612
87ef0d95 613%build
ea816ea6 614%{__libtoolize}
ceaaacee 615%{__aclocal}
4cd84746 616%{__autoheader}
7a9d72ce 617%{__autoconf}
7a9d72ce 618%{__automake}
7a9d72ce 619
048d06f8
JR
620# rpm checks for CPU type at runtime, but it looks better
621sed -i \
622 -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
623 -e 's|@host_cpu@|%{_target_cpu}|' \
624 -e 's|@host_os@|%{_target_os}|' \
fb35e2d9 625 macros.in
048d06f8 626
5c767dc1 627CPPFLAGS="-I/usr/include/lua53 %{rpmcppflags}"
624f96ff 628%configure \
01d7a578 629 WITH_PERL_VERSION=no \
bba1059c 630 __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
dcf91c25 631 __GPG=%{_bindir}/gpg \
f9d0e5f6
JR
632 %{?with_python3:PYTHON=python3} \
633 %{!?with_python3:%{?with_python2:PYTHON=python2}} \
3a3e476f 634 --disable-silent-rules \
cd86db2e 635 --enable-shared \
34865f27 636 --enable-bdb \
af0cc499 637 --enable-zstd \
fb35e2d9 638 --with-crypto=openssl \
c38bf1df 639 --with-lua \
34865f27
JR
640 --with-cap \
641 --with-acl \
642 --with-audit \
af0cc499 643 --with-archive \
f9d0e5f6
JR
644%if %{with python2} || %{with python3}
645 --enable-python \
646%endif
b0333243
JR
647 --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
648 %{!?with_plugins:--disable-plugins} \
34865f27
JR
649 --with-vendor=pld
650
34865f27
JR
651# --enable-ndb (EXPERIMENTAL) enable the new rpm database format
652# --enable-lmdb=[yes/no/auto] (EXPERIMENTAL) build with LMDB rpm database format support (default=auto)
34865f27 653# --with-imaevm build with imaevm support
cf6faebc 654
5c767dc1 655%{__make}
5c2ab5c7 656
fb95de52
JR
657%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_checkversion.c \
658 -o tools/rpmdb_checkversion -ldb-%{reqdb_ver}
8e8746c0
JR
659%{__cc} %{rpmcflags} -I/usr/include/db%{reqdb_ver} tools/rpmdb_reset.c \
660 -o tools/rpmdb_reset -ldb-%{reqdb_ver}
fb95de52
JR
661
662if tools/rpmdb_checkversion -V 2>&1 | grep "t match library version"; then
663 echo "Error linking rpmdb tools!"
664 exit 1
665fi
8e8746c0
JR
666if tools/rpmdb_reset -V 2>&1 | grep "t match library version"; then
667 echo "Error linking rpmdb tools!"
668 exit 1
669fi
91ee86a9 670
f9d0e5f6
JR
671%if %{with python2}
672cd python
673%py_build
674cd ..
675%endif
676
677%if %{with python3}
678cd python
679%py3_build
680%endif
681
b064b8e6 682%install
ff7bc1e6 683rm -rf $RPM_BUILD_ROOT
d1f5e279 684install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
7d12560f 685 $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/var/cache/hrmib}
54eb1770 686
d1f5e279 687cp -p %{SOURCE16} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
76214164 688
d1f5e279 689%{__make} install \
241257bf
AM
690 pkgconfigdir=%{_pkgconfigdir} \
691 DESTDIR=$RPM_BUILD_ROOT
718426e1 692
c546a4d6 693# cleanup
c2683840 694%ifnarch %{ix86} %{x8664} x32
2f409bb7 695rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
34865f27 696rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
2f409bb7
JR
697rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
698rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
699rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
700rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
701rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
702rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
25ac75ae
AM
703%endif
704
c2683840 705%ifnarch %{x8664} x32
2f409bb7
JR
706rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
707rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
708rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
709rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
25ac75ae
AM
710%endif
711
c546a4d6 712%ifnarch %{ppc}
34865f27
JR
713rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
714rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
715rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
716rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
717rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
2f409bb7 718rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
34865f27 719rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
25ac75ae
AM
720%endif
721
34865f27 722rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
2f409bb7
JR
723rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
724rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
725rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
726rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
34865f27 727rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
2f409bb7 728rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
34865f27 729rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
2f409bb7 730rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
c546a4d6 731
3a3e476f 732%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
644d8958 733
396a7387 734install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
396a7387 735
d1f5e279 736cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
d1f5e279 737cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
d1f5e279
JR
738cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_rpmlibdir}/hrmib-cache
739cp -p %{SOURCE13} $RPM_BUILD_ROOT/etc/sysconfig/rpm
e663e5ff 740
d1f5e279 741cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_bindir}/banner.sh
7c6dc55f 742
d1f5e279
JR
743cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
744cp -p %{SOURCE27} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
745cp -p %{SOURCE19} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautocompressdoc
746cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
747cp -p %{SOURCE21} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
748cp -p %{SOURCE22} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
749cp -p %{SOURCE24} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
08697680 750
f9d0e5f6
JR
751cp -p tools/rpmdb_checkversion $RPM_BUILD_ROOT%{_rpmlibdir}/
752cp -p tools/rpmdb_reset $RPM_BUILD_ROOT%{_rpmlibdir}/
753cp -p %{SOURCE29} $RPM_BUILD_ROOT%{_rpmlibdir}/dbupgrade.sh
9776a251 754
950eead3 755# move rpm to /bin
8191f3c5
JR
756%{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
757ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
758ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
759
950eead3 760# move essential libs to /lib (libs that /bin/rpm links to)
40675133
JR
761for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
762 mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
763 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
c2673e18
AF
764done
765
7d12560f
JR
766#./rpmdb --macros=macros --rcfile=rpmrc --dbpath=/home/users/baggins/devel/PLD/rpm/BUILD/rpm-4.15.1/x/ --initdb
767
f9d0e5f6
JR
768%if %{with python2}
769# Remove anything that rpm make install might put there
770%{__rm} -rf $RPM_BUILD_ROOT%{py_sitedir}
771cd python
772%py_install
773%py_postclean
774cd ..
775%endif
6f18cdb7 776
f9d0e5f6
JR
777%if %{with python3}
778# Remove anything that rpm make install might put there
779%{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
780cd python
781%py3_install
782cd ..
dae5e1a8 783%endif
01d7a578 784
d1f5e279
JR
785%{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
786
01d7a578 787# wrong location, not used anyway
2f409bb7 788%{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
01d7a578 789
90b03dd6 790%find_lang %{name}
cf6faebc 791
13eb5ebf 792%clean
d7df46b8 793rm -rf $RPM_BUILD_ROOT
76214164 794
be4d3036 795%posttrans
d25ec6ea 796if [ -e /var/lib/rpm/Packages ] && \
f9d0e5f6 797 ! %{_rpmlibdir}/rpmdb_checkversion -h /var/lib/rpm -d /var/lib/rpm; then
d25ec6ea 798 if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
6a934782 799 /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
8383afc3 800 echo
e4dd6a34 801 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
8383afc3
JR
802 echo
803 fi
3ca91ccd
JR
804 echo
805 echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
806 echo 'you should ignore it and restart poldek'
807 echo
f9d0e5f6 808 %{_rpmlibdir}/dbupgrade.sh
be4d3036 809fi
f7779567 810
b7ee97ef
JR
811%triggerpostun -- %{name} < 4.4.9-44
812%{_rpmlibdir}/hrmib-cache
813
ceaaacee
JB
814%post lib -p /sbin/ldconfig
815%postun lib -p /sbin/ldconfig
76214164 816
37a5a2fc 817%pretrans build
d755a548 818find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
8f76a271 819
3684d90f
JB
820%files -f %{name}.lang
821%defattr(644,root,root,755)
d1f5e279 822%doc ChangeLog CREDITS README
3684d90f 823
3acb62f3
ER
824%dir /etc/pki/rpm-gpg
825/etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
54eb1770 826
7a9d72ce 827%attr(755,root,root) /bin/rpm
8191f3c5
JR
828%attr(755,root,root) %{_bindir}/rpmdb
829%attr(755,root,root) %{_bindir}/rpmkeys
830%attr(755,root,root) %{_bindir}/rpmquery
831%attr(755,root,root) %{_bindir}/rpmverify
e73478cd 832
66edd895 833%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
b1541d4c 834%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
caf453d4 835
09bb810c 836%{_mandir}/man8/rpm.8*
8191f3c5
JR
837%{_mandir}/man8/rpmdb.8*
838%{_mandir}/man8/rpmkeys.8*
839%{_mandir}/man8/rpm-misc.8*
feb1f12e 840%lang(fr) %{_mandir}/fr/man8/rpm.8*
e2025ad1 841%lang(ja) %{_mandir}/ja/man8/rpm.8*
d1f5e279 842%lang(ko) %{_mandir}/ko/man8/rpm.8*
ff7bc1e6 843%lang(pl) %{_mandir}/pl/man8/rpm.8*
cf6faebc 844%lang(ru) %{_mandir}/ru/man8/rpm.8*
740f105d 845%lang(sk) %{_mandir}/sk/man8/rpm.8*
76214164 846
7d12560f 847%dir /var/lib/rpm
4acac5de 848
cf709a39
ER
849# exported package NVRA (stamped with install tid)
850# net-snmp hrSWInstalledName queries, bash-completions
851%dir /var/cache/hrmib
852
d755a548 853%{_rpmlibdir}/rpmpopt*
8191f3c5 854%{_rpmlibdir}/rpmrc
d755a548 855%{_rpmlibdir}/macros
08697680 856%dir %{_rpmlibdir}/macros.d
e8836e1f 857%dir %{_rpmlibdir}/platform
40675133 858%{_rpmlibdir}/platform/noarch-*
c2683840 859%ifarch %{ix86} %{x8664} x32
34865f27
JR
860%{_rpmlibdir}/platform/athlon*
861%{_rpmlibdir}/platform/geode*
40675133
JR
862%{_rpmlibdir}/platform/i?86*
863%{_rpmlibdir}/platform/pentium*
34865f27
JR
864%endif
865%ifarch %{x8664} x32
866%{_rpmlibdir}/platform/amd64*
867%{_rpmlibdir}/platform/ia32e*
868%{_rpmlibdir}/platform/x86_64*
83a0601a 869%{_rpmlibdir}/platform/x32*
e23edf35
JR
870%endif
871%ifarch alpha
40675133 872%{_rpmlibdir}/platform/alpha*
e23edf35
JR
873%endif
874%ifarch ia64
40675133 875%{_rpmlibdir}/platform/ia64*
e23edf35
JR
876%endif
877%ifarch mips mipsel mips64 mips64el
40675133 878%{_rpmlibdir}/platform/mips*
e23edf35
JR
879%endif
880%ifarch %{ppc}
40675133 881%{_rpmlibdir}/platform/ppc*
e23edf35
JR
882%endif
883%ifarch sparc sparc64
40675133 884%{_rpmlibdir}/platform/sparc*
e23edf35 885%endif
3684d90f 886
3de8e4a9 887%dir %{_rpmlibdir}/pld
396a7387 888
cf709a39
ER
889%attr(755,root,root) %{_rpmlibdir}/hrmib-cache
890
f9d0e5f6
JR
891%attr(755,root,root) %{_rpmlibdir}/dbupgrade.sh
892%attr(755,root,root) %{_rpmlibdir}/rpmdb_checkversion
893%attr(755,root,root) %{_rpmlibdir}/rpmdb_reset
df50421f 894
7d12560f
JR
895# valgrind suppression file for rpm
896%{_rpmlibdir}/rpm.supp
897
66edd895
JB
898%files base
899%defattr(644,root,root,755)
492a2bd4 900%dir %{_sysconfdir}/rpm
66edd895
JB
901%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
902%dir %{_rpmlibdir}
903%attr(755,root,root) %{_bindir}/banner.sh
904%attr(755,root,root) %{_rpmlibdir}/user_group.sh
905%dir /var/lib/banner
906
874f4c9a
MM
907%files lib
908%defattr(644,root,root,755)
40675133
JR
909%attr(755,root,root) /%{_lib}/librpm.so.9
910%attr(755,root,root) /%{_lib}/librpm.so.%{sover}
911%attr(755,root,root) /%{_lib}/librpmbuild.so.9
912%attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
913%attr(755,root,root) /%{_lib}/librpmio.so.9
914%attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
915%attr(755,root,root) /%{_lib}/librpmsign.so.9
916%attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
b0333243 917%{?with_plugins:%dir %{_libdir}/rpm-plugins}
874f4c9a 918
69131f1a
JB
919%files devel
920%defattr(644,root,root,755)
69131f1a 921%attr(755,root,root) %{_libdir}/librpm.so
950eead3 922%attr(755,root,root) %{_libdir}/librpmbuild.so
69131f1a 923%attr(755,root,root) %{_libdir}/librpmio.so
40675133 924%attr(755,root,root) %{_libdir}/librpmsign.so
950eead3
ER
925%{_libdir}/librpm*.la
926%{_includedir}/rpm
927%{_pkgconfigdir}/*.pc
69131f1a 928
69131f1a
JB
929%files utils
930%defattr(644,root,root,755)
d1f5e279 931%attr(755,root,root) %{_bindir}/rpm2archive
69131f1a 932%attr(755,root,root) %{_bindir}/rpm2cpio
fc36dfd5 933%attr(755,root,root) %{_bindir}/rpmgraph
d1f5e279 934%attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
69131f1a 935%attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
69131f1a 936%attr(755,root,root) %{_rpmlibdir}/rpmdb_loadcvt
25e974c7 937%attr(755,root,root) %{_rpmlibdir}/tgpg
d1f5e279
JR
938%attr(755,root,root) %{_rpmlibdir}/debugedit
939%attr(755,root,root) %{_rpmlibdir}/rpmdeps
69131f1a
JB
940%{_mandir}/man8/rpm2cpio.8*
941%{_mandir}/man8/rpmdeps.8*
fc36dfd5 942%{_mandir}/man8/rpmgraph.8*
69131f1a 943%lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
d1f5e279 944%lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
69131f1a 945%lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
69131f1a 946%lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
d1f5e279 947%lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
fc36dfd5
JR
948%lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
949%lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
69131f1a 950
3684d90f 951%files build
a45ae6d8 952%defattr(644,root,root,755)
66edd895 953%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
01d7a578
JB
954%attr(755,root,root) %{_rpmlibdir}/brp-*
955%attr(755,root,root) %{_rpmlibdir}/check-files
d755a548 956%attr(755,root,root) %{_rpmlibdir}/install-build-tree
d1f5e279 957%attr(755,root,root) %{_rpmlibdir}/elfdeps
01d7a578
JB
958%attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
959# needs hacked pkg-config to return anything
960%attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
d1f5e279 961%attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
37e965e8 962
70f8787d 963%attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
37e965e8 964# must be here for "Requires: rpm-*prov" to work
40675133
JR
965#%{_rpmlibdir}/macros.d/cmake
966#%{_rpmlibdir}/macros.d/gstreamer
40675133 967#%{_rpmlibdir}/macros.d/libtool
40675133 968#%{_rpmlibdir}/macros.d/perl
40675133
JR
969#%{_rpmlibdir}/macros.d/pkgconfig
970#%{_rpmlibdir}/macros.d/python
40675133
JR
971#%{_rpmlibdir}/macros.d/selinux
972#%{_rpmlibdir}/macros.d/tcl
973#%{_rpmlibdir}/macros.rpmbuild
f9d0e5f6 974
7d12560f
JR
975%attr(755,root,root) %{_rpmlibdir}/check-buildroot
976%attr(755,root,root) %{_rpmlibdir}/check-prereqs
977%attr(755,root,root) %{_rpmlibdir}/check-rpaths
978%attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
979%attr(755,root,root) %{_rpmlibdir}/debuginfo.prov
980%attr(755,root,root) %{_rpmlibdir}/desktop-file.prov
981%attr(755,root,root) %{_rpmlibdir}/find-provides
982%attr(755,root,root) %{_rpmlibdir}/find-requires
983%attr(755,root,root) %{_rpmlibdir}/metainfo.prov
984%attr(755,root,root) %{_rpmlibdir}/ocaml-find-provides.sh
985%attr(755,root,root) %{_rpmlibdir}/ocaml-find-requires.sh
986%attr(755,root,root) %{_rpmlibdir}/script.req
987%attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
988# Fedora has this in -build, but shouldn't this be in -devel?
989%attr(755,root,root) %{_rpmlibdir}/config.guess
990%attr(755,root,root) %{_rpmlibdir}/config.sub
991
f9d0e5f6
JR
992%dir %{_rpmlibdir}/fileattrs
993%{_rpmlibdir}/fileattrs/debuginfo.attr
994%{_rpmlibdir}/fileattrs/desktop.attr
995%{_rpmlibdir}/fileattrs/elf.attr
996%{_rpmlibdir}/fileattrs/font.attr
997%{_rpmlibdir}/fileattrs/libtool.attr
998%{_rpmlibdir}/fileattrs/metainfo.attr
999%{_rpmlibdir}/fileattrs/ocaml.attr
1000%{_rpmlibdir}/fileattrs/perl.attr
1001%{_rpmlibdir}/fileattrs/perllib.attr
f9d0e5f6
JR
1002%{_rpmlibdir}/fileattrs/pkgconfig.attr
1003%{_rpmlibdir}/fileattrs/python.attr
1004%{_rpmlibdir}/fileattrs/pythondist.attr
1005%{_rpmlibdir}/fileattrs/script.attr
77fcdbf7 1006
874f4c9a
MM
1007%attr(755,root,root) %{_bindir}/gendiff
1008%attr(755,root,root) %{_bindir}/rpmbuild
d1f5e279 1009%attr(755,root,root) %{_bindir}/rpmspec
874f4c9a 1010
a00926bc 1011%{_mandir}/man1/gendiff.1*
d1f5e279 1012%lang(pl) %{_mandir}/pl/man1/gendiff.1*
874f4c9a 1013%{_mandir}/man8/rpmbuild.8*
fefe9d30 1014%lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
fefe9d30 1015%lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
d1f5e279 1016%{_mandir}/man8/rpmspec.8*
f3fe287f 1017
89334051
AF
1018%files perlprov
1019%defattr(644,root,root,755)
d755a548 1020%attr(755,root,root) %{_rpmlibdir}/perl.*
9805fd6d 1021
80d3b868 1022%files pythonprov
d8fcb9b0 1023%defattr(644,root,root,755)
25d296e1 1024%attr(755,root,root) %{_rpmlibdir}/pythondeps.sh
d1f5e279 1025%attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
09bb810c 1026
f9d0e5f6 1027%if %{with python2}
cf6faebc 1028%files -n python-rpm
42a0025c 1029%defattr(644,root,root,755)
34865f27
JR
1030%dir %{py_sitedir}/rpm
1031%attr(755,root,root) %{py_sitedir}/rpm/*.so
1032%{py_sitedir}/rpm/*.py[co]
f9d0e5f6
JR
1033%{py_sitedir}/rpm-%{version}-py*.egg-info
1034%endif
1035
1036%if %{with python3}
1037%files -n python3-rpm
1038%defattr(644,root,root,755)
1039%dir %{py3_sitedir}/rpm
1040%attr(755,root,root) %{py3_sitedir}/rpm/*.so
1041%{py3_sitedir}/rpm/*.py
1042%{py3_sitedir}/rpm-%{version}-py*.egg-info
1043%{py3_sitedir}/rpm/__pycache__
50dc9ac0 1044%endif
5c2ab5c7 1045
b0333243
JR
1046%if %{with plugins}
1047%files plugin-audit
1048%defattr(644,root,root,755)
1049%attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1050
1051%files plugin-syslog
1052%defattr(644,root,root,755)
1053%attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1054
1055%files plugin-systemd-inhibit
1056%defattr(644,root,root,755)
1057%attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1058%{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1059
1060%files plugin-ima
1061%defattr(644,root,root,755)
1062%attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1063
1064%files plugin-prioreset
1065%defattr(644,root,root,755)
1066%attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1067
1068%files plugin-selinux
1069%defattr(644,root,root,755)
1070%attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1071%endif
1072
8191f3c5
JR
1073%files sign
1074%defattr(644,root,root,755)
1075%attr(755,root,root) %{_bindir}/rpmsign
1076%{_mandir}/man8/rpmsign.8*
1077
5c2ab5c7
AM
1078%if %{with apidocs}
1079%files apidocs
1080%defattr(644,root,root,755)
d1f5e279
JR
1081%doc doc/librpm/html/*
1082%endif
This page took 0.729532 seconds and 4 git commands to generate.