]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- clang-analyzer and lldb files update
[packages/llvm.git] / llvm.spec
CommitLineData
6df3b432
JB
1# TODO:
2# - move and package:
3# %{_datadir}/clang/clang-format-sublime.py - sublime plugin
4# %{_datadir}/clang/clang-format.el - emacs mode
5# %{_datadir}/clang/clang-format.py - vim plugin
6# - no content in doc package (it used to contain parts of clang apidocs and some examples)
bc88141a 7#
9556f4c9 8# Conditional build:
589b92f5
JB
9%bcond_without lldb # LLDB debugger
10%bcond_without polly # Polly cache-locality optimization, auto-parallelism and vectorization
11%bcond_without rt # compiler-rt libraries
12%bcond_without multilib # compiler-rt multilib libraries
13%bcond_without ocaml # OCaml binding
14%bcond_without doc # HTML docs and man pages
15%bcond_with apidocs # doxygen docs (HUGE, so they are not built by default)
16%bcond_with tests # run tests
9556f4c9 17
4ba3b2b3 18# No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
509439cf 19%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
9556f4c9
ER
20%undefine with_ocaml
21%endif
22
aa11c230 23Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 24Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 25Name: llvm
859162df 26Version: 3.8.1
1ba9fe1c 27Release: 0.1
aa11c230 28License: University of Illinois/NCSA Open Source License
29Group: Development/Languages
dd9350c7 30#Source0Download: http://llvm.org/releases/download.html
b883cf1e 31Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
859162df 32# Source0-md5: 538467e6028bbc9259b1e6e015d25845
b883cf1e 33Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
859162df 34# Source1-md5: 4ff2f8844a786edb0220f490f7896080
b883cf1e 35Source2: http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
859162df 36# Source2-md5: f140db073d2453f854fbe01cc46f3110
b883cf1e 37Source3: http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
859162df 38# Source3-md5: 9e4787b71be8e432fffd31e13ac87623
b883cf1e 39Source4: http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
859162df 40# Source4-md5: 8a40e697a4ba1c8b640b85d074bd6e25
b883cf1e 41Source5: http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
859162df 42# Source5-md5: 6e49f285d0b366cc3cab782d8c92d382
ba1cf74d 43Source6: http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
859162df 44# Source6-md5: 68cd069bf99c71ebcfbe01d557c0e14d
3c402b7e 45Patch0: %{name}-lld-link.patch
9f7b77bd
JR
46Patch1: %{name}-pld.patch
47Patch2: libdir.patch
48Patch3: x32-gcc-toolchain.patch
d96b39d3 49Patch4: cmake-buildtype.patch
2326a99f 50URL: http://llvm.org/
bc88141a 51BuildRequires: bash
d997b14b 52BuildRequires: bison
ac5fd320 53BuildRequires: cmake
d997b14b 54BuildRequires: flex
dd9350c7
JB
55BuildRequires: gcc >= 5:3.4
56# gcc4 might be installed, but not current __cc
57%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
58BuildRequires: __cc >= 3.4
9556f4c9 59%endif
2bbd0701
JR
60%ifarch x32
61BuildRequires: glibc-devel(x86_64)
62%endif
d997b14b 63BuildRequires: groff
bc88141a 64BuildRequires: libltdl-devel
d997b14b 65BuildRequires: libstdc++-devel >= 5:3.4
2bbd0701 66%if %{with ocaml}
c6c890ee 67BuildRequires: ocaml-ctypes-devel >= 0.4
2bbd0701 68BuildRequires: ocaml-findlib
77c13dab 69BuildRequires: ocaml-ocamldoc
2bbd0701
JR
70BuildRequires: ocaml-ounit
71%endif
8132e62b 72BuildRequires: perl-base >= 1:5.6
8c156e7d 73BuildRequires: perl-tools-pod
74BuildRequires: rpm-pythonprov
b0068ae4 75%{?with_doc:BuildRequires: sphinx-pdg}
b883cf1e
JB
76BuildRequires: tar >= 1:1.22
77BuildRequires: xz
dd9350c7
JB
78%if %{with apidocs}
79BuildRequires: doxygen
80BuildRequires: graphviz
81%endif
82%if %{with tests}
83BuildRequires: dejagnu
84BuildRequires: python
85BuildRequires: tcl-devel
356a0bbd 86%endif
589b92f5
JB
87%if %{with rt} && %{with multilib}
88%ifarch %{x8664}
89BuildRequires: gcc-c++-multilib-32
90BuildRequires: libstdc++-multilib-32-devel
91%endif
92%endif
b883cf1e 93%if %{with lldb}
c6c890ee 94BuildRequires: epydoc
64f4e87f
JB
95%ifarch i386 i486
96BuildRequires: libatomic-devel
97%endif
b883cf1e
JB
98BuildRequires: libedit-devel
99BuildRequires: libxml2-devel >= 2
100BuildRequires: ncurses-ext-devel
101BuildRequires: python-devel >= 2
c6c890ee 102BuildRequires: swig-python
b883cf1e 103%endif
b0068ae4
JB
104%if %{with polly}
105BuildRequires: cloog-isl-devel
b883cf1e 106# >= 0.18.2-2
b0068ae4 107BuildRequires: gmp-devel
2bbd0701 108BuildRequires: isl-devel >= 0.14
b883cf1e 109# optional
3eca6fe9 110BuildRequires: pluto-devel
b883cf1e 111BuildRequires: scoplib-devel >= 0.2.1-2
b0068ae4
JB
112#cuda-devel
113%endif
634a3e5b
JB
114%if %{with ocaml}
115BuildConflicts: llvm-ocaml
116%endif
8c514f23 117Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
118# LLVM is not supported on PPC64
119# http://llvm.org/bugs/show_bug.cgi?id=3729
120ExcludeArch: ppc64
aa11c230 121BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
509439cf 123%define abi 3.8
356a0bbd 124%define _sysconfdir /etc/%{name}
021b3c3d 125
9556f4c9
ER
126%define specflags_ppc -fno-var-tracking-assignments
127
6832a5c5
ER
128# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
129%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
130
782c6e1e
ER
131# clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
132# -Werror=format-security is for swig
133# TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
4a1d21cc 134%define filterout_c -fvar-tracking-assignments
782c6e1e 135%define filterout_cxx -fvar-tracking-assignments -Werror=format-security
4a1d21cc
JR
136%define filterout_ccpp -fvar-tracking-assignments
137
6df3b432 138# std::__once_call, std::__once_callable non-function symbols
9a23736f 139%define skip_post_check_so liblldb.so.*
6df3b432 140
aa11c230 141%description
142LLVM is a compiler infrastructure designed for compile-time,
143link-time, runtime, and idle-time optimization of programs from
144arbitrary programming languages. LLVM is written in C++ and has been
145developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
146currently supports compilation of C and C++ programs using clang
147frontend.
aa11c230 148
2326a99f
JB
149%description -l pl.UTF-8
150LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
151czasu kompilowania, linkowania, działania i bezczynności programów w
152dowolnych językach programowania. Jest napisana w C++, rozwijana od
153roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 154kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 155
8c514f23 156%package libs
87977e26
JR
157Summary: LLVM shared libraries
158Summary(pl.UTF-8): Biblioteki współdzielone LLVM-a
8c514f23
JB
159Group: Libraries
160Conflicts: llvm < 3.2
161
162%description libs
87977e26 163LLVM shared libraries.
8c514f23
JB
164
165%description libs -l pl.UTF-8
87977e26 166Biblioteki współdzielone LLVM-a.
8c514f23 167
bc88141a 168%package devel
621ec11f
JB
169Summary: Static libraries and header files for LLVM
170Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 171Group: Development/Languages
8c514f23 172Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
173Requires: libstdc++-devel >= 6:3.4
174
175%description devel
621ec11f
JB
176This package contains static libraries and header files needed to
177develop new native programs that use the LLVM infrastructure.
178
179%description devel -l pl.UTF-8
180Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
181potrzebne do tworzenia nowych programów natywnych wykorzystujących
182infrastrukturę LLVM.
bc88141a 183
9556f4c9
ER
184%package doc
185Summary: Documentation for LLVM
621ec11f 186Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
187Group: Documentation
188# does not require base
bc88141a 189
9556f4c9
ER
190%description doc
191Documentation for the LLVM compiler infrastructure.
bc88141a 192
621ec11f
JB
193%description doc -l pl.UTF-8
194Dokumentacja do infrastruktury kompilatorów LLVM.
195
9556f4c9
ER
196%package apidocs
197Summary: API documentation for LLVM
621ec11f 198Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
199Group: Development/Languages
200Requires: %{name}-doc = %{version}-%{release}
bc88141a 201
9556f4c9
ER
202%description apidocs
203API documentation for the LLVM compiler infrastructure.
bc88141a 204
621ec11f
JB
205%description apidocs -l pl.UTF-8
206Dokumentacja API infrastruktury kompilatorów LLVM.
207
b0068ae4
JB
208%package polly
209Summary: Polyhedral optimizations for LLVM
210Summary(pl.UTF-8): Optymalizacje wielościanowe dla LLVM-a
211Group: Development/Tools
212URL: http://polly.llvm.org/
213Requires: %{name} = %{version}-%{release}
214
215%description polly
216Polly is a high-level loop and data-locality optimizer and
217optimization infrastructure for LLVM. It uses an abstract mathematical
218representation based on integer polyhedra to analyze and optimize the
219memory access pattern of a program.
220
221%description polly -l pl.UTF-8
222Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
223optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
224reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
225do analizy i optymalizacji wzorców dostępu do pamięci przez program.
226
227%package polly-devel
228Summary: Header files for LLVM Polly optimization infrastructure
229Summary(pl.UTF-8): Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
230Group: Development/Libraries
231URL: http://polly.llvm.org/
232Requires: %{name}-devel = %{version}-%{release}
233Requires: %{name}-polly = %{version}-%{release}
234
235%description polly-devel
236Header files for LLVM Polly optimization infrastructure.
237
238%description polly-devel -l pl.UTF-8
239Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
240
d997b14b
AM
241%package -n clang
242Summary: A C language family frontend for LLVM
621ec11f 243Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
244License: NCSA
245Group: Development/Languages
8c514f23 246Requires: %{name} = %{version}-%{release}
87977e26 247Requires: clang-libs = %{version}-%{release}
d997b14b
AM
248
249%description -n clang
250clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
251of a crane or goose. 3. C-language family front-end toolkit.
252
253The goal of the Clang project is to create a new C, C++, Objective C
254and Objective C++ front-end for the LLVM compiler. Its tools are built
255as libraries and designed to be loosely-coupled and extendable.
256
621ec11f
JB
257%description -n clang -l pl.UTF-8
258clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
259piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
260z rodziny C.
261
262Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
263LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
264budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
265i rozszerzaniu.
266
87977e26
JR
267%package -n clang-libs
268Summary: Clang shared libraries
269Summary(pl.UTF-8): Biblioteki współdzielone Clanga
270Group: Libraries
271
272%description -n clang-libs
273Clang shared libraries.
274
275%description -n clang-libs -l pl.UTF-8
276Biblioteki współdzielone Clanga.
277
9eefd942
JR
278%package -n clang-multilib
279Summary: A C language family frontend for LLVM - 32-bit support
280Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
281License: NCSA
282Group: Development/Languages
283Requires: clang = %{version}-%{release}
284
285%description -n clang-multilib
286clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
287of a crane or goose. 3. C-language family front-end toolkit.
288
289The goal of the Clang project is to create a new C, C++, Objective C
290and Objective C++ front-end for the LLVM compiler. Its tools are built
291as libraries and designed to be loosely-coupled and extendable.
292
293This package contains the C compiler support for producing 32-bit
294programs on 64-bit host.
295
296%description -n clang-multilib -l pl.UTF-8
297clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
298piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
299z rodziny C.
300
301Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
302LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
303budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
304i rozszerzaniu.
305
306Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
307programów 32-bitowych na maszynie 64-bitowej.
308
d997b14b
AM
309%package -n clang-analyzer
310Summary: A source code analysis framework
621ec11f 311Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
312License: NCSA
313Group: Development/Languages
314Requires: clang = %{version}-%{release}
315# not picked up automatically since files are currently not instaled
316# in standard Python hierarchies yet
317Requires: python
318
319%description -n clang-analyzer
320The Clang Static Analyzer consists of both a source code analysis
321framework and a standalone tool that finds bugs in C and Objective-C
322programs. The standalone tool is invoked from the command-line, and is
323intended to run in tandem with a build of a project or code base.
324
621ec11f
JB
325%description -n clang-analyzer -l pl.UTF-8
326Clang Static Analyzer składa się ze szkieletu do analizy kodu
327źródłowego oraz samodzielnego narzędzia znajdującego błędy w
328programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
329myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
330
9556f4c9 331%package -n clang-devel
621ec11f
JB
332Summary: Header files for Clang
333Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 334Group: Development/Languages
8c514f23 335Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
336Requires: clang = %{version}-%{release}
337
338%description -n clang-devel
339This package contains header files for the Clang compiler.
340
621ec11f
JB
341%description -n clang-devel -l pl.UTF-8
342Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
343
9556f4c9
ER
344%package -n clang-doc
345Summary: Documentation for Clang
621ec11f 346Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
347Group: Documentation
348Requires: %{name} = %{version}-%{release}
349
350%description -n clang-doc
351Documentation for the Clang compiler front-end.
352
621ec11f
JB
353%description -n clang-doc -l pl.UTF-8
354Dokumentacja do frontendu kompilatora Clang.
355
9556f4c9
ER
356%package -n clang-apidocs
357Summary: API documentation for Clang
621ec11f 358Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
359Group: Development/Languages
360Requires: clang-doc = %{version}-%{release}
361
362%description -n clang-apidocs
363API documentation for the Clang compiler.
364
621ec11f
JB
365%description -n clang-apidocs -l pl.UTF-8
366Dokumentacja API kompilatora Clang.
367
b0068ae4
JB
368%package -n clang-tools-extra
369Summary: Extra tools for Clang
370Summary(pl.UTF-8): Dodatkowe narzędzia do kompilatora Clang
371Group: Development/Tools
372URL: http://clang.llvm.org/docs/ClangTools.html
373Requires: clang = %{version}-%{release}
374
375%description -n clang-tools-extra
376Extra tools for Clang.
377
378%description -n clang-tools-extra -l pl.UTF-8
379Dodatkowe narzędzia do kompilatora Clang.
380
ba1cf74d
JB
381%package -n lld
382Summary: The LLVM linker
383Summary(pl.UTF-8): Konsolidator z projektu LLVM
384Group: Development/Libraries
385URL: http://lld.llvm.org/
386Requires: %{name} = %{version}-%{release}
387
388%description -n lld
389lld is a new set of modular code for creating linker tools.
390
391%description -n lld -l pl.UTF-8
392lld to nowy zbiór modularnego kodu do tworzenia narzędzi
393konsolidujących.
394
395%package -n lld-devel
396Summary: Development files for LLD linker tools
397Summary(pl.UTF-8): Pliki programistyczne narzędzi konsolidujących LLD
398Group: Development/Tools
399URL: http://lld.llvm.org/
400Requires: %{name}-devel = %{version}-%{release}
401
402%description -n lld-devel
403Development files for LLD linker tools.
404
405%description -n lld-devel -l pl.UTF-8
406Pliki programistyczne narzędzi konsolidujących LLD.
407
5a7ac479
JB
408%package -n lldb
409Summary: Next generation high-performance debugger
410Summary(pl.UTF-8): Wydajny debugger nowej generacji
411Group: Development/Debuggers
ba1cf74d 412URL: http://lldb.llvm.org/
5a7ac479
JB
413Requires: %{name} = %{version}-%{release}
414
415%description -n lldb
416LLDB is a next generation, high-performance debugger. It is built as a
417set of reusable components which highly leverage existing libraries in
418the larger LLVM Project, such as the Clang expression parser and LLVM
419disassembler.
420
421%description -n lldb -l pl.UTF-8
422LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
423komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
424w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
425disasembler LLVM.
426
427%package -n lldb-devel
ba1cf74d
JB
428Summary: Development files for LLDB debugger
429Summary(pl.UTF-8): Pliki programistyczne debuggera LLDB
5a7ac479 430Group: Development/Libraries
ba1cf74d 431URL: http://lldb.llvm.org/
5a7ac479
JB
432Requires: %{name}-devel = %{version}-%{release}
433Requires: clang-devel = %{version}-%{release}
434Requires: lldb = %{version}-%{release}
435
436%description -n lldb-devel
ba1cf74d 437Development files for LLDB debugger.
5a7ac479
JB
438
439%description -n lldb-devel -l pl.UTF-8
ba1cf74d 440Pliki programistyczne debuggera LLDB.
5a7ac479 441
9556f4c9
ER
442%package ocaml
443Summary: OCaml binding for LLVM
621ec11f
JB
444Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
445Group: Libraries
9556f4c9
ER
446Requires: %{name} = %{version}-%{release}
447%requires_eq ocaml-runtime
448
621ec11f 449%description ocaml
9556f4c9
ER
450OCaml binding for LLVM.
451
621ec11f
JB
452%description ocaml -l pl.UTF-8
453Wiązanie OCamla do LLVM-a.
454
9556f4c9 455%package ocaml-devel
621ec11f
JB
456Summary: Development files for LLVM OCaml binding
457Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
458Group: Development/Libraries
459Requires: %{name}-devel = %{version}-%{release}
460Requires: %{name}-ocaml = %{version}-%{release}
461
462%description ocaml-devel
463The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
464for developing applications that use llvm-ocaml binding.
465
466%description ocaml-devel -l pl.UTF-8
467Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
468wykorzystujących wiązanie llvm-ocaml.
469
9556f4c9
ER
470%package ocaml-doc
471Summary: Documentation for LLVM's OCaml binding
621ec11f 472Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
473Group: Documentation
474Requires: %{name}-ocaml = %{version}-%{release}
475
476%description ocaml-doc
477HTML documentation for LLVM's OCaml binding.
478
621ec11f
JB
479%description ocaml-doc -l pl.UTF-8
480Dokumentacja HTML wiązania OCamla do LLVM-a.
481
aa11c230 482%prep
ba1cf74d 483%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
c999855f 484mv cfe-%{version}.src tools/clang
b883cf1e
JB
485%{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
486%{?with_lldb:mv lldb-%{version}.src tools/lldb}
487%{?with_polly:mv polly-%{version}.src tools/polly}
488mv clang-tools-extra-%{version}.src tools/clang/tools/extra
ba1cf74d 489mv lld-%{version}.src tools/lld
5a7ac479 490
3c402b7e 491%patch0 -p1
9f7b77bd 492%patch1 -p1
ebde279d 493%patch2 -p1
9f7b77bd 494%patch3 -p1
d96b39d3 495%patch4 -p1
ce9cc204 496
bacc8b96
ER
497grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
498 s,^#!.*bin/env python,#!%{__python},
499 s,^#!.*bin/env perl,#!%{__perl},
500}'
501
d756c460 502%build
41876fe7 503install -d build
ebde279d 504
d997b14b 505# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 506# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
41876fe7 507cd build
5e689738 508CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
2bbd0701 509
d96b39d3 510%cmake \
41876fe7
JR
511%ifarch %{x8664}
512 -DLLVM_LIBDIR_SUFFIX:STRING=64 \
513%endif
514%ifarch x32
515 -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
516%endif
9556f4c9 517%if %{with apidocs}
41876fe7 518 -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
d997b14b 519%endif
41876fe7
JR
520%if %{with doc}
521 -DLLVM_ENABLE_SPHINX:BOOL=ON \
e962ba72 522 -DSPHINX_WARNINGS_AS_ERRORS=OFF \
41876fe7 523%endif
6c382d2a 524 -DLLVM_ENABLE_PIC:BOOL=ON \
41876fe7
JR
525 -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
526 -DLLVM_ENABLE_CXX1Y:BOOL=ON \
82174e17 527 -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
9a23736f
JB
528 -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
529 -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
530 -DBUILD_SHARED_LIBS:BOOL=OFF \
d96b39d3 531 ../
41876fe7 532
d997b14b 533%{__make} \
1628dc68 534 VERBOSE=1 \
0a0b7076 535 REQUIRES_RTTI=1 \
d997b14b 536 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 537
827664e9 538%if %{with tests}
9556f4c9
ER
539%{__make} check 2>&1 | tee llvm-testlog.txt
540%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
541%endif
542
b0068ae4 543%if %{with doc}
41876fe7
JR
544%{__make} -C docs docs-llvm-html
545%{__make} -C docs docs-llvm-man
c6c890ee 546%if %{with ocaml}
41876fe7 547%{__make} -C docs ocaml_doc
c6c890ee 548%endif
41876fe7
JR
549%{__make} -C tools/clang/docs docs-clang-html
550%{__make} -C tools/clang/docs docs-clang-man
551%{__make} -C tools/lld/docs docs-lld-html
552%{__make} -C tools/lldb/docs lldb-python-doc
553%{__make} -C tools/lldb/docs lldb-cpp-doc
6df3b432 554%{__make} -C ../tools/clang/tools/extra/docs html
dd9350c7
JB
555%endif
556
aa11c230 557%install
558rm -rf $RPM_BUILD_ROOT
41876fe7 559%{__make} -C build install \
aa11c230 560 DESTDIR=$RPM_BUILD_ROOT
561
6df3b432
JB
562# only some .pyc files are created by make install
563%py_comp $RPM_BUILD_ROOT%{py_sitedir}
564%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
565
634a3e5b 566# Adjust static analyzer installation
9556f4c9 567# http://clang-analyzer.llvm.org/installation#OtherPlatforms
634a3e5b
JB
568install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
569%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
570%{__sed} -i -e 's,/\.\./libexec/,../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
571%py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
572%py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
573%py_postclean %{_datadir}/scan-view
d997b14b 574
6df3b432 575# not installed by cmake buildsystem
6df3b432
JB
576install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
577
b0068ae4 578%if %{with doc}
6df3b432 579cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
b883cf1e
JB
580# these tools are not installed
581%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
b0068ae4
JB
582# make links
583echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
dd9350c7
JB
584%endif
585
d997b14b 586# Move documentation back to build directory
2bbd0701 587%if %{with ocaml}
6df3b432 588rm -rf ocamldocs
634a3e5b 589%{__mv} $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
2bbd0701 590%endif
9556f4c9
ER
591
592# and separate the apidoc
593%if %{with apidocs}
6df3b432
JB
594rm -rf clang-apidoc
595cp -a build/tools/clang/docs/html clang-apidoc
9556f4c9 596%endif
d997b14b
AM
597
598# And prepare Clang documentation
d997b14b 599rm -rf clang-docs
9556f4c9 600install -d clang-docs
827664e9 601for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 602 ln tools/clang/$f clang-docs
d997b14b 603done
021b3c3d 604
6832a5c5 605# Get rid of erroneously installed example files.
6df3b432
JB
606%{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
607# test?
608%{__rm} $RPM_BUILD_ROOT%{_bindir}/llvm-c-test
609# not this OS
610%{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
6832a5c5 611
aa11c230 612%clean
613rm -rf $RPM_BUILD_ROOT
614
8c514f23
JB
615%post libs -p /sbin/ldconfig
616%postun libs -p /sbin/ldconfig
aa11c230 617
5a7ac479
JB
618%post -n clang -p /sbin/ldconfig
619%postun -n clang -p /sbin/ldconfig
620
6df3b432
JB
621%post -n clang-tools-extra -p /sbin/ldconfig
622%postun -n clang-tools-extra -p /sbin/ldconfig
623
5a7ac479
JB
624%post -n lldb -p /sbin/ldconfig
625%postun -n lldb -p /sbin/ldconfig
626
aa11c230 627%files
628%defattr(644,root,root,755)
8132e62b 629%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 630%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
631%attr(755,root,root) %{_bindir}/llc
632%attr(755,root,root) %{_bindir}/lli
8132e62b
JB
633%attr(755,root,root) %{_bindir}/llvm-ar
634%attr(755,root,root) %{_bindir}/llvm-as
635%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 636%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
637%attr(755,root,root) %{_bindir}/llvm-diff
638%attr(755,root,root) %{_bindir}/llvm-dis
4ba3b2b3 639%attr(755,root,root) %{_bindir}/llvm-dsymutil
827664e9 640%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 641%attr(755,root,root) %{_bindir}/llvm-extract
6df3b432 642%attr(755,root,root) %{_bindir}/llvm-lib
8132e62b 643%attr(755,root,root) %{_bindir}/llvm-link
3c402b7e 644%attr(755,root,root) %{_bindir}/llvm-lto
8132e62b 645%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 646%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
647%attr(755,root,root) %{_bindir}/llvm-nm
648%attr(755,root,root) %{_bindir}/llvm-objdump
b883cf1e 649%attr(755,root,root) %{_bindir}/llvm-profdata
8132e62b 650%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 651%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
652%attr(755,root,root) %{_bindir}/llvm-rtdyld
653%attr(755,root,root) %{_bindir}/llvm-size
f981d747 654%attr(755,root,root) %{_bindir}/llvm-stress
1628dc68 655%attr(755,root,root) %{_bindir}/llvm-symbolizer
827664e9 656%attr(755,root,root) %{_bindir}/llvm-tblgen
41876fe7
JR
657%attr(755,root,root) %{_bindir}/llvm-cxxdump
658%attr(755,root,root) %{_bindir}/llvm-pdbdump
4ba3b2b3 659%attr(755,root,root) %{_bindir}/obj2yaml
8132e62b 660%attr(755,root,root) %{_bindir}/opt
4ba3b2b3
JB
661%attr(755,root,root) %{_bindir}/verify-uselistorder
662%attr(755,root,root) %{_bindir}/yaml2obj
b0068ae4 663%if %{with doc}
a9beeab5 664%{_mandir}/man1/bugpoint.1*
a7973f21 665%{_mandir}/man1/lit.1*
a9beeab5
JB
666%{_mandir}/man1/llc.1*
667%{_mandir}/man1/lli.1*
8132e62b
JB
668%{_mandir}/man1/llvm-ar.1*
669%{_mandir}/man1/llvm-as.1*
670%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 671%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
672%{_mandir}/man1/llvm-diff.1*
673%{_mandir}/man1/llvm-dis.1*
b883cf1e 674%{_mandir}/man1/llvm-dwarfdump.1*
8132e62b 675%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
676%{_mandir}/man1/llvm-link.1*
677%{_mandir}/man1/llvm-nm.1*
b883cf1e 678%{_mandir}/man1/llvm-profdata.1*
8132e62b 679%{_mandir}/man1/llvm-ranlib.1*
c999855f 680%{_mandir}/man1/llvm-readobj.1*
f981d747 681%{_mandir}/man1/llvm-stress.1*
1628dc68 682%{_mandir}/man1/llvm-symbolizer.1*
a9beeab5 683%{_mandir}/man1/opt.1*
dd9350c7 684%{_mandir}/man1/tblgen.1*
b0068ae4 685%endif
bc88141a 686
8c514f23
JB
687%files libs
688%defattr(644,root,root,755)
9a23736f
JB
689%attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
690# non-soname symlink
691%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
692%attr(755,root,root) %{_libdir}/libLTO.so
8c514f23 693
bc88141a
ER
694%files devel
695%defattr(644,root,root,755)
696%attr(755,root,root) %{_bindir}/llvm-config
9a23736f 697%attr(755,root,root) %{_libdir}/libLLVM.so
0a8510f2 698%attr(755,root,root) %{_libdir}/BugpointPasses.so
8132e62b
JB
699%{_includedir}/llvm
700%{_includedir}/llvm-c
b883cf1e
JB
701%dir %{_datadir}/llvm
702%{_datadir}/llvm/cmake
b0068ae4 703%if %{with doc}
8132e62b 704%{_mandir}/man1/llvm-config.1*
b0068ae4 705%endif
bc88141a 706
6df3b432
JB
707#%files doc
708#%defattr(644,root,root,755)
9556f4c9
ER
709
710%if %{with apidocs}
711%files apidocs
712%defattr(644,root,root,755)
713%doc apidoc/*
714%endif
715
b0068ae4
JB
716%if %{with polly}
717%files polly
718%defattr(644,root,root,755)
719%doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
720%attr(755,root,root) %{_libdir}/LLVMPolly.so
721
722%files polly-devel
723%defattr(644,root,root,755)
9a23736f
JB
724%{_libdir}/libPolly.a
725%{_libdir}/libPollyISL.a
b0068ae4
JB
726%{_includedir}/polly
727%endif
728
d997b14b 729%files -n clang
bc88141a 730%defattr(644,root,root,755)
827664e9 731%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
8132e62b
JB
732%attr(755,root,root) %{_bindir}/clang
733%attr(755,root,root) %{_bindir}/clang++
509439cf 734%attr(755,root,root) %{_bindir}/clang-%{abi}
dd9350c7 735%attr(755,root,root) %{_bindir}/clang-check
6df3b432 736%attr(755,root,root) %{_bindir}/clang-cl
1628dc68 737%attr(755,root,root) %{_bindir}/clang-format
6df3b432 738%attr(755,root,root) %{_bindir}/git-clang-format
5a7ac479
JB
739%dir %{_libdir}/clang
740%dir %{_libdir}/clang/%{version}
741%{_libdir}/clang/%{version}/include
742%if %{with rt}
c6c890ee 743%ifarch %{ix86} %{x8664}
6df3b432 744%{_libdir}/clang/%{version}/asan_blacklist.txt
9eefd942
JR
745%dir %{_libdir}/clang/%{version}/lib
746%dir %{_libdir}/clang/%{version}/lib/linux
747%endif
748%ifarch %{ix86}
749%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
750%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
c6c890ee
JB
751%endif
752%ifarch %{x8664}
3c402b7e
JB
753%{_libdir}/clang/%{version}/dfsan_abilist.txt
754%{_libdir}/clang/%{version}/msan_blacklist.txt
9eefd942
JR
755%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
756%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
f4c0e8bd 757%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
3c402b7e 758%endif
5a7ac479 759%endif
3c402b7e
JB
760%dir %{_datadir}/clang
761%{_datadir}/clang/clang-format-diff.py
d997b14b 762
87977e26
JR
763%files -n clang-libs
764%defattr(644,root,root,755)
509439cf 765%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
87977e26 766
589b92f5 767%if %{with rt} && %{with multilib}
9eefd942
JR
768%ifarch %{x8664}
769%files -n clang-multilib
770%defattr(644,root,root,755)
771%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
772%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
773%endif
774%endif
775
d997b14b 776%files -n clang-analyzer
bc88141a 777%defattr(644,root,root,755)
d997b14b
AM
778%attr(755,root,root) %{_bindir}/scan-build
779%attr(755,root,root) %{_bindir}/scan-view
634a3e5b
JB
780%{_datadir}/scan-build
781%{_datadir}/scan-view
dd9350c7 782%{_mandir}/man1/scan-build.1*
4522eb9a
JB
783%dir %{_libdir}/scan-build
784%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
785%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
8132e62b 786
9556f4c9
ER
787%files -n clang-devel
788%defattr(644,root,root,755)
9a23736f
JB
789%attr(755,root,root) %{_libdir}/libclang.so
790%{_libdir}/libclang*.a
9556f4c9
ER
791%{_includedir}/clang
792%{_includedir}/clang-c
793
794%files -n clang-doc
795%defattr(644,root,root,755)
41876fe7 796%doc tools/clang/docs/*.{html,png,txt}
9556f4c9
ER
797
798%if %{with apidocs}
799%files -n clang-apidocs
800%defattr(644,root,root,755)
801%doc clang-apidoc/*
802%endif
803
b0068ae4
JB
804%files -n clang-tools-extra
805%defattr(644,root,root,755)
6df3b432 806%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
b0068ae4 807%attr(755,root,root) %{_bindir}/clang-apply-replacements
b883cf1e 808%attr(755,root,root) %{_bindir}/clang-query
4ba3b2b3 809%attr(755,root,root) %{_bindir}/clang-rename
b0068ae4
JB
810%attr(755,root,root) %{_bindir}/clang-tidy
811%attr(755,root,root) %{_bindir}/pp-trace
b0068ae4 812
ba1cf74d
JB
813%files -n lld
814%defattr(644,root,root,755)
815%doc tools/lld/{LICENSE.TXT,README.md}
816%attr(755,root,root) %{_bindir}/lld
817
818%files -n lld-devel
819%defattr(644,root,root,755)
9a23736f 820%{_libdir}/liblld[ACDEHMRXY]*.a
ba1cf74d
JB
821%{_includedir}/lld
822
5a7ac479
JB
823%if %{with lldb}
824%files -n lldb
825%defattr(644,root,root,755)
826%attr(755,root,root) %{_bindir}/lldb
6df3b432 827%attr(755,root,root) %{_bindir}/lldb-%{version}
4522eb9a 828%attr(755,root,root) %{_bindir}/lldb-argdumper
b883cf1e 829%attr(755,root,root) %{_bindir}/lldb-mi
6df3b432
JB
830%attr(755,root,root) %{_bindir}/lldb-mi-%{version}
831%attr(755,root,root) %{_bindir}/lldb-server
832%attr(755,root,root) %{_bindir}/lldb-server-%{version}
833%attr(755,root,root) %{_libdir}/liblldb.so.%{version}
b883cf1e 834%dir %{py_sitedir}/lldb
4522eb9a 835%attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
6df3b432
JB
836%{py_sitedir}/lldb/formatters
837%{py_sitedir}/lldb/runtime
838%{py_sitedir}/lldb/utils
839%{py_sitedir}/lldb/__init__.py[co]
840%{py_sitedir}/lldb/embedded_interpreter.py[co]
b883cf1e
JB
841%attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
842%attr(755,root,root) %{py_sitedir}/readline.so
5a7ac479
JB
843
844%files -n lldb-devel
845%defattr(644,root,root,755)
6df3b432 846%attr(755,root,root) %{_libdir}/liblldb.so
5a7ac479
JB
847%{_libdir}/liblldb*.a
848%{_includedir}/lldb
849%endif
850
9556f4c9 851%if %{with ocaml}
d997b14b
AM
852%files ocaml
853%defattr(644,root,root,755)
11b6f380
JB
854%{_libdir}/ocaml/META.llvm*
855%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
8132e62b
JB
856%{_libdir}/ocaml/llvm*.cma
857%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
858
859%files ocaml-devel
860%defattr(644,root,root,755)
8132e62b
JB
861%{_libdir}/ocaml/libllvm*.a
862%{_libdir}/ocaml/llvm*.a
863%{_libdir}/ocaml/llvm*.cmx*
9556f4c9
ER
864
865%files ocaml-doc
866%defattr(644,root,root,755)
6df3b432 867%doc ocamldocs/*
9556f4c9 868%endif
This page took 0.217325 seconds and 4 git commands to generate.