]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- adjusted clang resource path (should finally fix clang headers path)
[packages/llvm.git] / llvm.spec
CommitLineData
bc88141a 1#
d015c902
PS
2# TODO:
3# - fix include search path to support libdir/gcc/platform/version/include.
4# current error: /usr/include/wchar.h:39:11: fatal error: 'stdarg.h' file not found# include <stdarg.h>
5#
9556f4c9
ER
6# Conditional build:
7%bcond_without ocaml # ocaml binding
8132e62b 8%bcond_with apidocs # The doxygen docs are HUGE, so they are not built by default.
dd9350c7 9%bcond_without man # man pages
8132e62b 10%bcond_with tests # run tests
9556f4c9
ER
11
12%ifarch s390 s390x sparc64
13# No ocaml on these arches
14%undefine with_ocaml
15%endif
16
aa11c230 17Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 18Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 19Name: llvm
dd9350c7 20Version: 3.2
9206c2b1 21Release: 3
aa11c230 22License: University of Illinois/NCSA Open Source License
23Group: Development/Languages
dd9350c7 24#Source0Download: http://llvm.org/releases/download.html
f981d747 25Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
dd9350c7 26# Source0-md5: 71610289bbc819e3e15fdd562809a2d7
f981d747 27Source1: http://llvm.org/releases/%{version}/clang-%{version}.src.tar.gz
dd9350c7 28# Source1-md5: 3896ef4334df08563b05d0848ba80582
ebde279d 29Patch0: %{name}-config.patch
d997b14b 30# Data files should be installed with timestamps preserved
ebde279d
JB
31Patch1: %{name}-2.6-timestamp.patch
32Patch2: %{name}-pld.patch
25189042
JB
33# R600 target support from git://people.freedesktop.org/~tstellar/llvm
34Patch3: %{name}-r600.patch
2326a99f 35URL: http://llvm.org/
ebde279d
JB
36BuildRequires: autoconf >= 2.60
37BuildRequires: automake >= 1:1.9.6
bc88141a 38BuildRequires: bash
d997b14b 39BuildRequires: bison
d997b14b 40BuildRequires: flex
dd9350c7
JB
41BuildRequires: gcc >= 5:3.4
42# gcc4 might be installed, but not current __cc
43%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
44BuildRequires: __cc >= 3.4
9556f4c9 45%endif
d997b14b 46BuildRequires: groff
bc88141a 47BuildRequires: libltdl-devel
ebde279d 48BuildRequires: libtool >= 2:1.5.22
d997b14b
AM
49BuildRequires: libstdc++-devel >= 5:3.4
50BuildRequires: ocaml-ocamldoc
8132e62b 51BuildRequires: perl-base >= 1:5.6
8c156e7d 52BuildRequires: perl-tools-pod
53BuildRequires: rpm-pythonprov
dd9350c7
JB
54%{?with_man:BuildRequires: sphinx-pdg}
55%if %{with apidocs}
56BuildRequires: doxygen
57BuildRequires: graphviz
58%endif
59%if %{with tests}
60BuildRequires: dejagnu
61BuildRequires: python
62BuildRequires: tcl-devel
356a0bbd 63%endif
8c514f23 64Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
65# LLVM is not supported on PPC64
66# http://llvm.org/bugs/show_bug.cgi?id=3729
67ExcludeArch: ppc64
aa11c230 68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
356a0bbd 70%define _sysconfdir /etc/%{name}
021b3c3d 71
9556f4c9
ER
72%define specflags_ppc -fno-var-tracking-assignments
73
6832a5c5
ER
74# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
75%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
76
aa11c230 77%description
78LLVM is a compiler infrastructure designed for compile-time,
79link-time, runtime, and idle-time optimization of programs from
80arbitrary programming languages. LLVM is written in C++ and has been
81developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
82currently supports compilation of C and C++ programs using clang
83frontend.
aa11c230 84
2326a99f
JB
85%description -l pl.UTF-8
86LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
87czasu kompilowania, linkowania, działania i bezczynności programów w
88dowolnych językach programowania. Jest napisana w C++, rozwijana od
89roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 90kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 91
8c514f23
JB
92%package libs
93Summary: LLVM shared library
94Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
95Group: Libraries
96Conflicts: llvm < 3.2
97
98%description libs
99LLVM shared library.
100
101%description libs -l pl.UTF-8
102Biblioteka współdzielona LLVM-a.
103
bc88141a 104%package devel
621ec11f
JB
105Summary: Static libraries and header files for LLVM
106Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 107Group: Development/Languages
8c514f23 108Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
109Requires: libstdc++-devel >= 6:3.4
110
111%description devel
621ec11f
JB
112This package contains static libraries and header files needed to
113develop new native programs that use the LLVM infrastructure.
114
115%description devel -l pl.UTF-8
116Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
117potrzebne do tworzenia nowych programów natywnych wykorzystujących
118infrastrukturę LLVM.
bc88141a 119
9556f4c9
ER
120%package doc
121Summary: Documentation for LLVM
621ec11f 122Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
123Group: Documentation
124# does not require base
bc88141a 125
9556f4c9
ER
126%description doc
127Documentation for the LLVM compiler infrastructure.
bc88141a 128
621ec11f
JB
129%description doc -l pl.UTF-8
130Dokumentacja do infrastruktury kompilatorów LLVM.
131
9556f4c9
ER
132%package apidocs
133Summary: API documentation for LLVM
621ec11f 134Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
135Group: Development/Languages
136Requires: %{name}-doc = %{version}-%{release}
bc88141a 137
9556f4c9
ER
138%description apidocs
139API documentation for the LLVM compiler infrastructure.
bc88141a 140
621ec11f
JB
141%description apidocs -l pl.UTF-8
142Dokumentacja API infrastruktury kompilatorów LLVM.
143
d997b14b
AM
144%package -n clang
145Summary: A C language family frontend for LLVM
621ec11f 146Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
147License: NCSA
148Group: Development/Languages
8c514f23 149Requires: %{name} = %{version}-%{release}
d997b14b
AM
150
151%description -n clang
152clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
153of a crane or goose. 3. C-language family front-end toolkit.
154
155The goal of the Clang project is to create a new C, C++, Objective C
156and Objective C++ front-end for the LLVM compiler. Its tools are built
157as libraries and designed to be loosely-coupled and extendable.
158
621ec11f
JB
159%description -n clang -l pl.UTF-8
160clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
161piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
162z rodziny C.
163
164Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
165LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
166budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
167i rozszerzaniu.
168
d997b14b
AM
169%package -n clang-analyzer
170Summary: A source code analysis framework
621ec11f 171Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
172License: NCSA
173Group: Development/Languages
174Requires: clang = %{version}-%{release}
175# not picked up automatically since files are currently not instaled
176# in standard Python hierarchies yet
177Requires: python
178
179%description -n clang-analyzer
180The Clang Static Analyzer consists of both a source code analysis
181framework and a standalone tool that finds bugs in C and Objective-C
182programs. The standalone tool is invoked from the command-line, and is
183intended to run in tandem with a build of a project or code base.
184
621ec11f
JB
185%description -n clang-analyzer -l pl.UTF-8
186Clang Static Analyzer składa się ze szkieletu do analizy kodu
187źródłowego oraz samodzielnego narzędzia znajdującego błędy w
188programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
189myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
190
9556f4c9 191%package -n clang-devel
621ec11f
JB
192Summary: Header files for Clang
193Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 194Group: Development/Languages
8c514f23 195Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
196Requires: clang = %{version}-%{release}
197
198%description -n clang-devel
199This package contains header files for the Clang compiler.
200
621ec11f
JB
201%description -n clang-devel -l pl.UTF-8
202Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
203
9556f4c9
ER
204%package -n clang-doc
205Summary: Documentation for Clang
621ec11f 206Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
207Group: Documentation
208Requires: %{name} = %{version}-%{release}
209
210%description -n clang-doc
211Documentation for the Clang compiler front-end.
212
621ec11f
JB
213%description -n clang-doc -l pl.UTF-8
214Dokumentacja do frontendu kompilatora Clang.
215
9556f4c9
ER
216%package -n clang-apidocs
217Summary: API documentation for Clang
621ec11f 218Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
219Group: Development/Languages
220Requires: clang-doc = %{version}-%{release}
221
222%description -n clang-apidocs
223API documentation for the Clang compiler.
224
621ec11f
JB
225%description -n clang-apidocs -l pl.UTF-8
226Dokumentacja API kompilatora Clang.
227
9556f4c9
ER
228%package ocaml
229Summary: OCaml binding for LLVM
621ec11f
JB
230Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
231Group: Libraries
9556f4c9
ER
232Requires: %{name} = %{version}-%{release}
233%requires_eq ocaml-runtime
234
621ec11f 235%description ocaml
9556f4c9
ER
236OCaml binding for LLVM.
237
621ec11f
JB
238%description ocaml -l pl.UTF-8
239Wiązanie OCamla do LLVM-a.
240
9556f4c9 241%package ocaml-devel
621ec11f
JB
242Summary: Development files for LLVM OCaml binding
243Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
244Group: Development/Libraries
245Requires: %{name}-devel = %{version}-%{release}
246Requires: %{name}-ocaml = %{version}-%{release}
247
248%description ocaml-devel
249The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
250for developing applications that use llvm-ocaml binding.
251
252%description ocaml-devel -l pl.UTF-8
253Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
254wykorzystujących wiązanie llvm-ocaml.
255
9556f4c9
ER
256%package ocaml-doc
257Summary: Documentation for LLVM's OCaml binding
621ec11f 258Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
259Group: Documentation
260Requires: %{name}-ocaml = %{version}-%{release}
261
262%description ocaml-doc
263HTML documentation for LLVM's OCaml binding.
264
621ec11f
JB
265%description ocaml-doc -l pl.UTF-8
266Dokumentacja HTML wiązania OCamla do LLVM-a.
267
aa11c230 268%prep
827664e9 269%setup -q -a1 -n %{name}-%{version}.src
d997b14b 270mv clang-*.* tools/clang
ebde279d
JB
271%patch0 -p1
272%patch1 -p1
273%patch2 -p1
25189042 274%patch3 -p1
ce9cc204 275
19f21eee 276# configure does not properly specify libdir
3a1d4bb3 277%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
3a1d4bb3 278%{__sed} -i 's|/lib/|/%{_lib}/|' lib/Support/Unix/Path.inc
9206c2b1
JB
279# clang resources
280%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
281%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
19f21eee 282
bacc8b96
ER
283grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
284 s,^#!.*bin/env python,#!%{__python},
285 s,^#!.*bin/env perl,#!%{__perl},
286}'
287
9556f4c9 288install -d obj
aa11c230 289
290%build
ebde279d
JB
291cd autoconf
292%{__aclocal} -I m4
293%{__autoconf} -o ../configure configure.ac
294cd ..
295%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
296
d997b14b 297# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 298# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
d997b14b 299#
bc88141a 300# bash specific 'test a < b'
9556f4c9 301cd obj
d997b14b 302bash ../%configure \
bc88141a 303 --datadir=%{_datadir}/%{name}-%{version} \
632f3287 304 --disable-assertions \
d997b14b 305%ifarch %{ix86}
632f3287 306 --disable-pic \
9556f4c9 307%endif
632f3287
JB
308 --disable-static \
309 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
310 --enable-debug-runtime \
9556f4c9
ER
311%if %{with apidocs}
312 --enable-doxygen \
d997b14b 313%endif
25189042 314 --enable-experimental-targets=R600 \
bc88141a 315 --enable-jit \
aa11c230 316 --enable-optimized \
bc88141a
ER
317 --enable-shared \
318 --with-pic
319
d997b14b 320%{__make} \
0a0b7076 321 REQUIRES_RTTI=1 \
d997b14b 322 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 323
827664e9 324%if %{with tests}
9556f4c9
ER
325%{__make} check 2>&1 | tee llvm-testlog.txt
326%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
327%endif
328
dd9350c7
JB
329cd ..
330
331%if %{with man}
332%{__make} -C docs -f Makefile.sphinx man
333%endif
334
aa11c230 335%install
336rm -rf $RPM_BUILD_ROOT
9556f4c9 337%{__make} -C obj -j1 install \
d997b14b 338 PROJ_docsdir=/moredocs \
aa11c230 339 DESTDIR=$RPM_BUILD_ROOT
340
d997b14b 341# Static analyzer not installed by default:
9556f4c9
ER
342# http://clang-analyzer.llvm.org/installation#OtherPlatforms
343install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
344# create launchers
345for f in scan-{build,view}; do
9556f4c9
ER
346 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
347 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 348done
dd9350c7 349%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
350%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
351%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
352%py_postclean %{_libdir}/clang-analyzer/scan-view
d997b14b 353
dd9350c7
JB
354%if %{with man}
355install -d $RPM_BUILD_ROOT%{_mandir}/man1
356cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
357# these tools are not installed
358%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
359%endif
360
d997b14b 361# Move documentation back to build directory
d997b14b
AM
362rm -rf moredocs
363mv $RPM_BUILD_ROOT/moredocs .
ebde279d
JB
364%{__rm} -v moredocs/*.tar.gz
365%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
9556f4c9
ER
366
367# and separate the apidoc
368%if %{with apidocs}
369rm -rf apidoc clang-apidoc
370mv moredocs/html/doxygen apidoc
371cp -a tools/clang/docs/doxygen/html clang-apidoc
372%endif
d997b14b
AM
373
374# And prepare Clang documentation
d997b14b 375rm -rf clang-docs
9556f4c9 376install -d clang-docs
827664e9 377for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 378 ln tools/clang/$f clang-docs
d997b14b 379done
021b3c3d 380
6832a5c5 381# Get rid of erroneously installed example files.
ebde279d 382%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
6832a5c5 383
d997b14b
AM
384# remove documentation makefiles:
385# they require the build directory to work
9556f4c9
ER
386rm -rf moredocs/examples
387cp -a examples moredocs/examples
388find moredocs/examples -name Makefile | xargs -0r rm -f
6832a5c5 389
aa11c230 390%clean
391rm -rf $RPM_BUILD_ROOT
392
8c514f23
JB
393%post libs -p /sbin/ldconfig
394%postun libs -p /sbin/ldconfig
aa11c230 395
396%files
397%defattr(644,root,root,755)
8132e62b 398%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 399%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
400%attr(755,root,root) %{_bindir}/llc
401%attr(755,root,root) %{_bindir}/lli
8132e62b
JB
402%attr(755,root,root) %{_bindir}/llvm-ar
403%attr(755,root,root) %{_bindir}/llvm-as
404%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 405%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
406%attr(755,root,root) %{_bindir}/llvm-diff
407%attr(755,root,root) %{_bindir}/llvm-dis
827664e9 408%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 409%attr(755,root,root) %{_bindir}/llvm-extract
8132e62b
JB
410%attr(755,root,root) %{_bindir}/llvm-link
411%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 412%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
413%attr(755,root,root) %{_bindir}/llvm-nm
414%attr(755,root,root) %{_bindir}/llvm-objdump
415%attr(755,root,root) %{_bindir}/llvm-prof
416%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 417%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
418%attr(755,root,root) %{_bindir}/llvm-rtdyld
419%attr(755,root,root) %{_bindir}/llvm-size
f981d747 420%attr(755,root,root) %{_bindir}/llvm-stress
827664e9 421%attr(755,root,root) %{_bindir}/llvm-tblgen
a7973f21 422%attr(755,root,root) %{_bindir}/macho-dump
8132e62b 423%attr(755,root,root) %{_bindir}/opt
a9beeab5 424%{_mandir}/man1/bugpoint.1*
a7973f21 425%{_mandir}/man1/lit.1*
a9beeab5
JB
426%{_mandir}/man1/llc.1*
427%{_mandir}/man1/lli.1*
8132e62b
JB
428%{_mandir}/man1/llvm-ar.1*
429%{_mandir}/man1/llvm-as.1*
430%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 431%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
432%{_mandir}/man1/llvm-diff.1*
433%{_mandir}/man1/llvm-dis.1*
434%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
435%{_mandir}/man1/llvm-link.1*
436%{_mandir}/man1/llvm-nm.1*
437%{_mandir}/man1/llvm-prof.1*
438%{_mandir}/man1/llvm-ranlib.1*
f981d747 439%{_mandir}/man1/llvm-stress.1*
a9beeab5 440%{_mandir}/man1/opt.1*
dd9350c7 441%{_mandir}/man1/tblgen.1*
bc88141a 442
8c514f23
JB
443%files libs
444%defattr(644,root,root,755)
445%attr(755,root,root) %{_libdir}/libLLVM-%{version}svn.so
446
bc88141a
ER
447%files devel
448%defattr(644,root,root,755)
449%attr(755,root,root) %{_bindir}/llvm-config
827664e9 450%attr(755,root,root) %{_libdir}/libprofile_rt.so
8132e62b 451%{_libdir}/libLLVM*.a
827664e9 452%{_libdir}/libprofile_rt.a
1655c8b5 453%ifarch %{x8664}
0a8510f2 454%attr(755,root,root) %{_libdir}/BugpointPasses.so
19f21eee 455%attr(755,root,root) %{_libdir}/libLTO.so
8132e62b 456%{_libdir}/libLTO.a
1655c8b5 457%endif
8132e62b
JB
458%{_includedir}/llvm
459%{_includedir}/llvm-c
460%{_mandir}/man1/llvm-config.1*
bc88141a 461
9556f4c9
ER
462%files doc
463%defattr(644,root,root,755)
464%doc moredocs/examples moredocs/html
465
466%if %{with apidocs}
467%files apidocs
468%defattr(644,root,root,755)
469%doc apidoc/*
470%endif
471
d997b14b 472%files -n clang
bc88141a 473%defattr(644,root,root,755)
827664e9 474%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
dd9350c7 475%attr(755,root,root) %{_bindir}/c-index-test
8132e62b
JB
476%attr(755,root,root) %{_bindir}/clang
477%attr(755,root,root) %{_bindir}/clang++
dd9350c7 478%attr(755,root,root) %{_bindir}/clang-check
827664e9 479%attr(755,root,root) %{_bindir}/clang-tblgen
b3a27ca2 480%attr(755,root,root) %{_libdir}/libclang.so
493e5485 481%{_libdir}/clang
8132e62b 482%{_mandir}/man1/clang.1*
d997b14b
AM
483
484%files -n clang-analyzer
bc88141a 485%defattr(644,root,root,755)
d997b14b
AM
486%attr(755,root,root) %{_bindir}/scan-build
487%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 488%{_mandir}/man1/scan-build.1*
ae49e501 489%dir %{_libdir}/clang-analyzer
d997b14b 490
9556f4c9
ER
491%dir %{_libdir}/clang-analyzer/scan-build
492%{_libdir}/clang-analyzer/scan-build/*.css
493%{_libdir}/clang-analyzer/scan-build/*.js
494%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
495%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
496
8132e62b
JB
497%dir %{_libdir}/clang-analyzer/scan-view
498%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
499%{_libdir}/clang-analyzer/scan-view/Resources
500%{_libdir}/clang-analyzer/scan-view/*.py[co]
501
9556f4c9
ER
502%files -n clang-devel
503%defattr(644,root,root,755)
8132e62b 504%{_libdir}/libclang*.a
9556f4c9
ER
505%{_includedir}/clang
506%{_includedir}/clang-c
507
508%files -n clang-doc
509%defattr(644,root,root,755)
8132e62b 510%doc tools/clang/docs/*.{css,html,png,txt}
9556f4c9
ER
511
512%if %{with apidocs}
513%files -n clang-apidocs
514%defattr(644,root,root,755)
515%doc clang-apidoc/*
516%endif
517
518%if %{with ocaml}
d997b14b
AM
519%files ocaml
520%defattr(644,root,root,755)
bc8a0b58 521%{_libdir}/ocaml/META.llvm
8132e62b
JB
522%{_libdir}/ocaml/llvm*.cma
523%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
524
525%files ocaml-devel
526%defattr(644,root,root,755)
bc8a0b58 527%{_libdir}/libllvm*.a
8132e62b
JB
528%{_libdir}/ocaml/libLLVM*.a
529%{_libdir}/ocaml/libllvm*.a
530%{_libdir}/ocaml/llvm*.a
531%{_libdir}/ocaml/llvm*.cmx*
532%{_libdir}/ocaml/llvm*.mli
9556f4c9
ER
533
534%files ocaml-doc
535%defattr(644,root,root,755)
536%doc moredocs/ocamldoc/html/*
537%endif
This page took 0.111037 seconds and 4 git commands to generate.