]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- updated to 3.2 (llvm 3.1 left on llvm-3.1 branch)
[packages/llvm.git] / llvm.spec
CommitLineData
bc88141a 1#
d015c902
PS
2# TODO:
3# - fix include search path to support libdir/gcc/platform/version/include.
4# current error: /usr/include/wchar.h:39:11: fatal error: 'stdarg.h' file not found# include <stdarg.h>
5#
9556f4c9
ER
6# Conditional build:
7%bcond_without ocaml # ocaml binding
8132e62b 8%bcond_with apidocs # The doxygen docs are HUGE, so they are not built by default.
dd9350c7 9%bcond_without man # man pages
8132e62b 10%bcond_with tests # run tests
9556f4c9
ER
11
12%ifarch s390 s390x sparc64
13# No ocaml on these arches
14%undefine with_ocaml
15%endif
16
aa11c230 17Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 18Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 19Name: llvm
dd9350c7
JB
20Version: 3.2
21Release: 1
aa11c230 22License: University of Illinois/NCSA Open Source License
23Group: Development/Languages
dd9350c7 24#Source0Download: http://llvm.org/releases/download.html
f981d747 25Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
dd9350c7 26# Source0-md5: 71610289bbc819e3e15fdd562809a2d7
f981d747 27Source1: http://llvm.org/releases/%{version}/clang-%{version}.src.tar.gz
dd9350c7 28# Source1-md5: 3896ef4334df08563b05d0848ba80582
ebde279d 29Patch0: %{name}-config.patch
d997b14b 30# Data files should be installed with timestamps preserved
ebde279d
JB
31Patch1: %{name}-2.6-timestamp.patch
32Patch2: %{name}-pld.patch
2326a99f 33URL: http://llvm.org/
ebde279d
JB
34BuildRequires: autoconf >= 2.60
35BuildRequires: automake >= 1:1.9.6
bc88141a 36BuildRequires: bash
d997b14b 37BuildRequires: bison
d997b14b 38BuildRequires: flex
dd9350c7
JB
39BuildRequires: gcc >= 5:3.4
40# gcc4 might be installed, but not current __cc
41%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
42BuildRequires: __cc >= 3.4
9556f4c9 43%endif
d997b14b 44BuildRequires: groff
bc88141a 45BuildRequires: libltdl-devel
ebde279d 46BuildRequires: libtool >= 2:1.5.22
d997b14b
AM
47BuildRequires: libstdc++-devel >= 5:3.4
48BuildRequires: ocaml-ocamldoc
8132e62b 49BuildRequires: perl-base >= 1:5.6
8c156e7d 50BuildRequires: perl-tools-pod
51BuildRequires: rpm-pythonprov
dd9350c7
JB
52%{?with_man:BuildRequires: sphinx-pdg}
53%if %{with apidocs}
54BuildRequires: doxygen
55BuildRequires: graphviz
56%endif
57%if %{with tests}
58BuildRequires: dejagnu
59BuildRequires: python
60BuildRequires: tcl-devel
356a0bbd 61%endif
9556f4c9
ER
62# LLVM is not supported on PPC64
63# http://llvm.org/bugs/show_bug.cgi?id=3729
64ExcludeArch: ppc64
aa11c230 65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
356a0bbd 67%define _sysconfdir /etc/%{name}
021b3c3d 68
9556f4c9
ER
69%define specflags_ppc -fno-var-tracking-assignments
70
6832a5c5
ER
71# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
72%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
73
aa11c230 74%description
75LLVM is a compiler infrastructure designed for compile-time,
76link-time, runtime, and idle-time optimization of programs from
77arbitrary programming languages. LLVM is written in C++ and has been
78developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
79currently supports compilation of C and C++ programs using clang
80frontend.
aa11c230 81
2326a99f
JB
82%description -l pl.UTF-8
83LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
84czasu kompilowania, linkowania, działania i bezczynności programów w
85dowolnych językach programowania. Jest napisana w C++, rozwijana od
86roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 87kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 88
bc88141a 89%package devel
621ec11f
JB
90Summary: Static libraries and header files for LLVM
91Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a
ER
92Group: Development/Languages
93Requires: %{name} = %{version}-%{release}
94Requires: libstdc++-devel >= 6:3.4
95
96%description devel
621ec11f
JB
97This package contains static libraries and header files needed to
98develop new native programs that use the LLVM infrastructure.
99
100%description devel -l pl.UTF-8
101Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
102potrzebne do tworzenia nowych programów natywnych wykorzystujących
103infrastrukturę LLVM.
bc88141a 104
9556f4c9
ER
105%package doc
106Summary: Documentation for LLVM
621ec11f 107Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
108Group: Documentation
109# does not require base
bc88141a 110
9556f4c9
ER
111%description doc
112Documentation for the LLVM compiler infrastructure.
bc88141a 113
621ec11f
JB
114%description doc -l pl.UTF-8
115Dokumentacja do infrastruktury kompilatorów LLVM.
116
9556f4c9
ER
117%package apidocs
118Summary: API documentation for LLVM
621ec11f 119Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
120Group: Development/Languages
121Requires: %{name}-doc = %{version}-%{release}
bc88141a 122
9556f4c9
ER
123%description apidocs
124API documentation for the LLVM compiler infrastructure.
bc88141a 125
621ec11f
JB
126%description apidocs -l pl.UTF-8
127Dokumentacja API infrastruktury kompilatorów LLVM.
128
d997b14b
AM
129%package -n clang
130Summary: A C language family frontend for LLVM
621ec11f 131Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
132License: NCSA
133Group: Development/Languages
134
135%description -n clang
136clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
137of a crane or goose. 3. C-language family front-end toolkit.
138
139The goal of the Clang project is to create a new C, C++, Objective C
140and Objective C++ front-end for the LLVM compiler. Its tools are built
141as libraries and designed to be loosely-coupled and extendable.
142
621ec11f
JB
143%description -n clang -l pl.UTF-8
144clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
145piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
146z rodziny C.
147
148Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
149LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
150budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
151i rozszerzaniu.
152
d997b14b
AM
153%package -n clang-analyzer
154Summary: A source code analysis framework
621ec11f 155Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
156License: NCSA
157Group: Development/Languages
158Requires: clang = %{version}-%{release}
159# not picked up automatically since files are currently not instaled
160# in standard Python hierarchies yet
161Requires: python
162
163%description -n clang-analyzer
164The Clang Static Analyzer consists of both a source code analysis
165framework and a standalone tool that finds bugs in C and Objective-C
166programs. The standalone tool is invoked from the command-line, and is
167intended to run in tandem with a build of a project or code base.
168
621ec11f
JB
169%description -n clang-analyzer -l pl.UTF-8
170Clang Static Analyzer składa się ze szkieletu do analizy kodu
171źródłowego oraz samodzielnego narzędzia znajdującego błędy w
172programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
173myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
174
9556f4c9 175%package -n clang-devel
621ec11f
JB
176Summary: Header files for Clang
177Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9
ER
178Group: Development/Languages
179Requires: clang = %{version}-%{release}
180
181%description -n clang-devel
182This package contains header files for the Clang compiler.
183
621ec11f
JB
184%description -n clang-devel -l pl.UTF-8
185Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
186
9556f4c9
ER
187%package -n clang-doc
188Summary: Documentation for Clang
621ec11f 189Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
190Group: Documentation
191Requires: %{name} = %{version}-%{release}
192
193%description -n clang-doc
194Documentation for the Clang compiler front-end.
195
621ec11f
JB
196%description -n clang-doc -l pl.UTF-8
197Dokumentacja do frontendu kompilatora Clang.
198
9556f4c9
ER
199%package -n clang-apidocs
200Summary: API documentation for Clang
621ec11f 201Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
202Group: Development/Languages
203Requires: clang-doc = %{version}-%{release}
204
205%description -n clang-apidocs
206API documentation for the Clang compiler.
207
621ec11f
JB
208%description -n clang-apidocs -l pl.UTF-8
209Dokumentacja API kompilatora Clang.
210
9556f4c9
ER
211%package ocaml
212Summary: OCaml binding for LLVM
621ec11f
JB
213Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
214Group: Libraries
9556f4c9
ER
215Requires: %{name} = %{version}-%{release}
216%requires_eq ocaml-runtime
217
621ec11f 218%description ocaml
9556f4c9
ER
219OCaml binding for LLVM.
220
621ec11f
JB
221%description ocaml -l pl.UTF-8
222Wiązanie OCamla do LLVM-a.
223
9556f4c9 224%package ocaml-devel
621ec11f
JB
225Summary: Development files for LLVM OCaml binding
226Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
227Group: Development/Libraries
228Requires: %{name}-devel = %{version}-%{release}
229Requires: %{name}-ocaml = %{version}-%{release}
230
231%description ocaml-devel
232The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
233for developing applications that use llvm-ocaml binding.
234
235%description ocaml-devel -l pl.UTF-8
236Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
237wykorzystujących wiązanie llvm-ocaml.
238
9556f4c9
ER
239
240%package ocaml-doc
241Summary: Documentation for LLVM's OCaml binding
621ec11f 242Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
243Group: Documentation
244Requires: %{name}-ocaml = %{version}-%{release}
245
246%description ocaml-doc
247HTML documentation for LLVM's OCaml binding.
248
621ec11f
JB
249%description ocaml-doc -l pl.UTF-8
250Dokumentacja HTML wiązania OCamla do LLVM-a.
251
aa11c230 252%prep
827664e9 253%setup -q -a1 -n %{name}-%{version}.src
d997b14b 254mv clang-*.* tools/clang
ebde279d
JB
255%patch0 -p1
256%patch1 -p1
257%patch2 -p1
ce9cc204 258
19f21eee
PS
259# configure does not properly specify libdir
260sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
493e5485 261sed -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
19f21eee 262
bacc8b96
ER
263grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
264 s,^#!.*bin/env python,#!%{__python},
265 s,^#!.*bin/env perl,#!%{__perl},
266}'
267
9556f4c9 268install -d obj
aa11c230 269
270%build
ebde279d
JB
271cd autoconf
272%{__aclocal} -I m4
273%{__autoconf} -o ../configure configure.ac
274cd ..
275%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
276
d997b14b 277# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 278# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
d997b14b 279#
bc88141a 280# bash specific 'test a < b'
9556f4c9 281cd obj
d997b14b 282bash ../%configure \
bc88141a 283 --datadir=%{_datadir}/%{name}-%{version} \
632f3287 284 --disable-assertions \
d997b14b 285%ifarch %{ix86}
632f3287 286 --disable-pic \
9556f4c9 287%endif
632f3287
JB
288 --disable-static \
289 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
290 --enable-debug-runtime \
9556f4c9
ER
291%if %{with apidocs}
292 --enable-doxygen \
d997b14b 293%endif
bc88141a 294 --enable-jit \
aa11c230 295 --enable-optimized \
bc88141a
ER
296 --enable-shared \
297 --with-pic
298
d997b14b 299%{__make} \
0a0b7076 300 REQUIRES_RTTI=1 \
d997b14b 301 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 302
827664e9 303%if %{with tests}
9556f4c9
ER
304%{__make} check 2>&1 | tee llvm-testlog.txt
305%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
306%endif
307
dd9350c7
JB
308cd ..
309
310%if %{with man}
311%{__make} -C docs -f Makefile.sphinx man
312%endif
313
aa11c230 314%install
315rm -rf $RPM_BUILD_ROOT
9556f4c9 316%{__make} -C obj -j1 install \
d997b14b 317 PROJ_docsdir=/moredocs \
aa11c230 318 DESTDIR=$RPM_BUILD_ROOT
319
d997b14b 320# Static analyzer not installed by default:
9556f4c9
ER
321# http://clang-analyzer.llvm.org/installation#OtherPlatforms
322install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
323# create launchers
324for f in scan-{build,view}; do
9556f4c9
ER
325 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
326 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 327done
dd9350c7 328%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
329%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
330%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
331%py_postclean %{_libdir}/clang-analyzer/scan-view
d997b14b 332
dd9350c7
JB
333%if %{with man}
334install -d $RPM_BUILD_ROOT%{_mandir}/man1
335cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
336# these tools are not installed
337%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
338%endif
339
d997b14b 340# Move documentation back to build directory
d997b14b
AM
341rm -rf moredocs
342mv $RPM_BUILD_ROOT/moredocs .
ebde279d
JB
343%{__rm} -v moredocs/*.tar.gz
344%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
9556f4c9
ER
345
346# and separate the apidoc
347%if %{with apidocs}
348rm -rf apidoc clang-apidoc
349mv moredocs/html/doxygen apidoc
350cp -a tools/clang/docs/doxygen/html clang-apidoc
351%endif
d997b14b
AM
352
353# And prepare Clang documentation
d997b14b 354rm -rf clang-docs
9556f4c9 355install -d clang-docs
827664e9 356for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 357 ln tools/clang/$f clang-docs
d997b14b 358done
021b3c3d 359
6832a5c5 360# Get rid of erroneously installed example files.
ebde279d 361%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
6832a5c5 362
d997b14b
AM
363# remove documentation makefiles:
364# they require the build directory to work
9556f4c9
ER
365rm -rf moredocs/examples
366cp -a examples moredocs/examples
367find moredocs/examples -name Makefile | xargs -0r rm -f
6832a5c5 368
aa11c230 369%clean
370rm -rf $RPM_BUILD_ROOT
371
2326a99f
JB
372%post -p /sbin/ldconfig
373%postun -p /sbin/ldconfig
aa11c230 374
375%files
376%defattr(644,root,root,755)
8132e62b 377%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 378%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
379%attr(755,root,root) %{_bindir}/llc
380%attr(755,root,root) %{_bindir}/lli
8132e62b
JB
381%attr(755,root,root) %{_bindir}/llvm-ar
382%attr(755,root,root) %{_bindir}/llvm-as
383%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 384%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
385%attr(755,root,root) %{_bindir}/llvm-diff
386%attr(755,root,root) %{_bindir}/llvm-dis
827664e9 387%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 388%attr(755,root,root) %{_bindir}/llvm-extract
8132e62b
JB
389%attr(755,root,root) %{_bindir}/llvm-link
390%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 391%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
392%attr(755,root,root) %{_bindir}/llvm-nm
393%attr(755,root,root) %{_bindir}/llvm-objdump
394%attr(755,root,root) %{_bindir}/llvm-prof
395%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 396%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
397%attr(755,root,root) %{_bindir}/llvm-rtdyld
398%attr(755,root,root) %{_bindir}/llvm-size
f981d747 399%attr(755,root,root) %{_bindir}/llvm-stress
827664e9 400%attr(755,root,root) %{_bindir}/llvm-tblgen
a7973f21 401%attr(755,root,root) %{_bindir}/macho-dump
8132e62b 402%attr(755,root,root) %{_bindir}/opt
dd9350c7 403%attr(755,root,root) %{_libdir}/libLLVM-%{version}svn.so
a9beeab5 404%{_mandir}/man1/bugpoint.1*
a7973f21 405%{_mandir}/man1/lit.1*
a9beeab5
JB
406%{_mandir}/man1/llc.1*
407%{_mandir}/man1/lli.1*
8132e62b
JB
408%{_mandir}/man1/llvm-ar.1*
409%{_mandir}/man1/llvm-as.1*
410%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 411%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
412%{_mandir}/man1/llvm-diff.1*
413%{_mandir}/man1/llvm-dis.1*
414%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
415%{_mandir}/man1/llvm-link.1*
416%{_mandir}/man1/llvm-nm.1*
417%{_mandir}/man1/llvm-prof.1*
418%{_mandir}/man1/llvm-ranlib.1*
f981d747 419%{_mandir}/man1/llvm-stress.1*
a9beeab5 420%{_mandir}/man1/opt.1*
dd9350c7 421%{_mandir}/man1/tblgen.1*
bc88141a 422
bc88141a
ER
423%files devel
424%defattr(644,root,root,755)
425%attr(755,root,root) %{_bindir}/llvm-config
827664e9 426%attr(755,root,root) %{_libdir}/libprofile_rt.so
8132e62b 427%{_libdir}/libLLVM*.a
827664e9 428%{_libdir}/libprofile_rt.a
1655c8b5 429%ifarch %{x8664}
0a8510f2 430%attr(755,root,root) %{_libdir}/BugpointPasses.so
19f21eee 431%attr(755,root,root) %{_libdir}/libLTO.so
8132e62b 432%{_libdir}/libLTO.a
1655c8b5 433%endif
8132e62b
JB
434%{_includedir}/llvm
435%{_includedir}/llvm-c
436%{_mandir}/man1/llvm-config.1*
bc88141a 437
9556f4c9
ER
438%files doc
439%defattr(644,root,root,755)
440%doc moredocs/examples moredocs/html
441
442%if %{with apidocs}
443%files apidocs
444%defattr(644,root,root,755)
445%doc apidoc/*
446%endif
447
d997b14b 448%files -n clang
bc88141a 449%defattr(644,root,root,755)
827664e9 450%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
dd9350c7 451%attr(755,root,root) %{_bindir}/c-index-test
8132e62b
JB
452%attr(755,root,root) %{_bindir}/clang
453%attr(755,root,root) %{_bindir}/clang++
dd9350c7 454%attr(755,root,root) %{_bindir}/clang-check
827664e9 455%attr(755,root,root) %{_bindir}/clang-tblgen
b3a27ca2 456%attr(755,root,root) %{_libdir}/libclang.so
493e5485 457%{_libdir}/clang
8132e62b 458%{_mandir}/man1/clang.1*
d997b14b
AM
459
460%files -n clang-analyzer
bc88141a 461%defattr(644,root,root,755)
d997b14b
AM
462%attr(755,root,root) %{_bindir}/scan-build
463%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 464%{_mandir}/man1/scan-build.1*
ae49e501 465%dir %{_libdir}/clang-analyzer
d997b14b 466
9556f4c9
ER
467%dir %{_libdir}/clang-analyzer/scan-build
468%{_libdir}/clang-analyzer/scan-build/*.css
469%{_libdir}/clang-analyzer/scan-build/*.js
470%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
471%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
472
8132e62b
JB
473%dir %{_libdir}/clang-analyzer/scan-view
474%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
475%{_libdir}/clang-analyzer/scan-view/Resources
476%{_libdir}/clang-analyzer/scan-view/*.py[co]
477
9556f4c9
ER
478%files -n clang-devel
479%defattr(644,root,root,755)
8132e62b 480%{_libdir}/libclang*.a
9556f4c9
ER
481%{_includedir}/clang
482%{_includedir}/clang-c
483
484%files -n clang-doc
485%defattr(644,root,root,755)
8132e62b 486%doc tools/clang/docs/*.{css,html,png,txt}
9556f4c9
ER
487
488%if %{with apidocs}
489%files -n clang-apidocs
490%defattr(644,root,root,755)
491%doc clang-apidoc/*
492%endif
493
494%if %{with ocaml}
d997b14b
AM
495%files ocaml
496%defattr(644,root,root,755)
bc8a0b58 497%{_libdir}/ocaml/META.llvm
8132e62b
JB
498%{_libdir}/ocaml/llvm*.cma
499%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
500
501%files ocaml-devel
502%defattr(644,root,root,755)
bc8a0b58 503%{_libdir}/libllvm*.a
8132e62b
JB
504%{_libdir}/ocaml/libLLVM*.a
505%{_libdir}/ocaml/libllvm*.a
506%{_libdir}/ocaml/llvm*.a
507%{_libdir}/ocaml/llvm*.cmx*
508%{_libdir}/ocaml/llvm*.mli
9556f4c9
ER
509
510%files ocaml-doc
511%defattr(644,root,root,755)
512%doc moredocs/ocamldoc/html/*
513%endif
This page took 0.107169 seconds and 4 git commands to generate.